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1. Introduction 
Setting up GenCade for an idealized case along Galveston Island, TX illustrates model 
setup and application.  This area was chosen because it includes many of the various 
structures and features that may be included within a GenCade model.  It is important to 
note that the model presented has not been verified and many of the parameters included 
were chosen to exaggerate results or clarify model limitations. Figure 1 shows the area to 
be modeled and identifies major features to be included. The overall goal of this guided 
example is to allow the user to work with real and simulated datasets at a realistic 
location to demonstrate model capabilities. 
 

Goals for the exercise: 
1. Set up a GenCade Model 
2. Modify model to include different engineering alternatives 
3. Visualize & process results 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1. Example feature overview. 
 
This document begins with simplified step by step instructions for setting up the model. 
The intention is for the beginner to moderate user to be able to follow the steps and 
visualize everything in SMS similarly to the given figures.  As the topics become more 
advanced throughout this document, less explicit instructions are given. 
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Many of the steps presented can be done in more than one way or in a different order. 
The example format is set up so that advanced users can try other methods or skip 
sections. An SMS project file, .sms, and map file, .map, were created for each major 
section in the provided data. SMS files are saved under the GenCade\Hands-On 
Example\SMS Project Files folder. Map files are saved under the GenCade\Hands-On 
Example\Map Files folder. In order to start from any point in the exercise, go to the 
section of interest and open the related SMS project file. Users are referred to the online 
user guide at the link below for more detailed information on setting up and using 
GenCade. 
 

http://cirp.usace.army.mil/wiki/GenCade_Users_Guide   
 

2. Conceptual Model Setup 
As much of the setup as possible is done in conceptual model space through the SMS 
map module. Creating the model in this manner, as opposed to making changes in the 1D 
grid module, enables modification without duplication of effort. 

2.1. Set Up SMS 
GenCade is set up to run from SMS 11.1, a licensed copy of which must be installed on 
your machine. Take the following steps to set up SMS: 
 

 Open SMS 11.1 
 Identify location of GenCade executable. 

1. Edit->Preferences. Select the File Locations tab and scroll down to 
GenCade under Model Executables. 

2. Click the button under Executable located directly to the right of GenCade. 
3. Browse to the latest model version                                                     

GenCade\Hands-On Example\Models\ GenCade_v1_1w.exe, the newest 
provided executable. 

 Change coverage type to GenCade. 
1. Right click on the default coverage. 
2. Select Type-> Models->GenCade. 

 Set display projection. 
1. Click Edit->Projection then select Global projection. 
2. Set projection to UTM zone 15, NAD 83, meters. 
3. Set vertical projection to local with units in meters. 

 Note: The sign convention for the conceptual model grid is in degrees 
counterclockwise from the x axis. The sign convention will change after 
converting to the GenCade grid. 
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Figure 2. Set model type to GenCade. 
 

 Set map data projection in SMS. 
1. Right click on the Coverage name and select Projection (floating). 
2. Select Global projection. 
3. Set projection to UTM zone 15, NAD 83, meters. 
4. Set vertical projection to local with units in meters. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Figure 3. Select model projection. 
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 Change the background color to white. 
1. Click Display->Display Options then select the General window. 
2. Change the background color to white by clicking inside the sample and 

selecting white. 
3. Other display settings may be changed here to suit user preference. 
4. Click File->Save Settings to make the current settings the default. 

 
 
 
 

 

 

 

 

 

 

 

 

 
Figure 4. Change display options. 

 

2.2. Import Aerial Photographs 
Georeferenced aerials provide an easy way of identifying features to include in GenCade, 
forming the basis for much of the model setup. Take the following steps to import aerials: 
 

 Georeferenced aerials can be obtained from many sources including: 
o New flights 
o Government entities 

 http://datagateway.nrcs.usda.gov/ 
o Commercial entities 

 http://www.esri.com/software/arcgis/arcgisonline/ 
 Use Arcmap to save aerials at the desired extent with world file 

o SMS built in search 
 Web->Find Data->Image 

 Open  2008_Galveston.jpg files under GenCade\Hands-On Example\Aerials 
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1. Alternatively, images can be dragged from windows explorer to the SMS 
graphics window. 

2. SMS will auto-detect and apply world files (.jgw, etc.). 
3. Verify projection in SMS. 

 Right click on the image name and select Projection. 

 Select Global projection. 

 Set projection to UTM zone 15, NAD 83, meters. 

 Set vertical projection to local with units in meters. 

 Save often (  )! 

2.3. Initial Shoreline and Regional Contour 
The initial shoreline represents the initial condition from which model calculations begin.  
The regional contour represents the equilibrium shape of the shoreline in a regional 
context. A regional contour could be specified as an offshore contour, shoreline, or any 
other contour that accurately represents the regional shoreline trends. 
   
Create the initial shoreline:   

 Shoreline position data may be obtained from various sources including: 
o Aerials or charts. 
o Pick elevation from survey data. 
o Arcmap. 
o Texas Shoreline Change Project: used for this example. 

 The following steps are intended to provide an overview of how to convert raw 
data into an initial shoreline. 

1. Open .shp files under GenCade\Hands-On Example\Shoreline Data. 
2. Left click 1995.shp under GIS Data in the project explorer window. 
3. Convert shapes to features: Click Mapping-> Shapes->Feature Objects. 

 Select Yes to use all shapes. 

 Click Next twice and Finish to create features. 
4. The imported arc is in many different segments, but the initial shoreline 

must be a single segment. Use the general directions below to merge and 
adjust shoreline data to create a single representative shoreline arc. In 
order to complete the exercise in the allotted time, open the saved map file 
rather than processing the entire initial shoreline. 

 Click the Feature Arc Selection  button and delete any 
unnecessary arcs; those beyond the area of interest, in bays, etc. 

 Click the Feature Point Selection  button and select all points. 

 Right click and select Convert to Vertices to merge connected 
segments. This merges already connected segments imported from 
the shapefile. 
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 Select all points then zoom to any identified Feature Points not at 
the ends of the desired shoreline. 

 Use the Create Feature Arc tool to close gaps in the shoreline 
segment, then delete unneeded arc segments, and convert Feature 
Points to Vertices to create a single continuous arc (Figure 4). 

 Select the arc, then right click and select Attributes, choose Initial 
Shoreline from the dropdown menu. 

 If necessary to save time for the workshop example, Open 
1995_shoreline.map under GenCade\Hands-On Example\Map 
Files, then delete previous coverage. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5. Merge discontinuous arcs to create a single shoreline arc. 
 

5. Rigorous quality control is required to make sure the initial shoreline 
accurately represents the shoreline of interest. 

 This is a tedious process requiring detailed inspection of the 
shoreline. 

 Smoothing algorithms may be applied to speed up the process. 

 Select the shoreline arc. 

 Right click and select Smooth Arcs from the dropdown 
menu, use default settings, select OK .  

 Inspect shoreline for accuracy. 

2. Delete unneeded 
arcs 

3. Convert to 
vertices

1. Close gap 
with new arc 
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Figure 6. Smooth shoreline segment and inspect for accuracy. 
 
Create the regional contour: 

 Obtain data to represent regional contour: 
o Use initial shoreline. 
o Trace from aerials or charts. 
o Pick elevation from survey data; any contour may be used. 

 Create regional contour. 
o For this example, the initial shoreline is smoothed to estimate the regional 

contour to provide a clear example of how changes in the regional contour 
influence model results. For engineering applications, the selection of the 
regional contour must be carefully considered during the model 
verification process. 

1. Rename active coverage: right click 1995_shoreline coverage, select 
Rename and type “Initial Shoreline”.  

2. Open “1995_shoreline.map” under GenCade\Hands-On Example\Map 
Files, then select the arc. 

3. Right click and select Attributes, choose Regional Contour from the 
dropdown menu. 

4. Right click and select Smooth Arcs from the dropdown menu, set Number 
of Neighbors to 50, select OK.  

5. Inspect contour to verify that it follows the regional shoreline trends. 
6. Modify vertices as needed to shape the contour to match regional trends. 

 Zoom to the area near the south jetty. 
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 Reshape arc so that it follows the shoreline trend. 
7. Rename active coverage to “Regional Contour.”  
8. Save often. 
9. To simplify the workshop and ensure a uniform data set for later 

comparison, Open “regional_contour.map” to load prepared initial 
shoreline and regional contour coverages. New coverages will be loaded 
with a (2) after the title. Delete old coverages and rename new coverages 
to delete the (2).   

 

Figure 7. Close up of initial shoreline and regional contour. 
 

 Merge Regional Contour and Initial Shoreline coverages. 
1. Select the initial shoreline and regional contour coverages; hold down 

CTRL to select multiple coverages.  
2. Right click and select Merge Coverages. 

 A dialog provides the option to delete the source coverages. Select 
No to save the old coverages in case you need to merge again. 

 A new coverage is created named Merge coverage. 
3. Delete the initial shoreline and regional contour coverages if no longer 

needed. 

 Convert the data to the state plane coordinate system. 
1. Right Click the coverage name, then select Reproject  
2. Acknowledge the SMS warning that this is a non-reversible command.  
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3. Select Global projection under New projection. 
4. Set projection to State Plane Coordinate System, Texas South Central 

zone, NAD 83, feet. 
5. Set vertical projection to local with units in U.S. survey feet. 
o When working in U.S survey feet all input data and parameters must be 

entered in US customary units with the exception of the effective grain 
size (which is always in mm) and the wave height (which is always in m). 

 Convert the display projection to the state plane coordinate system. 
1. Select Edit ->Projection  
2. Select Global projection, then Set Projection. 
3. Set projection to State Plane Coordinate System, Texas South Central 

zone, NAD 83, feet. 
4. Set vertical projection to local with units in U.S. survey feet. 

 

2.4. Inlets 
1. Create a feature arc extending across the inlet. Position of the inlet on the 

GenCade grid is controlled by the location of the two endpoints. 
2. Once the inlet is drawn, select the arc and double-click on the line 

representing the inlet. 
3. Select Inlet from the drop down menu. 
4. Select Attributes. 
5. Name the inlet “Galveston”. 
6. Set Inlet Shoal Volumes under the Volume button to match Table 1.  

 Shoal volumes presented are for illustration purposes only. Shoal 
volumes can be measured with surveys or predicted using various 
relationships. For more information the reader is referred to 
Walton, T.L., Jr., and Adams, W.D. (1976). “Capacity of inlet 
outer bars to store sand,”Proc. 15th Coastal Eng. Conf., ASCE, 
1,919-1,937. 

 
7. Specify a dredging event of 1,000,000 yd3 from the Ebb Shoal starting 

1/1/1996 and ending 3/1/1996 under the Dredging button.  Note that these 
are hypothetical quantities and do not represent the actual study area. 

Table 1. Inlet Shoal Volumes. 

  Initial, yd3 Equilibrium, yd3 

Ebb 5,000,000 5,000,000 

Flood 1,000,000 1,000,000 

Left Bypass 1,000,000 1,000,000 

Left Attachment 500,000 500,000 

Right Bypass 1,000,000 1,000,000 

Right Attachment 500,000 500,000 
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8. Set the bypassing coefficients Y left and Y right to 1.0. 
9. OK to exit Attributes, the feature arc will turn blue representing an inlet. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8. Assign inlet attributes. 
 

2.5. Jetties 
1. Draw a feature arc over each jetty.  
2. Once each jetty is drawn, click on the Select Feature Arc button and 

double-click on the line representing the jetty. 
3. Select Left or Right Jetty on Inlet from the drop down menu. 

 The left jetty is to the left of the inlet when looking seaward from 
the beach. 

4. Select Attributes and set Permeability to 0.5 for the left jetty and 0.3 for 
the right jetty.  

5. Check the Diffracting box and set the Seaward Depth to 25 ft for both 
jetties. 
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Figure 9. Assign jetty attributes. 
 

2.6. Seawall 
1. Draw a feature arc over the seaward edge of the seawall. 

 Be careful not to click on an existing feature arc. This will split the 
arc. If this occurs, delete the new arc, convert the newly created 
feature node to a vertex, and reassign arc attributes as necessary. 

 Zoom to an extent that allows you to build the feature arc easily. 
Create an arc across the view extents, then pan over and join a new 
arc to the last arc created. When the entire seawall is covered, 
select all feature nodes and convert to vertices to merge the 
segments into a single arc. 

2. Activate the Select Feature Arc button and double-click on the line 
representing the seawall, choose Seawall from the drop down menu. 

3. To expedite the example, draw a less detailed seawall or Open 
“seawall.map” to load prepared coverages; delete other coverages and 
rename as required. 
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Figure 10. Add a seawall. 
 

2.7. Groins 
1. Zoom in to an area with groins and then draw a feature arc over the groin. 

 Be careful not to click on an existing feature arc. This will split the 
arc. If this occurs, delete the new arc, convert the newly created 
feature node to a vertex, and reassign arc attributes as necessary. 

2. Once the arcs are drawn, click on the Select Feature Arc button and select 
each arc representing a groin. 

3. Right click and select Attributes, then choose Groin from the drop down 
menu and specify the following parameters: 

 Permeability: 0.1. 
 Diffracting: checked. 
 Seaward depth: 8 ft. 

4. To expedite the example, create two groins only or Open “groins.map” to 
load prepared coverage and delete other coverages. The prepared coverage 
includes 15 groins. 
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Figure 11. Add groins to the map. 
 

2.8. Refine Points 
Refine points allow increased grid resolution near structures or rapidly changing 
shorelines. Using less grid cells decreases run time, therefore it is advantageous to use a 
coarse grid with refine points where needed, whenever possible.  Take the following 
steps to include refine points: 
 

 Identify locations where a finer grid may be suitable. 
o Any place with a steep gradient in the shoreline, smaller grid cells may be 

required.  
o Often, poor results will prompt addition of refine points iteratively. 
o Visually inspect the shoreline for locations that may require refine points. 
o For this example, refine points will be placed near the terminus of each 

structure. 
 Create Refine Points. 

1. Create a new feature point using the Create Feature Point  button near 
each end of the seawall.  

2. Select the Feature Points then right click and select Node Attributes. 
3. Check the Refine grid in I direction box and set the Base cell size to 50 ft. 
4. Repeat for each Feature Point. 

 Multiple feature points can be selected and defined as refine points 
simultaneously. 
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Figure 12. Add refine points near structures. 
 

2.9. Grid Frame 

1. Click the Create 1-D Grid Frame button , then click the location you 
want the grid frame to start, then click again at the desired ending location. 

 If a person was walking down the grid to the arrow, the water 
would be to the left and the land would be to the right. For 
example, if the GenCade grid arrow was pointing south, the water 
would be to the east (left) and the land would be to the west (right). 

2. Click on the Select 1-D Grid Frame button , then click inside the 
rectangle that appears on the grid frame. 

 The grid frame can be lengthened or shortened by dragging the end 
point and rotated by dragging the circle at the end of the frame. 

3. Right click and select Properties to define the following values:  
 Origin X: 3,358,200 ft (X coordinate of grid start point) 
 Origin Y: 13,747,700 ft (Y coordinate of grid start point) 
 Angle: 220º (Orientation of grid, º counterclockwise from x axis) 
 I size: 155,000 ft (Length of grid) 
 Select Use Refine Points 
 Maximum Cell Size: 500 ft (Maximum size of any grid cell) 
 Maximum Bias: 1.1 (Rate of cell size growth, i.e. 1.1 implies that 

each adjacent cell is 10% larger than its neighbor until the 
maximum is reached) 
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 Do not check Use inner growth. (If the use inner growth option is 
selected, the cells will also grow between the two refine points, 
rather than remain at the finer scale.) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13. Set up 1D grid frame. 
 

2.10. Wave Data 
Waves provide the forcing for shoreline change. SMS will accept wave data in 
meteorological, oceanographic, Cartesian, or shore normal convention and then 
automatically convert to the shore normal convention required by GenCade. Real wave 
data often has gaps or errant data. Therefore, wave data must be processed before it can 
be applied in GenCade. For this example, a simple averaged wave condition will be 
applied to clarify model results. Optionally, instructions for processing WIS data are 
provided in Section 2.10.1 to demonstrate a typically required step.  
 

 Open “waves_averaged.xlsx” under GenCade\Hands-On Example\Wave Data. 

 Add wave data to SMS 
1. Click Edit->Single Point Projection to add a feature point at coordinates 

of the wave gage.  
 Under Convert From select Global Projection and Set Projection 

to Geographic with NAD83 as the horizontal datum and Arc 
Degrees as the Planar Units. Set the Vertical Projection to Local 
and the Units to feet. 

 Under Convert To select Global Projection and Set Projection to 
State Plane Coordinate System, Texas South Central zone, with 
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NAD83 as the horizontal datum and feet as the Planar Units. Set 
the Vertical Projection to Local and the Units to feet. 

 Longitude: -94.6  
 Latitude: 29.1  
 Z: 50  
 Check the Create feature point box. 
 Select Close 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

Figure 14. Add feature point for wave gage. 
 

2. Double click on the feature point with the Select Feature Point tool active 
and check the Wave gage box, and then click the Options button. 

3. Enter Depth of 50 ft and click the Data button. 
4. Copy wave data from “waves_averaged.xlsx,” paste to the Wave Events 

window. 
5. Specify the angle convention of the wave data (Provided data is in Shore 

Normal Convention). 
 Select Shore Normal from the Convention drop down menu. 
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Figure 15. Add data to wave gage. 
 

3. Convert to GenCade Model Grid 
Now that all of the data have been loaded and organized, the grid can be created. Take 
the following steps to create the GenCade grid: 
 

 Load example map file: 
1. In order to use the specified cell numbers in the following examples, it is 

necessary to load the exact input data used throughout this example. If you 
choose not to load the example map file, some of the values in the 
remainder of this example should be expected to vary.  

2. Open wave gage.map under GenCade\Hands-On Example\Map Files, and 
then delete previous coverage. 

 Convert map to 1-D grid. 
1. Right click on the GenCade coverage and select Convert ->Map->1-D 

Grid. 
2. Verify that the settings in the properties window haven’t changed and 

select OK. 
3. Inspect the grid to ensure that all of the features translated from the 

conceptual model properly. Locations of features on the grid often require 
adjustment when the shoreline angle is steep relative to the grid. 

 Move the locations of the attachment bars so that they are at least 2 cells away 
from the jetties. 

1. Select the GenCade grid in the Project Explorer. 
2. GenCade->Edit Inlets opens the Inlet Reservoir Model window. 
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3. Under the Cell Position button for the Galveston inlet set/verify the 
following parameters: 

 Inlet beg. cell: 104 
 Inlet end cell: 115 
 Left bypass beg. cell: 101 
 Left bypass end cell: 102 
 Right bypass beg. cell: 117 
 Right bypass end cell: 118 

 Verify that all information entered in the conceptual model is correct in the 
GenCade model. 

1. Select the GenCade grid in the Project Explorer. 
2. Under the GenCade menu all of the various inputs can be reviewed or 

modified. 
3. Select GenCade->Edit Grid and notice that the Azimuth is not the same as 

the angle selected in the conceptual grid frame.  
 Note: The sign convention for the GenCade model grid is in degrees clockwise 

from north. Wave data must be relative to the orientation of the GenCade model 
grid and not the conceptual model grid. 

4. Setup and Run GenCade Model 
Take the following steps to set up the model control parameters and run GenCade: 
 

 Set model parameters. 
1. Select the GenCade grid in the Project Explorer. 
2. GenCade->Model Control opens the GenCade model control window 

with four tabs. 
3. Under the Model Setup tab enter the following:  

 Check the Full print output box 
 Start Date: 1/1/1995 00:00 
 End Date:  1/1/2000 00:00 
 Time Step: 1 hr 
 Recording Time Step: 720 hr 

4. Under the Beach Setup tab enter the following: 
 Effective grain size: 0.17 mm 
 Average berm height: 3 ft 
 Depth of Closure: 20 ft 
 K1: 0.4 
 K2: 0.2 

5. Under the Seaward BC tab enter the following: 
 Number of cells in the offshore contour smoothing window: 50 

6. Under the Lateral BC tab change the following: 
 Right lateral BC 

 Type: Moving 
 -10 ft per simulation period 

 Save GenCade 
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1. File->Save as, create a new folder, save “initial run”.  
 Run GenCade 

1. GenCade->Run GenCade. 
2. Wait for model to run and click Exit. 

5. Visualize Results in SMS 
This section demonstrates visualization of results in SMS. Working with GenCade output 
files in other programs is discussed in Section 8.  
 

 GenCade output files used in this example: 
1. *.slo – Shoreline Change File: The shoreline change file includes the 

shoreline position at each recording time step. 
2. *.irv – Inlet Shoal Volume File: Volumes for each component are output 

at each recording time step in this file. 
3. *.shi – Initial Shoreline Position File: This file contains the initial 

shoreline position. 
4. *.qtr – Longshore Transport File: The longshore transport file includes the 

calculated net transport at each recording time step. 
5. *.shdx – Grid Size File: This file enables easy conversion of model output 

to horizontal space. Each number in the file represents the size of each 
grid cell. 

6. *.prt – Print File: The print file includes all of the information saved 
during the run including shoreline position, shoreline change, breaking 
wave angle, offshore wave angle to the x-axis, and transport volume to the 
left and right after each year. The print file cannot be automatically 
imported into SMS. 

 Working with data in SMS. 
1. Open “initial run.slo” and “initial run.qtr”. 
2. Four data sets are now available under the GenCade grid in the Project 

Explorer and the Time Step window has opened. 
3. Change between datasets by clicking on the dataset of interest. 
4. Change time steps by clicking on time step of interest.  
5. Once selected, the arrow keys may be used to navigate through the lists. 
6. Transport rate, shoreline change, and rate of change are shown relative to 

the GenCade grid, while shoreline position is shown in the selected 
coordinate system. 

7. Select the Shoreline data set, zoom into an area of interest so you can see 
the initial and calculated shorelines, and then change the time step to 
observe shoreline change in time.  

8. Data->Film Loop will create a movie of the shoreline change at the 
selected zoom extents. 

9. To open a shoreline graph window click Display->Plot Wizard, select 
GenCade Shoreline from the Plot Type list on the Step 1 window, select 
Active data set and Active time step from the Step 2 window. 

10. Changes to the data set and time step are automatically applied to the 
graph. 
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11. Right click inside the Plot window and select Display Options to modify 
plot settings. 

12. To open an inlet time series graph window click Display->Plot Wizard, 
select GenCade Inlet TS from the Plot Type list on the Step 1 window, 
choose the Inlet “Galveston”, Start time “1/31/1995”, End time 
“12/6/1999”, and select the “Ebb” Dataset from the Step 2 window. 

13. After data have been loaded to a plot window data can be exported to 
figures or text by right clicking and selecting Export/Print. 

 
 

Figure 16. Display results in SMS. 
 

6. Note on Model Calibration and Verification 
There is not sufficient time in the workshop to calibrate and verify a model; however it is 
important to note that this point in the example is where that process would occur. The 
general process requires starting with a known condition, running the model over a period 
of time for which data exists, then comparing model results to measured data. The 
empirical transport coefficients, K1 and K2, would then be varied until the model results 
match measured data. In practice, a lack of data or some initially misunderstood process 
often requires varying other aspects of model setup to obtain good calibration (the 
condition where model calculations match observations). Ideally, another time period for 
which data exists would be simulated, using the same model setup, to verify that the 
model accurately represents the physical processes involved. It is important to remember 
to always base engineering decisions on a verified model. 
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7. Modifying GenCade for Project Analyses 
Now that you have a working GenCade model, it can be modified to evaluate potential 
projects that might include beach nourishment, dredging, jetties, groins, breakwaters, or 
seawalls.  Modifications may also be necessary to investigate model sensitivity to 
different input parameters.  

7.1. Sensitivity Analysis 
The next few tasks demonstrate sensitivity of GenCade to some model parameters: 
 

 Modify inlet shoal volumes to investigate relative importance of shoal volumes in 
the model. 

1. Save the GenCade model to a new folder, name it “shoal volumes”. 
2. Delete solution datasets in the Project Explorer. 
3. GenCade->Edit Inlet and select the Volume button  

 Change all initial volumes to match table 2 below: 
 

Table 2. Inlet Shoal Volumes. 

  Initial, yd3 Equilibrium, yd3 

Ebb 3,000,000 5,000,000 

Flood 600,000 1,000,000 

Left Bypass 600,000 1,000,000 

Left Attachment 300,000 500,000 

Right Bypass 600,000 1,000,000 

Right Attachment 300,000 500,000 
 

4. Save and run GenCade. 
5. Open “shoal volumes.slo”, then open “initial run.slo”. The last added data 

sets will be designated with a sequential numeric value in parentheses. 
Compare shoreline change near the inlet. 

6. Open an inlet time series graph to observe change in inlet volumes over 
time. 
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Figure 17. Modify inlet shoal volumes. 
 

 Modify empirical transport coefficient, K1. 
1. Save the GenCade model to a new folder, name it “transport mod”. 
2. Reset the inlet shoal volume data. 
3. Delete solution datasets in the Project Explorer. 
4.  Change K1 to 0.5 on the Beach Setup tab under Model Control. 
5. Save and run GenCade. 
6. Compare transport volumes in the print file. 

 Open transport mod.prt and shoal volumes.prt in a text editor 
(notepad, wordpad, etc) for quick comparison. 

 Modify number of cells in offshore contour smoothing window. 
1. Save the GenCade model to a new folder, name it “smoothing window”. 
2. Reset K1 to 0.4. 
3. Delete solution datasets in the Project Explorer. 
4.  Change Number of Cells in Offshore Contour Smoothing Window to 10 

on the Seaward BC tab under Model Control. 
5. Save and run GenCade. 
6. Compare transport volumes in the print file. 

 Open transport mod.prt and shoal volumes.prt in a text editor 
(notepad, wordpad, etc) for quick comparison. 

o Note: Sensitivity analysis should always be conducted to determine 
the appropriate value for this parameter. 
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 Modify the regional contour. 
1. Save the GenCade model to a new folder, name it “regional contour mod”. 
2. Use the Select Feature Vertex button to drag points on the regional 

contour reshaping it near the south jetty. 
3. Convert to 1-D grid, setup and run GenCade. 
4. Evaluate results. 

 
 
 

Figure 18. Modify regional contour. 
 

 Run GenCade without the regional contour. 
1. Save the GenCade model to a new folder, name it “no regional contour”. 
2. Delete the GenCade grid in the Project Explorer. 
3. Delete the regional contour. 
4. Convert to 1-D grid, setup and run GenCade. 
5. Evaluate results, notice large differences near the jetties and west end of 

the seawall. 

7.2. Beach Fill 
Add beach nourishment along the seawall: 

1. Open the previously saved model “initial run.sms”. 
2. Save the GenCade model to a new folder, name it “beachfill”. 
3. GenCade->Edit Beachfills. 
4. Input the following data in the Beach Fill window 

 Start date: 8/1/1995 
 End date: 12/1/1995 
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 Start cell: 213 
 End cell: 703 
 Added berm width: 150 ft 

5. Save and run GenCade and evaluate results. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 19. Add a beach fill. 
 

7.3. Breakwater 
Add a breakwater near the west end of the seawall: 

1. Save the GenCade model to a new folder, name it “breakwater”. 
2. Delete the GenCade grid in the Project Explorer. 
3. Draw a new feature arc in the location you want the breakwater. 
4. Define the feature arc as a Breakwater and input the following data in the 

Detached Breakwaters window: 
 Depth 1: 12 ft 
 Depth 2: 12 ft 
 Constant Transmission 
 Permeability (Perm): 0 

5. Convert to 1-D grid, setup and run GenCade, and evaluate results. 
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Figure 20. Add a breakwater. 
 

8. Processing Data in Excel 
It is often necessary to analyze data in programs other than SMS.  The following tasks 
demonstrate some typical tasks, illustrating the general procedure for working with 
GenCade output files. 
 

 Open “initial run.slo” with Excel, use space as the column delimiter. 
1. Files used in this example are located in GenCade\Hands-On 

Example\SMS Project Files\initial run. 
 Save the excel file as “work.xlsx” and rename the active sheet to “initial run_slo”. 

1. File “excel plots.xlsx” in GenCade\Hands-On Example\Excel contains the 
results of this section. 

 Since refine points were used to create a grid with variable spacing, the .shdx file 
must be used to determine the position of each cell. 

1. Data in the .shdx file is in a matrix format instead of in a single column or 
row. Each entry in the .shdx file represents the size of each cell. 

2. A Matlab program, “shdx_column.m”, is included in the Tools folder to 
convert grid size data in the .shdx file into a single column representing 
distance from grid origin. Matlab must be installed on your computer to 
run this program. Alternatively, this task can be completed in Excel. 

3. Open the file created by the Matlab program, “shore_position.out”, and 
copy into “work.xlsx” on a sheet named “shore_position”. 



 

26 

 Open “transport mod.slo” with Excel and copy into “work.xlsx”, name the sheet 
“transmod_slo”. 

 Create a plot with shoreline position at the end of each year for the initial run. 
1. Select values for the 19951227 time step on the “initial run_slo” sheet. 
2. Click Insert->Scatter, select scatter with smooth lines. 
3. With the new chart highlighted, click Design->Move Chart and select 

New Sheet title “initial run”. 
4. Right click in the chart area and click Select Data. 
5. Click Edit, then change the Name to the date, and add the X Series data 

from the “shore_position” sheet. 
6. Click OK, then Add data for shoreline position at the end of each year. 
7. Label axes as desired. 

 Calculate shoreline change for the initial run. 
1. Since the .slo file only contains shoreline position, the initial shoreline is 

needed to calculate shoreline change. 
2. The .shi file contains the initial shoreline position in a matrix format.  
3. To convert to a single row or column, either copy and paste in Excel or 

use a short program. The Matlab program, “shi.m,” will convert the data to 
a single row. The program writes the data to a file named “SHI.out.” 

 Note: A reference shoreline can be converted to grid format by 
assigning the shoreline as the initial shoreline and then converting 
to 1-D grid. SMS will then save the shoreline in the .shi file. This 
is convenient for model calibration/verification. 

4. Open “SHI.out” and copy into excel plot.xlsx to a sheet named “initial 
shoreline.” 

5. Make a copy of the “initial run_slo” sheet and name it 
“initial run_change”. 

6. Subtract the initial shoreline position from each calculated shoreline 
position. 

 Type “='initial run_slo'!B2-'initial shoreline'!A$1” into cell B2 
then drag all the way to the right, then down. 

7. Positive values are accretion, negative values are recession. 
 Create a plot of the total shoreline change for the initial run. 

1. Follow the general guidelines above and use the last time step of shoreline 
change for the Series Y Values. 

2. Put the new chart on a new sheet named “Total Shoreline Change”. 
 Calculate shoreline change for “transport mod.slo” and plot the total change on 

the same plot created for the initial run. 
1. Follow general guidelines described above. 

 Working with the other GenCade output files follows the same general method 
above. 
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9. Supplemental Data for Example Model Setup 
This section contains model setup parameters and cell addresses used for the inlet and 
structures in the example. Advanced users can skip to this section to quickly locate data 
needed for the example. 
 
 
Table 3. GenCade model setup parameters. 

Parameter Value 
Start Date 1/1/1995 0:00 
End Date 1/1/2000 0:00 
Time Step 1 
Recording Time Step 720 
Effective Grain Size, mm 0.17 
Average Berm Height, ft 3 
Depth of Closure, ft 20 
K1 0.4 
K2 0.2 
Height Amplification Factor 1 
Angle Amplification Factor 1 
Angle Offset 0 
Wave Components to Apply Primary 
Number of cells in offshore contour smoothing window 50 
Left Lateral Boundary Condition Pinned 
Right Later Boundary Condition, ft per sim. period Moving (-10) 
 
 
Table 4. Conceptual grid frame parameters. 

Parameter Value 

Origin X, ft 3,358,200
Origin Y, ft 13,747,700
Angle, º 220
I size, ft 155,000
Use refine points yes
Maximum cell size, ft 500
Maximum bias 1.1
Use inner growth no
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Table 5. Inlet cell locations. 

   Beginning Cell Ending Cell 

Inlet 104 115 

Left Bypass 101 102 

Right Bypass 117 118 
 
 

Table 6. Seawall segment locations. 

Start Cell Y1, ft End Cell Y2, ft 

157 21,830 201 22,558 

201 22,558 244 22,984 

244 22,984 270 23,232 

270 23,232 347 23,603 

347 23,603 382 23,627 

382 23,627 422 23,527 

422 23,527 469 23,506 

469 23,506 532 23,284 

532 23,284 692 22,628 

692 22,628 742 22,349 

742 22,349 842 21,994 

842 21,994 976 21,538 
 
 
Table 7. Groin locations and parameters. 

Cell Index Length, ft Permeability Seaward Depth, ft 

247 23,582 0.1 8 

303 23,911 0.1 8 

336 24,019 0.1 8 
366 24,142 0.1 8 
397 24,108 0.1 8 
414 24,210 0.1 8 
443 24,101 0.1 8 
472 24,125 0.1 8 
496 23,968 0.1 8 
519 23,870 0.1 8 
550 23,735 0.1 8 
578 23,682 0.1 8 
606 23,510 0.1 8 
636 23,217 0.1 8 
656 23,490 0.1 8 
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Table 8. Beach fill parameters. 

Begin Date End Date Start Cell End Cell Added Berm Width, ft 
1-Aug-95 1-Dec-95 213 703 150 

 
 
Table 9. Breakwater parameters. 
Start 
Cell 

Y1, ft 
Depth 
1, ft 

End 
Cell 

Y2, ft 
Depth 
2, ft 

Transmission Coefficient 

706 23,331 12 961 22,192 12 Constant 0 
 


