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Foreword 

The Hydrologic Engineering Center’s (HEC) recent developments in 
Geographic Information System (GIS) tools for hydrologic and 
hydraulic modeling result from many years of interest in geospatial data 
usage.  The earliest work was in the mid 1970's when HEC developed 
software based on the concepts developed in the Harvard University's 
School of Landscape Architecture, Honey Hill Project.  That early work 
culminated with the development of the Spatial Analysis Methodology 
(HEC-SAM), which included a grid-cell data bank and analysis 
software for hydrologic and flood damage calculations.  That early 
work had the same concepts as those of today, but the limitations in the 
computer hardware, GIS software, and data availability made 
widespread engineering applications difficult. 

The current development builds on those early experiences and takes 
the technology to several practical engineering products including 
HEC-GeoHMS.  HEC resurrected its earlier efforts by reviewing 
current GIS capabilities in association with Professor David Maidment 
from the University of Texas.  HEC and Dr. Maidment formulated a 
watershed data structure that would link GIS and hydrologic models.  
From that time, the definition and content of the GIS and hydrologic 
data structures evolved into a hydrologic GIS preprocessor, PrePro.  
Taking advantage of the wealth of terrain and geographic data readily 
available over the Internet and from government agencies, PrePro 
delineates streams and watersheds and builds the hydrologic model 
structure for HEC-HMS.  PrePro was the predecessor to HEC-
GeoHMS. 

The development of PrePro at the University of Texas was partially 
supported by HEC via the Corps’ Civil Works R&D program.  The 
effort also received substantial support from the Texas Department of 
Transportation as well as support from other national and international 
agencies.  PrePro development at the Center for Research in Water 
Resources at the University of Texas has been directed by Dr. 
Francisco Olivera.  GeoHMS has been developed by HEC and ESRI as 
a component of a Cooperative Research and Development Agreement 
between those two organizations.  Dr. Maidment, Dr. Olivera, and 
others at the Center for Research in Water Resources have provided 
valuable assistance for the development of GeoHMS. 
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Other GIS products that have been released or are under development 
by HEC include HEC-GeoRAS, a GIS utility for use with the HEC-
RAS river hydraulics program, and HEC-GeoFDA, a GIS utility for use 
with the HEC-FDA flood damage analysis package. 

For several years, HEC has developed a number of GIS modules for 
specific tasks, such as processing terrain for drainage path, generating 
grid-based rainfall, etc.  Those modules required users to be 
knowledgeable of UNIX, ArcInfo, hydrology, and a number of 
miscellaneous sub-programs.  HEC-GeoHMS combines the 
functionality of those ArcInfo programs into a package that is easy to 
use with a specialized interface.  With this ArcView capability and a 
graphical user interface, the user easily accesses customized menus, 
tools, and buttons instead of the command line interface in ArcInfo.  
With GeoHMS, users who are new to GIS have access to powerful GIS 
operations. 

GeoHMS Version 1.0 was developed to use readily available digital 
geospatial information to construct hydrologic models more 
expediently than using manual methods.  Also, development of basic 
watershed information will aid the user in estimating hydrologic 
parameters.  After gaining adequate experience with using GIS-
generated parameters, users can take steps to streamline the process of 
hydrologic parameter estimation. 

The Wisconsin Department of Natural Resources (WDNR) and 
Environmental System Research Institute’s, Inc. (ESRI) contributed 
greatly to the development of GeoHMS Version 1.1.  WDNR’s plans to 
develop completed HMS models with hydrologic parameters and 
topographic parameters for regional regression analysis provided 
GeoHMS Version 1.1 with a number of additional program procedures.  
As a result, GeoHMS Version 1.1 is more robust.  Users can extract 
more watershed characteristics from DEM and GIS data for developing 
hydrologic parameters.  Users can now work with digital elevation 
models (DEM) in a number of coordinate systems and projections.  
Users can recondition the DEM by imposing a known stream network 
onto the terrain grid.  Where appropriate, GeoHMS 1.1 facilitates the 
analysis and computation of hydrologic parameters for the hydrologic 
basin model.  GeoHMS 1.1 also expands its scope to develop the 
Hydrologic Modeling System (HEC-HMS) meteorologic model and 
control specifications.   

GeoHMS Version 1.1 will be the terminal release of the software using 
ESRI’s ArcView 3.x platform.  The next version, 2.0, is currently being 
built on the ESRI’s ArcGIS 8.x platform.   
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Introduction 

In recent years, advances in Geographic Information Systems (GIS) 
have opened many opportunities for enhancing hydrologic modeling of 
watershed systems.  With an openness to share spatial information via 
the Internet from government agencies, commercial vendors, and 
private companies, coupled with powerful spatial algorithms, the 
integration of GIS with hydrologic modeling holds the promise of a 
cost-effective alternative for studying watersheds.  The ability to 
perform spatial analysis for the development of lumped and distributed 
hydrologic parameters not only saves time and effort, but also improves 
accuracy over traditional methods.  In addition, hydrologic modeling 
has evolved to consider radar rainfall and advanced techniques for 
modeling the watershed on a grid level.  Rainfall and infiltration can be 
computed cell by cell providing greater detail than traditional lumped 
methods.  These advanced modeling techniques have become feasible 
because the consuming data manipulations can now be generated 
efficiently with GIS spatial operations.  For example, the ability to 
perform spatial overlays of information to compute lumped or grid-
based parameters is crucial for computing basin parameters, especially 
grid-based parameters.   

HEC-GeoHMS has been developed as a geospatial hydrology tool kit 
for engineers and hydrologists with limited GIS experience.  The 
program allows users to visualize spatial information, document 
watershed characteristics, perform spatial analysis, delineate subbasins 
and streams, construct inputs to hydrologic models, and assist with 
report preparation.  Working with HEC-GeoHMS through its 
interfaces, menus, tools, buttons, and context-sensitive online help, in a 
windows environment, allows the user to expediently create hydrologic 
inputs that can be used directly with the Hydrologic Modeling System, 
HEC-HMS.  

Chapter 1 discusses the intended use of HEC-GeoHMS and provides an 
overview of this manual.  Below is an outline of Chapter 1. 
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Contents 

• Technical Capabilities 
• Program Features 
• Intended Application of HEC-GeoHMS 
• User’s Manual Overview 
• Documentation Conventions 

Technical Capabilities 

Hydrologic modeling has evolved to represent the subbasin in more 
detail than the traditional lumped approach where hydrologic 
parameters are averaged over the subbasin.  With the availability of 
radar rainfall and spatial data, hydrologic modeling on a grid level has 
introduced a more detailed representation of the basin.  This distributive 
modeling approach utilizes the ModClark (Peters and Easton, 1996; 
Kull and Feldman, 1998) hydrograph transformation method, which 
tracks infiltration and excess rainfall on a cell by cell basis.  To meet 
the needs of both the traditional lumped and distributed basin 
approaches, HEC-GeoHMS can create HMS input files that are 
compatible with both approaches. 

HEC-GeoHMS version 1.0 creates a background map file, lumped 
basin model, a grid-cell parameter file, and a distributed basin model, 
which can be used by HMS to develop a hydrologic model.  The 
background map file contains the stream alignments and subbasins 
boundaries.  The lumped basin model contains hydrologic elements and 
their connectivity to represent the movement of water through the 
drainage system.  The lumped basin file includes watershed areas and 
reserves empty fields for hydrologic parameters.  To assist with 
estimating hydrologic parameters, GeoHMS can generate tables 
containing physical characteristics of streams and watersheds.  If the 
hydrologic model employs the distributive techniques for hydrograph 
transformation, i.e. ModClark, and grid-based precipitation, then a grid-
cell parameter file and a distributed basin model can be generated.  

HEC-GeoHMS version 1.1 allows the user to analyze DEM’s in a 
number of coordinate systems and projections, including Albers-Equal 
Area, Universal Transverse Mercator (UTM), Tranverse Mercator, 
Lambert, and the State Plane Coordinate System.   An added capability 
of version 1.1 allows users to use a more sophisticated “burning in” 
technique to impose the stream onto the terrain.  This is accomplished 
as a gradual step-wise process to better reproduce stream networks and 
watershed boundaries. With regards to hydrologic parameters 
estimation, users are equipped with a process to estimate initial values 
of some hydrologic parameters.  Users are able to compute lumped and 
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gridded curve numbers using both State Soil Geographic Data Base 
(STATSGO) and Soil Survey Geographic Data Base (SSURGO) soil 
databases.  Time of concentration and simple Muskingum-Cunge 
routing can also be estimated.  Finally, users can generate the 
meteorologic model based on the user gage-weighting method and 
generate control specifications based on the user’s input of a time 
window and computational time interval. 

Program Features 

HEC-GeoHMS is a public-domain extension to the ArcView GIS and 
Spatial Analyst extension.  ArcView GIS and its Spatial Analyst 
extension are available from the Environmental Systems Research 
Institute, Inc., ESRI.  HEC-GeoHMS runs on the Windows 
95/98/NT/2000/XP platforms.  The following program features 
illustrate GeoHMS’s functionality and ease of use. 

Data Management 
GeoHMS performs a number of administrative tasks that help the user 
manage GIS data derived from the program.  The data management 
feature tracks thematic GIS data layers and their names in a manner 
largely transparent to the user.  Prior to performing a particular 
operation, the data manager will offer the appropriate thematic data 
inputs for operation, and prompt the user for confirmation.  Other 
times, the data management feature manages the locations of various 
projects and also performs error checking and detection. 

Terrain Preprocessing 
GeoHMS allows users to perform terrain preprocessing in either a step-
by-step fashion or batch mode.  In the step-by-step process, the user 
often has the opportunity to examine the outputs and make corrections 
to the data set, as appropriate.  However, if the user has performed the 
terrain preprocessing a number of times, then batch processing will 
allow terrain preprocessing to be performed unattended. 

Basin Processing 
The emphasis of the subbasin delineation, processing, and manipulation 
capability is on flexibility, ease of use, and user interactivity.  As the 
user subdivides a basin or merges many smaller subbasins together, the 
results of the operation are displayed immediately for the user’s 
confirmation.  The ability to perform subbasin processing interactively 
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is powerful, because the results are presented quickly for the user to 
make a modeling decision instead of having to reprocess the data.  For 
example, the user can obtain a stream profile and look for significant 
grade breaks.  If a subbasin subdivision at a grade break is desired, the 
user, using the delineation tool, just clicks on the stream profile at the 
grade break.  Other tools allow the user to delineate subbasins in a 
batch mode by supplying a data set of point locations of desired outlets. 

Hydrologic Parameter Estimation 
Users can now compute the Curve Number loss rate parameter based on 
various soil and landuse databases.  The curve number can represent a 
lumped value for a subbasin or an individual cell for a grid-based 
subbasin.  In addition, watershed and channel characteristics together 
with a spreadsheet template are linked to GeoHMS to assist the users 
with estimation of initial values of time of concentration.  Also, basin 
and channel characteristics can be used to calculate CN Lag and simple 
prismatic Muskingum-Cunge routing parameters. 

HMS Model Support 
GeoHMS produces a number of hydrologic inputs that are used directly 
in HMS.  In addition, the program supports the estimation of hydrologic 
parameters by providing tables of physical characteristics of the streams 
and watersheds.  While working with HEC-GeoHMS, the user can 
toggle HEC-GeoHMS on/off in order to bring in other ArcView 
extension programs to perform spatial operations and develop 
additional parameters for populating the hydrologic model. 

Intended Application of HEC-GeoHMS 

HEC-GeoHMS is intended to process watershed data after the initial 
compilation and preparation of terrain data is completed.  The assembly 
of GIS data can be performed using standard GIS software packages 
that support ARC Grid format.  Even though this user’s manual 
provides some guidance and discussions on the proper approach for 
assembling data, HEC-GeoHMS is not intended as a tool for data 
assembly.  When assembling data, it is important to understand how to 
use GIS software to put data of different types and formats into a 
common coordinate system.  A few examples of required data include 
digital elevation model, digital stream alignments, and stream gage 
locations.  The most important data, and often the most difficult, is a 
“hydrologically corrected” digital elevation model, DEM.   
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When the data assembly is complete, HEC-GeoHMS processes the 
terrain and spatial information to generate a number of hydrologic 
inputs.  It is intended that these hydrologic inputs provide the user with 
an initial HMS model.  The user can estimate hydrologic parameters 
from stream and watershed characteristics, gaged precipitation, and 
streamflow data.  In addition, the user has full control in HMS to 
modify the hydrologic elements and their connectivity to more 
accurately represent field conditions. 

User’s Manual Overview 

This manual provides detailed instructions for using the HEC-GeoHMS 
ArcView extension to develop hydrologic inputs for HEC-HMS.  The 
manual is organized as follows: 

Chapter 1 - Introduction to HEC-GeoHMS 

Chapter 2 - Instructions for installing HEC-GeoHMS and getting 
started 

Chapter 3 - Overview of the major steps in using HEC-GeoHMS 

Chapter 4 - Data collection 

Chapter 5 - Issues related to data assembly, especially the terrain data 

Chapter 6 - Terrain preprocessing 

Chapter 7 - Basin processing 

Chapter 8 - Physical characteristics extracted for streams and 
watersheds 

Chapter 9 - Hydrologic parameter estimation 

Chapter 10 - Input files for HMS 

Chapter 11 - Example application of HEC-GeoHMS 

Appendix A - References 

Appendix B - HMS background map file format 

Appendix C - Grid-cell parameter file format 

Appendix D - Standard Hydrologic Grid (SHG) specifications  

Appendix E - Curve number grid development 

Appendix F - Example of SCS curve number computation process 
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Appendix G - Update procedure for new SSURGO data 

Appendix H - Frequently asked questions and corrections  

Appendix I - Program license agreement 

Documentation Conventions 

The following conventions are utilized throughout the manual to 
describe the windows and screens in the program interface.  Window 
and screen titles are shown in bold and italics.  Menu names, menu 
items, and button names are shown in bold.  Menus are separated from 
submenus with the right arrow ⇒.  Data to be typed into an input field 
on a window or screen is shown in the courier font and within 
“double quotes”.  A column heading, tab name, field title, and name of 
tables, files, or themes are shown in “double quotes”.  Names of tables, 
files, or themes are not case sensitive, but certain letters are capitalized 
for readability. 
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HEC-GeoHMS Installation 

This chapter discusses the hardware and software requirements and 
installation procedures for HEC-GeoHMS.  Prior to installing this 
software, ArcView GIS and the Spatial Analyst extension should be 
installed using their installation guides.  The following installation 
procedures apply to computers running the Windows 95/98 and 
NT/2000/XP operating systems.  After HEC-GeoHMS is installed, 
guidelines will be provided to load it within ArcView.  Below is an 
outline of Chapter 2. 
Contents 

• Hardware and Software Requirements 
• Installation of HEC-GeoHMS 
• Loading HEC-GeoHMS 

Hardware and Software Requirements 

The minimum hardware and software requirement for using HEC-
GeoHMS are similar to those of ArcView GIS.  However, when working 
with GIS, it is important to take into account the size of the data sets as 
well as the complexity of the analysis when determining adequate 
computer resources.  Even though the program will still work on a slower 
machine, the user will often experience long computing times.  To assure 
that performance is not being compromised, the following hardware 
recommendations should be considered with the idea that more computer 
resources, in terms of central processing unit (CPU) speed, memory, and 
hard drive space, could improve program performance. 

Recommended Hardware Specifications 
The recommended hardware specifications are as follows: 

CPU:    Pentium III 500Mhz 
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Memory:   256 MB 

Hard Drive Space:  Hard drive space available should be at least 20 
times the size of the terrain data.  For example, if 
the terrain data takes up 50 MB, then the available 
hard drive space should be about 1 GB.  In many 
cases, having ample hard drive space available will 
improve performance because the spatial operations 
often generate many temporary intermediate file 
and repeatedly perform files caching. 

Required Software Specifications 
The required hardware specifications are as follows: 

Operating System:    Windows 95/98/NT/2000/XP 

Pre-installed software: ArcView GIS 3.2 or later  

Spatial Analyst 1.1 extension or later 

Installation of HEC-GeoHMS 

The installation of HEC-GeoHMS will copy program files and sample 
data sets to the location of ArcView and Spatial Analyst.  HEC-GeoHMS 
can be installed using the: Automatic or Manual Installation procedure. 

Automatic Installation 
• Place the CD in the CD-ROM drive 
• If the setup program does not start, then select Start ⇒Settings ⇒ 

Control Panel.  Click the Add Hardware/Software icon 
• Follow the steps displayed in the message box to complete the 

installation. 

Manual Installation 
The manual installation of HEC-GeoHMS consists of copying GeoHMS 
files to where ArcView is installed.  Typically, ArcView is installed in 
C:\esri\Av_gis30\Arcview\.  For the purpose of this installation, the location 
of the ArcView files is referred to as $AVHOME.  Copy the following files 
to the specified ArcView sub-directories.  These files are saved under the 
Manual Installation directory on the CD-ROM. 
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Program Files    Specified Locations 
GeoHMS_readme.txt   $AVHOME\bin32 

HEC-GeoHMS.avx   $AVHOME\ext32   

g2i.dll       $AVHOME\bin32   

DirRemove.exe    $AVHOME\bin32   

geohms11.hlp     $AVHOME\help   

geohms11.GID    $AVHOME\help 

geohms11.CNT    $AVHOME\help  

hmspoint.avp     $AVHOME\symbols   

hmsmarker.avl     $AVHOME\symbols   

hmsline.avl     $AVHOME\symbols   

fdr.avl       $AVHOME\symbols   

hrap_alb.shp     $AVHOME\tools   

hrap_alb.shx     $AVHOME\tools   

hrap_alb.dbf     $AVHOME\tools 

hrap_alb.sbx     $AVHOME\tools 

hrap_alb.sbn     $AVHOME\tools 

hmsdesign.control    $AVHOME\etc   

hmsdesign.dss     $AVHOME\etc  

hmsdesign.gage    $AVHOME\etc  

HMSMetDesign.txt   $AVHOME\etc   

Tc.xls       $AVHOME\etc   

Tc.exe       $AVHOME\etc   

StatePlaneLookup.txt   $AVHOME\etc   

Loading HEC-GeoHMS 

Once HEC-GeoHMS is installed, it can be loaded within ArcView.  To 
do this, open ArcView.  ArcView extensions are loaded through the File 
menu on the main ArcView window.   
• Select the File ⇒ Extensions… menu item.   
• In the Extensions dialog that appears, scroll down until HEC-

GeoHMS is visible. 
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• Click on the name label HEC-GeoHMS to access the About 
information as shown in Figure 2–1. 

• Check the box to turn it on. 
• Press OK to close the dialog and watch the lower portion of the 

ArcView window for the installation notes. 

 
Figure 2–1. Extensions window with HEC-GeoHMS. 

In is not necessary to load the Spatial Analyst extension because 
GeoHMS will automatically load it.  When properly installed and loaded, 
HEC-GeoHMS will create two document types, MainView and 
ProjView, as shown in Figure 2–2. 
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Figure 2–2.  HEC-GeoHMS loaded within ArcView. 
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Working with HEC-GeoHMS – An 
Overview 

HEC-GeoHMS is a set of ArcView scripts developed using the Avenue 
programming language and Spatial Analyst.  It includes integrated data 
management and a graphical user interface (GUI).  Through the GUI, 
which consists of menus, tools, and buttons, the user can analyze the 
terrain information, delineate subbasins and streams, and prepare 
hydrologic inputs. 

The relationship between GIS, HEC-GeoHMS, and HEC-HMS is 
illustrated in Figure 3–1.  With the vertical dashed line separating the 
roles of the GIS and the watershed hydrology, HEC-GeoHMS provides 
the connection for translating GIS spatial information into hydrologic 
models.  The GIS capability is used for heavy data formatting, 
processing, and coordinate transformation.  The end result of the GIS 
processing is a spatial hydrology database that consists of the digital 
elevation model (DEM), soil types, land use information, rainfall, etc.  
Currently, HEC-GeoHMS operates on the DEM to derive subbasin 
delineation and to prepare a number of hydrologic inputs.  HEC-HMS 
accepts these hydrologic inputs as a starting point for hydrologic 
modeling.   
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Figure 3–1.  Overview of GIS and hydrology programs. 

The following steps describe the major steps in starting a project and 
taking it through the GeoHMS process.   Below is an outline of Chapter 3. 
Contents 

• Data Processing 
• Data Collection 
• Data Assembly 

• Terrain Preprocessing 
• Hydrologic Processing 

• Basin Processing 
• Stream and Watershed Characteristics 
• HMS Model Files 

• Hydrologic Parameters and HEC-HMS 

Data Processing 

Data Collection 
With the volume of spatial data available, it is important to identify the 
data that will meet project needs.  Spatial data comes in many formats, 
resolutions, intended uses, quality, and prices.  Prior to collecting data, 
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the project specifications should be thoroughly reviewed for any 
recommendations.  When a project does not specify a particular data 
set, review the project’s goals and objectives to help define acceptable 
data in terms of data storage, resolution, and accuracy.  In addition, 
economic factors should be considered to determine the cost 
effectiveness in collecting and assembling the data or purchasing the 
data from a vendor.  Whether the data are collected or purchased, 
metadata must also be acquired to provide necessary documentation for 
the data.  Data collection is discussed in greater detail in Chapter 4. 

Data Assembly 
Data assembly often requires efforts of an experienced GIS user.  
Because GIS data have many forms and formats, users often need to 
convert the data into a common format and then into a common 
coordinate system.  For example, data describing the terrain should be 
in ESRI’s ARC Grid format while vector data, such as stream 
alignments and streamflow gage locations, should be in the shapefile 
format.  By having a common coordinate system, these data sets can be 
overlaid and spatial operations can be performed on them.  Often times, 
data sets are provided in rectangular portions.  When assembling data, 
especially terrain, special efforts are required to ensure that data are 
continuous along the edges.  Terrain data assembly is discussed in 
Chapter 5. 

Terrain Preprocessing 

Using the terrain data as input, the terrain preprocessing is a series of 
steps to derive the drainage networks.  The steps consist of computing 
the flow direction, flow accumulation, stream definition, watershed 
delineation, watershed polygon processing, stream processing, and 
watershed aggregation.  These steps can be done step by step or in a 
batch manner.  Once these data sets are developed, they are used in 
later steps for subbasin and stream delineation.  It is important to 
recognize that the watershed and stream delineation developed in the 
terrain preprocessing steps is preliminary.  In the next step - basin 
processing, the user has the capability to delineate and edit basins in 
accordance with project specifications.  Terrain preprocessing is 
performed in the MainView document and is discussed in greater detail 
in Chapter 6. 

The MainView document is generally responsible for terrain 
preprocessing and spatial database setup.  Figure 3–2, Table 3-1, Table 
3-2, and 
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Table 3-3 show the menus, buttons, and tools added by HEC-GeoHMS 
when the MainView document is active. 

Menus

Tools Buttons
 

Figure 3–2.  MainView GUI with GeoHMS extensions features. 

Table 3-1.  MainView Menus. 
Menus Descriptions 

 
 

 

The Terrain Preprocessing menu 
is used to modify, process, and 
analyze the terrain.  It has the 
capability of processing the terrain 
in two ways: step by step or batch 
processing.  It also has a data 
management capability for tracking 
data sets as they are derived. 
(Chapter 6) 

 

 

 
 

After the terrain has been processed, 
the HMS Project Setup menu is 
used to extract the processed terrain 
information from the MainView.  
The extracted information will be 
placed in a separate view called the 
ProjView.  There are several options 
for extraction of terrain information. 
(Chapter 6) 
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The Utility menu contains 
miscellaneous tools dealing with 
assigning roles for data sets and 
developing graphical output.  Most 
users should not use this menu 
except for the graphic generation in 
the last two menu items. 

 

Table 3-2.  MainView Buttons. 
Buttons Names Descriptions 

 Find Area Find a number of locations that have the 
closest, but not exceeding, drainage area 
to the user-specified area.  This tool 
provides many candidate points.  In order 
to narrow the number of candidate points, 
the tool should be used when zoomed into 
the area of interest. 

 

 
Toggle 

GeoHMS 
Toggle the HEC-GeoHMS tools ON/OFF. 
When it is in the ON position, HEC-
GeoHMS tools are enabled.  When it is in 
the OFF position, tools from other 
extensions are enabled. 

 

 
Help Access context sensitive online help on 

any tools or menus.  Select the tool and 
Press it on any tool for online help. 
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Table 3-3.  MainView Tools. 
Tools Names Descriptions 

 Flow Trace Trace the flow path downstream of a user-
specified point (for visualization 
purposes). 

 Point 
Delineate 

Delineate the watershed contributing to a 
user-specified point. 

 Identify 
Area 

Identify contributing area in units as 
specified in the View’s properties 
“distance unit” field. 

 Specify 
Project 
Point 

Specify the downstream outlet and/or 
upstream source point for extraction of 
terrain information. 

 Contour This is an ArcView tool that is useful in 
HEC-GeoHMS.  This tool draws contours 
at the user-specified point. 

Hydrologic Processing 

Hydrologic processing is performed in the ProjView document, which 
is generally responsible for hydrologic model construction and setup.  
The menus, buttons, and tools available in the ProjView GUI are shown 
in Figure 3–3, Table 3-4, Table 3-5, and Table 3-6.  Typically, the user 
proceeds from Basin Processing (Chapter 7) to Basin Characteristics 
(Chapter 8) to Hydrologic Parameters (Chapter 9) to HMS (Chapter 10) 
menus. 

 
 
 

  

Menus 

Tools Buttons 
 

Figure 3–3.  ProjView GUI with GeoHMS extensions features. 
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Table 3-4.  ProjView Menus. 

Menus Descriptions 

 

 

This menu provides the user with 
interactive and batch processing 
capabilities to modify existing 
subbasins and delineate new 
subbasins.  There are also several 
tools available for subdividing 
basins and preparing batch points 
for delineation. (Chapter 7) 

 

 

After the user finalizes the basin 
delineation, this menu develops 
the physical characteristics for 
both the streams and subbasins 
based on the terrain model.  The 
stream characteristics will be 
stored in the stream’s attribute 
table.  Similarly, the basin 
characteristics will be stored in the 
subbasin’s attribute table.  These 
two tables can be exported for 
external computations. (Chapter 8) 

 

 

This menu facilitates a process for 
the user to estimate a number of 
hydrologic parameters, such as 
loss rate parameters and time of 
concentration.  (Chapter 9) 
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This menu performs a number of 
tasks related to HMS.  These tasks 
include assigning default names 
for the reaches and subbasins, unit 
conversion, checking and creation 
of the basin schematic, and HMS 
files generation. (Chapter 10) 

 

 

Similar to the menu in the 
MainView, this menu has a few 
new menu items that have been 
added to work soil and landuse 
databases. (Appendix E) 

Table 3-5.  ProjView Buttons. 
Buttons Names Descriptions 

 Find Area Same as those in the MainView 

 

 Toggle 
GeoHMS 

Same as those in the MainView 

 

 
Table 3-6.  ProjView Tools. 

Tools Names Descriptions 

 Identify 
Area 

Same as those in the MainView 

 

 Flow Trace Same as those in the MainView 
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 Basin 
Subdivide 

Subdivide existing basin or create new 
basin at user-specified point 

 

 Profile Extract the stream profile with elevation 
based on the terrain model 

 

 Batch Point Create a batch point shapefiles layer based 
on the user-specified point 

 

 Profile 
Subdivide 

While the stream profile chart is opened, 
this tool allows the user to subdivide 
existing basin at user-specified point 
along the stream profile. 

Basin Processing 
In this step, the user is provided with a variety of interactive and batch-
mode tools to delineate subbasins.  In the interactive mode, the tools 
allow the user to see the delineation results, assess outcomes, and 
accept or deny the resulting delineation.  The interactive tools should 
work quickly.  For example, the user sees the result of the merger of 
smaller basins or subdivision of a larger basin.  When the user performs 
interactive basin processing, the program will prompt the user to 
confirm the results.  A number of other interactive tools allow the user 
to delineate a basin from a stream profile, subdivide a basin at a stream 
confluence, and create a basin where a stream does not exist.  In the 
batch mode, the user can supply the outlet locations and the program 
will delineate subbasins at those locations, but without interaction to 
view and revise.   

Basin processing is one of the 
responsibilities of the ProjView 
document and is discussed in greater 
detail in Chapter 7. 

 

Stream and Watershed Characteristics 
When the streams and subbasins delineation have been finalized, the 
user can extract their physical characteristics.  The stream physical 
characteristics, such as length, upstream and downstream elevations, 
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and slope, are extracted from the terrain data and stored as attributes in 
the stream table.  Similarly, subbasin physical characteristics, such as 
longest flow lengths, centroidal flow lengths, and slopes, are extracted 
from terrain data and stored as attributes in the watershed table.  The 
current version of the program focuses on the extraction of physical 
characteristics instead of hydrologic parameters.  Physical characteristic 
tables can be exported and used externally to estimate hydrologic 
parameters.  When more experience is gained with applying GIS 
generated parameters, it is anticipated that the program will suggest 
ranges for hydrologic parameters, as appropriate.   

Computing stream and watershed 
physical characteristics under the Basin 
Characteristics menu is another 
responsibility of the ProjView 
document and is discussed in greater 
detail in Chapter 8.   

Hydrologic Parameters 
In addition to extracting stream and subbasin physical characteristics, 
the user has the option to estimate initial values of various hydrologic 
parameters.  Hydrologic parameters, such as the curve number, can be 
extracted as lumped and grid-based quantities from the soil and landuse 
databases.  Other hydrologic parameters, such as time of concentration, 
are computed from various data sets including terrain and precipitation 
data. 

Estimating hydrologic parameters 
under the Hydrologic Parameters 
menu is another responsibility of the 
ProjView document and will be 
discussed in greater detail in Chapter 
9.   
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HEC-HMS Model Files 
GeoHMS produces four files that can be used directly with HMS.  If 
the lumped modeling approach is used, then the user can generate the 
background-map file and the lumped-basin file.  If the distributed 
modeling approach is used, then the user can generate the background-
map file, the grid-cell parameter file, and the distributed basin file.  

Generating HEC-HMS model files 
under the HMS menu is another 
responsibility of the ProjView 
document and is discussed in 
greater detail in Chapter 10.   

 
 

 

Hydrologic Parameters 
and HEC-HMS 

When the GeoHMS-generated files are brought into HMS, the user has 
a partially completed HMS model.  To complete the HMS basin model, 
hydrologic parameters need to be estimated and entered using editors 
provided in HMS.  In addition, the user can add or remove hydrologic 
elements and their connectivity to reflect difficult modeling areas.  
Finally, the user needs to develop a Meteorologic Component to 
represent the precipitation and a Control Specifications Component to 
define the time window and other time-related specifications.  With 
these three model components completed, the user can refer to the 
HMS manual to make a simulation run and calibrate the hydrologic 
model. 
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C H A P T E R  4   

Data Collection 

The purpose of this chapter is to illustrate some of the ways spatial data 
are used in hydrology.  By understanding how the data sets are utilized, 
the user can focus adequate time, effort, and attention on the 
appropriate data set.  When collecting data, the user can assess the 
quality of the data and its metadata and insure that they meet project 
specifications.  This chapter also provides a list of data types, 
descriptions, and possible sources as a starting point for collecting data.  
Below is an outline of Chapter 4. 

 
Contents 

• Data Usage 
• Data Types, Descriptions, and Sources 

Data Usage 

Spatial data are collected and used in a variety of ways.  Understanding 
how data are used provides many important guidelines in data 
collection.  When the data are intended as input in the program, they 
should be collected with attention given to accuracy, resolution, validity 
of data source, and quality of documentation.  Oftentimes when the best 
available data are not adequate, the appropriate course of action will be 
to develop data that meets project specifications instead of putting 
efforts in collecting “bad” data.  Terrain data is critical because 
GeoHMS uses it to determine drainage paths and physical 
characteristics.  Other data often serve many useful roles, such as 
reference information, documentation, and visualization.   
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Reference Information for Results Validation  
Reference data depicting known stream alignments, stream flow gage 
locations, and drainage boundaries are very helpful for comparing and 
validating the GIS delineated streams and subbasins.   

Documentation of Field Conditions 
GIS data can be collected and used with existing spatial data to 
document field conditions.  For example, photographs of drainage 
structures as shown in Figure 4–1, and other field conditions can be 
photographed and geographically located with the street data to more 
effectively document these facilities and show their spatial 
relationships.   

 
Figure 4–1.  Field documentation with photographs. 

Data Visualization 
GIS data can be used to visualize multiple data sets.  For example, 
aerial images can be overlaid with subbasin boundaries to see land use 
patterns and variability.  

Data Types, Descriptions, and Sources 

The amount of GIS data available through government institutions and 
data vendors has grown greatly over the years.  Some of these data are 
available for free while others are provided for a fee.  Table 4-1 
provides a starting point for collecting and searching for GIS data.  The 
list provides brief descriptions of the data used in hydrology and their 
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sources.  Additional information on the data sets can generally be found 
at the respective institution’s web site.  Although terrain data is the 
minimum data requirement to run HEC-GeoHMS, the other data sets 
are important information for constructing the hydrologic model.  It is 
important to collect data for an area larger than your actual project 
region.  Finally, metadata must also be collected for documentation. 

 

Table 4-1.  Data Types, Descriptions, and Sources. 
Digital Elevation Model (DEM)  
DEMs are originally generated from USGS maps and are available 
for resolutions ranging from meters to kilometer cell size.  The 
availability of the finer DEM data may be scarce at this time.  The 
DEM at 30-by-30-meter resolution is generally used for modeling 
terrain because of their widespread availability. 

The most convenient source of seemless DEM data is the USGS’s 
National Elevation Dataset (NED). 

 

Source 

http://gisdata.usgs.net/ned/default.asp 

www.usgs.gov 

www.water.usgs.gov 

 

Hydrologic Unit Code (HUC) 
The HUC contains the major watershed boundaries as published by 
the USGS.  The HUC shows watershed boundaries at 4 levels of 
detail ranging from local to regional drainage area. 

 

Source 

www.usgs.gov 

Digital Line Graph (DLG) 
In addition to line representation of transportation data, such as 
streets and railroads, DLGs include water features, such as stream 
networks and irrigation ditches.  DLGs are maintained by the United 
States Geological Survey (USGS).   

 

Source 

www.usgs.gov 
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Stream Networks 
Stream networks are maintained by the Environmental Protection 
Agency (EPA).  Many versions of stream networks are available as 
the River Reach File (RF1), the River Reach File (RF3), and the 
National Hydrography Data set (NHD). 

 

Source 

www.epa.com 

http://nhd.usgs.gov 

 

Streamflow Gage Data  

Although streamflow gage data are natively non-spatial, the latitude 
and longitude coordinates of the gage are provided most of time.  
The streamflow gage locations can be converted into a GIS data set 
by using the coordinate information.  The majority of streamflow 
gages are maintained by the USGS, state governments, and flood 
control districts. 

 

The stream gages maintained by the USGS are organized by major 
basin names and the Hydrologic Unit Code.  These gages often 
provide the historical daily peak flow values and/or annual peak 
flow values. 

 

Source 

www.usgs.gov 

 

Digital Orthophoto Quarter Quads (DOQQ)  

Digital aerial photos with colors are available at various resolutions 
can be used as a background base map. 

 

Source 

Various governmental authorities and commercial vendors 
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Drainage Facilities Photographs  
Photographs can be taken of key drainage structures.  The 
photographs often include the areas looking upstream and 
downstream of the structures as well as the faces of the structures. 

 

Source 

Field observations conducted by the engineers. 

 

Street Data 
Street level data that is provided by the US Census Bureau often 
needs format conversion before it can be accessed though GIS 
software.  A number of data vendors have performed the format 
conversion as well as other value-added improvements. 

 

Source 

United States Census Bureau and commercial vendors 

 

Soil Types Data  
The Soil Surveys Geographic Data Base (SSURGO) data contains 
good detail, but is limited in coverage.  The State Soil Geographic 
Data Base (STATSGO) covers the entire USA, but in less detail. 

 

Source 

United States Department of Agriculture STATSGO and SSURGO 
CD- ROM 

http://www.ftw.nrcs.usda.gov/stat_data.html 

http://www.ftw.nrcs.usda.gov/ssur_data.html 

Land Use/Land Cover  

The USGS Land Use Land Cover (LULC) provides good coverage 
but may be dated. 

 

Source 

http://mapping.usgs.gov 

http://edc.usgs.gov 
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C H A P T E R  5   

Data Assembly  

The assembly of GIS data sets often requires conversion of file formats 
and coordinate systems, as well as geographical referencing of non-
spatial data sets.  For vector data, the industry-standard shapefile format 
is preferred when working with ArcView.  Examples of vector data that 
require conversions are Digital Line Graphs for stream alignments and 
State Soil Geographic Data Base (STATSGO) data for the hydrologic 
soil types.  For raster data, ESRI’s ARC Grid format should be used.  
Examples of raster data that require conversions are the terrain and 
radar rainfall data.  In addition to file formatting, data assembly often 
requires a number of map related transformations to ensure that vector 
and raster data are in proper alignment and map distortions are 
minimized.  That is, they have the same datum, projection, and 
common coordinate system.  These data sets can be overlaid for spatial 
analysis.  In essence, a spot on the various data sets refers to the same 
point on the ground in all data sets.  Some common map-related 
transformations are as follows. 

 
• Projection 
• Coordinate System  
• Vertical and Horizontal Datum 
• Units 
• Resolution 
• Accuracy 
• Scales 

When data are assembled with GIS software, the user should be aware 
of the distinctions between various spatial operations.  For example, 
when the user joins various sized terrain tiles into a continuous terrain 
model, the ArcInfo grid “merge” and/or “mosaic” commands produce 
different results.  The “merge” command will overwrite overlapping 
areas along the edges with the data that is merged last.  However, the 
“mosaic” command will perform smoothing of data values along the 
overlapping areas.  Recognizing the different approaches for combining 
terrain is crucial to prevent abrupt artificial changes in elevation along 
the edges of tiles that will affect drainage path determination.  Other 
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data assembly issues include combining various data sets of different 
resolution, filling data gaps as shown in Figure 5–1, and data re-
sampling techniques.   Below is an outline of Chapter 5. 

Data Gap
Data Gap

Data Gap

 
Figure 5–1.  DEM model with data gaps.  

Contents 

• Terrain Data Assembly 
• “Hydrologically Corrected” and “Depressionless” Terrain Model 
• Data Issues 
• Hydrologic Coordinate System Specifications  

Terrain Data Assembly 

The growth and availability in seemless terrain data in recent years has 
provided users with better quality data and minimized the need to 
manually assemble terrain data from small tiles of data.  The seemless 
terrain data are available in larger potions than the tile data.  Also, the 
seemless data has been edge-matched and contain the same coordinate 
system, datum, and units.  However, in some cases where manual 
assembly of terrain data is required, the user should be aware of many 
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important issues related to the data age, units, coordinate system, 
datum, etc.  Ultimately, the quality of the results depends heavily on the 
terrain data.  Traditionally, continuous terrain data was assembled 
manually from joining tiles of terrain information as shown in Figure 
5–2.  Then, data gaps were filled in with interpolated elevation values 
from neighboring elevation values to make a continuous DEM model as 
shown in Figure 5–3.  However, when terrain data were assembled in 
this manner, they often contained errors and areas that were 
problematic for computing drainage patterns from a hydrologic 
standpoint.  Often, terrain data undergoes extensive editing to correct 
problematic areas.  Automated routines are available to fill depressions 
in the DEM.  The “depressionless” DEM may still not have streams 
located properly when compared to other map and photo resources.  
Extensive editing is usually required to create a “hydrologically 
corrected or conditioned” DEM.  There are many issues surrounding 
terrain data assembly as discussed below. 

 
Figure 5–2.  DEM tile quad names. 
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Figure 5–3.  Continuous DEM. 

 

“Hydrologically Corrected” and “Depressionless” Terrain 
Model 

The preparation of  “hydrologically corrected” terrain data often 
requires much iteration through drainage path computations.  To 
represent the movement of water through the watershed, the 
“hydrologically corrected” DEM must have the proper accuracy and 
resolution to capture details of the stream alignments and watershed 
divides.  The problems often arise when the watershed has low relief 
and the resolution is not fine enough to delineate the needed details.  

Construction of a “hydrologically corrected” terrain model involves 
more complexity than combining tiled USGS’s DEMs into a unified 
DEM grid.  The DEM assembled from the USGS represented by 
elevation averages at regular intervals may not accurately represent 
stream locations and watershed boundaries.  For example, stream and 
watershed delineation sometimes does not coincide with published data 
sources like the EPA’s RF1 and the USGS’s watershed in the 
Hydrologic Unit Code (HUC).  A “hydrologically corrected” terrain 
model must represent accurate stream patterns across the landscape, 
stream alignments, topographic ridges, stream confluences, internal 
drainage areas, and drainage facilities.  Many factors, such as cell 
resolution, accuracy, topographic relief, and drainage facilities deserve 
careful consideration because they often affect the quality of the terrain 
model.  In theory, combining GIS data sets of different resolutions is 
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generally not recommended because of the difficulty in assessing the 
accuracy and the precision of the resulting data set.  In practice, 
however, combining data sets of various resolutions is necessary due to 
lack of uniform data and data coverage.   

In contrast to the effort required for the “hydrologically corrected” 
DEM, the “depressionless” DEM is simply constructed using 
automated algorithms to fill in the sinks or depressions in the assembled 
DEM.  In a “depressionless” DEM, all area is contributing to the most 
downstream outlet and therefore does not address closed basins or 
substantial non-contributing areas.  Because of the complexity and 
effort required for constructing a “hydrologically corrected” terrain 
model, a “depressionless” terrain model often serves as a simpler 
substitute in the analysis.  For study regions with moderate to high 
topographic relief, the “depressionless” terrain model may be adequate 
for the analysis.  For low-relief regions, however, the “depressionless” 
terrain model often needs additional work to adequately represent the 
terrain.  For example, a watershed with flat terrain often requires 
editing to force proper drainage location. 

Until better data quality and editing techniques are available, users may 
struggle with terrain data assembly.  It is important to identify the 
issues with the data so that the user can understand and fixes the 
problems.  As an encouraging note, many governmental institutions, 
including the USGS and the EPA, are working to develop seamless 
terrain information and streams and watersheds information, which will 
ease the data assembly efforts. 

Data Issues 

A number of issues have been identified to increase awareness as a first 
step in formulating a solution.  When assembling terrain data, the user 
should address the considerations shown in Table 5-1. 
Table 5-1.  Data Issues 

Data Issues Descriptions and Potential Solutions 

1.  Low-relief terrain With low-relief terrain, it is often difficult 
to delineate reliable drainage paths from 
relative average elevations.  Finer 
resolution terrain data should be 
considered for the flat region if it is 
available.  However, finer resolution data 
has its tradeoffs with increased storage 
and longer computation times.  Other 
possible approaches include imposing the 
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published stream alignment onto the 
terrain. 

 

2.  Man-made 
structures 

Man-made structures like dams often alter 
the flow direction because the water 
surface prevents the mapping of the 
reservoir bottom.  In addition, when the 
terrain data get filled, the terrain is 
represented as a flat surface behind the 
dam.  A potential way to deal with this 
situation would be to put an artificial 
notch at the dam and carve a stream on to 
the terrain. 

 

3.  Missing elevation 
data 

Missing elevation data often exist along 
the edges and can be filled with 
interpolated values from neighboring 
elevations.  Bad elevation data due to re-
sampling effects and other causes can be 
fixed with spot elevation editing on a cell 
by cell basis or by region. 

  

4.  Subsidence and 
other Environmental 
Impacts 

The ground surface may subside due to 
overdraft of groundwater.  Recognizing 
when the terrain data were developed, the 
terrain data should be checked for 
subsidence. 

 

5.  Subsurface Flow Volcanic soils, limestone formations, and 
canals/tunnels lead to drainage patterns 
that the terrain cannot reproduce.  These 
difficult features must be handled in 
GeoHMS by delineating the subbasin 
downstream of the feature to avoid the 
problem areas or modifying the terrain to 
impose the correct drainage patterns. 

 Hydrologic Coordinate System Specifications 
 

Transforming spatial data into a common coordinate system ensures 
proper alignment of various data sets for spatial analysis.  Coordinate 
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system transformation often leads to map distortions of direction, 
distance, shape, and area.  From a hydrologic perspective where the 
terrain and precipitation are important, a suitable coordinate system 
should preserve area.  The two possible coordinate systems are the 
Standard Hydrologic Grid (SHG) and the Hydrologic Rainfall Analysis 
Project (HRAP).  The SHG is based on the Albers Equal Area 
projection, which preserves area.  The SHG coordinate system is 
defined in Table 5-2.  More information on both coordinate systems is 
in Appendix D. 
 
Table 5-2.  Standard Hydrologic Grid Definition 
Projection: Albers Equal-Area 

Spheroid: GRS1980 

Datum: North American Datum, 1983 (NAD83) 

Central Meridian: 96 degrees 0 minutes 0 seconds West 

Latitude of Origin: 23 degrees 0 minutes 0 seconds North 

1st Standard Parallel: 29 degrees 30 minutes 0 seconds North 

2nd Standard Parallel: 45 degrees 30 minutes 0 seconds North 

False Easting: 0.0 

False Northing: 0.0 

Units: Meters 

 

Terrain Data Coordinate System and Projection Support 
 

In HEC-GeoHMS version 1.1, users are allowed to analyze terrain data 
in a number of coordinate systems and projections, including Albers-
Equal Area, Universal Transverse Mercator (UTM), Tranverse 
Mercator, Lambert, and the State Plane Coordinate System.   The user 
should always verify that the projection file (prj.adf) exists and is saved 
as part of the terrain grid data.  When the user wants to create a 
ModClark grid cell parameter file, the program will need this projection 
file. 
The Earth is represented as a spheroid.  For spheroid definition in the 
projection file, the units are assumed to be in meters.  If the units are 
not meters, then FEET are the only other valid option and should be 
specified in the projection file with an explicit UNITS = FEET entry.  
The following spheroids are supported: 

 GRS1980 
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 WGS84 

 WGS72 

 SPHERE 

 CLARKE1880 

 CLARKE1866 

 KRASOVSKY 

 INT1909 

 EVEREST 

 BESSEL 

 AUSTRALIAN 

 AIRY 

 

 



 
Chapter 6 Terrain Preprocessing 

39 

C H A P T E R  6   

Terrain Preprocessing 

Refering to the overview in Chapter 3, terrain preprocessing marks the 
first step to using HEC-GeoHMS.  In this step, a terrain model is used as 
an input to derive eight additional data sets that collectively describe the 
drainage patterns of the watershed and allows for stream and subbasin 
delineation.  The first five data sets in grid representation are the flow 
direction, flow accumulation, stream definition, stream segmentation, and 
watershed delineation.  The next two data sets are the vectorized 
representation of the watersheds and streams, and they are the watershed 
polygons and the stream segments.  The last data set, the aggregated 
watersheds, is used primarily to improve the performance in watershed 
delineation.  Terrain preprocessing is performed in the MainView. 

The objectives of terrain preprocessing ar: 
• Terrain is processed and analyzed using the 8-pour point approach to 

determine flow paths.  Terrain analysis is computer intensive and 
some steps may require several hours, depending on the amount of 
data and computer resources. 

• After terrain preprocessing is completed, the resulting data sets serve 
as a spatial database for the study.  With the information centralized 
in the spatial database, pertinent data sets can be extracted for 
subsequent work on building the hydrologic models.   

• Preliminary watershed and stream delineation provides results that 
can be verified with published information to detect possible errors in 
the terrain model.  If errors are detected in the terrain model, the 
DEM should be edited outside of GeoHMS.  When the DEM has 
been revised to better represent field conditions, it should be 
processed again to update the spatial database. 

This chapter will discuss terrain preprocessing features and functionality, 
HMS model setup, and related utilities.  Below is an outline of Chapter 6. 
 
Contents 
• Features and Functionality 
• Data Management 
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Features and Functionality 

The HEC-GeoHMS extension adds features and functionality to the 
standard ArcView program (Terrain Preprocessing, HMS Project 
Setup, and Utility), buttons, and tools are added to the standard 
ArcView GUI as shown in Figure 6–1.  A number of capabilities 
related to terrain processing are under the Terrain Preprocessing 
menu.  Once the terrain processing is complete, data can be extracted to 
support hydrologic model creation via the HMS Model Setup menu.  
The Utility menu allows users to perform some limited administrative 
tasks in assigning or changing a theme, which is to be identified and 
used by the program.  Each theme will be assigned a unique name or 
“tag” by which it will be known to the program.  The tags are names 
associated with themes that identify the role of the theme in the 
program.  Buttons perform tasks after they are activated, tools execute 
the task after they are activated and the user applies an action.  

Menus

Tools Buttons
 

Figure 6–1.  MainView GUI with GeoHMS extensions features. 

Data Management 
Data that are introduced or derived with the GeoHMS extension are 
managed through role association.  For example, when a DEM is 
introduced, GeoHMS will associate it with “RawDEM”, which is the 
original DEM.  When a Fill command is issued, the program will 
automatically offer the RawDEM as default for creating a 
depressionless DEM.  Aside from associating data sets with their 
intended roles as they are created, data management allows the user the 
ability to bring in other data sets and assign a role to them.  For 
example, if the user has developed the flow direction and accumulation 
grid in another program, they can bring these data in as themes and 
assign their roles.  This is a good way to keep track of data as they are 
generated.  Another example are the flow tracing and area tools; 
GeoHMS knows which data layer should be operated on to provide the 
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results.  Figure 6–2 shows the data management of themes on the left-
hand side and the assigned themes on the right-hand side.  The “Null” 
entry for the assigned theme indicates that the appropriate theme has 
not been created and assigned.  When the appropriate themes are 
created, their names replace the “Null” entry as shown in Figure 6–3. 

 
Figure 6–2.  Data Management window. 
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Figure 6–3.  Data management with assigned themes. 

Terrain Reconditioning 
Many users in the past have used the simple “burning in” techniques to 
force a stream network on the DEM.  This simple “burning in” 
technique allows the user to abruptly lower only the stream cell 
elevation by a fixed amount.  Similar to the simple “burning in” 
technique, the new Terrain Reconditioning method, located under the 
Terrain Preprocessing menu, allows the user to lower the elevation of 
the stream cell and also provides an option to gradually lower the 
neighboring cells along the stream.  This method creates a gradual 
transition from the overbank to the stream centerline in the DEM for 
water to enter the stream.   

In many cases where the stream cells in the DEM and the stream vector 
line are not aligned, this method can be used to eliminate the 
undesirable side effects of fictitious islands near the stream centerline 
and parallel streams as shown in Figure 6–4. 
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        Figure 6–4.  Cross-section views of simple burning-in (top) and reconditioned DEM (bottom). 

The Terrain Reconditioning menu modifies terrain by imposing line 
features on a grid by lowering (“burning”) and raising (“fencing”) grid 
cell elevation along the line feature.   This function requires two inputs, 
a grid and a line theme as shown in Figure 6-5, which must be present 
in the MainView to be accessible from the dropdown menu.  The 
function outputs a reconditioned grid.   

Modified
TerrainTerrain 

Stream Stream 

Fictitious 
Island 

Parallel 
Streams 

Before After 

Modified
TerrainTerrain 

Stream Stream 

Removed 

Before After

Buffer

Simple Burn-in 
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The original AGREE method was developed with Arc/Info by Ferdi 
Hellweger at the University of Texas at Austin in 1997.  For a full 
reference to the procedure refer to the web link: 
http://www.ce.utexas.edu/prof/maidment/GISHYDRO/ferdi/research/ag
ree/agree.html.  This implementation of the AGREE method in HEC-
GeoHMS is in the ArcView 3.x platform. 

In addition, HEC is working on releasing an interactive tool in ArcGIS 
8.x platform for reconditioning and editing the DEM.   Further 
information is available in the Appendix H under the frequently asked 
question #8. 

 

 

 
Figure 6–5.  DEM reconditioning data requirements. 

After initiating the function, the user needs to enter three reconditioning 
parameters as shown in Figure 6-6: 

• Vector buffer (cells) – this is the number of cells around the vector line 
theme for which the smoothing will occur. 

• Smooth drop/raise – this is the amount (in vertical units) that the river 
will be dropped if the number is positive or the fence will be extruded if 
the number is negative.  This value will be used to interpolate the DEM 
into the buffered area between the boundary of the buffer and the 
dropped/raised vector feature.  

• Sharp drop/raise – this is the additional amount (in vertical units) that 
the river will be dropped if the number is positive or the fence will be 
extruded if the number is negative.  This amount of additional 
burning/fencing will be on top of the smooth buffer interpolation.  
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Figure 6–6. DEM reconditioning parameters. 

For best results, users will often need to make iterative and multiple 
passes through this burning/fencing process.  After the reconditioned 
DEM is obtained, users should perform the Fill Sinks menu to remove 
potential sinks generated from the reconditioning process.  Use the 
filled reconditioned DEM to determine flow direction and flow 
accumulation.  Prior to creating the ProjView, where basin 
characteristics will be extracted, use the dropdown menu to change the 
"HydroDEM" to the original DEM that was not modified by the 
reconditioning process to ensure that the correct elevations are 
extracted for slope calculations. 

Terrain Preprocessing 
By applying the GIS algorithms discussed below, the terrain can be 
processed in two ways: step-by-step or batch processing.  With the 
step-by-step approach illustrated below, data sets are derived after each 
operation.  Greater control over the results is obtained because the user 
verifies the results and makes decisions before proceeding.  For 
example, prior to performing the stream definition, it is good practice to 
use the Identify Area tool and check the contributing area at several 
locations.  This information on the area can help pick a threshold for 
adequate stream definition.  In batch mode, all of the inputs like the 
threshold are entered up front, and then the program generates all of the 
data sets.  In a few instances, the batch mode may pause and prompt for 
more input to complete the terrain process.  For example, if there are 
too many outlets, the program will prompt for input to determine 
whether stream segments serve as an outlet.  When using the batch 
mode, there are some safeguards for changing the threshold to vary the 
detail of the stream definition.  After batch processing is complete, the 
user can use the Identify Area tool to estimate a good threshold and 
then specify that threshold when setting up a hydrologic model. 

GIS Approach 
GIS approaches toward hydrologic analysis require a terrain model that 
is “hydrologically corrected”.  A “depressionless” terrain model is used 
in the analysis. The GIS analyzes the “depressionless” terrain model by 
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applying the 8-point pour model, where water flows across the 
landscape from cell to cell based on the direction of the greatest 
elevation gradient.  The process of analyzing the landscape 
characteristics and slopes for stream networks and subbasin boundaries 
is presented in Table 10.  Steps in the analysis include filling 
depressions or pits, calculating flow direction and flow accumulation, 
delineating streams with an accumulation threshold, defining streams, 
segmenting streams, delineating watersheds, processing watershed 
polygons, processing streams, and aggregating watersheds. 

Depressionless DEM 
The depressionless DEM is created by filling the depressions or pits by 
increasing the elevation of the pit cells to the level of the surrounding 
terrain in order to determine flow directions.  The pits are often 
considered as errors in the DEM due to re-sampling and interpolating 
the grid.  For example, in a group of three-by-three cells, if the center 
cell has the lowest elevation compared to its eight neighboring cells, 
then the center cell’s elevation will be increased equaling the next 
lowest cell.  Filling the depressions allows water to flow across the 
landscape.  This assumption is generally valid when a large event storm 
fills up the small depressions and any incremental amount of water that 
flows into the depression will displace the same amount of water from 
the depression. 

The steps to fill the depressions are shown below. 
• Add the unfilled DEM into the MainView using the Add Theme 

button, see Figure 6–7.   

 
Figure 6–7.  Depressionless DEM. 
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• Select Terrain Preprocessing ⇒ Fill Sinks when a “MainView” 
document is active. 

• Confirm that the input of the RawDEM (also referred to as the 
unfilled DEM) is “Amer_meters”.  The output of the HydroDEM is 
“FillGrid”, see Figure 6–8.  “FillGrid” is a default name that can be 
edited by the user.  

• Press OK 

 
Figure 6–8.  Fill Sinks operation. 

The result of the Fill Sinks operation is the “Fillgrid” theme, as shown 
in Figure 6–9, where the lowest cell elevation is increased from 320.7 
meters to 324.2 meters.  

 
Figure 6–9.  Fill Sinks operation result. 
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Step-by-Step Process 
When performing this procedure, the user needs to bring in a 
“hydrologically corrected” or the “depresssionless” DEM from the 
previous step.  With the step-by-step approach, each step starts with 
offering a list of inputs that will be used to produce the output grid.  If 
the step-by-step procedure is performed in a sequential order, the 
program will be able to offer the correct data input for processing.  In a 
few instances, when certain steps are repeated or performed out of 
order, it would be important to verify that the appropriate data sets are 
used.   
 
Flow Direction.  This step defines the direction of the steepest 
descent for each terrain cell.  Similar to a compass, the eight-point pour 
algorithm specifies the following eight possible directions:  

 

1 = east, 2= southeast,  

4 = south, 8 = southwest,  

16= west, 32=northwest,  

64 = north, 128=northeast. 
 

The steps to compute flow directions are shown below. 
• Select Terrain Preprocessing ⇒ Flow Direction. 
• Confirm that the input of the HydroDEM is “fillgrid”.  The output 

of the FlowDirGrid is “FDirGrid”, as shown in Figure 6–10.  
“FDirGrid” is a default name that can be edited by the user. 

• Press OK 

 
Figure 6–10.  Flow Direction operation. 

The result of the Flow Direction operation is the “FdirGrid” as shown 
in Figure 6–11. 
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Figure 6–11.  Flow Direction operation result. 

 
Flow Accumulation. This step determines the number of upstream 
cells draining to a given cell.  Upstream drainage area at a given cell 
can be calculated by multiplying the flow accumulation value by the 
cell area. 

The steps to compute flow accumulation are shown below. 
• Select Terrain Preprocessing ⇒ Flow Accumulation.  
• Confirm that the input of the FlowDirGrid is “fdirgrid”.  The output 

of the FlowAccGrid is “FAccGrid”, as shown in Figure 6–12.  
“FAccGrid” is a default name that can be edited by the user. 

• Press OK 

 
Figure 6–12.  Flow Accumulation operation. 

The result of the Flow Accumulation operation is the “faccGrid”, as 
shown in Figure 6–13. 
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Figure 6–13.  Flow Accumulation operation result. 

 
Stream Definition.  This step classifies all cells with flow 
accumulation greater than the user-defined threshold as cells belonging 
to the stream network.  Typically, cells with high flow accumulation, 
greater than a user-defined threshold value, are considered part of a 
stream network. The user-specified threshold may be specified as an 
area in distance units squared, e.g., square miles, or as a number of 
cells.  The flow accumulation for a particular cell must exceed the user-
defined threshold for a stream to be initiated.  The default is one 
percent (1%) of the largest drainage area in the entire basin.  The 
smaller the threshold chosen, the greater the number of subbasins 
delineated by Geo-HMS. 

The steps to compute stream definition are shown below. 
• Select View ⇒ Properties; this opens the properties dialog shown 

in Figure 6–14. 
• “Map Units” are the units in which the GIS themes are projected.  

In this example, the horizontal unit of the DEM is measured in 
meters.  Specify the Map Units as meters from the dropdown 
menu. 

• “Distance Units” are the reporting units in ArcView.  In this 
example, “Distance Units” are chosen as miles so that the 
information generated from ArcView can be compared with the 
stream flow gage drainage area reported in square miles.  Specify 
the Distance Units as miles from the dropdown menu. 

• Press OK and then save the project. 
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Figure 6–14.  View Properties window. 

• Select Terrain Preprocessing ⇒ Stream Definition.  
• Confirm that the input of the FlowAccGrid is “faccGrid”.  The 

output of the StreamGrid is “StrGrid”, see Figure 6–15.  “StrGrid” 
is a default name that can be edited by the user. 

• Press OK 

 
Figure 6–15.  Stream definition operation. 

• The threshold types available under the dropdown menu are “Area 
in Distance Units squared”, or “Number of Cells” as shown in 
Figure 6–16. 

• Select Area in Distance Units squared. 
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Figure 6–16.  Stream threshold definition types. 

• Enter the threshold as “5” square miles, as shown in Figure 6–17.  
Press OK. 

 
Figure 6–17.  Stream threshold entry window. 

The result of the Stream Definition operation is the “strgrid”as shown 
in Figure 6–18. 

 
Figure 6–18.  Stream definition operation result. 

 
Stream Segmentation.  This step divides the stream into segments.  
Stream segments or links are the sections of a stream that connect two 
successive junctions, a junction and an outlet, or a junction and the 
drainage divide. 

The steps to compute flow segmentation are shown below. 
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• Select Terrain Preprocessing ⇒ Stream Segmentation. 
• Confirm that the input of the FlowDirGrid is “fdirgrid” and 

StreamGrid is “strgrid”.  The output of the LinkGrid is 
“StrLnkGrid”, see Figure 6–19.  “StrLnkGrid” is a default name 
that can be edited by the user. 

• Press OK 

 
Figure 6–19.  Stream Segmentation operation. 

 

The stream segmentation operation results in 13 stream segments as 
shown in the “strlnkgrid” theme in Figure 6–20.   

 
Figure 6–20.  Stream Segmentation operation result. 

 
Watershed Delineation.  This step delineates a subbasin or 
watershed for every stream segment. 
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The steps to delineate watersheds are shown below. 
• Select Terrain Preprocessing ⇒ Watershed Delineation. 
• Confirm that the input of the FlowDirGrid is “fdirgrid” and 

LinkGrid is “strlnkgrid”.  The output of the WaterGrid is 
“WShedGrid”, see Figure 6–21.  “WShedGrid” is a default name 
that can be edited by the user. 

• Press OK 

 
Figure 6–21.  Watershed Delineation operation. 

The watershed delineation operation results in 13 subbasins as shown in 
the “wshedgrid” theme in Figure 6–22.   

 
Figure 6–22.  Watershed Delineation operation result. 

 
Watershed Polygon Processing.  This step converts subbasins in 
the grid representation into a vector representation. 
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The steps to vectorize a grid-based watershed are shown below. 
• Select Terrain Preprocessing ⇒ Watershed Polygon Processing. 
• Confirm that the input of the WaterGrid is “wshedgrid” and the 

output of the Watershed is “Wshedshp.Shp”, see Figure 6–23.  
“Wshedshp.Shp” is a default name that can be edited by the user. 

• Press OK 

 
Figure 6–23.  Watershed Polygon Processing operation. 

The watershed polygon processing operation vectorized the grid-based 
subbasin into polygon vectors as shown in the “Wshedshp.Shp” theme 
in Figure 6–24.   

 
Figure 6–24.  Watershed Polygon Processing operation result. 

 
Stream Segment Processing.  This step converts streams in the 
grid representation into a vector representation. 

The steps to vectorize stream segments are shown below. 
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• Select Terrain Preprocessing ⇒ Stream Segment Processing. 
• Confirm that the input of the LinkGrid is “strlnkgrid” and 

FlowDirGrid is “fdirgrid”.  The output of the River is “River”, see 
Figure 6–25. “River” is a default name that can be edited by the 
user. 

• Press OK 

 
Figure 6–25.  Stream Segment processing operation. 

The stream processing operation vectorized the grid-based streams into 
line vectors as shown in the “River.shp” theme in Figure 6–26.   

 
Figure 6–26.  Stream Segment processing operation result. 

 
Watershed Aggregation.  This step aggregates the upstream 
subbasins at every stream confluence.  This is a required step and is 
performed to improve computational performance for interactively 
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delineating subbasins and to enhance data extraction.  This step does 
not have any hydrologic significance. 

The steps to aggregate watersheds are shown below. 
• Select Terrain Preprocessing ⇒ Watershed Aggregation. 
• Confirm that the input of the River is “River.shp” and Watershed is 

“Wshedshp.Shp”.  The output of the AggregatedWatershed is 
“WshedMg.shp”, a default name that can be edited by the user, see 
Figure 6–27. 

• Press OK 

 
Figure 6–27.  Watershed Aggregation operation. 

The watershed aggregation operation results are shown in the 
“wshedmg.shp” theme in Figure 6–28.   

 
Figure 6–28.  Watershed Aggregation operation result. 
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Full Processing Setup 
When terrain processing is performed in batch mode, Full Processing 
Setup is used under the Terrain Preprocessing menu.  The inputs are 
specified prior to processing, and a list of default names is presented.  
The full delineation accepts the depressionless DEM and derived 
drainage data sets.  Therefore, the DEM must be filled first to prepare 
for full delineation setup.  The inputs to the batch processing include 
the stream threshold for stream initiation. 

The steps to perform full preprocessing are shown below. 
• To preserve the content of MainView1, create another view called 

MainView2. 
• Select MainView on the project window, and press New 
• Add the “Amer_meters” DEM. 
• Perform Fill Sinks and name the filled DEM as “Fillgrid2”. 
• Select the Terrain Preprocessing ⇒ Full Preprocessing Setup. 

The default names are shown in Figure 6–29.  These default names 
need to be changed to avoid naming conflicts with the MainView1. 

 
Figure 6–29.  Full preprocessing setup with default theme names. 

• From the HydroDEM dropdown menu, select the fillgrid2.   
• Rename the default names by adding a “2” behind the default 

names as shown in Figure 6–30. 
• Press OK 
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Figure 6–30.  Full preprocessing setup with revised theme names. 

• Enter the threshold to initiate a stream in terms of a percentage of 
the largest drainage area.  In batch processing, the threshold must be 
defined as a percentage of the largest drainage area. 

• Enter “1” to initiate the stream at 1%. 

 

The full preprocessing operation creates the eight themes shown in 
Figure 6–31.   
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Figure 6–31.  Full preprocessing setup results. 

Data Exploration with Buttons and Tools 
This section discusses the buttons and tools that the user may need to 
explore and derive data.  The buttons and tools allow the user to find 
the drainage area at a point or find the point that has a specified 
drainage area.  The tools also allow the user to draw a flow path from a 
specified point and delineate the area tributary to a point.  This 
functionality allows the user to compare the GIS results with published 
results.  In the following example, a streamflow gage with specified 
drainage area will serve as the published data source. 

• Add the theme “gage.shp” with the  (Add Theme) button.  
There are four gages in this data set as displayed in Figure 6–32. 

 



 
Chapter 6 Terrain Preprocessing 

61 

Most Downstream
Gage: 26 sq mi

Zoom to
this box

 
Figure 6–32.  Gage locations. 

• Zoom in to the region of the most downstream gage whose reported 
drainage area is 26 square miles (sq mi). 

 

The descriptions and procedures for using available buttons are 
explained in Table 6-1. 
Table 6-1.  MainView button descriptions and procedures. 

Button Descriptions and Procedures 

 
Find Area 

Description 

This button allows the user to find possible locations 
on each stream that have the closest, but not 
exceeding, drainage area to a user-specified area.  This 
tool provides many candidate points, with some points 
containing much smaller areas than the target area.  In 
order to narrow the number of candidate points, the 
tool should be used when the user zooms to the area of 
interest. 

 

Procedure 

In this case, the downstream gage is close to three 
streams.  The user knows that the downstream gage 

drains 26 sq mi.  Using the  (Find Area) button, the 
user searches within the zoomed-in region for the 
locations along the streams where the area does not 
exceed the specified 26 sq mi.  With this information, 
the user can define the watershed of interest. 
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Select the threshold type and press OK.  

Enter the Area as “26”. 

 

The results of the search provide two possible points 

that do not exceed the specified area.  Using the  
(Identify Area) tool, the user finds that one possible 
point drains about 10 sq. miles while the other point 
drains about 26 sq mi.  From this analysis, the user 
understands that the downstream stream gage does not 
belong on the stream with 10 sq mi of drainage area or 
on the stream below the confluence.  The applicable 
location of the downstream gage is on the stream with 
the 26 sq mi drainage area. 

Most Downstream Gage: 26 sq mi per
input gage location.

~ 10 sq mi ~ 26 sq mi

Confluence ~
36 sq mi
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The descriptions and procedures for using available tools are explained 
in Table 6-2. 
Table 6-2. MainView tools descriptions and procedures. 

Tools Descriptions and Procedures 

 

Flow Trace 

Description 

This tool traces the flow path downstream of a user-
specified point. 

 

Procedure 

To verify the drainage paths and watershed 
boundaries, the user can apply the flow-tracing tool 
and click on the display.  The program draws a line 
representing the flow path from a user-specified point 
to the most downstream location.  The flow path 
lines can be selected and deleted when the user is 
done examining them. 

 

To delete the lines, select the graphic with a standard 

ArcView  (Pointer) tool or Select Edit  ⇒ Select 
All Graphics, and select Edit ⇒ Delete Graphics. 

 

 

 

Point 
Delineate 

Description 

This tool delineates the watershed tributary to a user-
specified point. 
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Procedure 

To use the tool, zoom in to the stream.  Select the 
Point Delineate tool.  Click Yes to enable snapping 
to a river or No to disable snapping. 

 

The results of this operation are saved in point and 
polygon shapefiles. 

 

Identify 
Tool 

Description  

This tool allows te user to identify contributing area 
for any cell in distance units as specified in the 
View’s properties. 

 

Procedure 

To identify contributing are for a cell, select the 
Identify tool and click on the cell in question. 

 

The drainage area in distance units at the cell is 
displayed in the lower left-hand corner of the status 
bar as shown below. 
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Hydrologic Model Setup 

The HMS Project Setup menu on the MainView GUI is responsible 
for extracting necessary information from the spatial database and 
creating an HMS project.  The approach for extraction involves 
specifying control points at the downstream outlet, which defines the 
tributary of the HMS basin.  As multiple HMS Basin models can be 
produced from the same spatial database, these models are managed 
through two shapefiles themes: project points “ProjPnts.shp” and 
project area “ProjArea.shp”.  The management of these models shows 
the regions that already have a project.  In addition, management of 
these models allows re-creation of a study area with different thresholds 
or delete the project and related files easily and conveniently. 

Start New Project 
To define a new project name and create a directory to contain 
extracted data and related files, go to the HMS Project Setup menu. 

 
• Select HMS Project Setup ⇒ Start New Project. 
• Enter the project name as “AmerRiv1” as shown in Figure 6–33. 

 
Figure 6–33.  New project definition. 

• Select the  (Specify Outlet Point) tool. 
• Specify the outlet point for a tributary basin model as shown in 

Figure 6–34. 
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This 
cell 

 
Figure 6–34.  Specify outlet location. 

• Select HMS Project Setup ⇒ Generate Project. 
• Select the method of generating the project.  Select Original 

stream definition from the dropdown menu as shown in Figure 6–
35.  The other two options are “A new threshold” and “Head basin 
area”.  The option “A new threshold” allows the user to specify a 
new threshold for the project.  The option “Head basin area” allows 
the user to specify a threshold such that the head subbasins are 
approximately equal to the threshold. 

 

 
Figure 6–35.  Generate project with options. 

• Press OK 
• Use the default name “ProjArea.SHP”as shown in Figure 6-36. 
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Figure 6–36.  Project manager theme window. 

• Press OK to generate a new project in the ProjView document type 
named “AmerRiv1” as shown in Figure 6–37. 

 
Figure 6–37.  New project for hydrologic model. 

In the ProjView named “AmerRiv1”, the following data sets are 
extracted and created for the specified study area.  The extracted area 
includes the buffer zone in order to deal with the boundary conditions.  
Data sets ending with “Grid” are raster data sets, and data sets with the 
“shp” extension are vector data sets in the industry standard shapefile 
format. 
• “fillgrid” represents the extracted terrain for the study area. 
• “fdirgrid” represents the extracted flow direction for the study area. 
• “strlnkgrid” represents extracted stream segments for the study area. 
• “SmallStrGrid” is an additional grid theme created using 10% of the 

specified threshold.  It contains denser stream representation for 
visualization purposes. 

• “WaterShp.Shp” represents the extracted subbasins for the study 
area. 

• “River.Shp” represents the extracted stream segments for the study 
area. 
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• “Amerriv1.shp” contains project outlet and source point that defines 
the study area. 

Additional HMS projects or Basin Models can be generated from the 
original set of preprocessed data.  As illustrated in Figure 6–38 and 
Figure 6–39, the user can extract the pertinent data sets from the 
MainView to create another project.  The benefit of this setup is that it 
allows the user to preserve the original data sets and work on multiple 
projects. 

Project A

Project B

 
Figure 6–38.  MainView with two projects. 

 

 
Figure 6–39.  Generation of a separate project B from Figure 6–38. 
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C H A P T E R  7   

Basin Processing 

After the terrain preprocessing is completed in the MainView window, 
the extracted data for the HMS model is generated and placed in the 
ProjView window, which allows the user to revise the subbasins 
delineation.  Subbasin and routing reach delineations include points 
where information is needed, i.e., streamflow gage locations, flood 
damage centers, environmental concerns, and hydrologic and hydraulic 
controls.  The tools described in this chapter will allow the user to 
interactively combine or subdivide subbasins as well as to delineate 
subbasins to a set of points.   

This chapter will discuss 
the tools for subbasin 
delineation that are 
available in the ProjView 
GUI under the Basin 
Processing menu.  Below 
is an outline of Chapter 7. 

 

Contents 
• Basin Merge 
• Basin Subdivision 
• River Merge 
• River Profile 
• Split Basins at Confluences 
• Batch Subbasin Delineation 
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 Basin Merge 

Under the Basin Processing menu, the Basin Merge menu item 
merges multiple subbasins according to the following rules.  This tool 
works interactively by presenting the result of the operation, allowing 
the user to examine the result, and giving the user options to accept or 
cancel the operation. 

 
Rules! 
• The subbasins must share a common confluence or 
• The subbasins must be adjacent in an upstream and downstream 

manner. 
• More than two subbasins are permitted. 

 
Steps 
• Make the “WaterShp.Shp” theme active by pressing on the theme 

with the   (Pointer) tool in the View’s table of contents.  The 
active theme appears raised. 

• Use the select tool  and select the two subbasins as shown in 
Figure 7–1. 

 
Figure 7–1.  Basin merge. 

• Select Basin Processing ⇒ Basin Merge, as shown in Figure 7–2. 
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Figure 7–2.  Basin merge menu item. 
• The result of the merged subbasin is shown with a red outline.  

Press Yes to accept the resulting merged subbasin or No to cancel 
the merge operation.   

• In this case, press Yes as shown in Figure 7–3. 

 
Figure 7–3.  Basin merge confirmation. 

The result of the merged basin is shown in Figure 7–4. 

 
Figure 7–4. Basin merge result. 
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Basin Subdivision 
 

A basin can be subdivided with the  (Basin Subdivide) tool.  The 

tool tip can be viewed by placing the pointer tool  over the  tool 
as shown in Figure 7–5.  The tool tip indicates that the users can 1) 
Click on the stream to subdivide a basin or 2) Control key plus Click to 
remove an unnecessary point.  The unnecessary point is often a residual 
from multiple basin subdivisions and merges.  Basin subdivision can be 
completed using one of the methods described below. 

 
Figure 7–5.  Basin subdivision tool. 

Method 1:  Basin Subdivision on Existing Stream 
An existing basin can be subdivided into two basins on an existing 
stream. 
• Zoom in to the area of interest as shown in Figure 7–6.  Make the 

“SmallStrGrid” theme visible by checking the box in the table of 
contents as shown in Figure 7–7.  The “SmallStrGrid” theme 
represents the grid cells that compose the stream network.  The 
existing streams are shown as blue lines according the “River.Shp” 
theme. 

Zoom-to box

 
Figure 7–6.  Zoom in prior to basin subdivision. 
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• Select the  tool. 
• Click on the cell of interest as shown in Figure 7–7. 

Click here

 
Figure 7–7.  Click on the cell to subdivide basin. 

• Accept the default name for the new basin outlet or overwrite it in 
the text box as shown in Figure 7–8.   

• In this example, accept the default name.  Press OK. 

 
Figure 7–8.  Default outlet name. 

• A few seconds later, the result shown by the red outline is 
displayed.  In this case, accept the result by pressing Yes.   

 
Figure 7–9.  Basin subdivision confirmation. 

The result of the operation is shown in Figure 7–10. 
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Subdivide
Point

 
Figure 7–10.  Basin subdivision result. 

Method 2:  Basin Subdivision without Existing Stream 
When an existing stream does not extend upstream far enough, the user 
can use the same Basin Subdivide tool to delineate a new subbasin.  
For example, in Figure 7–11, the blue (if document is in color) or dark 
(if document is in black and white) stream does not extend up to the 
area of interest indicated by the box.  The tool delineates a subbasin at 
the specified point that is not on the existing stream and traces a new 
stream segment downstream from the specified point to the existing 
stream. 

Zoom to
this box

 
Figure 7–11.  New subbasin delineation. 
• Zoom in to the area of interest and make the “SmallStrGrid” theme 

visible.   



 
Chapter 7 Basin Processing 

75 

• With the Basin Subdivide tool selected, click on the point shown 
below.  Notice that the existing blue or dark stream does not exist in 
Figure 7–12. 

Click on
this cell.

 
Figure 7–12.  Zoom in prior to basin delineation. 
• Accept the default name for the outlet and press OK as shown in 

Figure 7–13. 

 
Figure 7–13.  Default name of new outlet. 

The result of the operation is shown in Figure 7–14.  A new subbasin is 
created and a new blue or dark stream segment is also created from the 
specified point to the existing stream.  Where the two streams meet, a 
point is created for reference information.  The existing and new stream 
segments are not joined together. 
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Reference Point

New 
Stream 
Segment 

Existing 
Stream 
Segment

Delineation 
Point 

New 
Subbasin

 
Figure 7–14.  New subbasin delineation result. 

Method 3:  Basin Subdivision on Tributary 
Similar to Method 2, the situation in Method 3 involves subbasin 
delineation on a tributary branch where the stream does not exist.  For 
example in Figure 7–15, the blue or dark stream does not have a 
tributary stream extending up to the area of interest indicated by the 
delineation point.  Clicking on the delineation point with the Basin 
Subdivide tool delineates a subbasin at the specified point not on the 
existing stream, traces a new stream segment downstream from the 
specified point to the existing stream, and splits the existing stream at 
the confluence. 

 

Tributary

Delineation
Point

 
Figure 7–15.  Subbasin delineation on a tributary. 
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• Accept the default name for the outlet and press OK as shown in 
Figure 7–16. 

 
Figure 7–16.  Default name for outlet. 

The result of the operation is shown in Figure 7–17.  A new subbasin is 
created with the outlet at the user-specified point; and a new stream 
segment is created from the user-specified point to the existing stream.  
Where the new stream segment meets the existing stream, a confluence 
is established by splitting the existing stream into two segments.  At the 
confluence, there are two stream segments flowing in and one segment 
is flowing out.  The existing and new stream segments are not joined. 

 

New
Subbasin

Delineation
Point

New Stream
Segment

Existing Stream Segment
 

Figure 7–17.  Subbasin delineation on a tributary result. 
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River Merge 

When basin merges and subdivisions are performed, stream segments 
are often created.  As an example, the basin subdivision with method 2 
created a stream segment that extends from the existing stream to the 
user-specified basin outlet as shown in Figure 7–18.  The point shown 
in the figure illustrates that the two segments are not joined together.  
From a hydrologic perspective, the two segments are considered as 
routing reaches. 
If the user intends to model routing with multiple reaches, the user will 
need to develop routing parameters for both reaches.  However, if the 
user intends to model the routing with a single reach, then the user will 
need to merge both stream segments.  The capability to route the 
hydrograph through multiple reaches is supported in HMS.  The issue 
here is to raise awareness on modeling techniques options. 
Steps 
• Activate the “River.Shp”. 

• Select the two stream segments with the  (Select) tool. 
• Select Basin Processing ⇒ River Merge. 
• The selected stream segments become one segment.  The reference 

point is not deleted. 
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This reference point
separates the new and
existing streams.

Select the
existing stream.

Select the
new stream.

 
Figure 7–18.  River merge. 

River Profile 

The river profile tool provides information on slopes and grade breaks 
that can be used to delineate subbasins.  The river profile is created by 
extracting elevation values from the terrain model along the stream.  
Creating the river profile can be performed using two methods: River 

Profile menu item or the   (Profile) tool. 

Method 1: River Profile menu item 
Steps 
• While in the ProjView document, activate the “River.Shp” theme. 
• Select one or several contiguous stream segments shown in Figure 

7–18 with the  (Select) tool. 
• Select Basin Processing ⇒ River Profile. 

Method 2: Profile Tool 
Steps 
• Activate the “River.Shp” theme. 

• Select the  (Profile) tool and view the tool tip for directions as 
shown in Figure 7–19. 
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Figure 7–19.  Profile tool. 

• Click on the stream segment on the map to get the profile as shown 
in Figure 7–20. 

Grade Break

 
Figure 7–20.  Stream profile. 

The user can to subdivide a basin based on a grade break as shown in 
Figure 7–20.  
Steps 
• Select the  (Profile Subdivide) tool when the stream profile 

chart is active and view the tool tip for directions as shown in 
Figure 7–21. 

 
Figure 7–21.  Profile subdivide tool. 

• Click on the chart approximately at the grade break as shown in 
Figure 7–22. 
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Grade Break 

 
Figure 7–22.  Stream profile base on a stream. 
• Watch the corresponding point that the user clicked as it blinks on 

the map display. 
• Inspect the result and accept it by clicking Yes. 

Corresponding point on the map
that shows the grade break.

 
• Press OK to accept the default name for the outlet as shown in 

Figure 7–23. 

 
Figure 7–23.  Default name for outlet. 

The result of the basin subdivision is shown in Figure 7–24. 
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Grade Break
New

Subbasin
 

Figure 7–24.  Basin subdivision from a profile. 

Split Basins at Confluences 

The Split Basins at Confluences menu item allows the user to 
subdivide a basin at a confluence.  For the situation shown in Figure 7–

25, the menu item should be used instead of the interactive  (Basin 
Subdivide) tool. 

 
Rules! 
• Only one basin can be selected for each operation. 
• This menu item can be used with a basin having multiple 

confluences. 
Steps 
• Activate the “WaterShp.shp” theme on the ProjView document. 
• Select the basin containing the confluence as shown in Figure 7–25. 
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Confluence

 
Figure 7–25.  Subdivide basin at confluences. 

• Select Basin Processing ⇒ Split Basin at Confluences as shown 
in Figure 7–26. 

 
Figure 7–26.  Split Basin at Confluences menu item. 

The operation creates three subbasins as shown in Figure 7–27.  One 
basin for each stream segments. 
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Figure 7–27.  Basin subdivided at confluence. 

Batch Subbasin Delineation 

Subbasin delineation may also be accomplished through batch 
processing; this requires that a point shapefile be created which 
contains the desired outlet locations.  It is important to recognize that 
the batch subbasin delineation operates on the existing delineations by 
further delineating with the new outlet points in the shapefile.  To 
abandon the existing delineation, the user can batch process the outlet 
locations and follow with subbasin revisions to remove existing 
delineations. There are two methods for creating to create a point 
shapefile for batch subbasin delineation.   

Method 1: Batch Point Tool 

Apply the  (Batch Point) tool to place points on the map display 
and a point shapefile named “Batchpnt.shp” is created.  To use this tool 
effectively, turn on the StrLnkGrid or SmallStrGrid themes, zoom in 
until the grid cell is visible, and place the point within the grid cell. 
Rules! 
• The point should be located within the grid cell that has an existing 

stream. 
Steps 
• Place four batch points in the order shown in Figure 7–28. 
• Zoom in to the batch points to specify the batch points on the 

existing stream cells. 



 
Chapter 7 Basin Processing 

85 

Batch Point #1

Batch Point #2

Batch Point #3

Batch Point #4

 
Figure 7–28.  Subbasin delineation at batch points. 
• Click on the grid cell to specify batch point #1 as shown in Figure 

7–29.  Notice that batch point #1 follows the rule concerning the 
presence of the existing stream. 

Batch Point #1

 
Figure 7–29.  Batch Point #1 specification. 
• Accept the default name as “BatchPoint1” as shown Figure 7–30 by 

clicking OK. 

 
Figure 7–30.  Default name for Batch Point #1 outlet. 
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• Locate Batch Point #2 as shown in Figure 7–32 with same 
procedure as before. 

Batch Point #2

 
Figure 7–31.  Batch Point #2 specification. 

• Accept the default name as BatchPoint2 as shown in Figure 7–32.  
Press OK. 

 
Figure 7–32.  Default name for Batch Point #2 outlet. 
• Locate Batch Point #3 and #4.  Notice that Batch Point #3 and #4 

violate the rule concerning the presence of the existing stream. 
The batch-point shapefile contains the essential fields shown in Figure 
7–33.  These fields provide instructions and information for the 
programs to perform batch subbasin delineation. The field headings and 
values are discussed in Table 7-1. 

 

 
Figure 7–33.  Batch-Point attribute table. 
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Table 7-1.  Batch Point Fields, Descriptions, and Values. 
Field Headings Descriptions Possible Values 

Shape Standard ArcView 
requirement for noting the 
types (point, line, polygon) 
of shapefiles. 

Point 

SnapDist The distance between the 
user-specified point to the 
final outlet point for 
subbasin delineation. 

Real values in map 
units. 

Name The name of the outlet 
location (can be edited by 
the user). 

Text 

ID An identifier for tracking 
the number of points 
generated. 

Integer values 

BatchDone An indicator if batch 
processing has been 
performed for the points. 

“0” indicates that 
batch processing 
has not been 
performed. 

“1” indicates that 
batch processing 
has been 
performed. 

“-1” indicates that 
batch processing 
has been performed 
unsuccessfully. 

SnapOn A flag that can be set to 
enable snapping of the 
user-specified point to the 
stream. 

“1” enables 
snapping as a 
default. 

“0” can be entered 
by the user to 
disable snapping. 

PntDesc A text description for the 
user-specified point. 

“Batchpoint” 

PntTYPE A numerical value that 
corresponds to the 
PntDesc. 

“15” corresponds to 
the batch point 
type. 

 



 

Chapter 7 Basin Processing 

88 

• To process the batch points in the “Batchpnt.shp”, select Basin 
Process ⇒ Delineate at Batch Points as shown in Figure 7–34. 

 
Figure 7–34.  Delineate at Batch Points menu item. 

The result of the batch delineation is shown in Figure 7–35.  Notice that 
BatchPoint #1 and #2 have been successfully delineated.  However, 
BatchPoint #3 and #4 did not result in subbasin delineation because 
their placements do not comply with the rules. 

 
Figure 7–35.  Batch points delineation results. 

The attribute table of the “Batchpnt.shp” also shows a negative 
confirmation for subbasin delineation at Batch Points #3 and #4.  
Notice the “-1” under the BatchDone field heading in Figure 7–36. 

  

 
Figure 7–36.  Batch point attribute table after subbasin delineation. 
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Method 2: Import Batch Points 
This method is useful when the user has existing point shapefiles 
containing points of interest, streamflow gage locations, and/or 
previous hydrologic model outlet specifications.  The user can import 
the existing point shapefile to prepare a batch point shapefile. 
As an example, the streamflow gage locations contained in “Gage.shp” 
as shown in Figure 7–37 can be imported into “Batchpnt.Shp”. 

 
Figure 7–37.  Import batch points. 
Steps 
• Select the Basin Processing ⇒ Import Batch Points as shown in 

Figure 7–38. 

 
Figure 7–38. Import batch points menu item. 
• Select the “Gage.shp” theme as the input from the drop down menu 

as shown in Figure 7–39.  Press OK. 
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Figure 7–39.  Input point theme selection. 
• With the field names available in the “Gage.shp” theme, select the 

gage number (“Gage_no”) field to be imported in for the “Name” 
field in the “Batchpnt.shp” theme as shown in Figure 7–40.  The 
“Gage_no” field is a suitable choice because it has unique values.  
Press OK. 

 
Figure 7–40.  Field selection as name field. 
• Press Yes on Figure 7–41 to enable snapping. 

 
Figure 7–41.  Snap options. 

The result indicates that the four gages in the “Gage.shp” theme have 
been imported into the “Batchpnt.shp” theme as shown in Figure 7–42.  
Press OK. 
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Figure 7–42.  Import batch points confirmation. 

The “Batchpnt.shp” theme now contains 8 batch points as shown in 
Figure 7–43.  The four recently added batch points are shown in yellow 
(if this document is in color) or white (if this document is in black and 
white) in Figure 7–44. 

 
Figure 7–43.  Import batch points result. 

. 
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Figure 7–44.  Imported batch points in yellow or white. 

As shown in Figure 7–45, the “BatchDone” flags are set to “0” to 
indicate that the user can re-run the Delineate at Batch Points menu 
item to delineate subbasins at the four newly added batch points. 

These batch points will be processed
if batch delineation is performed.

 
Figure 7–45.  Batch-Points attribute table. 
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C H A P T E R  8   

Stream and Watershed 
Characteristics  

 

HEC-GeoHMS computes several topographic characteristics of streams and 
watersheds.  These characteristics are useful for comparing of basins and for 
estimating hydrologic parameters.  The user should compare and verify the 
physical characteristics with published information prior to estimating the 
hydrologic parameters.  The stream and watershed physical characteristics 
are stored in attribute tables, which can be exported for use with a 
spreadsheet and other programs.  When more experience is gained from 
working with GIS data, initial estimates of hydrologic parameters will be 
provided in addition to the physical characteristics.   

This chapter will discuss the tools 
for extracting topographic 
characteristics of the watershed and 
river that are available in the 
ProjView GUI under the Basin 
Characteristics menu. 

 

The physical characteristics extracted for the streams and subbasins are 
summarized in Table 8-1.  Below is an outline of Chapter 8. 

 

Contents 
• River Length 
• River Slope 
• Basin Centroid 
• Longest Flow Path 
• Centroidal Flow Path
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Table 8-1.  Physical Characteristics of streams and subbasins. 
 Physical Characteristics Attribute Table Heading 

Stream 

(River.Shp) 

Length 

 

Riv_Length 

 Upstream elevation US_Elv 

 Downstream elevation DS_Elv 

 Slope Slp_Endpt 

 Stream Profile N/A (See Chart) 

Watershed 

(WaterShd.shp) 

Area 

 

Area 

 

 Centroid Location N/A (See 
WshCentroid.shp) 

 Centroid Elevation Elevation 

 Longest Flow Path N/A (See LongestFP.shp) 

 Longest Flow Length Longest_FL 

 Upstream elevation USElv 

 Downstream elevation DSElv  

 Slope between endpoints Slp_Endpt 

 Slope between 10% - 
85% 

Slp_1085 

 Centroidal Path N/A (See 
CentoidalFP.shp) 

 Centroidal Length CentroidalFL 

The following sections illustrate the process outlined under the Basin 
Characteristics menu on the ProjView GUI to extract the stream and 
subbasin characteristics. 

River Length 

This step computes the river length for all subbains and routing reaches in 
the “River.shp” file as shown in Figure 8–1.  The initial attribute table the 
“River.shp” theme is shown in Figure 8–2.  The computed river length is 
added as an attribute to the existing “River.shp” attribute table as shown in 
Figure 8–2.  The length column in the attribute table is computed roughly 
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from the raster representation of the stream.  This step will compute the 
river length more accurately with the vector representation of the stream. 

 
Figure 8–1.  River shapefile. 

 
Figure 8–2.  Initial attribute table for the river shapefile. 

Steps 
• Select Basin Charateristics ⇒ River Length as shown in Figure 8–3. 

 
Figure 8–3.  River  Length menu item. 

• Press OK at the message box shown in Figure 8–4. 
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Figure 8–4.  River length confirmation. 

The river length computation results in the “Riv_Length” column being 
added to the attribute table, as shown in Figure 8–5.  “Riv_Length” is in the 
map units, which are meters in this example. 

 
Figure 8–5.  Populated attribute table with river length. 

River Slope 

This step extracts the upstream and downstream elevation of a river reach 
and computes the slope.  The upstream and downstream elevation and slope 
are added as columns to the “River.shp” attribute table with the column 
headings: “us_Elv”, “ds_Elv”, and “Slp_Endpt”. 
Steps 
• Select Basin Characteristics ⇒ River Slope as shown in Figure 8–6. 

 
Figure 8–6.  River Slope menu item 
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• Select meters for the DEM Vertical Units as shown Figure 8–7 
because this terrain data has vertical units in meters.  Sometimes, the 
terrain data has the horizontal units of meters and the vertical units in 
feet or decimeters.  Press OK. 

 
Figure 8–7.  DEM’s vertical units. 

 

• Press OK at the confirmation as shown in Figure 8–8. 

 
Figure 8–8.  River slope confirmation. 

The river slope computation adds the upstream and downstream elevations 
and slope to the existing attribute table as shown in Figure 8–9. 

 
Figure 8–9.  Populated attribute table with river slope. 
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Basin Centroid 

The basin centroid location can be estimated in four ways.  The engineering 
approach to locating the centroid with momentum calculations around the 
X- and Y-axis is not implemented here because the centroid may be outside 
of U-shaped and other odd-shaped subbasins.  The four methods of 
estimating the centroid are the bounding box, ellipse, flow path, and user-
specified.  The basin centroid menu item can operate on all of the subbasins 
or on selected subbasin. 

 

Steps 
• Select Basin Charateristics ⇒ Basin Centroid, as shown in Figure 8–

10. 

 
Figure 8–10.  Basin Centroid menu item. 

• Confirm the three inputs and one output in the operation as shown in 
Figure 8–11.  Press OK. 

 
Figure 8–11.  Basin centroid input and output files. 
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Method 1:  Bounding Box 
The Bounding Box method encompasses a subbasin with a rectangular box 
and approximates the centroid as the box center.  This method works really 
fast but may not be applicable with many basin shapes. 
• Select Bounding Box Method from the dropdown menu.  Press OK. 

 

 
Figure 8–12.  Centroid computation methods. 

• Press OK at the confirmation as shown in Figure 8–13. 

 
Figure 8–13.  Centroid confirmation. 

The result of the operation is a point shapefile, “WshCentroid.Shp”, 
showing the basin centroids as shown in Figure 8–14.   
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Figure 8–14.  Basin centroid results. 

The basin centroid elevation is computed and stored in the attribute table as 
shown in Figure 8–15.  In addition, the basin centroid elevation is also 
stored in the “WaterShd.shp” attribute table as shown in Figure 8–16. 

 

 
Figure 8–15.  Basin centroid attribute table. 
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Figure 8–16.  Watershed attribute table with centroidal elevation. 

Method 2:  Ellipse Method 
The Ellipse method encompasses a subbasin with an ellipse and 
approximates the centroid as the ellipse center.  This method is slower than 
the bounding box, but it generally produces more desirable estimates of the 
basin centroids. 
 
Rules! 
• This method works only on subbasins of 2,000,000 cells or less. 

 
Steps 
• Activate the “WaterShd.Shp” theme. 
• Select the subbasin as shown in Figure 8–17. 

 

 
Figure 8–17.  Basin centroid with ellipse method. 

• Open the “WaterShd.Shp” attribute table.  The highlighted row belongs 
to the selected subbasin.  Notice that the centroid elevation is 1633.7. 
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Figure 8–18.  Watershed attribute table with one subbasin selected. 

• Select the Basin Charateristics ⇒ Basin Centroid 
• Select the Ellipse Method from the dropdown menu as shown in Figure 

8–19.  Press OK. 

 
Figure 8–19.  Basin centroid with ellipse method selected. 

A new centroid is re-computed for the selected subbasin as shown in Figure 
8–20.  The ellipse method produces a centroid that is adjusted slightly 
compared to the bounding box method.  The elevation of the centroid is 
automatically updated in the “Wshcentroid.shp” and “WaterShd.shp” theme 
attribute tables.  The “Watershd.shp” and the attribute table are shown in 
Figure 8–20 and Figure 8–21. 

 
Figure 8–20.  Ellipse method basin centroid result. 
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Figure 8–21.  Centroidal elevation updated in watershed attribute table. 

Method 3:  Flow Path 
The Flow Path method draws the longest flow length for the subbasin and 
approximates the centroid as the midpoint on the longest flow length. 
Steps 
• Activate the “WaterShd.Shp” theme. 
• Select the subbasin as shown in Figure 8–22. 

 

 
Figure 8–22.  Basin centroid with flow path method. 

• Select the Basin Characteristics ⇒ Basin Centroid 
• Select the Flow Path Method from the dropdown menu as shown in 

Figure 8–23.  Press OK. 
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Figure 8–23.  Basin centroid with flow path method selected. 

Confirm the three inputs and one output in the operation as shown in Figure 
8–24.  The longest flow path, stored in the “Longestfp.shp” theme, is 
computed for the selected subbasin.  Press OK. 

 

 
Figure 8–24.  Flow path method input and output files. 

The results are shown in Figure 8–25.  A new centroid is re-computed for 
the selected subbasin.  The elevation of the centroid is automatically 
updated in the “Wshcentroid.shp” and “Watershd.shp” attribute tables. 
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Figure 8–25.  Flow Path method basin centroid result. 

 

 
Figure 8–26.  Centroidal elevation updated with the Flow Path method. 

Method 4:  User-Specified Centroid Location 
When the three previous methods do not produce satisfactory estimates of 
the centroid, this method allows to user to move the centroid to any location 
within the subbasin.   
Steps 
• Select the subbasin as shown in Figure 8–27. 



 

Chapter 8 Stream and Watershed Characteristics 

108 

 
Figure 8–27.  Selected subbasin for User-Specified method. 

• Zoom in to the selected subbasin as shown in Figure 8–28. 
• Open the “WaterShd.Shp” attribute table as shown in Figure 8–29. 

 

 
Figure 8–28.  Zoom in to the selected subbasin. 
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Figure 8–29.  Watershed attribute table with the selected subbasin. 

• Activate the “wshcentroid.shp” theme. 
• Select Theme ⇒ Starting Editing from the standard ArcView interface 

as shown in Figure 8–30. 

 
Figure 8–30.  Start Editing menu item. 

• When the “WshCentroid.Shp” is under editing mode, a dashed box is 
visible around the check box as shown in Figure 8–31. 

• Use the pointer tool and click on the existing centroid. 
• The pointer turns into a double arrow. 
• Click and drag the centroid to another location as shown in Figure 8–31. 

 

Dashed Box

 
Figure 8–31.  User-Specified new basin centroid location. 

• To stop editing and save the changes, select Theme ⇒ Stop Editing as 
shown in Figure 8–32. 
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Figure 8–32.  Stop Editing menu item. 

After a centroid is moved, the centroid elevation in the “WshCentroid.Shp” 
and “WaterShd.shp” attribute tables must be updated as shown in Figure 8–
33. 
• Select Basin Characteristics ⇒ Centroid Elevation Update 

 
Figure 8–33.  Centroid Elevation Update menu item. 

The result of the user-specified centroid is shown in Figure 8–34 and 
elevation updates to the attribute tables of the “WshCentroid.Shp” and 
“WaterShd.shp” themes are shown in Figure 8–35 and Figure 8–36. 

 

 
Figure 8–34.  Moved basin centroid result. 
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Figure 8–35.  Centroid elevation updated in the centroid attribute table. 

 
Figure 8–36.  Centroid elevation updated in the watershed attribute table. 

 

Longest Flow Path 

The Longest Flow Path operation computes a number of basin physical 
characteristics: the longest flow length, upstream elevation, downstream 
elevation, slope between the endpoints, and slope between 10% and 85% of 
the longest flow length.  These characteristics are stored in the 
“WaterShd.shp” theme. 
Steps 
• Select Basin Characteristics ⇒ Longest Flow Path as shown in Figure 

8–37.  The program will not prompt the user to verify the data input and 
output because that confirmation was already made before in Figure 8–
24. 
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Figure 8–37.  Longest Flow Path menu item. 

• Press OK in the confirmation message box as shown in Figure 8–38. 

 
Figure 8–38.  Longest flow path confirmation. 

The result of the longest flow path operation is shown in Figure 8–39. 

 
Figure 8–39.  Longest flow path result. 

The flow path attributes are written to both attribute tables for the 
“Longestfp.shp” and “WaterShd.shp” theme as shown in Figure 8–40 and 
Figure 8–41, respectively. 
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Figure 8–40.  Longest flow path attribute table. 

 
Figure 8–41.  Longest flow path results populated in watershed attribute table. 

Centroidal Flow Path 

This operation computes the centroidal flow path length by projecting the 
centroid onto the longest flow path.  The centroidal flow path is measured 
from the projected point on the longest flow path to the subbasin outlet as 
shown in Figure 8–42. 



 

Chapter 8 Stream and Watershed Characteristics 

114 

Longest Flow Path

Centroidal Flow Path

Centroid

Right
Angle

Projected
Point

 
Figure 8–42.  Centroidal flow path.  

Steps 
• Select Basin Characteristics ⇒ Centroidal Flow Path as shown in 

Figure 8–43.   

 
Figure 8–43.  Centroidal Flow Path menu item. 

• The program prompts the user to verify five data inputs and one output, 
see Figure 8–44.  Press OK. 
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Figure 8–44.  Centroidal flow path input and output files. 

• Press OK at the confirmation message box as shown in Figure 8–45. 

 
Figure 8–45.  Centroidal flow path confirmation. 

The result of the centroidal flow path operation is a line shapefile named 
“centroidalfp.Shp” and its attribute table as shown in Figure 8–46 and 
Figure 8–47, respectively.  The centroidal flow length in the “CentroidalFL” 
column is also stored in the “WaterShd.shp” attribute table as shown in 
Figure 8–48. 
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Figure 8–46.  Centroidal flow path result. 

 
Figure 8–47.  Centroidal flow path attribute table. 

 
Figure 8–48.  Centroidal flow path results populated in watershed attribute table. 
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C H A P T E R  9   

Hydrologic Parameters Estimation  

When the stream and subbasin physical characteristics have been extracted, 
users have the option to estimate a number of hydrologic parameters in 
GeoHMS Version 1.1.  Infiltration loss rates, in terms of curve numbers, can 
be estimated as lumped and grid-based quantities that are based on soil and 
landuse databases.  Other hydrologic 
parameters, such as time of concentration and 
Muskingum-Cunge routing parameters can be 
obtained from the terrain, surveyed data, and 
precipitation data.  

The estimated hydrologic parameters are 
subbasin curve number, ModClark grid curve 
number, Muskingun-Cunge routing 
parameters, subbasin time of concentration, 
and subbasin lag time.  The other steps and 
parameters, such as ModClark Processing, 
Rainfall 2 Year, TR55 Flow Path Segments, 
TR55 Flow Path Segment Parameters, TR55 
Export Tt Parameters to Excel, and Basin Slope, are intermediate steps for 
computing hydrologic parameters.  The Design Rainfall is only used for 
setting up a Meteorologic model as discussed in Chapter 10. 

The user should compare and verify these estimated hydrologic parameters 
against published information.  These hydrologic parameters are stored in 
attribute tables, which can be exported for use with a spreadsheet and other 
programs.  When more experience is gained working with GIS data, more 
initial estimates of hydrologic parameters will be provided.   

This chapter will discuss the tools for estimating hydrologic parameters that 
are available in the ProjView GUI under the Hydrologic Parameters menu. 
Below is an outline of Chapter 9. 

Contents 
• Subbasin curve number 
• ModClark gridded subbasin processing 



 

Chapter 9 Hydrologic Parameters Estimation 

118 

• Muskingum-Cunge routing parameters 
• Time of concentration 
• Basin lag time 
• Subbasin index precipitation          
 

Subbasin Curve Number 
This function overlays the subbasin boundaries over a curve number grid 
and computes the average curve number for the selected set of subbasins as 
shown in Figure 9-1.  The construction of a curve number grid is covered in 
Appendices E, F, and G.  If no subbasin has been selected, the function will 
process all subbasins.  This function also stores the curve number statistics 
in the table, Cnstat.dbf, saved in the project workspace. 

This function creates or updates one field in the subbasin shapefile theme: 
bcn: Average curve number value for the subbasin. 

 
Figure 9–1. Subbasin boundaries overlay with curve number grid. 
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Steps 
• Select Hydrologic Parameters ⇒ Subbasin Curve Number  
• Select the subbasin and curve number theme from the dropdown 

menus as shown in Figure 9-2. 
 

 
Figure 9–2. Input themes for curve number estimation. 

The resulting average lumped curve number for each subbasin is shown 
in Figure 9-3. 

 
Figure 9–3. Lumped curve numbers for subbasins. 

ModClark Gridded Subbasin Processing 

This section applies to the distributive modeling approach using the 
ModClark transform method.  The first function, ModClark 
Processing, creates a grid-based representation of the subbasin.  The 
second function, ModClark Grid CN, computes grid-based curve 
numbers for each of the ModClark grid cells.  These steps should be 
performed after the user has revised the subbasin and reach names and 
built the HMS schematic.  



 

Chapter 9 Hydrologic Parameters Estimation 

120 

ModClark Processing 
This function creates a ModClark grid cell polygon theme, which 
divides the subbasins into grid cells for the distributed-modeling 
approach.  It is produced by intersecting the subbasin polygons with the 
boundaries of cells in the precipitation-reporting grid.  GeoHMS 
supports two pre-defined precipitation grid geometries: the Standard 
Hydrologic Grid (SHG) and the Hydrologic Rainfall Analysis Project 
(HRAP).  However, it is recommended that the user select the SHG or 
the HRAP option instead of the “User Defined” option.  The “User 
Defined” option uses the SHG and the user can type in any cell size in 
meters.  With the radar rainfall reported in the HRAP grid format, the 
use of SHG or HRAP grids can ensure better alignment and 
compatibility between radar rainfall and a gridded subbasin.  More 
details on the selection of a grid format are available in the Appendix D. 

Irrespective of the selected unit system in HMS, the ModClark grid cell 
size is always in SI units to maintain alignment and compatibility with 
radar rainfall.  

There are three methods for creating the ModClark grid cell polygon 
theme: 

1. SHG Method: the user will be prompted to select the SHG cell size 
in meters. 

2. HRAP Method. 

3. User Defined: same as SHG, but the user can type in any cell size in 
meters. 

This function requires three inputs: 
• Flow direction grid 

• Subbasin shapefile 

• Input projection file (e.g. prj.adf file associated with the DEM). 

The operation creates the ModClark grid cell polygon theme, named by 
appending “ModClark” to the cell size.  The ModClark grid cell 
polygon theme contains the following fields: 
• Area: Area of the cell. 

• WshId: Unique identifier for each polygon in the ModClark theme. 

• Name: Name of the subbasin the cell is in. 

• Shg_x: x SHG coordinate of the cell (or HRAP_x: x HRAP 
coordinate of the cell). 

• Shg_y: y SHG coordinate of the cell (or HRAP_y: y HRAP 
coordinate of the cell). 
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• Mod_Area: Area in square kilometers  

• Flowlength: Average distance in kilometers of all the DEM cells in 
the ModClark polygon from the subbasin’s outlet.  This is in effect 
the average distance of the ModClark polygon from the sub basin 
outlet. 

Steps 
• Select Hydrologic Parameters ⇒ ModClark Processing. 
• Select SHG Method from the dropdown menu as shown in Figure 

9-4. 
• Press OK. 

 
Figure 9–4.  Precipitation grid types. 

• The SHG grid uses the Albers Equal-Area projection as shown in 
Figure 9-5.  Press Yes. 

  
Figure 9–5.  Default Albers projection. 

• Select the cell resolution for the SHG grid.  2000 (meters implied) 
is selected as shown in Figure 9-6.  A grid-cell resolution of 2000 
meters is often suggested when working with radar rainfall.  At that 
resolution, a grid cell has an area of four square kilometers if it 
resides entirely within a subbasin.  Along the subbasin boundaries, 
however, a grid cell is often broken into several pieces, which 
belong to several subbasins.  Press OK. 
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Figure 9–6.  Grid-cell resolution for SHG. 

A separate view is created to overlay the subbasin and the SHG grid 
(see Figure 9-7) and perform the intersection. 

 
Figure 9–7.  Intersection between subbasins and SHG grid. 

This operation creates a ModClark grid cell shapefile, 
“ModClark2K.shp”, with grid-cell travel distances to the subbasin 
outlet as shown in Figure 9-8. 
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Subbasin R150W120 ~ 5.696 sq.mi.

Area ~ 3.22 sq.km.

Subbasin R80W60 ~ 2.428 sq.mi. Area ~ 0.78 sq.km.
 

Figure 9–8.  Grid-cell parameter file result. 

The attribute table shown in Figure 9-9 displays the results for the 
selected cell.   

 
Figure 9–9.  ModClark grid cell polygon theme attribute table. 

ModClark Grid CN 
This optinal function computes the average curve number for each 
ModClark grid cell.   It will save the curve number statistics in the 
file Cnstat.dbf stored in the project workspace. 

Two input themes are required: 
• ModClark grid cell polygon theme  

• Curve number grid 

The function creates or updates the following field in the ModClark 
theme: 
• bcn: Average curve number value for the ModClark grid cell as 

shown in Figure 9-10. 
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Figure 9–10.  ModClark grid cell polygon theme with gridded curve number. 

Muskingum-Cunge Parameters 

This function facilitates a process for entering Muskingum-Cunge 
standard routing parameters for prismatic shaped channels in the stream 
attribute table.  The user will not be able to get accurate channel 
geometry because the DEM is often too coarse.  However, the users are 
allowed to link as-built drawings, photos, survey data, and other 
information that show channel shape and geometry as shown in Figure 
9-11.  This information can provide a basis for the user to specify 
channel dimension, shape, and other parameters. 

 

 
       Figure 9–11.  Field survey data and photographs. 
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Steps 
• Select at least one river segment as shown in Figure 9-12. 

 
Figure 9–12.  River segment selection. 

• Select Hydrologic Parameters ⇒ Muskingum-Cunge Parameter 

• Enter the bottom width of the channel, channel side slopes, and the 
channel’s roughness coefficient (Manning’s n) as shown in Figure 
9-13.  Only the prismatic channel type can be defined through this 
function. 

 

 
Figure 9–13.  Muskingum-Cunge standard parameters entry. 

This function creates or updates the following fields in the River 
shapefile theme as shown in Figure 9-14:  
• ChnSdSlp: Channel side slope. 

• ChnWidth: Channel width. 

• ChnShape: Channel shape. 

• ChnManN: Channel Manning’s number. 
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     Figure 9–14. Muskingum-Cunge standard parameters. 

Time of Concentration 

The time of concentration is estimated in accordance to the Natural 
Resources Conservation Service (NRCS) TR-55 methodology.  The 
following information is required to estimate travel time, 2-year 24-
hour rainfall amount, slopes, flow distance of precipitation excess on 
the land’s surface for the three NRCS flow regimes - sheet flow, 
shallow concentrated flow, and channel flow.  These inputs are used to 
populate a Microsoft Excel template spreadsheet.  Users are encouraged 
to check and overwrite these GIS derived parameters as well as provide 
additional inputs, such as Manning’s roughness coefficient, channel 
cross-sectional area, and wetted perimeter.  Users have full control over 
the spreadsheet to make changes to parameters and even equations, as 
appropriate.   

The spreadsheet is launched from a GeoHMS menu.  Oftentimes, 
GeoHMS is unable to locate Excel because the various directories that 
Excel can be installed on depends on the operating systems.  The user 
can help GeoHMS locate Excel by opening the Excel template (tc.xls 
file located in the \$AVHOME\etc folder) and then select the GeoHMS 
menu. 

Rainfall Two-Year  
This function computes the two-year rainfall for each subbasin needed 
for the calculation of travel time in accordance to the Natural Resources 
Conservation Service (NRCS) TR-55 methodology.  To be consistent 
with the TR-55 method for time of concentration computation, the 
precipitation intensity value should be in inches.  The two-year rainfall 
value is extracted at the subbasin centroid location from the 
precipitation intensity grid.  The function operates on a selected set of 
subbasins.  If no subbasin has been selected, the function processes all 
subbasins.  The function does not perform unit conversion; therefore 
the value for the precipitation intensity grid should be in inches. 

If the user has the 2-year, 24-hour precipitation intensity grid, then the 
function requires three input themes: subbasin theme, precipitation 
intensity grid, and the centroid theme. 
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If the user does not have the necessary precipitation intensity grid, then 
the user can click the Cancel button on Figure 9-15.  The function will 
offer to have the required field created (but not populated).  The user 
can then manually enter the precipitation intensity for each subbasin by 
editing the “Precip2Yr” field in the “watershed.shp” attribute table. 
Steps 
• Select Hydrologic Parameters ⇒ Rainfall 2 Yr  

• Select the subbasin shapefile, 2-year 24-hour precipitation intensity 
grid, and watershed centroid shapefile from the dropdown menus as 
shown below. 

 
Figure 9–15. Precipitation intensity computation. 

The function creates or updates one field in the subbasin theme as 
shown in Figure 9-16: 
• Precip2Yr: The precipitation in inches is extracted from the 

precipitation intensity grid at the location of the watershed centroid.  
If the grid is not in inches, the user needs to convert the unit 
manually. 

 
Figure 9–16. Precipitation intensity computation result. 

TR55 Flow Path Segments 
This function creates a point theme showing the flow regimes along the 
longest flow path for the computation of time of concentration in 
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accordance to the Natural Resources Conservation Service’s TR55 
methodology.  The function places two points along the longest flow 
path for each subbasin.  If no subbasin has been selected, the function 
processes all the subbasins.  The first point, AA, marks the break 
between sheet flow and shallow concentrated flow.  Point AA is by 
default located about 300 feet from the watershed divide along the 
longest flow path.  The second point, BB, marks the break between 
shallow concentrated flow and the channel flow.  Point BB is by default 
located where the longest flow path first encounters or intersects the 
channel. 
Steps 
• Select Hydrologic Parameters ⇒ TR55 Flow Path Segments 

• Select the subbasin shapefile, TR55 channel line shapefile (by 
default, the program uses the centroidal flow path), longest flow 
path shapefile, and flow accumulation grid from the dropdown 
menus as shown in Figure 9-17. 

 
Figure 9–17. Flow path break point computation. 

The function creates or updates the flow break point theme as shown in 
Figure 9-18.  This theme contains the following fields: 
• Name: Indicate whether the point is an "AA" or a "BB" point. 

• WshID: Subbasin identifier. 
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Figure 9–18. Flow path break point computation result. 

Once these points are placed by the program, the user has the flexibility 
to move them using ArcView standard editing tools to drag those points 
to a new location.  The user can use the custom tool (Define TR55 
Points), , to specify new AA or BB points and delete the old ones, 
see following section.   

The user can also apply the Interactive Flow Path tool, , to specify 
a different longest flow path by clicking on a different most remote 
point in the subbasin, see subsequent section. 

Define TR55 Points 
This tool modifies the location of the AA and BB points that define the 
TR55 flow path types obtained using the "TR55 Flow Path Segments" 
function.  When the tool is active as shown in Figure 9-19, click to add 
an AA point, Ctrl+Click to add a BB Point, or Shift+Click to remove an 
AA or BB point.  When a point is added, the old point of that type in 
the watershed is NOT removed automatically, so it must be removed 
manually or the functions for parameter extraction will not operate 
correctly.  There should be only one AA and one BB point in each 
watershed.  The result of using the Define TR55 Points tool is shown 
in Figure 9-20. 

 

  
Figure 9–19. Define TR55 points tool. 
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Figure 9–20. Define TR55 points results. 

Interactive Flowpath  
By secifying a different most remote point in the watershed, the user 
can use this tool to generate a different longest flow path than the one 
generated by the program. 
Steps  
• Select the Interactive Flowpath tool, . 

• Click on the location of the most hydraulically remote point in the 
subbasin 

The tool creates or updates the two following themes: 
• Longest flow path shapefile 

• Slope points10%-85% shapefile  

The user clicks on the desired flow path starting point in the watershed: 
the function will generate the flow path downstream to the outlet of the 
watershed.  The user will then be prompted whether to replace the 
existing flow path in this subbasin.  If the flow path is replaced, then 
the tool will identify the new locations of the 10% and 85% points and 
calculate the new slope parameters (see 10-85 LF Slope in the subbasin 
attribute table). 
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TR55 Flow Segment Parameters 
This function calculates the length and slope for the TR55 flow paths.  
It operates on a selected set of subbasins in the subbasin theme.  If no 
subbasin has been selected, the function processes all the subbasins. 

The function extracts the elevations from the terrain at the starting and 
ending points of the longest flow paths and at the AA and BB flow 
break points.  The lengths are measured along the longest flow paths 
between the four points of interest. 

The function creates or updates the following fields in the longest flow 
path theme as shown in Figure 9-21: 
• ChSlp: Slope for the TR55 channel flow segment (ft/ft) between 

point BB and the end of the channel. 

• ChLength: Length of the TR55 channel flow segment (between the 
BB flow break point and the outlet of the sub basin) (ft). 

• ShSlp: Slope for the TR55 shallow flow (overland flow) segment 
(ft/ft) between most remote point and AA. 

• ConShLength: Length of the TR55 concentrated shallow flow 
segment (between AA and BB flow break points) (ft). 

• ConShSlp: Slope for the TR55 concentrated shallow flow segment 
(ft/ft) between point AA and BB. 

• ShLength: Length of the TR55 shallow flow (overland flow) 
segment (between start of the longest flow path and the AA flow 
break point) (ft). 

 
Figure 9–21. Flow segment parameters results. 

Export TR55 Data 
This function exports the data about the TR55 flow segments to a 
Microsoft Excel template workbook.  The function operates on a 
selected set of subbasins in the subbasin theme.  If no subbasin has 
been selected, the function processes all the subbasins. 

In the Excel spreadsheet as shown in Figure 9-22, the blue (darkest 
shading) areas contain the data brought in from GeoHMS.  The user can 
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overwrite them if necessary, but those changes will not be transferred 
back to GeoHMS.  The green areas contain the data that the user inputs.  
Default values are provided and they should be revised to better reflect 
field conditions and project needs.  The white and yellow areas contain 
computed values; therefore they should not be modified in any way.  
They will be recomputed whenever there are changes to the blue and 
green areas. 

The Excel spreadsheet will be stored automatically in the project 
directory.  The full file name and its path are displayed in the cell B28 
or next to the cell entitled “Stored Workbook.”  The file name is 
concatenated with the “Tt” prefix and the date and time the file was 
created.  The file can be renamed using the standard Excel "Save as" 
capability. 

 
Figure 9–22. TR55 travel time computation results. 

Once the travel time of each subbasin is estimated, the user can press 
the calculator button, , to transfer the travel times back to 
GeoHMS as shown in Figure 9-23. 
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Figure 9–23. Travel time results exported to GeoHMS. 

The function creates or updates the following fields in the subbasin 
theme as shown in Figure 9-24: 
• BasinLag: Basin lag (hours), computed as 0.6*Tc. 

• LagMethod: Method used for lag computations.  For basins for 
which the TR55 method was used the entry will be "TR55". 

• Tc: Basin time of concentration (hours). 

 
Figure 9–24. Time of concentration results. 

Basin Lag Time 

In this section, the basin lag time is estimated with a two step process.  
The first step is used to estimate the basin or watershed slope.  In the 
second step, the basin lag time is estimated using the curve number 
method described in the NRCS National Engineering Handbook, 1972. 

Basin Slope 
This function computes the average basin slope in the watershed, which 
is used as an input for the computation of the CN Lag time.  The 
function operates on a selected set of subbasins from the subbasin 
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theme.  If no subbasin has been selected, the function processes all the 
subbasins.  The basin slope is determined by averaging the values of 
slope in the subbasin as defined by the slope grid.  If the slope grid does 
not exist, it will be computed using the ESRI ArcView Spatial Analyst 
slope operator. 
Steps 
• Select Hydrologic Parameters ⇒ Basin Slope 

• Select the terrain grid from the dropdown menu as shown in Figure 
9-25. 

• Specify the slope grid by typing its name in the text box. 

 
Figure 9–25. Basin slope theme selection. 

The function may create a slope grid if one is needed as shown in 
Figure 9-26.  It also creates or updates the following field in the 
subbasin theme as shown in Figure 9-27: 
• BasinSlp: Average subbasin slope. 
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Figure 9–26. Basin slope grid. 

 

 
Figure 9–27. Basin slope computation results. 

CN Lag Method 
This function computes the basin lag time according to the equation 
below based on the curve number method described in the NRCS 
National Engineering Handbook, 1972.  This method was developed for 
watersheds of less than 2000 acres.  The function operates on a selected 
set of subbasins in the subbasin theme.  If no subbasin has been 
selected, the function processes all the subbasins.  

 

 

 

Where:  Lag = basin lag time (hours) 

   L = hydraulic length of the watershed (feet) 

Lag = 
( L 0.8 * (S+1) 0.7 ) 

( 1900 * Y 0.5 ) 
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          ; where CN’ is approximately equal 
to the  curve number.  CN’ values 
between 50 to 95 are appropriate to 
this equation. 

   Y = watershed slope (%) 

The watershed slope (Y) value is determined in the previous step, Basin 
Slope, by averaging the values of slope in the watershed as defined by 
the slope grid.  If the slope grid does not exist, it will be computed 
using the ESRI ArcView Spatial Analyst slope operator. 

The function creates or updates the following fields in the watershed 
theme as shown in Figure 9-28: 
• BasinLag: Basin lag (hours). 

• LagMethod: Method used for lag computations.  For basins for 
which the CN lag method was used, the entry will be "CNLag". 

 
Figure 9–28. Curve number lag computation results. 

Subbasin Index Precipitation 

This function calculates the subbasin index precipitation used for the 
User-Specified Gage Weights method in the HMS Meteorologic 
Component.  The function operates on a selected set of subbasins in the 
watershed theme.  If no subbasin has been selected, the function 
processes all the subbasins.  The value is determined by selecting the 
amount from the rainfall grid located at the subbasin centroid.  There is 
no unit conversion, so the units of the grid will be used.  These units 
should match the units defined for the meteorologic model defined in 
the "Unit" entry in the "HMSMetDesign.txt" file (in $AVHOME\etc 
directory).  They should be in millimeters if the units are "SI" and in 
inches if the units are "English".    

This function requires three input themes: subbasin theme, precipitation 
intensity grid, and the centroid theme. 

CN’
10S =

1000
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If the user does not have the necessary precipitation intensity grid, then 
the user can click the Cancel button as shown in Figure 9-29.  The 
function will offer to have the required field created (but not 
populated).  The user can then manually enter the precipitation intensity 
for each subbasin by editing the “DesignRain” field.  The “design” rain 
here refers to a subbasin index precipitation used in the User Gage 
Weighting Meteorologic model. The result of this function is only used 
for setting up a Meteorologic model as discussed in Chapter 10. 
Steps 
• Select Hydrologic Parameters ⇒ Design Rainfall 

• Select the subbasin, design rainfall grid theme, centroid theme from 
the dropdown menus as shown in Figure 9-29. 

 
Figure 9–29. Design precipitation computation. 

The function creates or updates one field in the subbasin theme as 
shown in Figure 9-30. 
• DesignRain: Precipitation in inches is extracted from the 

precipitation grid at the location of the watershed centroid.  If the 
precipitation grid contains units that are not in millimeters or 
inches, then the user will need to do the unit conversion manually. 

 
Figure 9–30. Precipitation intensity computation result. 
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C H A P T E R  1 0   

Hydrologic Modeling System 

HEC-GeoHMS develops a number of hydrologic inputs for HEC-HMS: 
background-map file, lumped-basin schematic model file, grid-cell 
parameter file, and distributed-basin schematic model file.  The steps 
GeoHMS follows to create these files includes automatic naming of 
reaches and subbasins, checking for errors in the basin and stream 
connectivity, and producing an HMS schematic.  The hydrologic 
parameter data is then entered through HMS menus. 

 This chapter will discuss the tools for 
generating HMS model files that are available 
in the ProjView GUI under the HMS menu.  
Below is an outline of Chapter 10. 

 

Contents 
• Reach AutoName 
• Basin AutoName 
• Map to HMS Units 
• HMS Data Check 
• HEC-HMS Basin Schematic 
• HMS Legend 
• Add Coordinates 
• Standard HMS Processes 
• Background Map File 
• Lumped Basin Model 
• Grid Cell Parameter File 
• Distributed Basin Model 
• Meteorologic Model  
• HMS Project Setup 
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Reach AutoName 

This process names reaches in sequence from upstream to downstream.  
The naming convention combines the letter “R” and a number.  For 
example, the upstream reach starts with R10 and then R20, R30, R40, 
etc. are the reach names proceeding downstream.  The intent of this tool 
is to quickly name the reaches; the user can change the default names to 
something more descriptive. 
Steps 
• Select HMS ⇒ River AutoName as shown in Figure 10–1. 

 
Figure 10–1.  Reach autoname menu item. 

• Press OK on the confirmation message box. 

 

The Reach Autoname operation creates a “Name” column in the 
stream’s attribute table as shown in Figure 10–2. 

 
Figure 10–2.  Reach autoname result. 

The following steps can be used to edit the names in the attribute table. 
• Open and activate the attribute table of “River.shp”. 
• Select Table ⇒ Start Editing as shown in Figure 10–3. 
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Figure 10–3.  Edit reach name. 

• Select the  (Edit) tool. 
• Press on a name-field entry and revise it. 
• When the revision is done, select Table ⇒ Stop Editing as shown 

in Figure 10–4. 
• The user is prompted to Save Edits?  Press Yes to save and No to 

cancel the edit. 

 
Figure 10–4.  Stop and save revised reach name. 

Basin AutoName 

This process names the subbasins in sequence from upstream to 
downstream.  The naming convention adds “W + 10, 20, and etc.” to 
the receiving reach name to form the subbasin name. e.g., R20W20.  
The intent of this tool is to quickly name the subbasin, and the user can 
edit the default names to something more descriptive. 
Steps 
• Select HMS ⇒ Basin AutoName as shown in Figure 10–5. 

 
Figure 10–5.  Basin AutoName menu item. 

• The Basin Autoname operation creates a “Name” column in the 
“WaterShd.shp” attribute table as shown in Figure 10–6. 
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Figure 10–6.  Subbasin autoname result. 

Map to HMS Units 

This step converts the physical characteristics of the reaches and 
subbasins from the map units to the HMS units.  The map unit is the 
unit of the ArcView data; the terrain data is typically in meters.  The 
user has the option to convert the map units to English or the 
International System (SI) units supported by HMS.  HEC-HMS only 
uses the subbasin area at this time; the other characteristics can be used 
for regional parameter estimation.  

The Table 10-1 shows the HMS units in the English and International 
System. 
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Table 10-1.  HMS unit systems. 

 Physical Characteristics 
(Table Heading) 

HMS EnglishUnits 
(Table Heading) 

HMS SI Units 
(Table Heading) 

Stream 

(River.Shp) 

Length  

(Riv_Length) 

 

Upstream elevation 
(US_Elv) 

 

Downstream elevation 
(DS_Elv) 

 

Feet  

(Riv_Length_HMS) 

 

Feet 

(US_Elv_HMS) 

 

Feet 

(DS_Elv_HMS) 

 

Meters  

(Riv_Length_HMS) 

 

Meters 

(US_Elv_HMS) 

 

Meters 

(DS_Elv_HMS) 

 

Watershed 

(WaterShd.shp) 

Area 

(Area) 

 

Centroid Elevation 

(Elevation) 

 

Longest Flow Length 

(LongestFL) 

 

Upstream elevation 

(US_Elv) 

 

Downstream elevation 

(US_Elv) 

 

Centroidal Length 

(CentroidalFL) 

 

Square miles 

(Area_HMS) 

 

Feet 

(Elevation_HMS) 

 

Feet 

(Longest_FL) 

 

Feet 

(USElv_HMS) 

 

Feet  

(DSElv_HMS) 

 

Feet 

(CentroidalFL_HMS) 

 

Square kilometers 

(Area_HMS) 

 

Meters 

(Elevation_HMS) 

 

Meters 

(LongestFL_HMS) 

 

Meters 

(USElv_HMS) 

 

Meters 

(DSElv_HMS) 

 

Meters 

(CentroidalFL_HMS) 
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Steps 
• Select HMS ⇒ Map to HMS Units. 
• Select English from dropdown menu as shown in Figure 10–7.  

Press OK. 

 
Figure 10–7.  HMS unit conversion options. 

• Press OK in confirmation message box. 
 

The unit conversion operation results in three added columns for the 
stream attribute table as shown in Figure 10–8 and six added columns 
for the subbasin attribute table as shown in Figure 10–9.  The units of 
the added columns are specified in Table 10-1 for the selected unit 
system. 

 
Figure 10–8.  River attribute table populated with HMS units fields. 
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Figure 10–9.  Watershed attribute table populated with HMS units fields. 

HMS Data Check 

This step checks the data sets for consistency in describing the 
hydrologic structure of the model.  For example, the program checks 
for unique names for the reaches, subbasins, and outlet points.  In 
addition, the program checks that the rivers and centroids are contained 
within the subbasins and that rivers are connected with relevant points 
created in the basin processing step.  This is desirable for placement of 
the hydrologic elements’ names and connectivities on the HMS basin 
schematic.  In general, the program keeps track of the relationship 
between the stream segments, subbasins, outlet points, and other 
entities.  These checks are necessary because the relationships between 
hydrologic elements may have been broken by unintentional use of the 
tools. 

The program checks every spatial feature in the “River.shp”, 
“WaterShd.shp”, “Amerriv1.shp”, and “wshcentroid.shp” data files.  It 
produces a text file, “SkelConsChk.txt”, that presents the results on 
each feature and summarizes the results.  This step does not fix any of 
the problems.  However, the user can view the result and fix the 
problems manually using HEC-GeoHMS or HMS. 
Steps 
• Select HMS ⇒ HMS Check Data. 
• Review the input data sets as shown in Figure 10–10.  Press OK. 
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Figure 10–10.  HMS check data input and output files. 

• Make a note of the filename and its location as shown in Figure 10–
11.  Press OK. 

 

 
Figure 10–11.  HMS check data result file location. 

• Open the results file with a text editor and review the results. 

The “Checking Summary” at the end of the file shows that 4 of the 5 
items checked have no problems, see Figure 10–12.  The “VIP 
Relevance” check shows two problems.  The VIPs (very important 
points) represent locations of basin subdivision, outlets, centroids, etc.  
Sometimes, a few VIPs are no longer relevant or needed because the 
basin outlets may have changed as a result of basin processing. 

 
Figure 10–12.  HMS check data result summary. 
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• Scroll up the file and find that problems exist with BatchPoint1 and 
BatchPoint2 as shown in Figure 10–13. 

After examining the subbasin delineation, Batch Points 1 and 2 appear 
to be relevant because they serve as basin outlets.  Keep these problems 
in mind and fix them in HMS, if necessary.  These problems can also 
be fixed with some effort using HEC-GeoHMS by editing various 
tables.  Currently, the types of problems that can be easily fixed are 
reach and subbasin name revisions. 

 
Figure 10–13.  HMS check data problems. 

HEC-HMS Basin Schematic 

The HMS basin schematic is the GIS representation of the hydrologic 
basin model with basin elements and their connectivity.  This step 
creates a point shapefile, “HMSPoint.shp”, and a line shapefile, 
“HMSConnect.shp”.  The “HMSPoint.shp” contains point features, 
such as subbasin icon locations, outlets, and junctions.  Subbasin icons 
are placed at the centroid of the area.  The “HMSConnect.shp” contains 
line features, such as subbasin connectors and reaches.  The subbasin 
connector joins a subbasin icon to the basin outlet. 
Steps 
• Select HMS ⇒ HMS Schematic. 
• Review the input and output data sets as shown in Figure 10–14.  

Press OK. 
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Figure 10–14.  HMS schematic input and output files. 

• Press OK at the confirmation message box. 

The HMS schematic with ArcView symbols is shown in Figure 10–15. 

 
Figure 10–15.  Initial HMS schematic result. 

The attribute tables of the “hmspoint.shp” and “hmsconnect.shp” 
shapefiles are shown in Figure 10–16 and Figure 10–17.  The 
highlighted features are shown on the tables to display how the program 
uses the downstream element name, “Dstr_Name”, in both tables to 
establish element connectivity. 
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Figure 10–16.  HMS schematic point attribute table. 

 

 
Figure 10–17.  HMS schematic line attribute table. 
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 HMS Legend 

This process implements HMS symbology to represent point and line 
features more descriptively as hydrologic elements, such as junctions, 
subbasins, sources, and others.  The user has the option to toggle 
between HMS Legend and Regular Legend. 
Steps 
• Select HMS ⇒ HMS Legend. 
• The user can toggle between HMS Legend and Regular Legend 

by selecting HMS ⇒ HMS Legend or Regular Legend. 
 

 
Figure 10–18.  HMS schematic with symbols. 

Add Coordinates 

This step attaches geographic coordinates to hydrologic elements in the 
attribute tables of “HMSPoint.shp” and “HMSConnect.shp”.  The 
attachment of coordinates allows GIS data to be exported to a non-
proprietary ASCII format and still preserves the geospatial information. 



 
Chapter 10 Hydrologic Modeling System 

151 

 
Steps 
• Select HMS ⇒ Add Coordinates.  Press OK. 

The results are shown in Figure 10–19 and Figure 10–20.  For a point 
feature in Figure 10–19, the “CanvasX”, “CanvasY”, “Elevation” 
columns describe an outlet in 3-dimensional space.  For a line feature in 
Figure 10–20, the coordinate pair (“FromCanvasX”, “FromCanvasY”) 
and (“CanvasX, CanvasY”) describe a reach orientation with flow 
direction. 

 
Figure 10–19.  Point attribute table populated with coordinates. 
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Figure 10–20.  Line attribute table populated with coordinates. 

Standard HMS Processes 

An HMS basin model file contains the hydrologic data structure, which 
includes the hydrologic elements, their connectivities, and related 
parameters.  GeoHMS can export some of the hydrologic parameters to 
the HMS basin model file.  For those parameters that do not have a GIS 
input at this time, but are required to complete the HMS project, this 
function populates a series of fields with default values needed for 
setting up the HEC-HMS input files.  In GeoHMS Version 1.1, only 
one method for modeling is definable.  If changes to these modeling 
methods and parameters are required, they can be done after the basin 
model is imported into HMS.   

Changes to these modeling methods and parameters can also be made 
manually in GeoHMS by editing the “fieldmap.fmf” file located in the 
project file directory.   This file contains the default fields to be used for 
basin file generation.  If this file already exists, the user will be 
prompted whether to replace it.  If the file is replaced or overwritten, it 
will contain only default fields. Any user customizations will be lost 
and will require manual editing of the ‘fieldmap.fmf’ file.  Additional 
information can be added to this file as more parameters can be 
extracted using GeoHMS.  For further information review the help 
section on GeoHMS Field Specification for HMS Object Definition. 
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This operation creates an ASCII file named ‘fieldmap.fmf’ in the 
project directory.  Table 10-2 presents the fields in the “fieldmap.fmf” 
file and the default values set by this function. 
Table 10-2.  Default HMS modeling methods. 

Theme  Field (function) Default value 

HMSPoint TransMet (transformation method) "SCS" 

 LossMet (loss method) "SCS" 

HMSConnect RouteMet (routing method) "Muskingum Cunge Standard" 

SubBasin InitAbst (initial abstraction) 0 

 PctImp (percent impervious) 0 

Background-Map File 

The background-map file captures the geographic information of the 
subbasin boundaries and stream alignments in an ASCII text file that 
can be read by HMS.  The format specifications of the background map 
file are given in Appendix B. 
Steps 
• Select HMS ⇒ Background Map File. 
• Make a note of the filename and its location as shown in Figure 10–

21.  Press OK. 

 
Figure 10–21.  Background map file location. 

The resulting background map file in ASCII format looks similar to 
Figure 10–22. 
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        …many lines omitted … 

 

 
        …many lines omitted … 

Figure 10–22.  HMS background map file example. 

Lumped-Basin Model 

The lumped-basin model captures the hydrologic elements, their 
connectivity, and related geographic information in an ASCII text file 
that can be input to HMS.  This basin model should be used for a 
hydrologic model with lumped, not distributed, basin parameters.  
Lumped-basin models do not use gridded precipitation or the ModClark 
transform method. 
Steps 
• Select HMS ⇒ Lumped Basin Model. 
• Make a note of the filename and its location as shown in Figure 10–23.  

Press OK. 

 
Figure 10–23.  Lumped basin model file location. 

The resulting lumped-basin model file in ASCII format looks similar to 
Figure 10–24. 
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Figure 10–24.  HMS lumped-basin model example. 

Grid-Cell Parameter File 

This function generates the ModClark grid cell parameter file.  The 
grid-cell parameter file represents subbasins as grid cells for the 
distributed-modeling approach.  An ASCII file with name 
ProjectName.mod, which contains gridded subbasin information, will 
be created in the project directory.  The ModClark grid cell parameter 
file has been extended to include a gridded curve number.  The grid-cell 
parameter file contains the parameters and units as shown in Table 
10-3. 

This function requires one input theme: 

ModClark grid cell polygon shapefile 

 



 

Chapter 10  Hydrologic Modeling System 

156 

Table 10-3.  Grid-Cell Parameters Units 
 Physical Characteristics 

(Table Heading) 

 

Units 

 

Grid Cell Parameter 

(ModClark2K.Shp) 

X Coordinates  

(Shg_X) 

 

Y Coordinates  

(Shg_Y) 

 

Grid-Cell Travel 
Distance 

(FlowLength) 

 

Grid-Cell Area 

(Mod_Area) 

 

Curve Number 

(SCSCN) 

N/A 

 

 

N/A 

 

 

Kilometers 

 

 

 

Square 
kilometers  

 

N/A (Value 
between 0 and 
100) 

 

Steps 
• Select HMS ⇒ Grid Cell Parameter File. 
• Make a note of the filename and its location as shown in Figure 10–25.  

Press OK. 

 
Figure 10–25.  Grid-cell parameter file location. 

The resulting grid-cell parameter file in ASCII format looks similar to 
Figure 10–26. 
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  … Many lines omitted … 

Figure 10–26.  HMS grid-cell parameter file in ASCII format. 

Distributed-Basin Model 

Similar to the lumped-basin model, the distributed-basin model has 
additional labeling that references the grid-based subbasin in 
conjunction with the grid-cell parameter file.  The ModClark transform 
method and gridded precipitation must be used with distributed basin 
models. 
Steps 
• Select HMS ⇒ Distributed-Basin Model. 
• Make a note of the filename and its location as shown in Figure 10–27.  

Press OK. 

 
Figure 10–27.  Distributed-basin model file location. 

SCSCN 
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The resulting distributed-basin model file in ASCII format looks similar 
to Figure 10–28. 

 
Figure 10–28.  HMS distributed-basin model file example. 

Meteorologic Model File 

This function generates the HMS meteorological model file (*.met).  
The user will be prompted to specify the name of the meteorologic 
station whose temporal distribution will be used for the basins with the 
User-Specified Gage Weights method in HMS.  This is currently the 
only supported meteorologic model in GeoHMS.  Other meteorologic 
models can be specified through HMS. 

The "DesignRain" field in the subbasin theme contains the values that 
will be associated with each subbasin/gaging station.  The effect of this 
precipitation modeling approach is the following: 

1. All subbasins are assigned the same, user selected, gaging station.  
This gaging station (as defined in the dss file) should contain 
temporal distribution of one unit of precipitation (cumulative value 
= 1). 

2. "DesignRain" field contains the average design rainfall for each 
subbasin that will be used to adjust (scale/index) the unit 
precipitation defined by the gaging station.  It is important to match 
the duration of the event defined by the gaging station with the 
values stored in the "DesignRain" field.  For example, if the gaging 
station refers to a design rainfall pattern for a 100-year event of 24-
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hour duration, then the values in the "DesignRain" field should 
match those design criteria. 

3. The final effect is that each subbasin has the same temporal 
distribution pattern but the overall volume and peak rainfall is 
scaled using the individual values for each subbasin (as defined in 
DesignRain field). 

The list of available gages is defined in the HMSMetDesign.txt file.  
These gages need to have an entry in the hmsdesign.gage file pointing 
to the rainfall distribution pattern stored in the hmsdesign.dss file.  The 
three mentioned files should reside in the $AVHOME\etc directory.  
For customization of the available meteorological station, review the 
Rainfall Gage Specification help topic. 

It is important to note that the "Unit" entry in the "HMSMetDesign.txt" 
file ($AVHOME\etc directory) must be consistent with the units in the 
“DesignRain” field.  If the unit entry is "SI", than the DesignRain 
values must be in millimeters.  If the unit entry is "English", than the 
DesignRain values must be in inches.  GeoHMS does not provide 
functionality to convert different precipitation units into the HMS 
precipitation units, so it is user’s responsibility to insure that the 
precipitation units are correct (conversion can be easily performed 
using standard ArcView table editing operations – e.g. table calculator). 

HMS Project Setup 

This function generates a project subdirectory in the HMS project 
directory.  It copies all project specific and standard GeoHMS files into 
that directory.  If the directory exists, the files in there will be replaced.  
The location of the HMS project directory is specified in the 
HMSMetDesign.txt file (in $AVHOME\etc directory) as 
"HMSDataDirectory".  By modifying that entry, GeoHMS can be 
instructed to generate project subdirectories in a different parent 
directory. 

The following files are copied ("Project" identifies the name of the 
project in GeoHMS): 

"Project".basin copied from the GeoHMS project subdirectory. 

"Project".hms copied from the GeoHMS project subdirectory. 

"Project".met copied from the GeoHMS project subdirectory. 

"Project".map copied from the GeoHMS project subdirectory. 

"Project".mod copied from the GeoHMS project subdirectory. 
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"Project".dss renamed from hmsdesign.dss in $AVHOME\etc directory. 

"Project".control renamed from hmsdesign.control in $AVHOME\etc 
directory. 

"Project".gage renamed from hmsdesign.gage in $AVHOME\etc 
directory. 

This set of files completely defines an HMS project and can be directly 
loaded and executed from HMS without any further data manipulation.  
In general, quality control on the data input should be performed before 
actually performing the HMS run. 

Once created, the files in the HMS directory are not related to the files 
in the GeoHMS project directory, so any changes in one set of files will 
NOT be reflected in the other. 

Hydrologic Modeling System Connection 

The purpose of this section is to illustrate the procedure for interfacing 
the inputs developed in HEC-GeoHMS within HEC-HMS models.   

HEC-GeoHMS develops many components of an HMS model.  
GeoHMS capabilities extend from processing the terrain model to 
performing spatially intensive analysis for development of grid-based 
parameters.  The results produced can be controlled somewhat by 
focusing on the spatial description of the landscape characteristics and 
stream networks.  However, from a modeling standpoint, greater 
control over the model is often necessary to address difficult situations.  
HMS is powerful in that it offers full control over the model to address 
hydrologic connectivity, methodology, and parameters.  For example, 
HMS can be used to change the connectivity and eliminate, add, and 
revise hydrologic elements and their properties.   

The HMS project definition requires Basin, Meteorologic, and Control 
Specifications components (HEC, 2000).  The steps for setting up these 
three HMS components are discussed below.   

Directory Setup 
• Create the HMS project first, and then copy the background-map 

file, basin-model file, and grid-cell parameter file, if appropriate, 
into “D:\hmsproj\ GeoHMS_Ex1”. 

HMS Use 
• Start HMS. 
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• Select File ⇒ New Project on the HMS*PROJECT 
DEFINITION screen. 

• Enter the Project as “GeoHMS_Ex1” and Description as “GIS 
Application from HEC-GeoHMS” as shown in Figure 10–29. 

• Press OK. 

 
Figure 10–29.  New HMS project definition window. 

Basin Model 
Import the Basin Model with the following steps. 
• On the HMS*PROJECT DEFINITION screen, select 

Component ⇒ Basin Model ⇒ Import as shown in Figure 10–30. 

 
Figure 10–30.  Basin model import. 

• Navigate to “D:\hmsproj\ GeoHMS_Ex1”. 
• Select and import the “AmerRiv1” Basin Model. 
• Press Import as shown in Figure 10–31. 
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Figure 10–31.  HMS basin model import window. 

The following errors, shown in Figure 10–32 and Figure 10–33, warn 
the user that Batch Points 1 and 2 do not have a downstream element 
connection.  Press OK in both message boxes and make note to fix the 
downstream connections later with HMS. 

 
Figure 10–32.  Critical error on batch point 2. 

 
Figure 10–33.  Critical error on batch point 1. 

Background-Map File and Grid-Cell Parameter File 
Specify the background-map file and grid-cell parameter file with the 
following steps. 
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• Specify the background-map file and grid-cell parameter file by 
selecting the File ⇒ Basin Model Attributes menu item as shown 
in Figure 10–34.  This produces the Basin Model Attributes screen 
shown in Figure 10–35. 

 
Figure 10–34.  HMS basin model attributes menu item. 

 

 
Figure 10–35.  HMS basin model attributes specifications. 

• Select the Files tab. 
• To specify the Map File, press Browse. 
• Navigate to the D:\hmsproj\ GeoHMS_Ex1 and select the file 

“mapfile.map” as shown in Figure 10–35. 
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• To specify the Grid-cell File, press Browse. 
• Navigate to the D:\hmsproj\ GeoHMS_Ex1 and select the file 

“ModClark.mod” as shown in Figure 10–35. 
 
• To specify the default methods, select the Default tab.  Then select 

a loss rate, ModClark for transform (this is the grid-cell based unit 
graph), baseflow, and a routing method.  Press OK. 

 

The resulting basin model with the background map is shown in Figure 
10–36.  Notice that subbasins R150W120 and R160W130 are not 
connected to junctions (these were the problems noted for Batch Points 
1 and 2 in the previous data checking). 

 

 
Figure 10–36.  HMS basin model schematic. 
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To fix the missing junction, select the Junction element on the left side 
palette of the HMS Schematic screen and drag it onto the canvas and 
drop it at the outlet of subbasin R150W120. 

Use HMS to connect subbasin R150W120 to Junction-1.  Add routing 
reach R70 to connect Junction-1 to UserPoint2 as shown in Figure 10–
37. 

 
Figure 10–37.  Revision to basin connectivity with junction-1. 

To connect subbasin R160W130, first break the connection of R160 
and R60.  Then insert the Junction element on the left side palette by 
dragging and dropping it at the outlet of subbasin R160W130.  Use 
HMS to connect subbasin R160W130 to Junction-2, then connect reach 
R160 to Junction-2, and finally Junction-2 to reach R60 as shown in 
Figure 10–38. 

 

 
Figure 10–38.  Revision to basin connectivity with junction-2. 
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The corrected basin model is shown in Figure 10–39.   
• Select the Parameters menu to enter additional hydrologic 

parameters per menu items.  Save and close the HMS * Basin 
Model – AmerRiv1 window. 

 

 
Figure 10–39.  HMS basin model with correct connectivity. 

Meteorologic Model 
A number of methods are available to model the precipitation.  The 
following steps illustrate the grid-based precipitation method that is 
often used in conjunction with the grid-cell parameter file.  Gridded 
precipitation must be used with the ModClark transform method.  The 
grid-based precipitation for this example has been developed in SHG at 
2000-meter resolution.  The rainfall is stored as a series of grids at 1-
hour intervals in the Data Storage System, HEC-DSS (HEC, 1994 and 
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2000).  The rainfall may be directly from the National Weather Service 
(NWS) NexRad if the Hydrologic Rainfall Analysis Project (HRAP) 
cell format is used, modified to the HEC Standard Hydrologic Grid 
(SHG) format, or interpreted from point gages with another program, 
called GageInterp (HEC, 1999).  The precipitation grid format is 
aligned with the grid-cell parameter file.  The steps for developing the 
meteorologic model follow. 

 

 
Figure 10–40.  HMS Project with Basin Model. 

• From the HMS * Project Definition window as shown in Figure 
10–40, select Component ⇒ Meteorologic Model ⇒ New as 
shown in Figure 10–41.  The result is shown in Figure 10–42. 

 
Figure 10–41.  Met Model menu item. 

• Enter the Meteorologic Model name as “Radar” and the 
Description as “Grid-based precipitation,” see Figure 10–42.  Press 
OK. 
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Figure 10–42.  New meteorologic model. 

• From the “Add subbasins from basin model:” dropdown menu, 
select “AmerRiv1”.  Press the Add button and the subbasins in the 
“AmerRiv1” basin model are added to the “Subbasin” heading as 
shown in Figure 10–43.  Press OK. 

 
Figure 10–43.  Meteorologic model subbasin list. 
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• With the “Precipitation” tab active, select “Gridded Precipitation” 
from the “Method:” dropdown list as shown in Figure 10–44. 

 
Figure 10–44.  Meteorologic model methods. 

 
Figure 10–45.  Confirmation of precipitation method. 

• Press OK to the confirmation of precipitation method as shown in 
Figure 10–45. 
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Figure 10–46.  Gridded precipitation model options. 

• To specify the “Gridded Data File:”, Figure 10–46, press the 
Browse… button and navigate to and select the 
“D:\hmsproj\GeoHMS_EX1\sac_unit.dss”.   

• Enter the following pathname parts that are applicable to the 
“sac_unit.dss” file.  For “Pathname A Part:”, enter “SHG”, for 
“Pathname B Part:”, enter “SACRAMENTO”, for “Pathname C 
Part:”, enter “PRECIP”, and for “Pathname F Part:”, enter “UNIT”.   

• Check Yes to “Replace Missing data with zero?” as shown in 
Figure 10–46. 

Control Specifications 
The control specifications component contains time-related data (HEC, 
2000).  The following steps illustrate the creation of control 
specifications component with the time window and interval that are 
compatible with the precipitation.  HMS does not currently interpolate 
gridded precipitation to other time intervals; the simulation must be 
performed at the same 1-hour interval as the gridded rainfall.  The 
Control Specifications Component identifies a time window from 29 
February to 3 March 2000.  The computational time interval is set at 1 
hour.   

 



 
Chapter 10 Hydrologic Modeling System 

171 

• From the HMS * Project Definition window, select Component 
⇒ Control Specifications ⇒ New as shown in Figure 10–47. 

 

 
Figure 10–47.  Control Specifications menu item. 

• Enter “Control Feb 2000” for “Control Specs:” and “Time 
related specifications for Feb 2000 storm” for 
the ”Description:” as shown in Figure 10–48.  Press OK. 

 
Figure 10–48.  New Control Specifications. 

• Enter the Starting Date as “29Feb2000”, the Starting Time as 
“0000”, the Ending Date as “03Mar2000”, and the Ending Time 
as “0000”.  The time interval is 1 hour, which matches with the 
grid-based precipitation interval as shown in Figure 10–49.  Press 
OK. 
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Figure 10–49.  Control specifications time window. 

HEC-HMS Simulation 
An HMS run consists of Basin Model, Meteorologic Model, and 
Control Specifications components (HEC/, 2000) as shown in Figure 
10–50.  With these three components completed, HMS can compute 
flow.  The HMS parameter optimization capability can also be used 
with gridded models.  Refer to the HMS User’s Manual for examples of 
gridded basin simulations. 

 
Figure 10–50.  HMS components for simulation. 
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C H A P T E R  1 1   

Example Application - American 
River Basin 

The purpose of this chapter is to illustrate the major steps in the 
development a hydrologic model using GeoHMS Version 1.0.  The 
study watershed is the American River Basin tributary to Folsom Dam, 
just east of Sacramento, California.  The watershed consists of 4,817 
square kilometers (1,860 square miles).  The digital elevation model 
has been assembled to represent the watershed terrain.  In addition, 
streamflow gages have been compiled into a data layer of gage 
locations, names, drainage areas, and other attributes. 

Overview 

This chapter provides a detailed example of how to perform drainage 
analysis on a digital terrain model for development of an HEC-HMS 
model.  Eight additional data sets are derived that collectively describe 
the drainage patterns of the watershed.  This information will be used to 
perform a preliminary delineation of the streams and subbasins.  The 
first five data sets in the grid representation are the flow direction, flow 
accumulation, stream definition, stream segmentation, and watershed 
delineation grids.  The next two data sets are the vectorized 
representation of the watersheds and streams, and they are the 
watershed polygons and the stream segments.  The last data set, the 
aggregated watersheds, is used primarily to improve the performance in 
watershed delineation.  

The following tasks will be performed in the presentation of this 
example. Figures and tables numbers are not used as the information 
follows in the direct order of when the tasks and results are described.  
Processing times for most tasks are shown based on a Pentium III 500 
MHz with 256 MB of memory.  Besides the hardware specifications, 
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the terrain grid size is the most important factor in determining the time 
required to perform most of the operation. 

The sample data for this exercise includes the DEM 
(“AmerRiver_dem”) and gage outlet locations (“hec1ga.shp”).  The 
sample data is stored under the “AmerRiverData” directory on the CD-
ROM. 

The completed ArcView project (“AmerRiver.apr”) with the HMS 
model files illustrating the results of Tasks I to III is saved under the 
“AmerRiver” directory on the CD-ROM. 

 
Task I.  Preprocess the Terrain Model 

1. Open ArcView and load HEC-GeoHMS. 

2. Setup the working directory with terrain and stream flow gage 
data. 

3. Perform drainage analysis by processing the terrain using the 8-
pour point approach. 

4. Extract pertinent spatial data and setup a hydrologic model. 
 

Task II.  Basin Processing 

5. Revise subbasin delineation. 

6. Extract physical characteristics of streams and subbasins. 

7. Develop HMS inputs. 
 

Task III.  Hydrologic Modeling System 

8.  Setup an HMS model with inputs from HEC-GeoHMS. 
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Tasks 
Task I.  Preprocess the Terrain Model 

1.  Open ArcView and load HEC-GeoHMS  

• Create an empty folder called “\AmerRiver” on the hard drive.  This folder 
serves as the working directory for your project.  In this case E:\AmerRiver. 

• Open ArcView and create a new project as a Blank Project. 

• Select File ⇒ Extensions… 

• When the Extensions dialog appears, scroll down until HEC-GeoHMS is 
visible.   

 
• Press on the name label (HEC-GeoHMS) to access the About information. 

• Check the box next to it to turn it on.   

• Press OK to close the dialog and watch the status bar in the lower left-hand 
corner for the loading messages. 

It is not necessary to load the Spatial Analyst extension because GeoHMS will 
automatically load it.  When properly installed and loaded, HEC-GeoHMS will create 
two custom views, “MainView” and “ProjView” as shown below. 
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2.  Setup the working directory with terrain and streamflow gage data 

• Open a New MainView 

• Select the File ⇒ Manage Data Sources… 

• Navigate to the “CD-ROM\AmerRiverData” 

• Copy the DEM called “AmerRiver_dem” to your working directory 

• Add the “AmerRiver_dem” as a grid theme in the MainView 

• Select Theme ⇒ Properties.  Note that there are about 10 million (2834 rows 
* 3662 columns) cells at 30 meters resolution that cover a rectangular area of 
9340 sq km (3606 sq mi), which encompasses this study watershed of 4817 sq 
km (1860 sq mi). 

• Save the project as “AmerRiver.apr” in the working directory “E:\AmerRiver”.  
The location of the project is important because subsequent derived data sets 
are stored relative to the project location. 
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3.  Perform drainage analysis by processing the terrain using the 8-point pour-
down approach 

A.  Fill Sinks 

• Select Terrain Preprocessing ⇒ Fill Sinks.  

• Confirm that the input of the RawDEM (also refer to as the unfilled DEM) 
is “AmerRiver_dem”.  The output of the HydroDEM is “FillGrid”.  
“FillGrid” is a default name that can be edited by the user.  

 
• Press OK.   (This step takes about 45 minutes.) 
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B.  Flow Direction 

• Select Terrain Preprocessing ⇒ Flow Direction.  

• Confirm that the input of the HydroDEM is “Fillgrid”.  The output of the 
FlowDirGrid is “FdirGrid”.  “FdirGrid” is a default name that can be 
edited by the user. 

• Press OK.  (This step takes about 2 minutes.) 
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C.  Flow Accumulation 

• Select Terrain Preprocessing ⇒ Flow Accumulation.   

• Confirm that the input of the FlowDirGrid is “FdirGrid”.  The output of 
the FlowAccGrid is “FaccGrid”.  “FaccGrid” is a default name that can be 
edited by the user. 

• Press OK.  (This step takes about 21 minutes.) 
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The above screen does not appear complete, but it is.  Zoom-in to a part of the 
basin to display the details of the grid cells that make up the flow accumulation 
grid as shown below. 
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D.  Stream Definition 

• Select View ⇒ Properties. 

• The Map Units are the data units.  In this case, the DEM data units are 
measured in meters.   

• Specify the Map Units as “meters”. 

• The Distance Units are the reporting units in ArcView.  In this case, the 
Distance Units are chosen as miles so that the information reported from 
ArcView can be compared with the streamflow gage drainage area reported 
in square miles. 

• Specify the Distance Units as miles. 

• Press OK. 

 
• Save the project as “AmerRiver.apr” in the working directory 

“E:\AmerRiver”. 

• Select Terrain Preprocessing ⇒ Stream Definition. 

• Confirm that the input of the FlowAccGrid is “FaccGrid”.  The output of 
the StreamGrid is “StrGrid”.  “StrGrid” is a default name that can be 
edited by the user. 

• Press OK.  

• Select the threshold type as “Area in Distance Units squared”. 

• Enter the threshold for stream initiation at “50” square miles. 



 

Chapter 11 Example Application - American River Basin 

182 

• Press OK.  (This step takes about 30 seconds.) 

 
The result of the Stream Definition operation is the “StrGrid” shown below. 

 
Zoom-in to display the details of the grid cells that make up the stream 
definition grid. 

 



 
Chapter 11 Example Application - American River Basin 

183 

E.  Stream Segmentation 

• Select Terrain Preprocessing ⇒ Stream Segmentation.   

• Confirm that the input of the FlowDirGrid is “FdirGrid” and 
StreamGrid is “StrGrid”.  The output of the LinkGrid is 
“StrLnkGrid”.  “StrLnkGrid” is a default name that can be edited by the 
user. 

• Press OK.  (This step takes about 30 seconds.) 
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F.  Watershed Delineation 

• Select Terrain Preprocessing ⇒ Watershed Delineation.   

• Confirm that the input of the FlowDirGrid is “FdirGrid” and 
LinkGrid is “StrLnkGrid”.  The output of the WaterGrid is 
“WshedGrid”.  “WshedGrid” is a default name that can be edited by the 
user. 

• Press OK.  (This step takes about 6 minutes.) 
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G.  Watershed Polygon Processing 

• Select Terrain Preprocessing ⇒ Watershed Polygon Processing.   

• Confirm that the input of the WaterGrid is “WshedGrid”.  The output 
of the Watershed is “Wshedshp.Shp”.  “Wshedshp.Shp” is a default 
name that can be edited by the user. 

• Press OK.  (This step takes about 10 seconds.) 
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H.  Stream Segment Processing 

• Select Terrain Preprocessing ⇒ Stream Segment Processing.   

• Confirm that the input of the LinkGrid is “StrLnkGrid” and 
FlowDirGrid is “FDirGrid”.  The output of the River is “River”.  
“River” is a default name that can be edited by the user. 

• Press OK.  (This step takes about 10 seconds.) 
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I.  Watershed Aggregation 

• Select Terrain Preprocessing ⇒ Watershed Aggregation.   

• Confirm that the input of the River is “River.shp” and Watershed is 
“Wshedshp.shp”.  The output of the AggregatedWatershed is 
“WshedMg.shp”.  “WshedMg.shp” is a default name that can be edited 
by the user. 

• Press OK.  (This step takes about 30 seconds.) 
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4.  Extract pertinent spatial data and setup a hydrologic model 
In this step, a watershed is defined by its outlet.  A watershed can also be defined 
by an outlet and one or more source points which represent inflows from other 
drainage basins.  The watershed outline is delineated by GeoHMS, and a project 
view is created which contains the newly delineated subbasins, or project model.   

• Add the streamflow gage theme called “HEC1ga.shp” to the MainView to 
help determine the outlet location. 

• Make the “HEC1ga.shp” active and identify the gages shown below. 

 

Highlighted gage

 
• The identified gage has a drain area of about 493 sq. miles under the “Drain_area” 

heading. 
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• Zoom in on the gage and make the “StrlnkGrid” theme visible. 

 

 
 

• Use the  tool and click on the grid cell with the identified gage.  The grid cell 
has 492.009 sq mi of drainage area.  The result  is 
shown in the lower left corner.  This cell has a drainage area that is adequately 
close to that of the gage.   

• Now analyze the watershed that is tributary to this grid cell. 

 

• Select HMS Project Setup ⇒ Start New Project. 

• Enter “ProjAmer” as the project name. 

• Press OK. 

 

• Select  and click on the cell to specify the outlet location. 
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Click on this cell

 
• Name the outlet point as “Outlet_Amer”. 

 
• Press OK. 

 

 
• Select HMS Project Setup ⇒ Generate Project. 

• Select the “Original stream definition” from the dropdown menu. 

• Press OK. 

• Verify the watershed outline boundary and press Yes. 
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• Verify the project area shapefile and then press OK. 

 

 
• Note the workspace location and press OK. 

• Turn on the “ProjArea.shp” theme to show the area extracted for an HMS model. 
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The pertinent data sets are extracted from the specified outlet location.  A ProjView 
named “ProjAmer” is used for basin processing, basin characteristics, and HMS 
inputs. 

 
 

The extracted data sets are smaller.  For example, the extracted data for the “fillgrid” 
has 1308 rows and 2094 columns as compared to the original 2834 rows and 3662 
columns.  The following window can be accessed by activating the “FillGrid” theme 
and selecting Theme ⇒ Properties. 

 
 

Task II.  Basin Processing 

5.  Revise subbasin delineation 

A.  Merge Basins 
This process merges selected subbasins into one. 
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• Make the “WaterShd.Shp” active by clicking on the theme with the  
(pointer) tool.  The active theme appears raised. 

• Use the  (select) tool and select the two subbasins shown below. 

 

Select this
subbasin

Select this
subbasin

 
• Select Basin Processing ⇒ Basin Merge. 

• The result of the merged subbasin is shown with a red outline.   

• Press Yes to accept the resulting merged subbasin.   

 
The result of the merged basin is committed as shown below. 
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B.  Subdivide a Basin 
• Make the “Hec1ga.shp” theme active on the “ProjAmer” window. 

• Using the Identify tool on the streamflow gage with Station_ID 1144190. 

• Notice that the reported drainage area is 171 sq.miles. 

 
 

• Zoom in on the gage location. 

• Use the  (Identify Area) tool to find the computed drainage area. 

• Select the  tool. 

• With the “SmallStrGrid” visible, click on the cells near the gage to compute 
drainage areas. 
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• After searching nearby cells, the cell shown below is an adequate location for 

an outlet.  The computed drainage area is . 

 

• Select the  tool. 

• Click on the cell shown below to subdivide the subbasin. 
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Click on this cell.

 
• Press OK. 

 
 

• Verify the result shown below. 

 
• Press Yes. 
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The result of basin subdivision is shown below. 
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C.  Obtain River Profile and subdivide from the grade break 
• Activate the “River.Shp” theme. 

• Select the stream segment shown in the figure below with the  (select) 
tool. 

 
 

• Select Basin Processing ⇒ River Profile. 

Click on this
grade break.

 
 

• Review the stream profile. 

• The user can subdivide the basin based on the grade break shown in the 
above figure. 

• Select the  (point delineate) tool. 

• Click on the profile approximately where the grade breaks as shown in the 
profile.  
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• Click Yes. 

 
• Press OK. 

• Review the result and press Yes. 

 

 
The result of the basin subdivision is shown below. 

New subbasin outlet
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6. Extract Physical Characteristics of Streams and Subbasins 
 

The physical characteristics of the streams and subbasins are extracted and saved 
in attribute tables. 

 

A.  River Length 

• Select Basin Characteristics ⇒ River Length. 

• Press OK at the message box. 

• A “Riv_Length” column is added to the “River.Shp” attribute table. 

 

 
 

B.  River Slope 

• Select Basin Characteristics ⇒ River Slope. 

• Select the DEM Vertical Units as “meters” because the terrain data has 
vertical units in meters.  

• Press OK. 

• “Slp_Endpt”, “US_Elv”, and “DS_Elv” columns are added to the 
“River.Shp” attribute table. 
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C.  Basin Centroid 

• Select Basin Characteristics ⇒ Basin Centroid. 

• Confirm the three inputs and one output in the operation as shown below.   

 
• Press OK. 

• Select the Ellipse Method from the dropdown menu.   

 

 
• Press OK. 

• A new theme, “WshCentroid.Shp”, is created to represent the centroid 
locations.   
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The centroidal elevation is saved under the “Elevation” column in the 
“WaterShd.Shp” attribute table. 
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D.  Longest Flow Path 

• Select Basin Characteristics ⇒ Longest Flow Path. 

 
• Review the input and output themes.  Press OK.  (This step takes about 5 

minutes.) 

 

 
• Press OK on the confirmation screen. 

 

The results of the longest flow path operation are shown below. 
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The longest flow path computation also stores the physical parameters in the 
watershed’s attribute table as shown below. 

 
 

E.  Centroidal Flow Path 

• Select Basin Characteristics ⇒ Centroidal Flow Path. 

• The program prompts the user to verify the five data inputs and one output.   
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• Press OK. 

 

The result of the centroidal flow path operation is the line shapefile named 
“Centroidalfp.Shp” and its attribute table as shown in the figures below.  The 
centroidal flow length in the “CentroidalFL” column is also stored in the 
“WaterShd.shp” theme attribute table. 
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7.  Develop HMS Inputs 

A.  Reach AutoName 

• Select HMS ⇒ River AutoName. 

• Press OK on the confirmation message box. 

The Reach Autoname creates a “Name” column in the stream’s attribute table as 
shown in the table below. 

 
B.  Basin AutoName 

• Select HMS ⇒ Basin AutoName. 

• The Basin Autoname creates a “Name” column in the subbasin’s attribute 
table as shown in the table below. 
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C.  Map to HMS Units 

• Select HMS ⇒ Map to HMS Units. 

• Select English from dropdown menu.   

 

 
• Press OK and press OK again to confirmation message box. 

 

The results of the unit conversion are three added columns to the stream’s 
attribute table and six added columns to the subbasin’s attribute table.  The 
added columns contain the ending “_HMS”. 

 
 

 
 

D.  HMS Check Data 

• Select HMS ⇒ HMS Check Data. 

• Verify the input data sets below.   
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• Press OK. 

 

 
• Make a note of the filename and its location.  Press OK. 

 

The output file, “SkelConsChk.txt”, contains the results of the check results.  
The end portion of the file is shown below. 
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E.  HMS Schematic 

• Select HMS ⇒ HMS Schematic. 

• Review the input and output data sets as shown the window below. 

 
• Press OK and press OK again at the confirmation message box. 

 

The HMS schematic with ArcView symbols is shown in the figure below. 
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F.  HMS Legend 

• Select HMS ⇒ HMS Legend. 

• The user can toggle between HMS Legend and Regular Legend by 
selecting HMS ⇒ HMS or Regular Legend. 

 
 

G.  Add Coordinates 
This step attaches geographic coordinates to hydrologic elements in the 
attribute tables of “HMSPoint.shp” and “HMSConnect.shp”.  The attachment 
of coordinates allows GIS data to be exported to a non-proprietary ASCII 
format and still preserve the geographic information. 

• Select HMS ⇒ Add Coordinates.  Press OK. 

 

H.  Background-Map File 

The background-map file captures the geographic information of the subbasin 
boundaries and stream alignments in an ASCII text file that can be read by 
HMS.  

• Select HMS ⇒ Background-Map File. 

 
• Make a note of the filename and its location.  Press OK. 
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I.  Lumped-Basin Model 
The lumped-basin model captures the hydrologic elements, their connectivity, 
and related geographic information in an ASCII text file that can be read by 
HMS.  This basin model should be used for a hydrologic model with lumped, 
not distributed, basin parameters.  

• Select HMS ⇒ Lumped-Basin Model. 

 
• Make a note of the file name and its location.  Press OK. 

 

Task III.  Hydrologic Modeling System 

8.  Setup an HEC-HMS model with inputs from HEC-GeoHMS 

A.  Directory Setup 

• Create the HMS project first, and then copy the background-map file, 
basin-model file, and grid-cell parameter file, if appropriate, into 
D:\hmsproj\ ProjAmer. 

 
 

B.  HMS Setup 
• Start the HMS program. 
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• Select File ⇒ New Project. 

• Enter the Project as “ProjAmer” and Description as “GIS Application of 
HEC-GeoHMS to the American River Basin”. 

 
• Press OK. 

 

• Import the Basin Model on the HMS * Project Definition window, select 
Component ⇒ Basin Model ⇒ Import. 

 
• Navigate to “D:\hmsproj\ ProjAmer”. 

• Select “ProjAmer” under the Basin ID. 
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• Press Import. 

• Specify the background-map file by selecting File ⇒ Basin Model 
Attributes. 

• To specify the Map File, press on “Browse…” button. 

• Navigate to the “D:\hmsproj\ ProjAmer” and select the file “Mapfile.map”. 

 
 

• Press OK. 
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The basin model and the background-map files are brought into HMS resulting 
in the following HMS Basin Schematic. 

 

 
The subbasin and routing elements parameters are then input via HMS editors.  
That information may be available from previous studies and/or a new regional 
analysis by calibrating the model to gaged storms and then relating model 
parameters to physical characteristics of the subbasins.
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APPENDIX B 
 

 

Background-Map File Format 
 

 

Watershed boundaries and stream lines can be displayed as a 
background for hydrologic elements on the Basin Model screen.  
The use of a background map is optional and not required for any 
calculations.  This appendix describes the background-map file 
format.  The file can be produced using available geographic 
information system (GIS) tools. 

 

File Definition 
 

Watershed boundary and stream line features are both defined in 
the same file, which is in plain ASCII format.  Each feature type is 
contained in a separate section of the file; it is not important which 
section is first in the file.  Each section begins with the keyword 
"MapGeo" followed by a colon and either "BoundaryMap" or 
"RiverMap" (Figure B-1). 

 

A map segment defines a list of map coordinates that are 
connected by a line.  A closed segment defines a polygon and an 
open segment defines a line.  Closed segments are used for 
watershed boundaries and open segments are used for stream lines.  
Each segment begins with the keyword "MapSegment" followed 
by a colon and either "Closed" or "Open."  The last coordinate in a 
closed segment is automatically connected to the first coordinate. 

 

Segment coordinates are defined with x-y pairs.  Map features are 
automatically scaled in the Basin Model screen.  Coordinates are 
therefore independent of projection, units, and offset.  All 
segments must be in the same coordinate system. 
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Figure B-1. Sample background map file. 

 

 

 

 

 

MapGeo:  BoundaryMap 

MapSegment:  closed 

 582242.875000, 4174922.500000 

 582220.875000, 4174961.500000 

 582205.625000, 4175013.750000 

 581981.000000, 4174672.750000 

 582025.812500, 4174696.250000 

 582068.812500, 4174711.000000 

MapSegment:  closed 

 582810.125000, 4174024.500000 

 582874.687500, 4173973.750000 

 582950.687500, 4173902.750000 

 582554.000000, 4174000.250000 

 582667.687500, 4174003.750000 

 582810.125000, 4174024.500000 

MapGeo:  RiverMap 

MapSegment:  open 

 582750.187500, 4176706.000000 

 582687.000000, 4176594.000000 

 582657.375000, 4176468.500000 

 582613.125000, 4176359.500000 
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APPENDIX C 
 

 

Grid-Cell Parameter File Format 
 

 

The ModClark transform method requires a grid-cell file.  The file 
defines cells for each subbasin.  Parameters for each cell are also 
included in the grid-cell file.  This appendix describes the grid-cell 
file format.  The file can be produced using available geographic 
information system (GIS) tools. 

 

File Definition 
 

The grid-cell file begins with the keyword "Parameter Order" 
followed by a colon and parameter keywords indicating the order 
for reading parameters from the file (Figure C-1).  The keyword 
"End" must be on a line by itself after the "Parameter Order" line.  
Valid parameter keywords are shown in Table C-1.  Parameter 
keywords are not case sensitive and are separated by spaces.  If the 
parameter order is not defined, it is assumed to be: Xcoord Ycoord 
TravelLength Area.  The coordinate system of Xcoord and Ycoord 
used in the file must match the coordinate system used in the 
gridded DSS precipitation records.  Typically the coordinate 
system will be either Hydrologic Rainfall Analysis Project (HRAP) 
or Standard Hydrologic Grid (SHG). 

The data for a subbasin begins with the keyword "Subbasin" 
followed by a colon and the subbasin identifier.  One line 
beginning with the keyword "Grid Cell" follows for each cell in 
the subbasin.  Data for the subbasin ends with the keyword "End".  
Keywords are not case sensitive and may contain spaces.  Blank 
lines can be included and lines beginning with "#" are ignored as 
comments.  The same grid-cell file can be referenced by more than 
one subbasin, allowing data for many subbasins to be stored in the 
same file.  The identifier for a subbasin must be exactly the same 
in the grid-cell file as it is in the basin model. 
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Table C-1. Parameter keyword definitions. 

Keyword Definition Units 

XCoord x-coordinate of the southwest 
corner of the cell 

integer value 

YCoord y-coordinate of the southwest 
corner of the cell 

integer value 

TravelLength travel time index from the cell to 
the subbasin outlet 

kilometers 

Area area of cell within the subbasin square 
kilometers 

ScsCn SCS curve number of the cell real value 
(0.0-100.0) 

SmaUnit Soil moisture accounting unit 
name 

character 
string 

 

 

Figure C-1. Sample grid-cell parameter file.

 

Parameter Order: Xcoord YCoord TravelLength Area SCSCN 

End: 

Subbasin: 85 

Grid Cell: 633 359 88.38 3.76 

Grid Cell: 634 359 84.51 0.18 

Grid Cell: 633 358 85.55 16.13 

Grid Cell: 632 358 82.55 12.76 

Grid Cell: 625 348 13.75 12.07 

Grid Cell: 626 348 17.12 0.09 

Grid Cell: 622 347 21.19 3.26 

Grid Cell: 623 347 15.56 9.96 

End: 

Subbasin: 86 

Grid Cell: 637 361 59.13 6.79 

Grid Cell: 638 361 59.04 6.95 

Grid Cell: 636 361 56.68 1.17 
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A P P E N D I X  D  

 

 

Grids in HEC-DSS and HRAP and SHG Grid 
Systems 
 
Grids in HEC-DSS 

Contents of a Grid Record in HEC-DSS 

HEC-DSS records, including grid records, consist of a block of 
sequential data with an associated header array describing the data 
in the block.  In a time-series record, the sequence represents the 
variation of a parameter’s value through time at a fixed location.  
In a grid record, the sequence represents the variation of a 
parameter’s value over a region of the earth’s surface for a single 
interval of time.  The header array of a grid record contains 
information about the parameter values (their units and some 
summary statistics) and the two-dimensional array in which they 
are stored (the number of rows and columns in the array, and the 
location of the grid in geo-referenced coordinates).   

The contents of the header are described below for three types of 
grids.  All grid headers contain basic parameter and grid extent 
information.  In addition, the headers for HRAP grids and Albers 
equal-area grids (including SHG grids) contain additional 
descriptive information. 

 
Storage of Grid Values 

In the DSS file, grid parameter values are stored in a single array, 
starting with the value in the minimum-x, minimum-y (or lower 
left) cell in the two-dimensional array.  The values proceed by row 
in increasing column numbers and increasing row numbers, as 
illustrated in the figure below.  
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 7 8 9 

 1 2 3 4 5 6 7 8 9  4 5 6 

Array 1 2 3 

 grid 

 

Figure.  One-Dimensional Array Storing Two-Dimensional Grid of Parameter Values 

The array of parameter values is always compressed before it is 
written to a DSS file.  Two compression methods are used.  One is 
a run-length encoding method, which replaces repeated zero values 
with the number of times zero was repeated.  The second method is 
the deflate method, which is included in the zlib library described 
in RFC 1950.  The deflate format itself is described in RFC 1951.   
The deflate format and zlib are included in Javasoft’s Java 
Development Kit version 1.1 and higher. 

 

 
Grid Header Contents 

The contents of the grid header array are as follows 

 

Field Type Size (integers) 

Info Flat Size Integer 1 

Grid Type Integer 1 

Grid Info Size Integer 1 

Start Time Integer 1 

End Time Integer 1 

Data Units Text 3 

Data Type Integer 1 

Lower Left Cell X Integer 1 

Lower Left Cell Y Integer 1 

Number of Cells X Integer 1 

Number of Cells Y Integer 1 
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Cell Size Float 1 

Compression Method Integer 1 

Compressed Array Size Integer 1 

Compression Scale Factor Float 1 

Compression Base Float 1 

Max Data Value Float 1 

Min Data Value Float 1 

Mean Data Value Float 1 

Number of Ranges Integer 1 

Range Limit Table Float 20 

Range Counts Integer 20 

HRAP Headers append the following 

Data Source Text 3 

Albers Headers (including SHG) append the following 

Projection Datum Integer 1 

Projection Units Text 3 

First Standard Parallel Float 1 

Second Standard Parallel Float 1 

Central Meridian Float 1 

Latitude of Origin Float 1 

False Easting Float 1 

False Northing Float 1 

X Coordinate of Cell (0,0) Float 1 

Y Coordinate of Cell (0,0) Float 1 
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HRAP Grid System 
The Hydrologic Rainfall Analysis Project (HRAP) grid is a square-
celled mapgrid based on a Polar Stereographic map projection with 
the following parameters. 

Units: Meters 

Datum: Sphere (radius = 6371.2 km) 

Standard Parallel: 60º 0’ 0” North 

Central Meridian: 105º 0’ 0” West 

 

The mesh (cell) size of the grid is 4.7625 km, and the grid Y axis is 
aligned parallel with the central meridian (105E W). The grid is 
registered so that the north pole lies exactly 400 cells in the 
positive X direction and 1600 cells in the positive Y direction from 
the grid origin. Equivalently, the lower left corner of cell number 
(401, 1601) is located at the north pole. 

Examples 

As examples of cell identification in the HRAP system, indices of 
cells containing points in the western US and the eastern US are 
given. 

Western US: 

The location 121º 45′ west, 38º 35′ north (near Davis, California) 
projects to 260,174 m easting, 2,143,782 m northing, in the 
specified polar stereographic projection. In the HRAP system the 
indices of the cell containing this point are  

i = 54 

j = 450 

 

Eastern US: 

The location 76º 30′ west, 42º 25′ north (near Ithaca, New York) 
projects to 4,410,804 m easting, 3,018,420 m northing, in the 
specified polar stereographic projection. In the HRAP system the 
indices of the cell containing this point are 

i = 926 

j = 633 
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SHG Grid System 
The standard hydrologic grid (SHG) is a variable-resolution 
square-celled map grid defined for the conterminous United States. 
The coordinate system of the grid is based on the Albers equal-area 
conic map projection with the following parameters. 

Units: Meters 

Datum: North American Datum, 1983 (NAD83) 

1st Standard Parallel: 29º 30’ 0” North 

2nd Standard Parallel: 45º 30’ 0” North 

Central Meridian: 96º 0’ 0” West 

Latitude of Origin: 23º 0’ 0” North 

False Easting: 0.0 

False Northing: 0.0 

Users of the grid can select a resolution suitable for the scale and 
scope of the study for which it is being used. For general-purpose 
hydrologic modeling with NEXRAD radar precipitation data, HEC 
recommends 2000m cells, and HEC computer programs that use 
the SHG for calculation will select this cell size as a default. HEC 
will also support the following grid resolutions: 10,000 m, 5,000 
m, 1,000 m, 500 m, 200 m, 100 m, 50 m, 20 m, 10 m. The grids 
resulting from the different resolutions will be referred to as SHG-
2km, SHG-1km, SHG-500m and so on.  A grid identified as SHG 
with no cell-size indication will be assumed to have 2km cells  

For identification, each cell in the grid has a pair of integer indices 
(i, j) indicating the position, by cell count, of its southwest (or 
minimum-x, minimum-y) corner, relative to the grid’s origin at 
96Ε W, 23Ε N. For example the southwest corner of cell (121, 
346) in the SHG-2km grid is located at an easting of 242000 m and 
a northing of 692000 m. To find the indices of the cell in which a 
point is located, find the point’s easting and northing in the 
projected coordinate system defined above, and calculate the 
indices with the following formulas. 

i = floor( easting / cellsize ) 

j = floor( northing / cellsize ) 

Where floor(x) is the largest integer less than or equal to x.
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Examples 

As examples of cell identification in the SHG system, indices of 
cells containing points in the western US and the eastern US will 
be given in the 1km, 2km, and 500 m SHG grids. 

 

Western US: 

 

The location 121º 45′ west, 38º 35′ north (near Davis, California) 
projects to -2185019 m easting, 2063359 m northing, in the 
specified Albers projection.  In the SHG-2km system the indices of 
the cell containing this point are 

i = floor( -2185019 / 2000 ) = floor( -1092.5 ) = −1093 

j = floor(  2063359 / 2000 ) = floor( 1031.7 ) = 1031 

 

In the SHG-1km grid the indices are (-2186, 2063), and in SHG-
500m they are (-4371, 4126) 

 

Eastern US: 

 

The location 76º 30′ west, 42º 25′ north (near Ithaca, New York) 
projects to 1583506 m easting, 2320477 m northing, in the 
specified Albers projection.  In the SHG-2km system the indices of 
the cell containing this point are 

i = floor( 1583509 / 2000 ) = floor( 791.8 ) = 791 

j = floor( 2320477 / 2000 ) = floor( 1160.2 ) = 1160 

 

In the SHG-1km grid the indices are (1583, 2320), and in SHG-
500m they are (3167, 4640). 

 
References 

Hydrologic Engineering Center.  March 1995.  HEC-DSS User’s 
Guide and Utility Manuals (CPD-45).  US Army Corps of 
Engineers, Davis, CA. 
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A P P E N D I X  E  

Curve Number Grid Development 
The purpose of this appendix is to familiarize the users 
with the process of developing the curve number grid that 
is used as an input to GeoHMS for lumped and grid-
based curve number computation for the subbasin. The 
following new features under the Utility menu under the 
ProjView GUI will be described.  Other ArcView 
standard tools, such as conversion from polygon theme to 
a grid and the Geoprocessing Wizard will be discussed to 
help the user go through the five steps of curve number 
development. 
 

The new features in GeoHMS are circled in the above figure and are discussed below. 

Generate CN Theme 
 

This function computes a composite curve number for polygons in the CNPoly theme.  
The CNPoly theme is a polygon theme in which each polygon has a unique combination 
of land use and soil type.  

 

The CNPoly theme needs to have a field (Landuse) identifying the land use type and 
fields (Pcta, Pctb, Pctc, and Pctd) identifying percentage of hydrologic soil group.  The 
curve number values (CN) for each land use and hydrologic soil group are retrieved 
from a CN lookup table (in dbf format).  The user needs to develop their own CN lookup 
table.  In this table as shown below, the field "Value" contains the reference to the land 
use while fields A, B, C, and D contain the CN value for the different hydrologic soil 
groups (A, B, C, and D respectively).   

 



Appendix E  Curve Number Grid Development 

228 

 
The user will be asked to identify the CN lookup table each time the function is run.  
This provides the flexibility to compute a composite CN value for different conditions, 
by pointing to a different CN lookup table. 

 

The operation will add or update a user-specified field in the CNPoly theme.  The user 
will be prompted to specify whether to generate a new CN field, or to update an existing 
one.  If the user wants to create a new field, the user will have to provide a name for the 
field.  For updating the field, the user will have to select from the list of fields in the 
CNPoly theme.  This approach allows multiple CN fields to be associated with a single 
CNPoly theme.  For example, a set of CN fields might be created to identify normal, 
dry, and wet soil conditions. 

• UserDefinedField (SCSCN by default): Average CN value for each polygon in the 
CNPoly theme.  This average is computed based on the percent of hydrologic soil 
groups in the polygon (that has a unique land use type) and CN values from the 
lookup table.  The total percent of hydrologic soil groups in the polygon is always 
used for averaging, thus avoiding potential problems when the total percentages in a 
polygon do not add to 100.  It is best to account for all the hydrologic soil groups in 
a polygon to avoid potential problems in interpretation. 

 

It is the user responsibility to keep track on which CN field represents what conditions, 
and use it appropriately.  The CNPoly theme will be used to generate the CNGrid theme, 
using the standard Polygon to Grid conversion through the ArcView user interface.  
When doing this conversion, the user will be prompted to define the field whose values 
will be assigned to the newly created grid.  In case of CNGrid construction, this should 
be one of the CN fields.  When naming the new grid, it is recommended to use a 
descriptive name that will help identify what CN field conditions were used.  
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Generate LU/ST Grid 
 

The purpose of this function is to create a landuse/soil type grid that will be used to 
compute curve number grid statistics.  The resulting landuse/soil type grid is used in 
later step under the CN Basin Statistics.  This utility function generates a land use/soil 
type grid that is used as an intermediate step in the computation of CN basin statistics.  
This grid needs to exist before the CN basin statistics can be computed. 

 

This function requires three inputs: 

 

• HydroDEM grid 

• Curve number shapefile  

• Composite curve number field in the curve number shapefile ("Scscn" field – this 
field is picked by the user from the list of fields in the CNPoly theme at the time the 
function is executed).   There must be a field in the CNPoly theme called 
“SoilCode”.  The “SoilCode” field represents the soil type.  For example, when 
working with STATSGO data, the user should set the “SoilCode” field equal the 
“Muid” field. 

 

The function will perform the following operations: 

 

It will add or update the following field in the CNPoly theme: 

• Soil_lu: String obtained by concatenating the land use type ("Landuse" field), the 
soil type ("Unit_Id" field) if not blank, or hydrologic soil group letter if that field is 
blank, and the composite curve number ("Scscn" field). 

 

It will generate a land use/soil type grid, which has the same raster structure as the DEM 
grid.  The values in the grid correspond to “SOIL_LU” entry in the CNPoly theme. 

 

CN Basin Statistics 
 

This function generates a table containing curve number statistics for watersheds.  The 
function operates on a selected set of watersheds in the subbasin theme.  If no watershed 
has been selected, the function will process all the watersheds.  A results table is created 
in which for each watershed a set of unique land use/soil type combination is presented.  
For each of these combinations, a percent area in the watershed and CN are presented.  
This table can be used to identify which land use/soil type combination has the largest 
impact on the overall watershed curve number. 
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This function requires the following inputs: 

 

• Subbasin shapefile 

• Curve Number polygon shapefile 

• Soil landuse grid 

• CN field to use for classification ("Scscn"). 

 

This function generates a CN statistic table, which contains the following information: 

 

• WshID: Sub basin identifier. 

• Landuse: Land use type. 

• Soil: Soil type (hydrologic soil group or Unit_Id). 

• Scscn: Average CN value for the subbasin, for a given land use and soil type. 

• Cum_Area: Area of the subbasin having the given land use and soil type. 

• Area_Pct: Percentage of the area of the sub basin having the given land use and soil 
type. 

 

Five steps of Data Processing for Curve Number Grid Developement 

The data processing part of the curve number grid development are separated in five 
steps shown in the figure below. 
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Step 1: Processing soil types 
 

The two commonly used soil data sources are State Soil Geographic (STATSGO) and 
Soil Survey Geographic (SSURGO) soil database.  These soil data sources are provided 
by the Natural Resources Conservation Service (NRCS).  The STATSGO data types are 
coarser than the SSURGO data.  Comparing the STATSGO and SSURGO data as 
shown in the figures below shows that the STATSGO data has broader boundaries than 
the SSURGO data.  Often times, user will need to combine STATSGO and SSURGO 
together to have the best available data coverage of the study area. 

 

   
 STATSGO Database      SSURGO Database 

 

The user will find a variety of methods and software available for processing these soil 
database.   An example of soil processing performed with ArcInfo is discussed in 
Appendix F. 

 

Step 2: Merge soil data sources and create land use data 

 

The user will need to merge various soil databases by structuring tables with common 
fields.   Then the user will need to create or process land use data by digitizing land use 
data from areal photos and other sources. 

 

Then the user will need to union the merged soil data with the landuse data to create 
unigue combination of soil types and land use polygon theme.  The user may be able to 
use the Geoprocessing Wizard Extension from the ArcView 3.2 or later software 
package.  The Geoprocessing Wizard DOES NOT update the area field.  The user can 
use the following procedure to update the area of new polygons: 
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1) Run the geoprocessing wizard and do the union function. 

2) Open the table of the resulting theme and start editing it. 

3) Make the area field active. 

4) Open the field calculator (it will be computing the values for the Area field). 

5) Build the following expression: [Shape].ReturnArea 

6) Click on OK. 

 

There are other tools (public domain that can be downloaded from ESRI’s site) that do 
similar job that might update the area of the resulting polygons automatically. 

 

After performing step 2, the user should have a polygon theme containing unigue 
combination of land uses and soil types as shown the figures below.  In the middle of the 
figure below, the vertical line shows land use and the SSURGO soil data on the left and 
the STATSGO soil data on the right. 

 
 

The attribute table for the land use/ soil type polygon theme is shown below.  It shows 
the land use code in the “landuse” field with the percentage of hydrologic soil groups 
under fields “PctA”, “PctB”, “PctC”, and “PctD”. 
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Step 3: Curve Number Lookup 
The user can use GeoHMS to accomplish this step.  With the land use/ soil type 
combination polygon theme and a curve number lookup table, the user can apply the 
Generate CN Theme menu item under the Utility menu.  This step creates or updates a 
user-specified field with a curve number to each polygon as shown in the figure below 
based on the curve number lookup table.  The land use/ soil type combination polygon 
theme with the curve number field is now refered to as the curve number polygon theme. 

 

 

 
 

Step 4:  Conversion of Curve Number Polygon Theme into Curve Number Grid 
To convert the curve number polygon theme into a curve number grid, the user can use 
standard tool from the Spatial Analyst Extension.  The user can toggle off the GeoHMS 
extension to expose the Spatial Analyst Extension functionality. The user can set the 
analysis extent and cell size to be the same as the DEM under the Properties menu item 
under the Analysis menu.  With the curve number polygon theme active, the user can 
apply the Convert to Grid menu item under the Theme menu.   
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The user also needs to select a field to be used for the curve number value.  In the figure 
below, the “CN_Exist” field represents the curve number for existing condition was 
used for the curve number grid development. 

 
 
The user should choose “No” to not join the feature attributes to the grid as shown in the 
figure below.  The user should remember to toggle back to the GeoHMS extension. 

 
 

 
 

Step 5: Curve Number Grid 
The user should save the curve number grid.   To use the curve number grid for lumped 
and grid-based curve number computation for the subbasin, the user should add the 
curve number grid as a theme in the ProjView document.
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APPENDIX F 
 

 

Example - SCS Curve Number Computation 
Process 
 

This example, written by ESRI for the Wisconsin Department of Natural Resources, describes 
the procedures used to compute the SCS Curve Number data for Wisconsin in ArcInfo.  
Attempts were made to perform these procedures in ArcView; however, the sizes of the datasets 
were prohibitive.  ArcInfo is much more efficient at such processes.  The basic steps are: 

I.    STATSGO Preprocessing 
II.   SSURGO Preprocessing 
III. Soil Merging 
IV. Land Use Processing 
V. Curve Number Generation 

 

All coverages and tables used are in RED type and Courier New font.  All ArcInfo 
commands will be referenced with the Arc: prompt and in BLUE type.  Cnty or xxx in Italics 
refer to an individual county name or code. 

 

I. STATSGO Preprocessing 

Before merging the STATSGO and SSURGO data, they must have the same database 
structure.  The ‘WDNR-Flood Hydrology Tool’ will take a shapefile with the numeric 
fields ‘pctA’, ‘pctB’, ‘pctC’, and ‘pctD’ and compute a weighted average Curve Number 
based on the landuse and the CN lookup table.  First, the required fields must be created 
in STATSGO.  The STATSGO user manual should be read to understand the complex 
database design.  Basically, we can only determine the percent of each hydrologic soil 
group within each STATSGO polygon.  The lookup table with this information and final 
Statsgo coverage can be found at (J: = \\central\libraries): 

J:\gencov\cn\statsgo 
 

The original STATSGO data and related tables are located at: 

 STATSGO soil coverage = sgdpw92d  (statewide) 
Location:  /geo/wtm_data/geodb/wislib91/tile_1/sgdpw924 
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 STATSGO tables: 
Location: /geo/wtm_data/geodb/arcstorm/info_tables/1/info/sgdpw22d.mpu 

Location: /geo/wtm_data/geodb/arcstorm/info_tables/1/info/sgdpw22d.cmp 

 

The basic steps to compute the hydrologic soil group attributes are as follows: 
1. Add the field ‘Mu_hyd’ to the sgdpw22d.cmp table where ‘Mu_hyd’ = ‘Muid’ ++ 

‘Hydgp’. 

2. Summarize on the field ‘Mu_hyd’.  Include in the table ‘First_muid’, ‘First_hydgp’, 
and ‘Sum_comppc’.  This gives the sum percentage of each unique ‘Mu_hyd’ > 
summary.dbf. 

3. In the sgdpw22d.mpu table, add the fields ‘pctA’, ‘pctB’, ‘pctC’, ‘pctD’, 
‘pctA/D’, ‘pctB/D’, ‘pctC/D’ and calculate everything = 0. 

4. For each hydgp possibility, create a unique table by selecting one hydgp in 
summary.dbf and creating a new table so that there are seven unique tables (i.e. 
sum_a.dbf, sum_ad.dbf, sum_b.dbf, etc.).   

5. Join the first unique hydgp table (sum_a.dbf) to sgdpw22d.mpu.  Calculate ‘pctA’ 
= ‘Sum_comppc’.  Remove the join. 

6. Repeat step six for each unique hydgp table.  This will give the percentage of each 
hydrologic soil group within each ‘Muid’. 

7. The final ‘pctD’ column should contain the sum of ‘pctA/D’, ‘pctB/D’, ‘pctC/D’, 
and ‘pctD’.  Also, if the total percentages (A-D) do not add up to 100, then the 
remaining amount is added to pctD. 

8. The final table is called statsgohg.dbf.  For use in ArcInfo, permanent items 
‘pctA-D’ were added to sgdpw92d.pat.  Then the statsgohg.dbf table was 
related to the .pat to populate the items.  

 

II. SSURGO Preprocessing 
To simplify the SSURGO data, we will dissolve the polygons on the hydrologic soil 
group attribute.  The required coverages and tables include: 

 

 SSURGO soil coverage = cntypw9 (countywide) 
Location:  /geo/dnrdop/cty_soil/cnty_sl/cov/cntypw9 

 SSURGO hydrologic soil group lookup table = wixxxpro.txt 
Location: /geo/dnrdop/cty_soil/cnty_sl/tables/wixxxpro.txt 
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1. In ArcInfo, create a new workspace and copy all required coverages and tables to 
that location. 

2. Use ArcView 3.2 to convert the wixxxpro.txt table into an INFO table. 

• Start ArcView and add the .txt table to the project 

• Under Table > Properties, check off all fields except Musym and Hydgp 

• With the table active, select File > Export 

• Choose INFO as the export format  

• Navigate to the INFO directory in your workspace and name the table 
cntypw9.pro 

3. In ArcInfo, add a field to the SSURGO polygon attribute table for hydrologic soil 
group. 

Arc:  additem cntypw9.pat cntypw9.pat hydgp 11 11 c 

 

4. When relating tables, the relate fields must have the same name and field properties.  
Therefore, the Musym field in the cntypw9.pro table will have to be redefined to 
match that of the cntypw9.pat table (Note: All caps must be used in INFO, and 
the user name is ‘ARC’). 

Arc:  additem cntypw9.pro cntypw9.pro tmp 8 8 c # musym 

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTYPW9.PRO 

ENTER COMMAND >  IT       (Optional:  displays items in the selected table) 

ENTER COMMAND >  MOVE MUSYM TO TMP 

ENTER COMMAND >  LI MUSYM, TMP  (Optional:  displays values in the 
‘musym’ and ‘tmp’ fields) 

ENTER COMMAND >  Q STOP 

Arc:  dropitem cntypw9.pro cntypw9.pro musym 

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTYPW9.PRO 
ENTER COMMAND >  ALTER 

ITEM NAME >  TMP 

ITEM NAME >  MUSYM 

* Hit enter for the rest of the field properties 
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5. Next the cntypw9.pro table will be related to the cntypw9.pat table and the 
new hydgp field will be populated.  Then, for all records that do not contain a 
hydrologic group, hydgp will be populated with the musym code for record keeping 
(Note: still in INFO). 

ENTER COMMAND >  SEL CNTYPW9.PAT 

ENTER COMMAND >  RELATE CNTYPW9.PRO MUSYM ORDERED RO 

ENTER COMMAND >  MOVE $1HYDGP TO HYDGP 

ENTER COMMAND >  RESEL HYDGP = ‘’ 

ENTER COMMAND >  MOVE MUSYM TO HYDGP 

ENTER COMMAND >  Q STOP 

 

6. Dissolve each county based on hydgp. 

Arc:  dissolve cntypw9 cntydw9 hydgp poly 
(Note:  all dissolve coverages are stored in J:\gencov\cn\ssurgo) 

 

7. Delete the original coverage from the workspace. 

Arc:  kill cntypw9 all 

 

Update procedure for new SSURGO data is described in Appendix G. 

 

III. Soil Merging 

The SSURGO and STATSGO data must be merged into a seamless layer containing 
attributes of % A, B, C, and D hydrologic soil groups.  Ideally, this would be done 
statewide, but disk space was prohibitive.  Instead, the soil was processed in four major 
tiles and then clipped by basin for unioning with Wiscland.  The overall procedure is to 
union the SSURGO layers into one coverage, calculate the %A-D fields for SSURGO, 
remove the extent of the SSURGO coverage from the STATSGO layer, and union the 
STATSGO and SSURGO layers.  The required coverages include: 

 STATSGO soil coverage = sgdpw92d  (statewide) 
Location:  J:\gencov\cn\statsgo\sgdpw92d 

 SSURGO soil coverage = cntydw9 (countywide) 
Location:  J:\gencov\cn\ssurgo\cntydw9 

 Basin clip coverages = bsn-id_clip 
Location: J:\gencov\cn\basin_clip\cov\bsn-id_clip 
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1. The dissolved SSURGO coverages will be unioned into one coverage.  First, change 
the name of the ‘hydgp’ item in the second coverage so that it can be joined to the 
union.pat (union will not join items of the second coverage if that item name already 
exists in the first coverage).   

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTY2DW9.PAT 

ENTER COMMAND >  ALTER 

ITEM NAME >  HYDGP 

ITEM NAME >  HYDGP1 

* Hit enter for the rest of the field properties 

ENTER COMMAND >  Q STOP 

 

2. Union the first two SSURGO coverages into one layer. 

Arc:  union cnty1dw9 cnty2dw9 ssurgo1 # join 
 

3. Now populate the ‘hydgp’ field in the resulting coverage for those polygons added. 

Arc:  ae   (starts Arcedit module) 

Arcedit:  ec ssurgo1  (selects edit coverage) 

Arcedit:  ef poly  (specifies edit feature) 

Arcedit:  de poly  (specifies draw environment) 

Arcedit:  display 9999 

Arcedit:  draw  (Optional: may take some time for a large coverage) 

Arcedit:  sel hydgp = ‘’ (selects all records without hydgp attributes) 

Arcedit:  moveitem hydgp1 to hydgp 

 

4. The unioned coverage will most likely contain a number of sliver polygons at county 
boundaries that will not contain attributes.  Theoretically, one would identify the 
neighboring polygons of the sliver and attribute it with the appropriate soil group.  
However, this is not feasible due to the number of slivers encountered.  These slivers 
are attributed with some value (i.e. ‘NA’) for record keeping.  (Note: still in ArcEdit 
with the coverage selected.) 

Arcedit:  sel hydgp = ‘’  
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Arcedit:  ds (draw selected: make sure there are only slivers 
without attributes) 

Arcedit:  moveitem ‘NA’ to hydgp 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

 

5. Remove the unnecessary items from the .pat (do not remove the ‘ssurgo1#’ and 
‘ssurgo1–ID’ fields for the coverage!). 

Arc:  items ssurgo1.pat  (displays all items in the ssurgo1 polygon attribute   
      table) 

Arc:  dropitem ssurgo1.pat ssurgo1.pat cnty1dw9#, cnty1dw9-ID, cnty2dw9#, 
cnty2dw9-ID, hydgp1 

 

6. Repeat steps 8-13 for all SSURGO counties, this time using the previous union 
coverage as the input union coverage, i.e.: 

Arc:  union ssurgo1 cnty3dw9 ssurgo2 # join 

(Note:  Dane county contained significant overlap between Rock and Sauk counties 
and was clipped before union). 

(As mentioned, this process was carried out in four major tiles due to disk space.)  
The final coverage with all SSURGO data unioned into one will be referred to as 
unssurgo. 

 

7. Next determine the extent of unssurgo. 

Arc:  additem unssurgo.pat unssurgo.pat dslv 1 1 c  

Arc:  ae 

Arcedit:  ec unssorgo 

Arcedit:  ef poly 

Arcedit:  sel all 

Arcedit:  moveitem ‘y’ to dslv 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

Arc:  dissolve unssurgo ssrgoext dslv poly 
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(Note:  the statewide dissolved ssurgo extent (4-10-01) is stored in J:\gencov\cn\ssurgo) 

 

8. Next we will remove the SSURGO extent from the STATSGO layer (this will create 
a statewide STATSGO layer with ‘holes’ where SSURGO data exists).  Union the 
ssrgoext and sgdpw92d coverages. 

Arc:  union sgdpw92d ssrgoext statonly # join 

 

9. Now select all STATSGO polygons within the SSURGO extent and remove them. 

Arc:  ae 

Arcedit:  ec statonly 

Arcedit:  ef poly 

Arcedit:  de poly  

Arcedit:  display 9999 

Arcedit:  draw 

Arcedit:  sel dslv = ‘y’    (selects all polygons within the SSURGO boundary) 

Arcedit:  delete  (deletes all selected polygons and labels) 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

 
(Note:  the STATSGO layer with SSURGO extent removed is stored in J:\gencov\cn\statsgo) 

 

10. Add % A, B, C, and D hydrologic soil group fields to the unssurgo.pat. 

Arc:  additem unssurgo.pat unssurgo.pat pctA 3 3 i 

Arc:  additem unssurgo.pat unssurgo.pat pctB 3 3 i 

Arc:  additem unssurgo.pat unssurgo.pat pctC 3 3 i 

Arc:  additem unssurgo.pat unssurgo.pat pctD 3 3 i 

 

11. There are a number of possibilities for hydrologic soil group in the SSURGO data.  
Each polygon can have up to three different groups.  For example, ‘A-B-A/D’ would 
indicate that group A, group B, and group A/D soils were all found in that polygon.  
Since we do not know the percentages within a polygon, they will be split up evenly 
(giving the highest percentage to D, C, or B, as it is most conservative).  A/D 
indicates a soil behaves as A when drained, and D when undrained.  100 percent in 
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soil D is the most conservative in this case (assuming undrained).  For each unique 
hydr_gp, add the appropriate percentages to the four new fields.  Examples follow: 

 

HYD_GP PctA PctB PctC PctD 

A 100 0 0 0 

B 0 100 0 0 

C 0 0 100 0 

D 0 0 0 100 

A/D 0 0 0 100 

B/D 0 0 0 100 

C/D 0 0 0 100 

A-B 50 50 0 0 

A-C 50 0 50 0 

A-C/D 50 0 0 50 

A/D-C/D 0 0 0 100 

A-B-C 33 33 34 0 

A-B/D-A/D 33 0 0 67 

A-C-A/D 33 0 33 34 

None 0 0 0 100 

 

In ArcInfo, use the following commands: 

Arc:  additem unssurgo.pat unssorgo.pat done 1 1 c   

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL UNSSURGO.PAT 

ENTER COMMAND >  MOVE ‘N’ TO DONE  

ENTER COMMAND >  RESEL HYDGP = ‘A’ 

ENTER COMMAND >  CALC PCTA = 100 

ENTER COMMAND >  MOVE ‘Y’ TO DONE 

ENTER COMMAND >  ASEL   (selects all records) 

ENTER COMMAND >  RESEL HYDGP = ‘A-B’ 

ENTER COMMAND >  CALC PCTA = 50 
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ENTER COMMAND >  CALC PCTB = 50 

ENTER COMMAND >  MOVE ‘Y’ TO DONE 

ENTER COMMAND >  ASEL 

Etc. 

 

Do this for each major category (i.e. A, B, C, D, A/D, B/D, and C/D).  You do 
not have to do it for every possibility.  We can use the ‘Done’ field to 
keep track of which ones still need attributing. 

ENTER COMMAND >  ASEL 

ENTER COMMAND >  RESEL DONE = ‘N’ 

ENTER COMMAND >  LIST HYDGP (lists HYDGP values for selected 
records) 

 

By selecting the records not yet attributed (DONE = N) and using the LIST 
command, you can see which records are left.  Attribute all remaining 
records using the commands above.  All unknown values (NA, W, soil 
names carried over, etc.) should get ‘100’ in ‘pctD’. 

 

12. Next, Mapjoin the unioned SSURGO coverage with the statonly coverage.  In 
order to do this, the item definitions must be the same in both coverages. 

Arc:  items unssurgo.pat 

Arc:  items statonly.pat 

 
Compare the item definitions of both coverages.  Use the ADDITEM command to 
add the missing items from each coverage (and make sure they are in the same order 
– see additem usage).  I.e., 

Arc:  additem unssurgo.pat unssurgo.pat unit_id 7 7 c 

Arc:  additem statsonly.pat statsonly.pat hydgp 11 11 c 

Arc:  additem statsonly.pat statsonly.pat done 1 1 c 

 

Arc:  mapjoin mjsoil poly features 

Enter the 1st coverage:  unssurgo 

Enter the 2nd coverage:  statonly 

Enter the 3rd coverage:  end 
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13. This results in a final soil coverage with SSURGO data where available and 
STATSGO data elsewhere, and contains attributes of %A-D hydrologic soil group.  
Due to file size and processing limitations, the coverage should be clipped by basin. 

Arc:  clip mjsoil bsn-id_clip soil_bsn-id poly 

 
(Note:  the merged soil coverages clipped by basin are stored in J:\gencov\cn\soilmerge\bsn-
idcov\soil_bsn-id) 

 

IV. Land Use Processing 
 

The Wiscland land cover grid data must be reclassified to reduce redundant classes, 
converted into a polygon coverage, and clipped by basin before unioning with the soil data.  
The required layers are: 

 Wiscland land cover grid = wlcgw930  (statewide) 
Location:  K:\wlclib\wlcgw930\wlcgw930 

 Basin clip coverages = bsn-id_clip 
Location: J:\gencov\cn\basin_clip\cov\bsn-id_clip 

 

1. Identify the WWI classification of WLC (value).  For example, all of the forested 
classes will receive the same Curve Number, so classes 161-190 will be lumped into 
one category (see the cn_lookup.dbf table at J:\wtgislib\hydrology_tool\input_data). 

101 = High Urban 

104 = Low Urban 

105 = Golf Course 

110-118 = Agriculture 

124 = Forage Crops 

148 = Cranberry Bog 

150 = Grassland 

161-190 = Upland Forest 

200 = Open Water 

211-220 = Non Forested Lowland 

223-234 = Forested Lowland 

240 = Barren 

250= Shrubland 

255 = Cloud Cover 
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2. Add an item ‘WWI’ to wlcgw930.vat (full classification of WLC). 

Arc: additem wlcgw930.vat wlcgw930.vat wwi 3 3 I 

 
3. Calculate the new ‘WWI’ item to equal the following values: 

value 101 =  101 (High Urban) 

value 104 = 104 (Low Urban) 

value  105 = 105 (Golf Course) 

value 110-118 = 110 (Agriculture) 

value 124 = 124 (Forage Crops) 

value 148 = 148 (Cranberry Bog) 

value 150 =  150 (Grassland) 

value 161-190 = 161 (Upland Forest) 

value 200 =  200 (Open Water) 

value 211-220 =  211 (Non Forested Lowland) 

value 223-234 =  223 (Forested Lowland) 

value 240 = 240 (Barren) 

value 250 = 250 (Shrubland) 

value 255 = 255 (Cloud Cover) 

 

Arc: info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL WLCGW930.VAT 

ENTER COMMAND >  RESEL VALUE = 1O1 

ENTER COMMAND >  CALC WWI = 101 

ENTER COMMAND >  ASEL 

Etc. 
 

4. Create an info table to do a reclass. 

Arc: frequency wlcgw930.vat wlc.frq 

Enter the 1st item:  value 

Enter the 2nd item:  wwi 
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Enter the 3rd item:  end 

Enter the 1st item:  end 

 

5. Reclassify the grid with the info table option. 

Arc: grid 

Grid:  wwi_grid = reclass (wlcwg930, wlc.frq, nodata, value, wwi) 

Grid:  q 

 

6. Convert the reclassified grid into a polygon coverage. 

Arc: gridpoly wwi_grid wwi_poly 

 

7. Clip the polygon coverage by basin for intersecting with soil data. 
Arc:  clip wwi_poly bsn-id_clip wlc_bsn-id poly 0.001 

 
(Note:  the reclassified Wiscland coverages clipped by basin are stored in 
J:\gencov\cn\wiscland\bsn-idcov\wlc_bsn-id) 

 

V. Curve Number Generation 
 

The land cover and soil data must be unioned to provide unique polygons containing both 
land cover and soil information.  Then, the curve number is generated for each polygon, and 
the coverage converted into a grid for efficient processing with the HEC-GeoHMS Version 
1.1.  The required datasets are: 

 Wiscland land cover coverage = wlc_bsn-id  (basinwide) 
Location:  J:\gencov\cn\wiscland\bsn-idcov\wlc_bsn-id 

 Merged soil coverage = soil_bsn-id (basinwide) 
Location:  J:\gencov\cn\soilmerge\bsn-idcov\soil_bsn-id 

 Basin clip grids = bsn-id_clipg 
Location:  J:\gencov\cn\basin_clip\grid\bsn-id_clipg 

 

1. Union the soil and land cover coverages for each basin. 

Arc:  union soil_bsn-id wlc_bsn-id cnply_bsn-id # join 
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2. Check for sliver polygons resulting from the union and populate the soil properties. 

Arc:  ae 

Arcedit:  ec cnply_bsn-id  

Arcedit:  ef poly 

Arcedit:  sel pcta = 0 and pctb = 0 and pctc = 0 and pctd = 0 

Arcedit:  de poly 

Arcedit:  display 9999 

Arcedit:  ds   (draws selected polygons – should only be slivers) 

Arcedit:  moveitem ‘na’ to hydgp 

Arcedit:  calc pctd = 100 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

 

3. Generate the curve number theme using the ‘HEC-GeoHMS Version 1.1’ in 
ArcView.   

• Open ArcView and load the HEC-GeoHMS Version 1.1 extension 

• Open a new ProjView and add the cnply_bsn-id polygon theme 

• Open the theme table for cnply_bsn-id (with the theme active, choose 
Theme > Table) 

• From the Table menu, choose Properties 

• Scroll down and type Landuse as an alias to Grid-code and click OK 

• From the Edit… menu, choose Select All 

• Close the theme table and make the ProjView active  

• From the Utility menu, choose Generate CN Theme 

• When prompted for the CNPoly tag, choose cnply_bsn-id and click OK 

• Navigate to the Cn_lookup.dbf table and click OK (i.e. 
J:\wtgislib\hydrology_tool\input_data\cn_lookup.dbf) 

• If the error “Attempt to access record out of range 0” occurs, try again and it 
should work. 

 
(Note:  the CN polygon coverages clipped by basin are stored in J:\gencov\cn\CN_poly\bsn-
idcov\cnply_bsn-id) 
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4. Convert the CN polygon coverage into a grid using the grid module in ArcInfo.  
Make sure to set the extent and cell size to be equal to the clip grids. 

Arc:  grid 

Grid:  arctools 

• Click on Grid Tools from the ArcTools box and click OK 

• From the GridTools box, choose Analysis > Properties… 

• In the Grid Analysis Environment box, choose Grid… for the Cell size 

• Navigate to and choose the bsn-id_clipg grid and click OK 

• Again, choose Grid… for the Analysis window 

• Navigate to and choose the bsn-id_clipg grid and click OK 

• Click OK to close the Grid Analysis Environment box 

• From the GridTools box, choose ArcTools > Commands… 

• Type in the following command and hit enter: 

Cngrd_bsn-id = Int(polygrid(cnply_bsn-id, scscn, #, #, #)) 

• When it finishes processing, quite from the GridTools and ArcTools boxes 

 
(Note:  the CN grids clipped by basin are stored in J:\gencov\cn\CN_grid\cngrd_bsn-id) 
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A P P E N D I X  G  

UPDATE PROCEDURE FOR NEW SSURGO 
DATA 
 

Use the following procedure, written by ESRI for the Wisconsin Department of Natural 
Resources, to update the curve number data when new SSURGO data becomes available.  
The data is tiled by basin, so the following procedure must be carried out for all basins 
intersecting the new county.  See the document “CN Computation in AI.doc” for more 
information on these datasets.  The Wisconsin datasets are used as an example in the 
following procedure. 
All coverages and tables used are in RED type and Courier New font.  All ArcInfo 
commands will be referenced with the Arc: prompt and in BLUE type.  Cnty or xxx in 
Italics refer to an individual county name or code. 

First, map to the K: and J: drives: 

J:\\centralwwi\libraries 

K:\\centraletgo\libraries 

 

The required coverages and tables are: 

 New SSURGO soil coverage = cntypw9  
Location:  K:\cty_soil\cnty_sl\cov\cntypw9 

 New SSURGO boundary coverage = cntybw9 
Location:  K:\cty_soil\cnty_sl\cov\cntybw9 

 New SSURGO hydrologic soil group lookup table = wixxxpro.txt 
Location:  K:\cty_soil\cnty_sl\tables\wixxxpro.txt 

 Merged soil coverage = soil_bsn-id 
Location:  J:\gencov\cn\soilmerge\bsn-idcov\soil_bsn-id 

 Basin clip coverages = bsn-id_clip 

Location: J:\gencov\cn\basin_clip\cov\bsn-id_clip 

 Wiscland land cover polygon coverages = wlc_bsn-id  (basinwide) 
Location:  J:\genvcov\cn\wiscland\bsn-idcov\wlc_bsn-id 
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 Basin clip grids = bsn-id_clipg 
Location:  J:\gencov\cn\basin_clip\grid\bsn-id_clipg 

 
1.  In ArcInfo, create a new workspace and copy all required coverages and tables to that 
location. 

2. Use ArcView 3.2 to convert the wixxxpro.txt table into an INFO table. 

• Start ArcView and add the .txt table to the project 

• Under Table > Properties, check off all fields except Musym and Hydgp 

• With the table active, select File > Export 

• Choose INFO as the export format  

• Navigate to the INFO directory in your workspace and name the table 
cntypw9.pro 

3. In ArcInfo, add a field to the SSURGO polygon attribute table for hydrologic soil 
group. 

Arc:  additem cntypw9.pat cntypw9.pat hydgp 11 11 c 

 

4. When relating tables, the relate fields must have the same name and field properties.  
Therefore, the Musym field in the cntypw9.pro table will have to be redefined to 
match that of the cntypw9.pat table (Note: All caps must be used in INFO, and 
the user name is ‘ARC’). 

Arc:  additem cntypw9.pro cntypw9.pro tmp 8 8 c # musym 

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTYPW9.PRO 

ENTER COMMAND >  IT       (Optional:  displays items in the selected table) 

ENTER COMMAND >  MOVE MUSYM TO TMP 

ENTER COMMAND >  LI MUSYM, TMP  (Optional:  displays values in the 
‘musym’ and ‘tmp’ fields) 

ENTER COMMAND >  Q STOP 

Arc:  dropitem cntypw9.pro cntypw9.pro musym 

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTYPW9.PRO 
ENTER COMMAND >  ALTER 
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ITEM NAME >  TMP 

ITEM NAME >  MUSYM 

* Hit enter for the rest of the field properties 

 

5. Next the cntypw9.pro table will be related to the cntypw9.pat table and the 
new hydgp field will be populated.  Then, for all records that do not contain a 
hydrologic group, hydgp will be populated with the musym code for record keeping 
(Note: still in INFO). 

ENTER COMMAND >  SEL CNTYPW9.PAT 

ENTER COMMAND >  RELATE CNTYPW9.PRO MUSYM ORDERED RO 

ENTER COMMAND >  MOVE $1HYDGP TO HYDGP 

ENTER COMMAND >  RESEL HYDGP = ‘’ 

ENTER COMMAND >  MOVE MUSYM TO HYDGP 

ENTER COMMAND >  Q STOP 

 

6. Dissolve the coverage based on hydgp. 

Arc:  dissolve cntypw9 cntydw9 hydgp poly 

(Note:  all dissolve coverages are stored in J:\gencov\cn\ssurgo) 

 

7. Delete the original coverage from the workspace. 

Arc:  kill cntypw9 all 

 

8. Next we will remove the extent of the new SSURGO coverage from each of the 
merged soil layers that intersect the county.  First, add an identifier (ssrgo) to select 
the new coverage area.  Then, union the cntybw9 and soil_bsn-id coverages. 

Arc:  additem cntybw9 cntybw9 ssrgo 1 1 c 

Arc:  ae 

Arcedit:  ec cntybw9 

Arcedit:  ef poly 

Arcedit:  moveitem ‘s’ to ssrgo 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

Arc:  union soil_bsn-id cntybw9 rmsoilbsn-id # join 
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9. Now select all STATSGO polygons within the new SSURGO coverage boundary and 
remove them. 

Arc:  ae 

Arcedit:  ec rmsoilbsn-id 

Arcedit:  ef poly 

Arcedit:  de poly  

Arcedit:  display 9999 

Arcedit:  draw 

Arcedit:  sel ssrgo = ‘s’    (selects all polygons within the SSURGO boundary) 

Arcedit:  delete  (deletes all selected polygons and labels) 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

 

10. Add % A, B, C, and D hydrologic soil group fields to the cntydw9.pat. 

Arc:  additem cntydw9.pat cntydw9.pat pctA 3 3 i 

Arc:  additem cntydw9.pat cntydw9.pat pctB 3 3 i 

Arc:  additem cntydw9.pat cntydw9.pat pctC 3 3 i 

Arc:  additem cntydw9.pat cntydw9.pat pctD 3 3 i 

 

11. There are a number of possibilities for hydrologic soil group in the SSURGO data.  
Each polygon can have up to three different groups.  For example, ‘A-B-A/D’ would 
indicate that group A, group B, and group A/D soils were all found in that polygon.  
Since we do not know the percentages within a polygon, they will be split up evenly 
(giving the highest percentage to D, C, or B, as it is most conservative).  A/D 
indicates a soil behaves as A when drained, and D when undrained.  100 percent in 
soil D is the most conservative in this case (assuming undrained).  For each unique 
hydr_gp, add the appropriate percentages to the four new fields.  Examples follow: 

 

HYD_GP PctA PctB PctC PctD 

A 100 0 0 0 

B 0 100 0 0 

C 0 0 100 0 
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D 0 0 0 100 

A/D 0 0 0 100 

B/D 0 0 0 100 

C/D 0 0 0 100 

A-B 50 50 0 0 

A-C 50 0 50 0 

A-C/D 50 0 0 50 

A/D-C/D 0 0 0 100 

A-B-C 33 33 34 0 

A-B/D-A/D 33 0 0 67 

A-C-A/D 33 0 33 34 

None 0 0 0 100 

 

 In ArcInfo, use the following commands: 

Arc:  additem cntydw9.pat cntydw9.pat done 1 1 c   

Arc:  info 

ENTER USER NAME >  ARC 

ENTER COMMAND >  SEL CNTYDW9.PAT 

ENTER COMMAND >  MOVE ‘N’ TO DONE  

ENTER COMMAND >  RESEL HYDGP = ‘A’ 

ENTER COMMAND >  CALC PCTA = 100 

ENTER COMMAND >  MOVE ‘Y’ TO DONE 

ENTER COMMAND >  ASEL   (selects all records) 

ENTER COMMAND >  RESEL HYDGP = ‘A-B’ 

ENTER COMMAND >  CALC PCTA = 50 

ENTER COMMAND >  CALC PCTB = 50 

ENTER COMMAND >  MOVE ‘Y’ TO DONE 

ENTER COMMAND >  ASEL 

Etc. 

 

 Do this for each major category (i.e. A, B, C, D, A/D, B/D, and C/D).  You do not 
have to do it for every possibility.  We can use the ‘Done’ field to keep track of which 
ones still need attributing. 
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ENTER COMMAND >  ASEL 

ENTER COMMAND >  RESEL DONE = ‘N’ 

ENTER COMMAND >  LIST HYDGP (lists HYDGP values for selected 
records) 

 
 By selecting the records not yet attributed (DONE = N) and using the LIST 

command, you can see which records are left.  Attribute all remaining records using 
the commands above.  All unknown values (NA, W, soil names carried over, etc.) 
should get ‘100’ in ‘pctD’. 

 

12. Next, Mapjoin the SSURGO coverage with the rmsoilbsn-id coverage.  In order 
to do this, the item definitions must be the same in both coverages. 

Arc:  items cntydw9.pat 

Arc:  items rmsoilbsn-id 

 
 Compare the item definitions of both coverages.  Use the ADDITEM command to 

add the missing items from each coverage (and make sure they are in the same order 
– see additem usage).  I.e., 

Arc:  additem cntydw9.pat cntydw9.pat unit_id 7 7 c 

 

Arc:  mapjoin mjsoil poly features 

Enter the 1st coverage:  cntydw9.pat 

Enter the 2nd coverage:  rmsoilbsn-id 

Enter the 3rd coverage:  end 

 

13. This results in a final soil coverage with SSURGO data where available and 
STATSGO data elsewhere, and contains attributes of %A-D hydrologic soil group.  
The coverage should then be clipped to the basin extent. 

Arc:  clip mjsoil bsn-id_clip soil_bsn-id poly 

 

(Note:  the new merged soil coverage clipped by basin should be stored in 
J:\gencov\cn\soilmerge\bsn-idcov\soil_bsn-id) 

 

14. Next, union the soil and land cover coverages for the basin. 

Arc:  union soil_bsn-id wlc_bsn-id cnply_bsn-id # join 
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15. Check for sliver polygons resulting from the union and populate the soil properties. 

Arc:  ae 

Arcedit:  ec cnply_bsn-id  

Arcedit:  ef poly 

Arcedit:  sel pcta = 0 and pctb = 0 and pctc = 0 and pctd = 0 

Arcedit:  de poly 

Arcedit:  display 9999 

Arcedit:  ds   (draws selected polygons – should only be slivers) 

Arcedit:  moveitem ‘na’ to hydgp 

Arcedit:  calc pctd = 100 

Arcedit:  q 

Keep all edit changes?:  y 

Do you really want to do this?:  y 

 

16. Generate the curve number theme using the HEC-GeoHMS Version 1.1 in ArcView.   

• Open ArcView and load the HEC-GeoHMS Version 1.1 extension 

• Open a new ProjView and add the cnply_bsn-id polygon theme 

• Open the theme table for cnply_bsn-id (with the theme active, choose 
Theme > Table) 

• From the Table menu, choose Properties 

• Scroll down and type Landuse as an alias to Grid-code and click OK 

• Close the theme table and make the ProjView active  

• From the Edit… menu, choose Select All 

• From the Utility menu, choose Generate CN Theme 

• When prompted for the CNPoly tag, choose cnply_bsn-id and click OK 

• Navigate to the Cn_lookup.dbf table and click OK (i.e. 
J:\wtgislib\hydrology_tool\input_data\cn_lookup.dbf) 

• If the error “Attempt to access record out of range 0” occurs, try again and 
it should work. 

 

(Note:  the CN polygon coverages clipped by basin are stored in 
J:\gencov\cn\CN_poly\bsn-idcov\cnply_bsn-id) 
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17. Convert the CN polygon coverage into a grid using the grid module in ArcInfo.  
Make sure to set the extent and cell size to be equal to the clip grids. 

Arc:  grid 

Grid:  arctools 

• Click on Grid Tools from the ArcTools box and click OK 

• From the GridTools box, choose Analysis > Properties… 

• In the Grid Analysis Environment box, choose Grid… for the Cell size 

• Navigate to and choose the bsn-id_clipg grid and click OK 

• Again, choose Grid… for the Analysis window 

• Navigate to and choose the bsn-id_clipg grid and click OK 

• Click OK to close the Grid Analysis Environment box 

• From the GridTools box, choose ArcTools > Commands… 

• Type in the following command and hit enter: 

Cngrd_bsn-id = Int(polygrid(cnply_bsn-id, scscn, #, #, #)) 

• When it finishes processing, quite from the GridTools and ArcTools boxes 

 

(Note:  the CN grids clipped by basin are stored in 
J:\gencov\cn\CN_grid\cngrd_bsn-id) 

 

18. Make sure to update all revised data layers in J:\gencov and the CN grid in 
J:\wtgislib\hydrology_tool\bsn-id_base.  Notify all ‘WDNR-Flood Hydrology Tool’ 
users of the new datasets. 
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A P P E N D I X  H  

 

Frequently Asked Questions and Corrections 
 
Frequently Asked Questions 
 
1. What projections and spheroids are supported in GeoHMS? 

Answer  Projection support in GeoHMS is important when the users intend to 
perform distributed modeling with ModClark transformation method.  
When the user wants to create a grid cell parameter file for ModClark, 
GeoHMS will project the subbasin boundary shapefiles to the precipitation 
grid projection, which can be SHG or HRAP.  GeoHMS will then overlay 
the subbasin boundary shapefiles with the selected precipitation 
projection.  Finally, GeoHMS will reproject the intersected subbasin 
boundaries back to the original projection.   

In GeoHMS Version 1.0, only the Albers Equal-Area projection with 
spheroid of GRS1980 was available.   

In GeoHMS Version 1.1, projection support has been expanded to include 
Universal Tranverse Mercator (UTM), Tranverse Mercator, Lambert, and 
the State Plane and the following spheroids - GRS1980, WGS84, WGS72, 
SPHERE, CLARKE1880, CLARKE1866, KRASOVSKY,  INT1909, 
EVEREST, BESSEL, AUSTRALIAN, and AIRY. 

 
2. Why does my ModClark grid cell parameter file not work when I update to a new 

version of HMS? 

 

Answer The ModClark grid cell parameter file produced using GeoHMS Version 
1.0 will NOT work with the current HMS Version 2.2.  TheHMS grid cell 
parameter file format has changed in Version 2.2.  The only change is the 
heading for the curve number data; it is now “SCSCN” instead of 
“CurveNumber”, see following figures.  To correct this, change the 
keyword “CurveNumber” to “SCSCN”.   

GeoHMS Version 1.1 produces the ModClark grid cell parameter file in 
the new format that is compatible with the current HMS Version 2.2. 
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 New Format of the ModClark grid cell parameter file 

 

 
Old Format of the ModClark grid cell parameter file 

 

3. When trying to create the ModClark cell parameter file, I sometimes encounter the 
following error messages.  What do they mean? 

• No Intersecting records found 

• Need VAT in zone grid … 

• Zonal statistics program failed 

Answer The projection file (prj.adf) is necessary when performing the ModClark 
grid cell parameter file step.  If the user does not have the projection file or 
uses an unsupported projection in GeoHMS, they will get an error 
message.  To solve this problem, the user should verify the existence of a 
projection file (prj.adf) as part of the metadata for the terrain prior to 
analysis in GeoHMS to avoid the program prompting for it during 
execution.  The user should check that the projection and spheroid in the 
prj.adf file is supported by GeoHMS as shown in the figures below. 
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 Location of the Projection file (prj.adf) in the grid folder 

 

 
Content of the projection file – Check for support for the projection and spheroid 

4. Can I adapt the profile tool to plot other grid values along a line? 

Answer   Yes, the profile tool by default plots the DEM values along a stream but it 
can be used to plot values of any grid along a line theme.  To use this 
feature, the user will need to select a grid and a line theme and then click 
on the plot profile tool. 
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5. Is the Fill Sinks operation the same in ArcView and ArcInfo? 

Answer  Conceptually the Fill Sinks operation works the same way in ArcView and 
ArcInfo.  However, the Fill Sinks operation in ArcView appears not to be 
as reliable as the Fill command in ArcInfo.  If the Fill Sinks operation fails 
in ArcView, then the user should try running it in ArcInfo.  The Fill 
command in ArcInfo is capable of processing larger grids and greater 
numbers of sinks than in ArcView. 

 
6. Once in a while, I encounter a dialogue box prompting me to decide if a stream 

segment is an outlet?   For example: Stream Processing  - Is this an outlet option 
1,2,3,4 ?  When and why does this dialogue come up? 

Answer  This can happen when doing the “Stream Segment Processing” in the 
“Terrain Processing” menu.  As one of several stream segment processing 
steps, it is necessary to identify if a segment is an outlet or not.  An outlet 
is a segment that “drains” to the outside of the area of interest.  In most 
cases, we can identify this automatically based on the flow accumulation 
grid and from-to node orientation of the segment.  Where this approach 
fails is in areas with very short stream segments (basically one cell) where 
from and to nodes fall in the same grid cell and thus there is no distinction 
in flow accumulation between from and to nodes. 

 

Getting the one-cell stream segments does not happen often, and usually in 
the following cases. 

1) when dealing with small grids and small thresholds 

2) with DEMs that drain to flat areas 

3) with DEMs that include the buffer zone around the main area of 
interest that actually do not contribute to the main flow 

 
7. What should I do when I encounter a problem with processing the terrain in the Full 

Delineation Setup? 

Answer When the user encounters a problem with processing the terrain with the 
Full Delineation Setup, then the user should consider a step-by-step 
approach, which allows the user to check for problems and respond to 
program inquiries for additional information.  As an example, sometimes 
the program asks the user if a point is an outlet?  The user will need to 
answer some of these program inquiries before a preliminary watershed is 
generated. 
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8.  What are the future plans for updating GeoHMS from ArcView 3.x to ArcGIS 8.x? 

Answer HEC-GeoHMS Version 2.0 will be based on the ArcGIS 8.x platform or 
higher.  Currently, the internal “framework” library and terrain 
preprocessing capability are being programmed in ArcGIS 8.x or higher.  
Future work are as follows: 

 

• Migration to ArcGIS 8 – The rest of the GeoHMS 1.1 code will be 
ported in the ArcGIS 8.x platform or higher with the ArcHydro Data 
Model. 

 

• Comprehensive stream and watershed characteristics - GeoHMS will 
extract a more comprehensive list of stream and watershed 
characteristics to facilitate hydrologic parameter estimation and 
regional regression analysis for gaged and ungaged basins. 

 

• Hydrologic Parameter estimation – GeoHMS will facilitate users with 
tools and procedures to estimate unit hydrograph, loss rates, routing 
parameters, and snow melt parameters to support both lumped and 
distributed basin modeling. 

 

• Meteorologic Model – GeoHMS will develop meteorologic models 
based on gage weighting methods supported in HMS, such as Thiessen 
polygon and inverse distance.  In addition, GeoHMS will implement 
precipitation weighting techniques that account for orographic affects. 

 

• Data Storage System (HEC-DSS) connection – Users will be able to 
connect to DSS and access DSS and grid-based DSS files from 
GeoHMS to visualize hydrographs at gages and grid-based 
precipitation.  Users will be able to track both the spatial and temporal 
variation of precipitation. 

 

• Digital Dozer Terrain Data Assembly – The Digital Dozer software 
package is an ArcGIS extension for editing grid data.  This extension 
allows the user the edit the terrain data to better reflect the field 
conditions.  Digital terrain data in grid format is compiled using many 
different sources and technologies.  Recognizing the need to combine 
these data into one coherent and representative terrain model for the 
watershed, GeoHMS will provide support for an interface with a 
newly created DEM editing software for DEM assembly and editing. 
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Corrections 
 

1. There is a correction on page 72 in the GeoHMS Version 1.0 User’s Manual, July 
2000.  The third sentence in section entitled “Method 3:  Basin Subdivision on 
Tributary” contains an error.   

 

Original:   Clicking on the delineation point with the Point Delineation tool 
delineates a subbasin at a specified point not on the existing stream, traces 
a new stream, and splits the existing stream at the confluence.” 

 

Corrected: Clicking on the delineation point with the Basin Subdivision tool 
delineates a subbasin at a specified point not on the existing stream, traces 
a new stream, and splits the existing stream at the confluence.” 

 

2. There is a correction on page 33 in the GeoHMS Version 1.0 User’s Manual, July 
2000.  The second entry in Table 5-2 contains an error. 

 

Original: Spheroid: Clarke 1866 

 
Corrected: Spheroid: GRS1980 
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A P P E N D I X  I  

 

 

Program License Agreement 
 

 

Use of the program is governed by a license agreement.  The 
program can not be used unless the user accepts the terms of the 
agreement.  This appendix gives the full text of the program 
license agreement. 

 

License Text 
 

This HEC documentation and software was developed at U.S. 
Federal Government expense and is therefore in the public domain.  
Components of the HEC software were developed using 
proprietary commercial software.  The commercial portions of the 
HEC software may be purchased from the commercial vendors.  
Further, the agreements require that users accept the provisions of 
the copyright restrictions of the commercial software components 
as noted in the following paragraphs.  Please read and accept the 
provisions by so indicating. 

 

Copyright©  1996 ArcView GIS and Spatial Analyst Extension by 
Environmental Research Institute System, Inc.  All Rights 
Reserved. 

 

BY USING OR COPYING THIS SOFTWARE, USER AGREES 
TO ABIDE BY THE COPYRIGHT LAW AND ALL OTHER 
APPLICABLE LAWS OF THE U.S., INCLUDING, BUT NOT 
LIMITED TO, EXPORT CONTROL LAWS, AND THE TERMS 
OF THE FOLLOWING LICENSE AGREEMENT.  
HYDROLOGIC ENGINEERING CENTER SHALL HAVE THE 
RIGHT TO TERMINATE THIS LICENSE IMMEDIATELY BY 
WRITTEN NOTICE UPON USER'S BREACH OF, OR 
NONCOMPLIANCE WITH, ANY OF ITS TERMS.  USER MAY 
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BE HELD LEGALLY RESPONSIBLE FOR ANY COPYRIGHT 
INFRINGEMENT THAT IS CAUSED OR ENCOURAGED BY 
USER'S FAILURE TO ABIDE BY THE TERMS OF THIS 
LICENSE. 

 

License Agreement 
 

Hydrologic Engineering Center ("HEC") grants to the user the 
rights to install HEC-GeoHMS (the "Software") (either from a disk 
copy obtained from HEC, a distributor or another user, or by 
downloading it from a network) and to use, copy and/or distribute 
copies of the Software to other users, subject to the following 
terms and conditions: 

 

All copies of the Software received or reproduced by or for user 
pursuant to the authority of this License Agreement will be and 
remain the property of HEC. 

 

User may reproduce and distribute the Software provided that the 
recipient agrees to the terms of this License Agreement. 

 

No part of the Software may be exported or re-exported in 
contravention of U.S. export laws or regulations. 

 

THE SOFTWARE IS PROVIDED ON AS "AS IS" BASIS AND 
WITHOUT WARRANTY.  HEC DISCLAIMS ALL 
WARRANTIES, INCLUDING WITHOUT LIMITATION 
IMPLIED WARRANTIES OR MERCHANTABILITY, OF 
FITNESS FOR A PARTICULART PURPOSE AND OF 
FREEDOM FROM INFRINGEMENT OR RIGHTS OF 
OTHERS. 

 

HEC shall not be liable to any user for any damage or loss, 
including without limitation any indirect, consequential, special or 
exemplary damage or loss, whether or not advised of the 
possibility of such damage or loss. 

 

Upon request of HEC, the user will execute a written license 
agreement on the same terms and conditions here set forth. 
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This License Agreement constitutes the entire agreement between 
HEC and user relating to the Software, superseding all other 
agreements or representations, and is offered by HEC for 
acceptance only without modification in any respect, and will be 
deemed terminated without further notice upon any breach of its 
terms and conditions by user. 

 

U.S. Government Use.  Where the Products are being delivered to 
the U.S. Government under a U.S. Government contract or 
subcontract, use, reproduction and disclosure of the Products by 
the U.S. Government shall in the first instance, be subject to this 
Agreement.  To the extent that the U.S. Government is not bound 
by the terms and conditions of this Agreement, its use, 
reproduction and disclosure of the Products shall be subject to the 
restrictions set forth in (I) FAR 52.227-14, Alts., II and III, (ii) 
FAR 52.227-19, or (iii) DFARS 252.227-7013 © (1) (ii), as 
applicable.  For purposes of the FAR, the Products shall be deemed 
to be "unpublished" and licensed with disclosure prohibitions. 

 

BY ACCEPTING TO CONTINUE OPERATION OF THIS 
SOFTWARE, THE USER ACKNOWLEDGES ACCEPTANCE 
OF THIS LICENSE AGREEMENT AND EACH OF ITS TERMS 
AND CONDITIONS.
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