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Introduction 
 
 
This “Query Manual” consists of step-by-step instructions on how to query the 
ShoreZone database in both ESRI ArcGIS and Microsoft Access software 
platforms. The directions are accompanied by screen captures to help the user 
navigate the various data tables and windows in each software platform. Basic 
approaches to querying are defined and illustrated, from simple to complex, and 10 
examples are provided. Suggestions for troubleshooting and ways of ensuring the 
results are valid are also provided. The purpose of this guide is to empower a user 
who is familiar with the ShoreZone protocol and software platforms, so that the user 
can perform analytical queries of the database and can interpret the results. 
 
 
Specific query examples provided in this manual include: 
 

1. Determining the mapped distribution and shoreline length of the eelgrass (Zostera) 
bioband [ArcGIS Query]. 

2. Length summary of mapped shoreline types on the basis of BC Class [Microsoft 
Access Query]. 

3. Finding a digital still image that meets several criteria (BC Class, Shore Name, 
BioBand) [Microsoft Access Query]. 

4. Determining the mapped distribution of several shore types (BC Classes) [ArcGIS 
Query]. 

5. Determining the mapped distribution and shoreline length of the canopy kelps 
Macrocystis (giant kelp), Nereocystis (bull kelp), and Alaria fistulosa (dragon kelp) 
(MAC, NER, and ALF biobands) [ArcGIS Query]. 

6. Displaying multiple attributes: anthropogenic shorelines and shore modification 
features [ArcGIS Query]. 

7. Querying the Across-shore (Xshr) data to find shoreline with high marine debris 
potential [ArcGIS Query]. 

8.  Querying multiple tables to find Salt Marsh that is not associated with an Estuary 
[ArcGIS Query]. 

9. Extracting data from multiple tables using sub-queries to find Sandlance spawning 
habitat [ArcGIS Query]. 

10. Using a definition query to display selected attributes and make a simple map 
[ArcGIS Query]. 

 
 
In the GIS environment, these queries can then be used to produce a data table, a 
map (exportable as a JPG), or a new shapefile. The methods to achieve each of 
these actions will be described in the query examples. A sample Access database, 
GIS geodatabase, and ArcMap project for Southeast Alaska are included on a data 
DVD for use with this manual. 
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Note that FGDC-compliant metadata is included with the enclosed geodatabase. 
The metadata will define all tables and fields within tables, as well as briefly describe 
how the information was derived. Please refer to the ShoreZone Coastal Habitat 
Mapping Protocol (included on this Data DVD) for detailed information concerning 
methodology and definitions. 
 
To access the most up-to-data ShoreZone info please visit: 
http://alaskafisheries.noaa.gov/habitat/shorezone/szintro.htm 
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1. Determining the mapped distribution and shoreline length of the eelgrass 
(Zostera) bioband [ArcGIS Query] 
 
 
This first example will utilize ShoreZone data for Southeast Alaska housed in 
ArcGIS. It will illustrate how to create a new project, add data and basemaps, 
change the appearance of layers, run a simple query, export a shapefile of query 
results, calculate lengths, and view metadata. Subsequent examples will build on the 
tools you learn in these steps. 
 
 
• Open a new blank project in ArcMap 9.x 
• Click on the “File” menu and select “Add Data…” 
• Navigate to the location of the ShoreZone Personal Geodatabase. In this case, it 

is on the included disk in the folder “Query_Manual_GIS_Data.” Click once on 
the *.mdb file and select “Add.” 

• The “Add Data” window appears. Select the following data sets by holding down 
the CTRL key while clicking the file name with the mouse: 

- BioBand, BioUnit, Unit, and XShr data tables 
- Unit_lines feature class 

• Click “Add” 
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• Ensure the “Source” tab is selected on the bottom left hand side (shown by the 
red circle below). The screen display should resemble this: 
 

  
 
 

• Right click on the “BioBand” table and select “Open.” The “Attributes of BioBand” 
table will appear: 
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• Click on the “Options” drop-down menu on the lower right of the table (circled in 
red above). Select “Select by Attributes…” and the following window will open: 
 

 
 

• Note that the “Method:” line at the top of the box defaults to “Create a new 
selection.” Leave that option selected for this example. 

• Scroll down the list at the top of the table. The following steps will create query 
language in the SELECT FROM box: 
- Double click “ZOS” (the bioband that represents eelgrass) 
- Single-click “=” 
- Single-click the “Get Unique Values” button in the middle of the screen 

• A list of values that occur in the ZOS field will appear in the box above that 
button. In this case, there should be three values that appear (NULL, C, and P). 
To find records that have continuous eelgrass (occurrence in >50% of the unit), 
double click on the “C”.  

• Note that to find records with patchy eelgrass (occurrence in <50% of the unit), 
you would double click on the “P”. Continuous occurrence is used in this 
example. 
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• The query window should appear as this: 
 

 
 

• Note that you may also expand the query to select records (units) that have 
either continuous or patchy eelgrass by typing “ZOS” = ‘C’ or “ZOS” = ‘P’ into 
the query box. 

• Click “Apply” at the bottom of the window. 
• Scroll down to see selected records highlighted in blue. The number of records 

selected by this query is shown at the bottom of the table. In this example, 4,371 
out of 74,821 records have been selected. To see the total number of records in 
the table, click on the “>|” button (circled in red) at the bottom of the table. 
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• To calculate lengths or to view these records on the map, we must “relate” 
the BioBand attribute table to the unit_lines feature class that contains the spatial 
information. The necessary relationships are already constructed within 
ShoreZone geodatabases. Follow these steps: 

• Click on the “Options” drop-down menu at the bottom of the table and scroll up to 
“Related Tables”. A box will appear that lists the data tables related to the 
BioBand table. Select the relationship called “unit_lines_to_bioband_table.” 

• The “unit_lines” attribute table will open up with the records that have continuous 
eelgrass already selected. Scroll down to see them highlighted in blue. In this 
example, 3,657 records out of 21,186 have been selected. Record the first 
number for use during a later step. 

• Note that usually the number of selected records in the unit_lines feature class 
will be less than the selected records in the BioBand table. This is because a 
one-to-many relationship exists between them, in which each along-shore 
unit_lines (digitized shore segment) will have multiple across-shore “zones” 
associated with it (e.g. supratidal “A” zones, intertidal “B” zones or subtidal “C” 
zones). 

• To calculate the alongshore length of the selected units, right-click on the 
Shape_Length column header and select “Statistics.” The following box appears, 
showing the sum of the length of the selected features, along with other statistics: 
 

 
 

• The “Sum” is in meters. In this example, continuous eelgrass is mapped along 
980.0 km of shoreline. Record this length for use during a later step. 

• Note that when records are selected within a table (highlighted in blue), statistics 
are calculated for those selected units only. A subsequent step will illustrate 
how to calculate shoreline lengths for the entire table. 
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• Close or minimize the open windows and tables to view the spatial map with 
along-shore units having continuous eelgrass that have been highlighted by your 
query. Use the “Zoom” and “Pan” tools to investigate areas of interest. In the 
figure below, note that only mapped ShoreZone segments for the Southeast 
Alaska 2007 (and a small portion of the 2008) dataset is visible. A shoreline 
basemap is not shown. 
 

 
 
 

• To add a shoreline basemap as a layer in the view, select File>Add Data and 
navigate to the “alaska_63360_poly.shp” shapefile. 

• Note that the Alaska polygon shapefile is added to the layer pane along the left 
side of the window, with the view box checked. The next step will show you how 
to change the appearance of this basemap. 
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• To change the appearance of the basemap, double-click on the layer name to 
open the properties window (or right click on the layer name and select 
“Properties…” from the pop-up menu). Click on the “Symbology” tab. The 
following window appears: 
 

 
 

• Double click on the colored box below “Symbol” to select fill and outline colors. 
Use the “Fill Color:” drop-down box to select a color to represent the land. Also 
set the outline width and color to represent the shoreline. Click “OK.” 

• In the example below, the fill color has been set to “Yucca Yellow,” and the 
outline has been set to “Gray 50%” with a width of 0.40.  Use the zoom tools to 
zoom in and out if you like. 
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• To create a shapefile of the continuous eelgrass selection, right-click on the 
“unit_lines” layer, scroll to “Data” and select “Export Data...”  The following 
window appears: 
 

 
 
• Note that the “Export:” line at the top of the box defaults to “Selection features.” 

Leave that option selected for this example. 
• The “Use the same coordinate system as:” option defaults to “this layer’s source 

data.” Leave that option selected. 
• In the “Output shapefile to feature class:” drop down menu, click on the browse 

button (folder icon just to the right of the filename box). Browse to the folder in 
which you want to save the shapefile. Name the shapefile appropriately (such as 
“se2007_08_continuous_eelgrass.shp”). 

• Leave the “Save as type:” drop down menu to its default setting of “Shapefile” 
and click “OK” twice. 

• You will now be asked “Do you want to add the exported data to the map as a 
layer?” Click yes to add it. 

• Right click on the new shapefile and select “Open Attribute Table.” These are the 
attributes taken from the unit_lines shapefile for only the records you selected in 
your query. At the bottom of the table you will be able to see how many records 
have been exported to this new shapefile. Compare this number to the number 
you recorded after your selection query (3,657). If they match, the query and 
export steps were done correctly. 

• Right click on the Shape_Length column header and select “Statistics.” As long 
as no records are selected in the attribute table, the statistics returned will be for 
the entire attribute table. Compare the sum of the lengths to the number you 
recorded after your query to confirm they are the same (980.0 km).   
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• Note that the unit_lines feature class represents the digitized shoreline segments 
that have been “mapped” according to the ShoreZone Protocol. Click once on the 
unit_lines feature class to highlight it. Use the “Clear selected features” icon on 
the toolbar (or right click on unit_lines, scroll down to “Selection” and select 
“Clear selected features”). The highlighted blue segments will disappear from the 
map. 

• To calculate the total length of all mapped data, right click on the unit_lines 
layer, open the attribute table, right click on the “Shape_Length” column header, 
and select “Statistics.” Because no records are selected, the statistics returned 
represent all the data that has been mapped in Southeast during the 2007 (and a 
small portion of 2008) project. In this case, the shoreline mapped is 6234.5 km. 
Close the tables. 

• To view the metadata for the unit_lines feature class, right-click on the 
“unit_lines” layer, scroll to “Data” and select “View Metadata.” The following 
window appears with information concerning the feature class. The “Spatial” tab 
provides the coordinate system and projection information. The “Attributes” tab 
defines the fields (columns) within the attribute table. 
 

 
 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_1.mxd), along with the continuous eelgrass shapefile 
(named “se2007_08_continuous_eelgrass.shp”). Compare these results to yours. 
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2. Length summary of mapped shoreline types on the basis of BC Class 
[Microsoft Access Query] 

 
 
While ArcGIS geodatabases enable both spatial and quantitative analysis of 
ShoreZone data, it is also possible to perform simple, non-spatial queries of 
Microsoft Access databases to generate statistics for particular attributes of interest. 
Access databases house individual, regional projects such as the mapping of 
imagery collected in Southeast Alaska in 2007. The Access database for this region 
is included with this query manual. 
 
This example will illustrate how to query the Access database for a summary of 
shoreline lengths by shore type (BC Class), and how to obtain a list of digital still 
photos that represent a particular class. See Table A-2 in the ShoreZone Protocol 
for the definitions of these 35 shore types. 
 
 
• Open the Microsoft Access database named: 

ShoreZone_SE07_Dec09.mdb inside the “Query_Manual_MS_Access_Data” 
folder. 

 
• A list of “Tables” housed within the database appears: 
 

 
 
• Note that there are data tables and basic definition tables. Please refer to the 

ShoreZone Coastal Habitat Mapping Protocol for the Gulf of Alaska 2008 for 
details regarding the tables and the fields within them. A PDF of this protocol is 
included on the Data DVD provided with this query manual. 
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• Click on the “Queries” option on the left sidebar. Double-click “Create query in 
design view.” A “Show Table” box will appear.  Select the “Unit” table. The 
window should appear as this: 
 
 

 

 
 

• Click “Add” and “Close.” 
• The “Query1: Select Query” box will appear. 
 
• In the “Query1: Select Query” box, click once on the “Unit” table and scroll down 

to “BC_CLASS.” Click and hold “BC_CLASS” and drag it into the first column of 
the query grid. 
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• In the query grid, the “Field:” row should read “BC_CLASS” and the “Table:” row 
should read “Unit” as shown in the red oval on the previous page. 

• Click and hold “LENGTH_M” in the Unit table and drag it into the second column 
of the query grid.  

• Once “LENGTH_M” is in the second column, right click on it and choose 
“Properties”.   The “Field Properties” window will open.  To make the results 
easier to read use the drop-down menus to set the Format to “Standard” and the 
Decimal Places to “1”. 

 

 
 

• Close the Field Properties window and click the “Totals” button (Σ icon shown by 
the small red circle on the previous page). This adds a “Total: Group By” row to 
the query grid. 

• Click in the “Group By” box under the LENGTH_M column to make it active. A 
downward arrow appears, indicating a drop-down menu is available. Click on the 
arrow and select “Sum” from the drop-down menu. The query window should 
appear as this: 
 

 
 

• Run the query by clicking on the “Run” icon in the tool bar (exclamation point 
shown by the red circle above). 
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• The result is a window that lists the BC Class from 1 to 35 (BC 20 and 35 are 
missing since they were not mapped in this dataset) and the sum of the shoreline 
length (in meters) for each of those classes. 
 

 
 

• Right click on the top of the window and select “Query Design” to return to the 
query grid. To save the query, choose File > Save as from the menu bar. 

• In the “Answers” folder, you will find a query named “query_BC_Class_Length” to 
which you can compare your final query to check that you have done this 
correctly. To bring this query into your active database and compare them, select 
File>Get external data>Import and navigate to the database in the “Answers” 
folder. Click once on the file “ShoreZone_SE07_Dec09.mdb” and select “Import.” 

• An “Import Objects” window will appear. Under the “Queries” tab, select the 
“query_BC_Class_Length” query and click “OK.” Use the design view to compare 
the two queries. 

• Note: This data table could now be brought into Excel (example at right) and 
displayed using a Histogram which is a useful way to visualize the data. 
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3. Finding a digital still image that meets several criteria (BC Class, Shore 
Name, BioBand) [Microsoft Access Query] 

 
 
This example will enable you to find the name and location of a digital still photo that 
meets criteria you specify in a query. It will build on what you learned in Microsoft 
Access from Example 2. 
 
 
• Close the previous query, create a new blank one in design view, and add the 

Photos and Unit table. 
• Drag “BC_CLASS” from the Unit table down into the first column of the query 

grid. 
• Drag “SlideName” from the Photos table down to the second column of the query 

grid. 
• Drag “LENGTH_M” from the Unit table down to the third column of the query grid. 
• Drag “PHY_IDENT” from the Unit table down to the fourth column of the query 

grid. 
• Click in the ”Criteria” box under the BC_CLASS heading, type “31” and press the 

tab key. Note that you do not need the quotation marks around 31. Including 
quotes will cause a “Data type mismatch” error. 

• In the “Criteria:” box under the “SlideName” column, type “Is Not Null” and press 
the tab key. The “Query1: Select Query” window should appear as this: 
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• Run the query by pressing the exclamation point icon on the menu bar. The 
result is a list of all the digital still photos that correspond to a shore unit mapped 
as a BC Class 31 (organic shorelines and estuaries). Note that there are 2,221 
images that meet these criteria! 

• To become more selective in your search for a representative photo, right click 
on the top of the window and select “Design View” to return to the query grid. In 
the criteria box under LENGTH_M, type: 
 
>500 
 
and press the tab key. 
 

• When you run this query, it will return just those units mapped as BC Class 31 
that are over 500 meters in length. This query returns 1,718 records. 

• Out of these 1,718 photos, we want to find one of a unit that also has continuous 
eelgrass mapped in it (the ZOS band). Right click on the top of the window and 
select “Query Design” to return to the query grid. 

• Click on the “Query” menu at top and select “Show Table…” and the “Show 
Table” window will open, select the BioBand table.  Click “Add” and then “Close”. 

• From the BioBand table, click and drag the “ZOS” field down to the fifth column of 
the query grid. In the “Criteria:” box beneath ZOS, type “C” and press the tab key. 

• The query box should resemble this: 
 

 
 
 
• Run the query. The result should be 421 records of *.jpg images that are mapped 

as BC Class 31, are over 500 meters in length and have continuous (“C”) 
eelgrass mapped in them. 

• The PHY_IDENT field enables you to identify the location of an image in ArcGIS. 
• This query is saved as “query_Photo_Class31_>500meters_Eelgrass” in the 

“Answers” database. Compare the query to yours. 
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4. Determining the mapped distribution of several shore types (BC Classes) 
[ArcGIS Query] 
 
 
This example will use ArcGIS to illustrate how to add to perform a series of nested 
queries that add to, select from, or remove from the current selection. This example 
involves selecting all wide sediment-dominated flats by querying for BC Class 24, 
27, 28 and 29. It then illustrates how to remove certain records from the selection. 
 
 
• Open your ArcGIS project file from Example 1 (or the 

“Query_Manual_Example_1.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Right click on the “Unit” table and select “Open.” The “Attributes of Unit” table will 

appear. 
• Click on the “Options” drop-down menu on the lower right of the table and 

choose “Select by Attributes.” The following window will open: 
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• The “Method:” line at the top of the “Select by Attributes” box defaults to “Create 
a new selection.” Leave that option selected for this step. 

• The following steps will create query language in the SELECT FROM box: 
- Scroll down the list at the top of the table to see all the fields. 
- Double click “BC_CLASS”  
- Single-click “=” 
- Single-click the “Get Unique Values” button in the middle of the screen 

• A list of values that occur in the BC_CLASS field will appear in the box above 
that button. In this case, there should be numbers from 1 to 35 (Refer to table A-
2 in the ShoreZone Coastal Habitat Mapping Protocol for the Gulf of Alaska 
2008). Double click on “24.” 

• Click “Apply” at the bottom of the window. 
• Scroll down to see selected records highlighted in blue. The number of records 

selected by this query is shown at the bottom of the table. These are units that 
have been mapped as BC Class 24, or wide sand and gravel flats (3,975 units 
out of 24,682 are selected). 

• To view these records on the map, we must “relate” the Unit attribute table to 
the unit_lines feature class that contains the spatial information. The necessary 
relationships are already constructed within ShoreZone geodatabases. Follow 
these steps: 

• Click on the “Options” drop-down menu at the bottom of the table and scroll up to 
“Related Tables”. A box will appear that lists the data tables related to the Unit 
table. Select the relationship called “unit_lines_to_unit_table.” 

• The “unit_lines” attribute table will open, with the records that have been mapped 
as BC Class 24 already selected (2,292 out of 21,186). 

• Note that the number of selected records in the unit_lines feature class will 
usually be less than the selected records in the Unit table. This is because the 
query performed on the Unit table also selected variants (point features such as 
streams) that were mapped as BC Class 24. (Point features have no length.) 

• If you minimize the attribute table you will be able to see the selected shoreline. 
Use the zoom tools to zoom in and out of areas of interest. 

• Right click on the “Unit” table and open the “Attributes of Unit” table again. It 
should still have the 3,975 records that we queried for BC Class 24 selected. 

• We would also like to add BC Class 27 (wide sand beaches) to this selection. 
Click on the “Options” drop-down menu on the lower right of the table. Choose 
“Select by Attributes…” again. 

• This time click on the drop down list beside the “Method:” line at the top of the 
window and select “Add to current selection.” 

• This time we want to enter: 
"BC_CLASS" = 27 
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• Click “Apply” at the bottom of the window. 
• The “Attributes of Unit” table now shows all units that are classified as BC Class 

24 or 27 (4,023 out of 24,682). 
• To view these records on the map, choose Options>Related Tables> 

“unit_lines_to_unit_table” as you did above. Minimize the windows to see the 
selections on the map. 

• We also wish to add wide sand flats and wide mud flats to this selection (BC 
Classes 28 and 29). Open the Unit attribute table and click on the “Options” drop-
down menu on the lower right of the table. Choose “Select by Attributes…” to see 
the “Select by Attribute” window. 

• Ensure the drop-down list beside the “Method:” line at the top of the window 
shows “Add to current selection.” 
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• Click on the “Clear” button to clear the text in the SELECT box in order to write a 
fresh query. Then do the following: 
- Double-click “BC_CLASS” 
- Single-click “=” 
- Type “28” (without the quotation marks) 
- Single-click “Or” 
- Double-click “BC_CLASS”            
- Single-click “=” 
- Type “29” (without the quotation marks) 

• This example illustrates that you can use the “Get Unique Values” button just or 
simply type your selection in the box. Your query window should resemble this: 
 

 
 

• Click “Apply” at the bottom of the window. 
• The “Attributes of “Unit” table appears, with the units mapped as BC Class 24, 

27, 28, or 29 selected (4,190 out of 24,682). 
• Relate the Unit table to the unit_lines feature class to view the spatial locations 

of these units. The unit_lines table should show fewer units selected (2,375 units 
out of 21,186). Recall that this is because “point features” are contained in the 
Unit table but not in the unit_lines feature class. 



 22

• To test that this is the reason for the difference, we will remove the point features 
from the Unit table selection and see if it then matches the unit_lines selection. 
Minimize the unit_lines attribute table. 

• At the bottom of the “Attributes of Unit” table, click “Options,” choose “Select by 
attributes.” Change the “Method:” line at the top of the table to read “Remove 
from current selection.” 

• Highlight and clear the query script in the SELECT window and do the following: 
- Double-click “TYPE” 
- Single-click ”=” 
- Single-click “Get Unique Values” (note that the choices are ‘L’ and ‘P’) 
- Double-click ‘P’ 
- Click “Apply” 

• The “Attributes of Unit” table now shows only the “Line” features, not the “Point” 
features (2,375 out of 24,682 are selected). 

• Maximize the unit_lines attribute table again, and note that there are 2,375 
records selected. 

• Right-click on the Shape_Length field of the unit_lines table and choose 
“Statistics.” The sum of the lengths of these wide sediment flats is 840.2 km. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_4.mxd), along with the sediment flats shapefile 
(named “se2007_08_BC_class_24_27_28_29.shp”). Compare these results to 
yours. 

• Try running a query on the Unit table to “select from current selection” only those 
records that have a SHORENAME like ‘Edna*’ Hint: You should end up with the 
following script in the query box (noting the use of single quotes and the star sign 
to indicate a wild card): 
"SHORENAME" LIKE 'Edna*' 

• The query should show 16 records out of 24,682 selected and when viewed 
should highlight shore units in Edna Bay on Kosciusko Island.
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Map showing locations of “wide sediment-dominated flats” (BC Class 24, 27, 28 and 29).
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5. Determining the mapped distribution and shoreline length of the canopy 
kelps Macrocystis (giant kelp), Nereocystis (bull kelp), and Alaria fistulosa 
(dragon kelp) (MAC, NER, and ALF biobands) [ArcGIS Query] 
 
This example will use ArcGIS to illustrate how to select continuous and patchy 
mapped Macrocystis, Nereocystis, and Alaria fistulosa.  Most BioBands are mapped 
as either null, continuous or patchy (NULL, C, and P). This example will explore 
using all these values in the query language to get the results. 
 
• Open your ArcGIS project file from Example 4 (or the 

“Query_Manual_Example_4.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Right click on the “BioBand” table and select “Open.” The “Attributes of BioBand” 

table will appear. 
• All BioBands (with the exception of VER) are mapped as either null, continuous 

or patchy (NULL, C, and P).  Biobands can be queried by either looking for 
continuous and patchy occurrences or by utilizing the null values in the query; we 
will do both in this example. 

• Click on the “Options” drop-down menu on the lower right of the table and 
choose “Select by Attributes.” The query window will open with the “Method” line 
defaulting to “Create a new selection”.  Leave that option selected for this 
example. 

• The following steps will create query language in the SELECT FROM box: 
- Scroll down the list at the top of the table to see all the fields. 
- Double click “MAC”  
- Single-click “IS” 
- Single-click the “Get Unique Values” button in the middle of the screen 

• A list of values that occur in the MAC field will appear in the box above that 
button. In this case, there will be the values “NULL”, ‘C’ and ‘P’. 
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• Double click “NULL” , your query should look like this: 
 

 
 
 
• Click “Apply” at the bottom of the window. 
• All records that do not have MAC mapped have been selected.  There should be 

70,358 out of 74,821 selected. 
• Close the “Select by attribute” window and click on the “Options” tab at the 

bottom of the Bioband table.  Scroll up and select “Switch Selection”.  This will 
switch the selection and choose all the records that were not chosen before so 
that now all records with continuous (“C”) or patchy (“P”) MAC will now be 
selected.  There should be 4,463 out of 74,821 records selected. 

• We now have all records with continuous or patchy MAC selected but we also 
wish to add records that have continuous or patchy NER mapped. 

• Click on the “Options” drop-down menu on the lower right of the table and 
choose “Select by Attributes.  The query window will open with the previous 
query still in the “Select *FROM BioBand Where:” box.  Click on the “Clear” tab to 
get rid of this previous query. 
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• Click on the drop down list beside the “Method:” line at the top of the window and 
select “Add to current selection.” 

 
• The following steps will create query language in the SELECT FROM box: 

- Scroll down the list at the top of the table to see all the fields. 
- Double click “NER”  
- Single-click “IS” 
- Single-click “NOT” 
- Single-click the “Get Unique Values” button in the middle of the screen 

• A list of values that occur in the NER field will appear in the box above that 
button. In this case, there will be the values “NULL”, ‘C’ and ‘P’. 

• Double click “NULL”, your query should look like this: 
 

 
 
• Click “Apply” at the bottom of the window. 
• By using the query “NER” IS NOT NULL, all other records have been selected.  

All records with a “C” or a “P” in the NER field have been added to our selection.  
There should be 8,459 out or 74,821 records selected. 
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• Note that some selected records will now have a NULL value in either the MAC 

or NER field.  However the other field of interest (MAC or NER) should have a C 
or P in it.  This query has now selected units that have either continuous or 
patchy MAC, or units that have continuous or patchy NER.  A unit does not need 
to have both of MAC and NER to be selected in this query. 

• We now have all records with continuous or patchy MAC and continuous or 
patchy NER selected but we finally wish to add records that have continuous or 
patchy ALF mapped. 

• Open the “Select by Attributes” window again by clicking on the “Options” tab at 
the bottom of the BioBand table. Once this window is open click on the “Clear” 
tab to get rid of the previous query from the “SELECT *FROM BioBand WHERE:” 

• Ensure that “Add to current selection” is selected in the “Method” drop-down 
list at the top. 

• The following steps will create query language in the SELECT FROM box: 
- Scroll down the list at the top of the table to see all the fields. 
- Double click “ALF”  
- Single-click “=” 
- Single-click the “Get Unique Values” button in the middle of the screen 

• A list of values that occur in the ALF field will appear in the box above that 
button. In this case, there will be the values “NULL”, ‘C’ and ‘P’. 

• - Double click “C” 
- Single click “OR” 
- Double click on “ALF”  
- Single-click “=” 
- Double click “P”, your query should look like this: 
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• Click “Apply” at the bottom of the window. 
• The query has now selected all records that have continuous or patchy MAC, 

continuous or patchy NER and continuous or patchy ALF.  There should be 
8,970 out of 74,821 records selected. 

• To view these records on the map, choose Options>Related Tables> 
“unit_lines_to_bioband_table” as you did above. Minimize the windows to see 
the selections on the map. 

• Maximize the unit_lines attribute table again and note that there should be 8,970 
records out of 21,186 selected.  

• Right-click on the Shape_Length field of the unit_lines table and choose 
“Statistics.” The sum of the lengths of these canopy kelps is 2,591.8 km. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_5.mxd), along with the canopy kelps shapefile (named 
“se2007_08_MAC_NER_ALF.shp”). Compare these results to yours. 

• This query can be run in one step, try the following expression or a combination 
of the following expressions.  You should come up with the same answer.  

- "MAC" IS NOT NULL OR "NER" IS NOT NULL OR "ALF" IS NOT NULL 
- "MAC" = 'C' OR "MAC" = 'P' OR "NER" = 'C' OR "NER" = 'P' OR "ALF" = 

'C' OR "ALF" = 'P' 
- "MAC" IS NOT NULL OR "NER" = 'C' OR "NER" = 'P' OR "ALF" IS NOT 

NULL
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Map showing distribution of Giant Kelp, Bull Kelp and Dragon Kelp (BioBands MAC, NER and ALF).
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6. Displaying multiple attributes: anthropogenic shorelines and shore 
modification features [ArcGIS Query] 
 
This example will use ArcGIS to illustrate how to select anthropogenic manmade 
shoreline.  Once manmade shoreline is selected it will also illustrate how to select 
shore modification features such as riprap or concrete bulkheads. 
 
• Open your ArcGIS project file from Example 5 (or the 

“Query_Manual_Example_5.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Right click on the “Unit” table and select “Open.” The “Attributes of Unit” table will 

appear. 
• Click on the “Options” drop-down menu on the lower right of the table and 

choose “Select by Attributes.” The query window will open with the “Method” line 
defaulting to “Create a new selection”.  Leave that option selected for this 
example. 

• The following steps will create query language in the SELECT FROM box: 
- Scroll down the list at the top of the table to see all the fields and enter the 
following query: 
"BC_CLASS" = 32 OR "BC_CLASS" = 33 
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• BC Class 32 indicates that the unit was mapped as anthropogenic man-made 
(permeable shoreline) and BC Class 33 indicates that the unit was mapped as 
anthropogenic man-made (impermeable) shoreline.  The intertidal zone must 
exhibit >50% human alteration in the intertidal zone. 

• To view only the selected records click on the “Selected” tab at the bottom of the 
“Attributes of Unit” table.  This will hide all the records that weren’t selected in the 
query.  There should be 60 out of 24,682 units selected. 

• The field “SM1_TYPE” contains a 2 letter code indicating the primary type of 
shore modification occurring within the unit: BR = boat ramp; CB = concrete 
bulkhead; LF = landfill; SP = sheet pile; RR = riprap and WB = wooden bulkhead. 
The field ‘SM2_TYPE” indicates the secondary type of shore modification while 
the field “SM3_TYPE” indicates the tertiary type. 

• One of the most common shoreline modifications is Riprap.  To find the units that 
have riprap mapped as their primary shoreline modification click on the “Options” 
tab and open the “Select by Attribute” window. 

• This time we want to set the “Method” line at the top to “Select from current 
selection” and enter the following query: "SM1_TYPE" = 'RR' 
Your query should look like this: 
 

 
 

• There should now be 20 out of 24,682 records selected. 
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• The estimated percent occurrence of the primary shore modification is indicated 
in the field “SM1_PCT”.  The data in this field is entered in tenths (i.e. “2” = 20% 
occurrence within the unit.  We might be interested in ShoreZone units where the 
alongshore is completely comprised of riprap, so we could query this field for the 
number 10.  That would mean that the unit is 100% riprap alongshore. 

• Open the “Select by Attribute” window again and “Clear” the previous query. 
• Again we want to set the “Method” line at the top to “Select from current 

selection” and enter the following query: "SM1_PCT" = 10 
Your query should look like this: 
 

 
 
• There should be 5 out of 24,682 units selected. 
• To view these units click on the “Options” tab, scroll up to “Related tables” and 

choose the “unit_lines_to_unit_table” relationship.  
• In the “Attributes of unit_lines” right click on the field name “Shape_Length” and 

scroll down to “Statistics”.  There is 1.6km of shoreline classified as 
anthropogenic man-made and comprised of 100% riprap in Southeast Alaska 
2007 mapping. 

• Try another query looking for units that are comprised of Concrete Bulkheads 
(CB) or Wooden Bulkheads (WB). 

 

Note: A ShoreZone unit 
can be mapped as having 
a 100% Shore 
Modification but not be 
classified as a BC Class 
32 or 33. The Shore 
Modification Percentage 
field refers to the 
“alongshore length” of the 
modification while the BC 
Class field refers to the 
“intertidal area” of man-
made modification within 
a unit. 
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• The above query can also be written in one step, paying attention to the 
brackets. 
([BC_CLASS] = 32 OR [BC_CLASS] = 33) AND [SM1_TYPE] = 'RR' AND 
[SM1_PCT] = 10 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_6.mxd), along with the riprap shapefile (named 
“se2007_08_RipRap_100%.shp”). Compare these results to yours. 
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Map showing ShoreZone units classified as having 100% RipRap. (Marble Island, Sea Otter Sound)
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7. Querying the Across-shore (Xshr) data to find shoreline with high marine 
debris potential [ArcGIS Query]. 
 
 
This example will use ArcGIS to find areas where marine debris tends to 
concentrate.  A good indication of this is to look for cut log deposits in the supratidal 
zone. Areas with larger concentrations of cut logs are considered to have a higher 
potential of containing marine debris than areas with fewer or no cut logs. 
 
• Open your ArcGIS project file from Example 6 (or the 

“Query_Manual_Example_6.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Right click on the “Xshr” table and select “Open.” The “Attributes of Xshr” table 

will appear. 
• Click on the “Options” drop-down menu on the lower right of the table and 

choose “Select by Attributes.” The query window will open with the “Method” line 
defaulting to “Create a new selection”.  Leave that option selected for this 
example. 

• First, we are interest in supratidal zones that are 30 meters or more in width.  
The different zones, supratidal (A), intertidal (B) and subtidal (C) are found by 
querying the ZON field (Refer to table A-10 in the ShoreZone Coastal Habitat 
Mapping Protocol for the Gulf of Alaska 2008).  In this case we are looking for 
zone A, so the following steps will create query language in the SELECT FROM 
box for this: 

- From the list at the top of the table enter the following query: 
 

"ZON" = 'A' AND "WIDTH" >= 30. 
 

• Click on apply and there should be 3,623 out of 74,821 units selected. 
• This is a good start, but many of these units will not have cut logs in them.  The 

materials code for cut logs is ‘At’. They are usually thrown into the supratidal 
zone during storm events and are consequently mapped as being on top of or 
overlaying the sediment and vegetation.  For example they might show up in the 
database as ‘At/Cbc’ which translate to “Anthropogenic logs overlying Clastic 
boulder and cobble. 

• To search for cut logs we can simple add to our above query.  Remembering that 
the * sign is a wildcard we can and the following to our query: 

 
AND [Mat1] LIKE 'At*' 
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• The query should now look like this: 
 

 
 
• This should now return 11 out of 74,821 records.  To view these units click on 

the “Options” tab, scroll up to “Related tables” and choose the 
“unit_lines_to_xshr_table” relationship.   

• Use the zoom tools to zoom into the map.  As expected, many of them are south 
facing units as indicated by the highlighted segments. 
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• 11 areas with high potential for marine debris is a good start, but we might also 

be interested in areas with moderate potential for marine debris.  A supratidal 
zone with cut logs and a width between 10 and 30 meters is considered to have 
moderate potential for catching marine debris.  To search for these records we 
need to alter the widths in our query. 

• Entering the following query will find supratidal zones greater than 10 meters but 
less than 30 meters in width. 

 
[ZON] = 'A' AND ([WIDTH] > 10 AND [WIDTH] < 30) 
 
Paying attention to the placement of the brackets is important, as is the fact that 
an “AND” is used between the widths instead of an “OR”.  If (“WIDTH" > 10 OR 
"WIDTH" < 30) had been used then all A zone records in the table would be 
selected because every A zone is over 10 meters in width (10 meters and up) yet 
every A zone is also below 30 meters in width (0 to 30 meters).  Using an AND 
picks out the width that are only between 10 and 30 meters. 

• The above query should select 2,530 out of 74,821 records. 
• Now add the language asking for cut logs: 
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• The above query should select 166 out of 74,821 records. To view these units 
click on the “Options” tab, scroll up to “Related tables” and choose the 
“unit_lines_to_xshr_table” relationship.  Again many, but not all, of them 
appear to be south facing pockets. 

• You can also search for areas with low potential for marine debris by searching 
for supratidal zones that are less than or equal to 10 meters in width. 

 
[ZON] = 'A' AND [WIDTH] <= 10 AND [Mat1] LIKE 'At*' 
 

• The above query should return 915 out of 74,821 records of low marine debris 
potential. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_7.mxd), along with the high marine debris potential 
shapefile (named “se2007_08_High_Marine_Debris_Potential.shp”). Compare 
these results to yours. 
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Map showing ShoreZone units with High Marine Debris Potential.
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8. Querying multiple tables to find Salt Marsh that is not associated with an 
Estuary [ArcGIS Query] 
 
This example will use ArcGIS to find Salt Marsh occurrence that is not associated 
with an estuary.  The data of interest for this query exists in both the BioBand and 
Unit tables, so this example will show how to access the data to get the required 
results. 
 
• Open your ArcGIS project file from Example 7 (or the 

“Query_Manual_Example_7.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Salt Marsh is a bioband and is mapped in the “BioBand” table in the field PUC 

(Puccinellia) as either null, continuous or patchy (NULL, C, and P).  
• Right click on the “BioBand” table and select “Open.” The “Attributes of BioBand” 

table will appear. 
• Click on the “Options” drop-down menu on the lower right of the table and 

choose “Select by Attributes.” The query window will open with the “Method” line 
defaulting to “Create a new selection”.  Leave that option selected for this 
example. 

• The simple query of [PUC] = 'C' will return all the records that have a continuous 
occurrence of PUC. 

• There should be 5,818 out of 74,821 records selected after executing the above 
query. 

• Next we would like to query the BC Class to find which of these above selected 
units are not associated with an estuary; however the BC_CLASS field is located 
in a different table. 

• The field of interest is “BC_CLASS” and it is located in the Unit table. 
• To open the Unit table click on the “Options” tab, scroll up to “Related tables” and 

choose the “unit_table_to_bioband_table” relationship.  The Unit table will 
open with 5,608 out of 24,682 records selected.  These selected records are 
records that have continuous PUC mapped in them. Note that the number of 
selected records in the Unit table is less than the selected records in the BioBand 
table because of a one-to-many relationship mentioned earlier in this manual. 

• Scrolling down the table by using the slider bar at the right and looking at the 
“BC_CLASS” field it shows that units with continuous PUC occur in a wide range 
of BC Classes, but a lot of them occur in units classified as BC Class 31 which 
indicates the salt marsh is occurring in an estuary. (Refer to table A-2 in the 
ShoreZone Coastal Habitat Mapping Protocol for the Gulf of Alaska 2008).   

• To select those units where continuous PUC does not occur in an Estuary 
click on the “Options” drop-down menu on the lower right of the table and choose 
“Select by Attributes.” The query window will open and at the top change the 
“Method” line to “Select from current selection”.   

• Next enter the query: 
[BC_CLASS] <> 31 
Noting that “<>” is the sign for “does not equal”. 
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• The “Select by Attribute” window should look like this: 
 

 
 
• Click the “Apply” button and the results should show 4,857 out of 24,682 records 

selected.  These are 4,857 records where continuous Salt Marsh (PUC) occurs 
along the open coastline rather than in an estuary.  To view these units click on 
the “Options” tab, scroll up to “Related tables” and choose the 
“unit_lines_to_unit_table” relationship. 

• There should now be 3,264 out of 21,186 records selected in the Unit_lines 
attribute table, the number of records dropped from 4,857 to 3,264 records 
because 1,593 of the records were point features and are not located in the 
unit_lines table. 

• Closing the tables we can observe where these selected features occur.  Use the 
Zoom and Pan tools to investigate areas of interest. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_8.mxd), along with the Salt Marsh that is not 
associated with an Estuary shapefile (named 
“se2007_08_PUC_not_in_Estuary.shp”). Compare these results to yours.
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Map showing Salt Marsh (PUC) that is not associated with an Estuary (BC Class 31) 
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9. Extracting data from multiple tables using sub-queries to find Sandlance 
spawning habitat [ArcGIS Query] 
 
This example will use ArcGIS to show how to use a sub-query (a query nested 
inside another query) to extract data stored in another table. The last example 
showed how to query data that was in both the BioBand and BioUnit tables but it 
involved multiple queries and steps.   A sub-query will allow us to find potential 
Sandlance spawning beaches using one query to access data stored in multiple 
tables. 
 
• Open your ArcGIS project file from Example 8 (or the 

“Query_Manual_Example_8.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Sandlance spawning habitat can be divided into five different classes of potential.  

low, moderately low, moderate, moderately high and high potential.  For 
simplicity sake we will start by finding low potential habitat and work our way up 
to high potential. 

• Low potential of Sandlance spawning is shoreline designated as BC Class 24, 
25, 27 and 28. (Refer to table A-2 in the ShoreZone Coastal Habitat Mapping 
Protocol for the Gulf of Alaska 2008 for details).  This info is found in the Unit 
table in the field BC_Class. 

• As previous examples showed, the Unit table can be queried for this info and 
then the Unit table could be related to the Unit_lines feature class to spatial view 
the results.  However it is possible to query the Unit_lines feature class for this 
info by using a sub-query that will extract this info from the Unit table through the 
built in geodatabase relationships.  This allows the data to be spatially viewed in 
one step. 

• All four tables (BioBand, BioUnit, Unit and Xshr) are related to the Unit_lines 
feature class through the field “Phy_Ident”; we will use this field in our query to 
extract the required data from these four tables while querying the Unit_lines 
feature class. 

• Right click on the “Unit_lines” feature class and select “Open.” The “Attributes of 
Unit_lines” table will appear. 

• Click on the “Options” drop-down menu on the lower right of the table and 
choose “Select by Attributes” and the query window will open.  

• Enter the following query paying close attention to the placement of brackets: 
 

[PHY_IDENT] in (select [PHY_IDENT] from unit where [BC_CLASS] = 24 OR 
[BC_CLASS] = 25 OR [BC_CLASS] = 27 OR [BC_CLASS] = 28) 
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• The above query might initially seem a little confusing to start with but it can 
easily be deciphered.  Looking inside the brackets or the sub-query, it is simply 
asking to select the “Phy_Ident” from the “unit” table where BC_Class equals 
24, 25, 27 or 28.  Outside the brackets (at the start of the query) it is simply 
calling on the relationship between the Unit table and Unit_lines feature class 
that is based on the field Phy_Ident. 

• Click “Apply” at the bottom of the query window and 4,001 out of 21,186 records 
should be selected and we can already spatially view them on the screen. 

• We can test that this query did what we expected by clicking on the “Options” tab 
at the bottom of the unit_lines attribute table and scrolling up to “Related tables” 
and choose the “unit_lines_to_unit_table” relationship.  The Unit table should 
open with 4,001 records selected.  Scrolling down the table we can see only 
records that are classified as BC_Class 24, 25, 27 or 28 are selected.  Note that 
there might be additional records classified as BC_Class 24, 25, 27 or 28 that are 
not selected, but they will all be “Type P” (point features) and we are only 
interested in “Type L” (line features) for this query. 

• 4,001 records or 1,213 km of low potential Sandlance spawning habitat. We can 
narrow our search by searching for how many of the above 4,001 records occur 
in Protected areas.  This will then give us moderately low Sandlance spawning 
potential. 

• The following needs to be added to the above query: 
 

AND [PHY_IDENT] in (select [PHY_IDENT] from biounit where [EXP_BIO] = 'P') 
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• Your query should look like this, paying close attention to the placement of 

brackets and quotation marks: 
 

 
 
• Click on “Apply” and there should now be 2,494 out of 21,186 records selected. 
• Again we can test that this query did what we expected it to by clicking on the 

“Options” tab at the bottom of the Unit_lines attribute table and relating back to 
the BioUnit table.  The BioUnit table should open with 2,494 records selected, all 
of them with an “Exp_Bio” of “P”. 

• Click on the “Options” tab at the bottom of the BioUnit attribute table and relate 
back to the Unit table.  The Unit table should open with 2,494 out of 24,682 
records selected, all of them with a “BC_Class” of 24, 25, 27 or 28. 

• The next step to narrow our query is to search for moderate Sandlance spawning 
potential.  This is defined by adding eelgrass (zostera or ZOS) in the intertidal (B 
zone) zone to the search.  This data is found in the BioBand table.  

• Add the following to your query paying very close attention to the placement 
of brackets and quotation marks: 

 
AND [PHY_IDENT] in (select [PHY_IDENT] from bioband where ([ZOS] = 'P' OR 
[ZOS] = 'C') AND ([CROSS_LINK] LIKE '*B*')) 
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• Of note in this query is that we are using the field “Cross_Link” to define that we 
are only interested in the “B” (intertidal) zone.  You will notice the values in the 
field “Cross_Link” all have an A, B or C in them.  A wildcard (*) is used to help us 
search for “B” (intertidal) zones. 

• Your query should look like this and it should now return 631 out of 21,186 
records. 

 

 
 

• You can test this third part of the query by querying the BioBand table with the 
following: 
([ZOS] = 'P' OR [ZOS] = 'C') AND ([CROSS_LINK] LIKE '*B*') 
You should get 1,824 out of 74,821 records. 
Note that you can not test the third part of this query by simply relating the 
Unit_lines feature class back to the BioBand table.  This is because it is a one-to-
many relationship based on the field Phy_Ident.  Every record that is selected in 
the Unit_lines table with relate to many records in the BioBand table and those 
records in the BioBand table will also include the A (supratidal) and C (subtidal) 
zones (remembering that we are only interested in the B zone). 
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• moderately high Sandlance spawning potential is found by adding shorelines with 
sand/pebble, pebble/sand, or sand listed as the primary material in the upper 
intertidal (B1 zone) zone.  This data is in the Xshr table and can be found by 
adding the following to your query. Again paying close attention to the 
placement of brackets and quotation marks. 

 
AND [PHY_IDENT] in (select [PHY_IDENT] from xshr where [ZON] = 'B' AND 
[COMPONENT] = '1' AND ([MAT1] = 'Csp/' OR [MAT1] = 'Cps/' OR [MAT1] = 
'Cs/' )) 
 
There should now be 18 out of 21,186 records selected. 

• high Sandlance spawning potential is found by adding shoreline with cut logs in 
the supratidal (A zone) zone to the query.  This data is also in the Xshr table and 
can be found by adding the following to your query: 

 
AND [PHY_IDENT] in (select [PHY_IDENT] from xshr where [ZON] = 'A' AND 
[MAT1] LIKE 'At/*') 
 

• Your final query should look like this, paying extremely close attention to the 
placement of brackets and quotation marks: 

 
[PHY_IDENT] in (select [PHY_IDENT] from unit where [BC_CLASS] = 24 OR 
[BC_CLASS] = 25 OR [BC_CLASS] = 27 OR [BC_CLASS] = 28) AND 
[PHY_IDENT] in (select [PHY_IDENT] from biounit where [EXP_BIO] = 'P') AND 
[PHY_IDENT] in (select [PHY_IDENT] from bioband where ([ZOS] = 'P' OR 
[ZOS] = 'C') AND ([CROSS_LINK] LIKE '*B*')) AND [PHY_IDENT] in (select 
[PHY_IDENT] from xshr where [ZON] = 'B' AND [COMPONENT] = '1' AND 
([MAT1] = 'Csp/' OR [MAT1] = 'Cps/' OR [MAT1] = 'Cs/' )) AND [PHY_IDENT] in 
(select [PHY_IDENT] from xshr where [ZON] = 'A' AND [MAT1] LIKE 'At/*') 
 

• There should now be a total of 2 out of 21,186 records that have high 
Sandlance spawning potential.  One in Edna Bay on Kosciusko Island and one 
in Karta Bay on the east side of Prince of Wales Island as noted by the red 
circles on the map below. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_9.mxd), along with the High Sandlance Spawning 
Potential shapefile (“se2007_08_High_Sandlance_Spawn_Potential.shp”). 
Compare these results to yours. 
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Map showing High Potential Sandlance Spawning habitat.
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10. Using a definition query to display selected attributes and make a simple 
map [ArcGIS Query] 
 
This example will use ArcGIS to show how to use a definition query on a layer and 
allow only a selected subset of a layer to be displayed.  Once the definition query is 
constructed, simple instructions on how to compose and export a map for use in a 
report or presentation will be explored. 
 
• Open your ArcGIS project file from Example 9 (or the 

“Query_Manual_Example_9.mxd” file provided in the “Answers” folder). 
• Click on the “Source” tab on the lower left to display the tables within the file 

geodatabase. 
• Right click on the Unit_lines feature class and then scroll and click on 

“Properties…” (Or simply double-click on the Unit_lines layer name). 
• The “Layer Properties” window will open. This window has eleven different tabs 

and allows for many different options to be explored.  For example, clicking on 
the “Source” tab give us valuable information about the projection of the layer.  
We can see that this layer is projected in an “Alaska Albers NAD 1983” 
projection. 

• The tab of interest to start this exercise is the “Definition Query” tab, so click on 
that one.  This window only gives one option, so click the “Query Builder…” tab 
and a familiar “Query Builder” window will open. 

• Revisiting query number 9 in this manual we’ll look for areas with Moderately 
High Sandlance Spawning potential.   

• Referring back to the previous example enter the query for looking for Moderately 
High Sandlance Spawning potential into the query box: 

 
[PHY_IDENT] in (select [PHY_IDENT] from unit where [BC_CLASS] = 24 OR 
[BC_CLASS] = 25 OR [BC_CLASS] = 27 OR [BC_CLASS] = 28) AND 
[PHY_IDENT] in (select [PHY_IDENT] from biounit where [EXP_BIO] = 'P') AND 
[PHY_IDENT] in (select [PHY_IDENT] from bioband where ([ZOS] = 'P' OR 
[ZOS] = 'C') AND ([CROSS_LINK] LIKE '*B*')) AND [PHY_IDENT] in (select 
[PHY_IDENT] from xshr where [ZON] = 'B' AND [COMPONENT] = '1' AND 
([MAT1] = 'Csp/' OR [MAT1] = 'Cps/' OR [MAT1] = 'Cs/' )) 
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• Click on “OK” and the “Layer Properties” box should now look like this: 
 

 
 

• Before closing this window, click on the “Symbology” tab and then click on the 
large tab with the line running through it under the word “Symbol”. 
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• The “Symbol Selector” window that was seen back in Example 1 in this manual 
will open.  Change the line color to red and increase the line width to 3. 

• Click “OK” twice to close both windows and we should see a familiar result that 
was also seen back in Example 9. 

• To check that this query worked, right click on the Unit_lines feature class and 
open the attribute table.  There should be 0 out of 18 records selected.  Looking 
back to Example 9, the query for Moderately High Sandlance spawning potential 
also came up with 18 out of 21,186 records.  This query has come up with the 
exact same answer, except now it only shows the 18 records of interest on the 
map while the other records are hidden from view. 

• To make a simple map, close the attribute table and click on the View menu at 
the top and scroll down and click on “Layout View”.  The view will change to the 
map laid out on a page that is ready to be printed.  For simplicity sake we will 
continue with the page in the “Portrait” orientation but note that the page can be 
changed to the “Landscape” orientation though the File menu and the “Page and 
Print Setup…” option. 

• The screen should look like the one below, with the red circles noting which tool 
to use (the Select Elements tool) and where to click and “drag” the data frame to 
a different size to fit a Landscape orientation if you so choose. 
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• This is a good start but it is a bit hard to see the areas of interest so use the 
“Zoom” tool to zoom into an area of interest to you.  Also, all good maps should 
have a north arrow, scale bar, title and legend. 

• Click on the Insert menu at the top and select “North Arrow”.  The “North Arrow 
Selector” window will open; select an arrow on the left and click “OK”.  That 
arrow will be placed on the map, use the “Select Elements” tool to “drag” the 
arrow into the top right corner of the map. 

• Again click on the Insert menu and select “Insert Scale Bar”.  The “Scale Bar 
Selector” window will open; select a scale bar on the left and click “OK”.  The 
scale bar will be placed on the map. It might appear a bit confusing to start with 
so right click on it and choose “Properties” (or simply double click on the scale 
bar).  The “Alternating Scale Bar Properties” window will open.  The “Scale 
and Units” tab will let you adjust the scale and units to something that makes 
sense to you.  Also note that you can “drag” the edges of the scale bar to 
increase or decrease the distance it represents.  You can also add a border and 
a background in this window. When you are happy, “drag” the scale bar into the 
bottom right corner of the map. 

• Again click on the Insert menu and click on “Insert Title.”  A text box will appear 
on the map, type something like “Moderately High Sandlance Spawning 
Potential” into it. Then “drag” it to a position on the map that suits you, usually 
near the top.  Note that the “Properties” of this text box (accessed by double-
clicking on it) allows plenty more options including an option to add a border and 
background color. 

• Final click on the Insert menu and choose “Legend”.  The ‘Legend Wizard” will 
open.  If the “Unit_lines” and “Alaska_63360_poly” are the only layers that you 
have “checked” on the left side of you map, then they should be the only ones 
that show up in the “Legend Items” box on the right side of the Legend Wizard. 
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• Click “Next” and now we can add a title of your choice to the legend, leave the 
title as “Legend”, or simple delete it and have no title.  In this case we can leave 
the title as “Legend”. 

• Click “Next” and we can now add a border and background color to the legend 
which if often nice when making maps. 

• The next few options we won’t worry about in this example because they are very 
detailed options, so click “Next” twice more and then “Finish”. 

• The legend is now placed on the map; drag it down into the bottom left corner. 
• Finally, double click on the Unit_lines feature class and then on the “Symbology” 

tab.  In the box next to the words “Label appearing next to the symbol in table 
of contents:” type “Spawning Potential” and click “OK”. 
 

 
 

• Double-click on the “Alaska_63360_poly” feature class and do the same as 
above, typing “SE Alaska” into the box. 
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• The map should now look something like this: 
 

 
• To print the map click on the File menu and scroll down to “Print”. 
• To export the map to a .jpg, .tif or .pdf among other options, click on the File 

menu and scrolling down to “Export Map”.  Now choose what folder to save the 
map in, what “File name” to call it, what file format to save it as and finally the 
resolution you would like to save it as before clicking on the “Save” button. 

• This example is saved in the “Answers” folder as an ArcGIS project 
(Query_Manual_Example_10.mxd), along with a .jpg of the Spawning Potential 
map (named ”Moderately_High_Spawning_Potential_in_Sea_Otter_Sound.jpg”). 
Compare these results to yours. 
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Access and Use Constraints 
 
Protocols for data access and distribution are established by the program partner agencies. 
Please see www.coastalandoceans.com for a list of partner agencies and related web sites. 
Video imagery can be viewed and digital stills downloaded online at 
www.alaskafisheries.noaa.gov/maps/szintro.htm. Any hardcopies or published data sets 
utilizing ShoreZone products shall clearly indicate their source. To ensure distribution of the 
most current public information or for correct interpretation, contact the ShoreZone project 
manager at Coastal and Ocean Resources, Inc. At the time of publication, that person is Dr. 
John Harper. 
 
To effectively and appropriately use ShoreZone data, the user shall refer to the ShoreZone 
Coastal Habitat Mapping Protocol (2008) available at www.coastalandoceans.com. Data 
provided are derived from large, regional databases that are continually being updated and 
modified. The accuracy of some information is subject to change. Any published data sets 
utilizing ShoreZone products (printed, digital, or online) shall clearly indicate their source. If 
the user has modified the data in any way, the user is obligated to describe the types of 
modifications performed. The user specifically agrees not to misrepresent these data, nor to 
imply that changes made were approved by the ShoreZone program or its partners. 
 


