
CRAM #33 Cross Section Labeling & X30 Criteria – Summary and Exercises 
4/28/2010 

 - 1 - 

 

Table of Contents 
CRAM 33:  CROSS SECTION LABELING USING X30 CRITERIA - 2 - 

Summary and Overview ................................................................................... - 2 - 
Introduction: - 2 - 
Existing Features typical section: - 2 - 
Right of Way Typical Section: - 4 - 
Cross Section Labeling typical section: - 5 - 
Notes: - 6 - 
Requirements: - 6 - 
Primary Work Flow: - 6 - 

EXAMPLE 1) EXISTING FEATURES TYPICAL SECTION: DRAW EXISTING FEATURES IN 
CROSS SECTIONS - 7 - 

Preliminary Steps.............................................................................................. - 7 - 
Exercise Steps .................................................................................................. - 8 - 

1. Create a Proposed Cross Section Run for existing features: - 8 - 
2. Draw the Existing Features - 14 - 

EXAMPLE 2) RIGHT OF WAY TYPICAL SECTION: DRAW ROW/EASEMENT FEATURES IN 
CROSS SECTIONS - 15 - 
Preliminary Steps............................................................................................ - 15 - 
Exercise Steps ................................................................................................ - 16 - 

1. Create a Proposed Cross Section Run for ROW: - 16 - 
2. Draw the ROW and Easement Features - 22 - 

EXAMPLE 3) CROSS SECTION LABELING TYPICAL SECTION: LABEL PROPOSED SECTIONS 
WITH OFFSETS AND ELEVATIONS - 23 - 
Preliminary Steps............................................................................................ - 23 - 
Exercise Steps ................................................................................................ - 24 - 

1. Create a Proposed Cross Section Run for XS Labeling: - 24 - 
2. Draw the XS Labels - 32 - 

 



CRAM #33 Cross Section Labeling & X30 Criteria – Summary and Exercises 
4/28/2010 

 - 2 - 

CRAM 33:  CROSS SECTION LABELING USING X30 CRITERIA 

Summary and Overview 

Introduction:  

Preparing cross sections (xs) for PS&E reviews and for construction is a major task and a deliverable for most 
Central Federal Lands (CFL) 4R projects.  As shown within the “Sample Plans”, which are examples of how 
plan sheets are completed, many different labels and features are required within the cross sections.  The 
Federal Lands Highway (FLH) has developed cross section “criteria” files to display these labels and features.  
The X30 generation of criteria makes this available to Geopak users. 

This document provides guidance and procedures on the use of the X30 generation of criteria for labeling cross 
sections.  There are three different criteria “templates” that generate xs labeling.  Each of these will be covered 
in separate steps or exercises. 

Existing Features typical section: 
This typical section will search for MicroStation elements previously drawn in a 2D Plan file that represent the 
horizontal alignment of existing features.  This 2D plan file is usually obtained from the Survey branch and 
usually has a file name of "topoplm.dgn". 
 
Once finished searching the 2D plan file, the corresponding text for each existing feature will be drawn in the 
cross section file at the exact same offsets as found in the 2D plan file.  In some cases, lines will also be drawn 
representing existing thicknesses, (such as topsoil, pavement, sidewalks, and building foundations).  These lines 
can be used later to calculate end areas and volumes representing "in place" removals. 
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The complete list of “Existing Features” currently available is shown below: 
 

• Existing Pavements (Supports Showing Two Layers of Thickness) 
• Existing Gravel Pavements  
• Existing Shoulders  
• Existing Water Edge 
• Existing Lake Edge 
• Existing Wetlands 
• Existing Treeline 
• Existing Archaeological 
• Existing Thermal Wetlands 
• Existing Fence Line 
• Existing Topsoil (Supports Showing a Single Thickness) 
• Edge of Two Year (Q2) Flood 
• Edge of Ten Year (Q10) Flood 
• Edge of Twenty Year (Q20) Flood 
• Edge of Fifty Year (Q50) Flood 
• Existing Curb Face 
• Existing Sidewalk  (Supports Showing a Single Thickness) 
• Existing Building  (Supports Showing a Single Thickness) 
• Existing Retaining Wall Face 
• Existing Barrier Wall Face 
• Existing Underground Gas Line 
• Existing Underground Phone Line 
• Existing Underground Power Line 
• Existing Underground Sewer Line 
• Existing Underground CATV Line 
• Existing Underground Water Line 
• Existing Underground Fiber Optic Line 
• Existing Underground Irrigation Line 
• Existing Underground Steam Line 
• Existing Underground Storm Line 
• Existing Underground Oil Line 
• Existing Underground Force Main Line 
• Existing Overhead Phone Line 
• Existing Overhead CATV Line 
• Existing Overhead Power Line 
• Existing Overhead Fiber Optic Line 
• Existing Guardrail 

 
This typical will handle multiple instances of the above listed existing features.  It will check to make sure an 
even number of edges of rigid or gravel pavements, sidewalks, and building pad foundations exist in the plan 
view.  If an odd number of pavement edges are found (either rigid or gravel), then a warning message will be 
drawn stating "Irregular Pavement Found" and no pavement will be drawn for pavement.  In other words the 
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criteria must be able to find two lines to connect.  If there were three lines found then there is not a way for the 
criteria to determine which two lines are to be connected.  If an odd number of sidewalk or building pad 
foundation edges are found, then a warning message is displayed stating "Irregular Non-Topsoil Found" and 
no building pads nor sidewalks will be drawn.  In addition, if this error does exist, then no existing topsoil will 
be drawn if the topsoil thickness is set to a value greater than zero.  Therefore, it is important to understand that 
the topo file must contain even numbers of edges of these four existing items. 

To additional guidance on placing existing features, follow this link.   Guidelines for Existing 
Features.html 
 

Right of Way Typical Section: 
This typical section will draw existing and proposed right of way locations utilizing plan view elements in the 
right of way drawing.  The following types of right of way locations will be searched for and drawn if located: 

 
• Existing Right of Way 
• Construction Easement 
• Permanent Easement 
• Existing Property Line 
• Existing Utility Easement 
• Existing Prescriptive Easement 
• Existing Maintenance Limits 
• Proposed Right of Way 

 
This typical will handle multiple instances of the above listed right of way types.   
 

http://www.cflhd.gov/resources/CADD/documents/GuidelinesforfieldandofficepersonnelonExistingFeatures(X30Criteria).pdf�
http://www.cflhd.gov/resources/CADD/documents/GuidelinesforfieldandofficepersonnelonExistingFeatures(X30Criteria).pdf�
http://www.cflhd.gov/resources/CADD/documents/GuidelinesforfieldandofficepersonnelonExistingFeatures(X30Criteria).pdf�
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Cross Section Labeling typical section: 
This typical section will search for MicroStation elements previously drawn in the "Cross Section DGN" that 
represent the "bottom line" of the proposed cross section elements.  This labeling typical section is required to 
be run as a "post" process after the proposed cross sections are completed.  All break points representing a 
change in slope will be labeled assuming the symbology of those elements is included in the define_dgn 
variable named "Lines To Label". 
 

 



CRAM #33 Cross Section Labeling & X30 Criteria – Summary and Exercises 
4/28/2010 

 - 6 - 

Notes:  

• Using Geopak “Project Manager and the “Typical Section Generator” is recommended and is assumed 
in the exercises and examples. 

• Additional information for the use of the X30 criteria and these “typicals” is included in the “write” 
(.wri) files that are delivered with the X30 download.  These files can be accessed at: 
\Standards\V8_RESOURCE\X_30\Typicals\English or Metric 

 

Requirements:  

• MicroStation cross section file with existing ground cross sections. 
• Planimetric, Topography, Mapping and/or Right-of-Way MicroStation files with plan view elements 

drawn using the D&C manager for correct symbology.  
• A corresponding Geopak Coordinate Geometry (COGO) database file (.gpk). 
• The FLH database (.ddb) file, for level symbology and FLH design elements. 

Primary Work Flow:  

1. Create the Geopak existing ground sections (not shown in this document).   
2. A Geopak “Project” (.prj) file (creation not shown in this document). 
3. From the Project Manager, create a working alignment for the specific roadway (not shown in this 

document).  
4. Create a “Proposed Cross Section Run” for the desire typical. 
5.  Process the Proposed Cross Section Run 
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EXAMPLE 1) EXISTING FEATURES TYPICAL SECTION: DRAW 
EXISTING FEATURES IN CROSS SECTIONS 

Description:  This example will demonstrate the process for drawing existing features into cross sections 
using the existing features typical (X30 criteria). 

Preliminary Steps 
1. Download from the cflhd.gov website, or Copy directory K:\CADD Coordinator\4A_Training & 

Presentations\CRAM Sessions\CRAM_33 to the local C:\My Documents\ directory. 
2. Open MicroStation in the X30_English workspace.  Open MicroStation File C:\My 

Documents\CRAM_33-(XS_Lableling_Criteria\ XSE(Labeling)_01.dgn 
3. Set the Working Directory to the C:\My Documents\ CRAM_33-(XS_Labeling_Criteria)\ directory 

through the User Preferences. 
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Exercise Steps 
1. Create a Proposed Cross Section Run for existing features:  This step will demonstrate 

how to create a “run” for drawing existing features into cross sections. 
  
1.1. Open the XS Labeling.prj project under the User = Designer, and set the Working Alignment to 

“Sample”. 

  

     

  
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1.2. Select “Proposed Cross Sections” and start/create a new Run.  A “run” is a file that is stored in the 
project (.prj) file.  It acts as an input file that calls to identified MicroStation files and criteria.  From the 
“Select Run” dialog, select Run>New.  Use an appropriate name for the “run” that explains what 
typical/criteria is being used.  For this example, use ExFeat. 
 

  

   
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1.3. Select the “run” (ExFeat) and then configure and edit the settings. 
 

  
 

1.4. Use the following settings for the ExFeat run. 
1.4.1. XS DGN File:  File = XSE(Labeling_01.dgn), Tolerance = 0.01 

 

 
 

1.4.2. Pattern:  Toggle “Use Working Alignment Definition” 
1.4.3. Existing Ground:  Toggle “Use Working Alignment Definition” 
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1.4.4. Shapes:  On the drop down tool, select “Shapeless”.  Although superelevation shapes are needed 
to apply the ROW Features criteria to the Typical Section Generator, the criteria files do not read 
the information on the shapes.  The shapes can be “dummy” shapes.  However, the criteria will not 
work correctly if “Shapeless” is not selected. 
 

 
 

1.4.5. Shape Clusters:  1) Verify the Chain and Profile information.  2) Select “Add” to populate the 
shape cluster window.  3) Highlight the shape cluster.  4) Select “Typical”.  A Typical Sections 
dialog will appear. 
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1.4.5.1.Typical Sections:  This dialog applies a specific “Typical Section” to the shape clusters.  
Each Typical Sections call a specific group and order of X30 criteria files to be processed.  
Select the ROW typical, verify/set the desired station range and then select Apply. 
 

 
 

1.4.6.  Define DGN Variables:  No settings are needed.  In this dialog, specific elements that were not 
drawn using the FLH (English or Metric) database (.ddb) file could be identified so that the criteria 
files recognized them.  The use of the FLH database files and symbologies are recommended.  This 
can also be used for identifying different locations for MicroStation elements used in the X30 
criteria.  Again, placing these elements in non-standard locations is not recommended. 
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1.4.7. Define Variables:  For this exercise, set the three variables identified below.  The Existing TOPO 
DGN = TOPO(Labeling)_01.dgn,  GEOPAK Lines DGN (file used for non-design criteria 
elements.  For example Cut/Fill override lines) = PLN(Labeling)_01.dgn and the Cell Scale 
Multiplier = 0.1.  

 
 

1.4.8. Redefinable Variables:  These are used to set project specific variables on existing features.  For 
this example, use the default values except for the Existing Topsoil Thickness.  Highlight the 
variable “_d_ExistTopsoilThick” and select Edit.  Change the value to 4/12 and select Save. 
 

   
 

1.4.9. Plot Parameters:  Toggle all off.  
1.4.10. Drainage:  No settings are needed. 
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1.4.11. Once settings are complete, save the run by selecting File>Save Settings. 
 

 
 

2. Draw the Existing Features:  This step will draw the Existing Feature elements into the cross 
sections. 

 
2.1. Load the Proposed Cross Section Run.  This step is already done in this example.  If the ExFeat run 

was closed, it must be re-opened from the Road Project>Proposed Cross Sections dialog. 
 
2.2. Process the ExFeat “Run”.  From the Proposed Cross Sections – ExFeat dialog, select File>Run.  

This starts the file, runs the criteria and draws the existing features. 
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EXAMPLE 2) RIGHT OF WAY TYPICAL SECTION: DRAW 
ROW/EASEMENT FEATURES IN CROSS SECTIONS 

Description:  This example will demonstrate the process for drawing existing and/or propose right-of-
way elements into cross sections using the ROW typical and X30 criteria. 

Preliminary Steps 
1. Download from the cflhd.gov website, or Copy directory K:\CADD Coordinator\4A_Training & 

Presentations\CRAM Sessions\CRAM_33 to the local C:\My Documents\ directory. 
2. Open MicroStation in the X30_English workspace.  Open MicroStation File C:\My 

Documents\CRAM_33-(XS_Lableling_Criteria\ XSE(Labeling)_01.dgn 
3. Set the Working Directory to the C:\My Documents\ CRAM_33-(XS_Labeling_Criteria)\ directory 

through the User Preferences. 
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Exercise Steps 
1. Create a Proposed Cross Section Run for ROW:  This step will demonstrate how to create a 

“run” for drawing ROW and easement features into cross sections. 
  
1.1. Open the XS Labeling.prj under the User = Designer project and set the Working Alignment to 

“Sample”. 

  

     

  
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1.2. Select “Proposed Cross Sections” and start/create a new Run.  A “run” is a file that is stored in the 
project (.prj) file.  It acts as an input file that calls to identified MicroStation files and criteria.  From the 
“Select Run” dialog, select Run>New.  Use an appropriate name for the “run” that explains what 
typical/criteria is being used.  For this example, use ROW. 
 

  

   
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1.3. Select the “run” (ROW) and then configure and edit the settings. 
 

   
 

1.4. Use the following settings for the ROW run. 
1.4.1. XS DGN File:  File = XSE(Labeling_01.dgn), Tolerance = 0.01 

 

 
 

1.4.2. Pattern:  Toggle “Use Working Alignment Definition” 
1.4.3. Existing Ground:  Toggle “Use Working Alignment Definition” 
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1.4.4. Shapes:  On the drop down tool, select “Shapeless”.  Although superelevation shapes are needed 
to apply the Existing Features criteria in the Typical Section Generator, the criteria files do not read 
the information on the shapes.  The shapes can be “dummy” shapes.  However, the criteria will not 
work correctly if “Shapeless” is not selected. 
 

 
 

1.4.5. Shape Clusters:  1) Verify the Chain and Profile information.  2) Select “Add” to populate the 
shape cluster window.  3) Highlight the shape cluster.  4) Select “Typical”.  A Typical Sections 
dialog will appear. 
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1.4.5.1.Typical Sections:  This dialog applies a specific “Typical Section” to the shape clusters.  
Each Typical Sections call a specific group and order of X30 criteria files to be processed.  
Select the ROW typical, verify/set the desired station range and then select Apply. 
 

 
 

1.4.6.  Define DGN Variables:  No settings are needed.  In this dialog, specific elements that were not 
drawn using the FLH (English or Metric) database (.ddb) file could be identified so that the criteria 
files recognized them.  The use of the FLH database files and symbologies are recommended.  This 
can also be used for identifying different locations for MicroStation elements used in the X30 
criteria.  Again, placing these elements in non-standard locations is not recommended. 
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1.4.7. Define Variables:  For this exercise, set the three variables identified below.  The Right of Way 
DGN = TOPO(Labeling)_01.dgn, and the Cell Scale Multiplier = 0.1.  

 
 

1.4.8. Plot Parameters:  Toggle all off.  
1.4.9. Drainage:  No settings are needed. 
1.4.10. Once settings are complete, save the run by selecting File>Save Settings. 
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2. Draw the ROW and Easement Features:  This step will draw the ROW Feature elements into the 
cross sections. 

 
2.1. Load the Proposed Cross Section Run.  This step is already done in this example.  If the ROW run 

was closed, it must be re-opened from the Road Project>Proposed Cross Sections dialog. 
 
2.2. Process the ROW “Run”.  From the Proposed Cross Sections – ROW dialog, select File>Run.  This 

starts the file, runs the criteria and draws the ROW features. 
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EXAMPLE 3) CROSS SECTION LABELING TYPICAL SECTION: LABEL 
PROPOSED SECTIONS WITH OFFSETS AND ELEVATIONS 

Description:  This example will demonstrate the process for placing offset and elevation labels on 
proposed cross section elements. 

Preliminary Steps 
1. Download from the cflhd.gov website, or Copy directory K:\CADD Coordinator\4A_Training & 

Presentations\CRAM Sessions\CRAM_33 to the local C:\My Documents\ directory. 
2. Open MicroStation in the X30_English workspace.  Open MicroStation File C:\My 

Documents\CRAM_33-(XS_Lableling_Criteria\ XSE(Labeling)_03.dgn 
3. Set the Working Directory to the C:\My Documents\ CRAM_33-(XS_Labeling_Criteria)\ directory 

through the User Preferences. 
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Exercise Steps 
1. Create a Proposed Cross Section Run for XS Labeling:  This step will demonstrate how to 

create a “run” for drawing labels on proposed cross section elements. 
  
1.1. Open the XS Labeling.prj project under the User = Designer and set the Working Alignment to 

“Sample”. 

  

     

  
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1.2. Update the working alignment definition:  With the “Sample” working alignment chosen, select the 
Define button.  Change the XS DGN File to XSE(Labeling)_03.dgn. 
 

  

  
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1.3. Select “Proposed Cross Sections” and start/create a new Run.  A “run” is a file that is stored in the 
project (.prj) file.  It acts as an input file that calls to identified MicroStation files and criteria.  From the 
“Select Run” dialog, select Run>New.  Use an appropriate name for the “run” that explains what 
typical/criteria is being used.  For this example, use XS_Lab. 
 

  

   
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1.4. Select the “run” (XS_Lab) and then configure and edit the settings. 
 

   
 

1.5. Use the following settings for the ROW run. 
1.5.1. XS DGN File:  File = XSE(Labeling_03.dgn), Tolerance = 0.01 

 

 
 

1.5.2. Pattern:  Toggle “Use Working Alignment Definition” 
1.5.3. Existing Ground:  Toggle “Use Working Alignment Definition” 
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1.5.4. Shapes:  On the drop down tool, select “Shapeless”.  Although superelevation shapes are needed 
to apply the Existing Features criteria in the Typical Section Generator, the criteria files do not read 
the information on the shapes.  The shapes can be “dummy” shapes.  However, the criteria will not 
work correctly if “Shapeless” is not selected. 
 

 
 

1.5.5. Shape Clusters:  1) Verify the Chain and Profile information.  2) Select “Add” to populate the 
shape cluster window.  3) Highlight the shape cluster.  4) Select “Typical”.  A Typical Sections 
dialog will appear. 
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1.5.5.1.Typical Sections:  This dialog applies a specific “Typical Section” to the shape clusters.  
Each Typical Sections call a specific group and order of X30 criteria files to be processed.  
Select the XS_Lab typical, verify/set the desired station range and then select Apply. 
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1.5.6.  Define DGN Variables:  This step will identify the proposed cross section element endpoints 
that are to be labeled.  1) Highlight the “Lines To Label” variable.  Select/update the DGN File = 
XSE(Labeling)_03.dgn.  3) Then, set the Search Criteria by toggling the attribute and matching 
the elements to be labeling in the cross section. (See note below)  4) To complete the step, select 
the Modify button. 
Note:  If more than one xs element is chosen, the criteria will label the element that is below 
the others.  The best application of this criteria is for labeling excavations and Subgrade.  The 
example selected all proposed xs elements including mse excavation.  Items that do not 
represent earthwork elements were not selected. 
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1.5.7. Define Variables:  For this exercise, set the three variables identified below.  Cross Section DGN 
= XSE(Labeling)_03.dgn, and the Cell Scale Multiplier = 0.1.  
 

 
 

1.5.8. Redefinable Variables: Use default (15). 
1.5.9. Plot Parameters:  Toggle all off.  
1.5.10. Drainage:  No settings are needed. 
1.5.11. Once settings are complete, save the run by selecting File>Save Settings. 
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2. Draw the XS Labels:  This step will draw the ROW Feature elements into the cross sections. 
 

2.1. Load the Proposed Cross Section Run.  This step is already done in this example.  If the XS_Lab was 
closed, it must be re-opened from the Road Project>Proposed Cross Sections dialog. 

 
2.2. Process the XS_Lab “Run”.  From the Proposed Cross Sections – XS_Lab dialog, select File>Run.  

This starts the file, runs the criteria and draws the existing features. 
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