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SECTION 1: Introduction  

The Eastern Federal Lands Highway Division (EFLHD) has established CADD standards and 
procedures for the automation of the development of plans, specifications and estimates (PS&E) 
Packages. 

       The primary functions of the EFLHD Highway Design CADD Procedures Guide (CPG) are to: 

i)  Provide guidance on CADD methods and policies which are as current as practical. 
ii)  Assure uniformity of practice for projects designed by or for EFLHD. 

This guide does not eliminate the need for other references or training. Portions of the material in 
this guide may be specifically superseded by subsequent Official Issuances of the EFLHD or FLH 
(e.g., CADD Manual, PDDM). 

Variations from this guide will be necessary for special or unusual conditions, or between the 
issuances of new or revised source documents and any corresponding updates of the CPG. 
Consequently, instructions in this document are not intended to preclude the exercise of individual 
initiative and judgment in reaction to project specific conditions or application of current state of the 
art practices. Rather, such initiative and judgment is encouraged when it is appropriate and there is a 
rational basis for deviation. However, it is equally important that there be consistency in the 
application of this manual. The objective is uniformity of process and presentation. 

1.1- Software Package & Trademarks 

The EFLHD has adopted MicroStation as its standard graphics package. MicroStation is a drafting 
package developed, marketed and sold by Bentley Systems Inc. The EFLHD has also adopted 
GEOPAK, by Bentley Systems Inc. as its standard road design system with modifications to meet 
EFLHD standards. Other trade names computer protocols, and file formats mentioned in this manual 
are the trademarks of their respective owners. In no event will the appearance of any graphic, 
description of any graphic, picture, screen display, or any other method of conveying meaning be 
considered to impair the rights of the respective owners. 

The system operates on a Personal Computer (PC) running NT/2000/ Window XP operating system.  

Standard File types and extension: There are many types of CADD files in use at EFLHD as 
shown below. 

Extension Description Standard CADD Directory/Working Directory 
. DGN MicroStation graphics design file M:\Projects\.......\..\.......\proj_dev\CADD 

. DGNLIB MicroStation V8 library containing level 
d fi i i l d di i l

M:\Engineering_Software\Cadd_resource_v8\X_30\Standards\Library_Files 

. DDB GEOPAK D&C Manager database file M:\Engineering_Software\Cadd_resource_v8\X_30\Standards\DDBS 

. RSC MicroStation resource file M:\Engineering_Software\Cadd_resource_v8\X_30\Standards\Resources 

. CEL MicroStation V8 cell file M:\Engineering_Software\Cadd_resource_v8\X_30\Standards\Cell_Lib 

. X30 GEOPAK  criteria(X30) files M:\Engineering_Software\Cadd_resource_v8\X_30\Typicals 

. TIN GEOPAK digital terrain model M:\Projects\.......\..\.......\ techserv\survey\FinalMapping 

. PSL GEOPAK plan & profile cut sheet criteria 
fil

M:\Engineering_Software\Cadd_resource_v8\Plan&Profile_Shts 

. XSSL GEOPAK cross section cut sheet criteria 
fil

M:\Engineering_Software\Cadd_resource_v8\Cross-Sec_Shts 

. GPK GEOPAK  COGO file M:\Projects\.......\..\.......\proj_dev\CADD 
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1.2- Installation and Configuration 

1.2.1-General 

This section outlines the setup for a typical installation of MicroStation at EFLHD.  

1.2.2- Installation 

MicroStation v8 is installed in c:\BentleyV8\ for a typical EFLHD setup. 
GEOPAK v8 is installed in c:\Geopak88\ for a typical EFLHD setup. 

1.2.3- Configuration Variables and Files 

The configuration and associated files for MicroStation and GEOPAK that are used for plan 
development at EFLHD are typically stored in a directory tree “M:\Engineering_Software\_v8\”. 

EFLHD_Eng_30.pcf is the Project Configuration File containing the MicroStation and GEOPAK 
Configuration Variables settings necessary for a EFLHD Roadway project. All of the MicroStation and 
GEOPAK configuration variables referenced throughout this document are set in this file.  

Unit definition is also set ft, Ft, and ‘as Survey foot for MicroStation V8/XM through this configuration 
file. 

 

1.3- Revisions and Updates 

CADD Coordinator (Spencer Beale), with input from CADD Manager (Richard McDaniel), IT section 
and CADD users, will develop and maintain standards and procedures for the EFLHD CADD related 
activities.  

This guide will be revised by the CADD Coordinator as needed to insure that it is up to date with 
EFLHD standards. 

If you have suggestions, which we strongly encourage, please submit them to the CADD Coordinator 
Highway Design Section. 

 

1.4- The Appendixes 

 The appendixes at the back of this manual include A&E CADD setup procedures. 
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SECTION 2- Project Administration 

2.1- Project Directory   

The sharing of information is a vital part of the success of a EFLHD project. Thus, when a new project 
begins, a centralized directory structure is needed. Since it is important that data is shared but not corrupted 
by unauthorized users, the Division has established a standard procedure for directory creation and file 
naming.  

Generally new project directories are requested by the Planning & Programming Branch in conjunction 
with the request to add the project into the Project Management System (PrMS). If an additional directory 
is needed, or if the original request has not been made or fulfilled in a timely fashion, Users should contact 
the PrMS Specialist (Bradley Bookwalter) or the CADD Coordinator (Spencer Beale) by email to make the 
request. The email request should include the project number, name of the Agency, and the State of the 
project. The Coordinator will setup the standard root directories on the central CADD server. 

Each directory has the appropriate security access set by section. Thus, Highway Design staff is only 
allowed write access to the “proj_dev” subdirectory. Other directories will be “read only” for Highway 
Design staff. The Highway Design CADD Directory Structure is shown in “Green”. See directory 
structure Section 2.1.1. 

IT Services has optimized levels of security so that project related folders, up to and including the 
“proj_dev” root directories, cannot be deleted or edited. However, any folder can be created by an 
individual user, past that level. Obviously, users need to follow certain naming conventions of folders in 
order to effectively communicate with others. 

If preferred, after each milestone distribution, create a new subdirectory with the equivalent name (30%, 
70%, etc…) under the CADD folder. Create a copy of all files and place them into this new directory as an 
electronic record. Current CADD files will always stay in CADD sub-directory of the project 
directory.  (It is recommended that you manage the old files as design progresses, ex;  delete 30% 
milestone dgn files after 95% PS&E is distributed.  Delete 70% dgn files after 100% is distributed . . . ) 
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2.1.1- Directory Structure 

The directory structure for all workstations and Personal Computers has been established as shown below. 

                                                  M:\ 

                                                             

                 Projects 

                             Agency/Partner/Programs/Park/Location 

                                            US State, if any 

                                        Project Name/Number 

   

      proj_dev  techserv p&c  Misc  Constr  Bridge 

    

 

 

 

 

 

 

 

 

 

 

 

 

CADD_Resource_V8\ and \_V8i 

All CADD Standard Resources, Cells and 
criteria  (X30) files for MicroStationV8 and 

GEOPAK  

/CADD 

/Corresp 

/Distribu 
/e-mail 

/Eng_Coord 

/Misc 

/Picture 

/Plots 
/Quantity 
/Scoping 

/SCR 
/SOW_IGE 

geotech/ 

/hydra/ 

/pavement/ 

/survey/ 

/Design/ 
/Microsta/ 

/Plots/ 
/Specials/

/data/field data 
/data/office data 
/FinalMapping 

/mapping 

/OrthoImage 

/TGO data 

Existing topography, map and tin files 

(Designer needs to use this file as 
reference) 

/Std-Det      (All FLH Std’s and EFL Details) 

All current CADD files (.dgn’s), GEOPAK files and 
the directory created by GEOPAK (prjdbs) 

IN_House or A/E 
30%_PS&E 
70%_PS&E 
95%_PS&E 
99%_PS&E 

100%_PS&E 

Amendments 

Asbuilts 

Bid_Results/Bidder_Questions 

Constr_Staking_Data 

All Plan Sheets                        
in pdf  formats 
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2.2- File Naming Conventions and Plan Sheet Organization 

There are many types of files in use at EFLHD as discussed in Section-1. Of utmost importance is the 
naming convention of the MicroStation design files produced throughout a project. The file naming 
convention is set up to allow anyone to identify the contents of a CADD file without actually opening the 
file. The following design File Naming Convention is to be implemented on all new projects. This 
convention is to be used by all EFLHD users and A&E consultants.   

Also, shown at the end of this section, is the order of plan sheets for a typical EFLHD project. It is hard to 
imagine every type of file that may be created in a special case. If a file is not shown, best judgment must 
be exercised to place the file in an appropriate place within the plan set. 

2.2.1- Highway Design- CADD File Naming Conventions  

There are two types of design files that are produced in the process of generating construction plan sheets; 
sheet design files and master design files. Sheet design files represent the finished construction documents 
for a project, and the master design files will be used as a reference to the sheet design files. Following are 
examples of two types of files used in developing a set of construction plans.                                                               
Sheet Design Files: Title Sheets, Typical section sheets, Plan & profile sheets, Cross section sheets, etc.       
Master Design Files: Survey files (contain topography, utility), Master GEOPAK design files (contains 
proposed alignment, shape, etc.), Sheet border file (contain sheet border, project #, etc.), Hydraulic files 
(contains all proposed drainage and erosion control items), etc. 

Assigning file names to CADD design files is to be done with consistency to make future searches for the 
files and plan organization a simpler task.   

All EFLHD MicroStation design files should be named with the following formats. 
             
              XXX-YYYYYYYY_ZZZ.dgn 

 
                                                                                              File type descriptor (See 2.2.1.4) 
                                                                                                    

       Project number descriptor (See 2.2.1.3) 
 

Section number descriptor (See 2.2.1.1) - Master Design Files             
Sheet number descriptor (See 2.2.1.2) - Sheet Design File     

 
 
2.2.1.1- For all Master Design Files: 
 

 
Section Number 
Descriptor 

Departments or Sections 

01 Highway design 
02 Survey 
03 Hydraulics 
04 Safety/Environmental 
05 Geotechnical 
06 Traffic/Pavement 
07 Bridge 
08 Construction 
09 A&E (Consultant) 

 
2.2.1.2- Plan Sheet Organization: 



                                                                                                                                                    
12

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note:-   I, L, O, and Q letter designations are not to be used so as not to cause confusion between  
these letters and the numbers 0 and 1. 

 

 
 
 
 
 

2.2.1.3- Project Number Organization: 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
 

 
 
 
 
 
 
 
 
 

Sheet 
Number 
Descriptor 

Description 

A Title Sheet, Conventional Plan Symbols and Abbreviations, Location plan, 
Survey and horizontal alignment information plan 

B Typical Sections 
C Tabulation of quantities and Summaries & Schedules 
D Mainline Plan and Profile Sheets 
E-H Minor Roadways Plan and Profile Sheets and others. 
K Pipe Profiles or Drainage Cross Sections 
M Erosion Control Plan & Narrative, Landscape Plan (last) 
N Temporary Traffic Control Plans 
P Permanent Signing & Striping Plans 
R Bridge Plans 
S Standard Details Sheets and Special Details (Only for Highway design) 
T Mainline Cross Section Sheets 
U-Z Minor Roadways and others Cross Section Sheets 

 Forest Highway    Park Road Refuge Road Other 

Project Name AR  PFH 65-3(5) PRA RICH 
300(1),305(1) 

RRP-LOP 10(2) MT OMAD 18(33) 

State/Park/Program Arkansas Richmond National 
Park 

Lake Ophelia 
national Wildlife 

Refuge 

Missile Road 

Highway Route 65 300, 305 N/A 18 
Segment of Route 3 N/A N/A N/A 
Project Number 5 1 2 33 
Project Number 
Descriptor 

AR653(5) RICH300(1) LOP10(2) OMAD18(33) 
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2.2.1.4- Roadway Design File Type Descriptor: File types refer to the designated use. 
 
    

File Type File Type descriptor 

Sheet Design Files 
Title Sheet     ttl  
Symbols and Abbreviations        sym 
Vicinity Maps/Location Sheet   loc 
Survey & Horizontal Alignment Inf.  sur 
Typical Sections    typ 
Summary of quantities/Tabulation  qnt 
Plans and profiles    Pln(for plan), prf(for profile), 

p&p(for plan & profile) 
Storm drainage plan    dpl 
Storm drainage profile    dpr 
Box Culvert  Plan & Profile   bpp 
Drainage cross section    dxs 
Utility Plans and profiles   upp 
Erosion Control Plan/narrative   e&s 
Landscaping Plan lnd 
Temp Traffic control plan   tcp 
Permanent Signing & Striping plan  ssp 
Bridge Plan     brp 
Roadway Cross sections  sheets   xss 

Master Design Files 
Project Border File bdr 
Master file for design and Alignment        des 
Master file for Profile                                  pro 
Super elevations, pattern for x-sections      wrk 
GEOPAK Lines not for plan sheets      lin 
Area Pattern for new pavement   etc.         pat 
Master Cross section (mainline)                Dxs 
Minor Roadways cross section& others       Exs, Fxs, Gxs, Hxs,  etc. 
Hydraulic, drainage, sediment & erosion hyd

 
 
 
 
 

Note: The 3-digit file descriptor is given for most of the sheets in a typical plan set and 
master design files. As it is hard to foresee every type of file that may be included in a plan 
set, a special case may arise where there is no file descriptor for a file that has been created. 
In such a case, follow the rest of the naming convention as closely as possible, while 
generating a unique file descriptor for the new file.  
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2.2.2- File Naming Conventions of Standards and special Details  

 All FLH standards should be downloaded from WFLHD and not renamed. 

 All EFLHD Details are copied from EFLHD’s Standard directory and also not renamed. 

 
 Standards, Details, and Special Details will be kept in Std-Det directory on the project directory. 

 
 
 

Note:   1.A special Detail is a modified standard, detail, or project specific detail and should end with a 
letter .  

 2. The Standard Sheet number should have S prefix on it as shown in Section 2.2.1.2.  
 3. The sheet numbers of the specials and details are determined after all the standards, details, 

and special details are assembled. 

 

 
 
 
 
 
 

2.2.3- File Naming Conventions of EFLHD GEOPAK Job number ” .gpk” files:  

                                                   Job###.gpk 

 
This binary file is created when the user starts a coordinate geometry (COGO) session for the first time 
or is created through the Project Manager. All coordinate geometry elements are stored in this file. 
Multiple users can access this file at the same time, and only one file should be created for each project. 
The “###” is the only variable in this filename. It represents a job number (up to 3 alphanumeric 
characters) unique to a project and is defined by the user upon creation. 
When working on EFLHD projects, the .gpk number will be assigned by the Highway Design Manager. 
The convention will be a standard numeric system, starting at 600 for year 2006 and 700 for year 2007 
and so on. The first .gpk file assigned in year 2006 would be job600.gpk, then job601.gpk, etc. 
Internally, EFLHD personnel will request a .gpk number from the CADD Coordinator. The CADD 
Coordinator will then assign a number, from a file on the server, documenting the project information 
for the assigned number. This document will be the master list of all .gpk files assigned for all projects.  
The read-only file is located at; 
M:\Engineering_Software\cadd_resource_v8\Master_GPK Numbers\MasterGPK-List.xls. 
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2.2.4- Example:  
 

Suggested Naming Convention for Lake Ophelia National Wildlife Refuge, RRP LOP 10(2) 

 
 
 

Sheet 
Series 

Sheet No. Description Design File 
names 

Remarks 

A A01 
A02 
A03 
A04 

Title Sheet 
Symbol & Abbreviation Sheets 
Location Map Sheet 
Survey Information Sheet 

A01-LOP10(2)_ttl 
A02-LOP10(2)_sym 
A03-LOP10(2)_loc 
A04-LOP10(2)_sur 

 

B  
B01 
B02 

 
Typical Section Sheet 1 
Typical Section Sheet 2 

B-LOP10(2)_typ 
Model name B01 
Model name B02 

Typical Sections 
 

C  
C01                  
C02                  
C03                  
C04 

 
Tabulation Of Quantity Sheet 
Summaries & Schedules 1 
Summaries & Schedules 2 
Summaries & Schedules 3  etc. 

C-LOP10(2)_qnt 
Models name C01 
Models name C02 
Models name C03 
Models name C04 

Quantity Sheets 

D  
D01 
D02 
D03 
D04 

 
Plan & Profile Sheet 1 of Road 1 
Plan & Profile Sheet 2 of Road 1 
Plan & Profile Sheet 3 of Road 1 
Plan & Profile Sheet 4 of Road 1 

D-LOP10(2)_pnp 
Models name D01 
Models name D02 
Models name D03 
Models name D04 

Plan & Profile sheet for 
Mainline Roadways 

D05 
D06 
D07 
D08 

Plan & Profile Sheet 1 of Driveway 
Plan & Profile Sheet 2 of Parking lot 
Plan &Profile Sheet of  Box Culvert 
Plan & Profile for Utilities 

D05-LOP10(2)_p&p 
D06-LOP10(2)_p&p 
D07-LOP10(2)_p&p 
D08-LOP10(2)_p&p 

Driveway, Parking lot, culvert, 
and utilities  related to 
Mainline roadways 

E-H  
 

Road 2, all minors roads, and other 
roadways 
 

 Follow same as D series Sheets 

K K01 
K02 
K03 

Drainage Cross Sections Road 1 
Drainage Cross Sections Road 2 
Drainage Cross Sections others 

K01-LOP10(2)_dxs  
 

M M01 
M02 to M03 
M04- to M05 

Erosion Control Narrative 
Erosion Control Plan sheet Road 1 
Erosion Control Plan sheet Road 2 

M01-LOP10(2)_e&s 
MA-LOP10(2)_e&s 
MB-LOP10(2)_e&s 

 
Use models M02 & M03 
Use models M04 & M05 

N N01 to N03 
N04 to N05 
N6 

Temp. Traffic Control Plan  Road 1 
Temp. Traffic Control Plan  Road 2 
Temp. Traffic Control Plan  others 

NA-LOP10(2)_tcp 
NB-LOP10(2)_tcp 
N06-LOP10(2)_tcp 

Use models N01 N02, & N03 
Use models N04 & N05 
 

P  Permanent Signing & Striping Plan  Follow as N Series sheets 
T T01 to T30 Cross Section Mainline Road 1 T-LOP10(2)_xss All cross section sheets of 

Road 1 will be in one design 
file 

U U01 to U10 Cross Section minors Road 2 U-LOP10(2)_xss Same as in T Series 
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2.3- Plan Sheet Organization 
 
 
 
 
 
 

Example of Index to Sheets for the above project: 

 
 
 

Sheet No. Description 
A01 
A02 
A03 
A04 

Title Sheet 
Symbol & Abbreviation Sheets 
Location Map Sheet 
Survey Information Sheet 

B01 –B02 Typical Sections 
C01                
C02 –C04      

Tabulation Of Quantity 
Summaries & Schedules  

D01-D08 Plan & Profile Sheet of Mainline Road, Driveway, Parking Lots. 
E01-E06 Plan & Profile Sheets of minor road 2, Driveway, Parking Lot 
K01-K03 Drainage Cross Sections 
M01- M05 Erosion Control Plan and Narrative 
N01-N06 Temp. Traffic Control Plan 
R01-R09 Bridge Plans 
S01-S19 Standard Details Sheets 
T01 to T30 Cross Section Mainline Road 1 
U01 to U10 Cross Section minors Road 2  
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SECTION 3:  MicroStation(V8) Basics 

 

3.1- MicroStation Design File Settings 

3.1.1- Setting Button Assignments: 

By default, the mouse buttons are assigned as shown below. 

                                            

Each of the buttons can be set to something different.  For instance, if you wanted to assign your  
mouse button as shown below follow the instruction ahead.  

                                   

To set up the mouse buttons, go to Workspace->Button Assignments…..                                                  
In the Button Assignments dialog box under Buttons, choose Data. If the assignment under Invoked 
by is anything other than Left Button then move the mouse into the Button Definition Area and press 
the Left mouse button.   In the Button Assignments dialog box under Buttons, choose Tentative.   If 
the assignment under Invoked by is anything other than Middle Button then move the mouse into the 
Button Definition Area and press the Middle mouse button (the wheel).   In the Button Assignments 
dialog box under Buttons, choose Reset.   If the assignment under Invoked by is anything other than 
Right Button then move the mouse into the Button Definition Area and press the Right mouse 
button.  Finally, press the OK button. 
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3.1.2- Compress Design File:  

From the MicroStation dialog box, choose File -> Compress -> Design. This physically removes all logically 
deleted elements.     

3.1.3- Save Settings:  

From the MicroStation dialog box, choose File -> Save Settings. This save all the design file settings so that 
when the file is open the next time, all the settings will be restored. 
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3.2- Level Assignments 

3.2.1- Introduction 

To maintain uniformity among different drawing files, it is essential that an organized leveling system be 
used. MicroStation V8 allows levels to be saved on a name basis instead of previous number based system. 
A design file may contain an unlimited number of levels in which data may be displayed. There are two 
primary ways in which to assign symbology to each element: first, the color, weight, and line style of the 
graphic elements are set independently. Second, a new addition introduced in MicroStation V8, is ByLevel 
symbology.  With ByLevel symbology each level may have a pre-assigned color, line style, and weight.  
By selecting the desired level, these attributes are automatically set. 

 In MicroStation 2004, levels and the associated ByLevel symbology are stored in a DGN library, and 
may be attached to any MicroStation file.  In order to maintain the X30 criteria and future versions of 
Geopak criteria files, FLH_Combined.dgnllib are controlled FLH wide.  EFLHD designers and 
consultants will not be able to add new levels to the FLH_Combined.dgnllib file. 

 For EFLHD employees, the standard DGN Library will be automatically attached while opening a 
design file using the Project Configuration (EFLHD_Eng_30). 

Note:- In EFLHD, most elements should be placed with the GEOPAK D&C manager, the  .ddb file.  
This is the best way to insure that elements are placed with the proper symbology, for final output 
and for use at later stages for GEOPAK criteria files and for computing quantities. See Section 7.3. 

 All levels are named and have a default color, line weight, and style.                                                                   

 Level definitions are stored and managed by “FLH_Combined.dgnlib”                                                            

 Levels have ByLevel Symbology and Override Symbology settings.                                                                    

 Users shall not create their own levels for use in any design files submitted or exchange with EFLHD.              
 (See list of FLH levels in EFLHD CADD Manual)    

 Levels can be managed by Level Manager and Level Display icons as shown below.    
Go to Setting>Level>Manager 
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3.3- References 

3.3.1- Introduction 

External design files can be attached to the current file as a reference. Attached references 
maintain a dynamic link with the current file, allowing changes in the attached references to be 
reflected in the current file. Elements in the attached file display as though they are part of the 
current file. References, however, are a one-way reference in that you cannot edit attached files 
while you are working in your current design. 

A reference file must be a design (dgn) file or DWG (AutoCAD) file that is attached to the design 
file in which you are currently working. User can also attach the current file to itself.  Drawing 
files in other format e.g. tiff file, pdf file etc can be attached to your design file through Raster 
Manager. 

A design file or dwg(Autocad) file can be attached to the design file through the Reference 
Manager as shown below. 

 Access Reference Manager through File>Reference  

               

 Once selected Tools>Attach to attach design file will activate Attach Reference dialog  
as shown below. 

            

  

 

 

 

 

 

 Enable the check box of Save Relative Path as shown above (recommended to all users). 
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Note:- Save Relative Path setting as shown in Attach Reference dialog box circled in  red 
has essentially replaced the Save Full Path option of earlier versions, MicroStation 
V8 searches for reference file attachments in the following manners if not checked: 

1. Active directory 2. Relative path directory 3. MS_RFDIR directory 4. full path 
directory   

 Select the design file to be referenced from the Attach Reference dialog and click OK. 

                                    

 Select the Model you want to reference. 
 ALWAYS select Coincident – World. 
 Select check box for True Scale 
 Click OK to attach the selected model of the design file, the Reference Manager dialog 

will look as shown below. 

                 

 
Note:- Coincidnte-World setting adjusts reference files with different Global Origins and 

is the only attachment method to preserves coordinate system values. 
  

True Scale setting adjusts reference files with different Units of Resolution. 
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3.4- Models 

 

 3.4.1- Introduction 
 

Bentley has introduced the concept of models with MicroStation V8. Whereas a V7 design file used to be 
one single design space, a V8 design file is a container of models, each of which behaves much like a 
separate design file. MicroStation V8 design files can contain more than one "model" -- each model is 
analogous to an entire V7 design file. In MicroStation V8, models introduce an entirely new approach. 
When you set up a new DGN file in MicroStation V8, you create at least one model within your new 
DGN, whether you know it or not. You can create an unlimited number of models in a DGN file. Every 
model has its own set of eight views. 
 
Design models can be either 2D or 3D. A design model can also be used as a reference or placed as a cell. 
There are two types of models: design or sheet. By default, the view windows of design models have 
black backgrounds and those of sheet models have white backgrounds (EFLHD Highway Section prefer 
Design model rather than Sheet model except quantity sheets). 
 
 
Note:- In EFLHD configuration set up, model is set to be created ALWAYS 2D for 2D dgn file and 3D for 
3D design files(Using default seed file “Sur_ft2D” for 2D dgn files and Sur_ft3D for 3D dgn files) 

 
. 
 

 
3.4.2- Models dialog box 

 
MicroStation V8 offers a simple dialog box to manage models. The Models dialog box can be accessed 
through File > Models or by clicking on the Models icon. 
The Models dialog box is explained in the graphic below: 
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3.4.3- Tips on Models 

 To switch between the models, you simply double-click on the model name in the Models dialog box 
or select a view group associated with the desired model.                                                                                       
  

 Each model has its own reference attachments. When you attach a reference, one of the new 
parameters you set is the model to access as part of the reference definition. 

 

 

 You can also drag and drop DGN or DWG files from Windows Explorer into the Models dialog box to 
import the models from the selected files. Similarly you can use drag and drop to drag models from the 
Models dialog in another open session of MicroStation V8 to the Models list box and drop them in to 
import the models.  

 

3.4.4- EFLHD Preferences regarding Models  
 
EFLHD prefer to use Models on the following sheets of PS&E Plan set.                                         
 Typical Sections (If you have more than one sheet of Typical Sections, use model). 
 Quantity Sheets (Use EFLHD Quantity sheet with Excel file). 
 Plan sheet, Plan & Profile Sheet, E&S sheets, Stripping Plan sheets etc., see Plan &Profile Sheet 

clipping. 
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3.5- Plotting 

 

3.5.1- Introduction 

 
MicroStation has a built-in printing process. Printing is available by using the MicroStation pulldowns 
File>Print. The Print dialog is shown below. 
 

                 
 
One of the common ways to ensure that a plot will be printed to scale and right format is to: 
 
 Place a fence at the corners of the border of your design file.  
 Select the magnifier at Printer and paper size on the Print dialog box as shown in yellow for the 

list of print drivers. Select the right print driver (EFLHD print driver) as explained in Section 
3.5.2, next page.  

 Select Color icon on the Print dialog as shown in Green and select either Gray scale (for Cross 
section and Plan &Profile sheets), full color for colorful sheets or Monochrome for all black sheets 
for LPT (Bentley) Drivers. For Window drivers, Color icon is set automatic, doesn’t need to select. 
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3.5.2- EFLHD Internal Plotting 
At EFLHD there are several plot drivers for both 11x17 and 8 ½ x 11 and for color, and black & white.  
Listed below are the location and purposes of the plot drivers (.plt). 

 

To Print Sheet: 

11"x17" / 8½” x11” - BENTLEY driver for black-and-white (b&w) sheets (Metric and English) 

        Plot driver location: M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\plt_lpt2\e_lpt2.plt  
 
    Example: Use this driver for all plan sheets except p&p Sheets and Cross Section Sheets. 

11"x17" / 8½” x11” - BENTLEY driver for shaded b&w sheets (Metric and English) 

        Plot driver location:  M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\plt_lpt2\e_lpt2s.plt  
 
     Example: Use this driver for P&P Sheets and Cross Section Sheets. 
 

11"x17" / 8½” x11” - WINDOW driver for color, shaded and b&w (Metric and English) 

       Plot driver location:  M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\Window\  
                                   

HP5500_331-Cave_HD.plt -For printer Room No 331, Highway_Cave. 
   HP5550_100-Proc_Admin.plt -For printer Room No 100, Admin. 
   HP5550_140-survey_TS.plt -For printer Room No 140, Survey.  

  HP5550_320_HD.plt  -For printer Room No 320, Highway Design. 
   HP5550_340-Bridge2.plt -For printer Room No 340, Bridge. 
   HP5550_350-TS.plt  -For printer Room No 350, Technical. 
   HP5550_220-HD.plt  -For printer Room No 220, Highway Design. 

To Create a PDF File: 

For 11"x17" / 8½” x11” Black-and-White Sheets (Metric and English) 

     Plot driver location:  M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\PDF\eflhd_bw-pdf.plt 
 
                          Example: Use this driver for all plan sheets except P&P Sheets and Cross Section   

                       Sheets. 

For 11"x17" / 8½” x11” Shaded Black-and-White Sheets (Metric and English) 

         Plot driver location: 
M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\PDF\eflhd_shade&color-pdf.plt 

 M:\Engineering_Software\Cadd_resource_v8\Plotting\Plot_Driver\PDF\pdf_EFLHD_v8.plt (Latest) 
 
                         Example:  Use these driver for p&p Sheets, Cross Section Sheets, and all other sheets. 
 

Pen tables: The appropriate pen table is automatically attached when the user selects the plot driver file. 
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3.5.3- Batch Printing 
 

Batch printing will allow users to plot files without having to open the file and place a fence around the data to 
get a plot. Batch printing is a MicroStation utility used to print and re-print sets of drawings.  Job sets are 
created containing the desired drawing files and a set of print specifications are created for each job set.  The 
print specifications are defined containing information such as printer, print area, layout, and display.  This 
chapter will detail each of the necessary settings associated with Batch Printing. 

 Select File>Batch Print from the main MicroStation pull-down menus as shown below. 

 

 

 Once selected the Batch Print dialog box is activated.  The top bar on this dialog will show the current Job 
Set.  Shown below as [Untitled].  Once a new Job Set is created or an existing Job Set is opened the name 
will replace [untitled]. 

 

 To open an existing job set select File>Open and select the desired job. 

Job Sets are lists of files to be printed, along with the associated print specifications used to print the files 
such as which printer, what area to print, what scale, which pen table, etc.  Each job set created will have 
the extension, .job. 
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Step I 

 Creating a New Job Set- The user must first select the design files to be added to the Job Set.   

 Select Edit>Add Files… 

 

 

 

 The user may also alternatively select the Add Design Files icon, as shown below. 

 

 

 Once selected the Select Design Files to Add dialog box will activate as shown below. 

                                 



                                                                                                                                                    
28

 Select the desired directory from the upper right Directories box.  Once you have navigated to the 
correct directory, select the desired files from the upper left Files box.  You may select multiple files 
by using the control or shift keys while selecting. 

 After selecting the desired files, the Add button will be active.  Select the Add button and the selected 
files will be populated in the selected files box at the bottom of the above dialog box. 

 Once complete, select the done button. The Batch Print dialog box will display as shown below. 

 

 

 

Step II 

 Now set the plot specifications (Plot specifications tell MicroStation how to plot the selected files). 

 Select Specifications>Manage, or select the Manage Specification icon, as shown below. 

                                                                                                

         

 

 Once selected the Batch Print Specification Manager dialog box will activate. 
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 Select Printer Type and highlight Default Specification. Begin by renaming the default printer to be 
a more descriptive name.  Select Rename from the dialog box shown above, the Rename Printer 
Specification dialog box will activate.  Give a descriptive name, shown as 8150DNCA below, and 
select OK. 

 

 

 

 Once renamed, highlight the printer on the left and the newly renamed 8150DNCA on the right, and 
select Properties. 

 

 

 

 

Note:-In most cases the EFLHD user will want to select one of the plot driver files found in the 
M:\Engineering_Software\cadd_resource_v8\Plotting\plotdrv\ directory in order to achieve 
special plotting effects such as shading contours or p&p sheet grids. 

 

 

 Once Properties is selected, the following dialog box will activate allowing the user to select the 
desired printer driver.  Click the Driver button on the Properties dialog and select the printer driver 
(see Section 3.5.2) and choose OK. 
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 Select Print Area Type and highlight Default Specification on the Specification Manager dialog and 
rename the Print Area specification to be more descriptive, shown below as EFLHD. 

 

 Select EFLHD Specification of Print Area and click on Properties button. The EFLHD Properties 
dialog box will appear as shown below.  

 

 

Note:- This step will be to set the desired print area.  Using the EFLHD standard sheet border 
cells will ensure that a plot shape will be available to define the area to be plotted for each 
sheet.  Included with each border is a plot shape on level D_Plot_shape that has been created 
as a construction element so it will not plot unless desired. The print area properties dialog, 
shown above, allows the user to select the attributes of the plot shape and to look for the plot 
shape in the master file, reference files, or both.  If any of the design files to be plotted has 
more than one sheet then check the Process Multiple Boundary Elements box at the bottom of 
the properties dialog 

 

 Select the attributes of the plot shape as shown above and click OK.  When selecting the References 
check box the box below becomes active to allow the user to select certain reference files by logical 
or file name.  If this box is left empty all of the reference files will be searched. 

Note:-The level of the plot shape must be typed in. The drop-down box will only include the 
levels in the master file, as the list could get quite long. 
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 From the Batch Print Specification Manager dialog box select Layout. 

 

 

 

 Select Default from the right hand box and then select Properties.  For layout, the name (default) 
may be renamed if desired however there may be little need to change these specifications so default 
may be fine. 

 

 Select Maximize, Center, and the correct units and select OK. 

 From the Batch Print Specification Manager dialog box select Display. 

 

 

 Select New to create a new set of specifications.  Input a new name and click OK. 
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 Select the new name from the right hand box and then select Properties. 

 

 

 

 

 The display dialog is similar to the view attributes dialog box, but is specific to printing.  In 
MicroStation 2004 Edition you have the ability to plot with attributes different than the current view.  
From this dialog box you also have the ability to specify a pen table. 

 From the example above we have turned Constructions, Print Border, and Ref Boundaries Off.  This 
allows us to use these features during our work but not to plot them. 

 Select the desired attributes and select OK. 

 Close the Batch Print Specification Manager by selecting the X in the upper right corner. 

 Once the files have been added and the specifications set, select File>Save.  This will save all of the 
settings in a Job Set file with a .job extension.  Job Set files may be stored in any convenient directory.  
There is no standard or default directory where batch print looks for these files. 

 

 

 

 

Step III – Printing 

 
 If reprinting a previously saved Batch Print Job Set use File>Open in the main Batch Print dialog pull 

down menus to select the .job file for that Job Set.  This will populate the dialog with the files to be 
printed and the associated print specifications.  If continuing directly from Workflow 2 above 
(Creating a New Job Set) then skip this step. 
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 From the Batch Print dialog, shown below, select the printer icon. 

    

 

 The Print Batch dialog will activate. 

 

 

 

 From this dialog box the user can select a print range, and log file. 

 

 Select OK and the files will be sent to the printer.  A status bar will be displayed during the process, as 
shown below. 
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SECTION 4:   MicroStation - EFLHD Standard Procedures 

 

4.1- EFLHD Standard Settings 

 

4.1.1- Open MicroStation File 

ALWAYS pick Project Configuration of Workspace from the “MicroStation Manager” dialog box as 
shown below.   

                 

Select “EFLHD_Eng_30” for English project, “EFLHD_Met_30” for Metric project of Highway 
Design Section, and “Bridge_Arch” for Bridge drawings of Bridge Section. 

Using the Project Configuration of workspace “EFLHD_Eng_30” will give the user access to the X30 
Generation of Standard Files (Level library, line styles, cell library, color table, text styles, ddb files, etc) 
and also set the MicroStation in Survey Feet Unit environment. 

 

 

Note:-Unit of Bridge Design files are set as International Foot and Highway design files are set 
for Survey Foot. 
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4.1.2- Creating a New CADD File 

 

 

All design files must be created from a Seed file. A separate two dimensional seed file has been 
developed for English and Metric scale design file. These are “Sur_ft2D.dgn”, and “Metric_2D.dgn”.  

ALWAYS use the seed files from M:\Engineering_Software\Cadd_resource_v8\X30\Standard\seed\ 
when creating a new file. There is an English one (Sur_ft2D or 3D) and a metric one (Metric_2D or 3D). 
While in the MicroStation Manager Window (the first screen that pops up when you open 
MicroStation), make sure that the Project is set to “EFLHD_Eng_30” under Workspace. Next, rename 
the file and save it in your project folder. 

 

 
 
 

Note:-These seed files have several operating parameters set specific to that sheets purposes and 
scale .Some of the parameters are as follows: 

  a. Working Units: Imperial --- Master Unit- Survey Feet (‘)  
                                Sub Unit- Survey Inches (“) 
                              Resolution- 10000 per Survey Foot 
  b. Global origin set to lower left (GO=0,0)                                                                                           
         See M:\Engineering_Software\Cadd_resource_v8\X30\Standard\seed\  

for available standard EFLHD Seed Files. 
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4.1.3- Text Styles settings in use at EFLHD 

MicroStation V8/XM gives the user the ability to save the various text settings as a text style.  With 
MicroStation V8/XM text styles the user no longer needs to set text parameters such as text font, height, 
width, etc. each time text is needed.  Each of these settings is saved within a text style. 

 

At EFLHD there is 1 text style for each italics and non-italics for both standard text and title/heading 
text. This is a total of 4 text styles for English as shown below. 

 

 

 

Note:- Creating a new design file with the seed file and opening the new design file using with 
project configuration file(EFLHD_Eng_30) will give the user access to the EFLHD  text 
styles and dimension styles settings. 

 

To use EFLHD text styles setting, set and lock the Annotation Scale in Model properties as shown 
below in different steps.   

Set the Annotation Scale  

 
Step 1. Open Model dialog box follow, File>Models , then click on the Edit Model properties icon 

 as shown below: 
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Step 2. Select the annotation scale from the Model Properties dialog as shown below.   
 In the example, the annotation scale  has been set to 1”=100’.      
 Once the model properties have been set, select OK. 

 

                                       

 

Set the Setting Annotation Lock 
 

Step 3. Annotation Lock can be selected from the main Microstation pull down menus by selecting 
 Settings>Locks>Annotation Scale, as shown on the left below, or by using the locks menu on 
 the Microstation status bar, as shown on the right below. 

 

                                 

Step 4. With the Annotation Scale lock on, text will now be placed at the proper size for the output scale. 
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Step 5. Select the Place Text tool. 

 

 

                            

 

Step 6. From the tool settings window, select the desired text style. 

 

                                 

 

Step 7. By selecting the English Italics Standard Text, the proper text size, font, line spacing, etc. will be 
 set automatically. 

 

                               

 

Step 8. Begin placing text. 

 

4 FLH Text Styles
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4.2- Border Sheet 

 

 Standard Border Sheets have been developed by the EFLHD Highway Design Section and will be used for 
all EFLHD projects.  

 
 Border design files are kept in the following directory. 

                 “M:\Engineering_Software\Cadd_resource_v8\Borders\01-EFLHD_bdr.dgn”. 

 

 English and Metric borders are kept in different models of this border design file.  

 

 Designer needs to copy this file into project working directory.  

 

 Rename this file according to the EFLHD’s naming convention [e.g. “01-lop10(2)_bdr.dgn” for RRP-

LOP 10(2) project].  

 

 Edit all project information of the English and Metric border according to the working project. 

  

 

 
  

                                                                                                                         

                                       

 

 

                                                                                      

    
 

Note: - - Text’s font, style, and size will not be changed by the users. 
            -The English border is drawn for 1”=100’ (US Customary) 
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4.3- Title Sheet    

The Title Sheet identifies the set of plans, conveys the general type of improvement planned, and locates the 
improvement. The Title Sheet includes, at least the major criteria under which the improvement is designed, 
a sketch showing the location  of the proposed project, a State map, a complete index of the sheets in the 
plan set, and the length of project.   

                                                                                                         

 Standard Title Sheets for each partner agency have been developed and are kept in the following directory. 

                 “M:\Engineering_Software\Cadd_resource_v8\Standard_Shts\Titles” 

 Copy these files into your project working directory.  

 Rename the files according to the EFLHD’s naming convention [e.g. “A01-lop10(2)_ttl.dgn” for RRP-

 LOP 10(2) project].   

 

 Replace location map and key map for the required State. Edit all required information according to the 

project. 

 
 

 
 
 

Note:- - Text’s font, style, and size will not be changed by the users. 
           - Project border will not be used as reference in the Title design file. 
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4.4- Symbols and Abbreviations Sheet 
 

 
The Symbols & Abbreviations Sheet details all of the standard plan symbols and abbreviations currently in 
use by EFLHD. The symbols and abbreviations should not be changed on a project-to-project basis. When 
a special symbol is required for a specific project, show it in the space designated for the Project Specific 
Symbol. 

 
 

 
 A standard Symbol and Abbreviation Sheet is developed for EFLHD and will be used for all EFLHD 

projects. See M:\Engineering_Software\Cadd_resource_v8\ 
 

 Copy this file into the project working directory.  
 
 

 Rename the file according to the EFLHD naming convention [e.g. “A02-lop10(2)_sym.dgn” for RRP-LOP 
10(2) project].   

 
 Re-attach project border design sheet file of your working project directory. 
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4.5- Location Map Sheet 
 

The Location Map shows the location and limits of the improvement. The location sketch shows physical 
features that will aid in the identification of the proposed road location, including intersecting and adjacent 
roads, prominent landmarks, towns, property lines, and a north arrow. A graphic scale is included for the 
location sketch so the scale will be applicable on reduced size prints. 

 
 Create a new DGN file using “Sur_ft2D.dgn” seed file.  

 
 Name this file according to the EFLHD Naming Convention [e.g. “A03-lop10(2)_loc.dgn” for RRP-LOP 

 10(2) project].  
 

 Attach your project border file using reference default model selection (Note border is drawn for 1”=100’ 
 US Customary).  

 
 Use models in the same location map design file, if project have more than one location map sheet. 
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4.6- Survey Information Sheet 
 
 

The Survey Information Sheet shows the horizontal and vertical datum notes(State Plane Coordinates; NAD, 
NAVD, etc; mapping on grid or ground with scale factor; location map showing all primary and secondary 
control points; sketches of references of project control points including staked centerline points 
(POT,PC,PT, etc.); subsurface utilities note (SUE Level A,B,C or D); coordinate listing of project control 
points (NEZ plus type of points); and coordinate listing of proposed alignment or staked centerline data. 
 

 
 

 Create a new DGN file using “Sur_ft2D.dgn” seed file. 
   

 Name this file according to the EFLHD Naming Convention [e.g. “A04-lop10(2)_sur.dgn” for RRP-LOP 
10(2) project]. 

 
 Attach your project border file using reference default model selection. Change the scale according to the 

project requirement (Note border is drawn for 1”=100’ US Customary). 
 

 Attach project horizontal alignments, existing features and control points, and the survey information from 
the survey file.  

 
 Use models in the same survey info design file, if project have more than one survey info sheet. 
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4.7- Typical Section Sheet 
 
 

The Typical Section shows the shape of the finished cross-section within the construction limits, and 
represents the appearance of the completed project. It must be specific enough to describe the proposed 
work, its location, and material needed. 

 
 

 
 Create a new DGN file using “Sur_ft2D.dgn” seed file.  

 

 Rename this file according to the EFLHD Naming Convention [e.g. For one sheet typical sections. The file 

name will be “B01-lop10(2)_typ.dgn”. Use models if you have more than one sheet. The file name will be 

“B-lop10(2)_typ.dgn”. B1, B2 will be the models name for RRP-LOP 10(2) project].  

  

 Attach your project border file . (Attach reference on other models also if you have more than one sheet). 

 

 Use models in the same Typical section sheet design file, if project have more than one typical section 
sheet. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



                                                                                                                                                    
45

4.8- Quantity and Summaries Sheet 
 

The Summary of Quantities tabulation combines and summarizes the contract quantities for all pay items. 
This summary informs prospective bidders where to locate work within the plan sheets, the difference 
between plan quantities and bid schedule quantities, if any, and expands on contract bid schedule 
information. 
  

 
4.8.1- EFLHD Quantity Sheet Information 
 

Standard Quantity Design Sheets are developed by EFLHD to improve efficiency and consistency in the 
process of generating quantity summaries and schedules sheets for the PS&E Package. 

 
There are two design files and one excel file. 
 

 Border file, 01-EFLHD_bdr.dgn (M:\Engineering_Software\Cadd_resource_v8\Borders\01- 
EFLHD_bdr.dgn). 

 This file is used for border as referenced to the quantity design sheets in each model. 
 

   Quantity Sheet Design File, Quantity.dgn 
(M:\Engineering_Software\Cadd_resource_v8\Quantity_Shts\Quantity.dgn)   
(This file has different summaries and Schedules on each model) 
 
   Quantity Spread Sheet, Quantity.xls                                
 (M:\Engineering_Software\Cadd_resource_v8\Quantity_Shts\Quantity.xls) 
  (This file has same summaries and Schedules in each of the sheets) 

 
 Note:- For consultants, these files are available through the CADD_Resources_V8.zip download(See 

Appendix A).   
 
 

 
4.8.2- Summaries & Schedules Sheets 
 
 

 Step I 
 Copy these files (explained above in section 4.8.1) into the working directory. 
 Rename these files as per EFLHD Naming Convention (See Section 3 of this guide). 
 
 

 Step II 
 Open Quantity Sheet Design file. 
 

Note:-This file has the Tabulation of Quantities sheets in the Default Model and all other Summaries 
and Schedules sheets in different Models of the design file. 01-EFLHD_bdr.dgn border file is 
already referenced to these models. You can’t see the border in any of the models as you have 
changed the border file name and directory.  

 
 Reattach all border reference files you need to use with your project border file.  
 
 Click model view at the bottom left and select different Summaries and Schedules in your design file.  

Some are shown as below:  
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 Tabulation of Quantity             Clearing And Removals                Construction Signs                            Drainage  
   

 
 The Tabulation of Quantity Sheet is in the Quantity Tabulation Sheet Views models and Summaries 

and Schedules Sheets are in different models of the design sheet.  
 

 Summaries and Schedules are as follow:  
  i) Clearing and Removals, ii) Construction Signs, iii) Drainage, iv) Earthwork, v) Erosion 

 Control, v) Pavement Striping, and vi) Permanent Sign Sheets. 
 

 The tables of different sheets of each model are linked with Excel worksheets. The Excel file has the 
Summaries and Schedules in different worksheets as shown below in red circles:  

 
 

 
 
  
 The above spreadsheet has seven worksheets and each worksheet has three tables for different 

Summaries and Schedules (sheet1, sheet2 and sheet3). These sheets have a link connection with the 
Quantity Sheet design file. Any changes in the spreadsheet will automatically be changed in your 
Quantity Sheet design file. 
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 The link in the Quantity Sheet design file with the Excel file will be lost because of a change in 
directory and files name. To reestablish the link, follow Step III. 

 
 

 
    Step III 
 
 Open the Quantity Sheet design file. Open Clearing and Removal Models. 

 
 Open Links menu through Edit>Link as shown below: 

 
 

 

                                  
 
 
 

 The Links Menu for Clearing and Removal Models will appear. 
 

 

                           
 

 Highlight one line on link menu as shown above and click on Change Source.  
 Change Source menu will appear. 
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 Select the Quantity excel file from the working directory of the Change Source menu. Select all 
three lines one by one and change the source of the link by selecting the same Excel file.  

 
 Change the source of all the links in each Model with the same Excel file. 

 
 Open the Excel file and select the working sheets of Summaries and Schedules to use. Edit 

according to the project information and save the Excel spreadsheet file. 
 
 

 Open the Quantity Sheet design file and select Edit>Update Links as shown below. Your design 
file will be updated according to the Excel Spreadsheet. 
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4.8.3- Tabulation of Quantity Sheets 
 

 Use Quantity Sheet files (explained in Section 4.8.1). 
 This file has the Tabulation of Quantities sheets in the Quantity Tabulation Sheet Views Model.   
 Reattach the border reference file.  
 Import Quantities of Engineer’s Estimate System (EES) into Tabulation of quantity sheet file. 

 
 

4.8.3.1- Import Quantities of Engineer’s Estimate System into Tabulation of quantity sheet file. 
 
 
      FOR EXPERIENCED USERS(See next page for 1st time users) 
 

Step I:   

- Create txt file from your project Engineer’s Estimate.  

- Open the Engineer’s Estimate of your project. 

- Create a text file for Quantity tabulation sheet > Go to CADD Files on main menu of EES and 
click on create files.   

 

   Step II:   

- Edit the text file with UltraEdit-32 software (Use any column mode text Editor). 

- Extra blank columns of the table need to be deleted from the original text file created by EES. 

- Open text file with UltraEdit-32. Go to Column and select Column mod, highlight all 
columns text that you want to delete and press delete. 

- Save the final text file and repeat the same for other text files if it is created by EES. 

                             

Step III:     

- Import EE’s table into the Quantity Tabulation Sheet “dgn” file. 

- Open the Quantity Sheet design file (Default model). 

- Select Change text attributes or text attributes in your design file. 

           - Set the “change text attributes” or “text attributes” setting as shown below: 

 

               Text Style=Style (none) 
                        Font = 3 
                      Height=7.0 
                       Width= 6.0 
             Line spacing=6.0 
       Interchar spacing=0.0 
                         Slant =0.0 
                            Line length = 255 
                    Underline=Disable 
                       Vertical=disable 
           Line space type=Automatic 
 

- Select save setting, File>Save Setting. 

- Import text file by selecting File>Import>Text 

- Select your text file and click OK. 

- Place the text on the left portion of your sheet when it appears on your screen.                                        

- Repeat steps to import other text file (if you have) into the dgn file and place the text on the 
right portion of your sheet when it appears on your screen. 
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FOR FIRST TIME USERS 

 
Step I: Create txt file from your project Engineer’s Estimate 
 

- Open the Engineer’s Estimate for the project 

  

    
- Click on “CADD Files” on the main menu of the Project EES as shown above. 

- The “Edit CADD sheet headings” menu will appear as shown below: 

             

 
    

- In “Path for CADD files” type the directory string and file name. 

 

- Click on ”Create files”. It will create text files in the given directory.  

 

Note:- It will create one or more  files in text format depending on the size of the quantities 
table in the EE’s. 
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Step II: Edit the text file with UltraEdit-32 software (Use any column mode text Editor). 

 

- This is how the original EE’s table will appear in the dgn file, if import without edit: 

 

 
 

 

- The extra blank columns, shown within the red rectangle needs to be removed before 
importing into the dgn file. 

 

- Use UltraEdit-32 software to remove the blank columns (Consultant may use any other Text 
Editor software with column mode edit capability). 

 

- Open text file with UltraEdit-32,the text file will appear as shown below:                              
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- Select Column >Column mode from the top menu bar as shown below: 

-  

   
 

- The highlighted portion shown below is the extra columns you want to remove. Select these 
columns by clicking at point 1 and drag your cursor to point 2. Then press delete on your 
keyboard or select File>Delete as shown below: 

 

                                                                           

 
   

- The final text file will look like this: 

 

                                        

1

2 
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- Save this file and close UltraEdit. 

- Repeat the same steps for each text file. 

 

Step III:   Import EE’s table into Quantity Tabulation Sheet “dgn” file. 

 

- Open Quantity Sheet dgn file (Quantity Tabulation Sheet View model).  

- Select the Change text attributes in your design file as shown below: 

                          
 

- Set the change text attributes settings as shown below: 

 

               Text Style=Style(none) 

                        Font = 3 

                      Height=7.0 

                       Width= 6.0 

             Line spacing=6.0 

       Interchar spacing=0.0 

                         Slant =0.0 

                            Line length = 255 

                    Underline=Disable 

                       Vertical=disable 

           Line space type=Automatic 
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- After the text attributes settings, select save setting, File>Save Setting. 

- Import the text file by selecting File>Import>Text, as shown below: 

 

                               
 

- Select your text file and click OK,  as shown below: 

 

                             
    

- Place the text on the left side of your sheet as shown below: 
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- Repeat the same step to import the second text file into the dgn file. Place the text on the right 
side of the sheet as shown below: 
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4.9- Plan and profile Sheets 

The designer may incorporate plan and profile sheets, plan sheets, line graphs, or other descriptive sheets 
that describe the proposed work. When laying out plan and profile sheets, avoid dividing major structures, 
highway intersections, interchanges, or grade separations between sheets. 

 

See Section 6 to create Plan & Profile Sheet Clipping using Geopak Civil Software. 
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4.10- Approach Roads and Parking Area 

Plans, profiles, and details for approach roads, parking areas, turnouts, and other associated roadways 
may be placed in a single section or in multiple sections as appropriate. It may be appropriate to include 
approach road plans with the mainline plan and profile sheets. Use unique stationing for designed 
approach roads and secondary roads. 
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4.11- Erosion and Sediment Control 

 
 A standard Erosion and Sediment Control Narrative Sheet is developed for EFLHD and will be used for all 

EFLHD projects with Erosion and Sediment Control Plans.  
 

 See M:\Engineering_Software\Cadd_resource_v8\Standard_Shts\ESC_Narrative 
 

 Copy this file into the project working directory.  
 

 Rename the file according to the EFLHD naming convention [e.g. “M01-lop10(2)_e&s_nar.dgn” for RRP-
LOP 10(2) project].   

 
 Re-attach the project border sheet file from your working project directory. 
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4.12- Temporary Traffic Control  

See Section 6 to create Plan & Profile Sheet Clipping using Geopak Civil Software. 
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4.13- Permanent Traffic Control  

See Section 6 to create Plan & Profile Sheet Clipping using Geopak Civil Software. 
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4.14- Drainage Details and profile 
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4.15- FLH Standards and EFLHD Details 

4.15.1- Introduction 

FLH Standard Drawings are intended to cover various design elements and be applicable nationwide. 
They have been posted on the Western Federal Lands Highway Division office website for repetitive use 
in the plans. Each standard drawing is available in both Metric and US Customary units and conforms to 
the FP-03. 

EFLHD Detail Drawings are also created within the Division on a continual basis by the Highway 
Design office to clarify the work required in the plans. 

4.15.2- EFLHD Policy 
 

The following are the EFLHD policies regarding Standard Drawings and EFLHD Detail Drawings: 
 

 All three Divisions have one set of Standard Drawings known as the FLH Standard Drawings. These 
Standards Drawings are located on the WFLHD website. 

         http://www.wfl.fha.dot.gov/design/standard/  
 

 Each Division also has their own set of Detail Drawings.  
EFLHD Detail Drawings are located on the EFLHD website.  Details 2011 
EFLHD Detail Drawings are also available in the following directory:  
All V8 Details - M:\Standards\EFLHD_Detail-Drawings\V8\ 

 
   Use EFLHD Detail Drawings when there is no available FLH Standard Drawing and/or when the 

Standard is not appropriate for the project.  
 

 FLH Standard Drawings and Eastern Federal Lands Detail Drawings may be modified based on 
individual project requirements.  Submit modified FLH Standards, EFLHD Details and completely 
new project specific Details to the HD CADD Coordinator, through your HDM, for review prior to 
including the drawing(s) in your submittal plans.  Describe any and all modifications made to the 
drawing when submitting to the CADD Coordinator. 

 
   When FLH Standard Drawings are modified, renumber as follows: 

i) Modified Standard Drawings become Project Specific Detail Drawings. 

ii) Change Drawing Numbers by adding alphabetic characters.                                                         
(e.g. Standard Drawing # 635-01 will be renumbered as Project Specific Detail Drawing # 635-
01A).   

iii) Replace the word “Standard” with “Detail”. 

iv) Replace “Federal Lands Highway Division” with “Eastern Federal Lands Highway Division”. 

v) Remove “Standard Approved For Use” and dates. (your changes will not have been approved on 
the FLH level) 

vi) Change the File Name to match the new Detail number.                                                                
(e.g. A  Standard file name st63501.dgn would change to st63501a.dgn). 

 
 When EFLHD Detail Drawings are modified, renumber as follows: 

 
i) Modified EFLHD Detail Drawings become Project Specific Detail Drawings. 

ii) Remove “Detail Approved For Use” and dates. (your changes will not have been approved on the 
EFL level) 
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iii) Change Drawing Numbers by adding alphabetic characters. 
 (e.g. EFLHD Detail Drawing # E633-02 will be renumbered as Project specific Detail Drawing # 
E633-02A for the English version). 
 

iv) Change the File Name to match the new Detail number.   
                   (e.g. A  EFLHD Detail file name st63302_detail.dgn would change to st63302a_detail.dgn). 
 
  When adopting a detail from a DOT /  another source / or creating a completely NEW detail, 

number as follows; 
 

i) New details are Project Specific Detail Drawings. 
ii) Add an “E” prefix and alphabetic character at the end. (e.g. #E602-A) 
iii) Provide a reference to the source of the adopted detail. 
iv) Provide the original source Detail No. 
v) Review/Revise original source detail’s Notes.   

 
 Always use FLH Standard Drawings and EFLHD Detail Drawings from the original 

sources/directory as shown above and NOT from old project directories. 
 
 
 

4.15.3- Use FLH Standard Details (V8) copied from WFLHD Website 
 

Step I 

 Copy border file “EFLHD_bdr.dgn” from “M:\Engineering_Software\Cadd_resource_v8\Borders\ 
“directory into your project working directory. Change file name as per EFLHD naming Convention 
(e.g. 01-lop10(2)_bdr.dgn for LOP 10(2) project). 

 
 Open eflhd_border.dgn file and choose Metric and US Customary views from the “View Groups” 

dialog (Metric and English need both views to use Standard drawings downloaded from WFLHD 
Website). 

 

          
 
 
 Edit text for your project information “the top right corner of the border”.                                           

(Edit this for both Metric and US Customary views). 
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Note:- If you already have the Border for your project then skip Step I.  

Step II 

 Copy/Download the Standard drawing from WFLHD Website. 
 Choose Metric or US Customary views from the “View Groups” as per your project requirement. 
 Turn off the following levels from the active files:  

D_WFL_Arch 
D_Trad 

   D_EFL_Handles 
   D_EFL_Border 
   D_EFL_Arch 
   D_CFL_Print 

D_CFL_Iplot 
 Attach your project border from your project directory. Attach Metric or US Customary view as 

your requirement of your reference file. (Only metric will be used for dual unit) 
 Turn off level default and D_EFL_Handles in the border reference file. 

 
Step III  

 Make sure to “Save Settings” for your permanent display. 
 

4.15.4- Use EFLHD Details (V8)  
 

Step I 

 
 Copy border file “EFLHD_bdr.dgn” from “M:\Engineering_Software\Cadd_resource_v8\Borders\ 

“directory into your project working directory. Change file name as per EFLHD naming Convention 
(e.g. 01-lop10(2)_bdr.dgn for LOP 10(2) project). 

 
 Open eflhd_border.dgn file and choose Metric and US Customary views from the “View Groups” 

dialog (Metric and English both views need both views to use EFLHD Detail drawings). 
 

          
 
 
 Edit text for your project information “the top right corner of the border”.                                           

(Edit this for both Metric and US Customary views). 
 

                                            
 

Note:- If you already have the Border for your project then skip Step I.  



                                                                                                                                                    
65

Step II 

 
Copy/Download EFLHD Detail drawing from EFLHD Website.                                                               
Or copy from M:\Standards\EFLHD_Detail-Drawings\V8\ directory. 

  
 Choose Metric or US Customary views from the “View Groups” 
 Re-attach your project border from your project directory.  

 
 
 

Step III 
  

 Make sure to “Save Settings” for your permanent display. 
 

4.16- Cross Section Sheet 

 See Section 7 to create Cross Section Sheets Clipping using GEOPAK Civil Software. 
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SECTION 5:  Geopak – Basic 

5.1- Introduction 
GEOPAK 2004 Edition (GEOPAK), the civil engineering design software in use at the Federal Highway 
Administration’s Eastern Federal Lands Highway Division (EFLHD), is a comprehensive software package 
that covers every project phase from conceptualization to final quantities and construction stake-out. The 
software works within the MicroStation graphic environment providing true interactive design. As with any 
powerful software, and many complex processes, there are many different ways to accomplish a given task.  
This guide will outline the necessary procedures to ensure proper adherence to EFLHD standards for project 
design. 

 

The BASIC steps of a GEOPAK design are as follows:                                                                                              
  (These steps may be adjusted depending on the type of projects and personal preferances). 

Step I-  Get the .TIN file and mapping file from our Survey Branch. The mapping file usually has an 
extension of “***_map.dgn” (for planimetrics).  

 Note:-In order to create Profile,Ccross sections,Earthwork, or 3D models with GEOPAK you must 
have Digital Terrain Module (DTM) file that is compatible with GEOPAK Software. GEOPAK 
default DTM file is known as .TIN file.  This is an abbreviation for “triangulated irregular 
network”. The .TIN file is usually made from the field data file by the Survey section. So rather than 
get into how to make the .TIN file I will simply say, “Get the .TIN file from Survey.” 

 Currently, it is the responsibility of the Survey Branch to provide the mapping and .TIN file to 
design. These files will normally located at       
  “m:\Project\project directory… \techserv\survey\FinalMapping\” directory at EFLHD. 

Step II- Create a horizontal alignment. This can be done several ways, either through Coordinate Geometry 
or through Interactive Horizontal Design.  

Step III-  Display and annotate the horizontal alignment graphically.  

Step IV-   Generate the existing ground profile.  

Step V- Display the “existing ground” profile graphically. This can be done two ways. 

Step VI-   Create the vertical alignment. This can be done several ways, either through Coordinate Geometry 
or through Interactive Vertical Design.  

Step VII- Display the “design” profile graphically. This can be done two ways.  

Step VIII – Design any required/desired widening.  

Step IX – Develop Plan and Profile Sheets. 

Step X –Generate the superelevation, (the Shapes).  

Step XI- Draw Pattern lines across the horizontal alignments (for location of cross sections).  

Step XII- Generate the existing ground cross sections.  
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Step XIII- Generate the proposed cross sections.  

Step XIV- Develop Cross Section Sheets.  

Step XV-Generate the construction limits for the plan view.  

Step XVI- Calculate the earthwork.  

Step XVII- Generate any miscellaneous staking reports.  

Step XVIII- Generate a 3D model.    

 
5.2- Geopak Files Names 

 
Geopak uses and /or creates files during the design process. Several of the more common files are detailed 
shown below. 

 
 

Job###.gpk: 

This is Geopak Coordinate Geometry file where all coordinate geometry elements are stored. GPK file is 
comprised of stored geometric elements such as points, lines, curves, spirals, chains, parcels and profiles. 
This binary file is created when the user starts a coordinate geometry (COGO) session for the first time. 
Multiple users can access this file at the same time, and only one file should be created for each project. The 
“###” is the only variable in this filename. It represents a job number (up to 3 alphanumeric characters) 
unique to a project and is defined by the user upon creation.  

 
 

Note:- In EFLHD the Job number will be assigned by the Highway Design Manager for all the projects. 
          (See Section 2.2.3 for gpk number naming convention) 
 
 
 
 

Project-name.prj:  

It is a binary file resulting from the creation of a new project. It stores information for use by the Geopak 
Project manager.  

The name specified must be a valid Windows file name (i.e., it cannot contain the special characters \ /: *? “ 
< > | ).  Although there is no standard naming convention used for .prj files in EFLHD, it’s good practice to 
use a name that relates to the project’s  route designation because the Project Name specified here is used to 
access the Project Manager setup for the project in subsequent sessions. 

fname###.ioc  

ASCII input file for loading data during a COGO session. "###" Represents the job number and "oc" is the 
operator code (users initials). Filename characters are limited to 5 characters plus the 3 job number character 
designation as indicated with the example. 

fname###.ooc   
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ASCII output file created by GEOPAK during a COGO session. Variables are the same as defined above. 
Filename characters are limited to 5 characters plus the 3 job number character designation as indicated with 
the example. 

fname.tin     

A binary file containing triangular surfaces also known as the digital terrain model (DTM).  

 
 

 

5.3- User Preference 

 When a user begins Geopak for the first time or after Geopak has been reloaded, there are certain 
User Preferences the user needs to set. The User Preferences dialog box can be accessed from 
Applications > Geopak Road > User Preferences. The following dialog box appears.  

 

               

 The Working Directory identifies where the data files for a particular project can be found. If a 
user does not want to work within a specific project, the field may be left blank, and Geopak uses 
the directory wherein the open MicroStation file is located.  

Note: - EFLHD designer usually work more than one project; the field to be left blank 
ALWAYS as a default preference.   

 By clicking the Feature Preferences button, the following dialog box is invoked.  
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This defines the default file utilized for representation of coordinate geometry and survey elements 
when visualization is utilized during an active coordinate geometry session as well as the scale in 
which these elements will be displayed.  

 

 

 By pressing the COGO Preferences button, the following dialog box is invoked.  

 

The Job (GPK) Directory field specifies the location of the GPK file. If any of the above directory 
fields are blank, they will default to the Working Directory set in the GEOPAK User preferences 
dialog box (EFLHD’s preferred set up- Kept blank as above shown directory). 
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5.4- Setting Up Project Manager (Geopak) 

5.4.1- Project Manager Introduction: 

Project Manager is a Geopak tool that associates a project with its respective coordinate geometry job 
number, users, working directories and project files. Project Manager provides the user with an easy 
workflow system that keeps records of processes run throughout the design of a project. 

You must first setup Project Manager in order to start your project through Geopak. The use of Project 
Manager is required to create proposed cross-sections through the Typical Section Generator (Using X30 
criteria file).  

Note:-It is required to use the Project Manager for all EFLHD projects working with MicroStation V8 
and Geopak X30. 

 Open MicroStation design file. Invoke Project Manager by either using the pull-downs 
Applications > Geopak Road > Project Manager  

                        

 Or by using the Tools icon shown below: 
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 When Project Manager is invoked the dialog appears as shown below. The current directory is 
displayed at the top of the dialog box. Current project file is displayed under the Project area. 
Project area showing blank mean there is no existing projected at the displayed directory. 

                                                       

Project Tools  

 There are four options under the Projects pull down, New, Edit, Delete and Exit as shown below.  

 

 The New menu option is used to create a new project. The .prj file is stored in the directory shown 
in the Directory path at the top of the Project Manager Dialog box.  

 The Edit option on the pull down menu is used to change any settings associated with the currently 
selected project.           

Existing Project 
file display area 
- Empty space 
means no existing 
project present at 
the current 
directory. 

Current directory 
is displayed 

To navigate the current 
directory structure 
area 
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 The Delete option on the pull down menu is used to delete any project that has been stored. The user 
highlights the project in the Projects list box and selects Delete.    

 The Exit option on the pull down menu closes the Project Manager and writes the settings to a 
resource file.  

 

Directory Tools  

 There are two options under the Directory pull down, Create New Directory and Current 
Working Directory as shown.  

 

The Create New Directory option creates a new directory on your computer within the current 
directory. If the Current Working Directory option is chosen, the directory path in Project Manager is 
changed to that directory.  

Note: - Always select the Current Working Directory to access the Road Project. 

Administration Tools  

 The Administration menu option is used to set a password on a project, if desired.  

 

Note: - Never Select Password for EFLHD’s Project. 
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5.4.2- Create a Project 

Step I 

 EFLHD always recommend to Create a Project under your current working directory. This is 
easily done by using the pull-downs on the Project Manager dialog, Directory > Current Working 
Directory as shown below: 

                                            

 

 Once the Directory is set, create the New Project by using the Project Manager pull-downs, 
Projects > New as shown below: 
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 Key in the Project Name, the Project Name can be any number of alphanumeric characters.  

 The Working Directory specifies the location of the project data files and may be manually 
entered. In lieu of typing, the Select button may be clicked and the appropriate directory selected. 

Note:-The Working Directory can be left blank if it is desired to have all of the MicroStation 
and GEOPAK files in a single directory (EFLHD’s default preference).  

 The next field is for keying in the GEOPAK (COGO) Job Number or the Select button may be 
clicked and the appropriate GEOPAK job number can be selected. 

Note: - Each project should have one job number assigned by Highway Design 
Manager/CADD Coordinator.  

If the user is creating a new project that does not have an existing .gpk file then the GEOPAK job 
number should be keyed into the Job Number field.  This is how a new .gpk file is created within 
Project Manager.  If the user is creating a new project that has an existing .gpk file, click on the 
Select button and select the existing .gpk file.  If the existing .gpk file isn’t visible in the selection 
window then either the Working Directory is incorrect or the existing .gpk file is not in the 
Working Directory. 

Note:-i) The Project Name specified is combined with a “.prj” extension to create the main 
Project Manager set-up file in the working directory. 
 
 
 
 

Step II 

 

 Select the Preferences button from Create New Project Menu, the GEOPAK User Preference 
dialog box will appear as shown below:  
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 Set the desired project related preferences. US Customary Unit specific preferences in EFLHD are 
shown in the dialog boxes below. 

 Keep the working directory and all the COGO preferences’ directory as blank (EFLHD’s 
preferred setting preference).  

Note: -This section is already discussed in Section 5.3. 

 Select Ok to close the Geopak User Preferences dialog box and Create New Project dialog will 
come back again. 

                          

 Type a short Project Description in the “Create New Project” dialog box.  

 

 When OK is clicked, the Project Manager dialog will appear as shown below, highlight the 
.prj file and click on OK: 
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Step III 

Create a User 

 Once a project is highlighted and OK is selected, the Project Users dialog appears.   
  

 Select Users > New from the pull downs as shown below.. 
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 Complete the New User dialog similar to the illustration below and click on OK: 

                                           

 

Note:- EFLHD policy is to create and use only one user for one project and not to use password. 

 

 The Project Users dialog will appear similar to the illustration shown below. Highlight the User 
and click on OK. 



                                                                                                                                                    
78

 

                                        

 When OK is pressed the Project Manager Road Project dialog will appear as shown below. 
Notice the Project name, the User name and Job # match what was previously set up. 

 

    

   

 

 

 

 

Project Name 

GEOPAK Job Number 
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Road Project Dialog  

 The top of the Road Project dialog box displays the Working Directory, Working Alignment 
(if defined), User and GEOPAK Job Number. In addition, a toggle for Working Alignment 
Influence Runs is also supported. The bottom portion of the dialog box displays the various 
processes supported during the design process. The small square in the upper right corner will 
condense the dialog box as depicted in the graphic below.  

 
 
 
 
 
 

 

                              
 
 
 

 

 

 

 

5.4.3- Create a Working Alignment 

The concept of a working alignment enables the designer to organize a project and to access project 
information without continually typing the required information. On a simple project, only one working 
alignments may be needed. However, on a more complicated project, an unlimited number of working 
alignments may be defined. With each working alignment, the designer can define associated data. The 
designer can easily change from one working alignment to another by selecting the desired alignment listed 
in the Select dialog. Once the working alignment is selected, all previously stored data is utilized in 
subsequent processing. Three tools relating to working alignments are located at the top of the Road Project 
box:             
 1)Select,  2)Define button, and 3)Working Alignment Influence Runs(toggle on left side of dialog box) 

 Click on the Select button to create a new Working Alignment as shown below: 

                           

Click this square will 
expand/condense the 

dialog box 

File pull down menu support Close and Exit:- 
 
Close- user returned to the Applications dialog box.
Exit-   user is exited from the Project Manager.

User can instruct the 
software to remember the 
Project, User, or Road in 
subsequent sessions. 
 
Note: EFLHD prefer not to 
select any option here. 

Auto Sink option can be enabled: 
 
The Road Project flow chart sinks 
behind all open views when any tool 
is selected from the flow chart. 
Once the tool is closed, the Road 
Project flow chart will be brought to 
the top of the view window.
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 The Select Working Alignment dialog appears. Use the pulldowns and select Run > New as 
shown below. Click on OK. 

                                                      

 

 The New Run Name dialog appears. Type in the name of the “Run” to create. The Description 
field is optional. Click on OK. 

                                                          

 The Select Working Alignment dialog appears. Highlight the desired run (you may eventually 
have several) and click on OK. 

                                               

 



                                                                                                                                                    
81

 Notice how the Project Manager (Road Project) dialog is now set to use the Working Alignment 
“spr”, as shown below: 

                                             

 

 Click on the Define button. We are now ready to being “defining” everything about the alignment 
that we want to use. 

                              

 

 The Working Alignment Definitions dialog appears using the working alignment “spr”. 

                             

 Complete each of the required “Sections” of this dialog by clicking on each and completing the 
fields. Required sections are Plan View, Pattern, Shapes, Cross-Section View, and Existing 
Ground. 

   

 You are now ready to begin the design. 
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5.4.4- Project Manager Process 

 

 

The primary Project Manager dialog box is depicted above. The advantage of utilizing the Project Manager 
rather than selecting functions directly from the Road menu is that pertinent information stored within the Project 
Manager is automatically displayed within the invoked dialog box. Therefore, job numbers, chain names, 
stationing, file names and data associated with the project do not have to be typed in each time a dialog box is 
utilized. However, if the user chooses to change the fields, they have that option.  

Many of the Project Manager processes function identically to their corresponding dialog boxes invocation from 
the Road menu. However, some of the procedures invoke the Select Run dialog box prior to invoking the actual 
dialog box. The Select Run dialog box enables the user to set up different options to use in alternative design 
choices or different typicals.  
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5.5- Create Horizontal Alignment (Geopak) 
 There are many different, and acceptable, methods of creating horizontal geometry using Geopak. Some 
 are described as follow:  

1. Coordinate Geometry (COGO) 

2. Graphical COGO/Horizontal Alignment Generator (both are similar) 

3.  Store Graphics.   

Any of these methods are acceptable to EFLHD. Regardless of the method used, the final alignment must 
be drawn into MicroStation using the GEOPAK D&C Manager, with the “V8_ENGLISH.ddb” (FLH) 
file.  This will assure that the elements are drawn with the correct symbology, matching the FLH 
standards. 

5.5.1- Coordinate Geometry (COGO): 
 

This method allows the user to have more precise control over tangent bearings, control point 
coordinates, etc., than with Store Graphics, if done properly. But the disadvantages of these methods are 
the Commands for the command line and input file methods are difficult to memorize, small adjustments 
are hard to make, and the process is time consuming. 
 
You can create the horizontal geometry by typing commands in at the COGO command line, by creating 
an input file with a sequence of COGO commands and loading it into COGO, or by using the dialog box 
driven Store Curve from Tangents, Locate Traverse, etc., tools that are accessed from the COGO pull 
down menus to generate the commands.  If you use the input file method, remember that the COGO input 
file name can only be 8 characters long, must have the job number as the last three digits in the name, and 
the extension has to have an “i”+ the operator code.  (i.e. XXXX101.isa), where the i stands for input file. 

 

 

                    
 
 
 
 
 

Tool Bar consist of drop 
down options and icons 

COGO Key-in: This 
field enables manual entry 
of COGO commands. 

Output Display 
Windows shows the 
results generated by the 
commands. 
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5.5.1.1- Steps to follow to create a Chain from Point A to B as shown: 

                              
Chain from Point A to Point B 
 
    Y (Northing) X (Easting) 
    
TAN1 From Point(5000): 1500.000 1250.000 ---Point A 
   To Point(5001): 1500.000 1367.957  
      
CUR1 Radius=818.511 

TAN2 From Point(5002): 1770.821 1976.230  
   To Point(5003): 2212.417 2373.845  

CUR2 Radius=818.511 

TAN3 From Point: 2473.161 2854.074 (5004) 
   To Point: 2518.881  3142.737  (5005) 

CUR3 Radius=1432.394 

TAN4 From Point:  2668.911  3591.129  (5006) 
   To Point:  2832.335 3898.485 (5007) 

CUR4 Radius=1432.394 

TAN5 From Point:  3000.000 4570.953  (5008) 
   To Point:  3000.000  5750.000  (5009) ---Point B 
 
 

 
Step 1: Open the Coordinate Geometry dialog box by clicking on the Coordinate Geometry button on  
  the Project Manager flow chart as shown: 

                                                 

A 

B 
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  You can also select the Coordinate Geometry button on the GEOPAK main dialog box. 

                                          
 

The Geopak Coordinate Geometry dialog box appears as shown below.       
                  

   

 Note:-If you are using Project Manager, Coordinate Geometry dialog box will be invoked.  
 Otherwise, the Job Number and Operator code will have to be entered in the COGO Startup 
dialog  box.  Project Name and Subject are optional fields.  Press the OK button to bring up the 
 Coordinate Geometry window. 

Step 2: Store Points 
 

  Select Store Point follow Element  Point  Store from the Coordinate Geometry dialog box. 

                             
 

 Enter Point # (start with 5000) 
 Check the Auto Increment Box 
 Enter the Northing and Easting for the point from above given data. 
 Store Point 
 Repeat until all from and to points have been stored. (You should have 10 points, starting from 

5000, 5001………5009) 
 Close the Store Point dialogue box. 
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Step 3: Store Chain for Tangent line 
 
  Select Store Chain follow Element Chain  Store from the Coordinate Geometry dialog box. 

 

                  
 

 Chain name: Tan# (Starting with Tan1) 
 Change Begin Station to Station As Is 
 Under Element Type select Point 
 Point Name: Type in the points between which the tangent falls. (for example: Tan1 lies 

between 5000 and 5001, so type 5000 first and hit Add, then type 5001 and hit Add) 
 Store Chain 
 Repeat until all tangents have been stored. (In all you should have 5 tangents, starting from 

Tan1, Tan2…….Tan5) 
 Close the Store chain from Elements dialog box. 
 

 
 

Step 4: Store Curve 
   
  Select Store curves follow ElementCurveStoreBy End Points from the Coordinate  
  Geometry dialog box. 

                          
 

 Name: Cur# (Starting with Cur1) 
 Enter the PC point# (To-point of back tangent)  
 Enter the PT point# (From-point of ahead tangent) 
 Change PI Point to Radius, and enter the radius of the curve from above given data. 
 Choose clockwise or counterclockwise based on the direction of curve. 
 Store Curve  
 Repeat until all curves have been stored. (In all u should have 4 curves, starting from Cur1, 

Cur2…..Cur4) 
 Close the Store Curve dialog box. 
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Step 4: Store Chain for whole Alignment 
   
  Select Store Chain again follow ElementChainStore From Element from the Coordinate 
  Geometry dialog box. 

 

                                    
 

 Chain Name: RCOGO 
 Change As Is to Begin Station and enter 10+00 
 Set the Element Type (which is Point at present) to Chain and add TAN1  
 Now set the Element Type to Curve and add CUR1 
 Continue adding all chains (tangents) and curves in the proper order. (TAN1, CUR1, TAN2, 

CUR2, ……….TAN5) 
 Store Chain 
 Close the Store Chain from Elements dialogue box. 
 Save this session. Go under File  File Utility in the Coordinate Geometry window. 
 Select  Save 
 Close the Coordinate Geometry window. 
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5.5.2- Graphical COGO/Horizontal Alignment Generator: 
 

Graphical COGO and the Horizontal Alignment Generator, allow the user to create coordinate geometry 
elements, much the same as the original COGO tools, but with a much more graphic and user-friendly process. 
 

 

5.5.2.1- Graphical COGO: 
 

 Graphical COGO can be accessed by selecting: 
  Applications>Geopak Road>Geometry>Graphical Coordinate Geometry, as shown below.  
 

                         
 
 

 Graphical COGO can also be accessed by selecting the icons from the main Geopak Road tool box. 
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5.5.2.2- Horizontal Alignment Generator: 
 

 Horizontal Alignment Generator can be accessed by selecting: 
  Applications> Geopak Road >Geometry>Layout Horizontal Alignments, or 
 

 Or Horizontal Alignment Generator can be accessed by selecting the icons from the main Geopak 
Road tool box. 

                         
 

 The Horizontal Alignment Generator can also be accessed using Project Manager by clicking on 
the Horizontal Alignment button on the flow chart.   

 

Note:-The Graphical COGO cannot be accessed directly from Project Manager. 

 

 The File pull-down menu allows the user to set preferences for how newly created elements will be 
displayed, how to name elements, and which geometry tables to use as a default. 

                                                 

 The User Preferences dialog is very useful.  It allows the user to preselect the Element symbologies 
for lines curves and spirals, as well as the symbology for the “Modify” tool.  This makes it very easy to 
distinguish the geometric components from each other while laying out the alignment.  
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Note:-1) An important thing to remember is that the components never have to be drawn 
graphically in order to be manipulated later.  COGO has several “Visualization” options.  It is 
possible to simply “Temporarily Visualize” a component or components for manipulation or for 
storing the components as a chain.  Graphics just make the .dgn file larger and also limit you to the 
old world of single precision.  The Visualization options can be set on the COGO dialog box.  I 
would recommend using “Temporary Visualization”.  This way nothing is ever written to the file.  

2) These symbologies are used only when the elements are NOT stored directly to the GPK. To store 
the elements as simple, graphic elements (single precision), the option, “Save as COGO Elements” 
must be checked OFF under the category “COGO Element Names”. 

3)  To specify the color of these elements for storing as COGO elements (double precision)…. 
Modify the .smd file via the Geopak User Preferences, (Applications > Geopak Road > User 
Preferences).  

 In addition you may also set up your own naming convention for storing the geometric components.  
This is done under the Category “COGO Element Names”.  

Under the Category COGO Element Names, you may setup your own naming convention for Points, 
Lines, Curves and Spirals.  If the names are left blank, the software will default to the following 
naming conventions, using the “Next Available” name concept:  

    Points…(1,2,3…)  
    Lines… (L1, L2, L3…)  
    Curves… (C1, C2, C3…)  
    Spirals… (S1, S2, S3…)  

 

                               

One very important option on this dialog is “Save as COGO Elements”, (mentioned earlier).  This is 
what differentiates between whether the components will be stored as graphics (single precision) or as 
COGO elements (double precision).  To save the components directly to the GPK database and as 
double precision, make sure this option is “checked”.  

 

Note:- The trick here is that the names you key-in will not take effect until this dialog is 
“dismissed”. 
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 Currently FLH/EFLHD does not have the Curve Design Tables setup yet. We are using as default 
setup by Geopak.  

 

 Under the Category Spiral Design Tables, a set of files have been set up to provide the user with an 
easy way to add spirals (using the AASHTO minimum lengths) to a user defined curve radii or degree.  
For example, when laying out an alignment with the new Geopak 2001 tools, the user simply keys-in a 
simple curve radius or degree and the spiral length values are automatically populated by accessing this 
“table” file.  

EFLHD uses the Spiral Design Tables. To access the Spiral Design Tables, path should be set to  

“M:\ Engineering_Software\Cadd_resource_v8\X_30\Standards\Bin\english or metric” 

 

 

The Design Tables menu allows the user to view the settings for the current default design tables.  In 
the Design Tables pulldown, the user sets the paths and file names for the tables to be accessed. Once 
the English or Metric Spiral Curve table is selected, select the design speed and number of lanes.  
These tables correspond with the AASHTO Green Book.   

 

                                     

 

  Note:-Currently EFLHD uses only the Spiral Curve tables (Metric and English).  
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 Under the Category Geometry Settings, the user selects the Curvature Definition, as shown below.  

                              

 Under the Category Dynamic Increments, the user selects the Increment adjustment Values, as shown 
below.  

If “checked” the option Activate PageUp/PageDown shortcut keys will allow the user to increment 
the elements during design by using the PageUp and PageDown keys on the keyboard.  

                                
 
 

 The tools menu activates the COGO tools that will be used to create geometry elements.  Selecting 
Tools>Main accesses the following tool frame. 

                           
 From the main tool frame , shown above, additional tools may be accessed from each of the six main 

tool box icons. Each of the tool boxes, as well as the tools from Graphical COGO, may be used 
together to create any combination of geometry, from the simplest to the most complex.  

Note:-Using these tools to set a horizontal alignment, if done properly, is just as accurate as 
traditional command line COGO. This process is slower than than using store graphics.  
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5.5.2.3- Examples of using the new Horizontal Alignment Generator… 

 First of all COGO must be running for this to work.  No need to worry about this though, because 
the software prompts you for a COGO session if you don’t already have one active. 

 
 Check your Horizontal Alignment Generator User Preferences settings as explained earlier to 

make sure that you have correctly selected all of the desired settings.  

 Check to make sure that your Spiral Design Tables are pathed correctly.  These tables aren’t 
actually necessary, but make it much easier when using spirals and making sure that you are using 
the minimum spiral lengths for the appropriate design speed and curvature.  The path (for office 
workstations) should be set to 
M:\Engineering_Software\Cadd_resource_v8\X_30\Standards\Bin\english. Browse to this 
directory and select the appropriate table file.                       

 
   

 Select the Main tool box from the Tools pulldown (as shown previously).  
 To place a typical Spiral Curve Spiral (SCS), (most common way): 

 Make sure that “Temporary Visualization” (my preference) has been selected in COGO.  

 Create the entry and exit tangents, using the Store Line by 2 Points tool.  

                         

  



                                                                                                                                                    
94

 Select the Place SCS (Intersecting Elements) tool.  Identify the tangents, (follow the on screen 
prompts).  Once the second tangent is identified, the 3 elements of the SCS will appear (as keyed-
in in the dialog).  To “Modify” the length values, you may highlight one of the length fields and 
use the little arrows for increasing or decreasing the values. Setting the Increment Values was 
explained earlier (above).  The position of the SCS can be easily warped into place.  When you are 
satisfied with the location of the SCS…simply data point the screen.  If you had “Save as COGO 
Elements” toggled ON, those components are now stored in the GPK database.      

 

 

 

 Storing these components as a chain is much easier with Geopak 2001.  Even though they are not 
actually drawn graphically… Geopak can see them.  To store (for example) these 5 components as 
a chain, invoke the Geopak 2001 Store Chain tool.  

                                                     
 With Geopak 2001 Store Chain there is no need to continuously click until all of the elements are 

collected.  Simply complete the dialog with the Chain Name, Begin Station etc… and data point 
any component that is visualized and accept it with another data point.  All adjacent components 
will be considered for the chain.  You will see several small arrows pointing in a direction.  These 
directional arrows are asking you if this is the direction that you want to store the chain stationing.  
If this is not the direction, simply click reset and the directional arrows will switch… or as some in 
the South say….”swap”.  Once the arrows are pointing the right direction, data point the screen 
again.  The components are now stored as a chain.  
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 You may have noticed that on the Store Chain dialog there is an “Opposing Element” option.  The 
options are Transpose and Create.  These options are given because sometimes the components 
may not be stored all going in the same direction.  When you store the chain at a direction and 
some of the components were stored in the opposing direction, you have the option to have 
Geopak Transpose those offending elements or Create new elements instead leaving the original 
ones alone…  I would recommend using Transpose and keep the GPK file smaller and cleaner.  
The recommended Max Gap setting for a metric design is 0.01 and for English design is 0.03. 

 

For a little more complicated example…. Let’s place an SCSCS, (an easy way) 

 Make sure that “Temporary Visualization” has been selected in COGO, (shown previously in SCS 
example).  

 Create the entry tangent, using the Store Line by 2 Points tool, (shown previously in SCS 
example).  

 Create the first SC using the Place SC Tangent to Line tool.  

Note: There is a “Truncate Back Element” option available with these tools, I would suggest using it 
to trim the back components. 

         

 

 Create the second SC using the Place SC Tangent to Curve tool.  

 

 

 Create the exit Spiral and it’s exit Tangent using the Place ST Tangent to Curve tool.  
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To create a switchback (delta that exceeds 180 degrees) SCS 

 Make sure that “Temporary Visualization” has been selected in COGO, (shown previously in SCS 
example).  

 Create the entry and exit tangents, using the Store Line by 2 Points tool, (shown previously in SCS 
example).  

 Invoke the “Place SCS (Intersecting Elements)” tool.  Make sure you have “Loop (Exterior 
Construction)” checked.  Identify and accept the first tangent.  Identify and accept the second 
tangent.  Pretty simple!  

 

             

 
 
There are many other cool tools available with Geopak 2001… such as Place Dynamic Alignment… This tool 
allows you to pre-select geometric values and design “on the fly”.   Give it a try.  

               

 

To Modify the Visualized elements: 
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Visualized elements can be further manipulated using any of the 4 “Manipulate” tools.  

 Move Plan View Element  
 Rotate Plan View Element  
 Extend Plan View Element  
 Delete Element  

It is very important to mention that visualized elements cannot be deleted from the GPK file with the normal 
MicroStation “Delete Element” tool.   That tool only deletes elements that are written to the design file.   To delete 
these visualized elements, use the “Delete Element” tool on the “Manipulate” tool box.   Of course these elements 
can also be deleted via COGO key-ins or COGO Navigator.  
 
 
 
 
 

TO VIEW THE OUTPUT LISTING 

 There are two ways to do this.   After the alignment is stored, activate the COORDINATE GEOMETRY 
dialog box.  

 At the top of the COGO dialog box type DES ALI [chain name].  
 This produces an output listing similar to the old RDS listing that many people are familiar with.  

OR… 

 At the top of the COGO dialog box type DES CHA [chain name].  
 …or… use the COGO pulldowns, Element > Chain > Describe/List/Print, select the chain and press 

Describe.  
 This produces the normal GEOPAK output listing.  

NEXT…To actually print a hard copy of this alignment, at the top of the COGO dialog box, type CLEAR, press 
ENTER, type DES ALI [chain name], press ENTER, or DES CHA [chain name], press ENTER, and type OUT 
[filename], and press ENTER.   These same commands are also available from the “Coordinate Geometry” dialog 
box “pull downs” located at the top of the dialog box.  

To display the alignment graphically, (for Final plans) see Display the Horizontal Alignment. 
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5.5.3- Store Graphics: 
 

The store Graphics procedure is the simplest and quickest method to create a horizontal alignment.  The user 
can use standard Microstation draw utilities to layout the alignment then use the Store Graphics tool to store 
the alignment into COGO.  Even though Microstation measurements are to single precision, GEOPAK stored 
elements are computed to double precision accuracy.  Store Graphics will make slight adjustments to the 
graphical element locations as required forcing each element in the chain to be exactly tangent to the 
immediately preceding element and the immediately following element.  These adjustments are always minor 
(e.g. the coordinates of a curve’s PC and/or PT may be adjusted a few millimeters to force the curve to match 
the tangents exactly) but they do occur and the user has no control over them.  However, if the graphical 
elements were drawn correctly then the chain that gets stored into the gpk file is exactly as “accurate” as a 
chain stored using any of the other methods. 

 This command cannot be accessed using Project Manager, but can be accessed the following two 
ways.  From the GEOPAK pull down menus select, Applications>GEOPAK 
ROAD>Geometry>Store Graphics 

                                      

 

 Or by selecting the icons from the Geopak Road tool box as shown below: 
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 Selecting the Store Graphics Icon will invoke the Store Graphics Dialog box.  You can store 
the elements as Complex Chain, Selection Set or Single Element. 

 

 

Note:-Advantages –Use simple Microstation commands to layout alignment, adjustments to 
alignment are quick, and the only point numbers used are on the alignment (usually just the first 
and last). 

Disadvantages – 1. Not as accurate as COGO.  Store Graphics makes minor adjustments to the 
as-drawn elements in order to get them to tie together mathematically.2. Cannot draw spirals 
using Microstation commands.  If spirals are needed, you must use Horizontal Alignment 
Generator to create that element, and then you may continue using Microstation commands.  

 

 
 

To display the alignment graphically, (for Final plans) see Display the Horizontal Alignment Section. 
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5.6- Display the Horizontal Alignment And Drawing Other Plan Features 
 
 

5.6.1- Display the Horizontal Alignment 
Geopak’s Design and Computation (D & C) manager is the tool that automates the display the Horizontal 
Alignment through the use of a hierarchical database, .ddb, containing information about each element of the 
horizontal alignment display to be placed within a set of plans.The .ddb file in use at EFLHD can be found at: 
M:\Engineering_Software\Cadd_Resource_v8\X_30\Standard\DDBS\English\V8_English.ddb 

 

 Access the D&C Manager by selecting the MicroStation pull downs:  
Applications > Geopak Road > Design & Computation Manager as shown below 

 
 

                    
 

 Or can be access from the Road Tools icon as shown below:  
 

 

Note:- The EFLHD .ddb file is already attached through project configuration setup. If EFLHD’s D&C 
Manager is not attached as shown above, then change it through File>Open>and select the” 
M:\Engineering_Software\Cadd_resource_v8\X_30\Standard\DDBS\English\V8_English.ddb”. 
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 In the “Design and Computation Manager” dialog box, Select CL Proposed Centerlines/Baseline as 
shown below:  
 

 
   

 Single click on Draw Plan & Profile … as shown below:  
 

 

 
   

 Key in or Select the Job Number … as shown below and click on OK (in both dialogs):  
 

 

 Note:- This step (shown above) will not be necessary if the Project Manage is open. 
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Display the Chain Information: 
 

 Toggle “Element Type” to Chains … as shown below:  
 

 
   

 Set the Label Scale as your Plan sheet scale.  
 Select the chain you want to display with a single click shown inside the circle. Alignment information 

will display onto MicroStation file. 

 

Annotate the Horizontal Alignment: 

 Again toggle “Element Type” to Stationing … as shown below:  

                       
 
 Set the Label Scale as your Plan sheet scale.  
 Select the chain you want to display with a single click inside the circle shown above. This will annotate 

your alignment stationing.  
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5.6.2- Draw Widening And Other Plan View Features for X30 Criteria (Geopak) 

 
To develop roadway features representing the proposed roadway to be recognized by Proposed Cross 
section tool as set in X30 Criteria files, two specific GEOPAK tools will be utilized: D&C Manager to 
determine element symbology and Draw Transition to place the elements between specific pairs of stations 
offsets. 
The D&C Manager is a tool that allows the user to standardize graphics elements (symbology) for drafting. 
FLH has developed a database (V8_ENGLISH.ddb) for D&C Manager. It is used to draw the elements 
which have preset standard symbology of the elements according to X30 criteria input file (especially for 
proposed cross section).           
The Draw Transition tool draws a line/curve based on a beginning station/offset and an ending 
station/offset relative to a selected chain. Use of this command includes road widening, edge of the 
pavement, shoulder, curb &gutter, retaining wall location, guardrail; curve widening, lane transitions and 
roadway stripping.  

 

Step I 
 
In your “wrk” file; 
 

 Access the D&C Manager by selecting the MicroStation pull downs:  
Applications > Geopak Road > Design & Computation Manager as shown below. 

 

                    
 

 Or can be access from the Road Tools icon as shown below:   
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Note:  The V8_ENGLISH .ddb file is  attached through project configuration setup. If FLH   
D&C Manager is not attached as shown above, then change it through                 
File>Open>and select the”V8_English.ddb”. 
 

 Five Categories are used to group and classify the features and items used in creating construction 
drawings. Define_dgn category is used specially for drawing X30 Criteria elements. This category 
contains two sub-categories: Proposed and Existing category. The sub-categories break down each 
classification into more specific items, such as Widening, Plan View Overrides, etc are the su-
categories of Proposed category. Within a category, the individual items that are included are 
designated according to the process that they will be used for. This hierarchical data structure 
functions much like a directory. Double clicking enables the user to move up or down within the 
database as shown below.   

                               
   

 In the “Design and Computation Manager” dialog box as shown above, Select Prop. Edge 
Widened Shape (same cross slope as shape). The second dialog box appears as shown below: 

                                
   

 Select Place Influence option as shown above.        
          When the place Influence toggle is activated, elements are drawn using the level, symbology and    
           attributes as defined in the GEOPAK database. 
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Step II 

 
 To invoke the Draw Transition dialog, select Application>GEOPAK Road>Plans 

Preparation>Draw Transition or select its icon from the GEOPAK Road tool palette as shown 
below. 

 

                         
 
 
 

 The Draw Transition dialog is shown below. 
 

                                  
 
 

 Fill in the Draw Transition dialog with the information for the transition. This includes the Job 
number, the reference Chain, the desired Beginning Station, Beginning Offset, and Ending 
Station and Ending Offset then click Draw. This will draw the elements you have selected in the 
D&C Manager. 

      To draw another element, select the element in D&C Manager and fill the Draw   
 Transition dialog for Beginning Station, Beginning Offset, and Ending Station and Ending 
 Offset as required for the specific element and then click again Draw. 
 

 
                                         

Note:  Draw Transition utilizes standard surveying convention for offsets. A positive offset 
(i.e., 55.0) would be to the right, while a negative offset (i.e., -55.0) would be to the left, of 
the chain. Orientation is according to the direction of stationing. 
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5.7- Create/Draw Existing Ground Profile (Geopak) 
There are two methods available for creating and storing an Existing Ground Profile; Traditional Method and a 
Draw Profile Tool Method. Any of these methods are acceptable to EFLHD. Regardless of the method used, the 
final alignment must be drawn into MicroStation using the “V8_ENGLISH.ddb” D&C Manager file.  This will 
assure that the elements are drawn with the correct symbology, matching the FLH standards. 
EFLHD’s preferred method i.e. Draw Profile Tool Method is explained in the following section.   

 
5.7.1- Draw Profile Tool Method (EFLHD Preferred Method): 

The Draw Profile Tool Method allows for not only storing the ground profile into COGO, but also the ability 
to draw it (graphically) without actually going into the Design and Computation Manager  directly.  
You must have a horizontal alignment (Chain) stored in COGO and a  .TIN file.  

 
 Create a new DGN file for the Profiles using “Sur_ft2D.dgn” seed file.  

 Rename this file according to the EFLHD Naming Convention (e.g. 01-lop10(2)_pro.dgn).  

  Open a MicroStation  design file and invoke the Draw Profiles tool via the pulldowns, (as shown below):  
 Applications > Geopak Road > Plans Preparartion > Draw Profiles  
 … or use the Draw Profiles icon, (as shown below):  

                                        

 When the dialog box (below) appears, Select the Job Number and Chain. You’ll notice that unless you 
already have a profile cell placed in the design file, all fields will be ghosted out except for the 2 icons to 
the right of the Job Number and Chain fields. You must place a profile cell before you can create a 
profile.  
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5.7.1.1- Create Profile Cell 

 Click on the Dialog Profile Cell Control icon as shown below: 

                      

 The Profile Cell Control dialog appears as shown below. Click on Place Profile Cell: 

                     

 The Place Profile Cell dialog appears (shown below) along with the Profile Cell attached to your cursor 
awaiting placement.  

 The beginning station should populate automatically. The Horizontal and Vertical scales are normally set 
as shown below for 10H and 1V scale with No Gap. The Top Elevation and Bottom Elevation of Cell 
Range are set according to profile minimum or maximum elevation range.  

       
       
                                                                          < Origin Elevation of the Profile cell  
 

 

                                                                     <Elevation range can be gotten from the contour lines elevations. 

 

 Once the dialog is completed, data point in your design file somewhere where the profile cell won’t 
interfere with other previously drawn graphics. 

                                            

Note:- The profile cell origin should look similar to the graphic shown above. The profile cell text 
parameters are set by the active MicroStation text settings. 

 Close the Profile Cell Control dialog box. 
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5.7.1.2- The “Surfaces” Tab: The Surface tab defines the surfaces utilized as source data when drawing 
 profiles. Multiple surfaces from a variety of sources can be drawn in a single processing. Each surface to 
 be drawn must be added to the list box. 

 Select the Surface tab in Draw Profile dialog box after the Profile cell is established, the dialog box 
dynamically changes as shown below. 

                
 

 Select Label Scale according to the Plan sheet scale for the texts size (e.g. 100 for 100 scale Plan Sheets).  

 On Surfaces tab as shown above, select the folder icon in the Details area, and then select the .TIN file to 
cut the profile. Set the Method to Triangles (This instructs the software to compute elevations at each 
location that the chain intersects a triangle leg from the TIN). 

 Use By Feature mode in the Display Setting area of the dialog box. Click the paintbrush icon and select 
the item “EXPROF Existing ground Profile”from the D&C Manager (V8_English.ddb).  
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 Press OK. 
 Click the Add Surface Setting icon to add the profile to the list box as well as draw the profile into the 

MicroStation file. 

                                                 
 
 

 The final setting on Draw Profile for Surface tab is as shown below. The recommended Filter Tolerances 
in EFL should be left at the default values of Horizontal=0.30 and Variance=0.10. 

 

                                                                

Note:- Use the following icon as shown below to store an Existing Profile in COGO, though it is not 
required to display into your MicroStation  file in EFLHD. 

                

 Software now will display your Existing Profile in your design file. 
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5.8- Create Proposed Vertical Alignment (Geopak) 

There are two ways to create proposed Vertical Alignment graphically.    
   

5.8.1- The “VPI Based” Profile Design Tool: 

 Select the Vertical Alignment button on the Project Manager dialog box as shown below: 

                  

 or Select APPLICATIONS > GEOPAK ROAD > GEOMETRY > LAYOUT PROFILES (VPI  
  Based) or from the Road Tools icon as shown below: 
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 Most likely… if you’re at this point in your design, you have already extracted a ground profile and have 
it displayed graphically.  Click on Identify Cell, data point the cell, click on OK.  
   

 This will invoke the GEOPAK Profile Generator as shown below:  

 

 From the pull down menu, select File > Preferences….   This invokes the Preferences dialog as shown 
below:  

                                              

This is where you set the preferences for dynamically laying out the profile. User has the option of 
selecting Maintain K Value or Maintain Curve Length.   We typically select Maintain Curve 
Length.   When finished, click on OK.  

 From the pulldown menu, select File > K-Values Table. This invokes the K-Values Table dialog as 
shown below:  
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 Using the File pulldown, select File > Open and browse to the folder  M:\Engineering_Software\ 
Cadd_resource_v8\X_30\Standards\Bin\english\ and select the appropriate K-Value table.  Press OK as 
shown below. Press again OK on K Values dialog. 

 

 The GEOPAK Profile Generator is shown below (with the K-Value table “Kvalues_2004english.kvl” 
selected):  

 

 To begin using the GEOPAK Profile Generator, click on Dynamic and snap to the beginning of where 
you want the profile to start.   This would usually be exactly at the beginning of the existing ground 
profile.   Accept the snap with a data point of the mouse.  

 Pan on ahead, click on Insert After and data point the screen where the next VPI should be.   I would 
suggest laying out all the VPIs first, save the file, using the pulldown, File > Save As and then go through 
designing the vertical curves.   The vertical curves can be entered by typing in the length in the field, or 
simply selecting the design speed on the GEOPAK Profile Generator.  

 When finished, save the file again.   The vertical alignment can now be reviewed using COGO by using 
the COGO pulldowns Element > Profile > Print.   Select the Profile and click on Apply.  
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5.8.1.1- Reload/Modify the Profile: 

 

 Select the Vertical Alignment button on the Project Manager dialog box (as shown in Section 5.8.1). 

 Click on Identify Cell, data point the cell, click on OK (as explained in Section 5.8.1).  
 

 This will invoke the GEOPAK Profile Generator.  

 Select File > Load Profile on Profile Generator dialog box as shown below.           

  

 Click on Select and pick the Profile.   

 Click OK will load the Profile Generator with profile data for edit as shown below. 

          

 

  Click on Next VPI to move to the VPI to be adjusted or use the horizontal slide bar.   When the little 
reference circle is on the VPI to be adjusted, click on Dynamic and slowly move the cursor into the 
circle.   Nothing will happen until the cursor gets close to the reference circle.   You may then modify the 
profile dynamically.   When finished modifying, (make sure Redefinition of Elements is On in the 
COGO dialog box and save the file again. VPIs can also be inserted or deleted, dynamically.  
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5.8.2- Display Proposed Profile: 

Use the Draw Profile Tool setup to display Proposed Profile.  

 
  Open a MicroStation  design file and invoke the Draw Profiles tool via the pulldowns, (as shown below):  
 Applications > Geopak Road > Plans Preparartion > Draw Profiles  
 … or use the Draw Profiles icon, (as shown below):  

                                        
 

 Draw Profile dialog box appears as shown below.  

 

                                                                

 Select the COGO tab.   
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5.8.2.1- The “COGO” Tab: The COGO tab is utilized for drawing any profile that has been previously 
stored into the gpk file. The functionality of the remainder of the dialog is very similar to the Surfaces tab.  

 Select the COGO tab in Draw Profile dialog box, the dialog box dynamically changes as shown below. 

                                 

 Select the Profile Name to be drawn in Details section of the icon. Keep the Vertical Offset defaults to a 
value of 0. Station Limits may also be specified to have the software draw only a portion of the profile. 

 Use By Feature mode in the Display Setting area of the dialog box. Click the paintbrush icon and 
select the item “DPROF Design profile”from the D&C Manager (V8_English.ddb).  
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 Press OK. 
 Click the Add COGO profile Setting icon to draw the profile into the MicroStation file as shown below. 

                                                 
 

 Software now will display your Proposed and Existing Profile into MicroStation file. 
 
 
 
 

5.8.3- To print a Vertical Profile Output file: 
 
 

 Open COGO 
 Use pull downs, select Element>Profile>Utility 
 Select Profile (e.g. PROSPR) to be printed as shown below. 

                                                    
 

 Select Print icon as shown above. The Coordinate Geometry dialog box will display the Profile data as 
shown below. 

 

                    
 

Add COGO Profile Settings 
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 Type ‘Out ProSPR (File name, maxm 8 character) in COGO Key-in and Enter, as shown below. 
 

 
 

 GEOPAK COGO will create an output file for the proposed data file ProSPR714.osa in working directory. 
 Where 714 is the Job number and osa stand for Output for User SA for this project. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Out ProSPR 
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5.9- Existing Ground Cross Sections (Geopak) 
 

5.9.1- Draw Pattern Lines (Geopak) 

 
The project designer shall create a design file containing the pattern lines representing the locations of all 
cross sections in the process of generating the existing and proposed cross sections, earthwork etc. The 
pattern lines for each alignment, along which original ground cross sections are derived, shall be 
distinguished by the pattern lines layer name P_GPK_Pattern_01, P_GPK_Pattern_02 …, etc in EFLHD.  
 

 

 Create a new dgn file (give the name e.g. 01-xxxx_wrk.dgn) and reference your dgn file that contains 
your chain to this file just to be able to see position of the chain.  

 Select the Draw Pattern button from the Project Manager dialog box as shown below: 

                  
 

 The Draw Pattern Lines dialog appears as shown below:  

                        

 This application will simply draw normal MicroStation line elements perpendicular to your chain at 
user specified increments, station ranges, and widths and at user specified Level Symbology. To 
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select the Level Symbology, double click in the rectangle to the right of Level Symbology at the 
bottom of the dialog.  

 The Geopak Set Feature dialog appears as shown below:  

                                   

 Complete the Geopak Set Feature dialog settings as desired and press OK. 
 Complete the Draw Pattern Lines dialog settings as desired and press Draw Pattern Lines.   You should 

now have a series of lines perpendicular to your referenced chain.   Later, we will use these lines to 
generate existing ground cross sections from the “TIN” file.  
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5.9.2- Generating the Existing Ground Cross Sections (Geopak) 

 
First of all the designer must have the following: 

1) A .TIN file.  
2) A .dgn file containing your “pattern lines”. (explained in Section 5.9.1)  
3) A horizontal alignment stored in COGO. (explained in Section 5.5)  
4) A .dgn file to create your “existing ground cross sections”.  

 

 Create a new dgn file(give the name e.g. 01-xxxx_Dxs.dgn). The existing ground cross sections 
will be drawn in this dgn file.         
  

 Select the Existing Ground Cross Sections button from the Project Manager dialog box as shown 
below: 

 

                      

 The Draw Cross Sections dialog will appear as shown below:  
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 Select the “XS Cells” Tab: Here the designer tells Geopak where to find the information to create 
the cross section cells and how they are to be laid out.  

 Select “By DGN File” method for the selection of the Pattern.  

 Toggle on the desired element parameter, (i.e.. Level, Weight…)  the press the Select button.  The 
Mask dialog is displayed, wherein the desired parameter settings may be identified.  You may 
select as few or as many parameters to identify the desired pattern lines or line strings. Or use the 
match button to select the element parameters. 

 Select Levels “P_GPK_Pattern_01” (Or select the levels created during the Draw Pattern 
procedures). 

 

 Select Scale to 10 and 10 as a standard practice in EFLHD. And keep all the setting for spacing as 
default as shown above. 

 Select the Surface tab in Draw Cross Section dialog box, the dialog box dynamically changes as 
shown below (The user creates ground cross sections from a TIN file through this tab). 
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 Select the folder icon in the Details area, and then select the .TIN file to draw the cross section. Set 
the Method to Triangles (This instructs the software to compute elevations at each location that the 
pattern lines intersect a triangle leg from the TIN) and select Type to Line. 

Note: For several reasons, these elements should be drawn as lines not line strings. 

 Use By Feature mode in the Display Setting area of the dialog box. Click the paintbrush icon and 
select the item “Exist Ground in XS”from the D&C Manager (V8_English.ddb) as shown below.  

 

                    
 
 Press OK. 
 

 Recommended Filter Toleraces at EFLHD are shown below: 

 Metric tolerances are .03 and .009  
 US Customary tolerances are 0.10 and 0.03 (as shown below):  

                               

 Click the Add Surface Setting icon to add the surface to the list. (Delete any incorrect surfaces) 
  

                                                 
 
  
 Click on the Draw button located in the upper right corner of the dialog to draw the existing cross 

section in the design file. 

 M:\CADD_Resources_V8\X_30\Standards\DDB\V8_English.ddb 
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5.10- Developing the Shape “Superelevation”(Geopak) 
 

A graphical representation of the superelevation  transition breaks can be produced in the form of MicroStation 
complex shapes. These complex shapes are plotted in a design file and read when running Templates to produce 
the Proposed Cross sections. 
 The user fills out several dialog boxes in order to create an ASCII input file.   When this input file is executed, 
the results are graphical elements representing the lane widths and superelevation cross slopes.   I would 
describe these graphical elements as intelligent 2D elements.  

The Designer must have a horizontal alignment stored in COGO, a proposed profile stored in COGO, and a dgn 
file to create a complex Geopak Shape.  

 

 Open the design file(01-xxxx_wrk.dgn) that you created for Pattern lines (See Section 5.9.1). You will 
draw Shapes for Superelevation in this design file. 

 Select the Calculate Superelevation button from the Project Manager dialog box as shown below: 
 

                  
 

 The Select Run dialog appears. Use the pulldowns and select Run > New as shown below. Click 
on OK. 
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 The New Run Name dialog appears. Type in the name of the “Run” to create. The Description 
field is optional. Click on OK. 

                                                          

 The Select Run dialog appears. Highlight the desired run (you may eventually have several) and 
click on OK. 

                                                

 The Automated Superelevation dialog will appear as shown below:  
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 Set the directory for Superelevation Preferences by using the pulldowns File > Directories as as 
shown below: 

                                          

 Click on Default All (as shown below) and all directories will be set as shown below. The example 
below illustrates the English directory paths.  

For Metric the path is M:\Engineering_Software\Cadd_Resource_V8\X_30\Standards\Bin\Metric. 

                                    

 Click on Symbologies to set the element symbology for the Auto Shapes.  It is recommended to 
use P_RDW_Super_Shapes for the shapes as shown below.  
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 The Superelevation Preferences (file) can be selected it from the Automated Superelevation 
dialog as shown below:  

                            

Note:-AASHTO 2004 recommended that the proportion of runoff length on the tangent range 
from 60 to 90 percent for all speeds. FLH has selected options within the range of AASHTO 
2004 recommendation. Typical preference is set 67% and developed three set of preferences 67-
33, 70-30 and 80-20 for transition distribution as shown above.         
 Explanations of this can be found on page 175 in AASHTO 2001 and on page 182 in AASHTO 
2004.  

 The next step is to simply tell Geopak a little more about your design.  Complete the top portion of 
the Automated Superelevation dialog:  

                                     

 

 Select the GPK file  
 Identify the Chain  
 Key-in the Design Speed  
 Select the Superelevation Preference file   
 Select the maximum “e” value  
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 Select from the toggle Divided or Undivided.  We typically design 2 lane roads, so select 
Undivided.  

 The L Selection is made for you.  It’s tied to the Superelevation Preference file selection.  
 Select the Profile.  Click on both the Left and Right Tabs to make sure that the Profile has been 

selected for both.  
 For most cases, set the Tie option to Offset and the Offset data field to 0.00.  

 

 Select Quick Entry for your shapes as shown below:  

                                                           

 The  Quick Entry tool allows the user to enter the data for both the left and right shapes 
simultaneously… however the Dependency must be changed manually if one is desired to be 
Independent.  

 Enter the values in the data fields and press OK.  

                                       

 The result is shown below:  

                                 



                                                                                                                                                    
128

 As mentioned earlier… as a result of using the  Quick Entry tool, the Right shape will also be set to 
Dependent.  To change the right shape to be Independent, simply click on the Right tab and uncheck the 
Dependent box (as shown below).  I normally create one side Dependent and the other Independent 
simply so that they are automatically drawn in different colors, (see Symbology pull down explained 
previously).  Both sides can actually be Dependent, but they both cannot be Independent.  

                                  

 Note:- Remember, all of this is done to simply create an ASCII input file, (which can be edited).   

 Now fill the Input File name and click on Generate Superelevation Transitions (This file will be created 
and placed in your working directory).  

 When the input file is created the Geopak Text Editor will automatically pop up as shown below.  Click on 
the icon at the far right (Create Superelevation Shapes) to process the file.    

                    

 Once pressed the “Create Superelevation Shape”, the superelevation shapes will be drawn into the 
MicroStation design file. 

   

IMPORTANT:  You should always review how the shapes have been calculated and drawn, before 
proceeding any farther with your design. You may also edit this file according to your project requirement. 
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5.11- Proposed Cross Section (Geopak) 

 Open the design file (01-xxxx_Dxs.dgn) which was created for the Existing cross section (Section 5.9.2). 
The Proposed Cross section will be developed on the top of Existing Cross Section. 

 Open Project manager and put a check mark in the white box for Working Alignment Influence Runs as 
shown below: 

                          

   Note:- Making sure the working alignment is defined. 

 Select the Proposed Cross Section button from the Project Manager dialog box as shown below: 
 

                  
 

 The Select Run dialog appears. Use the pulldowns and select Run > New as shown below. Click 
on OK. 



                                                                                                                                                    
130

                                                      

 The New Run Name dialog appears. Key in the name of the “Run”. The Description field is 
optional. Click on OK. 

                                    

 The Select Run dialog appears. Highlight the Run and click on OK as shown below: 

                                     

 

 The Proposed Cross Sections dialog appears. Notice that the name of the Run (in this case 
Run_1) also appears at the top of the dialog as shown below: 
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 Click on XS DGN File and browse to the cross section DGN file. Adjust the Tolerance setting as 
described below: 

                                   

Note:- The “Tolerance” setting is very important.      
  For Metric projects, tolerance= 0.003, and for US Customary projects, tolerance= 0.01. 

 Click on Pattern and put a check in the white box for Use Working Alignment. Since your 
pattern lines have been previously defined in your working alignment “spr”, there is no need to 
identify them again. 

                                   

 Click on Existing Ground and put a check in the white box for Use Working Alignment. Since 
your Existing Ground has been previously defined in your working alignment “spr”, there is no 
need to identify it again. 

   0.01 
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 Click on Shapes. This Typical Section requires superelevation shapes. Put a check in the white 
box for Use Working Alignment.  

                                        

 Click on Shape Clusters. Initially the dialog appears as shown below, basically blank with many 
of the option buttons ghosted out: 
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 Click on the Scan button and the List of Clusters dialog appears as shown below. Highlight the 
shape cluster: 

                                                  

 Click on the Add button as shown below: 
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 When the Add button is pressed the shape cluster information gets added to the collection 
window. Highlight the information in the collection window. The Typical button becomes 
unghosted. Click on the Typical button as shown below: 

                                                 

 The Typical Sections dialog appears as shown below. Select the desired Typical Section.  
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Note:- Note the Description button located on the right side of the dialog. When pressed, this 
invokes a file that provides detailed information on how the typical works including detailed 
drawings. 

 For this example we are using Undivided New Construction, so select UNPAVT. 
You may apply this Typical Section to the Whole Chain or a Station Range. When Apply to 
Station Range is selected, be sure to include the region numbers, as shown below (r 1). 
 
Note:-Do not check the white “On” Chain box. Chances are you will never use this option. 

 Select Apply at the bottom of the dialog. 
Each Typical Section is associated with different combinations of criteria files. When Apply is 
pressed, the user is basically instructing the software what criteria files to use (and where) and 
populates the Proposed Cross Sections dialog as shown below: 
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 Click on Define DGN Variables. You can ignore this portion of the Proposed Cross Sections 
dialog as it only applies to the Automated Cross Section Labeling Typical. 

            

 Click on Define Variables. This portion of the dialog is where you specify “Global” variables 
such as the name of your mapping file where all the existing features are drawn (existing fence, 
existing edge of pavement…....). You must also specify the names of all other DGN files where 
the software is supposed to look for plan view elements, such as proposed widening lines, or 
proposed guardrail. 

- Highlight the Variable, (such as CROSS SECTION DGN), by clicking in the white area.  
- Once highlighted, the default value will populate the Value field.  
- Key-in the Value and press Modify.  

                         

 Click on Redefinable Variables. This portion of the dialog is where the user can set project 
specific values for their design. 
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 In the example below, the 1st Surfacing Layer variable (_d_SurfacingLayer1Thickness) needed 
to be modified. The Variable was highlighted and the Edit button was pressed. When Edit was 
pressed the Redefinable Variables Editor dialog was invoked. The default value was changed to 
0.03. The Save button was pressed. 

               

Note:-See Appendix-A for more help on Editing Redefinable Variables. 

 

 Click on Plot Parameters. Uncheck all Plot options as shown below: 
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 Drainage is not used in Eastern Federal Lands.       
  

 When all modifications are completed, save the Run settings using the pulldown Files > Save 
Settings as shown below: 

                                          

 To execute the Proposed Cross Section Run, use the pulldown Files > Run as shown below: 

                                         

 The dialog below will appear. Set the dialog to To Screen or to create a .log file by selecting To Log File. 
Check Pause On Each Section and press Apply. 

                                  

 After the first cross section is plotted, you may uncheck the Pause on Each Section toggle and press 
Apply again to complete the run. 
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5.11.1- Save Backup of Proposed Cross Section Run as an ASCII Input File 
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5.12- Draw Construction Limits (Geopak) 
 

This will draw the graphical elements representing the top of cut and toe of fill on the Plan view. 
First of all the designer needs to have a cross section file (e.g. 01-xxxx_Dxs.dgn) containing existing ground and 
proposed elements,( i.e. top of pavement, ditch, cut and fill slopes etc.) and a design file(e.g. 01-xxxx_des.dgn) 
for displaying construction limits graphically. 

 
  

 Open a design file (01-xxxx_Dxs.dgn) containing your Existing and Proposed Cross Sections.  
 Open Project manager and Select the Limits of Construction button from the Project Manager dialog 

box as shown below: 
 

                  
 

 The Select Run dialog appears. Use the pulldowns and select Run > New as shown below. Click on OK. 

                                                      

 



                                                                                                                                                    
141

 The New Run Name dialog appears. Type in the name of the “Run” to create. The Description field is 
optional. Click on OK. 

                                                          

 The Select Run dialog appears. Highlight the desired run and click on OK. 

                                                

 
 

 The Limit of Construction dialog appears as shown below:  

                                             

 Key in all appropriate data.   The Plan Dgn (e.g. 01-xxxx_des.dgn) field is the name of the .DGN file that 
you want the construction limits elements to be drawn into. Set the Tolerance to 0.03 
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 The Parameters button, when pushed, brings up the Plot Parameters for Construction Limits  dialog.                 

 

                            

 

Note:-These construction limit lines should match the weights and line styles shown on the 
“Conventional Symbols and Abbreviations” sheet shown in your plans.   The EFLHD 
CADD standards call for these lines to be drawn on Level name 
P_RDW_Slope_Stake_Limits. 

      Cut Line… color 2, weight 3, line style 1,  
 Fill Line…color 2, weight 3, line style 3  
 Transition Line…color 2, weight 1, line style 4,  
 

 An option is the “Place Construction Limit” in the Plot Parameters for Construction Limits dialog.   When 
this is toggled on, text may also be drawn in the Plan dgn file (never used in EFLHD).  

 When finished keying in your Plot Parameters for Construction Limits, press OK.   After double 
checking all the fields in the “Limit of Construction” dialog press APPLY. 

 If everything was successful, you can open the Plan Dgn (e.g. 01-xxxx_des.dgn) file that you selected 
 and see your construction limits. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



                                                                                                                                                    
143

5.13- Earthwork Quantities (Geopak)   
 

FLH has created a seed earthwork run that is in sync with the .x30 criteria. The actual file is located on the 
server under M:\Engineering_Software\Cadd_Resource_V8\X_30\Standards\Seed_runs\projdbs\user\. The name 
of the file is FLH.004 

 
Follow the steps below to use the seed earthwork run 
 Open a cross section dgn file (01-xxxx_Dxs.dgn) that contains your proposed Cross sections elements. 
 Open Project manager and put a check mark in the white box for Working Alignment Influence Runs as 

shown below: 

                          

 Select the Earthwork button from the Project Manager dialog box as shown below: 
 

                  
 

 Select Run > Copy > Project from the pulldowns, as shown below:  
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 Using the Browse capabilities of the Directories portion of the dialog, double click your way to the folder 
M:\Engineering_Software\Cadd_Resource_V8\X_30\Standards\Seed_runs\, as shown below. Select 
FLH.prj and press OK.  

                                 

 Select [user] and press OK, as shown below:  

                                     

 Select earthwk and press OK, as shown below:  
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 Type in a Run Name that fits your project and an optional Description. Press OK, as shown below:  

                                   

 Select your earthwork run and press OK, as shown below. Be patient, as it may take 30 seconds or so to 
copy the run from the server:  

                                    

 The Project Manager Earthwork dialog will appear, as shown below. Notice the name of the run is shown 
in the blue title bar:  
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 Click on the XS DGN File category on the left side of the dialog and click on the Select button to select 
your cross section file.  

 Adjust the Tolerance to one of settings shown below.  
o Metric projects should have a Tolerance setting of 0.001  
o US Customary projects should have a Tolerance setting of 0.03  

 

                    

 Selecting the XS DGN File and setting the Tolerance setting are the only mandatory adjustments that need 
to be made to this run.  

 Other categories (such as Centroid Adj) can be adjusted to suit your project as desired.  

 When all adjustments are complete, save the run by using the pulldowns File > Save Settings, as shown 
below:  
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 To process the earthwork run, select Run from the pulldowns File > Run, as shown below:  

                                

 The Earthwork dialog will appear as shown below. Set the dialog to To Log File, type in a name for your 
earthwork report, toggle Pause On Each Section to ON and press Apply.  

                              

 After checking your first cross section, toggle Pause On Each Section to OFF and press Continue as 
shown below:  
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 The earthwork report can be reviewed using any ASCII text editor.  

 

 The documentation below is simply for illustration on how Geopak interprets the various elements drawn in a 
cross section file. The examples below do not reflect the current levels or colors used with V8.  

 
 

Below is what the output file (at station 12+160) would look like. 

 
             Material Name    End Areas  Unadjusted Adjusted   Mult   Mass 
Station                                  Volumes    Volumes   Factor Ordinate 
                              (square    (cubic     (cubic                    
                               meters)    meters)    meters)                  
----------- ---------------- ---------- ---------- ---------- ------ -------- 
12+160.00   ITEM_NO._20401__ROADWAY_EXCAVATION 
                Common Exc       0.00          0          0   1.00 
              Subgrade Exc       0.15          4          4   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         0.00          0          0   1.00        4 
            ITEM_NO._20801__STRUCTURE_EXCAVATION 
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                Common Exc       0.66          7          7   1.00 
              Subgrade Exc       4.26         43         43   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         0.00          0          0   1.00        4 
                Mass ordinate for ITEM_NO._20801__STRUCTURE_EXCAVATION = 49 
            SUITABLE 
                Common Exc       0.00          0          0   1.00 
              Subgrade Exc       0.00          0          0   1.00 
               Subsoil Exc       0.00          0          0   1.00 
                    Fill         1.22         87         87   1.00      -83 
            ITEM_NO._40101__HOT_ACP 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         0.54         11          0   0.00      -83 
            ITEM_NO._30201__EMULSIFIED_BASE_GR_D 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         0.43          9          0   0.00      -83 
            ITEM_NO._30101__AGGREGATE_BASE_GR_D 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         1.10         22          0   0.00      -83 
            ITEM_NO._20407_SELECT_TOPPING 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         2.33         47          0   0.00      -83 
            ITEM_NO._25103__KEYED_RIPRAP 
                Common Exc       0.00          0          0   0.00 
              Subgrade Exc       0.00          0          0   0.00 
               Subsoil Exc       0.00          0          0   0.00 
                    Fill         3.85         39          0   0.00      -83 

 
 
 
 
 
 
 
 
 
 

5.14- Reports (Geopak) 
 

GEOPAK uses the proposed cross section files to produce staking reports in EFLHD format.  The creation of 
these will be required on all EFLHD projects that have cross sections.  These reports include the Subgrade 
Template Report, the Staking Details Report and the Blue Top Report. 
  
With the development of FLH standard files and the x30 criteria, Central Federal Land has developed a 
Microsoft Visual Basic Application (MVBA) to generate a Subgrade Template Report. This new cross section 
report replaces the previously generated FHWA Slope Stake Report and the Red Top Report. 
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GEOPAK progresses from left to right across each cross section while preparing each report. The user will 
need to provide the level symbology of the existing ground and all the proposed elements to be reported on.  
These reports will be placed in ASCII files for ease of printing and electronic transfer. 
 
The following sections will describe the processes used to create each of the reports. 

 

 

5.14.1- Subgrade Template Report: 
 

The Subgrade Template Report includes the red top (Subgrade) stake locations plus points at all breaks in 
the roadway prism cross-section (i.e. ditch lines, hinge points, curb lines, sidewalks, benches, walls, etc.), 
plus the slope sake catch point and the reference hub point.  
The Subgrade Template Report MVBA evaluates text elements within GEOPAK cross sections and produces 
a report based on the text elements found that match the user-specified search criteria. 
The Subgrade Template Report provides a better format for presenting staking data to contractors, is easier 
to understand, provides ease for quality control check, and allows for unlimited number of template points.  
Subgrade Template Point Identification Sheets were developed to help clarify the information contained in 
the Subgrade Template Reports. Subgrade Template Point Identification Sheets are used to identify template 
points along each typical cross section. These Sheets can be access on 
“M:\Engineering_Software\Cadd_resource_v8\Standard_Shts\SG_Template\subgrade_template.dgn” 
directory. 

 
 Open the cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and proposed Cross 

sections. 
 Select the Plan View Design button from the Project Manager dialog box as shown below: 

 

                  
 
 
 The following dialog box will appear. Select the Design and Computation Manager Icon.  

 

                                                     
 

Note:-D & C Manager can also be accessed through Applications > GEOPAK ROAD>Design & 
Computation Manager or from the Main Geopak Road Tools dialog box. Any method can be used to 
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activate the D& C Manager, but make sure the project manager dialog is activated prior to accessing 
the Subgrade Template Report MVBA; this will allow the MVBA to access project related settings. 
  

 
 Select the CFL Subgrade Template Report from the MVBA Applications category in the 

V8_English.ddb (D&C Manager) as shown below.  
 

                                  
 
 

 Double click the Subgrade Template Report. The Subgrade Template Report dialog box will 
appear as shown below.  

                                

                                   
Note:-The Subgrade Template Report MVBA has three tabs which must be filled in prior to 
generating the Subgrade Template Report. The first tab entitled “General” contains general 
information including, Job #, Chain, Begin and End Station and the headers for the report.  

 
 Enter the project information as shown above. Toggle on Write Subgrade Trace Elements, while the 

report is generated, a trace line is drawn to spot check the text points selected for the report. The trace 
line is drawn to a level named X_P_Subgrade_Trace. The trace line can be visually reviewed to ensure 
the correct path was used.  
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 Select “Search Symb” tab. Under this tab, symbologies for Text, Existing Ground, and Proposed Grade 

needs to be defined. Symbology can be defined by matching or by selecting levels, colors, weights and 
styles.  

 

                                                        
 
 
 

Note:-When the Subgrade Template Report MVBA is invoked, the VBA loads a default Subgrade 
Template Settings (.sts) file and automatically places it into the working directory. The default 
Subgrade Template Settings (.sts) file contains all the settings of the Search symb tab  and the 
Search Text tab according to FLH Template setup.The user can modify the settings as appropriate 
for their project and save this file or rename the file and save it to the Working Directory. 
 
  
 

 Select the “Search Text” tab. Identify all the text to search for in the cross sections that define the path 
along the subgrade to generate the report. The default Subgrade Template Settings (.sts) file contains 
the text to generate report for a standard project. Modify, delete or add text values based on the typical 
section of your project. Use the Subgrade Template Point Identification Sheets as a guide in identifying 
text points.  

 
 When the Reference hub cells have been used and found, the report will use “Refhub” to label the 

point in the report. Any cell with the name “ REFHUB” found in the cross section and lying on the 
existing ground will be listed in thereport. 

 
Reference Hub is not used in any of the EFLHD project for the staking purposes.  

 Select the “Search Text” tab. Select the level X_Text_Search, X_Text_Wall_Points and 
X_Text_Subgrade, associated colors, weights and styles. Use the Match button to select the 
symbology.  

 
 Select the “Existing Ground” tab. Select the level X_E_Ground_XS, associated color, weight and style. 

Use the Match button to select the symbology.  
 

 Select the “Proposed Grade” tab. Select the proposed grade symbology from Slope Stake Cut/Fill to 
Slope Stake Cut/Fill; define the path to search for the text to generate the report. Use match button to 
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select the symbology and use highlight button to view selection. Use the Subgrade Template Point 
Identification Sheets as a guide to select the path for the report .  

 
 

Note:-Subgrade Template Point Identification Sheets are created with project specific information 
and included with the project specific Subgrade Template Report. Template points on the Subgrade 
Template report correlate with the points on the Subgrade Template Point Identification Sheets.  
 
 

 
 In the Search Text tab:- The “Text” is the text string to search for in the cross section. The “Rpt Label” is 

the label to use in the report to represent the text string found. The “Type” is the type of point this text 
string represents which must be centerline, shoulder, catch point or other. Some of the FLH standard search 
texts are included into the Search Text tab default setup as shown below.  

 

                                      
 
 
 
  
 The user can manipulate the search text list with the help of edit tools as shown above.  

 
Note:-Text must be entered as it appears in the cross sections. This MVBA is case sensitive. The 
tolerance value defines the distance the application will search for text in relationship to a proposed 
subgrade element vertex. The tolerance value should be around the value as shown for both metric 
and English projects. 
  

 Once all the settings have been defined, Select the Save Settings Icon to save the project settings. The 
project modified Subgrade Template Report settings are saved to your working directory as Subgrade 
Template Settings.sts. Select Save Settings to Another File Icon to save your project settings to a different 
setting file name.  
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 Select Generate Report to create the report with the defined parameters.  

 

                                   
 

 The following dialog will appear asking to provide the name of the subgrade report file to be created. 
Provide a name and Select Save.  

 

                                
 

 Occasionally errors are found in the cross sections. These may be caused by incorrect symbology (either in 
the cross sections or that specified in the dialog) or by search text not specified correctly. When an error 
occurs on any given cross section the user will be presented with a dialog similar to the following:  

 

                               
 The description of the error in the dialog will indicate the location and type of error that was found.  

 
 

 When the application has finished processing the final cross section in the specified range a message will 
be displayed indicating it is done. Select OK.  
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 Use Cross Section Navigator to view your cross sections with the subgrade traced elements.  

 
 The Subgrade Template Report  will produce the following report as shown below. The report will be 

saved in the location specified and can be viewed and printed using any text editor application. UltraEdit is 
preferred for viewing and printing the Subgrade Template Report.  

 
 
12/04/2007                                           Test Project 1                                            Page# 20 
                                                         BAWA 1E19 
                                                        Mainline Road 
                                                  SUBGRADE TEMPLATE REPORT (ft) 
 
                                       Left Side                                                 Right Side 
                  ------------------------------------------------    ----------------------------------------
-------- 
   Station        Cut/Fill        Slope      Distance   Elevation    Super          Super    Elevation   Distance    Slope   Cut/Fill 
 
 20+00.00       F 0.94       -1:4.00      20.65       121.03 
                                                 16.90       121.97   -4.450%     -4.450%    121.97     16.90 
                                                                                                       120.47     22.90   -1:4.00    F 1.50 
                                                                                                       120.88     25.39    1:6.00    C 0.42 
 
   Station       Easting        Northing        Elevation    Offset               Id          Slope     Horiz.   Vertical 
                                                                                                      Diff.     Diff. 
 
 20+00.00    1354095.02     498407.91     121.03     -20.65  CP 
                                                                                      -1:4.00      -3.75     -0.94 
                1354097.90     498405.52     121.97     -16.90  SHLD 
                                                                                       -0.045     -16.90     -0.75 
                1354110.92     498394.74     122.72      -0.00  CL                         0.00      0.00 
                                                                                        0.045     -16.90      0.75 
                1354123.93     498383.96     121.97      16.90  SHLD 
                                                                                      -1:4.00       6.00     -1.50 
                1354128.56     498380.13     120.47      22.90  HPC 
                                                                                        1:6.00       2.49      0.42 
                1354130.47     498378.55     120.88      25.39  CP 
 

 The Subgrade Template Reports generated for construction should be accompanied by the typical 
Subgrade Template Point Identification Sheets for the project. The Subgrade Template Point 
Identification Sheet shown below identifies the template points in the Subgrade Template Report along 
a typical cross section. 
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5.14.2- Staking Detail Report: 

 
The Staking Detail Report is used to locate the catch points (tie down point between the proposed finish 
grade and the existing ground) at each section. Referencing this catch points, the Staking Report lists the left 
and right offset and its corresponding elevation, and the slope of the proposed finish grade.  The Staking 
Detail Report are generated from the cross section file by accessing the XS Report dialog.   

 
 Open the cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and proposed Cross 

sections. 
 Select the Reports & XS Quantities button from the Project Manager dialog box as shown below: 
 

                  

 The XS Report dialog will appear as shown below.   Click User and fill out the Report Header Dialog 
box.  This Report Header information can be saved by clicking on File and selecting the path and file 
name to be saved.   
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 Select the Staking Detail button from the XS Report dialog box. When selected, you will get the 
following dialog box. 

           

 To set the symbology values for the Existing Ground Line and Proposed Finish Grade, pick the 

symbology button  to get the following dialog boxes: 

           

 Set the existing ground line symbology as shown above. Select the bottom of the pavement layer, ditch 
slope, cut slope and fill slope for proposed finish grade. The values shown in the Existing Ground Line and 
Proposed Finish Grade sections will allow GEOPAK to progress through the top of subgrade.  This is the 
path needed to get the correct report.   
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Note:- The values shown in the Proposed Finish Grade are only for a standard ditch or fill section.  
There will need to be additional symbology added to the Proposed Finish Grade section if retaining 
walls and other elements are added to the cross sections. 
 

 Once the existing and proposed symbology has been selected, provide a name for the report and select 
Apply to process the Staking Detail Report.  

 
 
 

                                                                                       STAKING DETAIL REPORT(Ft)    

                                Slope              Left Stake                                      Right Stake                                                Slope 

   STATION                                C/F      DIST      ELEV    SUPER    ADJ.   SUPER   ELEV.   DIST         C/F               

    18+50.00 R 1        6.00:1.     C  0.99   28.81    126.86   -0.020   128.13   -0.020   126.77    28.27  C    0.89       6.00:1. 

  19+00.00 R 1        6.00:1.     C  0.77   27.55    124.81   -0.020   126.28   -0.020   124.77    25.87  C    0.74       4.00:1. 

  19+50.00 R 1        6.00:1.     C  0.73   27.29    122.92   -0.020   124.45   -0.020   122.60    25.35  C    0.41       6.00:1. 

  20+00.00 R 1       4.00:1       F  0.94   20.65    121.03   -0.020   122.72   -0.020   120.88    25.39  C    0.42       6.00:1. 

  20+50.00 R 1        6.00:1.     C  0.36   25.05    119.27   -0.020   121.17   -0.001   119.84    27.29  C    0.73       6.00:1. 

  21+00.00 R 1        6.00:1.     C  0.66   26.89    118.12   -0.027   119.79    0.027   117.71    28.62  C    0.27DL   -6.00:1. 

  21+50.00 R 1        6.00:1.     C  1.91   34.36    118.06   -0.037   118.57    0.037   118.36    17.34  C    0.59DL   -4:1. 

 
5.14.3- Blue Tops Reports:  

  
Blue Tops reports indicate all breakpoints at the top of base course. Based on FLH-defined text strings placed 
on each cross section, GEOPAK determines the offset and elevation in addition to the slope between each pair 
of adjoining vertices. There are two reports that are needed; the standard Blue Top Report and the XYZ Blue 
Top Report(provide Northing, Easting values, and Elevations).  To generate this report, access the 
MicroStation file containing the cross sections and select the Blue & Red Top buttonfrom the XS Report 
dialog box. 

 
 Open a cross section dgn file (01-xxxx_Dxs.dgn) that contains your existing and proposed Cross 

sections elements. 
 Select the Reports & XS Quantities button from the Project Manager dialog box as shown below: 
 

                  

 The XS Report dialog will appear as shown below.   Click User and fill out the Report Header Dialog 
box.  This Report Header information can be saved by clicking on File and selecting the path and file 
name to be saved.   
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 Select the Blue &Red Top button from the XS Report dialog box. When selected, you will get the 
following dialog box. 

                                       

 

 Toggle the type of report to be generated, (located at the left of the directory path) to Blue.  

 Key in the Job number and Chain.  
   

 If you want notes for the entire chain, highlight the Beg Sta. Field and press delete.   The application will 
automatically set this field to the beginning station of the chain.   Repeat this for the End Sta. Field. You 
may also simply key in a desired station range.  
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 To set the symbology values for the Existing Ground Line and Proposed Finish Grade, pick the 

symbology button  to get the following dialog boxes: 

           

 

 The values defined in the Existing Ground Line and Proposed Finish Grade sections will allow GEOPAK 
to progress through the top of base course. You may need to include the top of pavement symbology if the 
foreslope has the same symbology along the base course as the pavement section. The values shown in the 
Existing Ground Line and Proposed Finish Grade sections will allow GEOPAK to progress through the top 
of base course(Aggregate Course) as shown below.  This is the path needed to get the correct report.   

 

 

 Keep the Span and Reference button toggle off as shown below.  

                    

 Select the Text button to bring up the Blue and Red Top Text Set dialog box as shown below:  
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 Review the cross section to select text at the points that you want reported. For X_30 FHWA criteria, the 
text placed on your cross sections on a level named X_Text_Search. Review your cross sections and key 
in the text to search for and its description.   Press Add or Delete after each entry.   To Modify an entry, 
simply highlight the entry, adjust the values in the white fields and click Modify. When finished … these 
entry’s can be saved for recalling later, by clicking on the File pulldown.   Select the path and filename to 
save this information. The text set for your project can be saved as a *.lis file. 

Note:-The EFLHD_Default.lis file is located at 
“M:\Engineering_Software\Cadd_resource_v8\Standard_Shts\SG_Template\” directory for 
your project.Open this file through File>Open in Blue &Red Top Text Set dialog and modify 
according to your project information. 

 Prior to running the Blue Top Report, make sure the Blue button is shown in the Blue &Red Top Report 
dialog box. Select Apply to process the report. Report is shown below for one cross section. 

                                                              

      BLUE TOPS REPORT(Ft) 

STATION               SSF         HPF         SHLD_AB   Travelway   Travelway     CL_AB        Travelway    Travelway        SHLD_AB      HPC            SSC             

-----------------   -------------- -------------- -------------- -------------- ------------ ------------ ----------------- -------------- -------------- --------------  
20+00.00R1[SPR]   121.03      121.97         123.20         123.02         123.36         123.22         123.36          123.02           123.20         120.47         120.88                  

                   -20.65     -16.90         -12.00         -10.00         -10.00             0.00           10.00            10.00             12.00             22.90          25.39              

                              -0.94      -0.250          0.087         0.000           0.013            0.013           0.000            0.087           -0.250          0.167 

 

 The XYZ Blue Top Report is the same as the Blue Top Report, just change the button that says Blue to 
XYZ as shown below. Provide a new name for the report and select Apply. 
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                                XYZ Blue Top Report 
       Station                      X                          Y                       Z          Offset      ID         SLOPE 
--------------------          ------------       ------------       ------------   --------     ------      ------ 
20+00.00R1[SPR]         1354097.900     498405.523        121.970    -16.902      HPF    

                                                                                           -0.250    
                            1354101.676     498402.396        123.195    -12.000   SHLD_AB    
                                                                                            0.087    
                            1354103.216     498401.120        123.022    -10.000   Travelway    
                                                                                            0.000    
                            1354103.216     498401.120        123.355    -10.000   Travelway    
                                                                                            0.013    
                           1354110.917     498394.742        123.222      0.000   CL_AB    
                                                                                            0.013    
                           1354118.619     498388.363        123.355     10.000   Travelway    
                                                                                            0.000    
                           1354118.619     498388.363        123.022     10.000   Travelway    
                                                                                           0.087    
                           1354120.159     498387.088        123.195     12.000   SHLD_AB    
                                                                                           -0.250    
                          1354128.556     498380.134        120.470     22.902   HPC    
                                                                                            0.167    
                          1354130.474     498378.545        120.885     25.392   SSC    

 

SECTION 6:  Geopak – EFLHD Procedures 

 

6.1- GEOPAK Plan & Profile Sheet Clipping (Geopak 8.x) 

Note:-  The procedure outlined below is specific to creating plan & profile sheets, double plan, and 
separate plan and profile sheet for 11”X17” sheet sizes only. 

GEOPAK will create Plan sheets, Profile sheets, double plan sheets and plan/profile sheets. These sheets 
are generally created at 20, 40, 50, and 100 scale English (ft/in).      
Station range, drawing areas, and many other variables are contained in the sheet library files 
eflhd_Eng_sheets.psl.  The sheet library file contains many values specific to EFLHD such as cell library 
names and locations, specific sheet cells to be used, drawing scales, and a variety of text parameters. It cannot 
be modified by the user.                                                                                                                                
The sheet library files for EFLHD projects are located at:  
M:\Engineering_Software\Cadd_resource_v8\Plan&Profile_Shts\ 
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The user copies this file into his/her working directory in order to run the Plan & Profile sheet smoothly. 

Prior to using the GEOPAK Plan and Profile Sheet Composition tool, three files need to be created.  
Clip.dgn, Plan_motif.dgn and Profile_motif.dgn should be created to assure proper setup of plan and 
profile sheets.  Outlined below are the uses and instructions for creating each file.    

 

6.1.1- Create Clip Sheets and Motif Files 

Clip Sheet file Creating a drawing to display the sheet boundaries will allow the user to always have a 
visual representation of each sheet layout in relation to the others.  If the design changes, 
having this file will allow the user to move sheets around to better fit any design changes.  
Create this sheet, and reference the map file, the horizontal alignment design file and 
profile design file into this new file. By referencing the overall design into the                
“01-ProjectName_Clip.dgn” file, any future design changes will be displayed in this new 
file, instantly showing the designer which sheets, if any, will need to be adjusted.   

  

Motif files Motif files act as seed files for clipping plan and profile sheets. Each Motif file should be a 
blank file with the proper reference files attached, and the proper levels for each file turned 
on or off.  The Plan and Profile Sheet Composition tool will use these files when clipping 
each sheet and each clip sheet will have the correct files displayed with the correct levels 
on.  For example, if the plan view in a final plan sheet needs to show overall design, 
mapping, raster images, ROW, etc., with specific levels on or off for each of these files, 
you would only need to setup this combination once in the motif file.  This information 
would be used to create each sheet. These sheets should be named 01-ProjectName-
Plan_motif.dgn and 01-ProjectName-Profile_motif.dgn. Create Plan_motif design file, 
attach each reference file that should be shown in the plan view, and turn on or off any 
levels to make the display look exactly like the final plan sheets in plan view.  Repeat 
these steps for the Profile_motif design file, referencing the profile sheet into the motif 
file. 

 

 

 

6.1.2- Plan/Profile sheets using GEOPAK 

 
Open the Clip.dgn and select the Plan and Profile Sheet Composition tool from Project Manager by 
selecting the button for Plan & Profile Sheets.  Select a Run or create a new Run.  
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A row of icons is available to access the dialog boxes listed below. The corresponding menu access 
selections are noted in parenthesis. 

 Sheet Composition (Tool>Sheet Composition) 

   Layout Sheet (Tools> Sheet Layout) 

 Clip Sheets (Tools>Sheet Clip) 

 Modify Sheets (Tools> Modify) 

                Sheet Number Manager (Tools>Sheet Number Manager) 

To the right of the icons are the Sheet Name list box and the scale. This list box contains a list of sheet 
types that are configured in the currently selected sheet library. 

Note:  This tool requires what GEOPAK refers to as "Sheet Libraries" be set up ahead of time. These sheet 
libraries contain a variety of Agency specific information. Cell Library names and locations, 
drawing scales, variety of text parameters, locations for the graphics to be clipped and placed 
within the sheet cells..…..... and many others.                                                                                  
This documentation is not targeted at teaching the process of setting up the Sheet Libraries. It is 
already setup for EFLHD users. 

In order to complete the setup procedure you will need to know the scale you want the plan section of the 
P&P sheets to be drawn to. The following table outlines the available combinations of station range, 
horizontal, and overlaps for various scales that are commonly used in EFLHD.  
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                                           TABLE 1 

 Sheet name       Scale    Station Range     Horizontal    Overlap         Remark 

20 Plan/Profile      20           280             15           Multiple of 5    (Plan &Profile Sheet)                          
20 Sep P/P       20           280                    15           Multiple of 5    (Separate Plan and Profile)    
20 Double Plan     20            280                    15                   Any          (Double Plan Sheet) 

40 Plan/Profile      40           550             15           Multiple of 10   (Plan &Profile Sheet)                            
40 Sep P/P       40           550                    15           Multiple of 10   (Separate Plan and Profile)    
40 Double Plan     40            550                    15                   Any           (Double Plan Sheet) 

                           

50 Plan/Profile      50           700             12.5      Multiple of 12.5    (Plan &Profile Sheet)                          
50 Sep P/P       50           700                    12.5      Multiple of 12.5   (Separate Plan and Profile)    
50 Double Plan     50            700                    12.5                  Any          (Double Plan Sheet) 

 

100 Plan/Profile     100       1400              25           Multiple of 25    (Plan &Profile Sheet)                          
100 Sep P/P        100       1400                     25           Multiple of 25   (Separate Plan and Profile)    
100 Double Plan    100       1400                     25                    Any          (Double Plan Sheet) 

 

 

 

 

 

 

 

 

 

 

6.1.3- Example -Clipping an English project using 100 Scale Plan/Profile sheets. 

1. The following Plan Sheet Layout dialog box appears. Select 100 Scale Plan/Profile using the drop down 
arrow, and adjust the Scale field to 100 ft/in as shown below:  
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2. From the pull downs, select Settings > Sheet Layout and adjust the Sheet Layout Settings as shown 
below and press OK: 

 

 

3. Invoke the Sheet Composition dialog by clicking on the Sheet Composition icon from the Plan Sheet 
Layout dialog as shown below: 

                  

4. Modify the Sheet Composition dialog box as shown below:    

 

 

 

 

 

 

 

 

                                                                  < Use Table 1 to populate the Clip area 
 

                

 

Note:                                                                                                                                                          
The dialog shown is settings for a 100 Scale PLAN/PROFILE “sheet style".” Other "sheet styles" have 
been created for English projects. The settings can be found at the end of this documentation.  

Select either of them: 

                  . 
Note:-  
- Radial, it makes it very clear and clean. 
- Others, need some clean up but have more   
   control 
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5. Invoke the Layout Sheets tools by selecting the Layout Sheets icon from the Plan Sheet Layout dialog as 
shown below: 

        

 

                                           Layout Settings Tool 

6. Select Multiple Sheets from the dialog box and Select the GPK file by keying it into the “Job:” box, or by 
browsing using the file open icon. 

 

7. To populate the Plan Port Data dialog box, double click anywhere along the row for Port 1 in the Layout 
Settings dialog box and the following dialog box will be open.                                                                                    

                           

8. Select the correct Chain and the appropriate Plan Motif file.  Press OK.   

9. To populate the Profile Port Data dialog box, double click anywhere along the row for Port 2 in the 
Layout Settings dialog box and the following dialog box will be open. 

                  

10. If a profile cell exists for the file that is referenced to the Clip.dgn file then click on Identify cell, place 
data point on the profile cell and accept.  Profile Data dialog fields can be populated using this method, or 
by manually entering in the required information. 

11. Select the appropriate Profile Motif file.  Press OK.  
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12. GEOPAK will calculate the number of sheets to layout; number of sheets calculated will be placed on the 
button at the bottom right of the Layout Settings dialog box.  The extend distance filed will allow the user 
to enter a value that will shift the clipping shapes backwards or forwards a given distance.  If the number 
of sheets is acceptable, press the Layout 8 Sheets button and GEOPAK will draw clipping shapes into the 
drawing.                                                                                                                                                                    
The clipping shapes for both the Plan and Profile have now been placed as shown below: 

      

 

 

Close the Sheet Layout dialog by clicking on ”X” at the top right.                                                                       
Note: In order for the data to be clipped correctly, use the Sheet Layout Modify Tools.  Two most 
common types of modification supported are sliding the sheets and modifying the drawing area.  The 
drawing area cannot be increased in Length (Horizontal) or Height (Vertical) to exceed the Drawing 
Area setup in the sheet library. 

13. For extremely curved chains and steep vertical curves it may be necessary to modify the clipping shapes once 
the clipping shapes are placed.  Use the Modify Sheets icon, from the Plan Sheet Layout dialog  to invoke the 
Modify tools, as shown below: 

           

        

                               

14. Identify the Sheet (Clipping Shape) to be modified by clicking on the ID button and then data pointing the 
clipping shape or simply select it from the pick list, via the down arrow.   
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NOTE:                                                                                                                                                     
The application is intelligent enough to know whether a Plan clipping shape or Profile clipping shape 
has been identified. When a Profile clipping shape is identified, the "Sheet Chord Offset" ”field 
changes to "Bottom Elevation",”(as shown above). When modifying the vertical position of a Profile 
clipping shape, toggle "Bottom Elevation" ON, type in the desired "bottom of the shape" ”elevation, or 
press Dynamic and move the shape up or down. 

15. Use the Sheet Number Manager tool to number sheets according to EFL standards.  To invoke the Sheet 
Number Manager tool, use the Sheet Number Manager icon, from the Plan Sheet Layout dialog, as shown 
below: 

 

       

 

 

 

16. Click inside the white area anywhere on row one, hold down the shift key and click a second time anywhere on 
the last row.  Once all rows are selected, click on Edit Sheet Number as shown above. 

17. For EFL specific sheet numbering scheme where the sheets are numbered in sequence beginning with D1, 
complete the Edit Sheet Number dialog as shown below and press OK: 
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                   Edit Sheet Number Tool 

18. When OK is pressed the Sheet Number Manager dialog will appear as shown below: 

           

 

Note:-  With different run for the same alignment clip, user must recheck the sheet number and sequence.                

19. Once the clipping shapes are placed and satisfactorily modified, invoke the Clip Sheets tool. Select the Clip 
Sheets icon from the Plan Sheet Layout dialog as shown below: 

 

            

20. Select the working directory in the Output File box.  Keep the sheet name prefix in the second field as blank, 
change the design file name latter after process. The Geopak appends the beginning sheet number to the “Sheet 
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Name”. You most likely will have to rename this (or these) file(s) later as per EFLHD Naming Convention (eg. 
D-LOP(2)_p&p.dgn). 

 

21. Select Orientation to Rotate View.  The sheet cell and the view are rotated and the clipped graphics maintains 
its coordinate grid intelligence, thus allowing for labeling right on the sheet. 

Note: EFLHD policy to choose Rotate View, thus not to loose coordinate grid intelligence of the clipped 
graphics. 

  

22. Select Sheet per File to total number of sheets, thus sheet will be drawn in different models of the design file. 
EFLHD prefer to use all sheet shown in different models of one design file.    

Note: EFLHD prefer to use models for all the sheets in one design file.   

23. Select the Sheet Range required from the pick list, using the drop down arrows.  Use the Sheet Number 
Manager Tool to renumber sheets to EFL specific sheet numbering scheme, (such as D1, D2, D3….) as 
explained earlier.   

24. Enter Labels and Annotation.  An example of a completed Clip Sheets dialog is shown below (illustrating the 
results of the completed Labels and Annotation fields)… when completed press Process Sheets. 

                                                       

 

                                                 

 

 Note: Keep 9 space between SE (Region) and PR (state), and 11 space between PR(state) and ERFO-RRP 
10(2)[Project Number]. These spaces depend on the length of the project number characters 
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6.2- Cross Section Sheets 

6.2.1- General Information: 
 

The Cross Section Sheet dialog can be accessed by selecting Application > GEOPAK Road > Cross Sections 
> Cross Section Sheet Composition from the Microstation pull down menu, or from the GEOPAK Road tool 
palette, or the Road Project dialog as shown below. 

 

  

 Click on the Cross section Sheets icon as shown above. 
 

Note:- When you access the Geopak Cross section Sheets function from the Road Project dialog box, 
you will be prompted to select a run. From the Select Run dialog box, select Run > New to create a 
new cross section sheet run. The New Run Name dialog box is opened. Key-in the Run Name and an 
optional Description. Select OK. The new run is created and is available for selection from the Select 
Run dialog box. From the Select Run dialog box, select the name of the run that you would like to 
open. Select OK to open the run.  
 

  
 The Cross Section Sheet Composition dialog box will be open as shown below.   

 

                        
 

 The following step-by-step procedure refers to the marked-up graphic of the main Cross Section Sheets 
Composition dialog shown above.   
 

(1) Cross Section Sheet Composition’s file name is always displayed on the top of the dialog box.  
 This file is the Sheet Library, which contains the parameters for the Cross Section Sheets and is saved in a 

 

3 
2 
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 Sheet Library file. Sheet layout configurations can be saved in the sheet library and recalled for future 
 use. Sheet libraries have a default extension of “*.xssl ”.  

 The sheet library “EFLHD_xssheet.xssl” has been configured for use with EFLHD’s Standard Cross 
 Section Sheet Cells. This sheet library can be obtained from the following directory.           
 M:\Engineering_Software\Cadd_resource_v8\Cross-Section_Shts\                                             
 Note:-For Consultants, this file is available through the CADD_Resources_V8.zip download.   

(2) Active Cross Section Sheet:  EFLHD has defined Cross Section sheets in different formats and scales. 
 Select the format and scale from the Table 1:  

 
 

 XS Sheet Format 

 
 

English Scale 
Active Cross 
section sheets Notes 

 

 
 

1”=30’
    xs_1xH_30_eng 

  1"=20'   xs_1xH_20_eng 

 
  1"=10' 

      
xs_1xH_10_eng 

 

 
 
 

1”=30’

    xs_1xV_30_eng 

  
1"=20'   xs_1xV_20_eng 

 
  1"=10' xs_1xV_10_eng 

 

 

1"=20'   xs_2xH_20_eng 

 

 
  1"=10' xs_2xH_10_eng 

 

 

1"=20'   xs_2xV_20_eng 

  

  1"=10' xs_2xV_10_eng 

Table 1 
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(3) The left side of the Cross Section Sheet Composition dialog box contains a list of parameters. When  a 
parameter is selected, a graphic explanation of the parameter appears in the lower left portion of  the 
dialog box and key-in fields for each variable appear to the right.                                                                
XS DGN File, Sheet DGN File, and Sheet Labels parameters need to be edited by the user. The rest of the 
parameter is already set through the EFLHD’S Sheet library file.  

 

6.2.2- Create Cross Section Sheets: 

 Step I 
- Copy sheet library file “EFLHD_xssheet.xssl” from the “M:\Engineering_Software\ 
Cadd_resource_v8\Cross-Section_Shts\”   into your project working directory.  

  
Note:-For Consultants, this file is available through the CADD_Resources_V8.zip download.   

 - Create a new MicroStation design file for your Cross Section Sheet in your working directory as        
   explained in Section 4.1.2. Give the name of the file according to the Naming Convention as explained in 
   Section 2.2 (e.g. T01-LOP(2)_xss.dgn)  

 

 Step II 
 - Open the cross section file that contains the cross sections that need to be placed on sheets. 
  
 - Open the Cross section sheets dialog through your Road Project dialog (shown in General Information     
    earlier).  The Cross Section dialog will appear as shown below. 
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 Step III 

 - Attach the cross section sheet library via the menu item File>Sheet Library>Attach (as shown below )   
   and select “EFLHD_Eng_xssheet.xssl” from your working directory. The name of the attached Sheet   
   Library is shown in the title bar.   
                      

                          
 

 
 Step IV 
 
 - After attaching the EFLHD cross section sheet library, the Active Cross Section         
   Sheet option will display the sheet layout options shown below.  
         

                         
 
 -  Select the cross section sheet layout from the pull down menu of Active Cross Section Sheet. Use   
    Table 1 to select the sheet layout. 
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 Step V 
 -  Select XS DGN File option in the left side of the menu. The Cross Section Sheet dialog in the right side 
    will appear as shown below.               
                                  

                                     
 
 -  XS DGN File field in the right side of the menu is used to specify the name of the design file containing 
    the original cross sections. Select the cross section file by use of the select XS DGN File icon. The   
    Chain and stationing will be filled out automatically and the software will find all elements within the   
    confines of the cross section cell. 
 
 Step VI 
 -  Select Sheet DGN File option in the left side of the menu. The Cross Section Sheet dialog will appear   
    in the right side as shown below.               
 

                               
 
 -  Sheet DGN File field in the right side of the menu is used to specify the name of the design file where   
    GEOPAK will compose the cross section sheets.  Select the cross section sheet file created in STEP I by 
    use of the select Sheet DGN File icon.  Keep the rest of the key-in field of this option as default setup.   

 Note:- GEOPAK does not create the cross section sheet file. The file must be created prior to processing.  
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 Step VII 
 
 -  Select Sheet Labels option in the left side of the menu. The Cross Section Sheet dialog will appear as   
    shown below.  
 

                                                   
           
 -  Sheet Labels field in the right side of the menu has a table with Name, Label, X Coordinate, Y     
    Coordinate, Display, and Plot column.  EFLHD Sheet library has already been configured to place   
    Sheet Labels on EFLHD Standard cross section sheet. Designer is only responsible for changing the   
    field of Label column. Edit this field by selecting the row of the table and then click on the cell which   
    needs to be change. The information for the Labels used by EFLHD is shown as below.  
 

 

 

      Note:-Sheet Number have Prefix T or U or... 

 
 
 Step VIII 
 
 -  Save your work by using File>Sheet Library>Save.    
 -  Now click on Layout Sheets to process the cross section sheets layout.  
 
 

  Agency Name 

       Begin Sta., and End Sta. 
 (Don’t change) 

      Road Name 

                Region 

                      State 
         Sheet #                  Project # 
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6.3- Draw Graphics Elements as Pay Items Using D&C Manager  
 

6.3.1- Intoduction: 
 

The D&C Manager is also used by Geopak to standardize graphics elements for drafting and pay items 
quantities.  
EFLHD Standard D&C Manager database “EFLHD_ENGLISH.ddb” has been developed by EFLHD to 
draw the graphics elements into the plan view sheets according to the EFLHD’s symbols and 
abbreviations sheet and compute the quantity of the same. 
 
 The D&C Manager database “EFLHD_ENGLISH.ddb” is located in the following directory:  
M:\Engineering_Software\CADD_Resource_V8\X_30\Standards\DDBS\English\ 
 

Note:- There are two D&C Manager Databases available in that directory, EFLHD_ENGLISH.ddb 
and V8_ENGLISH.ddb. The V8_ENGLISH.ddb database has been developed by FLH and is 
used to draw chain, chain stationing, profiles, and the elements for use with X30 criteria (for 
proposed cross section). 

 
 

 The D&C Manager can be accessed by using the MicroStation pull downs:  
 Applications > Geopak Road > Design & Computation Manager ... or from the Road Tools icon 

as shown below:  

                          

 The default D&C Manager database is attached as V8_English.ddb which is set by EFLHD 
Configuration setup. The user needs to change the database. 

 Select File> Open from the D&C Manager dialog box to access “EFLHD_ENGLISH.ddb” from 
the “M:\Engineering_Software\CADD_Resource_V8\X_30\Standards\DDBS\English\” directory. 

 The currently selected database is displayed in the dialog as shown below. 

                          

Note:- The D&C Manager database is a password protected file and can not be edited by the 
designer. Suggestions or request for enhancements should be forwarded to the CADD 
Coordinator at EFLHD. 
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 The basic component of the hierarchical tree is the Category. The database EFLHD_ENGLISH.ddb 
contains four sub categories: Roadway Design, 20 Scale, 40 Scale, 50 Scale and 100 Scale (These 
categories will be selected according to the scale of the plan sheet “11X17 sheet size”). A double-
click on the Roadway Design, 100 Scale category will reveal several categories as shown below. 

                                   

 

6.3.2- Drawing Custom Graphical Elements into Plan View  

 A double-click on the Erosion Control category reveals several items as shown below: 
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 Similarly each sub-category has several items within it. 
 The items contain specific functions related to defining element symbology or placing pay items. 

These items will be used to set drafting standards for MicroStation commands and the resulting 
graphics are tagged with a pay item attribute that can be used to calculate plan quantities. 

Note:-All item numbers are set according to the Pay Item number as per FP-03, US 
Customary Unit.  

 The Place Influence toggle is used to override the currently active MicroStation symbology settings. 
The Place Influence toggle button is located on the D&C Manager Tool Setting dialog as shown 
below. 

                               

 

Note:-When the Place Influence toggle is activated, elements are drawn using the level, 
symbology and attributes as defined in the GEOPAK database 
“EFLHD_ENGLISH.ddb”. 

 

 

 By toggling on Place Influence, you can use MicroStation commands to place elements utilizing the 
drafting standards established for the currently selected item in the D&C Manager database.  

 If you double click the name of any item in EFLHD’s D&C Manager that is used to place a cell, the 
place cell command will be automatically selected. If Place Influence is on, the cell will be floating 
on your cursor, ready to place in the design file. Similarly, if you click any item that is used to place 
line, the place line will be automatically selected. The line will be placed using the level, color, 
weight and custom line style setting associated with the line item. 
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6.3.3- Generating Quantities in D&C Manager 

When generating quantities, a collection set can be defined for computation and easy recall. Collection 
sets can consist of entire categories or individual items. 

Step I:             

 Click on the Compute icon. 

                                      

 

 Select the Category, and then with a right click, select the Add to Collection option from the 
pop-up menu. The designated category appears in the Collection list box located at the bottom 
of the dialog box. D&C Manager computes quantities for every item found in the selected 
Category as well as any Sub-categories. 

 

Note:- To add individual items, select an individual Pay Item with a single click, and then right click 
on the highlighted item, selecting the Add to Collection option from the pop-up menu. You can 
also double click on the item to add the item into a collection set. 

 

 

 

  Collection box 

     Category 

  Sub-category 
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Step II   

 Plan Quantity Computation dialog box as shown below will appear when user selects the 
Compute icon in Step I. 

                                 

 

 Fill in the required information in the Plan Quantity Computation dialog box then click on 
Compute Quantities. 

Note:--  The “Extents” determines which elements are included in the set. In addition to the 
extents, if the Range option is active, the element must exist within the extents and range 
(distance left and right of the baseline) for the element to be computed. 

 Computation Results are as shown below: 

                                   

 The dialog box displays the pay items and associated computed quantity. The user has the 
option to select the format of the quantity output. Now click on the Export, a text file will be 
created on the selected directory, which can be opened by any text editor. 
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Appendix A 
 
 

More Help for Editing Redefinable Variables 
 

Note: Plan View Override Elements overwrite all Redefinable Variable values 
 

_d_DefinePavementLayers 
 
This variable defines the number of proposed surfacing layers that are to be closed off vertically, and not 
“daylighted” to the shoulder foreslope in guardrail or aggregate shoulder locations.  Use the 
_d_DefinePavementLayers variable where guardrail or aggregate shoulder is present.  

 
     The default value = 1 
 
EXAMPLE:                           EXAMPLE: 
 
       if (Sta >= 0+00 R 1) then                 if (Sta >= 0+00 R 1) then 

    {                  { 
       _d_DefinePavementLayers = 1                 _d_DefinePavementLayers = 2 
     }                   } 
 

 
 
 
 
_d_FirstFullLengthLayer 
 
This variable defines the number proposed surfacing layers to “daylight” to the shoulder foreslope.  Use the 
_d_FirstFullLengthLayer variable where no guardrail or aggregate shoulders are present.  
 
The default value = 1 
 
EXAMPLE:                      EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then                if (Sta >= 0+00 R 1) then 

{                 { 
   _d_FirstFullLengthLayer = 1                   _d_ FirstFullLengthLayer = 2 
 }                 } 
 

 



                                                                                                                                                    
185

_s_PavementClosureOption 
 
This variable sets how the edge of pavement is to be closed if not “daylighted” to the shoulder foreslope (i.e. 
_d_FirstFullLengthLayers   = 2 or more).  The option was created for the different needs of the three FHWA 
divisions.  Use a 1:1 pavement edge for typical Central Federal Lands (CFL) projects and a vertical edge for 
Easter Federal Lands (EFL) projects.  Use ^V^ for a vertical closure or ^S^ for a one to one slope closure.  The 
selected closure option also applies when guardrail is present. 
 
The default value = ^V^ 
 
EXAMPLE:                       EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then                  if (Sta >= 0+00 R 1) then 

{                  { 
  _s_PavementClosureOption = ^V^               _s_PavementClosureOption = ^S^ 
 }                   } 
 

 
 

 
 
 
_d_SurfacingLayer1Thickness 
 
This defines the thickness of the first layer in the proposed pavement structure.  Use this variable for all projects 
with a proposed driving surface.  The first surfacing layer thickness must be greater than zero and expressed in 
master units.   
 
The default values = 4/12 or .100 
 
EXAMPLE:  
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_SurfacingLayer1Thickness = 3/12 
 }           
 
 
 
_d_SurfacingLayer2Thickness to _d_SurfacingLayer5Thickness 
 
These variables define the thickness of additional layers in the proposed pavement structure.  Use these variables 
when more than one proposed pavement structure layers are desired.  The surfacing layer thicknesses 2 through 5 
may be set to zero. 
 
Note:  Cross Sections with guardrail will not be drawn correctly, without at least two layers of 
surfacing. The fill slope will begin at the top of the foreslope, instead of the bottom. One work 
around for this is to use two layers of surfacing, and then delete out the ‘dummy’ layer. For 
consistency in Staking Reports, use a ‘dummy’ layer through out the entire project.  
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_d_WedgeDepth 
 
This variable defines the depth of the wedge adjacent to the non-daylighted surfacing layer(s) and is expressed in 
master units.  Use this variable for projects that require a different shoulder material other than a surfacing lever.  
When used, the wedge will be drawn with different symbology (shoulder backfill) so that earthwork values can be 
separated.  If the wedge depth is set to a value greater than the depth of the surfacing layers which are not 
“daylighted”, the wedge will be drawn to the same depth as the surfacing layers which are not “daylighted”.  If no 
wedge is desired, set the value to zero. 
 
The default value = 0 (no wedge) 
  
 
 
 
 
EXAMPLE:   In this example, the first layer thickness is 3/12, the second layer is 6/12 and 
the third layer thickness is 8/12. 
 
  if (Sta >= 0+00 R 1) then        if (Sta >= 0+00 R 1) then 

{         { 
   _d_WedgeDepth = 10/12          _d_WedgeDepth = 10/12 
}         } 
          

 
 
with:  _d_FirstFullLengthLayer = 2  with:  _d_FirstFullLengthLayer = 3  

      
  if (Sta >= 0+00 R 1) then        if (Sta >= 0+00 R 1) then 

{         { 
   _d_WedgeDepth = 10/12          _d_WedgeDepth = 10/12 
}         } 
          

 
 
with:  _d_FirstFullLengthLayer = 2  with:  _d_FirstFullLengthLayer = 3  
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_d_ShoulderForeSlope 
 
This variable defines the shoulder foreslope and is expressed in a rise:run format.  All proposed cross section use 
this variable.  The slope will always be assumed to be negative in value.     
 
The default value = 1:4 
 
Note: The shoulder foreslope variable can be overridden with plan view overrides.  
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_ShoulderForeSlope = 1:2 
 }              
 

 
 
 
 
_s_RecoverableShoulderForeSlope 
 
This variable is used to override the ‘normal’ shoulder foreslope when a recoverable slope is used.  Only use this 
variable when the recoverable slope is preferred over the shoulder foreslope.  Set this variable to ^Yes^ to override 
the shoulder foreslope variable with a recoverable slope.  If set to ^No^, the shoulder foreslope will equal the 
shoulder foreslope variable.   
 
This variable must be used in conjunction with the redefinable variable _d_RtRecoverableSlopeDist (or Lt). If 
these variables are set to zero, no override will occur.  The slope of the recoverable distance is set with the 
Redefinable variable _d_RtRecoverableSlope (or Lt).  The use of the variable _d_RtSecondarySlope is optional, if 
the value is set to 0:0 then the secondary fill slope will be selected from the fill slope criteria table. 
 
The default value = Yes 
 
EXAMPLE:   
 
   if (Sta >= 0+00 R 1) then 
         { 
             _s_RecoverableShoulderForeSlope = ^Yes^  
          } 
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   if (Sta >= 0+00 R 1) then 
         { 
            _s_RecoverableShoulderForeSlope = ^No^  
         } 
 

 
 
 
 
 
_d_SubExDepth and _d_SubExType  
 
These variables set the location, depth and type of subexcavation to be drawn in the proposed cross sections.  Use 
these variables whenever it is necessary to show subexcavation in cross section views or to accurately measure the 
earthwork volumes associated with subexcavation. 
 
The variable _d_SubExDepth defines the depth of subexcavation.  Use the variable in all locations of 
subexcavation regardless of the type of subexcavation defined (Type 1 or 2) which also must be defined. The 
variable needs to be expressed in master units and no negative sign is required. The depth is measured differently, 
depending upon the type of subexcavation selected; see the description of _d_SubExType for an explanation. 
  
The default value = 0 
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_SubExDepth = 24/12 
 }      
 
The variable _d_SubExType defines the type of subexcavation.  Use in conjunction with _d_SubExDepth for all 
subexcavation locations.  Type 1 subexcavation, which is defined as below proposed subgrade, is invoked by 
setting the variable equal to 1.  Type 2 subexcavation, which is defined as below existing ground, is invoked by 
setting the variable equal to 2. 
 
The default value = ^2^ 
 
Note: The subexcavation type and depth variables can be overridden with plan view overrides. 
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EXAMPLE 1:  Note:  The bottom of the Type 1 subexcavated area is parallel to the proposed 
subgrade and it automatically ends when it intersects the fill slope or the bottom of the ditch.  No 
plan view elements are required. 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_SubExType = ^1^ 
 }  
 

 
 

Subexcavation quantity = Crosshatched area 
Subexcavation Backfill quantity = Crosshatched area + Hatched area 

 
EXAMPLE 2:  Note:  Type 2 Subexcavation requires two plan view lines (LV= 
P_RDW_Edge_of_Subexcavation) to define the offset distances from centerline. The bottom of the 
subexcavated area is horizontal and the depth is measured from the existing ground on the left 
hand side. 
  
  if (Sta >= 0+00 R 1) then 

{ 
  _d_SubExType = ^2^ 
 } 
    

 
 

Subexcavation quantity = Hatched area + Crosshatched area 
Subexcavation Backfill quantity = Crosshatched area 
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_d_MaxWidenSearchDistance 
 
This variable defines the distance in master units to search for a pavement widening line in plan view.  The 
distance is measured from centerline.  This variable is used when cross sections may cross other edges of pavement 
widening from other roads or in switchbacks.  Extraneous lines will cause errors when proposed cross sections are 
drawn.   
 
The default values = 12 (ft) or 3.6 (m) 
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_MaxWidenSearchDistance = 40 
 } 
 
 
 
_d_BackofCurbSearchDistance 
 
This variable defines the distance in master units to search for the back of Type 1 or Type 2 curb in plan view.  The 
distance is measured from the edge of traveled way.  Type 1 and Type 2 curb lines in plan view act as a trigger and 
exact horizontal position is not important.  Use this variable to work with the plan view offset values drawn. 
 
The default values = 3 (ft) or 1 (m) 
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_BackofCurbSearchDistance = 40 
 } 
 
 
 
_d_Type3CurbSearchDistance 
 
This variable defines the distance in master units to search for Type 3 curb in plan view.  The distance is measured 
from centerline.  Type 3 curb lines in plan view act as a trigger and exact horizontal position is not important.  Use 
this variable to work with the plan view offset values drawn. 
 
The default value = 20  
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then 

{ 
  _d_Type3CurbSearchDistance = 20 
 } 
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_d_ClrZoneRecovCutDist and _d_ClearZoneCutSlope 
 
These redefinable variables are used define cut situation clear zone distances and allowable slopes.  Additionally, 
these variables are used to label or check proposed cut slopes that do not meet the defined distance or exceed the 
allowable cut slopes within a clear zone.  Any cut slope that exceeds the allowable slope within the defined clear 
zone will be labeled.  The criteria will also label a case where the clear zone distance is not met.   
 
Note:  Use of these variables does not draw a “barn roof” clear zone section.  These variables are 
used where “barn roof” sections are not proposed. 
 
The variable _d_ClrZoneRecovCutDist defines the distance to perform the check from the top of the shoulder 
foreslope to the outer edge of the clear zone in a cut situation.  
 
The variable _d_ClearZoneCutSlope sets the allowable clear zone slope in a cut situation.   
 
If no check of the slopes is required, leave the _d_ClrZoneRecovCutDist variable set to 0 (default). 
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

{ 
     _d_ClrZoneRecovCutDist = 10  

}  
 

 
 

with:  _d_ClearZoneCutSlope = 1:6 
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_d_ClrZoneRecovFillDist and _d_ClearZoneFillSlope 
 
These redefinable variables are used define fill situation clear zone distances and allowable slopes.  Additionally, 
these variables are used to label or check proposed fill slopes that do not meet the defined distance or exceed the 
allowable fill slopes within a clear zone.  Any fill slope that exceeds the allowable slope within the defined clear 
zone will be labeled.  The criteria will also label a case where the clear zone distance is not met.   
 
Note:  Use of these variables does not draw a “barn roof” clear zone section.  These variables are 
used where “barn roof” sections are not proposed. 
 
The variable _d_ClrZoneRecovFillDist defines the distance to perform the check from the top of the shoulder 
foreslope to the outer edge of the clear zone in a fill situation.  
 
The variable _d_ClearZoneFillSlope sets the allowable clear zone slope in a fill situation.   
 
If no check of the slopes is required, leave the _d_ClrZoneRecovFillDist variable set to 0 (default). 
 

EXAMPLE: 
 
 if (Sta >= 0+00 R 1) then   

{ 
_d_ClrZoneRecovFillDist = 10  

}      
 

 
 

with:  _d_ClearZoneFillSlope = 1:6 
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_d_LtRecoverableSlopeDist and _d_LtRecoverableSlope and 
_d_LtSecondarySlope 
 
These redefinable variables are used to create a safe recovery area or “barn roof” section in cut and fill situations 
on the left side of the roadway.  Use these variables to build safety into the proposed roadway or when the defined 
clear zone requirements are not met. 
 
The variable _d_LtRecoveralbeSlopeDist defines the horizontal distance for the recoverable slope and is measured 
from the top of the shoulder foreslope or edge of pavement if no shoulder is proposed. 
 
The variable _d_LtRecoverableSlope defines the slope for the recoverable slope and is expressed as negative 
rise:run values.   
 
The variable _d_LtSecondarySlope defines a secondary slope and is used to set fill slopes when recoverable slopes 
are used.  Use this variable if it is necessary to have a constant fill slope or if the standard fill slopes are not 
desired.  Any value, expressed in a rise:run format, other than 0 (default) will override the fill slope table.  If the 
secondary slope is flatter that the recoverable slope, the recoverable slope will be used instead.  It is not necessary 
to set this variable when using recoverable slopes 
 
If no recoverable slope is desired, set _d_LtRecoverableSlopeDist = 0 (default). 
 
EXAMPLE: 
 
if (Sta >= 0+00 R 1) then  
      {            with:  _d_LtRecoverableSlope = -1:6 
  _d_LtRecoverableSlopeDist = 10        _d_LtSecondarySlope = -1:3 
       }              _d_RecoverableShoulderForeSlope = 
^Yes^ 
 
Note:  If _d_RecoverableShoulderForeSlope is set to ^No^, then the shoulder foreslope is controlled 
by the _d_ShoulderForeSlope variable. 
 

 
 
      Cut Situation          Fill Situation 
 
Note:  In the cut situation, the secondary slope does not override the ditch slope, which is controlled 
by the redefinable variable _d_DitchForeslopeLt 
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_d_RtRecoverableSlopeDist and _d_RtRecoverableSlope and 
_d_RtSecondarySlope 
 
These redefinable variables are used to create a safe recovery area or “barn roof” section in cut and fill situations 
on the right side of the roadway.  Use these variables to build safety into the proposed roadway or when the 
defined clear zone requirements are not met.  See the description above for the Left side variables. 
 
 
 
_d_FillSlope1 and _d_ FillSlope1Height (and Fill Slopes 2 through 9) 
 
These redefinable variables define the fill slope selection criteria, based on the height of the fill slope. The slope is 
expressed in a rise:run format.  The slope will be assumed to be negative.  The fill height is a maximum height for 
the corresponding slope and is expressed in master units. 
 
Note: All fill slope variables can be overridden with plan view overrides.  
 

EXAMPLE:      EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then     if (Sta >= 0+00 R 1) then   

{           { 
  _d_FillSlope1 = 1:6    _d_FillSlope1Height = 2.0 

   }            } 
     
In the example, all fill slopes with a height of two feet or less will be drawn at a -1:6 slope. 
 
 
 
 
_d_CutSlope1 and _d_ CutSlope1Height (and Cut Slopes 2 through 9) 
 
These redefinable variables define the cut slope selection criteria, based on the height of the cut slope. The slope is 
expressed in a rise:run format.  The slope will be assumed to be positive.  The cut height is the maximum height for 
the corresponding slope and is expressed in master units. 
 
Note: All cut slope variables can be overridden with plan view overrides.  
 

EXAMPLE:      EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then     if (Sta >= 0+00 R 1) then   

{           { 
  _d_CutSlope1 = 1:6    _d_CutSlope1Height = 2.0 

   }            } 
     

In the example, all cut slopes with a height of two feet or less will be drawn at a 1:6 slope. 
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_d_DitchForeslopeLt and _d_DitchForeslopeHeightLt and 
_d_FlatBottomDitchWidthLt 
 
These redefinable variables set the design parameters of the left roadside ditches.  Use them to vary the heights, 
slopes and shapes of ditches throughout a proposed project. 
 
This variable _d_DitchForeslopeLt variable defines the slope of the left ditch from the subgrade hinge point in a 
rise:run format. The slope will always be assumed to be negative. 
 
The default value = 1:4  
 

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_DitchForeslopeLt = 1:4 

     }  
     
 
This variable _d_DitchForeslopeHeightLt defines the vertical height of the left ditch from the subgrade hinge point 
in master units. 
  
The default values = 1.5 (ft) and 0.5 (m)  
 

EXAMPLE 1: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_DitchForeslopeHeightLt = 2.0 

     }      
   

 
 

Note: The ditch foreslope and the ditch foreslope height variables can be overridden with plan view 
overrides. 
 
 
The variable _d_ FlatBottomDitchWidthLt defines the width of the left flat bottom ditch and is measured in master 
units.  This variable is used when a flat bottom ditch is preferred over a “V” ditch. If a “V” ditch is desired, leave 
this variable set to zero (default). 
  
Note: The flat bottom ditch width variable can be overridden with plan view overrides.  
 

 
 
 
 
 
 
 



                                                                                                                                                    
196

EXAMPLE 2: 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_FlatBottomDitchWidthLt = 2 
  } 

  
 
 
 
_d_DitchForeslopeRt and _d_DitchForeslopeHeightRt and _d_FlatBottomDitchWidthRt 
 
These redefinable variables define the dimensions of the ditch on the right side. See the descriptions above for the 
left side ditch variables. 
 
Note: The all these variables can be overridden with plan view overrides.  
 
_d_GroundDropOffSearchDistance and _d_GroundDropOffSampleDistance 
 
These variables are used to define how and when a ditch is created in a fill situation.  If the shoulder subgrade 
point is above ground and the bottom of the ditch foreslope is below ground, the criteria will check to see if the 
ground slopes to a point below the defined ditch bottom.  If this is the case, a fill slope will be drawn intersecting 
existing ground and a ditch will not be drawn.    
 
Note:  The bottom if the ditch foreslope is set by the variable for ditch foreslope height. 
 
The variable _d_GroundDropOffSearchDistance defines the distance in master units used to determine how far to 
search to see “if” the ground falls below the ditch bottom in a fill situation.  This distance is defined in master 
units and is measured horizontally from the shoulder subgrade point.  
  
The default values = 50 (ft) and 15 (m) 

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_GroundDropOffSearchDistance = 50 
  }  

 
The variable _d_GroundDropOffSampleDistance sets the distance in master units used to determine the increment 
to move along the ground to determine if the ground falls off below the bottom of ditch in a fill situation.  
 
The default values = 1 (ft) and 0.3 (m) 
  

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_GroundDropOffSampleDistance = 1 
  } 
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_d_DaylightSlope and _d_DaylightWidth and _d_DaylightOption 
 
These variables are used to define the slope width and type of “daylighted” slope that is drawn.  “Daylighted” 
slopes are used in cut situations when there is a possibility to grade out a slope instead of having a roadside ditch.   
 
_d_DaylightSlope defines the slope in rise:run format to draw the daylight slope. 
  
The default value = -1:20 
 

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_DaylightSlope = -1:20 
  } 
  

_d_DaylightWidth is a redefinable variable that defines the maximum width of the “daylighted” slope measured 
horizontally from the bottom of the ditch foreslope in master units.  Use the variable in cut situations where there is 
a choice to either create a ditch or grade out to an existing slope. 
 
The default values = 30 (ft) and 10 (m) 
  

 
 
 
EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_DaylightWidth = 10 
  }  

 
_d_DaylightOption defines the method of daylighting a slope. Use ^S^ to daylight from the shoulder subgrade; use 
^D^ to daylight from a ditch foreslope and use ^N^ if no daylight slope is desired. 
 
The default value = ^D^ 
  

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then    if (Sta >= 0+00 R 1) then 

  {           { 
     _d_DaylightOption = ^S^    _d_DaylightOption = ^D^ 
  }           } 
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_d_RockSlopeLT and _d_RockSlopeRT 
 
These redefinable variables are used to define the slope of the lower portion of a broken back cut slope.  The slope 
of the upper portion of the broken back cut slope is defined by the slope selection criteria or by plan view 
overrides.  The elevation where the change in slope occurs is triggered by a line drawn on the cross section with 
the D&C Manager.  
  
The default value = 4:1 
 

EXAMPLE: 
 
  if (Sta >= 0+00 R 1) then   

  { 
     _d_RockSlopeLt = 8:1 
  } 

 
 
 

_s_ExcavationLimit and _s_ExcavationLimitOffset 
 
These redefinable variables are used to label the limits of excavation. If no labels are desired, set the variable 
_s_ExcavationLimit to ^N^.  The offset of the label can be positive (outside of tie) or negative (inside of tie).  
  

EXAMPLE: 
if (Sta >= 0+00 R 1) then    if (Sta >= 0+00 R 1) then 

  {           { 
     _s_ExcavationLimit = ^Y^          _s_ExcavationLimitOffset = 0 
  }           } 
 

 
 

Note:  Earthwork processes require the use of Excavation Limit labels. 
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Appendix B 
 

Optimizing Linestyle scales in Microstation 
 
To make plan preparation easy, all base files should be set to a line style scale of 100.  Before you begin 
placing any lines in the base file of a new project, go to Utilities           Key-in as shown below.   
 

 
 
In the Key-in dialogue box, type in the following command: active linestyle scale=1 
 

 
 
Be sure to “save settings” after entering this command (Ctrl + F).  With this command, there will be no 
scaling of the linestyles when they are placed in the base file.  Therefore, place all lines to the appropriate 
scale you would use on a 100 scale plan sheet.  Using the D&C Manager, Eastern already has quite a few 
items sized for 100 scale plan sheets.  However, in the event that the lines do not appear to be displaying at 
the correct line style scale, you can always edit the line style scale of an individual line, without modifying 
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the line style scale of other lines you have already placed.  Go to Element           Linestyles           Custom as 
shown below.   
 

 
 
Using this dialogue box, you may change the scale factor by typing in a new scale factor for the line.  
The dialogue box will instruct you to “Click to Activate” once you have entered a new linestyle 
scale.  Click on the diagram of the line style, and then use the line placement tool to begin placing a 
new line at the new linestyle scale.   
 

  
 
The real advantage of using this method is about to pay off.  If you have drawn everything in the base file as 
you would use on a 100 scale plan sheet, it now becomes simple to cut plan or detail sheets at whatever scale 
you desire (20, 50, 100, 200, etc.).  Simply cut the plan sheet as normal with the base file referenced in.  Then, 
bring up the Utilities           Key-in dialogue as before.  Then type in the linestyle scale of the new sheet you 
just created.   
 
For a 50 scale plan sheet, type in the command: active linestyle scale=0.5 
For a 200 scale plan sheet, type in the command: active linestyle scale=2.0 
Etc. 
 
The line style scales will automatically update to display at the correct size for the sheet scale you are using.  
This means, that with a single base file, you can cut plan sheets and details sheets at different scales, and 
have all of them come out looking correct.  Just be sure to “save settings” again after entering the linestyle 
scale for the sheet you just created.   
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Linestyle scale as displayed at 200 scale 
 

 
 
Linestyle scale as displayed at 50 scale 
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Appendix C 
 

Using the Safety Edge Shoulder_SE.x30 Criteria File 

 
In Project Manager > PROPOSED CROSS SECTIONS Tool 
Scroll down to Shape Clusters, Highlight the RT Side Slope Condition, in the Criteria Files 
window, 
 

 
 
1. Delete the shoulder.x30 criteria file (answer “yes” to the prompt)  
2. Add the shoulder_SE.x30 criteria file (you may have to navigate to 

M:\Cadd_resource_v8\X_30\Typicals\English with the Select button) 

 
 
 
 
 
 
Highlight and Hit “To Criteria” 
Close the dialog with “Done” 
 
 
This will add the Safety Edge criteria file shoulder_SE.x30 at the bottom of the list. 
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It is IMPORTANT that the sequence of the criteria files is maintained for the order in which 
Geopak wants to build your cross sections. 
 
Use the “Up” button to move the file back into its proper order (directly AHEAD of the slopes.x30 
criteria file)   
 
 

**** REPEAT THE SAME FOR THE LT SLOPE CONDITION **** 
 
 

Scroll down to Redefinable Variables, find and highlight the _s_PavementClosureOption Variable. 
 

  
 
 

Hit Edit to open the Variable Editor. 
 
Edit the option to ^S^ for the pavement 
to close with a slope rather than a 
vertical line.   
 
Save the change. 
 
 
(although the description still says “one to one slope” , the shoulder_SE.x30 we just added will build a 30 
degree edge) 
 
Save Settings and (re)Run your cross sections. 
 
 
 
 
 
 
 

Ex.; 
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