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Foreword 

Foreword 
HEC-GeoRAS is an extension for use with ArcView GIS, a general 
purpose Geographic Information System software program developed 
and copyrighted by the Environmental Systems Research Institute, 
Inc., (ESRI) Redlands, California.  HEC-GeoRAS is written in the 
Avenue programming language. 

The HEC-GeoRAS extension was developed though a Cooperative 
Research and Development Agreement between the Hydrologic 
Engineering Center (HEC) and ESRI.  HEC-GeoRAS Version 3.1 is 
the result of continued development by HEC of the AVRAS 2.2 
extension, written by ESRI in cooperation with HEC. 
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Chapter 1 Introduction 

C H A P T E R  1   

Introduction 
HEC-GeoRAS is an ArcView GIS extension specifically designed to 
process geospatial data for use with the Hydrologic Engineering 
Center’s River Analysis System (HEC-RAS).  The extension allows 
users with limited GIS experience to create an HEC-RAS import file 
containing geometric attribute data from an existing digital terrain 
model (DTM) and complementary data sets.  Results exported from 
HEC-RAS may also be processed.  

The current version of HEC-GeoRAS creates an import file, referred 
to herein as the RAS GIS Import File, containing river, reach and 
station identifiers; cross-sectional cut lines; cross-sectional surface 
lines; cross-sectional bank stations; downstream reach lengths for the 
left overbank, main channel, and right overbank; and cross-sectional 
roughness coefficients.  Additional geometric data defining levee 
alignments, ineffective flow areas, and storage areas may be written 
to the RAS GIS Import File.  Hydraulic structure data are not written 
to the import file.  Water surface profile data and velocity data 
exported from HEC-RAS may be processed into GIS data sets. 

Chapter 1 discusses the intended use of HEC-GeoRAS and provides 
an overview of this manual. 

Contents 

• Intended Application of HEC-GeoRAS 

• Overview of Requirements 

• User’s Manual Overview 
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Chapter 1 Introduction 

Intended Application of HEC-GeoRAS 

HEC-GeoRAS creates a file of geometric data for import into HEC-
RAS.  It also enables viewing of exported results from RAS.  The 
import file is created from data extracted from data sets (ArcView 
shapefiles) and from a Digital Terrain Model (DTM).  HEC-GeoRAS 
requires a DTM represented by a triangulated irregular network 
(TIN). The shapefiles and the DTM are referred to collectively as the 
RAS Themes.  Geometric data is developed from calculating the 
intersection of the RAS Themes.  

Prior to performing hydraulic computations in HEC-RAS, the 
geometric data must be imported and completed and flow data must 
be entered.  Once the hydraulic computations are performed, exported 
water surface and velocity results from HEC-RAS may be imported 
back to the GIS using HEC-GeoRAS for spatial analysis.  GIS data is 
transferred between HEC-RAS and ArcView using a specifically 
formatted GIS data exchange file. 

Overview of Requirements 

HEC-GeoRAS 3.1 is an ArcView GIS (Environmental Systems 
Research Institute, 1996) extension that provides the user with a set of 
procedures, tools, and utilities for the preparation of GIS data for 
import into RAS and generation of GIS data from RAS output.  While 
the GeoRAS extension is designed for users with limited geographic 
information systems (GIS) experience, knowledge of ArcView GIS is 
advantageous.  Users, however, must have experience modeling with 
HEC-RAS and have a thorough understanding of river hydraulics to 
properly create and interpret GIS data sets.  

Hardware and Software Requirements 
HEC-GeoRAS 3.1 is an extension for use with ArcView GIS 3.2, or 
higher, with the 3D Analyst 1.0 extension.  While not required, the 
availability of the Spatial Analyst extension significantly speeds up 
post-processing.  HEC-GeoRAS presently only runs on Windows 
2000/NT/98/95.  

The full functionality of HEC-GeoRAS 3.1 requires HEC-RAS 3.1.  
Older versions of HEC-RAS may be used, however, with limitations 
on importing roughness coefficients, ineffective flow data, levee data, 
and storage area data; exporting velocities; and filtering cross-section 
data points. 
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Data Requirements 
HEC-GeoRAS requires a DTM in the form of a TIN.  The DTM must 
be a continuous surface that includes the bottom of the river channel 
and the floodplain to be modeled.  Because all cross-sectional data 
will be extracted from the DTM, only high-resolution DTMs should 
be considered for hydraulic modeling.  Measurement units used are 
relative to those in the DTM.  If the units of the DTM are not 
specified, they will not be written to the HEC-RAS import file. 

User’s Manual Overview 

This manual provides detailed instruction for using the HEC-GeoRAS 
ArcView extension to develop geometric data for import into HEC-
RAS and view results from HEC-RAS simulations.  The manual is 
organized as follows: 

Chapter 1-2 provides an introduction to HEC-GeoRAS, as well as 
instructions for installing the extension and getting started. 

Chapter 3 provides a detailed overview of HEC-GeoRAS. 

Chapter 4 describes HEC-RAS pre-processing requirements and 
detailed instruction for developing an HEC-RAS GIS Import File. 

Chapter 5 describes HEC-RAS post-processing options and detailed 
instruction on developing a GIS data set from exported HEC-RAS 
results. 

Chapter 6 provides an example application of HEC-GeoRAS for new 
users looking to learn basic functionality. 

Chapter 7 provides an example application of HEC-GeoRAS for 
more experienced users seeking to learn the detailed extension 
functionality. 

Appendix A contains a list of references. 

Appendix B contains a sample import and export file.  
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C H A P T E R  2   

HEC-GeoRAS Installation 
The installation procedure for the HEC-GeoRAS ArcView GIS 
extension is the same for Windows 2000/NT/98/95 operating systems. 

This chapter discusses ArcView GIS requirements and instructions 
for installing the HEC-GeoRAS extension. 

Contents 

• Hardware and Software Requirements 

• Installation 

• Loading HEC-GeoRAS 

 

 

Hardware and Software Requirements 

HEC-GeoRAS 3.1 requires ArcView 3.2 GIS for Windows 
95/98/NT/2000 and the 3D Analyst 1.0 extension.  The availability of 
the Spatial Analyst 1.0 extension will speed-up the post-processing, 
but is not required.  There are no additional requirements; however, 
you should identify the availability of disk space for creating GIS data 
sets.  

Installation 

The GeoRAS extension is installed and loaded as any other ArcView 
extension.  To make the extension visible to ArcView, copy the file 
hecgeoras.avx to the ArcView extension subdirectory 
(AVHOME\ext32).  The AVHOME directory is usually 
c:\esri\av_gis30. 
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Once the GeoRAS extension has been copied to the destination 
directory, it can be loaded from ArcView. 

Loading HEC-GeoRAS 

ArcView extensions are loaded through the File menu on the main 
ArcView window.  Select the File ⇒ Extensions  menu item.  In the 
dialog that appears (see Figure 2-1), scroll down to the HEC-
GeoRAS item and use the corresponding check box to turn it on.  
Press OK to close the dialog and load the HEC-GeoRAS extension. 

The 3D Analyst extension automatically loads with the GeoRAS 
extension.  If available, load the Spatial Analyst extension, as was 
done with the HEC-GeoRAS extension. 

 

 
Figure 2-1.  Load ArcView extensions dialog. 
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C H A P T E R  3   

Working with HEC-GeoRAS – 
An Overview 

HEC-GeoRAS is a set of procedures, tools, and utilities for 
processing geospatial data in ArcView GIS using a graphical user 
interface (GUI).  The interface allows the preparation of geometric 
data for import into HEC-RAS and processes simulation results 
exported from HEC-RAS. 

To create the import file, the user must have an existing digital terrain 
model (DTM) of the river system in the ArcInfo TIN format.  The 
user creates a series of line themes pertinent to developing geometric 
data for HEC-RAS.  The themes created are the Stream Centerline, 
Flow Path Centerlines (optional), Main Channel Banks (optional), 
and Cross Section Cut Lines referred to, herein, as the RAS Themes. 

Additional RAS Themes may be created/used to extract additional 
geometric data for import in HEC-RAS.  These themes include Land 
Use, Levee Alignment, Ineffective Flow Areas, and Storage Areas. 

Water surface profile data and velocity data exported from HEC-RAS 
simulations may be processed by HEC-GeoRAS for GIS analysis. 

Chapter 3 provides an overview of the steps necessary to develop the 
RAS GIS Import File (for importing geometric data into HEC-RAS) 
and processing the RAS GIS Export File (results exported from HEC-
RAS).  It is also designed to familiarize the user with the ArcView 
environment.  An overview diagram of the HEC-GeoRAS process is 
shown in Figure 3-1.  Chapter 4 and Chapter 5 more completely 
discuss HEC-RAS data pre- and post-processing, respectively. 

Contents  

• Getting Started 

• Developing the RAS GIS Import File 

• Running RAS 

• Processing the RAS GIS Export File 
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Start an ArcView
Project

GIS Data Development
preRAS menu

Generate RAS
GIS Import File

Run HEC-RAS

Generate RAS
GIS Export File

RAS Results
Processing

postRAS menu

Enough Cross
Sections?

Yes

No

Correct
inundated

area?
No

Sufficient
map detail?NoEnough Cross

Sections?

Yes

Yes

Reduce grid
cell size

No

1.  Create Stream Centerline
          - Label river and reach names
          - Attribute theme
          - Extract elevations
2.  Create Banks theme
3.  Create Flow Path Centerlines
           - Label flow paths
4.  Create/Edit Land Use theme
           - Estimate n-values
5.  Create Levee Alignment
          - Extract/input elevations
6.  Create Cross Section Cut Lines
           - Attribute theme
           - Extract elevations
7.  Create Ineffective Flow Areas
8.  Create Strorage Areas
           - Extract elevation-volume

1.  Create new project
2.  Import RAS GIS Import File
3.  Complete geometric, hydraulic structure
       and flow data
4.  Compute HEC-RAS results
5.  Review results for hydraulic correctness

1.  Import RAS GIS Export File
2.  Generate water surface TIN
3.  Generate floodplain and depth grid
4.  Generate velocity TIN
5.  Generate velocity grid

Detailed flooplain
analysisYes

 
Figure 3-1.  Process flow diagram for using HEC-GeoRAS. 
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Getting Started 

Start ArcView GIS.  Load the GeoRAS extension by selecting File ⇒ 
Extensions... on the main ArcView window and selecting HEC-
GeoRAS from the extension choices.   The 3D Analyst extension will 
automatically load.  If available, load the Spatial Analyst extension to 
speed up post-processing. 

When the GeoRAS extension loads, menus, buttons, and tools are 
added to the ArcView interface.  These additions are intended to aid 
the user in stepping through the geometric data development process 
and post-processing of exported HEC-RAS simulation results.  The 
GeoRAS extension menus, buttons, and tools are shown in Figure 
3-2. 

Data processing menus 

Editing tools 

Processing buttons 

 
Figure 3-2.  HEC-GeoRAS interface additions. 

Menus 
The HEC-GeoRAS preRAS, postRAS, and GeoRAS_Util menus 
displayed at the top of the ArcView interface are discussed below. 

PreRAS 
The preRAS menu option is used for pre-processing geometric data 
for import into HEC-RAS.  Items in the preRAS dropdown menu are 
listed in the recommended (and sometimes required) order of 
completion.  Items available from the preRAS menu items are shown 
in  
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Create empty RAS Themes 

Specify RAS Themes and RAS GIS Import File 
(RASImport.sdf) 

Determine Stream Centerline connectivity and 
orientation 
Extract elevations along stream centerline 
(Creates 3D shapefile) 

 
Populate the Cross-Sectional Cut Line theme 
attribute table with geometric properties 
 
 
Extract elevation data for each cross section 
(Creates 3D shapefile) 

Determine Manning’s n Values from land use  

Calculate levee positions at cross sections 

Identify ineffective flow area 

Calculate elevation-volume curve for storage 
areas 

Create the RAS GIS Import File 
sections 

Figure 3-3. Pre-processing menu options. 

PostRAS 
The postRAS menu option is used for post-processing exported HEC-
RAS results.  Items available from the postRAS dropdown menu are 
listed in the order of completion.  Items available from the postRAS 
menu are shown in Figure 3-4. 
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Select TIN, RAS GIS Export File, and output 
parameters 

Read RAS GIS Export File (RASExport.sdf) 
and build base data 

Create inundation maps from water surface 
profile data

Create velocity data sets 

Figure 3-4. Post-processing menu options. 

GeoRAS_Util 
The GeoRAS_Util menu option provides utilities for editing themes 
and theme management.  The procedures performed by these utilities 
are not required to develop geometric data sets, but are there to assist 
the user with various functions.  GeoRAS_Util items are shown in 
Figure 3-5. 

 

 
Create Land Use / n value summary table 

Complete the levee profile by extracting 
elevation values from table or TIN 
Flip line orientation 

Edit GeoRAS theme tag values 
             (expert users only) 

Figure 3-5. Utilities available when using HEC-GeoRAS. 

Buttons 
There are two buttons provided below the menu bar.  A button 

initiates an action immediately after being pressed.  The  button 
generates the RAS GIS Import File, just as the Generate RAS Import 
File (summary of Header Export, Centerline Export, XS Export) item 

under the preRAS menu.  The  button imports the RAS GIS 
Export File by performing the Theme Setup and Read RAS Export 
File steps under the postRAS menu.  These buttons should only be 
used after data sets have been verified and importing/exporting data 
have become repetitive tasks. 

Tools 

Tools, provided beneath the button bar on the ArcView interface, 
allow you to perform a specific action.  A tool, when activated, turns 
a lighter color gray and looks as if it is depressed.  The four tools 

11 



 
Chapter 3 Working with HEC-GeoRAS – An Overview 

added to the interface by GeoRAS are the  (River ID); 
(Flowpath); (XS Plot); and  (Levee) tools.  The River ID 

and Flowpath tools allows you to provide a Stream ID and Reach ID 
for each reach in the Stream Centerline theme and to identify the left, 
middle, and right flow paths in the Flow Path Centerlines theme, 
respectively.  The XS Plot tool allows you to preview the cross-
sectional elevations and the Levee tool allows you to assign 
elevations to a levee alignment for interpolation. 

Developing the RAS GIS Import File 

The main steps in developing the RAS GIS Import File are as follow: 

• Starting a New Project 

• Creating RAS Themes 

• Generating the RAS GIS Import File 

Starting a New Project 
You should save the ArcView project to the appropriate directory 
before creating any themes. This may require using the file browser to 
create and name a new directory.  The directory to which the 
ArcView project is stored becomes the default directory when 
creating or adding new themes.  It is the location where the RAS GIS 
Import File is written. 

To save the project, select File ⇒ Save Project from the ArcView 
main interface, select the directory, input the project name, and press 
OK.  ArcView projects are given the .apr file extension. 

Once the project has been saved, start a new view by pressing the 
New button on the project window.  The project window will be titled 
with the name of the current project.  The view is composed of two 
parts: the table of contents and the map display.  The table of contents 
lists the themes and the map display shows the features of the theme.  
The HEC-GeoRAS extension is only visible on the ArcView 
interface if a view document is active. 

Next, load the DTM and any background themes for the river system 

to the new view.  To load the Terrain TIN, press the  (Add 
Theme) button or select the View ⇒ Add Theme menu item on the 
ArcView interface.  This step invokes a browser.  Select “TIN Data 
Source” from the Data Source Type pick list and browse to the 
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location of the Terrain TIN.  Select the TIN and press OK.  The TIN 
is added to the current view. 

You can load other themes using the same procedure by specifying 
the Data Source Type as a Feature, Image, Grid, or TIN. 

Creating Contours 
If the Terrain TIN is very detailed, it may not be appropriate to use 
for a background layer.  (Extremely large TIN data sets take much 
longer to display to the screen than small TINs.)  Line themes, such as 
contours, however, will normally display more quickly.   

Make the TIN theme active in the view by selecting it from the table 
of contents with the mouse.  This creates a box around the theme 
making it appear raised. Create a new theme of contour lines by 
selecting the Surface ⇒ Create Contours menu item. (The Surface 
menu was added to the ArcView interface when the 3D Analyst 
extension was loaded.)  This invokes the dialog box shown in Figure 
3-6. Next, enter the contouring parameters and press OK 

 
Figure 3-6.  Dialog for entering contouring parameters. 

ArcView will generate a theme of contours from the selected TIN 
with the default name of “Contours of TINname”, where TINname is 
the name of the active TIN.  If the contour interval specified is too 
fine in relation to the resolution of the TIN, ArcView may not 
properly process the data.  If the interval specified is too large, the 
contour theme created will not provide an adequate visualization of 
the land surface. 

To display the contour lines, click on the corresponding check box in 
the table of contents.  If the contouring does not provide sufficient 
definition of the river network and main channel, create the contour 
theme again using a finer contour interval. 

Creating RAS Themes 
The next step is to create the RAS Themes that will be used for 
geometric data development and extraction.  The line themes that 
need to be created are the Stream Centerline, the Main Channel Banks 
(optional), the Flow Path Centerlines (optional), and the Cross 
Section Cut Lines. Additional data sets you may wish to create 
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include a polygon theme of land cover to estimate provide Manning’s 
n values, a polyline theme of levee alignments, a polygon theme for 
representing ineffective flow areas, or a polygon theme to calculate 
floodplain storage areas.  Existing shapefiles or ArcInfo coverages 
may be used for each RAS Theme; however, they will need to contain 
the attributes as specified in the following sections.  If ArcInfo 
coverages are used, always convert them to a shapefile. 

Feature themes are created using basic ArcView tools.   The GeoRAS 
preRAS menu directs the user through the data development 
procedure.  The following section provides an overview for creating 
the RAS Themes.  Detailed descriptions on creating RAS Themes and 
theme structure are in Chapter 4. 

Stream Centerline 
The Stream Centerline theme should be created first.  Select the 
preRAS ⇒ Create Centerline Theme menu item.  The dialog 
shown in Figure 3-7 will appear.  Enter the theme name and 
destination directory and press OK. 

 
Figure 3-7. Standard file dialog window for specifying theme name. 

The Stream Centerline theme is added to the current view; it is active 
and editable.  To start adding features to the Stream Centerline theme, 
select the  (Draw Line) tool.  Move the cursor over to the view’s 
map display and cross hairs will appear.  Draw river reaches one by 
one, from upstream to downstream using the mouse.  Each reach is 
represented by one line having a series of vertices.  To start a line use 
the mouse to left click, using left clicks to add vertices, and double-
click to end a line.  After creating the river network, select View ⇒ 
Stop Editing. 

The Stream Centerline theme, however, is not complete until each 
River Reach has been assigned a name.  Make sure the Stream 
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Centerline theme is still active and select the  (River ID) tool.  
Cross hairs will appear as the cursor is moved over the map display.  
Use the mouse to select a River Reach.  The dialog shown in Figure 
3-8 will be invoked to name the river and reach.  Previously specified 
river names are available from a drop down list using the down arrow 
to the right of the river name field.  Reach names for the same river 
must be unique.  River and reach names may be up to 16 characters in 
length. 

 
Figure 3-8.  River and reach identification window. 

Main Channel Banks 

Select the preRAS ⇒ Create Banks Theme menu item.  Enter the 
theme name and destination directory in the dialog that appears and 
press OK.   

Use the Draw Line tool to draw the location of the channel banks.  
Separate lines should be used for the left and right bank of the river.  
Bank lines from tributary rivers may overlap the bank lines of the 
main stem.  After defining each bank line, select View ⇒ Stop 
Editing.  Creating the Main Channel Banks theme is optional. 

Flow Path Centerlines 

Select the  preRAS ⇒ Create Flowpath Theme menu item.  Enter 
the theme name and destination directory in the dialog that appears 
and press OK.   

If the Stream Centerline theme exists, the centerline will be copied as 
the flow path for the main channel.  Use the Draw Line tool to draw 
the hydraulic flow path (center of mass of flow) in the left and right 
overbank, in the upstream to downstream direction.  When finished 
drawing and editing flow paths, select View ⇒ Stop Editing.  

Each flow path must be labeled with an identifier of Left, Middle, 
Right, corresponding to the left overbank, main channel, or right 
overbank.  One by one, use the  (Flowpath) tool to label each 
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flow path.  After activating the Flowpath tool, select each flow path 
with the cross-hairs cursor.  This dialog shown in Figure 3-9 will 
appear allowing the user to select the correct flow path label from a 
list. Creating the Flow Path Centerlines theme is optional. 

 
Figure 3-9. Label flow path window. 

Cross-Sectional Cut Lines 

Select the preRAS ⇒ Create XS Cut Lines menu item.  Enter the 
theme name and destination directory in the dialog that appears and 
press OK.  

Use the Draw Line tool to draw the locations where cross-sectional 
data should be extracted from the Terrain TIN.  Each cross-sectional 
cut line should be drawn from the left overbank to the right overbank, 
when facing downstream.  Cross-sectional cut lines are multi-segment 
lines that should be drawn perpendicular to the flow path lines.  Cut 
lines must cross the main channel only once and no two cross sections 
may intersect. 

Land Use 
Land use data may be used to estimate Manning’s n values for each 
cross section; however, creating the land use theme and estimating n 
values is optional.  Load the Land Use polyline theme to the view 
using the Add Theme button.  Make the theme active and select the 
GeoRAS_Util ⇒ Create LU-Manning Table menu item.  The 
dialog shown in Figure 3-10 will be invoked, allowing you to select 
the land-use description field.  Use the drop-down list to pick the field 
and press OK. 

 
Figure 3-10. The user will need to specify which field to reference for the land 
use / Manning’s n value relationship. 

Another dialog will appear allowing you to specify a new table name 
and destination directory.  Enter the table name (“lumanning.dbf” is 
default) and press OK. 
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The new table is a summary of all land-use descriptions and has a 
blank N_value field for Manning’s n values.  To edit the N_value 
field values the user will need to edit the new table. 

From the project window, select the tables document.   The name of 
the table (“lumanning.dbf”) will appear as an available document.  
Double-click it to open it or select the table and press the Open 
button.  The table will open with the field names across the top shown 
in italics with a gray background.   

To edit the N_value field values, select Table ⇒ Start Editing.  Note 
that the field names are no longer in italics, indicating that the table 
may be edited.  Use the  (Edit Cells) tool to edit n values in the 
table.  When finished entering n values, select Table ⇒ Stop 
Editing. 

Select the view document used for creating the themes and the 
GeoRAS interface will appear.  

Levee Alignment 
Levee alignments may be specified in the geometric data.  Select the 
preRAS ⇒ Create Levee Alignment menu item.  Enter the theme 
name and destination directory in the dialog that appears and press 
OK. 

Use the Draw Line tool to digitize the levee aligment(s).  HEC-RAS 
currently allows only one levee per bank.   Select the GeoRAS_Util 
⇒ Levee Profile Completion to create a 3D shapefile from the levee 
alignment.  If the levee alignments are for existing levees, GeoRAS 
will pick up elevations from the terrain TIN (assuming the levees are 
represented in the terrain).  If, however, the alignments are proposed, 
you must specify the proposed levee elevations.  Detailed instructions 
for editing levee elevations are given in Chapter 4.  Creating the 
Levee Alignment theme is optional 

Ineffective Flow Areas 

Select the preRAS ⇒ Create Ineff. Flow Areas menu item.  Enter 
the theme name and destination directory in the dialog that appears 
and press OK.   

Use the  (Draw Polygon) tool to draw the location of the 
ineffective flow areas.  Ineffective flow areas should intersect each 
cross section twice, indicating an “ineffective flow block”.  After 
defining each ineffective flow area, select View ⇒ Stop Editing.  An 
ineffective flow “trigger” elevation may be specified by the user or 
based on the terrain data.   Detailed instructions for editing ineffective 
flow area data are given in Chapter 4.  Creating the Ineffective Flow 
Areas theme is optional. 
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Storage Areas 
Storage areas may be used when modeling in unsteady flow.  To 
create storage areas, select the preRAS ⇒ Create Storage Areas 
menu item.  Enter the theme name and destination directory in the 
dialog that appears and press OK.   

Use the  (Draw Polygon) tool to draw the location of the storage 
areas.  In general, storage areas should not intersect cross sections as 
this would indicate an area simultaneously conveying water and 
storing water.  After defining each storage area, select View ⇒ Stop 
Editing.  Storage areas are used to compute elevation-volume 
relationships for floodplain storage.  Detailed instructions for editing 
storage areas are given in Chapter 4.  Creating the Storage Areas 
theme is optional. 

Generating the RAS GIS Import File 
After creating/editing each RAS Theme, select the preRAS ⇒  
Theme Setup menu item.  The pre-processing theme setup dialog 
shown in Figure 3-11 allows you to select the RAS Themes used for 
data development and extraction and to select the RAS GIS Export 
File name. 

 
Figure 3-11. Pre-processing theme setup dialog. 
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Use the drop down lists to select the Terrain TIN and two-
dimensional data inputs for processing.  The three-dimensional data 
(intermediate data) will be derived along the way by GeoRAS.  Also 
specify the RAS GIS Export File.  The file extension is 
“.RASimport.sdf” and cannot be changed by the user . Press OK 
when finished. 

Next, select the preRAS ⇒ Centerline Completion menu item.  This 
process completes the centerline topology.  Select preRAS ⇒ 
Centerline Elevations to create a new 3D shapefile.  The user will be 
asked to name the shapefile (“stream3D.shp” is default) and select the 
destination directory. 

The next step is to add the geometric attributes to the Cross Section 
Cut Line theme.  Select the preRAS ⇒ XS Attributing menu item.   
Stream and reach, stationing, bank station,  and downstream reach 
length information will be appended to each cross section cut line. 

To complete the cross-sectional data, station-elevation data needs to 
be extracted from the Terrain Tin.  Select the preRAS ⇒ XS 
Elevations menu item.  This will create a cross-sectional surface line 
theme (a 3D shapefile, default name “xscutlines3D.shp”) from the 
cross-sectional cut lines. 

If you have a Land Use theme with estimated roughness coefficients, 
select the preRAS ⇒ Manning’s n Values to determine the 
horizontal variation in Manning’s n values along each cross section. 

If you have a completed Levee Alignment (3D), select preRAS ⇒ 
Levee Positions to calculate the intersection of the levees at the cross 
sections. 

If you have ineffective flow data, select the preRAS ⇒ Ineffective 
Flow Areas to calculate the location of ineffective flow areas at the 
cross sections. 

If you have storage areas, select the preRAS ⇒ Storage Areas to 
calculate the elevation-volume relationship for each storage area of 
interest. 

Lastly, select the preRAS ⇒ Generate RAS GIS Import File menu 
item.  This step writes the header information, stream centerline 
information contained in the Stream Centerline (3D) theme, and 
cross-sectional information contained in the XS Surface Lines (3D) 
theme to the RAS GIS Import File in the HEC-RAS import file 
format.  Manning’s n values, levee alignment data, ineffective flow 
data, and storage data will be written, if available. 
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Running RAS 

After importing the geometric data extracted from the GIS, 
completion of the hydraulic data will be necessary.  Hydraulic data 
that is not imported includes contraction and expansion coefficients, 
hydraulic structure data such as bridges and culverts, and optional 
data such as levees and ineffective flow areas.  Flow data and the 
associated boundary conditions need to be supplied, as well.  For a 
more complete discussion on importing geometric data, refer to the 
HEC-RAS User’s Manual, Chapter 13 (Hydrologic Engineering 
Center, 2002). 

After running various simulations in HEC-RAS, export the results.  
For a more complete discussion on exporting GIS data, refer to the 
HEC-RAS User’s Manual, Chapter 13 (Hydrologic Engineering 
Center, 2002). 

Processing the RAS GIS Export File 

The main steps in processing HEC-RAS results are: 

• Reading the RAS GIS Export File 

• Processing RAS Results Data 

Reading the RAS GIS Export File 
The first step for importing HEC-RAS results into the GIS is to select 
the RAS GIS Export File.  Select the postRAS ⇒ Theme Setup 
menu item.  The dialog shown in Figure 3-12 will appear to allow the 
user to select the RAS GIS Export File (.RASExport.sdf).  The dialog 
also allows the user to select the Terrain TIN used for floodplain 
delineation, identify the directory to write post-processing results to, 
and the cell rasterization size for grid calculations.  
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Figure 3-12. Post-processing theme setup dialog. 

The output directory specified will be created one level down from 
where the GeoRAS project is stored.  All post-processing results will 
be stored in the Output Directory.  The Output Directory is the 
directory name only (NOT the entire pathname). 

Select the postRAS ⇒ Read RAS GIS Export File menu item.  
HEC-GeoRAS will read the export file and begin creating preliminary 
data sets.  Preliminary shapefiles created include the following: 

• Stream network shapefile 

• Cross section cut lines shapefile 

• Bounding polygon shapefiles for each water surface profile  

• Main channel banks shapefile (optional) 

• Velocity point shapefile for each water surface profile (optional) 

• Storage areas polygon shapefile (optional) 

These data sets are created without user input and will be used later 
for building inundation and velocity data sets. 

Processing RAS Results Data 
Post-processing of RAS results creates GIS themes for inundation and 
velocity analysis.  All GIS themes developed during RAS post-
processing are based on the content of the RAS GIS Export File and 
the Terrain TIN.  For data consistency, the same Terrain TIN used for 
generation of the RAS GIS Import File should be used for post-
processing.  A maximum of 10 water surface profiles can be 
processed for a given GeoRAS project (due to ArcView limitations). 
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Inundation Results 
Once the RAS GIS Export File has been read, the user can begin 
creating inundation data sets.  The first step is to create water surface 
TINs for each water surface profile.  Select the postRAS ⇒ WS TIN 
Generation menu item.  This will invoke a dialog with a pick list of 
water surface profile names.  Multiple water surface profiles may be 
selected by holding down the SHIFT key during selection.  Press OK 
to build the water surface TINs. 

One water surface TIN will be created for each selected water surface 
profile.  The TIN is created based on the water surface elevation at 
each cross section and the bounding polygon data specified in the 
RAS GIS Export File.  The water surface TIN is generated without 
considering the Terrain TIN. 

The floodplain may then be delineated for each water surface profile 
for which a water surface TIN exists.  Select the postRAS ⇒ 
Floodplain Delineation menu item.   

A floodplain polygon will be created for each water surface profile 
TIN that was created previously.  Each floodplain polygon results 
from intersecting the water surface and terrain surface.  The 
floodplain delineation procedure converts the water surface TIN and 
Terrain TIN to lattices (grids) with the same cell size and origin.  A 
depth grid is then created wherever the water surface grid is higher 
than the terrain grid.  The depth grid is converted to the floodplain 
polygon. 

If the Spatial Analyst extension is available, the water depth grid 
computations will be optimized.  If the Spatial Analyst is not present, 
a point theme will also be generated, with the depth of the water at 
each point as an attribute. 

Velocity Results 
Velocity data sets may be generated after performing the floodplain 
delineation.  Select the postRAS ⇒ Velocity TIN Generation menu 
item.   A dialog will appear allowing the user to select water surface 
profiles.  The pick list will only contain the names for which the 
floodplain has been delineated.  Velocity TINs will then be created 
with bounds and identified by the associated floodplain polygon. 

After creating a velocity TIN, a velocity grid may be computed using 
the postRAS ⇒ Velocity Grid Generation menu item.  Velocity 
results must be interpreted carefully.  Velocity data exported from 
HEC-RAS are accurate estimates at each cross section; however, 
interpolation results away from cross sections may be poor. 
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C H A P T E R  4   

Developing the RAS GIS 
Import File 

The RAS GIS Import File consists of geometric attribute data 
necessary to perform hydraulic computations in HEC-RAS.  The 
cross-sectional geometric data is developed from an existing Digital 
Terrain Model (DTM) of the channel and surrounding land surface, 
while the cross-sectional attributes are derived from points of 
intersection of RAS Themes.  The DTM must be in the form a 
triangulated irregular network (TIN). 

RAS Themes created include the Stream Centerline, Main Channel 
Banks (optional), Flow Path Centerlines (optional), and Cross-
Sectional Cut Lines, Land Use (optional), Levee Alignment 
(optional), Ineffective Flow Areas (optional), and Storage Areas 
(optional).  Geometric data and cross-sectional attributes are extracted 
from the DTM and RAS Themes to generate a file that contains: river, 
reach, and station identifiers; cross-sectional cut lines; cross-sectional 
surface lines; cross-sectional bank stations; and downstream reach 
lengths for the left overbank, main channel; and right overbank.  
Optionally, a land use polygon theme may be specified to extract 
roughness coefficients; levee alignments may be used to specify flow 
impediments; ineffective flow areas may be used to identify non-
conveying flow areas; and storage areas may be used to develop 
elevation-volume relationships for unsteady-flow modeling.   

Expansion/contraction coefficients and hydraulic structure data such 
as bridges and culverts are not written to the RAS GIS Import File. 

Chapter 4 discusses the steps in developing the RAS GIS Import File. 

Contents 

• Digital Terrain Model 

• Contours 

• Stream Centerline Theme 

• Main Channel Banks Theme 
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• Flow Path Centerlines Theme 

• Cross-Sectional Cut Lines Theme 

• Land Use Theme 

• Levee Alignment Theme 

• Ineffective Flow Areas Theme 

• Storage Areas Theme 

• Generating the RAS GIS Import File 

Digital Terrain Model 

HEC-GeoRAS requires an existing DTM in the form of a TIN.  The 
TIN must be representative of both the land surface of the channel 
bottom and adjacent floodplain areas.  The TIN should be constructed 
to depict the floodplain interest from elevation point data and 
breaklines identifying linear features of the landscape.  Elevation data 
for each cross section is extracted from the DTM.  The DTM will also 
be used for determining floodplain boundaries and calculating 
inundation depths. 

Developing a hydraulic model begins with an accurate geometric 
description of the surrounding landform, especially the channel 
geometry.  Channel geometry typically dictates flow in river systems; 
therefore, only DTMs describing channel geometry with high 
accuracy and resolution should be considered for the basis of 
performing hydraulic analysis.  Further, RAS Themes should be 
created with thoughtful evaluation of the river hydraulics as 
governed by the terrain. 

Contours 

Creating a theme of contours from a TIN theme is not required to use 
GeoRAS.  However, it is often a logical first step that helps the user 
visualize the study area. Displaying the Terrain TIN provides detailed 
information on the river network and floodplain, but the display may 
prove too time-consuming to refresh during digitizing, panning, and 
zooming.  The contour line theme, however, will refresh quickly and 
provide a good visual for delineating the river network and locating 
cross sections. 
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To create contours from a TIN, make the Terrain TIN theme active 
and select the Surface ⇒ Create Contours menu item.  Enter the 
contour interval in the dialog that appears (see Figure 4-1) and press 
OK.  The contour interval should be based on the definition of the 
Terrain TIN. “Contour interval” units will be based on the Terrain 
TIN, while the “Base contour” will be the elevation assigned to the 
first contour.  

  
Figure 4-1. Contour parameters dialog. 

It should take only a minute or so to create the contours, depending on 
the contour interval specified and the number of points in the Terrain 
TIN.  The status bar at the bottom of the ArcView interface will 
inform you of the contouring process.  When completed, the contour 
line theme will be added to the current view’s table of contents.  The 
contour theme is intended for visualization only, and is not used 
during the data extraction process. 

Stream Centerline Theme 

The river and reach network is represented by the Stream Centerline 
theme.  The network is created on a reach by reach basis, starting 
from the upstream end and working downstream following the 
channel thalweg.  Each reach is comprised of a River Name and a 
Reach Name. 

The Stream Centerline is used for assigning river stationing to cross 
sections and to display as a schematic in the HEC-RAS Geometric 
editor.  It may also be used to define the main channel flow path. 

Rules! 
• All river reaches must be connected at junctions.  Junctions are 

formed when the downstream endpoint (TO node) of a reach 
coincides with the upstream endpoint (FROM node) of another 
reach. 

• The Stream Centerline arcs must point downstream: the line must 
start at the upstream end and finish at the downstream end (the 
FROM node of the arc upstream of the TO node). 
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• Each river reach must have a unique combination of its River 
Name (Stream ID) and Reach Name (Reach ID). 

• Stream Centerlines should not intersect, except at junctions where 
endpoints are coincident. 

• Junctions are formed from the intersection of two (or more) 
rivers, each having a different River Name (Stream ID). 

Creating the River Network 
Select the preRAS ⇒ Create Stream Centerline menu item.  This 
will create a new shapefile (default name of “Stream.shp”) with 
Stream_ID and Reach_ID fields in the associated table.   The Stream 
Centerline theme will be added to the current view and will be active 
and editable. Create the stream network by digitizing and connecting 
reaches in the downstream direction. 

To create a river reach, select the Draw Line tool.  Use the left mouse 
button to begin a reach.  Create the reach downstream using the left 
mouse button to add vertices along the way.  When finished creating a 
reach, double-click the left mouse button. 

Interactive pan and zoom options are available when editing a theme.  
Use a right click, when digitizing on screen, to invoke the popup 
menu.  When the pan option is selected, for instance, the window will 
pan to make the current cursor location the center of the screen. 

After creating the river network, select Theme ⇒ Stop Editing.  
Complete the Stream Centerline theme by adding river and reach 
identifiers using the  (River ID) tool.  After activating the River 
ID tool, select a reach with the cross-hairs cursor.  Enter the River 
Name and Reach Name in the dialog shown in Figure 4-2. 

 
Figure 4-2. River and Reach Name dialog. 
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Junctions  
Junctions are formed at the confluence of three or more reaches. Note 
that in HEC-RAS, you may only have a new reach (junction) at a flow 
change location. In order for a junction to be formed, reach endpoints 
must be coincident.  Two ways for insuring junctions are formed at 
endpoints is discussed below. 

Interactive snapping 
Interactive snapping is used while creating a line and is the preferred 
method for snapping endpoints.  Before creating a line using the 
Draw Line tool, right click in the display window.  From the popup 
window (contents may vary depending on 
what mode the user is in) select Enable 
Interactive Snapping using the left mouse 
button.   

Next activate the  (Snap) tool that 
appears on the tool bar.  This allows the 
user to select the interactive snapping 
tolerance visually.  Use the cursor in the 
display window to draw the snapping 
distance (press and hold the left mouse 
button, release when desired).  

Once the interactive snapping is on, and the tolerance has been set, 
the user can snap endpoints on the fly.  To snap the endpoint of one 
reach at a junction, right click on the display screen just before 
placing the downstream endpoint.  Select Snap to Endpoint from the 
popup window.  To end the line, double-click within the snap 
tolerance of the other endpoint - it will snap to the other endpoint 
forming a junction. 

General snapping 
General snapping can be used to form a 
junction after river reaches have already 
been created.  This method is not 
recommended (although often necessary) 
because vertices may be snapped to the 
wrong location.  

From the popup window (contents may 
vary depending on the mode) select Enable 
General Snapping using the left mouse 
button.  

Next activate the  (Snap) tool that appears on the tool bar.  This 
allows you to select the interactive snapping tolerance visually.  Use 
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the cursor in the display window to draw the snapping distance 
(choose a small snapping distance, it helps if you are zoomed in). 

Once the general snapping has been set the user can adjust vertices of 
previously created lines.  Vertices of new lines will also snap to 
vertices within the snap tolerance, so be wary.  To snap the endpoint 
of an existing line, select the   (Vertex Edit) tool (a line theme 
must be active and editable).  Select the endpoint to move by clicking 
once at the endpoint.  Move the endpoint near the junction by 
pressing down on the left mouse button and dragging the endpoint.  
At the junction release the mouse button.  Do not drag the endpoint all 
the way to the junction, but near the junction (just within the snap 
tolerance).  The user will see the endpoint snap to the other endpoint 
(vertex) if the move was close enough.  Make sure the endpoint snaps 
to the correct vertex! 

Uniqueness 
The stream network must have unique reach names for each river.  
Use the River ID tool to check that each reach on a river has a unique 
name or open the Stream Centerline attribute table. 

Directionality  
The Stream Centerline theme must be created in the downstream 
direction.  To check the orientation of the river network, change the 
line symbol to a line symbol with arrows. 

Adding Tributaries to a Network  
Tributaries are added to an existing river network at a junction.  If the 
junction already exists, simply add the new river reach using the 
interactive snapping method described earlier at the endpoint. 

To add a tributary to the middle of a river reach, the reach must first 
be split.  To split a river, make the Stream Centerline active and 
editable and select the  (Split) tool from the tool bar.  This tool 
allows the user to draw a line across the existing river reach.  After 
the reach is split, use the  (Select Features) tool to select and 
delete the extraneous two lines.  Second, use the River ID tool to edit 
the reach names so that they are unique.  Last, add the tributary using 
the interactive snapping method, described earlier, to snap the 
endpoint at the junction. 

A simpler step might be to just create the new tributary using the 
Split tool.  Digitize the tributary down to the main reach and then 
simply cross the reach where the junction should be.  This will 
automatically split the existing river reach and form a junction.  Next, 
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delete the extraneous line (the overlapping end of the new tributary) 
and use the River ID tool to edit the River and Reach names. 

Adding Reaches to a Network 
The Stream Centerline theme must be active and editable.  To add a 
reach to an existing river network, split the reach at the desired 
location using the Split tool.  Use the River ID tool to edit the two 
reach names.   

Merging Reaches in a Network 
The Stream Centerline theme must be active and editable.  Use the 
Select Features tool to select the two river reaches.  (The reaches 
must share common endpoints.)  Select the Edit ⇒ Union Features 
menu item.  Use the River ID tool to check the reach name of the 
new reach.  Make sure the two reaches share an endpoint when 
performing this task! 

Main Channel Banks Theme 

The Main Channel Banks theme defines the main channel flow from 
flow in the overbanks.   

Cross-sectional bank stations will be assigned based on the 
intersection of Main Channel Banks theme and the cross-sectional cut 
lines. 

Rules! 
• Exactly two bank lines may cross each cross-sectional cut line. 

• Bank lines may be broken. 

• Orientation of bank lines is not important. 

• Creating this theme is optional. 

Creating the Bank Station Lines 
Select the preRAS ⇒ Create Banks menu item.  This will create a 
new shapefile (default name of “Banks.shp”) and add it to the current 
view.  The theme will be active and editable. 

Bank station lines should be created on either side of the channel to 
differentiate the main conveyance channel from the overbank areas.  
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To add bank station lines, select the Draw Line tool.  Use the left 
mouse button to start the line and to place vertices.  Double-click the 
left mouse button when finished with the line. 

Create bank lines for each side of the channel for each river.  Bank 
station lines of tributaries may overlap those of the main channel.  
Cross-sectional cut lines may only intersect two bank station lines.   

When finished editing the Banks theme, select Theme ⇒ Stop 
Editing. 

Flow Path Centerlines Theme 

The Flow Path Centerlines theme is used to identify the hydraulic 
flow path in the left overbank, main channel, and right overbank by 
identifying the center of mass of flow.  If the Stream Centerline theme 
already exists you have the option to copy the stream centerline for 
the flow path in the main channel.  Flow paths must be created in the 
direction of flow (upstream to downstream). 

Downstream reach lengths are calculated between cross-sectional cut 
lines along the flow path centerlines for the left overbank, main 
channel, and right overbank. 

Rules! 
• Flow path lines must point downstream - in the direction of flow - 

(the FROM node upstream of the TO node). 

• Each flow path must cross each cross-sectional cut line exactly 
once. 

• Flow path lines should not intersect. 

• Creating this theme is optional. 

Creating the Flow Path Centerlines 
Select the preRAS ⇒ Create Flowpaths menu item.  This will create 
a new shapefile (default name of “Flowpath.shp”) with the LineType 
field and add it to the view.  The LineType field is used to identify the 
flow path in the left overbank, main channel, or right overbank.  The 
flow path theme will be active and editable. 

If the Stream Centerline theme was created previously using the 
Create Stream Centerline item on the preRAS menu, the dialog shown 
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in Figure 4-3 will be invoked allowing the user to copy the stream 
centerline shape to the flow path theme. 

 
Figure 4-3.  Copy the stream centerline to the Flow Path Centerline theme. 

Complete the Flow Path Centerlines theme by drawing (digitizing) in 
the flow paths in the overbank areas.  Begin by selecting the Draw 
Line tool.  Draw the flow path lines in the direction of flow (upstream 
to downstream) using the left mouse button to start the line (left-
click), add vertices (left-click), and end the line (double-left-click). 

Be sure the flow path lines are drawn in the downstream direction.  
To check, change the line symbol to a line symbol with arrows. Each 
flow path line must cross a cross-sectional cut line exactly once and 
should not cross each other. 

When finished creating the Flow Path theme, select Theme ⇒ Stop 
Editing. 

Cross-Sectional Cut Lines Theme 

The location, position, and extent of cross sections are represented by 
the Cross-Sectional Cut Lines theme.  Cut lines should be 
perpendicular to the direction of flow and at times it may be necessary 
to dog-leg the cross-sectional cut line to conform to this requirement.  

While the cut lines represent the planar location of the cross sections, 
the station elevation-data is extracted along the cut line from the 
DTM. 

Rules! 
• Cross-sectional cut lines must be pointed from the left overbank 

to right overbank, when looking downstream. 

• Cut lines should be perpendicular to the direction of flow 
(considering the range of flow events). 

• Cross-sectional cut lines should not intersect. 
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• Cross-sectional cut lines must cross each of the three flow path 
lines and two bank station lines exactly once. 

• Cut lines must not extend beyond the extent of the Terrain TIN! 

Creating Cross-Sectional Cut Lines 
Select the preRAS ⇒ Create XS Cut Lines menu item.  This will 
create a new shapefile (default name of “Xscutlines.shp”), add it to 
the view, and make it active and editable. 

Add the location of each cross section using the Draw Line tool.  
Begin on the left overbank area (when facing downstream) and click 
the left mouse button to begin the cut line.  Use the left mouse button 
to place vertices and left double-click when finished with the cut line.  
The cut lines should be drawn perpendicular to the direction of flow, 
cross a reach line exactly once, and should not cross another cut line. 
Be sure that the cut line covers the entire extent of the floodplain and 
does not extend beyond the extent of the Terrain TIN.   

Check the cross section by changing the line symbol to a line symbol 
with arrows, on the symbol palette.  If the cut line was constructed in 
the incorrect direction, it can be flipped using the Flip Polyline item 
available under the utility menu.  To flip the cut line, select the line 
using the Select Feature tool.  Next, select the GeoRAS_Util  ⇒ 
Flip Polyline menu item. 

When finished editing the Cross-Sectional Cut Line theme, select 
Theme ⇒ Stop Editing. 

Previewing Cross Sections 

Cross section profiles can be previewed using the  (XS Plot) tool.  
To preview a cross section, select the XS Plot tool.  GeoRAS will 
extract the elevation data for each cross section and write it to a 
scratch file (“xsplot.dbf”) located in the GeoRAS project file 
directory.  If the file already exists, a dialog will be invoked asking 
the user to overwrite the data.  Only overwrite the data if the 
placement of the cross sections has changed or you have added cut 
lines since the last time using the XS Plot tool. 
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Figure 4-4.  Overwriting cross-sectional data is only required if cut lines have 
been modified since last using the XS Plot tool. 

Once the cross-section station-elevation data has been extracted to the 
scratch file, a cursor ( ) will appear allowing the user to select a 
cross section to preview.  Use the cursor to select a cross-sectional cut 
line.  When selected, the cut line will be highlighted and the cross 
section will be plotted in a charting window titled “XS Plot” with 
labeled axis. 

 
Figure 4-5.  XS Plot 

The chart will be titled using the Stream ID and Reach ID and Station.  
If this information has not been identified, a cross section ID will be 
applied.  The x-axis is labeled “Station” and the y-axis is labeled 
“Elevation”.  The units used for display will be the default units for 
the underlying Terrain TIN.  

When the XS Plot window is active, the  (Point Identify) tool will 
be available.  The Point Identify tool allows the user to identify a 
point in the cross section in plan view.  To identify a point, select the 
Point Identify tool then click on a point in the cross section plotted.  A 
red graphic dot will be drawn in the view document along the cross 
section at the selected point.  The view will be centered to the point 
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(to insure it is visible).  Additional points may be added using the 
Point Identify tool for the same or different cross sections. 

To remove graphic dots from the screen, use the  (Pointer) Tool to 
select the graphic dot and press the DELETE key.  Alternatively, all 
graphics can be deleted by selecting Edit  ⇒ Select All Graphics and 
pressing the DELETE key. 

Land Use Theme 

A polygon theme may be used to estimate Manning’s n values along 
each cut line. If the polygon theme used is a land use theme, an 
additional field titled N_value will need to be added. 

GeoRAS provides functionality to create a summary table of land 
uses and user specified n values.  The table of n values is then joined 
to the land use data tables.  Alternatively, a field titled N_value may 
be added to the land use table using standard ArcView functionality.  
Extracting n values at cross sections is an optional process. 

Rules! 
• Land use theme must be a polygon data set that encompasses the 

entire expanse of each cross section. 

• The land use theme must have a field titled N_value. 

Creating the Land Use Table 
The Land Use polygon theme must have a N_value field.  To add the 
field to the land use shapefile, activate the land use theme and select 
the GeoRAS ⇒ Create LU-Manning Table menu item.  This will 
invoke a dialog (see Figure 4-6) to allow the user specify which field 
will be referenced for the land use attributes.  Select the field name 
and press OK. 

 
Figure 4-6.  Land use field selection dialog. 

The attributes of the selected field will be summarized and written to 
a new table.  The default name for the table will be “lumanning.dbf” 
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and will be stored in the project directory.  The dialog browser shown 
in Figure 4-7 will appear and allow you to change the file name and 
location. 

 
Figure 4-7. Summary n value table naming dialog. 

The “lumanning” table created will have the land use field and an 
N_value field.  To edit the n-value field, select the Tables document 
from the project window.  The new table (“lumanning.dbf”) will be 
listed.  Select the table and press the Open button.  Note that the field 
headings are in italics, indicating that the table is not editable. 

Make the table editable by selecting Table ⇒ Start Editing. (The 
field headings will be in normal text.)  Use the  (Edit) tool to 
enter n values corresponding to land use.  After entering each n value 
be sure to hit the ENTER key or click in a new cell to record the value 
(especially on the last entry).  When finished entering values, select 
Table ⇒ Stop Editing. 

Note that the “lumanning.dbf” table is joined to the land use data set.  
Therefore, the land use shapefile and lumanning database file need to 
be kept together (referenced in the ArcView project).  Each time the 
ArcView project (.apr) is opened, the tables will be joined using the 
ArcView Join function.  To keep user defined n values with the land 
use data, create a new shapefile with the attached n-value data.  Make 
the land use theme active.  Make sure that all records are unselected 
and select the Theme ⇒ Convert to Shapefile menu item. 

Levee Alignment Theme 

The Levee Alignment theme is used to delineate linear features that 
obstruct the lateral flow of water in the floodplain.  This theme is 
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intended to be used on leveed systems, but should also be used to 
indicate high roads or ridges that connect multiple cross sections. 

Note that HEC-RAS Version 3.1 only supports one levee per 
overbank per cross section – one levee in the left overbank, one levee 
in the right overbank. 

The levee alignment tools are intended to work with both “existing” 
and “proposed” levees.  “Existing” levees means levees that are 
reflected in the Terrain TIN, while “proposed” levees indicate the 
levee profile data is not represented in the Terrain TIN. 

Rules! 
• Levee lines may intersect each cross section only once. 

• One levee per bank (HEC-RAS 3.1 limitation).  

• Levee alignment table must have the field titled Levee_ID. 

Creating Levee Alignments 
Select the preRAS ⇒ Create Levee Alignment menu item.  This 
will create a new shapefile (default name of “levees.shp”), add it to 
the view, and make it active and editable. 

Add the location of each levee using the Draw Line tool.  Left-click 
to start a line and add vertices and double-click to end the levee line.  
After creating each levee line, open the Levee Alignment table.  The 
table contains the field Levee_ID.  This is a required field.  

Make the table editable by selecting Table ⇒ Start Editing.  Use the 
 (Edit) tool to enter an identifier for each levee alignment in the 

Levee_ID field.  The identifier may be a character string up to 16 
characters long and must not have spaces in the name.  After entering 
each identifier be sure to hit the ENTER key or click in a new cell to 
record the value (especially on the last entry).  When finished entering 
values, select Table ⇒ Stop Editing. 

Entering Levee Profile Data 

Levee profile data may be entered using the  (Levee Elevations) 
tool.  This option is necessary to create a levee that is not represented 
in the terrain TIN.  To enter elevations along a levee, select the Levee 
Elevation tool.  Using the  (Bullseye Pointer), click on a specific 
point along a levee.  The levee will become selected and a screen 
allowing the user to specify an elevation will appear, as shown in 
Figure 4-8.  

36 



 
Chapter 4 Developing the RAS GIS Import File 

 
Figure 4-8.  User-specified levee profile data dialog. 

The elevation point entered will be saved in a levee-specific table 
automatically generated.  The table will be labeled using a 
concatenation of “Levee” and the identifier found in the Levee_ID 
field.  Levee profile information is stored in the individual levee table 
in the field headings Station and 
Elevation.  Station is the distance 
from the beginning of the levee to the 
specified-point Elevation.  (Therefore, 
if the levee is constructed from 
upstream to downstream, the river 
stationing will equal zero at the 
upstream end (the beginning) and get 
larger moving downstream.) 

The final levee profile will be created based on an interpolation of the 
user-specified levee profile data.  No extrapolation will occur along 
the levee outside of the specified elevations. 

Entering Surveyed Data 
Surveyed station-elevation data may be entered by hand using 
standard ArcView Table tools or in a spreadsheet.  To do so, first use 
the Levee Elevation tool to create a table linked to the levee 
alignment.  Select the Levee Elevation tool and use the pointer to 
choose a “dummy” location along the levee.  This will create an 
empty table for entering levee profile elevations.  Enter a “dummy” 
elevation for the selected point. 

Next, open the levee table (called “Levee”+Levee_ID) make the table 
editable by selecting Table ⇒ Start Editing.  Select Edit ⇒ Add 
Record to add additional records in the levee table. Use the  
(Edit) tool to enter station-elevation data.  (Be sure to check the that 
orientation of the levee line matches that of the surveyed levee profile 
data.)  Lastly, remove or overwrite the “dummy” record. 

If entering the surveyed data using the table options in ArcView is  
cumbersome, open the table in a spreadsheet and enter the data. 

Completing the Levee Alignment 
GeoRAS requires the final levee alignment to be a 3D shapefile.  
Completing the levee alignment requires that elevation data is 
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extracted.  Select GeoRAS_Util ⇒ Levee Profile Completion to 
convert the 2D Levee theme to a 3D theme.  If no user elevations 
have been specified, the elevation data will be extracted from the 
Terrain TIN.  If, however, additional elevation data has been 
specified, levee elevations will be interpolated between the specified 
points. 

Ineffective Flow Areas Theme 

Ineffective flow areas may be used to identify portions of the cross 
section that do not actively convey flow.  This theme may be readily 
constructed using visual cues upstream and downstream of bridges 
and culverts and in backwater areas  

Rules! 
• Ineffective flow area polygons must intersect a cross-sectional cut 

line exactly twice to form a “block”. 

Creating Ineffective Flow Areas 
Select the preRAS ⇒ Create Ineff. Flow Areas menu item.  This 
will create a new shapefile (default name of “inefflow.shp”), add it to 
the view, and make it active and editable. 

Add the extents of each ineffective flow area using the  (Draw 
Polygon) tool.  Click the left mouse button to begin the storage area.  
Left-click to add vertices to the polygon and finish the polygon by 
double-clicking.  When finished creating the Ineffective Flow Paths 
theme, select Theme ⇒ Stop Editing. 

The attribute table for the Ineffective Flow Areas Theme will have a 
field titled IA_ID.  This field is required. The user can change the 
default identifiers using the table editing tools. 

Storage Area Theme 

Storage areas are used to model floodplain storage during unsteady-
flow analysis.  Storage areas are not reflected in the cross-sectional 
geometry.  This theme is constructed by identifying the bounds of the 
storage area. 
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Rules! 
• Storage areas must be contained within the bounds of the Terrain 

TIN. 

• Storage areas should not overlap one another or cross sections. 

Creating Storage Areas 
Select the preRAS ⇒ Create Storage Areas menu item.  This will 
create a new shapefile (default name of “storages.shp”), add it to the 
view, and make it active and editable. 

Add the boundary of each storage area using the  (Draw Polygon) 
tool.  Click the left mouse button to begin the storage area.  Left-click 
to add vertices to the polygon and finish the polygon by double-
clicking.  When finished creating the Storage Areas theme, select 
Theme ⇒ Stop Editing. 

The attribute table for the Storage Areas Theme will have a field titled 
SA_ID.  This field is required.  The user can change the default 
identifiers using the table editing tools. 

Theme Attributing 

Once the RAS Themes have been created, the geometric data 
extraction process may begin.  The Stream Centerline theme needs to 
be completed and the cross-sectional attributes (geometric data for 
each cross section) need to be calculated.  Note that the Stream 
Centerline theme must be correctly created before completing the 
Cross-Sectional Cut Line theme and the Cross-Sectional Cut Line 
theme must be completed before extracting additional data such as 
Manning’s n values, levee positions, and ineffective flow areas. 

Theme Setup 
Before performing calculations on themes, the role of each theme 
should be specified.  Select the preRAS  ⇒ Theme Setup menu 
item.  The dialog shown in Figure 4-9 will be invoked to allow you to 
specify the “Input Data” themes. 
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Figure 4-9.  Pre-processing theme setup. 

If the themes were created using the step outline on the preRAS 
menu, the “Input Data” field will be filled in; however, if the 
shapefiles were added to the project as previously created data,use the 
drop down lists to select the appropriate themes.  The RAS GIS 
Import File name will need to be specified.  Enter the RAS GIS 
Import File name and press OK.  The extension RASimport.sdf will 
be appended to the filename. 

Centerline Completion 
Complete the stream centerline data by selecting the preRAS ⇒ 
Centerline Completion menu item.  This process will establish the 
connectivity and orientation.  The Stream Centerline is not 
“complete” until the Centerline Elevations menu item has been run 
to create a 3D Stream Centerline theme. 

There are two processes that take place during the Centerline 
Completion item on the preRAS menu. Centerline Topology, 
establishes the connectivity and orientation (upstream and 
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downstream ends) of the river network.  The Lengths/Stations item 
computes the river reach lengths.   

Centerline Topology 
The Centerline Topology process establishes the connectivity and 
orientation (upstream and downstream ends) of the river network.  
The Stream Centerline theme must contain the Stream_ID and 
Reach_ID fields to complete the centerline topology.  This process 
may be completed by selecting the preRAS ⇒ Centerline Topology 
menu item. 

The Centerline Topology process will add the from_Node and 
to_Node fields to the Stream Centerline theme attribute table.  The 
user must check that the node values are computed correctly.  The 
from_Node indicates the upstream end of a river reach while the 
to_Node indicates the downstream end of a river reach.  Therefore, a 
junction will be formed where three endpoints are coincident: two to-
nodes and one from-node. 

Lengths/Stations 
This function computes the lengths along the stream centerline to the 
downstream and upstream most point on each river reach.  The fields 
from_ST (downstream endpoint), to_ST (upstream endpoint), and 
ArcLength are added to the Stream Centerline theme.  This step is not 
“required” but the fields must have data. 

Centerline Elevations  
The Centerline Elevations function creates a 3D shapefile from the 
Stream Centerline (2D) theme using the Terrain TIN to extract 
elevation data.  The elevation data will be extracted from the TIN at 
every triangle edge.  Stream centerline data will be written to the RAS 
GIS Import File from the 3D Stream Centerline shapefile. 

XS Attributing 
Cross section attributes are added to the Cross-Sectional Cut Line 
theme using the preRAS ⇒ XS Attributing menu item.  After all the 
attributes (river and reach names, stationing, bank stations, and reach 
lengths) are appended to the Cross Section Cut Line (2D) shapefile 
attribute table.  The 2D shapefile is then converted to a 3D shapefile 
by selecting preRAS ⇒ XS Elevations. 

Stream/Reach Names 
This function adds the Stream_ID and Reach_ID items to the Cross-
Sectional Cut Line theme based on the intersection of the cut line with 
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the stream centerline.  The Stream Centerline theme must have the 
Stream_ID and Reach_ID fields. The XS_ID field is also added to the 
Cross Section Cut Line Theme.  The XS_ID field is used to relate 
additional data for Manning’s n values, levees, and ineffective flow 
areas. 

Stationing 
The stationing function adds the cross-sectional stationing based on 
the intersection of the cross-sectional cut lines and the stream 
centerline (2D).  The Stream Centerline theme must have the from_ST 
and to_ST items.  The Station field is added to the Cross Section Cut 
Line theme. 

The stream stationing will be developed based on the unit system 
inherent to the data (usually this is based on the Terrain TIN, since it 
is used as the background map).  Therefore, stationing can be changed 
to a new unit system either in HEC-RAS or in ArcView.  

To change the units within ArcView make a dummy field in the 
Cross-Sectional Cut Line table.  Highlight the dummy field and use 
the Calculate button to covert the station units.  Now use the 
Calculate button to set the Station field data equal to the dummy field 
data.  Changing the stationing data in ArcView is not recommend 
because this convolutes the data; however, this may be required for 
some data sets. 

Bank Stations 
Bank station positions for each cross section are computed from the 
intersection of the cross-sectional cut lines and bank station lines.  
Bank station positions are calculated as the percent distance along the 
cut line from its start in the left overbank.  L_BankP and R_BankP 
fields are added to the Cross Section Cut Line theme for the left and 
right bank positions by percent, respectively.  The bank station 
calculation method is shown in Figure 4-10. 
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left bank
right bank

 
Figure 4-10. Calculation of bank station locations from bank lines and cross 
section cut lines. 

Reach Lengths 
This function adds downstream reach lengths to each cross section cut 
line based on the intersection of the flow path centerlines and the cut 
lines.  L_ReachL, M_ReachL, and R_ReachL fields are added to the 
Cross Section Cut Line theme for the downstream reach lengths in the 
left overbank, main channel, and right overbank, respectively.  The 
method for calculating downstream reach lengths is shown in Figure 
4-11. 

 

left 

right 

channel

 
Figure 4-11. Calculation of downstream reach lengths from the flow path 
centerlines and cross section cut lines. 
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XS Elevations 
The XS Elevation function creates a 3D shapefile from the Cross 
Section Cut Line theme.  Station-elevation data is extracted from the 
Terrain TIN at the edge of each triangle along a cut line.  The Cross 
Section Cut Line (2D) theme should be completely processed before 
converting it to a 3D shapefile.  A visualization of the elevation 
extraction process is shown in Figure 4-12. 

TIN

Resultant cross section

Cross section cut line

 
Figure 4-12. Extraction of station-elevation data from a TIN. 

Manning’s n Values 
Manning’s n values are extracted from the Land Use theme during 
this process.  The Land Use theme must have an N_value field and 
cover the extent of all cross sections.  

The field XS_ID in the Cross Section Cut Line theme is joined to a 
table of Manning’s n values.  Manning’s n values are reported at each 
change along the polygon data set as a percent along the cross section 
cut line.  The data extraction process is shown in Figure 4-13. 
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Figure 4-13.  Calculation of n-value locations. 

Manning’s n value data for each cross section is reported to a table 
titled Manning.  This table is comprised of three important fields: 
XS_ID, Fraction, and N_Value.  XS_ID is used to relate the n values 
to the cut lines in the Cross-Sectional Cut Line theme.  Fraction 
indicates the beginning of the N_Value for the given XS_ID. 

Levee Positions 
Levee positions are extracted during this process.  There must be a 3D 
shapefile of levee profile data with a field titled Levee_ID in the 
feature attribute table to perform this function.  

Levee position and elevation data is extracted from the intersection of 
the Cross-Sectional Cut Line theme and the Levee 3D theme.  Data is 
reported to a table titled Levee Positions.  The Levee Positions table 
will have the following fields listed below. 

• XS_ID – identifies the cross section in the Cross Section Cut Line 
theme with the same identifier. 

• Levee_ID –  identifies the levee. 

• Position – reports the position of intersection of the levee and 
cross section as a fraction from the beginning of the cross section.  

• GrndElev – reports the ground elevation as extracted from the 
Terrain TIN at the levee position. 

• Elev – reports the top-of-levee elevation at the given Position for 
the Levee_ID. 

45 



 
Chapter 4 Developing the RAS GIS Import File 

 

Ineffective Flow Areas 
Ineffective flow area data is extracted during this process for each 
cross –sectional cut line.  An Ineffective Flow Area polygon theme 
must be present for this function to work. 

Ineffective flow area data are extracted based on the intersection of 
the Cross Section Cut Line theme and the Ineffective Flow Area 
theme.  Data are reported in “blocks” to a table titled Ineffective Flow 
Areas indicating the beginning and ending locations for each 
ineffective area.  The Ineffective Flow Areas table will have the 
following fields listed below. 

• XS_ID – identifies the cross section in the Cross Section Cut Line 
theme with the same identifier. 

• IA_ID – identifies the ineffective flow area. 

• BegPct – reports the beginning position of intersection of the 
ineffective flow area and cross section as a fraction from the 
beginning of the cross section.  

• EndPct – reports the ending position of intersection of the 
ineffective flow area and cross section as a fraction from the 
beginning of the cross section. 

• BegElev – reports the ground elevation as extracted from the 
Terrain TIN at the BegPct. 

• EndElev – reports the ground elevation as extracted from the 
Terrain TIN at the EndPct. 

• UserElev – indicates the user-specified elevation to turn the 
ineffective flow option off. 

The UserElev field allows the user to specify a specific elevation for 
turning the ineffective flow block off in HEC-RAS.  If the user does 
not specify an elevation, the larger of EndPct and BegPct will be used 
as the default trigger elevation. 

Storage Areas 
Storage area data are extracted for each storage area based on the 
Terrain TIN.  There are two main components to the process:  
extraction of the elevation data points in the area of the TIN and 
calculation of the Elevation-Volume data.  After performing the data 
extraction, the 2D Storage Area theme will be converted to a 3D 
theme.  This function works on the selected set of storage areas 
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thereby allowing the user to extract elevation-volume data for each 
storage area individually.  If no storage area is selected, elevation-
volume data will be extracted for all storage areas. 

Elevation Data 
The extraction of the elevation data points in the Terrain TIN is only 
used to visualize the storage area being inundated in HEC-RAS 
during unsteady-flow simulation of results.  A dialog will appear 
giving the user the choice of skipping the point extraction.  Extracting 
the terrain data is not a required step and it is recommended that it be 
skipped. 

 
Figure 4-14.  Skipping the terrain data extraction will save time. 

If the terrain extraction process is not skipped, a point file of terrain 
points within the storage area(s) in the Terrain TIN will be created 
called “sa_points.shp”. 

Elevation-Volume Data 
Elevation-volume data will be computed for each storage area based 
on the values in the Storage Area attribute table.  The fields in the 
Storage Area attribute table are listed below. 

• SA_ID – uniquely identifies the storage area. 

• MinElev – reports the minimum terrain elevation within SA_ID. 
Elevation-volume data will be calculated from MinElev to 
MaxElev. 

• MaxElev – reports the maximum terrain elevation within SA_ID.  
Elevation-volume data will be calculated from MinElev to 
MaxElev. 

• UserElev – allows the user to specify a maximum elevation for 
calculating the elevation-volume data.  UserElev overrides 
MaxElev. 

Elevation volume data will be calculated for elevations ranging from 
the MinElev to the MaxElev.  To extend the upper end of the 
elevation-volume rating curve, a user-specified elevation may be 
entered in the UserElev field to override the MaxElev calculated. 
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Elevation-volume data is reported for each storage area to a separate 
table titled “E-V for Storage SA_ID”.  Each table will have Elevation-
Volume data between the elevations of MinElev and MaxElev.  Units 
will be the same as the terrain data. 

Elevation-volume calculations are performed at different elevation 
“slices” within each storage area (this assumes a “level pool” within 
the storage area).  Ten incremental elevations are considered.  
Volume calculations are performed on a gridded basis with the grid-
cell size a function of total storage area being considered.   

Generating the RAS GIS Import File 

To generate the RAS GIS Import File, the 3D Stream Centerline and 
Cross Section Surface Line (3D) shapefile must be created from the 
RAS Themes.  Geometric data from the two 3D shapefiles is written 
to the RAS GIS Export File.  The geometric data includes: river, 
reach, and station identifiers; cross-section cut lines; cross-section 
surface lines; main channel bank stations; downstream reach lengths 
for the left overbank, main channel; and right overbank.  Additional 
data for Manning’s n values, levees, ineffective flow areas, and 
storage areas may also be written to the geometric data file. 

Before writing the RAS GIS Import File, select the preRAS ⇒ 
Theme Setup menu item.  In the Theme Setup dialog, check that the 
Intermediate Data files (3D shapefiles) are correct, the correct Terrain 
TIN is listed, and that the RAS GIS Import File name is specified 
correctly.  Press OK to save settings and dismiss the setup window. 

Generate RAS GIS File 
To write the RAS GIS Import File, select the preRAS ⇒ Generate 
RAS GIS Import File menu item.  Header, stream network, and 
cross section information is written to the import file in a specific data 
exchange format readily importable to HEC-RAS.  For a more 
detailed discussion of the GIS data exchange file format, refer to 
Appendix B.  The Generate RAS GIS Import menu item performs the 
three tasks of Header Export, Centerline Export, and XS Export menu 
items. 

Header Export 
The Header Export menu item generates the header section for the 
RAS GIS Import File.  It uses the 3D Stream Centerline, Cross 
Section Surface Line, and Terrain TIN themes to generate the header 
information. 

48 



 
Chapter 4 Developing the RAS GIS Import File 

Projection and unit parameters are taken from the Terrain TIN.  If the 
TIN’s projection parameters are missing (TIN’s .prj file) the user will 
be asked to specify the unit type (METRIC or US CUSTOMARY), 
while all the other projection parameters are set to “null”. 

Centerline Export 
The Centerline Export function writes out the stream network to the 
import file based on the 3D Stream Centerline theme.  Each river 
reach endpoint will be identified in the file separately.  The stream 
centerline coordinates (x,y,z) are reported, including the distance to 
the downstream endpoint. 

XS Export 
The XS Export menu item writes out the geometric data for each 
cross section.  Geometric data reported includes: river and reach 
identifiers, cross section stationing, bank station locations, 
downstream reach lengths, cross section cut line coordinates (x, y), 
and cross section surface line coordinates (x, y, z), Manning’s n 
values, levee data, and infective flow data. 

Storage Area Export 
The Storage Area Export menu item writes out the geometric data for 
each storage area.  The geospatial coordinates for each storage area in 
the Storage Area shapefile will be written out.  However, elevation-
volume data will only be written for those storage areas that have 
corresponding elevation-volume data table.  A dialog will report the 
results to the user if there is not an elevation-volume data table for 
each storage area (see Figure 4-15).  You will have to complete this 
data in HEC-RAS, however, if the storage area is connected to the 
system. 

 
Figure 4-15.  Status window will inform the user of missing elevation-volume data 
tables. 
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C H A P T E R  5   

Generating GIS Data from 
HEC-RAS Results 

HEC-GeoRAS facilitates the generation of GIS themes from exported 
HEC-RAS simulation results.  Floodplain delineation and water depth 
themes may be created from exported cross-sectional water surface 
elevations using HEC-GeoRAS.  Velocity themes may also be 
generated. 

Chapter 5 discusses the processing of exported HEC-RAS results 
using HEC-GeoRAS. 

Contents 

• Importing a RAS GIS Export File 

• Processing Water Surface Elevation Data 

• Processing Velocity Data 

Importing a RAS GIS Export File 

Importing a RAS GIS Export File requires two steps.  The user must 
identify the export file and specify the location to store results to pre-
process the raw data file.  These steps are performed using the Theme 
Setup and Read RAS GIS Export File items on the postRAS menu. 

Theme Setup 
Select the postRAS ⇒ Theme Setup menu item.  This will invoke 
the dialog shown in Figure 5-1, which allows the user to specify the 
RAS GIS Export File, Terrain TIN, Output Directory, and 
Rasterization Cell Size. 

51 



 
Chapter 5 Generating GIS Data from HEC-RAS Results 

 
Figure 5-1. Theme setup for GeoRAS post-processing. 

Select the RAS GIS Export File using the  button.  HEC-RAS 
writes the export file with the RASexport.sdf file extension.  Select the 
Terrain TIN using the  button. 

Specify the Output Directory name.  This the subdirectory, NOT the 
entire pathname.  All post-processing GIS data sets will be written to 
the Output Directory.  The path name of the Output Directory will be 
the name specified appended to the pathname of the location of the 
ArcView project file.  Use a short (rather than long), meaningful 
Output Directory name as it will be used for naming several of the 
GIS themes created later.  Spaces are not allowed in the Output 
Directory name (or the entire directory pathname). 

Enter the Rasterization Cell Size.  This cell size will be used in post-
processing to rasterize the Terrain TIN and resulting TINs for grid 
cell computations (floodplain delineation, flood depth grids, and 
velocity grids). The smaller the cell size, the longer the processing 
time, but depending on the resolution of the Terrain TIN, the more 
accurate spatial location of the floodplain delineation. The 
Rasterization Cell Size should be selected based on the resolution of 
the Terrain TIN.  As a practical consideration, start with a larger cell 
size and evaluate the resulting floodplain delineation and processing 
time.  Refine the cell size during future delineations to improve the 
resulting floodplain boundary.  

Read RAS GIS Export File 
Once the post-processing theme setup is complete, RAS results can be 
read into the GIS.  Select the postRAS ⇒ Read RAS GIS Export 
File menu item.  This function will read the RAS results and create 
base data for GIS post-processing.  The initial base themes created 
include: stream network, cross-sectional cut lines, cross-sectional 
surface lines, banks station lines, water surface profile bounding 
polygons, and velocity mass points. 
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Stream Network 
A stream network theme is created from the RAS GIS Export File.  It 
will identify the location of the stream centerline as represented in 
HEC-RAS and have the River and Reach names.  The stream network 
shapefile will be named based on the concatenation of the Output 
Directory name and “_SN”.  This theme is not used during post-
processing 

Cross-Sectional Cut Lines 
A cross-sectional cut line theme will be created based on the cross-
sectional alignment in RAS during simulation.  The cross-sectional 
cut line theme will include the stream, reach, and station identifiers 
for each cross section location. Water surface elevations for each 
flood event are exported at each cross section including whether or 
not the cross section was interpolated in HEC-RAS.  The cross-
sectional cut line shapefile will be named based on the concatenation 
of the Output Directory and “_XS”.  This theme will be used to create 
the water surface TIN for inundation mapping. 

Cross-Sectional Surface Lines 
A 3D shapefile of cross sections will be created if the cross section 
surface line data is present in the RAS GIS Export File.  It will have 
the attributes of the cross-sectional cut line theme. The cross-sectional 
surface line shapefile will be named based on the concatenation of the 
Output Directory and “_XS3D”.  This theme is not used in post-
processing. 

Bank Stations 
If the bank station data is present, a line theme of bank station 
locations will be created. The bank line shapefile will be named based 
on the concatenation of the Output Directory and “_Banks”.  This 
theme is not used in post-processing 

Bounding Polygons 
Bounding polygon shapefiles will be created for each water surface 
profile exported.  The bounding polygon data defines the RAS model 
extent, thereby limiting the edge of the water surface to the end of 
cross sections, levees, and bridge and culvert openings.  Each 
bounding polygon shapefile name will be a concatenation of “bp” and 
the water surface profile name. A “w” will be added to the water 
surface profile name if it begins with a numeric character. 

Velocity Mass Points 
If velocity data is present, a point theme of velocity mass points will 
be created.  A separate theme will be created for each water surface 

53 



 
Chapter 5 Generating GIS Data from HEC-RAS Results 

profile exported.  The shapefile names will be a concatenation of “vp” 
and the water surface profile name. 

Processing Water Surface Elevation 
Data 

Water surface elevations are written to the RAS GIS Export File at 
each cross section for each flood event.  This water surface data in 
conjunction with the terrain elevation data is used for floodplain 
delineation and determining water surface depths.  Inundation 
mapping may be performed for up to 10 water surface profiles per 
GeoRAS project (assuming no velocity TINs will be created). 
(ArcView is limited in the number of TINs that can be added to a 
project.)  For additional water surface profile data or to analyze 
velocity data, create additional ArcView projects. 

Water Surface TIN Generation 
The first step in the delineation process creates a water surface TIN 
from the water surface elevations attached to each cross section.  To 
build the water surface TIN, select the postRAS ⇒ WS TIN 
Generation menu item.  This invokes a dialog allowing the user to 
chose which water surface profile data to process. 

 

Big 
Bigger 
Biggest 

 
Figure 5-2.  Select the water suface profiles to process. 

Hold down the SHIFT key while selecting profile to select more than 
one.  Once the profile(s) have been selected, press the OK button.  A 
water surface TIN for each selected profile will be created.  An 
example water surface TIN is shown in Figure 5-3. 
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Figure 5-3.  Example water surface TIN clipped by a bounding polygon. 

The water surface TIN is created irrespective of the Terrain TIN and 
is clipped by the bounding polygon.  The bounding polygon limits the 
water surface to the areas as modeled by HEC-RAS and should be 
scrutinized around meandering portions of the river model.  The water 
surface TINs created will be named as a concatenation of “wstin” and 
the water surface profile name. 

Floodplain Delineation 
Floodplain delineation is performed using the postRAS ⇒ 
Floodplain Delineation menu item.  

Rasterization of the water surface TIN and Terrain TIN is the next 
process.  The grids are created using the Rasterization Cell Size 
specified in the post-processing Theme Setup dialog.  The floodplain 
is then delineated where the water surface elevations are higher than 
the terrain elevations or the edge of the water surface grid is limited 
by the bounding polygon, as shown in Figure 5-4. 
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Figure 5-4.  Example floodplain delineation with terrrain contours. 

The same rasterized water surface TIN and Terrain TIN are subtracted 
to create a water depth grid.  An example grid of water surface depths 
is shown in Figure 5-5.  If Spatial Analyst is loaded (Spatial Analyst 
is not required, although it is recommended), the depth grid will be 
named from a concatenation of “gd” and the water surface profile 
name.  Otherwise an intermediate point theme matching the 
computational grid layout will be created and named with the 
concatenation “pd” and the water surface profile name. 

Floodplain delineation results should be carefully examined.  
Spurious ponds may be present and should be deleted in the GIS or 
modeled behind levees.  Inappropriately placed cross sections may 
result in bounding polygon data incorrectly limiting the floodplain. 
The floodplain delineation process in GeoRAS is an iterative process 
that should be used to refine the hydraulic model in HEC-RAS. 
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Figure 5-5.  Example depth grids displayed with terrain contours. 

Processing Velocity Data 

Velocity data are written to the RAS GIS Export File at each cross 
section for each flood event.  It is important to consider that velocity 
results generated from HEC-RAS simulations are the result of a one-
dimensional hydraulic model.     

Velocity TIN Generation 
Select the postRAS ⇒ Velocity TIN Generation menu item.  This 
process builds a TIN from the velocity mass point shapefile created in 
the Read RAS Import File process.  The TIN building process for the 
velocity TIN does not follow any hydraulic rules.  Triangulation (and 
therefore interpolation) is base purely on the spatial layout of the 
mass points.  Results must be carefully scrutinized. 

Velocity Grid Generation 
Select the postRAS ⇒ Velocity Grid Generation menu item.  This 
process will create a grid of velocities from the velocity TIN based on 
the Rasterization Cell Size input in the post-processing theme setup 
dialog.  An example velocity grid is shown in Figure 5-6. 
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Figure 5-6.  Example velocity grid displayed with terrain contours. 

Velocity results must be carefully scrutinized and treated with 
increasing skepticism as they get farther from the cross section.  
Further, incorrect results may arise dictating hydraulic model 
refinement. 
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C H A P T E R  6   

Example Application -  
Wailupe River 

This chapter provides an example application of how to use the HEC-
GeoRAS extension in ArcView GIS for supporting hydraulic model 
development and analysis with HEC-RAS.  This will be a step by step 
procedure of how to develop geometric data for import into HEC-
RAS and how to develop GIS data sets from exported results from 
HEC-RAS simulations. 

The example demonstrated is for the Wailupe River, HI, where a TIN 
exists for the river system.  The figures used may not be 
hydraulically accurate and are intended for demonstration 
purposes only.  Chapters 3-5 provide more detailed discussion of the 
steps performed in this example. 

Contents 

• Loading HEC-GeoRAS 

• Starting a New Project 

• Creating Contours from a TIN 

• Creating RAS Themes  

• Attributing RAS Themes 

• Writing the RAS GIS Import File 

• Running HEC-RAS 

• Importing the RAS GIS Export File 

• Generating GIS Data from RAS Results 
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Loading HEC-GeoRAS 

Start ArcView to begin.  Load the HEC-GeoRAS extension by 
selecting File ⇒ Extensions… menu item from the main ArcView 
interface.  Activate the HEC-GeoRAS extension by placing a check in 
the corresponding checkbox.  Do the same for 3D Analyst and the 
Spatial Analyst extension, if available. 

Starting a New Project 

Before continuing, decide on the directory where the GIS data will be 
stored.  If the directory does not exist, create it using a file manager.  
For this example, the project directory is “Wailupe”. 

Save the project to the project directory by selecting File ⇒ Save 
Project.  In the browser that appears, navigate to the project 
directory, enter the project name (“Wailupe”), and press the OK 
button. 

Make sure that the Project Window (titled “wailupe.apr”) is active 
and select Project ⇒ Properties.  Set the Work Directory in the 
Project Properties window (see Figure 6-1) to the project directory 
established previously.  This insures that data sets created by default 
ArcView procedures will be stored in the same place as those created 
by GeoRAS. 

 
Figure 6-1. Define the “Work Directory” to establish the default location for saving 
data in ArcView. 

From the Project Window, select the View document and press the 
New button.  Make the view (View1) active by clicking in the view’s 
window. 
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Creating Contours from a TIN 

Load the Terrain TIN using the View ⇒ Add Theme menu item.  
Use the “Data Source Types” selection list to select TIN Data Source 
as shown in Figure 6-2.  If the TIN is stored in the Project Directory it 
will be listed.  Otherwise navigate to the correct directory.  Select the 
Terrain TIN.  

 
Figure 6-2. Use the “Data Source Types” selection list on the Add Theme dialog. 

Create contours from the Terrain TIN by selecting Surface ⇒ Create 
Contours.  You will be prompted to enter the contour interval.  Use 
the default (10) and press OK.  The contour theme will be added to 
the view’s table of contents. 

Make the contours visible by placing a check in the corresponding 
checkbox.  If the contours do not provide adequate definition, 
generate a new theme using a smaller contour interval. 

Creating RAS Themes 

In this next section you will create and edit a series of themes 
collectively referred to as the RAS Themes.  The RAS Themes are 
created to extract geometric data for hydraulic analysis.  These five 
themes are the Stream Centerline, Banks, Flow Path Centerlines, 
Cross Section Cut Lines themes, and Land Use themes. 

Stream Centerline 
The Stream Centerline theme is used to establish the river reach 
network. 
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Make the current view (View1) active.  The GeoRAS menus, buttons, 
and tools will be available from the ArcView interface.  Select 
preRAS ⇒ Create Stream Centerline menu item.  The dialog box 
shown in Figure 6-3 will appear.  Specify a name for the new 
shapefile and destination directory and press OK. 

 
Figure 6-3.  The default name for the Stream Centerline theme is "stream." 

The Stream Centerline theme shapefile will be added to the view and 
will be active and editable.  You are now ready to create the two river, 
three-reach river network shown in Figure 6-4. 

 
Figure 6-4.  River and reach network for the Wailupe River. 

Activate the  (Zoom In) tool and zoom into the upper portion of 
the watershed.  Next, activate the  (Draw Line) tool.  Begin the 
first reach by placing the cursor at the upstream most point and left 
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clicking.  This creates the upstream endpoint.  Begin creating the 
reach in the downstream direction by left clicking to add vertices. 

If you run out of digitizing space while creating the river reach, you 
can pan on the fly.  While still in the Draw Line mode, move the 
cursor to the portion of the window you want to see, right click over 
the display window, and select Pan from the popup window.   

When you reach the confluence of the two reaches, double-click to 
end the reach. 

Before creating the next reach you should 
enable snapping.  Right click in the display 
window.  In the popup menu that appears, 
select Enable Interactive Snapping. 

You also need to set the snapping 
tolerance.  Activate the  (Snap) 
interactive tolerance tool.  Move the cursor 
to the downstream endpoint of the reach 
you just created and draw a small circle 
around the endpoint using the cursor (click and hold to draw the 
circle, let go to finish).  Now you are ready to draw the next river 
reach. 

Pan or zoom to the upstream end of the 
next reach.  Activate the Draw Line tool 
and begin drawing the reach down to the 
confluence.  When you are ready to end 
the line at the junction, right click on the 
display window.  In the popup menu that 
appears, select the Snap to Endpoint 
option. 

The cursor will change from the standard 
drawing cross-hairs to a pointer with a 
circle.  The circle defines the interactive 
snapping tolerance distance.  Place the 
cursor at the junction and double click to 
end the line. 

With the Draw Line tool still active create the third reach.  First, right 
click over the display window and select Snap to Endpoint. (This will 
snap the first point you place at the junction.)  Move near (within the 
snap tolerance distance) and click to start the reach.  The line will 
automatically snap to the intersection.  Use the mouse to draw the 
remainder of the reach, using the pan and zoom tools as required. 
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When finished drawing the river reach network, select the Theme ⇒ 

Stop Editing menu item.  Use the  (Zoom to Active Theme) 
button to zoom to the full extent of the Stream Centerline theme. 

Now label each river reach with an identifier.  Activate the  (River 
Reach ID) tool.  Use the cursor in the display window to select a 
river reach.  Upon selection, the dialog shown in Figure 6-5 will 
appear.  Enter the River Name and Reach Name for each reach.  In 
this example the Wailupe River has and Upper and Lower reach and 
the Kului Gorge is a Tributary stream. 

 
Figure 6-5. Label each river reach with a unique name. 

Banks 
The Banks theme is used for identify the main channel conveyance 
area from that of the overbank floodplain areas. 

Select the preRAS ⇒ Create Banks menu item.  The Banks theme 
shapefile will be created and added to the view.  The theme will be 
active and editable. 

Establish the bank station locations on either side of the channel for 
the Wailupe River and Kului Gorge using the Draw Line tool.  Use 
the pan and zoom tools discussed earlier to navigate.  Make sure that 
there is only one line for each bank station location.  When finished 
select Theme ⇒ Stop Editing menu item.  The resultant bank lines 
should look like those illustrated in Figure 6-6. 
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Figure 6-6. Delineation of the main channel from overbanks areas. 

Flow Path Centerlines 
The Flow Path Centerlines theme is used to determine downstream 
reach lengths between cross sections in the channel and overbanks 
areas. 

Select the preRAS ⇒ Create Flowpaths menu item.  Because you 
have already created the Stream Centerline theme, a dialog box will 
appear asking you if the center flow path should be copied from the 
Stream Centerline theme.  Press Yes to copy the centerline.  

Create flow paths in the left and right overbank for each of the rivers 
using the Draw Line tool.  Create the flow paths in the direction of 
flow (from upstream to downstream) and located to indicate the 
center of mass of flow for a specific event.  When finished, select 
Theme ⇒ Stop Editing menu item.  Your flow paths should look 
similar to those in Figure 6-7. 
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Figure 6-7. Illustration of flow path centerlines. 

Now label each flow path with an identifier.  Activate the  (Label 
Flowpaths) tool.  Use the cursor in the display window to select a 
flow path.  Upon selection, the dialog shown in Figure 6-8 will 
appear.  Select from the drop down list the correct label for the left 
overbank, channel, and right overbank flow paths. 

 
Figure 6-8. Each flow path must have an identifier of “Left”,” Channel”, or “Right”. 

Cross-Sectional Cut Lines 
Cross section cut lines are used to identify the location at which cross-
sectional data will be extracted from the Terrain TIN and for bank 
station, downstream reach length, and land use computations. 

Select the preRAS ⇒ Create Flowpaths menu item.  Use the Draw 
Line tool to create cross-sectional location lines.  Use the mouse to 
drawn the cross-sectional lines from the left overbank to the right 
overbank perpendicular to the direction of flow. When finished, select 
Theme ⇒ Stop Editing menu item.  Your cross section cut lines may 
look similar to those in Figure 6-9. 
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Figure 6-9. Cross section cut lines span the entire floodplain. 

Previewing Cross Sections 
Cross section profiles similar to that in Figure 6-10 can be previewed 
through the series of steps described below. 

1. Select the  (XS Plot) tool. 

2. Select Yes in the dialog that appear to extract the cross-sectional 
data. 

 

3. Use the cursor to select the cross section of interest. 

4. The cross section will be plotted in a chart window, as shown in 
Figure 6-10. 
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Figure 6-10. Example cross section previewed using the XS Plot tool. 

Land Use 
The Land Use theme is used to reference roughness coefficients for 
each cross section. 

Make the Land Use theme active.  Select the GeoRAS_Util ⇒ 
Create LU-Manning table menu item.  In the dialog that is invoked, 
select the field that holds the land-use data values from the selection 
list.  This will create a summary table (default name “lumanning.dbf”) 
of land use values and create a field titled N_value. 

 
Figure 6-11.  Select the land use field dialog. 

From the project window, select the tables document.   The name of 
the table will appear as an available document.  Select the table and 
press the Open button.  The table will open with the field names 
across the top shown in italics with a gray background. 

Select Table ⇒ Start Editing to begin entering n values.  Note that 
the field names are no longer in italics, indicating that the table may 
be edited.  Use the  (Edit Cells) tool to edit values in the table.  
When finished entering n values, select Table ⇒ Stop Editing. 
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Select the view document used for creating the themes to access the 
GeoRAS menus. 

Attributing RAS Themes 

The theme attributing process is where the GIS performs calculations 
and appends the results to corresponding tables.  The two themes 
which have data appended to their tables are the Stream Centerline 
and Cross Section Cut Lines themes.   

Before attributing the themes make sure you have the correct themes 
specified.  Select the preRAS ⇒ Theme Setup menu item.  Using 
the drop down lists in the pre-processing dialog window, select the 
theme corresponding to the Terrain TIN and the “Input Data” fields.  
Also enter the name for the RAS GIS Import File you will create later 
(RASImport.sdf will be appended to the filename). 

Stream Centerline Theme 
Select the preRAS ⇒ Centerline Completion menu item.  This will 
establish the connectivity and directionality of the reach network and 
then create a 3D shapefile by extracting elevation data from the 
Terrain TIN. 

Stream and reach fields (Stream_ID and Reach_ID) were already 
present in the Stream Centerline theme table.  The fields appended to 
the table and a short description is provided in Table 6–1. 

 

Table 6–1. Fields appended to Stream Centerline theme table. 

Field Description 

From_node Integer assigned to upstream endpoint 

To_node Integer assigned to downstream endpoint 

To_station Stationing at upstream endpoint 

From_station Stationing at downstream endpoint 

Arclength Length of line defining reach 

Check that each field has been added to the Stream Centerline theme 
table.  Make the Stream Centerline (3D) theme active and press the 

 (Table) button.  This will bring up the table for the active theme.  
Check to ensure that the fields are correctly there and that each value 
has been filled in. 
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Cross-Sectional Cut Lines Theme 
Select the XS Attributing menu items.  If you select the preRAS ⇒ 
XS Attributing menu item, all the functions below (and indented) it 
will be run.  (As a general rule, only use the XS Attributing menu 
item on “good” data sets that have been tested using the individual 
menu items.) The XS Attributing item calculates the cross-sectional 
geometric properties for each RAS Theme.  However, you should go 
through each individual attribute individually, following the order on 
the preRAS menu (Stream/Reach Names, Stationing, Banks, Flow 
Paths). The fields appended to the table are provided in Table 6–2. 

Table 6–2 .  Fields appended to the Cross Section Cut Lines theme table. 

Field Description 

Stream_ID Stream Name taken from the Stream Centerline. 

Reach_ID Reach Name taken from the Stream Centerline. 

XS_ID Cross section ID linked to LUManning table. 

Station Cross section stationing. 

R_BankP Fraction of cut line to right bank station. 

L_BankP Fraction of cut line to left bank station. 

R_ReachL Downstream reach length for right overbank. 

M_ReachL Downstream reach length for channel. 

L_reachL Downstream reach length for left overbank. 

Dialog boxes will inform you if each step is successful.  After all the 
processing is completed, however, you should check that each field 
has indeed been added and have reasonable values. 

Make the XS Cut Lines (2D) theme active and press the Table button.  
This will bring up the table for the active theme.  Check that the fields 
are correctly there and that each value has been filled in. 

Make the view active.  Select the preRAS ⇒ XS Elevations menu 
item.  This will create a 3D shapefile (XS Surface Line) from the 
Cross-Sectional Cut Lines (2D) shapefile by extracting elevations 
from the Terrain TIN.  The attribute table for the new 3D shapefile 
will be identical to 2D shapefile and the elevations. 

Manning’s n Values 

If you have the Land Use theme completed with a field titled 
N_values, extract the estimated Manning’s n values by selecting the 
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preRAS ⇒ XS Elevations menu item.  This will create a new table 
of n value data for each cross section.  The table is called “Manning” 
and will be used to write the data to the RAS GIS Import File. 

Writing the RAS GIS Import File 

Once you have the 3D Stream Centerline and the 3D XS Surface Line 
themes created, you are ready to write the RAS FIS Import File.  You 
already specified the RAS GIS Import File name earlier, but if you 
wish to change it you can using the preRAS ⇒ Theme Setup menu 
item. 

Select the preRAS ⇒ Generate RAS GIS Import File menu item.  
This will create the import file complete with header, stream network, 
and cross section information.  You will be prompted, upon 
completion, for the name and location of the file. 

Running HEC-RAS 

To use HEC-RAS in concert with GeoRAS, perform the following 
steps: 

1. Start a new project in HEC-RAS. 

2. Import the RAS GIS Import File into HEC-RAS.  This is 
accomplished from the Geometric Data editor by selecting File ⇒ 
Import Geometry Data ⇒ GIS Format.  For a more complete 
discussion on importing geometric data, refer to the HEC-RAS 
User’s Manual, Chapter 13. 

3. Complete the hydraulic data.  Hydraulic structure data such as 
bridges and culverts, as well as levees, blocked obstructions, or 
ineffective flow areas will need to be completed.  Banks station 
data may need to be modified using the graphical cross section 
editor.  This is available by selection Tools ⇒ Graphical XS 
Edit… menu item on the Geometric Data editor. 
 
The cross-sectional station-elevation data may need to be filtered 
down to less than 500 points. This is available by selecting Tools 
⇒ Cross Section Points Filter menu item on the Geometric Data 
editor of HEC-RAS. 

4. Complete the flow data and boundary conditions.  Specify water 
surface profile names.  For use with GeoRAS, avoid using a 
number as the first character in the profile name and using blanks. 
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5. Export the HEC-RAS simulation results to the RAS GIS Export 
File.  This is accomplished by selecting File ⇒ Export GIS Data 
from the main HEC-RAS window.  For a more complete 
discussion on exporting GIS data, refer to the HEC-RAS Users 
Manual, Chapter 13. 

Importing the RAS GIS Export File 

Once the file has been exported from HEC-RAS you can read the data 
into the GIS.  Select the postRAS ⇒ Theme Setup menu item.  This 
will invoke the dialog shown in Figure 6-12 (with empty fields).  
Select the RAS GIS Export File and Terrain TIN, enter the Output 
Directory and Rasterization Cell Size, and press OK.   This will 
create a new subdirectory that contains all the post-processing results 
from GeoRAS. 

 
Figure 6-12.  Post-processing theme setup dialog. 

Next, select the postRAS ⇒ Read RAS GIS Export File menu item.  
This will read the results from the export file and create initial data 
sets.  The stream network, cross section data, and bank station data 
will be read and shapefiles will automatically be generated.   

The shapefile names will be a concatenation of the Output Directory 
and an abbreviation (_SN, _XS, _Banks).  The bounding polygon data 
and velocity point data will be read and shapefiles will be 
automatically generated.  Shapefile names will be a concatenation of 
an abbreviation (Bp, Vp) and the water surface profile name.   
Shapefiles created are summarized in Table 6–3. 
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Table 6–3.  Initial post-processing shapefile names. 

Shapefile Description 

…_SN Stream network line shapefile. 

…_XS Cross section cut lines shapefile. 

…_Banks Bank line shapefile. 

Vp… Velocity point shapefile for each water surface. 

Bp… Bounding polygon shapefile for each water surface. 

Generating GIS Data from RAS Results 

Once the data has been read in from the RAS GIS Export File, you 
are ready to create water surface and velocity data sets.  All the post-
processing from this point forward will be using the initial data set 
you created in the previous step.   

Water Surface TIN 
Select the postRAS ⇒ WS TIN Generation menu item.  A dialog 
will be invoked allowing you to select the water surface profile for 
which to create the water surface TIN. You may select one or many of 
the water surface profiles by clicking once on each profile.  Press OK 
to begin the TIN generation process. 

The water surface TIN is created from the cross-sectional cut lines 
theme (_XS) and the bounding polygon theme (Bp) for the respective 
water surface profile names.  The water surface TINs created will 
have the water surface profile name prefixed by “Wstin” and will be 
added to the current view (Output Directory). 

Depth Grid 
Select the postRAS ⇒ Floodplain Delineation menu item.  This 
time a dialog will appear allowing you to select from a list containing 
water surface profile names for those which have a water surface TIN 
(created in the previous step). You may select one or many of the 
water surface profiles by clicking once on each profile.  Press OK to 
begin the floodplain delineation. 

The floodplain delineation will create a polyline theme identifying the 
floodplain and a depth grid. The names will be the water surface 
profile name prefixed by “Fp” and “Gd” for the floodplain and depth 
grid, respectively. 
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Turn on the floodplain polygon by selecting the corresponding 
checkbox.  The floodplain should look similar to that shown in Figure 
6-13.  Use the pan and zoom tools to scrutinize the floodplain 
delineation. 

Next, turn on the depth grid by selecting the corresponding check 
box.  Zoom into an interesting area and use the  (Identify) tool 
tool to find water depths at various locations.  An example depth grid 
and water depth is shown in Figure 6-14. 

 
Figure 6-13.  Example floodplain delineation. 
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Figure 6-14.  Example depth grid with identify results for water depth.  Deeper 
water is indicated by darker blue. 

Velocity TIN 
Select the postRAS ⇒ Velocity TIN Generation menu item.  This 
will provide a dialog that will allow you to pick from a list.  The list 
will contain water surface profile names for which a floodplain 
delineation (floodplain polygon) has been performed and that have a 
velocity point shapefile.  You may select one or many of the water 
surface profiles by clicking once on each profile.  Press OK to begin 
velocity TIN generation. 

The velocity TIN will have the name of the water surface profile 
prefixed by “Veltin” and will be added to the current view. 

Velocity Grid 
Select the postRAS ⇒ Velocity Grid Generation menu item.  
Velocity grids (see Figure 6-15) will be generated for from each 
velocity TIN. 

The velocity grids will have the name of the water surface profile 
prefixed by “Vgd” and will be added to the current view.  Display a 
velocity grid by selecting the corresponding checkbox.  Again, 
pan/zoom to an interesting area and use the identify tool to find areas 
of high velocity. 
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Figure 6-15.  Example velocity grid.  Higher velocities are indicated by darker 
red. 
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C H A P T E R  7   

Example Application - 
Baxter River 

This chapter provides detailed discussion of how to use the HEC-
GeoRAS extension in ArcView GIS for supporting hydraulic model 
development and analysis with HEC-RAS.  This provodes a step-by-
step procedure of how to develop geometric data for import into 
HEC-RAS and how to develop GIS data sets from results exported 
from HEC-RAS. 

This example is for the fictional Baxter River that majestically 
meanders through Tule Town, USA.  We begin our example with a 
TIN of the river system that incorporates detailed terrain data in both 
the main channel and adjacent floodplain.   The detailed terrain model 
will be the basis for this example. 

The figures used in this example are intended to demonstrate the 
GeoRAS process and underlying principles and may not be 
hydraulically accurate.  For more discussion on the steps addressed in 
this example refer to Chapters 3-5. 

Contents 

• Loading HEC-GeoRAS 

• Starting a New Project 

• Creating Contours from a TIN 

• Creating RAS Themes 

• Attributing RAS Themes 

• Generating the RAS GIS Import File 

• HEC-RAS Hydraulic Analysis 

• Importing the RAS GIS Export File 

• Generating GIS Data from RAS Results 
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Loading HEC-GeoRAS 

Start the ArcView GIS program.  Load the HEC-GeoRAS extension 
by selecting the File ⇒ Extensions menu item from the main 
ArcView interface.  Activate the HEC-GeoRAS extension by placing 
a check in the corresponding checkbox.  Do the same for 3D Analyst 
extension and the Spatial Analyst extension, if available. 

 
Figure 7-1.  Load the HEC-GeoRAS extension by checking it on. 

Starting a New Project 

Before continuing through the GeoRAS data development, it is a 
good idea to think through the directory structure for your data.  
Decide on the location to store your GIS data.  If the directory does 
not exist, create it using a file manager.  Make sure there are no 
spaces in any of the directory pathnames!  Move your Terrain TIN to 
an appropriate directory.  For this example, the project directory has 
been named “Example31” (since this example will demonstrate 
functionality of GeoRAS 3.1). 

Save the ArcView project to the project directory by selecting File ⇒ 
Save Project.  In the browser that appears, navigate to the project 
directory, enter the project name (“BaxterRiver”), and press the OK 
button. 
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Setting the Work Directory 
The Work Directory is the directory ArcView will use by default for 
creating data sets; therefore, any data you create using GeoRAS will 
by default be stored to the specified Work Directory.   

Make sure that the Project Window (titled “baxterriver.apr”) is 
active and select Project ⇒ Properties.  Set the Work Directory in 
the Project Properties window to the project directory established 
previously (see Figure 7-2).  The pathname for the Work Directory 
must be typed in correctly; ArcView will not create a new directory.  
Once you have specified the directory press the OK button. 

 
Figure 7-2.  Define the Work Directory to set the default location for saving data. 

From the Project Window, select the View document and press the 
New button (or double-click the View document).  This will make an 
empty view (View 1).  Make View 1 active by clicking in the view’s 
window.  Note that the GeoRAS extension menus, buttons, and tools 
now show up on the ArcView interface. 

You can change the name of View 1 by selecting View ⇒ Properties 
from the ArcView interface.  As shown in Figure 7-3, the title of the 
view has been changed to RAS Themes.  Other properties can be 
changed from the View Properties dialog, including the background 
color. 
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Figure 7-3.  View properties dialog.  

Save your newly created project be choosing File ⇒ Save Project.  
Note that what you are actually saving each time you save your 
project is the project’s settings.  You are not saving data; you are 
saving what windows are open, what size they are, what data is 
displayed, how it is displayed, etc. 

Creating Contours from a TIN 

Load the Terrain TIN using the View ⇒ Add Theme menu item.  
Use the “Data Source Types” selection list to select TIN Data Source 
as shown in Figure 7-4.  If the TIN is stored in the Project Directory it 
will be listed.  Otherwise navigate to the correct directory.  Select the 
Terrain TIN (“baxtertin”). 

 
Figure 7-4.  Select the Data Source Type to add a TIN. 
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Create contours from the Terrain TIN by selecting Surface ⇒ Create 
Contours.  You will be prompted to enter the contour interval.  Use 
the default (10) and press OK.  The contour theme will be added to 
the view’s table of contents. 

Make the contours visible by placing a check in the corresponding 
checkbox.  If the contours do not provide adequate definition, 
generate a new theme using a smaller contour interval. 

Creating RAS Themes 

In this next section, you will create and edit a series of themes 
collectively referred to as the RAS Themes.  The RAS Themes are the 
basis for the geometric data extracted in the GIS for hydraulic 
analysis in HEC-RAS.  The RAS Themes include: Stream Centerline, 
Banks, Flow Paths Centerlines, Cross-Sectional Cut Lines, Land Use, 
Levee Alignments, Ineffective Flow Areas, and Storage Areas. 

The RAS Themes will be used in the following section titled 
Attributing RAS Themes to extract geometric data as attributes for 
import into HEC-RAS. 

Stream Centerline 
The stream centerline is used to establish the river reach network.  
The stream network must be digitized in the direction of flow with 
reach endpoints coincident at junctions. 

Make the current view (“BaxterRiver”) active.  The GeoRAS menus, 
butons, and tools are now available from the ArcView interface.  
Select the preRAS ⇒ Create Stream Centerline menu item.  A file 
browser will appear with the default name of “stream.shp” for the 
Stream Centerline shapefile.  Change the name as desired, make sure 
the file will be save to the correct directory, and press OK. 

A blank Stream Centerline theme will be added to the view and will 
be active and editable, allowing you to create the stream network.  
The two river, three reach network for Baxter River system is shown 
in Figure 7-5. 
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Figure 7-5.  Stream network for the Baxter River. 

Based Figure 7-5 you have an idea of what the river system looks 
like: the Baxter River flows from the Upper to Lower reach, with a 
tributary dividing the two reaches.  We will start by digitizing the 
stream centerline. 

Activate the Zoom In tool and zoom into the upper portion of the 
watershed (zoom in so that the channel is well defined by the 
contours).  If the channel is not well defined, you may have to use the 
Terrain TIN for visualization or create a new set of contours.  Next, 
activate the Draw Line tool. 

Begin digitizing the upper reach by placing the cursor at the upstream 
most point of the study area and left-clicking.  This creates the 
upstream endpoint.  Continue the reach downstream by left-clicking 
to add vertices. 

If you run out of viewable space while digitizing, you can pan (or 
zoom) on the fly.  To pan, move the cursor to the edge of the view 
window (where you want to move to) and right-click.  In the popup 
menu that appears, select Pan (or choose one of the zoom options). 

Continue creating the stream network.  Double-click to finish a reach.  
For the Baxter River there is one junction where the Teal Creek 
enters.  This means we will digitize three reaches with endpoints at 
the junction.  Go ahead and finish digitizing all the reaches, we will 
create the junction after the river network skeleton has been digitized. 
(See the Chapter 6 Example to create the junction on the fly, using 
interactive snapping.) 

River and Reach Naming 
Each river must have a unique reach name and each tributary must 
have a unique river name.  Use the  (River Reach ID) tool to give 
each river and reach a name. 
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Click on the River Reach ID tool to make it active.  With the 
labeling cursor, select each river reach to name.  The River and Reach 
Name dialog will appear allowing you to enter the river and reach 
name.  In this example the Baxter River has an Upper and Lower 
reach and Teal Creek is a Tributary. 

 
Figure 7-6.  River and Reach labeling dialog. 

After labeling each River Reach, look at the Stream Centerline 
attribute table.  To open the table, activate the Stream Centerline 
theme and press the Open Table button.  Note that there are two fields 
in the Stream Centerline table: Stream_ID and Reach_ID.  Under 
each of fields will be the River Name and Reach Name for each river 
reach.  More fields will be added later to verify stream network 
connectivity. 

 
Figure 7-7.  Stream attribute table after labeling river reaches. 

Creating a Junction 
For this example we will create the 
junction using the General Snapping 
method. Note that junction must have 
the endpoints of all three reach 
coincident.  Use the Zoom In tool to 
zoom into the junction of interest.  
Now right-click in the window and 
select Enable General Snapping. 

When general snapping is activated, 

the general snapping  (Snap 
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Tolerance) tool will appear on the tool bar.  Activate the Snap 
Tolerance tool.  Now set the general snap tolerance using the cursor.  
You do this by left-clicking-and-holding the mouse button.  A circle 
will form as you drag the cursor (release when finished).  The circle 
indicates the snapping tolerance for the endpoints. 

Next activate the  (Vertex) tool.  Click on one of the reach 
endpoints (holding the mouse button down) and drag it toward the 
junction.  The circle that appears around the endpoint is the same 
snapping tolerance set previously.  When you release the mouse 
button the endpoint will snap to whatever vertex is within the circle. 

 
Figure 7-8.  Progression for creating a junction using the General Snapping 
technique. 

Do the same for the tributary. The Stream Centerline theme has now 
been created.  Double-check that it was created in the downstream 
direction and that all reaches have been named.  You will double-
check the connectivity later in the Theme Attributing section. 

Main Channel Banks 
The Main Channel Banks theme is used to identify the main channel 
conveyance area from that of the overbank floodplain areas.  This 
theme is not required and there are good tools within HEC-RAS for 
locating bank stations; however, laying out the bank station lines in 
the GIS will require you to read the terrain.  This results in greater 
insight to water movement in the floodplain and in identifying non-
conveyance areas. 

Select the preRAS ⇒ Banks menu item.  The Banks theme shapefile 
(blank) will be created, tagged, added to the view.  It will be active 
and editable. 

Establish the bank station location on either side of the channel for the 
Baxter River and Teal Creek using the Draw Line tool.  Use the pan 
and zoom tools discussed earlier to navigate.  Make sure that there is 
only one line for each bank station location.  It may be necessary 
during this process to turn on the Terrain TIN and zoom way in to 
really see the channel definition.  When finished digitizing the bank 
lines select Theme ⇒ Stop Editing to save the edits.  The resultant 
bank lines for this example are illustrated in Figure 7-9. 
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Figure 7-9.  Bank lines delineate the main channel from the overbank areas. 

Flow Path Centerlines 
The Flow Path Centerlines theme is used to determine downstream 
reach lengths between cross sections in the channel and overbanks 
areas.  A flow path line should be created in the centerof mass of flow 
in the main channel and overbank areas for the water surface profile 
to be studied. 

Select the preRAS ⇒ Create Flowpaths menu item.  Because you 
have already created the Stream Centerline theme, a dialog box will 
appear asking you if the center flow path should be copied from the 
Stream Centerline theme.  Press Yes to copy the centerline.  

Create flow paths in the left and right overbank for each of the rivers 
using the Draw Line tool.  Create the flow paths in the direction of 
flow (from upstream to downstream) and located to indicate the 
center of mass of flow for a specific event.  When finished, select 
Theme ⇒ Stop Editing menu item.  Your flow path lines should 
look similar to those in Figure 7-10. 
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Figure 7-10.  Illustration of flow path centerlines. 

Now label each flow path with an identifier.  Activate the  (Label 
Flowpaths) tool.  Use the cursor in the display window to select a 
flow path.  Upon selection, the dialog shown in Figure 7-11 will 
appear.  Select the correct label from the drop down list for the left 
overbank, channel, and right overbank flow paths. 

 
Figure 7-11.  Each flow path must have an identifier of “Left”,” Channel”, or 
“Right”. 

Check that the flow path type has been identified for each flow path.  
Open the flow path attribute table and verify that the LineType field 
has data for each polyline.  The attributes for the Baxter River 
example flow paths theme is shown in Figure 7-12.  Note that there is 
a Stream_ID and Reach_ID field.  This field was added when we 
copied the Stream Centerline theme for the “Channel” flow path.  
Therefore, there are only Stream and Reach names provided for the 
Channel flow path. 
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Figure 7-12.  Flow path attribute table with the LineType field data properly 
entered. 

Cross-Sectional Cut Lines 
Cross-sectional cut lines are used to identify the location cross-
sectional data is extracted from the Terrain TIN.  The intersection of 
the cut lines with the other RAS Themes will determine bank station 
locations, downstream reach lengths, Manning’s n values, levee 
positions, and ineffective flow areas. 

Cut lines should always be located perpendicular to the direction of 
flow and oriented from the left bank to right bank.  Cut lines must 
cover the entire extent of the floodplain to be modeled.  Creating the 
Flow Path Centerlines theme previously will assist you in laying out 
the cut line perpendicular to flow. 

Select the preRAS ⇒ Create Flow Paths menu item.  Use the Draw 
Line tool to create cut lines.  Use the mouse to draw the cut lines 
from the left overbank to the right overbank dog-legging the cut line 
perpendicular to the flow path lines.  When finished, select the 
Theme ⇒ Stop Editing menu item.  The cross-sectional cut lines for 
the Baxter River are shown in Figure 7-13. 
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Figure 7-13.  Cross-sectional cut lines span the entire floodplain. 

Previewing Cross Sections 
After cut lines are digitized, the cross sections that will be extracted 
from the Terrain TIN can be previewed.  This is often useful to check 
that the cut line spans the entire floodplain and to identify the flow 
distribution through a cross section.  To preview a cross section, 
follow the steps listed below. 

1. Select the  (XS Plot) tool.  

2. Select Yes in the dialog that appears to extract the cross-sectional 
data. 

 
Only update the table if the cut lines have been altered since the 
last time you previewed a cross section. 

3. Use the cursor to select the cross section of interest.  

4. The cross section will be plotted in a chart window, as shown in 
Figure 7-14. 
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Figure 7-14.  Cross section preview using the XS Plot tool. 

Note that for this example, the cross section plot is labeled “Cross 
section 48”.  If the cross section has Station attributes, the stationing 
is used for the label. 

Now lets check the location of our bank station lines at the cross 
section.  With the XS Plot window active, select the  (Point 
Identify) tool.  This will give you a bulls-eye cursor to identify a 
point; use it to click at the location of the bank stations on the cross 
section plot.  Red graphic dots will be drawn to the view window, 
identifying the location along the cross section, as shown in Figure 
7-15. 

 

Figure 7-15.  Use the Point ID tool to locate points in a cross section 
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Land Use 
The Land Use theme is used to establish roughness coefficients for 
each cut line.  The Land Use theme must be a polygon theme and 
have a field titled N_value in its attributes. 

For this example, we have a simple land use theme for the area 
surrounding Tule Town.  As depicted in Figure 7-16, there are many 
land use categories and even more polygons that need to have an n 
value assignment. 

 
Figure 7-16.  Land Use data for the vicinity of Tule Town. 

The example land use data set does not have an N_value field, so we 
need to add it.  Make the Land Use theme active.  Select the 
GeoRAS_Util ⇒ Create LU-Manning Table menu item.  In the 
dialog that is invoked, select the field that holds the description of the 
land use data. 

 
Figure 7-17.  Select the land use description field. 

A file browser will then appear allowing you to choose the name of 
the lookup file (“lumanning.dbf” is default) that will summarize the 
land use categories and allow you to enter n values.  This table will be 
joined to the Land Use theme.  Choose a filename and location and 
press OK. 

From the project window, select the tables document.  The name of 
the table (“lumanning.dbf”) will appear as an available document.  
Open the table by double-clicking on it.  The table will open and the 
field names will appear in italics.  Note that the table is a summary of 
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land use categories and has a blank field titled N_value.  The N_value 
field has been joined to the Land Use theme. 

Select the Table ⇒ Start Editing menu item to begin entering n 
values.  (Note that the field names are no longer in italics, indicating 
that the table is in edit mode.)  Use the  (Edit Cells) tool to edit 
values in the table.  When finished entering n values, select Table ⇒ 
Stop Editing. 

 
Figure 7-18.  Example "lumanning" table with land use description and estimated 
n values. 

Select the view document (“BaxterRiver”) used for creating the 
themes to access the GeoRAS menus.  Open the Land Use theme 
attribute table.  Note that the field N_value has been joined from the 
“lumanning” table. 

 
Figure 7-19.  The N_value field will be joined to the Land Use theme. 
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Levee Alignment 
The Levee Alignment theme is used to identify features that impede 
or direct the flow of water from moving out into the floodplain. 

In our example, the rather well-to-do members of Bushwood Country 
Club have elected to construct a levee to protect their beloved homes.  
Despite the fact that this levee is not in our Terrain TIN, we can 
incorporate their proposed plans into our GeoRAS model 
development. 

Select the preRAS ⇒ Create Levee Alignment menu item.  Using 
the Draw Line tool, digitize the levee alignment.  The levee 
alignment on Baxter River protecting Bushwood Estates is shown in 
Figure 7-20. 

 
Figure 7-20.  Levee alignment for Bushwood Estates. 

Once the levee alignment has been digitized, enter the Levee_ID in 
the Levee Alignment attribute table.  For this example, the levee is 
called “Bushwood”.  

 
Figure 7-21.  Levee Alignment theme attribute table. 

Next, the levee elevation profile data must be entered.  Luckily for us, 
the contractor who is building the levee has the information we need 
and we can easily enter it visually using the  (Levee Elevations) 
tool.  Once the Levee Elevations tool is active click, on a location to 
enter an elevation.  The dialog shown in Figure 7-22 will be invoked 
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showing you what the ground elevation is at that point and allowing 
you to specify a new elevation. 

 
Figure 7-22.  Enter the new levee elevation for the specified point. 

The elevation will be written to a new table called “LeveeBushwood” 
(for our example).  If you make a mistake and do not want a new 
elevation at the specified point, press the Cancel button.  The 
“LeveeBushwood” table can also be edited using standard ArcView 
table editing tools.  The levee profile results are shown in Figure 7-23 
along with the locations of data entry. 

 
Figure 7-23.  Levee profile data is stored in a separate table.  Locations for data 
entry are depicted as dots. 

You now have a levee alignment and profile data, but this must be 
converted to a continuous elevation profile.  Select the GeoRAS_Util 
⇒ Levee Profile Completion menu item.  This will convert the 2D 
levee alignment to a 3D levee shapefile.  The process uses the Station 
and Elevation data to interpolate elevations along the levee alignment 
and saves it as a new 3D levee profile.  Now we can get the position 
and elevation at any point along the Levee Alignment (3D) theme. 

For our example, we used a “proposed” levee – a levee that was not 
incorporated in the terrain data.  If the levee was represented in the 
terrain data, we would only need to digitize the alignment.  When 
running the Levee Profile Completion process, elevation data would 
have been taken directly from the Terrain TIN. 
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Ineffective Flow Areas 
Ineffective flow areas are used to define areas that are not actively 
conveying water.  

There are many bridges across the Baxter River, so we lay out 
ineffective flow areas based on flow contracting as it approaches the 
bridge opening and expanding as it exits the bridge.  An example set 
of ineffective flow areas are shown in Figure 7-24. 

 
Figure 7-24.  Ineffective flow areas at a bridge. 

To create ineffective flow areas, select preRAS ⇒ Create Ineff. 
Flow Areas menu item.  Use the  (Draw Polygon) tool to digitize 
the bounds of the ineffective flow area polygon.  Once the ineffective 
flow area has been digitized, open the Ineffective Flow Area theme 
table and enter an IA_ID.   (If you have many ineffective areas, you 
can leave the naming up to GeoRAS.  We will look at this during the 
Attributing RAS Themes section of this example.) 

Storage Areas 
Storage areas are used in unsteady-flow modeling to represent 
floodplain storage.  Storage areas must be connected to the main 
conveyance channel in HEC-RAS. 

For our example, there are two areas of low-lying land that will store 
water during flood events.  In other words, water will flow into the 
areas during the rise of the hydrograph and may flow back into the 
river during hydrograph recession. 

To create the storage area, select the preRAS ⇒ Create Storage 
Areas menu item.  Use the  (Draw Polygon) tool to digitize the 
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bounds of the storage area polygon.  Once the storage area has been 
digitized, open the Storage Area attribute table and enter the SA_ID.  
As shown in Figure 7-25 and Figure 7-26, our storage areas are called 
“Northside” and “Southside”. 

 
Figure 7-25.  Storage areas along Baxter River. 

 
Figure 7-26.  Storage Area theme attribute table. 

Note that the Storage Area attribute table has several fields with no 
data (“0.0”).  The MinElev and MaxElev fields will be automatically 
filled in later during the storage area elevation-volume calculation.  If 
however, you wanted to override the calculated MaxElev you could 
specify the UserMax as the maximum elevation, to extend the 
elevation-volume rating curve.  For this example we will not specify 
an alternative maximum elevation.  

Attributing RAS Themes 

Thus far you have created (digitized) the GIS RAS Themes needed to 
extract geometric data for HEC-RAS.  The theme attributing process 
is where the GIS performs calculations using the RAS Themes and 
appends the results to corresponding tables.  The two main themes 
which have data appended to their tables are the Stream Centerline 
theme and the Cross-Sectional Cut Line theme. 
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Before attributing the themes, make sure that you have the correct 
themes specified.  You do this through the preRAS ⇒ Theme Setup 
menu item.  Using the drop-down lists in the pre-processing dialog 
window, select the theme corresponding to the Terrain TIN and all of 
the “Input Data” fields.  At this time, also enter the name for the RAS 
GIS Import File.  The theme setup for this example is shown in Figure 
7-27.  We will create this file later. 

 
Figure 7-27.  Theme Setup for the Baxter River example. 

Stream Centerline Theme 
Select the preRAS ⇒ Centerline Completion menu item.  This will 
run the Centerline Topology and Lengths/Stations menu items.  The 
centerline topology establishes the river connectivity and adds the 
from_Node and to_Node fields to the Stream Centerline theme.  
Check these fields to make sure they make sense.  What “makes 
sense”?  Well, make sure that at each junction the reach endpoints all 
share a common node number (in this example, you have 2 to_Nodes 
that have the same from_Node at the junction).  The completed 
attribute table is shown in Figure 7-28.  
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Figure 7-28.  Completed Stream Centerline theme attribute table. 

The Lengths/Stations item calculates the starting and ending station 
of each reach and calculates the corresponding length.  (Note that the 
to/from Nodes work in the direction of flow, while the stationing 
to/from ST works from downstream to upstream.) 

After the Stream Centerline theme has been attributed, convert the 2D 
shapefile to a 3D shapefile.  Select the preRAS ⇒ Centerline 
Elevations menu item.  This will extract elevations along the 
centerline from the Terrain TIN.  This new 3D shapefile is what will 
be written to the RAS GIS Import File, later in this example. 

Cross-Sectional Cut Lines Theme 
Cross-sectional attributes are added to the Cross-Sectional Cut Lines 
theme using the menu items located under the XS Attributing menu 
item.  Selecting the XS Attributing menu item will run in sequence 
the Stream/Reach Names, Station, Bank Stations, and Reach Lengths 
menu items. 

Select each individual menu item in sequence noting whether the 
process runs to a successful completion.  If successful, the cut line 
attribute table will look something like that shown in Figure 7-29.  
Stream/Reach Names adds the XS_ID, Stream_ID, and Reach_ID 
fields; Station menu item adds the Station field; Bank Stations adds 
the R_BankP and L_BankP fields; and Reach Lengths adds the 
R_ReachL, M_ReachL, and L_ReachL fields. 

 
Figure 7-29.  Cross-Sectional Cut Line attribute table. 

If, however, the cut lines and another RAS Theme are not properly 
digitized and attributed, processing will stop.  For this example, the 
cut lines did not extend across both bank lines.  Therefore, when we 
ran the Bank Stations menu item, GeoRAS gave an error message:  
“There are not exactly 2 bank lines intersecting a single cross section!  
Bank percentage calculations FAILED.”  This is a good error 
message, but now we need to know which cross section failed.  Open 
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the cut lines table and the answer pops out.  The cross section that 
failed is the “first” cross section that has “0.00000” where some 
positive fraction should be.  Take a look at the cut line table shown in 
Figure 7-30.  The bad cross section has an XS_ID of “57”. 

 
Figure 7-30.  Debugging GeoRAS problems in the Cross-Sectional Cut Line 
table. 

 Once you have the attribute table open.  You can scroll through and 
find the corrupt cross section.  Use the Select tool to highlight the 
cross-sectional cut line, then go back to your view and zoom into the 
current selection.  Once zoomed in, you should be able to figure out 
what caused the problem! 

Extract Cross-Sectional Elevations 
To finish the with the cut line theme, extract the terrain elevations.  
Select the preRAS ⇒ XS Elevations menu item.  The 2D cut lines 
theme will be converted to a 3D shapefile by extracting elevations 
from the Terrain TIN.  An elevation is extracted each time the cut line 
crosses and triangle edge in the TIN.  The attribute table for the 3D 
shapefile will be identical to the 2D shapefile. 

Manning’s n Values 
Manning’s n values for each cross-sectional cut line will be extracted 
from the Land Use theme, if the Land Use theme has an N_value 
field.  Extract the estimated n values by selecting the preRAS ⇒ 
Manning’s n values menu item.  This will create a new table of n 
value data for each cross-sectional cut line.  The table is called 
“Manning” and is shown in Figure 7-31.  
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Figure 7-31.  Example Manning table cross section n values. 

Levee Positions 
Levee positions for each cross-sectional cut line will be extracted for 
each levee in the 3D Levee theme. (Note that HEC-RAS 3.1 supports 
only one levee per bank.) 

Select the preRAS ⇒ Levee Positions menu item.  The intersection 
of the Levee (3D) theme and the Cross-Sectional Cut Lines theme 
will locate levee positions for each cut line.  Levee elevations will be 
taken from the Levee (3D) theme.  Levee position data will be written 
to a table called “Levee Positions”, as shown in Figure 7-32. 

 
Figure 7-32.  Levee position data for selected cross sections. 
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Ineffective Flow Areas 
Ineffective flow areas for each cross section will be determined from 
the intersection of the Ineffective Flow Areas Theme and the Cross-
Sectional Cut Lines theme. 

Select the preRAS ⇒ Ineffective Flow Areas menu item.  If the 
ineffective flow area identifier IA_ID has not been uniquely specified, 
GeoRAS will automatically generate it for you (as is done in this 
example).  The intersection of each ineffective flow area with a cut 
line and the corresponding terrain elevation will be calculated and 
reported to a table called “Ineffective Flow Areas”.  The fields BegPct 
and EndPct indicate the intersection points at each XS_ID and 
BegElev and EndElev report the associated terrain elevations.  The 
higher of the two elevations will be used in HEC-RAS for the trigger 
elevation.  If you wish , you can override the trigger elevation by 
editing the table under the UserElev field.  An example ineffective 
flow areas table is shown in Figure 7-33. 

 
Figure 7-33.  Ineffective flow areas attribute table. 

Storage Area Completion  
If you are performing a steady-flow analysis of your river system, you 
won’t have any storage areas.  For this example, we will assume you 
will be performing an unsteady-flow analysis. 

Select the preRAS ⇒ Storage Areas Completion menu item.  In this 
example we have already named the storage areas using the SA_ID 
field; however, GeoRAS will automatically give them a unique ID, if 
necessary.    

GeoRAS will then ask you if you want to extract the terrain data from 
the Terrain TIN within each storage area (Figure 7-34).  This would 
allow you to visualize flow exchange in the storage area with the river 
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during unsteady flow analysis in HEC-RAS, but we will skip this 
step, as it is time-consuming to gather the terrain data (and the current 
version of HEC-RAS does perform the flow visualization in storage 
areas). 

 
Figure 7-34.  Select No to skip the terrain data extraction process. 

The wait cursor will then appear and the Elevation-Volume 
relationship for each storage area will be calculated.  The data will be 
written to tables using “E-V for Storage” as a prefix.  In this example, 
the tables are “E-V for Storage Northside” and “E-V for Storage 
Southside”.  Elevations will be calculated for ten elevation intervals 
from the MinElev to the MaxElev as specified in the Storage Area 
attribute table.  Example elevation-volume tables are shown in Figure 
7-35. 

 
Figure 7-35.  Elevation-Volume data for Northside and Southside storage areas. 

After the elevation-volume table has been created for each storage 
area, the 2D Storage Area shapefile will be converted to a 3D 
shapefile, using the Terrain TIN elevations for the elevations along 
the edge of each storage area.  The 3D shapefile will be sent the RAS 
GIS Import File to show the location of storage areas to be modeled. 

 

101 



 
Chapter 7 Example Application – Baxter River  

Generating the RAS GIS Import File 

Once you have created the 3D Stream Centerline theme and 3D XS 
Cut Lines theme, you are ready to write the RAS GIS Import File.  
You specified the file name before (“BaxterRiver”) in the preRAS ⇒ 
Theme Setup, but is always a good idea to check the filename again 
before you create the file. 

 
Figure 7-36.  Use the preRAS Theme Setup to identify the correct shapefiles and 
RAS GIS Import File name. 

You can use the Theme Setup dialog (shown in Figure 7-36) to 
double check that the correct shapefiles were used for extracting data 
(Input Data) and that the correct 3D shapefiles will be used to write 
the data to the RAS GIS Import File (Intermediate Data).  (Note that 
required data is indicated by a asterisk (*); intermediate data is 
constructed from the 2D RAS Themes; and the file extension 
.RASimport.sdf will be added to the RAS GIS Import File name.) 

Select preRAS ⇒ Header Export, preRAS ⇒ Centerline Export, 
preRAS ⇒ XS Export one by one to write the RAS GIS Import File. 
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If the Terrain TIN does not contain a projection file, you will be 
informed and then asked to specify the units of the Terrain TIN.  The 
series of dialogs are shown below. 

 
Figure 7-37.  Dialog invoked if the Terrain TIN does not have a projection file. 

 
Figure 7-38.  You must specify the units of the Terrain TIN if no projection file 
exists. 

You will be informed after the successful completion of writing the 
header.  Proceed to write the stream centerline, cross section, and 
storage area sections of the file.  The status bar at the bottom of the 
ArcView GIS window will give you updates as the data is written to 
the data exchange file. You will be prompted if each part is successful 
or if it fails. 

After generating each section of the RAS GIS Import File, you should 
open the file and check to see that all the data was written out.  Check 
to make sure the number of river reaches is correct and the number of 
cross sections is right.  Checking an ASCII text file for mistakes is not 
easy, but is a skill you will gain through experience. 

HEC-RAS Hydraulic Analysis 

HEC-RAS allows you to perform one-dimensional steady flow and 
unsteady flow analysis of river systems.  The general steps in using 
HEC-RAS 3.1 in concert with GeoRAS, are discussed in the 
following section.  A complete discussion on using the HEC-RAS 3.1 
software, modeling guidelines, and technical information can be 
found in the HEC-RAS User’s Manual, Applications Manual, and 
Hydraulic Technical Reference Manual. 
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Start a new project in HEC-RAS 

Start a new project in HEC-RAS and save it to the directory you want 
the HEC-RAS file to be stored in. 

Import the RAS GIS Import File   

Open the Geometric Data Editor and select File ⇒ Import Geometry 
Data ⇒ GIS Format.  Browse to the RAS GIS Import File 
BaxterRiver.RASimport.sdf and select it.  The data will be read in and 
the Import Options window will allow you to select the data to 
import.  Go through each of the import options, selecting those that 
are appropriate.  The default option is to import all the data in the 
RAS GIS Import File.  Once the data has imported, the Geometric 
Data Editor schematic will show a georeferenced schematic of the 
river system, as shown in Figure 7-39.  You will see the stream 
alignment, cross section locations, bank stations, levees, ineffective 
flow area locations, storage areas, and feature labels. 

 
Figure 7-39.  Georeferenced HEC-RAS schematic generated from imported GIS 
data. 

After importing the geometric data, the first thing you will need to do 
is perform a quality control check on the data.  Make sure there is no 
obviously erroneous data or missing data.  Next, look at your data 
more closely by going through each cross section plot.  Check that 
Manning’s n values are reasonable, bank stations are placed correctly, 
levees and ineffective flow areas are placed correctly spatially and 
have the correct vertical component, check that no cross section has 
more than 500 points using the multiple cross section points filter, etc.  
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One of the best tools for visualizing and editing data is the Graphical 
Cross Section Editor. 

 
Figure 7-40.  Graphical Cross Section Editor in HEC-RAS. 

There are many other tools available in HEC-RAS Geometric Data 
Editor accessible through the Tables menu and Tools menu for 
completing and editing data. 

Complete the hydraulic structure data 
Bridges, culverts, and weirs must be entered by hand using the HEC-
RAS editors. For each structure, you must input the geometric data 
and hydraulic coefficients.  Further, the hydraulic structure data will 
affect the affective flow areas through bounding cross sections. 

In this example, we have two storage areas that we must connect with 
the main channel.  Lateral weirs are used to connect the storage areas 
to the main channel.  The storage areas were constructed behind 
roads, so we can use the top-of-road profile for the lateral weir 
profiles.  You can use GeoRAS to extract this data using the  (XS 
Plot) tool.  

Consider the weir profile to be an additional cross section.  Select the 
preRAS ⇒ Create XS Cut Lines menu item.  A dialog will come up 
asking if you want to “tag” the new theme as being the XS Cut Lines 
theme.  Chose Yes so that GeoRAS knows which theme the XS Plot 
tool should work on. (Note that you will have to use the preRAS ⇒ 
Theme Setup later to select the correct XS Cut Lines theme to use 
the XS Attributing functions.)  Make sure to override the default 
theme name with a good name (like “Weirs”). 
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Now digitize the weir cut line using the Draw Line tool.  Make sure 
to digitize the weir line from upstream to downstream, as this is the 
direction HEC-RAS will use it.  Once you have drawn your weir 
lines, stop editing the theme.  An example weir for the “Northside” 
storage area is shown in Figure 7-41. 

 

Weir line 

 
Figure 7-41.  Storage area with weir line. 

Now that the weir lines are drawn, use the XS Plot tool.  When you 
select the XS Plot tool a file named “xsplot.dbf” is written to the 
directory where your project is saved.  The station-elevation data can 
be copied from the xsplot.dbf file (using a spreadsheet) to the 
Weir/Embankment editor in HEC-RAS. 

Complete the flow data and boundary conditions 
For an unsteady flow analysis you will need to enter all inflow 
hydrographs, boundary conditions, and initial conditions through the 
Unsteady Flow Editor.  We have entered an inflow hydrograph for the 
Baxter River and Teal Creek and a normal depth downstream 
boundary condition,for the Baxter River.  The initial conditions were 
set to the “baseflow” conditions for each river reach.  The storage 
area elevations were set to the minimum elevations based on the 
elevation-volume curve. 
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Figure 7-42.  Inflow hydrograph for the Baxter River. 

Run HEC-RAS  
Next, you will need to go to the simulation window and enter the 
simulation time parameters and computation intervals.  This is also 
where you will turn on the velocity distribution information, if you 
want to have velocity data available for export to the GIS.  Select 
Options ⇒ Flow Distribution Locations to set the distribution of 
flow for each cross section. 

 

 
Figure 7-43.   Unsteady Flow Analysis simulation window for HEC-RAS. 
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Next, run HEC-RAS by hitting the Compute button. During the run, 
a computation window will appear giving you the status of your run.   

Review results and refine model 
After simulating the hydraulic analysis, you will need to look at the 
detailed output HEC-RAS provides to see how to improve the 
hydraulic model.  This may require going back to the GIS to get 
additional geometric data or just modifying what is in HEC-RAS.  
You will need to carefully look at the calculations performed at each 
hydraulic structure and identify how you can improve the 
calculations.  Modify the boundary conditions, initial conditions, and 
the computation interval to make the model stable. 

After going over all the data, simulate again.  Now go back and 
review your results again and refine you model.  Simulate, review, 
refine, repeat! 

Bounding Polygon 
Make sure to always check the “bounding polygon”, to make sure 
HEC-RAS is modeling the floodplain as you intended.  If some of 
your GIS data not georeferenced, you will have problems getting the 
data back to the GIS.   

To turn on the bounding polygon information, select the Tools ⇒ 
Plot GIS Reach Bounds menu item in the Geometric Data editor.  
Then select the river reaches of interest.  The bounding polygon for 
the Baxter River model is shown in Figure 7-44. 

 

 
Figure 7-44.  Bounding polygon for the Baxter River example. 

The bounding polygon will reveal the absolute boundaries of the 
floodplain to be mapped in GeoRAS.  Make sure that the cross 
sections are wide enough and spaced close enough together to capture 
the entire extent of the floodplain. 
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You can also quickly identify which bridges and levees were not 
over-topped during simulation, using the bounding polygon 
information in HEC-RAS. 

Export results 
Once satisfied with model results, you are ready to export the water 
surface profile(s) for processing in the GIS.  From the main HEC-
RAS window, select the File ⇒ Export GIS Data menu item.  This 
will invoke the GIS Export window shown in Figure 7-45. 

Enter the file name to for the GIS data and where to store the file.  
Select the water surface profile to write and any other additional data 
and press the Export Data button. 

 
Figure 7-45.  HEC-RAS GIS Export window. 

Importing the RAS GIS Export File 

Once the RAS GIS Export File has been created, read the data into the 
GIS and processes it to create a flood inundation map.  Select the 
postRAS ⇒ Theme Setup menu item.  This will invoke the post-
processing dialog shown in Figure 7-46 (with empty fields).  Select 
the RAS GIS Export File (*.RASexport.sdf), Terrain TIN, enter the 
Output Directory and Rasterization Cell Size, and press OK.  This 
will create a new View (titled with the Output Directory name 
“MaxWsp”) and create a new directory that will hold all the post-
processing results from GeoRAS. 
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Figure 7-46.  Post-processing theme setup dialog. 

Next, select the postRAS ⇒ RAS GIS Export File menu item.  This 
will read the results from the export file and create initial data sets.  
Shapefiles will automatically be created for the stream network, cross 
sections, and bounding polygon data.  Other shapefiles may be 
created depending on the output options you selected when exporting 
the data from HEC-RAS.  The Terrain TIN will be added to the 
MaxWsp view, as well. 

Generating GIS Data from RAS Results 

Now that the data has been read from the RAS GIS Export File and 
base data has been created, you are ready to create water surface and 
velocity data sets.  All of the post-processing from this point forward 
will be done using the initial data sets created during the Read RAS 
GIS Export File step. 

Water Surface TIN 
Select the postRAS ⇒ WS TIN Generation menu item.  The dialog 
shown in Figure 7-47 will be invoked allowing you to select the water 
surface profile to create the water surface TIN.  In this case, we only 
have one profile to select (MaxWS).  Click once on the profile and 
press the OK button to create the water surface TIN. 

 
Figure 7-47.  Select the water surface profile to map. 
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The water surface TIN will be created from the cross-sectional cut 
lines theme (“Maxwsp_xs”) and bounding polygon theme (“BP 
MaxWS”).  The water surface TIN created will have the water surface 
profile name prefixed by “WS” (“WS MaxWS”) and will be added to 
the MaxWsp view.  The actual TIN filename will be “wstinwsp000” 
and may be identified through the Theme ⇒ Properties dialog. 

Floodplain Delineation 
Select the postRAS ⇒ Floodplain Delineation menu item.  This will 
delineate the floodplain for the “WS MaxWS” TIN.  (If there were 
many water surface TINs, a dialog would have prompted you to 
choose those you wished to process.) 

The floodplain delineation process will first create a depth grid using 
the Rasterization Cell Size to rasterize the water surface TIN and 
Terrain TIN and find the elevation difference.  This depth grid will be 
called “GD MaxWS” in the view and saved as “gdwsp000” on the 
hard drive. (If you do not have the Spatial Analyst extension loaded, 
an additional point shapefile will be used to perform the grid 
calculations.)  The associated floodplain will then be delineated based 
on the grid.  This theme will be added to the view and called “FP 
MaxWS” with a filename of “fpwsp000.shp”. 

Turn on the floodplain shapefile and take a look at the results.  For 
this example, the floodplain shown in Figure 7-48 is zoomed in to only 
a portion of our model. 

 

F
igure 7-48.  Initial floodplain delineation overlaying contours and cut lines. 

Note that our delineation resulted in some “interesting” features, as 
indicated by the arrows in Figure 7-48.  We have disconnected areas of 
flow, along with some other disconcerting inundation areas.  Consider 
each piece of our floodplain and determine whether it makes 
hydraulic sense. 
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The areas to the North of the river are wet because we have a storage 
area located there (called “Northside”).  Storage areas will not 
properly delineate the floodplain, because HEC-RAS only uses them 
for volume calculations (low area fills first); however, if the entire 
storage area was to fill, then we could map the inundation because the 
volume would spread over the entire storage area.  This is the case at 
the “Southside” storage area. 

Next, look at the island of water on the south side of the river denoted 
by an arrow.  There must be as mistake here, right?  How did the 
water get over there?  We must consult the digital terrain data to 
determine if indeed water could get over there.  After checking the 
Terrain TIN, we find that there is no way water could have gotten 
over there, so we must go back to HEC-RAS model and add levees 
which will keep water from flowing out in that portion of the cross 
section and restrict our bounding polygon.  We will do this for the 
other areas under suspicion (as noted by the arrows) on the river’s 
south bank, using the HEC-RAS Graphical Cross Section Editor 
(Figure 7-49) to add levees at the cross sections of interest. 

Other options for removing extraneous areas of ponding are to reduce 
the width of the cross section (not recommended) or to modify the 
bounding polygon before performing the floodplain delineation step. 

 
Figure 7-49.  Use the HEC-RAS graphical cross section editor to add levees. 

After adding additional levees on high ground in HEC-RAS, you will 
need to rerun HEC-RAS to compute new water surface profiles, 
export the results, and then perform the GeoRAS post-processing to 
visualize the results to the floodplain.  The modified floodplain is 
shown in Figure 7-50.  Note that we still have a few very small 
isolated areas of flooding.  Again, this is not hydraulically correct.  
We could fix this through better placement of our levee or modifying 
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our bounding polygon.  As you can see, this is an iterative process 
that requires many iterations between HEC-RAS and the GIS to come 
up with results that are hydraulically correct.  We will move on with 
our example, neglecting further refinement. 

 
Figure 7-50.  Floodplain inundation map results after adding levees to the 
hydraulic model. 

You can now turn on the depth grid and use the various tools to pan, 
zoom, and identify resultant depths in the floodplain.   Using the 
depth grid with a color gradient will allow you to quickly identify 
areas flooded to greater (or lesser) depth.  The Identify tool will 
allow you find water depths at various locations, as illustrated in 
Figure 7-51.  

 
Figure 7-51.  Flood depth grid with Identify Results window. 

Further, you will want to zoom in along the edge of the floodplain and 
determine whether the grid cell size you used is small enough to 
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accurately delineate the floodplain.  In this example, we used a 20ft 
grid cell size, but for other studies this may not be the best choice. 

Velocity TIN 
Select the postRAS ⇒ Velocity TIN Generation menu item.  This 
will create a velocity surface from the “VP MaxWS” point shapefile 
and will add it to the view.  Note that the interpolation is based purely 
on the layout of the points and the internal triangulation criteria used 
by ArcView GIS.  You will need to scrutinize your results and see if 
they make sense!   

Velocity Grid 
Select the postRAS ⇒ Velocity Grid Generation menu item.  This 
will create a grid from the velocity TIN.  Again, you can use the 
velocity grid to analyze the results of the hydraulics model. At each 
cross section the velocity results computed in HEC-RAS will be 
correctly represented; however, as you depart from the cross sections 
the velocity estimates accuracy will be reduced.   An example 
velocity grid is shown in Figure 7-52. 

 
Figure 7-52.  Example velocity grid. 
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Append ix  B  

HEC-RAS Import/Export Files 
for Geospatial Data 

At version 2.0, HEC-RAS introduced three-dimensional (3D) 
geometry for the description of river networks and cross-sections.  
This capability makes it possible to import channel geometry from 
CADD or GIS programs without conversion from real-world 
coordinates to station-elevation descriptions for the cross sections, as 
HEC-2 required.  Similarly, water-surface elevations calculated at 
cross sections can be exported to CADD or GIS programs, where they 
can be used to create model water surfaces for inundation mapping. 

Supported HEC-RAS Data Exchange 

 

Using a formatted ASCII text file, HEC-RAS Version 3.1 will import 
a basic description of the channel geometry including:  
 

• The structure of the stream network, as represented by 
interconnected reaches. 

• The location and description of cross sections. 

• Manning’s n values for each cross section. 

• Levee positions (limited to one per bank) and elevations. 

• Ineffective flow area positions and elevations. 

• Storage area elevation-volume data. 
 

Using the same file format, HEC-RAS can write a file exporting the 
results of a hydraulic model run to a CADD or GIS program.  At a 
minimum, reported results include the locations of cross sections and 
the calculated water-surface elevations at those cross sections.  
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The Import/Export Data File Structure 
 

This section gives general rules for the construction of an HEC-RAS 
geometric data import or export file.  It is not necessary to understand 
all these rules to build an import file, but they may be useful when 
debugging failed imports.  The rules given here are a portion of the 
definition of a general-purpose geometric data exchange format being 
developed at HEC for its NexGen model programs.  Note: These file 
formats are evolving, in that additional data types will be added, 
and some of the existing ones may be modified for future versions.  
If you are writing software to read and write these file formats, 
please keep in mind that you may need to modify your software to 
stay compatible with future versions of HEC-RAS.  
 
Records and Keywords 

 

The HEC-RAS geometric data import file is composed of records, 
which in turn are composed of keywords and values.  All records 
must contain one keyword, and all keywords end with a colon (:).  A 
record can also contain a value or a set of values following the 
keyword, i.e., after the colon.  Spaces, tabs, or line ends can be placed 
between a keyword and values within a record.   
 
A record that contains a keyword and no value marks the beginning or 
the end of a group of related records (for example, the record "BEGIN 
HEADER:" marks the beginning of the header section of a data file).  
A record that contains a keyword and a value assigns that value to the 
part of the model named by the keyword.  
 
When a keyword is read, all spaces up to the colon are removed and 
all letters are capitalized.  The keywords "Begin Header:", "Begin 
header:", and " Be GiNH eadEr:" are all equivalent to 
"BEGINHEADER:".  For readability, keywords named in this manual 
will contain internal spaces.  
 
Values 

 

A record can assign a single value to a single variable, or multiple 
values to an array.  Values can be integers, floating point numbers, 
text strings, or locations (X,Y,Z, label).  A single value in an array of 
values is called an "element" of that array.  
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A numerical value (integer or floating point) cannot contain 
internal blanks.  A floating point number can contain a decimal point; 
an integer cannot.  Elements in an array of numerical values can be 
separated by commas, blanks, tabs, or line ends.   
 
A text string can contain internal blanks, tabs, and commas, but 
cannot contain internal line ends.  Elements in an array of text strings 
must be separated by line ends.  
 
A location consists of three coordinate values and a label (X, Y, Z, 
label). The first two coordinates are planar, the third gives elevation.  
The coordinate values are floating point numbers, and the label can be 
any type of value (although the label can be restricted to a particular 
data type in a particular context). In certain contexts, the elevation 
value or the label may not be required.  If a label is used, all three 
coordinate values must be given; the value "NULL" is valid for the 
elevation coordinate only.  The coordinate values and the label can be 
separated by commas, blanks, or tabs, but a location cannot contain 
internal line ends.  Elements in an array of locations must be 
separated by line ends.  
 
Data Groups 

 

Records in the data file can be collected in two types of groups: 
objects and file sections.  An object is a group of records that combine 
to describe an entity within the model, a cross section for example.  A 
file section is a logical or functional grouping of data, the file header, 
for example, is a section that contains a description of the whole file.   

Objects and file sections begin and end with records that contain 
keywords, but no values.  A file section starts with a record 
containing a keyword composed of the word "BEGIN" followed by 
the section name and a colon, and ends with a keyword composed of 
the word "END" followed by the section name and a colon.  For 
example, records containing only the keywords "BEGIN HEADER:" 
and "END HEADER:" are used to start and end the header section of 
a file.  An object starts with a record containing a keyword naming 
the object type and ends with a record containing the keyword 
"END:" only.  For example, a cross-section object begins and ends 
with records containing the keywords "CROSS-SECTION:" and 
"END:" only.   
 
Comments 
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line end are ignored.  A line that begins with a hash is equivalent to a 
blank line.   

HEC-RAS Channel Geometry Import File 

HEC-RAS reads channel geometry from a text file composed of three 
data sections:  

• A header, containing descriptions that apply to all data in the file.   

• A description of the stream network, containing reach locations 
and connectivity.   

• A description of the model cross-sections, containing their 
location on the stream network and data required to support the 
HEC-RAS model.   

An example HEC-RAS Channel Geometry Import file and HEC-RAS 
model results export file is shown at the end of this appendix.  
 
Header 

 

The header is bounded by the records "BEGIN HEADER:" and "END 
HEADER:" and must contain a record to identify the units system 
used in the imported data set.  The units system can be US 
CUSTOMARY or METRIC.   
 
BEGIN HEADER: 
 
 
UNITS: ENGLISH 
 
END HEADER: 

 

Records that may be included in the header are listed in the  
Table B-1:  
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 Table B-1 
 
 
Keyword 

 
Value Type 

 
Value 

 
UNITS: 

 
string 

 
ENGLISH or METRIC 

 
PROFILES: 

 
string array 

 
List of profiles exported from HEC-RAS.  
Not used on import. 

 
DTM TYPE: 

 
string 

 
type (e.g., TIN or raster) 

 
DTM: 

 
string 

 
name of digital terrain model 

 
STREAM LAYER: 

 
string 

 
name of stream layer in CADD or GIS 

 
NUMBER OF REACHES 

 
integer 

 
number of hydraulic reaches contained in 
the file. 

 
CROSS-SECTION LAYER: 

 
string 

 
name of cross-section layer in CADD or 
GIS 

 
NUMBER OF CROSS-
SECTIONS: 

 
integer 

 
number of cross sections in the file 

 
MAP PROJECTION: 

 
string 

 
projection (coordinate) system used (e.g., 
STATEPLANE) 

 
PROJECTION ZONE: 

 
string 

 
projection zone (if applicable, e.g., 5101) 

 
DATUM: 

 
string 

 
reference datum for planar coordinates 

 
VERTICAL DATUM: 

 
string 

 
reference datum for vertical coordinates 

 
Stream Network  

 

The stream network section is bounded by the records "BEGIN 
STREAM NETWORK:" and "END STREAM NETWORK:" and 
contains records describing reaches and reach endpoints.   At a 
minimum, the stream network section must contain at least two 
endpoints and one reach.  The minimum requirements for a stream 
network are shown below. 
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BEGIN STREAM NETWORK: 

 ENDPOINT:  476132.66, 65291.86, 155.28, 1 

 ENDPOINT:  478144.53, 64296.61, 123.72, 2 

 

 REACH: 

  STREAM ID: Below Springfield 

  REACH ID: Blue River 

  FROM POINT: 1 

  TO POINT: 2 

  CENTERLINE: 

   476132.66, 65291.86, 155.28, 23.13 

   476196.08, 65196.61, 154.47, 23.09 

    lines omitted 

   478144.53, 64296.61, 123.72, 22.41 

 END: 

END STREAM NETWORK: 

 
A reach endpoint is represented by a record containing the keyword 
"ENDPOINT:" followed by four comma-delimited fields containing 
the endpoint’s  X,Y,Z coordinates and an integer ID.   

A reach is represented by a multi-record object that begins with a 
record containing only the keyword "REACH:" and ends with a 
record containing only the keyword "END:."  At a minimum, a reach 
object must contain records setting values for a stream ID, a reach ID, 
a FROM point, and a TO point.  A reach=s FROM and TO point IDs 
must match IDs for endpoints listed before the reach object in the file.  
The reach object must also contain an array of locations defining the 
stream centerline.  This array begins with a record containing only the 
keyword "CENTERLINE:" and ends when any keyword is 
encountered.  A location element in the array contains the X, Y, and Z 
coordinates of a point on the stream centerline, and the point=s river 
station.  In HEC-RAS, elevation and stationing are optional in the 
stream network definition.  If a location element includes a station 
value, it must occupy the fourth field in the element.  If the elevation 
is not known, the word "null" must take its place.  

Station values are assumed to be in miles for data sets in English 
units, and in kilometers for data sets in metric units.  Stationing is 
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used for indexing locations along reaches, and is not used to precisely 
locate objects in the model.   
Records that may be included in a stream network section are 
listed in Table B-2: 
 

 Table B-2 
 

 
Keyword 

 
Value Type 

 
Value 

 
ENDPOINT: 

 
location 

 
coordinates and integer ID 

 
REACH: 

 
none 

 
marks beginning of reach object 

 
END: 

 
none 

 
marks end of reach object 

 
The following records are required for a reach object. 
 
STREAM ID: 

 
string 

 
identifies reach’s membership in stream 

 
REACH ID: 

 
string 

 
unique ID for reach within stream 

 
FROM POINT: 

 
string 

 
integer reference to upstream endpoint 

 
TO POINT: 

 
string 

 
integer reference to downstream endpoint 

 
CENTERLINE: 

 
location array 

 
array elements contain coordinates and 
(optionally) floating point station value.  

 
 

Cross Sections 
 

The cross-sectional file section begins with a record containing the 
only the keyword "BEGIN CROSS-SECTIONS:" and ends with a 
record containing the only the keyword "END CROSS-SECTIONS:."  
A cross section is represented by multi-record object beginning with a 
record containing only the keyword "CROSS-SECTION:" and ending 
with a record containing only the keyword "END:."  

A cross-sectional object must include records identifying the stream, 
reach, and station value of the cross-section, a 2D cut line, and a 
series of 3D locations on the cross section.  Stationing is given in 
miles for data sets with plane units of feet and in kilometers for data 
sets with plane units of meters.  A cut line is composed of the label 
"CUT LINE:" followed by an array of 2D locations.  A cross-
sectional polyline consists of the label "SURFACE LINE:" plus 3D 
coordinates written as comma-delimited X, Y, Z real-number triples, 
one triple to a line.  

Records that may be included in the cross-section file section are 
listed in Table B-3:  
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Table B-3 

 
 
Keyword 

 
Value Type 

 
Value 

CROSS-SECTION: none marks beginning of cross-section object 
END: none marks end of cross-section object 
The following records are required for a cross-section object. 
STREAM ID: string 
REACH ID: string 

identifiers for stream and reach where cross-
section is located (must refer to existing streams 
and reaches in the model) 

STATION: floating point relative position of cross-section on stream 
CUT LINE: location array array elements contain 2D coordinates of cross 

sectione stike line 
SURFACE LINE: location array array elements contain 3D coordinates of cross 

section points 
The following records are optional for a cross-section object. 
BANK POSITIONS: floating point 

(2 elements) 
Fraction of length along cut line where main 
channel bank stations are located.  (values 0.0 - 
1.0) 

REACH LENGTHS: floating point 
(3 elements) 

Distance along left overbank, center channel, and 
right overbank flow paths to next cross-section 
downstream (units are feet or meters). 

NVALUES: floating point 
(n paired 
elements) 

Manning’s n values expressed as fraction along 
cut line to start of n-value (fraction, n-value). 

LEVEE POSITIONS: String, + 2 
floating point 
elements  

Levee positions expressed as fraction along cut 
line to position with elevation (ID, fraction, 
elevation). 

INEFFECTIVE POSTIONS: String, + 3 
floating point 
elements 

Ineffective flow areas expressed as a fraction 
along cut line to beginning and end positions with 
trigger elevation (ID, begin fraction, end fraction, 
elevation).  

WATER ELEVATION: floating point 
array 

Water surface elevation values.  Used for export 
of model results.  Not read on import. 

 
Additional Properties 

 

In addition to the cross-sectional properties, levee alignment, 
ineffective flow area, and storage area data may be written to the 
geometric data exchange file.  This data is written to the file after the 
“END-CROSS-SECTIONS:” header.  With the exception of the 
storage area elevation-volume data, the additional properties data is 
used for display purposes in HEC-RAS.  Additional geometric data, 
not required for HEC-RAS, are listed in Table B-4. 
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Table B-4 
 

 
Keyword 

 
Value Type 

 
Value 

Levee records 
BEGIN LEVEES: none Marks beginning of levee object 
LEVEE ID: string Levee identifier.  Corresponds to ID in LEVEE 

POSITIONS object at cross section 
SURFACE LINE: location array Array elements contain 3D coordinates of levee 

profile points.  Array concludes with END:. 
END LEVEES: string Marks end of levee object 
Ineffective flow area records 
BEGIN INEFFECTIVE 
AREAS: 

none Marks beginning of ineffective flow object. 

INEFFECTIVE ID: string Ineffective flow area identifier.  Corresponds to 
ID in INEFFECTIVE POSITIONS object at cross 
section 

POLYGON: location array Array elements contain 3D coordinates of 
ineffective flow polygon points(X, Y, Elevation).  
Array concludes with END:. 

END INEFFECTIVE AREAS: none Marks end of ineffective flow object. 
Storage area records 
BEGIN STORAGE AREAS: none Marks beginning of storage area object. 
SA ID: string Storage area identifier. 
SURFACE LINE: location array Array elements contain 3D coordinates of storage 

area polygon points.  Array concludes with END:. 
ELEVATION-VOLUME: floating point 

array  
Describes elevation-volume relationship for SA 
ID with paired data (elevation, volume).  Array 
concludes with END:. 

TERRAIN: floating point 
array  

Describes terrain in vicinity of storage area in 3D 
point data (X, Y, Elevation).  Array concludes 
with END:.  

END STORAGE AREAS: none Marks end of storage area object 
 

HEC-RAS Model Results Export File 

 

HEC-RAS exports model results to a text file using the same format 
as the data import file.  The contents of the files, however, are not 
identical.  The stream network section is not required for data export, 
and the surface line may be omitted from the cross-section objects.  
An example HEC-RAS model export file is shown at the end of this 
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discussion.  Model results are reported with the following elements 
(Table B-5), which are not required (and are not read) in the import 
file. 

  

Table B-5 

 
Keyword 

 
Value Type 

 
Value 

 
The following record is optional in the Header section of the export file. 
PROFILE NAMES: string array Name(s) of water surface profiles reported in the 

file.  This record is required if more than one 
profile is reported. 

 
The following record is required for each cross-section object. 
WATER ELEVATIONS: floating point 

array 
Elevation of water surface at the cross-section.  
The array must contain one value for each profile. 

The following records are optional for a cross-section object. 
PROFILE ID: string  Water surface profile name. This must match a 

name in the Profile Names record in the header. 
VELOCITIES: floating point 

(pair) 
Fraction along cut line and value of velocity 
(fraction, value).  Velocities record must follow 
Profile ID record. 

WATER SURFACE 
EXTENTS: 

location array A series of 2D locations marking the limits of a 
water surface. 

The following records make up a section defining a bounding polygon of the water surface limits.  
BEGIN BOUNDARIES: none Marks start of boundaries file section. 
END BOUNDARIES: none Marks end of boundaries file section. 
PROFILE LIMITS: none Marks start of an object defining the limits of a 

single water surface profile. 
 
PROFILE ID: string Name of profile.  This must match a name in the 

Profile Names record in the header. 
POLYGON: location array A series of 2D locations marking the limits of a 

water surface.  A single profile limit can be 
merged from multiple polygons. 

 
 

• HEC-RAS allows the user 16 character profile names.  Profile 
names must begin with a letter. 

• If no profile name is provided, only one water elevation will be 
written for each cross section. 
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Water Surface Bounding Polygon 
 

In addition to a water surface elevation at each cross section (one for 
each profile), the HEC-RAS program sends a bounding polygon for 
each hydraulic reach in the model (the program outputs a new set of 
bounding polygons for each profile computed).  The bounding 
polygon is used as an additional tool  in assisting the GIS (or CADD) 
software to figure out the boundary of the water surface on top of the 
terrain.  

In most cases, the bounding polygon will represent the outer limits of 
the cross section data, and the actual intersection of the water surface 
with the terrain will be inside of the polygon.  In this case, the GIS 
software will use the water surface elevations at each cross section 
and create a surface that extends out to the edges of the bounding 
polygon.  That surface is then intersected with the terrain data, and the 
actual water limits are found as the location where the water depth is 
zero.  

However, is some cases, the bounding polygon may not represent the 
extents of the cross-section data.  For example, if there are levees 
represented in the HEC-RAS model, which limit the flow of water, 
then the bounding polygon will only extend out to the levees at each 
cross section.  By doing this, when the information is sent to the GIS, 
the bounding polygon will prevent the GIS system from allowing 
water to show up on both sides of the levees.  

In addition to levees, the bounding polygon is also used at hydraulic 
structures such as bridges, culverts, weirs, and spillways.  For 
example, if all of the flow is going under a bridge, the bounding 
polygon is brought into the edges of the bridge opening along the road 
embankment on the upstream side, and then back out to the extent of 
the cross-section data on the downstream side.  By doing this, the GIS 
will be able to show the contraction and expansion of the flow 
through the hydraulic structures, even if the hydraulic structures are 
not geometrically represented in the GIS.  

Another application of the bounding polygon is in FEMA floodway 
studies.  When a floodway study is done, the first profile represents 
the existing conditions of the flood plain.  The second and subsequent 
profiles are run by encroaching on the floodplain until some target 
increase in water surface elevation is met.  When the encroached 
profile is sent to the GIS, the bounding polygon is set to the limits of 
the encroachment for each cross section.  This will allow the GIS to 
display the encroached water surface (floodway) over the terrain, 
even though the water surface does not intersect the ground.  
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Import/Export Guidelines 

The following rules apply to channel and cross-section import/export 
data.  
 
Defining The Stream Network 
• The stream network is represented by a set of interconnected 

reaches.  A stream is a set of one or more connected reaches that 
share a common stream ID. 

• A stream is composed of one or more reaches with the same 
stream ID, and each reach in a stream must have a unique reach 
ID.  Every reach must be identified by a unique combination of 
stream and reach IDs. 

• Stream IDs and Reach IDs are alphanumeric strings up to 16 
characters long.  Reach endpoint IDs are integers. 

• Streams cannot contain parallel flow paths.  (If three reaches 
connect at a node, only two can have the same stream ID.)  This 
prevents ambiguity in stationing along a stream. 

• A reach is represented by an ordered series of 3D coordinates, and 
identified by a stream ID, a reach ID, and IDs for its endpoints.   

• A reach endpoint is represented by its 3D coordinates and 
identified by an integer ID. 

• Reaches are not allowed to cross, but can be connected at their 
endpoints (junctions) to form a network.   

• The normal direction of flow on a reach is indicated by the order 
of its endpoints.  One point marks the upstream or "from" end of 
the reach, the other marks the downstream or "to" end of the 
reach.   

 
Defining Cross Sections 

 

• Each cross section is defined by a series of 3D coordinates, and 
identified by a stream name and reach name (which must refer to 
an existing stream and reach) and a station, indicating the distance 
from the cross-section to the downstream end of the stream.  

• A cross-section line can cross a reach line exactly once, and 
cannot cross another cross-section line.   

Results of a water surface calculation are exported in a file that 
contains cross-section locations in plane (2D) coordinates, water-
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surface elevations for the cross-sections, and boundary polygons for 
the reaches.   
 

 
Water Surface Export Data Rules 

 

• A cross-section is represented by a water surface elevation and a 
series of 2D coordinates on the cross-section cut line.  The full 
width of the cross-section is included. 

• One bounding polygon is created for each reach in the stream 
network, and for each profile. 

• A reach’s bounding polygon is made up of the most upstream 
cross-section on the reach, the endpoints of all cross-sections on 
the reach, and the most upstream cross-sections of reaches 
downstream of the reach. 

• For purposes of defining bounding polygons only, the endpoints 
of a cross-section are adjusted to the edge of the water surface at 
the cross-section if the cross-section is part of a floodway, a 
leveed section of the reach, or the water extent is controlled by a 
hydraulic structure.  This allows calculated water surfaces that are 
higher than the land surface to be reported back to the CADD or 
GIS program. 
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Sample HEC-RAS Geometry Import File 

 
BEGIN HEADER: 
 
  DTM TYPE: TIN 
  DTM: d:\georas\wailupe\wai_tin 
  STREAM LAYER: d:\georas\wailupe\stream3d.shp 
  NUMBER OF REACHES: 3   
  CROSS-SECTION LAYER: d:\georas\wailupe\xscutlines3d.shp 
  NUMBER OF CROSS-SECTIONS: 40 
  MAP PROJECTION: STATEPLANE 
  PROJECTION ZONE: 5103 
  DATUM: NAD27 
  UNITS: ENGLISH 
 
END HEADER: 
 
 
BEGIN STREAM NETWORK: 
 
  ENDPOINT: 582090.487, 49258.898, 218.609, 1 
  ENDPOINT: 582331.707, 47063.536, 114.164, 2 
  ENDPOINT: 583735.405, 47715.344, 278.222, 3 
  ENDPOINT: 584138.295, 41249.225, 1.140, 4 
 
  REACH: 
    STREAM ID: Wailupe 
    REACH ID: Upper 
    FROM POINT: 1 
    TO POINT: 2 
    CENTERLINE: 
      582090.487, 49258.898, 218.609, 8640.151 
many lines omitted 
      582331.707, 47063.536, 114.164, 6402.057 
  END: 
 
  REACH: 
    STREAM ID: Kului Gorge 
    REACH ID: Tributary 
    FROM POINT: 3 
    TO POINT: 2 
    CENTERLINE: 
      583735.405, 47715.344, 278.222, 1813.116 
many lines omitted 
      582331.707, 47063.536, 114.164, -0.000 
  END: 
 
  REACH: 
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    STREAM ID: Wailupe 
    REACH ID: Lower 
    FROM POINT: 2 
    TO POINT: 4 
    CENTERLINE: 
      582331.707, 47063.536, 114.164, 6402.057 
many lines omitted 
      584138.295, 41249.225, 1.140, 0.000 
  END: 
 
END STREAM NETWORK: 
 
BEGIN CROSS-SECTIONS: 
 
  CROSS-SECTION: 
    STREAM ID: Wailupe 
    REACH ID: Lower 
    STATION: 220.827 
    BANK POSITIONS: 0.50343, 0.51543 
    REACH LENGTHS: 87.418, 220.827, 159.365 
    NVALUES: 
      0.00000,0.150 
      0.50213,0.035 
      0.53983,0.150 
    LEVEE POSITIONS: 
      leftlevee, 0.11314, 240.05 
      rightlevee, 0.68370, 240.12 
    INEFFECTIVE POSITIONS: 
      IneffArea1, 0.00000, 0.16538, 9.07 
    CUT LINE: 
      586214.122, 42127.918 
      581980.991, 40806.059 
    SURFACE LINE: 
      586214.122, 42127.918, 4.007 
many lines omitted 
      581980.991, 40806.059, 6.390 
  END: 
 

many Cross sections omitted 
 
  CROSS-SECTION: 
    STREAM ID: Wailupe 
    REACH ID: Lower 
    STATION: 6269.258 
    BANK POSITIONS: 0.52237, 0.56932 
    REACH LENGTHS: 170.100, 164.521, 158.965 
    NVALUES: 
      0.00000,0.066 
      0.19234,0.150 
      0.47239,0.035 
      0.56874,0.150 
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      0.94231,0.066 
    INEFFECTIVE POSITIONS: 
      IneffArea1, 0.16534, 0.21538, 3.04 
      IneffArea2, 0.34321, 0.44223, 2.69 
    CUT LINE: 
      582723.174, 46846.449 
      582426.438, 46878.916 
      581953.514, 47082.992 
    SURFACE LINE: 
      582723.174, 46846.449, 161.917 
many lines omitted 
      581953.514, 47082.992, 165.010 
  END: 
 
  CROSS-SECTION: 
    STREAM ID: Wailupe 
    REACH ID: Upper 
    STATION: 6822.378 
    BANK POSITIONS: 0.49244, 0.55533 
    REACH LENGTHS: 142.689, 139.905, 126.201 
    NVALUES: 
      0.00000,0.066 
      0.27498,0.150 
    CUT LINE: 
      582774.257, 47502.740 
      582593.433, 47493.464 
      582343.062, 47465.635 
      582083.418, 47502.740 
    SURFACE LINE: 
      582774.257, 47502.740, 170.548 
many lines omitted 
      582083.418, 47502.740, 164.059 
  END: 
 

many Cross sections omitted 
 
  CROSS-SECTION: 
    STREAM ID: Wailupe 
    REACH ID: Upper 
    STATION: 8032.371 
    BANK POSITIONS: 0.42694, 0.47784 
    REACH LENGTHS: 206.927, 210.604, 211.292 
    NVALUES: 
      0.00000,0.066 
      0.15324,0.150 
      0.68394,0.066 
    CUT LINE: 
      582496.067, 48736.476 
      582190.057, 48657.628 
      581893.321, 48625.161 
    SURFACE LINE: 
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      582496.067, 48736.476, 241.056 
        many lines omitted 
      581893.321, 48625.161, 231.414 
  END: 
 
  CROSS-SECTION: 
    STREAM ID: Kului Gorge 
    REACH ID: Tributary 
    STATION: 1089.584 
    BANK POSITIONS: 0.37339, 0.57995 
    REACH LENGTHS: 263.179, 255.877, 223.864 
    NVALUES: 
      0.00000,0.150 
      0.48348,0.055 
      0.59834,0.150 
      0.70202,0.066 
    CUT LINE: 
      583337.968, 47187.952 
      583207.930, 47327.062 
      583153.496, 47381.496 
      583126.279, 47608.306 
    SURFACE LINE: 
      583337.968, 47187.952, 257.736 
       many lines omitted 
      583126.279, 47608.306, 326.921 
  END: 
 
  CROSS-SECTION: 
    STREAM ID: Kului Gorge 
    REACH ID: Tributary 
    STATION: 833.707 
    BANK POSITIONS: 0.37549, 0.54129 
    REACH LENGTHS: 197.573, 189.074, 185.550 
    NVALUES: 
      0.00000,0.066 
      0.16943,0.150 
      0.44398,0.055 
      0.60938,0.150 
      0.95939,0.066 
    CUT LINE: 
      583223.051, 46967.190 
      583071.844, 47103.276 
      583020.434, 47402.665 
    SURFACE LINE: 
      583223.051, 46967.190, 232.596 
        many lines omitted 
      583020.434, 47402.665, 286.581 
  END: 
 

many Cross sections omitted 
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  CROSS-SECTION: 
    STREAM ID: Kului Gorge 
    REACH ID: Tributary 
    STATION: 273.138 
    BANK POSITIONS: 0.54139, 0.65533 
    REACH LENGTHS: 139.815, 273.138, 79.293 
    NVALUES: 
      0.00000,0.150 
      0.37784,0.055 
      0.62948,0.035 
      0.64874,0.150 
    CUT LINE: 
      582546.842, 47088.605 
      582555.984, 47189.171 
      582550.499, 47240.368 
      582552.327, 47295.223 
    SURFACE LINE: 
      582546.842, 47088.605, 145.787 
       many lines omitted 
      582552.327, 47295.223, 144.778 
  END: 
 
END CROSS-SECTIONS: 

 
BEGIN LEVEES: 
 
  LEVEE ID: leftlevee 
  SURFACE LINE: 
    582686.905, 48638.117, 242.798 
    582686.782, 48630.794, 242.448 
      many lines omitted 
    584905.959, 41579.637, 239.222 
END: 
  LEVEE ID: rightlevee 
  SURFACE LINE: 
    582025.910, 48779.758, 242.024 
    582025.910, 48777.907, 242.024 
        many lines omitted 
    583583.969, 41036.677, 239.356 
  END: 
 
END LEVEES: 
 
BEGIN INEFFECTIVE AREAS: 
 
  INEFFECTIVE ID: IneffArea1 
  POLYGON: 
    584481.034, 42523.915 
    584575.461, 42759.984 
     many lines omitted 
    584481.034, 42523.915 

 
 B-18 



 
Appendix B HEC-RAS Import/Export Files for Geospatial Data 

  INEFFECTIVE ID: IneffArea2 
  POLYGON: 
    582993.795, 44365.257 
    583418.720, 44719.362 
      many lines omitted 
    582993.795, 44365.257 
  END: 
 
END INEFFECTIVE AREAS: 
 
BEGIN STORAGE AREAS: 
 
  SA ID: SA_Area1 
  SURFACE LINE: 
    582769.822, 44692.545  
    582769.822, 44701.057  
      many lines omitted 
    582769.822, 44692.545  
  END: 
  ELEVATION-VOLUME: 
    40.000, 0.000 
    46.000, 66435.249 
    52.100, 450771.888 
    58.200, 1446462.804 
    64.200, 2809967.042 
    70.300, 4369947.061 
    76.300, 6029131.699 
    82.400, 7762270.948 
    88.400, 9573820.153 
    94.500, 11436156.068 
    100.500, 13329687.798 
    106.600, 15238976.327 
  END: 
  TERRAIN: 
    582827.853, 44749.516, 52.003 
    582830.979, 44755.204, 52.003 
      many lines omitted 
    583268.917, 45257.861, 100.012 
  END: 
 
END STORAGE AREAS: 
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Sample HEC-RAS Geographic Data 
Export File 

 
BEGIN HEADER: 
  UNITS: ENGLISH 
  DTM TYPE: TIN 
  DTM: d:\georas\wailupe\wai_tin 
  STREAM LAYER: d:\georas\wailupe\stream3d.shp 
  CROSS-SECTION LAYER: d:\georas\wailupe\xscutlines3d.shp 
  MAP PROJECTION: STATEPLANE 
  PROJECTION ZONE: 5103 
  DATUM: NAD27 
  VERTICAL DATUM:  
  NUMBER OF PROFILES:  3  
  PROFILE NAMES:  
    Big 
    Bigger 
    Biggest 
  NUMBER OF REACHES:  3  
  NUMBER OF CROSS-SECTIONS:  103  
END HEADER: 
 
BEGINSTREAMNETWORK: 
 
ENDPOINT:582331.71,47063.54, , 1 
ENDPOINT:582090.49,49258.90, , 2 
ENDPOINT:584138.30,41249.23, , 3 
ENDPOINT:583735.41,47715.34, , 4 
 
REACH:  
 STREAM ID: Wailupe          
 REACH ID: Upper            
 FROM POINT:  2  
 TO POINT:  1  
 CENTERLINE: 
     582090.49,     49258.90, , 
 many line omitted 
     582331.71,     47063.54, , 
 END: 
 
REACH:  
 STREAM ID: Wailupe          
 REACH ID: Lower            
 FROM POINT:  1  
 TO POINT:  3  
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 CENTERLINE: 
     582331.71,     47063.54, , 
many lines omitted 
     584138.30,     41249.23, , 
 END: 
 
REACH:  
 STREAM ID: Kului Gorge      
 REACH ID: Tributary        
 FROM POINT:  4  
 TO POINT:  1  
 CENTERLINE: 
     583735.41,     47715.34, , 
many lines omitted 
     582331.71,     47063.54, , 
 END: 
 
ENDSTREAMNETWORK: 
 
BEGIN CROSS-SECTIONS: 
 
  CROSS-SECTION: 
    STREAM ID:Wailupe          
    REACH ID:Upper            
    STATION:8032.371 
    CUT LINE: 
      582496.067 , 48736.476  
      582190.057 , 48657.628  
      581893.321 , 48625.161  
    BANK POSITIONS:0.42600,0.47700 
    WATER ELEVATION:199.3957,200.6774,203.5746 
    WATER SURFACE EXTENTS: 
      582242.56,   48671.16,   582212.81,   48663.49 
      582246.10,   48672.07,   582209.73,   48662.70 
      582262.79,   48676.37,   582197.27,   48659.49 
    PROFILE ID:Big 
        VELOCITIES: 
          0.43251,   5.29 
          0.44147,   11.31 
          0.45140,   11.48 
          0.46148,   10.50 
          0.46968,   4.35 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.42484,   1.25 
          0.43231,   5.93 
          0.44145,   12.24 
          0.45141,   12.40 
          0.46151,   11.44 
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          0.47008,   4.88 
          0.47839,   1.21 
    PROFILE ID:Biggest 
        VELOCITIES: 
          0.41496,   3.61 
          0.43201,   6.82 
          0.44142,   13.32 
          0.45143,   13.44 
          0.46155,   12.59 
          0.47070,   6.09 
          0.48537,   3.64 
  END: 
 

Many cross sections (and interpolated cross sections) omitted 
 
  CROSS-SECTION: 
    STREAM ID:Wailupe          
    REACH ID:Upper            
    STATION:6682.474 
    CUT LINE: 
      582641.922 , 47366.533  
      582444.447 , 47335.449  
      582336.567 , 47337.277  
      582062.296 , 47381.161  
    BANK POSITIONS:0.38000,0.47199 
    WATER ELEVATION:133.7104,135.6018,139.3349 
    WATER SURFACE EXTENTS: 
      582417.69,   47335.90,   582377.28,   47336.59 
      582419.39,   47335.87,   582375.14,   47336.62 
      582437.89,   47335.56,   582370.92,   47336.69 
    PROFILE ID:Big 
        VELOCITIES: 
          0.39480,   4.79 
          0.40794,   10.33 
          0.42583,   11.09 
          0.44240,   7.20 
          0.45444,   1.62 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.39368,   4.71 
          0.40788,   10.07 
          0.42586,   10.67 
          0.44287,   7.40 
          0.45565,   2.49 
    PROFILE ID:Biggest 
        VELOCITIES: 
          0.36681,   2.52 
          0.39108,   5.05 
          0.40781,   10.10 
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          0.42589,   10.52 
          0.44336,   7.84 
          0.45805,   3.38 
  END: 
 
  CROSS-SECTION: 
    STREAM ID:Kului Gorge      
    REACH ID:Tributary        
    STATION:1089.584 
    CUT LINE: 
      583337.968 , 47187.952  
      583207.93 , 47327.062  
      583153.496 , 47381.496  
      583126.279 , 47608.306  
    BANK POSITIONS:0.37300,0.57900 
    WATER ELEVATION:219.1924,220.2025,221.5454 
    WATER SURFACE EXTENTS: 
      583192.52,   47342.48,   583177.65,   47357.34 
      583193.66,   47341.33,   583176.64,   47358.36 
      583195.18,   47339.81,   583175.29,   47359.70 
    PROFILE ID:Big 
        VELOCITIES: 
          0.44533,   10.34 
          0.46033,   8.44 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.44432,   11.33 
          0.46129,   9.32 
    PROFILE ID:Biggest 
        VELOCITIES: 
          0.44296,   12.44 
          0.46257,   10.34 
  END: 
 

Many cross sections (and interpolated cross sections) omitted   
 
  CROSS-SECTION: 
    STREAM ID:Kului Gorge      
    REACH ID:Tributary        
    STATION:273.138  
    CUT LINE: 
      582546.842 , 47088.605  
      582555.984 , 47189.171  
      582550.499 , 47240.368  
      582552.327 , 47295.223  
    BANK POSITIONS:0.54099,0.65500 
    WATER ELEVATION:135.2666,136.3284,137.8818 
    WATER SURFACE EXTENTS: 
      582554.32,   47204.74,   582552.81,   47218.77 
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      582554.37,   47204.24,   582552.76,   47219.30 
      582554.45,   47203.51,   582552.67,   47220.11 
    PROFILE ID:Big 
        VELOCITIES: 
          0.56337,   1.54 
          0.57644,   10.95 
          0.59787,   15.34 
          0.61730,   13.10 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.56256,   2.97 
          0.57620,   12.59 
          0.59789,   17.18 
          0.61875,   14.67 
          0.63251,   1.86 
    PROFILE ID:Biggest 
        VELOCITIES: 
          0.56137,   4.30 
          0.57597,   14.31 
          0.59791,   19.12 
          0.61927,   16.89 
          0.63330,   5.09 
  END: 
 
  CROSS-SECTION: 
    STREAM ID:Wailupe          
    REACH ID:Lower            
    STATION:6269.258 
    CUT LINE: 
      582723.174 , 46846.449  
      582426.438 , 46878.916  
      581953.514 , 47082.992  
    BANK POSITIONS:0.52401,0.56900 
    WATER ELEVATION:123.9078,125.2825,127.845 
    WATER SURFACE EXTENTS: 
      582309.53,   46929.36,   582276.02,   46943.82 
      582309.55,   46929.35,   582275.92,   46943.87 
      582326.40,   46922.09,   582195.49,   46978.57 
    PROFILE ID:Big 
        VELOCITIES: 
          0.52365,   2.47 
many lines omitted 
          0.56408,   1.21 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.52363,   2.70 
many lines omitted 
          0.56380,   1.27 
    PROFILE ID:Biggest 
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        VELOCITIES: 
          0.51786,   2.90 
many lines omitted 
          0.66018,   0.35 
  END: 
 

  Many cross sections (and interpolated cross sections) omitted 
 
  CROSS-SECTION: 
    STREAM ID:Wailupe          
    REACH ID:Lower            
    STATION:220.827  
    CUT LINE: 
      586214.122 , 42127.918  
      581980.991 , 40806.059  
    BANK POSITIONS:0.50300,0.51500 
    WATER ELEVATION:5.503006,5.881266,6.600093 
    WATER SURFACE EXTENTS: 
      586214.12,   42127.92,   583114.30,   41159.95 
      586214.12,   42127.92,   581980.99,   40806.06 
    PROFILE ID:Big 
        VELOCITIES: 
          0.00851,   0.55 
many lines omitted 
          0.71676,   0.18 
    PROFILE ID:Bigger 
        VELOCITIES: 
          0.00855,   0.63 
many lines omitted 
          0.72186,   0.25 
    PROFILE ID:Biggest 
        VELOCITIES: 
          0.01783,   0.55 
many lines omitted 
          0.99398,   0.11 
  END: 
 
END CROSS-SECTIONS: 
 
BEGIN STORAGE AREAS: 
  SA ID: SA_Area1  
 WATER ELEVATION: 5.2454, 5.65658, 6.12648 
  SURFACE LINE: 
    582769.822, 44692.545  
    582769.822, 44701.057  
      many lines omitted 
    582769.822, 44692.545         
     
  END: 
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END STORAGE AREAS: 
 
BEGIN BOUNDS: 
  PROFILE LIMITS: 
    PROFILE ID:Big 
    POLYGON: 
      581893.32 , 48625.16  
many lines omitted  
      581908.77 , 48563.31  
    POLYGON: 
      583126.27 , 47608.3  
many lines omitted 
      583090.99 , 47539.75  
    POLYGON: 
      581953.51 , 47082.99  
many lines omitted 
      581934.96 , 47008.78  
  END: 
 
  PROFILE LIMITS: 
    PROFILE ID:Bigger 
    581893.32 , 48625.16  
many lines omitted  
      581908.77 , 48563.31  
    POLYGON: 
      583126.27 , 47608.3  
many lines omitted 
      583090.99 , 47539.75  
    POLYGON: 
      581953.51 , 47082.99  
many lines omitted 
      581934.96 , 47008.78  
  END: 
 
  PROFILE LIMITS: 
    PROFILE ID:Biggest 
    581893.32 , 48625.16  
many lines omitted  
      581908.77 , 48563.31  
    POLYGON: 
      583126.27 , 47608.3  
many lines omitted 
      583090.99 , 47539.75  
    POLYGON: 
      581953.51 , 47082.99  
many lines omitted 
      581934.96 , 47008.78  
  END: 
END BOUNDS: 
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