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How to Use the Configuration Manager

Each time the Flight Path Tool Application is started, the Configuration Manager allows a con-
figuration file to be selected and loaded. The configuration file can save almost anything from the
tool that is configurable such as data layers, data overlays, favorite flight routes, vertical cross
sections, and zoom levels. There is a Default file that comes with the application, and if no files
have been previously saved, this will be the only option. Once configuration files have been
saved, those will be listed, as well as the Default file, and Other.... The Other... option is used to
browse the local file system to load aconfiguration file from another location. Left click the arrow
in the drop down box to select a configuration file, then click the Load button to load the applica-
tion.

The Configuration Manager is also used to save and load configuration files. To load a different
configuration file after the application has started, left click File->Load and choose a configura-
tion file from the local file system.
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How to Zoom

Q The zoom button is selected by default when the flight path tool is loaded. When a differ-

ent button is used, the zoom button is automatically re-selected after that operation is completed.
To zoom, click and hold the left mouse button and diag the mouse (creating a “rubber band”) over
the area of interest. Release the button and the map will redraw to the selected area.

Q The back button reverts to the previous zoom state. If the Continental U.S. is currently

showing, and the zoom button is then used to zoom into Colorado, clicking the back button will
re-draw the map over the Continental U.S. Note that the displayed data will be any currently
selected Background Grids or Data Overlays.

'@ The overview button changes the area displayed in the main window. Left click the over-

view button. In the Overview window, click and hold the left mouse button down within the red
box and drag the box to the new area of interest. Release the mouse button and the map in the
main window will redraw to the selected area. Zoom on an area in the main window (see above)
and a smaller box will appear. Note, the red box surrounds the area selected by zooming, so if a
zoom state has not been selected, the box will surround the entire map. The edges of the red box
may also be dragged to resize the zoom area.

The View menu item is used to view other parts of the world in the main window. If Europe is
selected, the World map overlay should also be selected in the Data Layers area. In the Data
Layers dialog, scroll down to the Map Overlays item and check World in the list of check
boxes. Then, select the desired data type from the Data Overlays check boxes. Note that the
background grid data sets are not available for places outside the Continental U.S.



#™ The pan button is for moving to different areas of the currently selected view. To pan the

map, click the pan button, then click and drag the map with the left mouse button to the new area
of interest. Release the button and the map will redraw to the selected area.



How to Change the Altitude

The altitude slider is marked with text indicating altitude in feet. Click and hold the left mouse
button within the orange box on the slider and drag the mouse until the desired altitude turns
orange. Release the mouse button and the map will be redrawn with data at the requested altitude.
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How to Choose the Data Valid Time

The time slider is used to change the data in the main window. The red line shows the current
time, and the orange slider determines the selected data valid time.

Click and hold the left mouse button within the orange box on the time slider and drag the mouse
until it is on the desired time. Release the mouse button and the map will be redrawn with data at

the requested time.
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How to Choose the Time Range and Animate

The time range shown below the map limits the valid times which can be selected and defines the
time range which will be animated. To change the time range or animation properties, left click on
the Configure->Time menu at the top of the main window.

The Time & Animation Configuration window has two tabs. The first, Time, is used to control
the visible time range. The second, Animation, is used to control the length and speed of anima-
tion. The Cancel button closes the dialog without making any further changes, while the Apply
button commits all changes.
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The Time tab allows configuration of the number of tick marks on the time slider and whether or
not the sliding button snaps onto the nearest tick mark. It also controls whether the application is
in Archive Mode or Real-time Mode.

In Real-time Mode (the default), the application automatically looks for new data on the interval
specified in the Update every pulldown menu. In this mode, there are several options for the
range and selected time in the time slider. By default, the selected time is Always ‘now’, meaning
that it moves forward as time progresses; New data are selected as they become available. Other
options are to have the selected time stay Fixed at its current setting or to have the selected time
always be Offset from the ‘now’ time. The Date Range is the time range shown in the time selec-



tor and the time range over which animation will take place. By default this range moves forward
as time progresses, always showing the same number of hours before ‘now’ and after ‘now’.
Selecting a Fixed start time instead, allows the range to be fixed from a Fixed start time to a
Max date range.

In Archive Mode, the application does not automatically look for new data or change the selected
time. In this mode, the Start time and End time must be explicitly set.

Animation Tab

The Animation tab allows configuration of the number of frames used to represent the time
range and the frame delays.

By default, the Number of Frames is equal to the number of tick marks in the time range. Sliding
the selector left or right increases or decreases, respectively, the number of frames. The Frame
interval automatically updates to show the amount of time between frames. The Number of
Frames can also be set by typing a number into the Frame interval field and pressing the Enter
key.

The Delay between each frame and the delay between the end of the loop and its automatic restart
can also be set. The Enter key must be pressed for changes to be registered.

Animation Control Buttons

The animation buttons to the left of the time slider in the main window are used to launch and
control animation. During animation, each frame’s selected time is shown in the time slider.
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The upper left button is used to step backwards one frame at a time, while the upper right button is
used to step forwards one frame at a time. The lower left button starts animation going backwards
in time, while the lower right button starts animation going forwards in time. The lower center
button starts animation in “ping-pong” mode, alternately going forwards then backwards in time.
When animation is in progress, the upper center button may be used to stop the animation.



How to Select Data Types

Data Layers and the valid times at which data sets are available are shown in the scrollable win-
dow below the time slider in the main window.
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Data Layers are organized into groups. Background Grids are gridded, colored, data sets,
derived from forecast models: temperature, relative humidity, wind speed, icing probability, and
turbulence probability. Data Overlays are icons which can be drawn over grids: wind barbs,
METAR observations, pilot reports, AIRMETs and SIGMETs, and TAFs. Map Overlays are
static topographic grid and line features which give geographic context to the data: topography,
state outlines, country and coast outlines, rivers, roads, and counties. Data Layer groups can be
hidden or expanded by clicking the circle to the left of their name.

Data Layer Visibility

Data Layers are made visible by clicking the checkbox to the left of their name. Only one Back-
ground Grids layer can be visible as a grid at any given time. Turning on a grid automatically
turns off all other grids. Background Grids layers, however, can also be drawn as unfilled con-
tours. See the section on “How to Configure Data Layers” for more information on displaying
contours over a grid. When a Data Layer is visible, the information in the Available Data Sets
area to its right is shown in color. When a Data Layer is not visible, this information is greyed
out.

Available Data Sets

The Available Data Sets area shows the available valid times for each Data Layer. Model-derived
data is represented by a circle below the time at which the data set is valid. Continuously updated
data, such as METARSs and pilot reports, are represented by a single circle with “wings.” The
width of the wings indicates the temporal extent of the available data. For these data sets, only the
most recent reports are available, regardless of the selected time. Static data such as topography
and state outlines are represented by the text Static Data. For Model-derived data, the selected
data set is the latest data set which is valid on or before the currently selected time. This data set is
indicated by a larger circle than for the unselected available data sets. As shown above, some
Data Layers may be showing data sets whose valid times are different than others.

Layer Order Configuration

Data Layers are drawn one on top of another like sheets of acetate. Any information which a
Data Layer draws can obscure information from a Data Layer below it. Generally, gridded data




layers are drawn first, followed by contours and wind barbs, topography, data overlays such as
METARSs, and finally, map overlays such as state boundaries. When a gridded data set is enabled
as a contour, its Data Layer is automatically moved up so that the contours are drawn over any
other gridded data set. In some cases, it may be required to manually change the Data Layer draw-
ing order. Left click the Configure->Layer Order menu item in either the Flight Path Tool or
Vertical Cross Sections window to change the order that data layers are drawn. The Data Layer
Order Manager dialog box will appear. Left click and drag visible data layers up or down in the
list to change the order the layers are drawn. The names of visible layers are drawn in black font,
while the names of invisible layers are greyed out, and layers can be made Visible or Not Visible
by selecting the appropriate button. The inner buttons move the selected layer one step, while the
outer buttons move the layer to the top or bottom.
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How to Configure Data Layers

All Data Layers can be configured to change their appearance, but the attributes which can be
configured may be different depending on the Data Layer. To access a Data Layer’s configuration
dialog, left click the Configure menu at the top of the application, then select the Data Layer
group, and finally, the Data Layer name.
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Data Layer configuration dialogs all have Apply, OK, and Cancel buttons. Apply commits any
changes to the Data Layer configuration and forces it to redraw, but does not close the dialog. OK
commits any changes to the Data Layer configuration, forces it to redraw, and closes the dialog.
Cancel ignores any changes to the Data Layer configuration and closes the dialog. All of the con-
figurations described below require Apply or OK to take effect.

Common Configuration

All Data Layers may be Enabled or Disabled. This is the same functionality as using the check-
boxes in the Data Layers area at the bottom of main window. All Data Layers also have transpar-
ency. Sliding the marker between More and Less alters the Data Layer’s Transparency from
clear to opaque, respectively.

Gridded Data Layers

Gridded Data Layers can be drawn as grids and/or contours. When the Show data as Grid
checkbox is selected, the data are drawn as color-filled polygons. When the Show data as Con-
tours checkbox is selected, data are drawn as contours. Contour Intervals, Colors, and Labels
may all be configured. In order to show contours of one gridded Data Layer over the grid of
another gridded Data Layer, the Fill Contours option must be off.
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Wind Barbs Data Layer

The wind barbs Data Layer allows its Wind Barb Density to be configured. Sliding the marker
between Fewer and More changes the wind barb density from very sparse to extremely dense,
respectively. The midpoint results in barbs which are spaced approximately one barb apart.
Because wind barbs are derived from the gridded windspeed field, there are also controls for
drawing the wind speed as a grid or contours. These controls are identical to enabling the Wind
Speed Data Layer in the Background Grids group.
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METARSs Data Layer

The METARSs Data Layer allows the observed variables to be independently selected, as well as

adjustment of the METAR density
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When no METAR variables are turned on, which is the default, all METAR stations display an
icon. The icon is colored according to the flight category and shaped according to the cloud cover-
age, as documented at:

http://www.aviationweather.gov/adds/metars/description/page no/4|

METAR variables may be toggled on or off by clicking in the checkbox next to their name, or
clicking their title in the key image. The variables for each station are drawn around the station
location as shown below. Tables explaining the weather symbols can be found at:
http://www.aviationweather.gov/static/adds/docs/metars/wxSymbols annol.pdf
http://www.aviationweather.gov/static/adds/docs/metars/wxSymbols anno2.pdf]
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When any variable other than the default cloud coverage/flight category icon is turned on, the
Metar Density is enabled. The Metar Density controls how many METAR stations are shown on
the map using a feature called “progressive disclosure.” Levels of progressive disclosure include
All, More, Default, and Fewer. Under progressive disclosure, more stations are displayed for a
“close-in” zoom than for a “far-out” zoom. The actual number of stations displayed depends on
the prioritized importance of the stations in the current view, how close the stations are to one
another, and the selected Metar Density level, where:

» All means all stations will be shown, and they will most likely overlap.

* More means most stations will be shown, and some may overlap.

» Default means the higher priority stations in the view will be shown, and none will overlap.
* Fewer means only the highest priority stations will be shown, with space between them.

PIREPs Data Layer

The PIREPs Data Layer can be configured to Show Icing reports, Show Turbulence reports, and/
or Show Weather reports. The default is to Show Icing. Reports can fall into more than one cate-
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gory if they contain information about more than one hazard. More information about PIREP
symbols may be found at:

http://www.aviationweather.gov/adds/pireps/description|

The height(s) at which the PIREP was logged and/or any hazards reported may be shown by
enabling the Show Heights checkbox. The heights appear as flight level numbers to the left of the
PIREP symbol. When more than one number appears, the lower one is the minimum height at
which any hazard was reported and the upper one is the maximum height. In some cases, the
height range may not correspond to the hazard identified by the PIREP symbol.

The number of PIREPs shown may be limited by using the altitude sliders. By default, PIREPs at
all altitudes are shown. To limit the display to PIREPs between certain altitudes, drag the yellow



http://www.aviationweather.gov/adds/pireps/description

sliders at the top and bottom of the altitude slider to define a new altitude range. The entire range
may also be moved by dragging its dark grey center.
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AIR/SIGMETs Data Layer

The AIRMET and SIGMET Data Layer may be configured to show certain types of warnings. By
default, all warnings are displayed. Clicking the checkbox next to their name toggles individual
warning types off or on. The entire group of Airmets or Sigmets may also be toggled off or on



by clicking the checkbox next to the group title. The flight levels between which the warnings
apply may be displayed by toggling the Show Heights checkbox. It is off by default.
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Topography Data Layer

There are 4 different resolutions of the static topography data in the Flight Path Tool. By default,
the Skm resolution is selected. In order to match the topography grid cells exactly to a model grid,
it may be desirable to change topography to one of the other resolutions. Only one of the resolu-

tions may be visible at a given time.

When enabled, the topography is drawn in shades of brown, intersecting the model data according
to the selected altitude. The shade of brown indicates the topographic height at each cell, with the
darkest browns used for low elevations and the lightest browns used for the highest elevations.
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How to Create a Flight Path
Creating a Flight Path

1. % Left click the airplane button to begin a flight path.

2. Using the mouse, place the cursor, which is now an airplane, on/near the desired departure air-
port and click the left mouse button to begin a new path.

3. Left click once on/near all en-route airport(s) to continue the route. A line will appear con-
necting the points where you have clicked.

4. Upon reaching the final destination, double-click on/near the destination airport. This double-
click action ends the path and the program requests the data from the server and creates a new
window called Vertical Cross Sections. This process may take a few seconds.
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Navigating the Vertical Cross Sections Window

The window that “pops up” after a flight route has been created is called Vertical Cross Sections.
Once a path has been created, it is stored in the tool’s history. All paths created in a session or
saved in a configuration file can be accessed by selecting the View -> History menu item in the
Vertical Cross Sections window. There is also a list of “classic” paths that can be selected from
the View->Classics menu item.

Exporting and Printing

The File->Export Image menu item can be used to save either the image in the main Flight Path
Tool window, or a Vertical Cross Section as a png file on your local hard drive. The images can
be printed by selecting File->Print Image and following the instructions in the subsequent dialog
box.

Saving a Path in a Configuration File

Save flight paths and their Vertical Cross Sections, by saving a configuration file. Left click on
File->Save as... in the Flight Path Tool window and the Configuration Manager dialog box will
appear. Left click on the arrow in the drop down box and slect Other... to open a file browser and
specify the name and location on the local hard disk for the new configuration file. When the
saved configuration file is loaded during subsequent sessions, the data will be current, with the
saved routes available via the View->History menu in the Vertical Cross Sections window.
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