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Logging-on to the System and Creating an Account 
 

From the Faculty Profile System (FPS) home page, https://faculty.unt.edu/ ,log 

on using your existing University EUID and password.  Logging on will automatically 

establish your account, create your profile and bring you to the profile creation page, “My 

Profiles”.   

On this page you will note that next to your name a red “light” labeled Inactive will 

be displayed.  To the right of that label will be a hyperlink, Edit, that will take you to your 

profile’s data entry screen.  Click on Edit. 

 
* Please note this process step does not create a public view of your profile.  In order to make your profile 
viewable to the community you must first “activate” your account through a process to be discussed later. 
 
**The FPS architecture has been designed on a structure that requires screen resolutions of 1280x1024 
or better.  At lower resolutions left-hand page displays may be truncated, particularly “Start Date” and 
“End Date” Text Boxes.  Prior to logging on to the FPS and your profile data entry page verify your PC’s 
display setting through your desktop’s control panel. 
 

Edit Profile Screens 

 
On the Edit Profile page you will note a grey menu bar with four embedded links; 

Home, Browse, Search and Support.  Activating anyone of these links will take you to 

the labeled system page.  Doing so will also exit you from the profile creation pages and 

require you to re-login to return to the “My Profiles” page. 

 Below the menu bar, three profile management tabs will be displayed; Edit, View 

and ToolBox.   

The Edit tab will always be your default on start up.  The Edit page is the primary 

data entry interface and provides direct access to each of the 26 available profile 

modules.  Many of the profile modules are discipline specific and may not be applicable 

to your academic and professional situation.  That’s OK.  The system will allow you to 

input and publish only those modules you personally choose to display.  You also have 

the ability to populate any particular profile module with data but hide it’s content from 

public view. 

The View tab provides a display of your profile as it will be seen by other users of 

the system.  Using the View tab allows you to see what the published version of your 

profile will look like without leaving the profile editing mode and the necessity of a re-

login. 

https://faculty.unt.edu/�


Faculty Profile System – User’s Desk Guide 
 

 

Office of Institutional Research & Effectiveness 
University of North Texas, Denton, Texas                             2 
 

Clicking on the ToolBox tab provides access to three personal profile 

management process; Profile Settings, Profiles to Disciplines and Biosketches & Vitas.  

The FPS has been conceptualized and designed for future expandability and display 

detail, however, at present only the Profile Settings hyperlink is operational and has 

been established as the default page within the section.   

The Profile Settings page supports three processes; first, it supports the profile 

activation process mentioned earlier; secondly it allow you to control what system 

modules, populated or empty, are displayed on your published profile; and thirdly to 

create one or more custom modules. 

Return to the Edit tab to begin creating your FPS profile.  Remember, you will 

have to return to the ToolBox tab to activate your populated FPS modules so that it is 

viewable to the community. 

 

Creating Your FPS Profile 
 

 All personal profile data entry is accomplished within the Edit tab.  There are two 

primary data entry points; Contact Information and system modules.  While populating 

any of the 26 system modules is optional, Contact Information is a required entry.  Data 

entry methodologies vary in number and type between the various modules; however, 

there are some core process protocols common to each data entry point. 

 In every case, access to the data entry interface is located on the right-hand side 

of the page.  Except for the Contact Information interface, which is a required entry, 

three processes are presented; Help, Delete and Add.  The Contact Information 

interface only offers an Edit option with the expectation that the “Text Box” data entry 

interface is self-explanatory and the required nature of the entry makes the addition of 

Help, Delete and Add features moot.   

 Within an individual module’s input page interface, data entry methodologies may 

differ based upon the type of information to be conveyed.  However, each module’s page 

management process will be identical, based on the Help, Delete, and Add tools.  

  

• Help – Clicking on the Help hyperlink opens a new browser window and brings to 

the top of the page a description of the intended propose of module and a link to 

a “pop-up” of a completed example of a given module’s data entry page. 
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• Delete – Clicking on the Delete hyperlink will clear all inputted data within a given 

module’s data entry fields.  A “pop-up” will appear requiring a confirmation to 

proceed.  Data will be irretrievable once confirmed. 
 

• Add – Clicking on Add will open a particular module’s data entry interface.  While 

the input methodology will differ between modules, each interface will initially 

display two page management processes; Save and Cancel.  Data entries are 

not automatically save upon exit.  The Save hyperlink must be clicked after each 

data entry session to preserve inputted values to your profile table.  The Cancel 

hyperlink allows you to clear inputted data from within the module’s data input 

interface.  These functions are applicable to both the Contact Information and 

system module interfaces.  Once data has been inputted into the interface a third 

page management process will become available, Hide.  The Hide page 

management process allows the user to enter as many data entries within his or 

her profile while controlling what is viewable on the published page. 
 

Data Entry Methodologies 
 

 A data entry methodology matrix is provided at Appendix A.  The “Faculty Profile 

System Data Input Methodologies by Program Module” matrix displays program module 

titles, descriptions of the data input methodologies, and an explanation of the exceptions 

or special instructions for use of the named data input methodology within a particular 

module title.  This document can also be used as a checklist when troubleshooting data 

input errors. 

 

• Text Box – The Text Box is used within all profile modules.  Available input 

capacity is fixed and sized to ensure standardization of all profiles within the 

FPS.  Entries of characters in excess of the defined parameters will be truncated.  

Text Boxes are generally employed within the system to provide a single, specific 

data item.  Details and/or amplifying information should be entered within a Text 

Editor interface when provided.   
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Text Boxes are used throughout the FPS to gather “date” data and are 

programmed as a special case data entry items.  Dates are always required 

fields.  For those profile modules displaying a span of time, “Start Date” and “End 

Date” Text Boxes are provided in tandem.  In cases where the span of time 

occurs within a single year or less, leave the “Start Date” blank and enter your 

“year” data in the “End Date” Box.  All date entries must include four characters 

in a YYYY format. 

 

• Text Editor – A Text Editor input interface offers an almost unlimited character 

capture capability as well as relatively “rich” data display options such as custom 

fonts, text line orientation, bulleting and indenting found in most simple word-

processing systems.  The Text Editor also allows for the insertion of hyperlinks, 

images, and tables.  Hyperlinks and tables are inserted at the cursor point 

through a “pop-up” dialog Box activated when the menu item is clicked.   

 

Images must be first upload to your profile using the Image “Browse” explorer 

feature.   

 

 
      

 

First, provide a brief descriptive title of the page in the “Name” Text Box.  This is 

a required step.  Next, click on the “Browse” button to open the file system 

explorer window.  Double click on the image file you would like to upload; its 

address should appear in the “Image” Text Box.  Once the image address is 

displayed in the “Image” Text Box place your cursor at the desired entry point 
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and then click on the page management element, Save.  You will be 

automatically taken to the View tab page where your image should be visable as 

it will be seen when published.  

 

To remove an image, place a check in the “Remove”  Check Box and click on the 

page management element, Save.  As with image inserting, you will 

automatically be taken to the View tab page where you will be able to see your 

updated content. 

 

The Text Editor  is more than a wordprocessor, it is in fact a What You  See Is 

What You Get (WYSIWYG) Hypertext Markup Language (HTML) code 

generator.  For additional capability and display flexibility users familiar with 

HTML have the option of coding directly to the page  by placing a check in the 

“View Source” Check Box.  To insert more than one image within a single Text 

Editor interface will require individual HTML coding through the “View Source” 

option.  

 

• Check Box – This data input method is common throughout the 26 profile 

module edit interfaces and allows for a simple on/off “switch” for specific page 

content.  There are often multiple Check Boxes grouped within a single profile 

module’s data input interface.   

 
 

All Check Boxes are view by the system independently and are not required 

entries.  For all profile module data input interfaces the default setting for a 

Check Box is blank or “off”. 

 

• Radio Button – Like the Check Box, Radio Buttons serve as a simple on/off 

switch, however, an empty entry is not accepted.   
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By design a Radio Button is always a required entry, a choice must be made 

between the given options. 

 

• Drop Down Menu – Many profile module data input interfaces employ one or 

more Drop Down Menus.  Drop Down Menus are also required entries by design. 

Within the FPS Drop Down Menus will usually default to “Other”.   

 
 
Input of data must be drawn from the available items provided by the menu.  

User must determine a closest fit from the list, no mechanism for custom input of 

Drop Down Menu variables is available through this data input methodology.  

The “Other” option can be used and explained through the use of the associated 

Text Editor.  
 

Trouble Shooting 
 

Along with this desk guide and the Faculty Profile System Data Input Methodologies by 

Program Module matrix ,FPS administrators have developed a collection of Frequently 

Asked Questions (FAQ) associated with FPS profile creation.  This feature is available 

as a link on the FPS homepage as well as by request by sending an email to 

IRDept@unt.edu.  In some instances your questions maybe unique to your particular 

professional situation or hardware/software configuration.  Personalized assistance is 

available during regular business hours by calling the Office of Institutional Research at 

940.565.2085.

mailto:IRDept@unt.edu�
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Appendix A. 

 

Faculty Profile System Data Input Methodologies by Program Module 
 

Program Module Data  Input Interface Type(s) Data Input Interface Special Characteristics 
Contact Information Text Box , Image Browser  Standalone Image Browser – Ability to insert a single image, 

usually a photograph of one’s self. 
Professional Preparation Text Box , Check Box Standard input for methodology for interface type. 
Research and Expertise Text Box, Text Editor w/ Image 

Browser, Check Box 
 “Name” is a required field to save and publish the page. 

Appointments Text Box , Check Box Standard input for methodology for interface type. 
Publications Text Box, Text Editor w/o Image 

Browser, Check Box, Drop Down, 
Radio Button 

Limited Capability Text Editor – Allows for unrestricted character 
entries but only limited display features. 

Editorships Text Box , Check Box Date Spanning Feature – Date, in YYYY format, must be entered in 
at least the “End Date” Text Box. 

Performances Text Box , Check Box Standard input for methodology for interface type. 
Exhibitions Text Box , Check Box Standard input for methodology for interface type. 
Major Work in Collections Text Box , Check Box Standard input for methodology for interface type. 
Lectures/Symposia Text Box , Check Box Standard input for methodology for interface type. 
Patents Text Box , Check Box Standard input for methodology for interface type. 
News Articles Text Box, Text Editor w/ Image 

Browser, Check Box 
“Title” is a required field to save and publish the page. 

Presentation and Projects Text Box, Text Editor w/ Image 
Browser, Check Box 

Date Spanning Feature – Date, in YYYY format, must be entered in 
at least the “End Date” Text Box. 
 
 “Name” is a required field to save and publish the page. 

Consulting Activities Text Box , Check Box Date Spanning Feature – Date, in YYYY format, must be entered in 
at least the “End Date” Text Box. 

Peer Reviewer Activities Text Box , Check Box Standard input for methodology for interface type. 
Affiliations Text Box , Drop Down Standard input for methodology for interface type. 
Teaching Text Box, Text Editor w/ Image 

Browser, Check Box 
 “Name” (course name) is a required field to save and publish the 
page. 

Mentoring/Advising Text Box , Drop Down Date Spanning Feature – Date, in YYYY format, must be entered in 
at least the “End Date” Text Box. 

Committees Text Box , Check Box Date Spanning Feature – Date, in YYYY format, must be entered in 
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at least the “End Date” Text Box. 
 

Program Module Data  Input Interface Type(s) Data Input Interface Characteristics 
Memberships Text Box , Check Box Date Spanning Feature – Date, in YYYY format, must be entered in 

at least the “End Date” Text Box. 
Honors and Recognitions Text Box , Check Box Standard input for methodology for interface type. 
Field Experience Text Box , Check Box Date Spanning Feature – Date, in YYYY format, must be entered in 

at least the “End Date” Text Box. 
Professional Community Engagement Text Box , Check Box Standard input for methodology for interface type. 
Renowned Teachers Text Box, Text Editor w/ Image 

Browser, Check Box 
 “Name” is a required field to save and publish the page. 

Selected Bibliography Text Box , Check Box Standard input for methodology for interface type. 
Short Biography Text Box, Text Editor w/ Image 

Browser, Check Box 
 “Name” is a required field to save and publish the page. 

 

 

 

 


