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Introduction

Welcome to Adobe Systems Incorporated’s “Creating Accessible Adobe® PDF Files: A Guide for Document Authors.” 
This is a step-by-step guide that covers the basics for creating and optimizing Adobe Portable Document Format 
(PDF) files so that they can be made more accessible to users with disabilities such as blindness or low vision. 

This guide provides information on using Adobe Acrobat® 6.0 software and Adobe Acrobat Capture® 3.0 software 
to optimize documents for distribution as PDF documents that can be easily read with the aid of Microsoft® 
Windows® based assistive technology, such as screen magnification or screen reading software. 

For more information on reading accessible PDF documents with assistive technology, consult the companion 
booklet to this one: “Reading PDF Documents with Adobe Reader 6.0, A Guide for People with Disabilities.”

Adobe PDF and accessibility

PDF is a standard on the World Wide Web and is also used to distribute electronic documents over corporate 
networks, by e-mail, and on digital media. Users of Adobe Acrobat software can turn virtually any electronic 
document or scanned image into a PDF file. These files can then be read by anyone using free Adobe® Reader® 6.0 
software. Many corporations, educational institutions, and government agencies use PDF to distribute documents 
to the public or to groups in their organizations. PDF is also the basis for new processes; its support for accessible 
electronic forms, digital signatures, password security, and electronic mark-ups make PDF the ideal platform for 
converting yesterday’s paper-based business processes to interactive digital processes.

Adobe is committed to providing solutions that improve the accessibility of both Adobe Acrobat software and the 
information contained in Adobe PDF files. In 1997, Adobe introduced the Access.Adobe website 
(http://access.adobe.com). In 2001, Adobe enhanced the PDF specification to allow the creation of “tagged” PDF 
files in Adobe Acrobat software. Tagging a PDF file makes significant improvements to the accessibility of the 
document, providing a mechanism to indicate the precise reading order and improve navigation, particularly for 
longer, more complex documents. It is possible to add alternate text descriptions (alt text) to graphics appearing in 
tagged PDF documents. Tagging PDF files enables content reflow for large type display without content disappearing 
from the edges of documents. Tagging also allows PDF files to be presented on smaller devices, such as personal 
digital assistants (PDAs) and cellular phones.

Does making PDF documents accessible affect their appearance? 

Tagging a PDF document for accessibility does not affect its look or visual integrity. The logical structure tree, or tags 
tree containing the information used by assistive technology, is an underlying interpretation of structural elements 
found in the visual representation of a PDF document. 

One of the strengths of tagging is that the tags tree can be rearranged so the document is more readable to those who 
have difficulty accessing the visual document. Tags provide a mechanism for adding alt text to images and links, 
which makes it easier for readers to navigate and understand a document. Table headings can be identified so that 
people using assistive technology can relate information in a table to a column title instead of having information 
read to them randomly.

For more information, see “Tagged PDF” on page 14.
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How to use this guide 

This guide was created for users who are familiar with the different applications described. For more detail on each 
application and feature, please refer to the product user guides.

The guide is organized by document type. For example, if you need information on converting Microsoft Office 
documents to accessible PDF documents, you can find this information in section two. 

The following table is an overview of the topics, tools and sections in this guide that contain information on making 
PDF documents accessible based on specific document types.

To do this Use this tool Section

Checking and testing PDF documents for accessibility Use either:

• Adobe Acrobat 6.0 Standard

• Adobe Acrobat 6.0 Professional

Section one

Accessibility basics Use either:

• Adobe Acrobat 6.0 Standard

• Adobe Acrobat 6.0 Professional

Section two

Creating accessible PDF documents from Adobe InDe-
sign®

Adobe InDesign 2.0 or later Section three

Creating accessible PDF documents from Adobe 
FrameMaker®

Adobe FrameMaker 7.0 or later Section three

Creating accessible PDF documents from Adobe Page-
Maker®

Adobe PageMaker 7.0 or later Section three

Creating accessible PDF documents from Microsoft 
Office applications

• Microsoft Office 2000 or later

• Adobe Acrobat 6.0 Standard

• Adobe Acrobat 6.0 Professional

Section three

Creating accessible PDF documents from existing PDF 
documents

Adobe Acrobat Professional 6.0 Section four

Creating accessible PDF documents from scanned doc-
uments

Use either:

• Paper Capture (Acrobat 6.0 Professional or Acrobat 
6.0 Standard)

• Adobe Acrobat Capture 3.0 and Adobe Capture 
Agent Pack

Section five

Creating accessible PDF forms • Adobe Acrobat 6.0 Professional Section six

Creating accessible PDF forms • Adobe Acrobat 6.0 Professional

• Adobe PDF Forms Access (a standalone utility bun-
dled in the Adobe Capture Agent Pack)

Section six

Optimizing the accessibility of PDF documents Adobe Acrobat 6.0 Professional Section seven

Manipulating tagged PDF structural elements Adobe Acrobat 6.0 Professional Section eight
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Section One: Checking PDF Documents for 
Accessibility

Check PDF documents for accessibility as part of the PDF document creation process before distributing them to 
users. The checking feature examines the PDF document to determine if it has the necessary information to make it 
accessible. The items checked include alt text for figures, specified languages for text, reliable character encodings, 
and the logical structure tree that references all of the document contents.

The following types of documents often have PDF accessibility problems:

• Documents that contain only scanned images of text and no text available to assistive technologies such as screen 
readers

• Documents that don’t contain tags because the author used an older version of Acrobat that did not support 
tagging, doesn’t know how to use the tools provided, or is using non-Adobe tools for creating PDF

• PDF documents that are forms without fillable fields. Fillable fields allow users to complete forms online. Without 
fillable fields added to PDF forms, users must first print a form to complete it in handwriting or by using a 
typewriter.

• PDF documents that don’t provide alt text on images or hyperlinks. Alt text on images provides information about 
images and why they have been placed in a document. Alt text on hyperlinks provides text-based navigation to 
links. For example, using the word “search,” instead of the actual Web address, provides better navigational infor-
mation.

Quick Check (Acrobat 6.0 Professional, Acrobat 6.0 Standard, and Adobe Reader 6.0)

An accessibility Quick Check can be performed in Acrobat 6.0 Professional, Acrobat 6.0 Standard, and Adobe Reader 
6.0. Quick Check quickly analyzes a document and reports any issues it finds. The result of a Quick Check is a 
message containing information on document accessibility.

Acrobat 6.0 Professional can provide a more complete check for accessibility. The result of a Full Check is a detailed 
report identifying inaccessible tag elements and other accessibility problems. You can view the tags with their 
associated content, add alt text to images or links, and repair the tags tree.

To perform an accessibility Quick Check, do one of the following:

• In Acrobat 6.0 Professional and Acrobat 6.0 Standard, choose Advanced > Accessibility > Quick Check. 

• In Acrobat Reader 6.0, choose Document > Quick Check.
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A message box reporting no accessibility issues in a PDF document

 
A message box reporting inaccessible elements of a PDF document

Full Check (Adobe Acrobat 6.0 Professional)

In Acrobat 6.0 Professional, you can perform an accessibility Full Check in addition to an accessibility Quick Check.

Full Check lets you create accessibility reports. Once Full Check is activated, you can make choices about the kinds 
of accessibility issues you look for in a PDF document.

Note that checking for accessibility might report problems with elements in a tagged Adobe PDF file that you may 
be able to ignore. For example, Full Check might report that some images in the file do not have alt text; if these 
images are just decorative page borders, however, they are unnecessary for someone with a vision impairment and 
do not require alt text. Similarly, the accessibility checker might report that a running header is not part of the tags 
tree. You can leave the running header as-is, or modify it to be an artifact because this information does not need to 
be vocalized by a screen reader.

Note: An accessibility Full Check can be time-consuming; stop the process by pressing the Escape key.

To analyze the tagging in a PDF document by using the accessibility Full Check:

1  Choose Advanced > Accessibility > Full Check. 

2  Select Create Accessibility Report, and choose a location for the report.

3  Select Create Comments In Document if you want to see the accessibility issues identified with comments in the 
document so that the problems appear in context.

Note: Delete these comments from the document after they’ve been addressed.

4  Specify the pages you want included in the accessibility check. 

5  Select the Checking Options that you want.
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6  Click Start Checking. 

7  Open the accessibility report that you created. It is a Hypertext Markup Language (HTML) file with the same 
name as the document.

8  Select and open the HTML file. A frame on the left side of the browser contains the identified inaccessible 
elements; the PDF document is on the right. 

9  In the document on the left, select a link that identifies an inaccessible element. The associated content is 
highlighted in the document on the right. Although you can review generated comments in the browser, you must 
open the original tagged PDF document in Acrobat 6.0 Professional to repair accessibility problems.

The Accessibility Full Check options dialog box
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An Accessibility Full Check report in a browser
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In the screen shot below, an image was identified as missing alt text. As you review accessibility reports, you must 
decide whether or not an element needs to be tagged for comprehension, understanding, knowledge, or consistency. 

 
Highlighted content in a Full Check Accessibility Checker Report

Viewing comments created by Full Check

You can also create and view comments on accessibility issues. Do this by selecting the Create Comments In 
Document option in the Accessibility Full Check dialog box.

Selecting this option identifies the comments in the PDF document by putting a frame around suspect areas. 
Comment details appear when the mouse is positioned over an area. If you select this option, you do not need to 
open the HTML-based report.

To have comments automatically appear, do one of the following:

• Choose Edit > Preferences > Commenting, and then select Automatically Open Pop-ups On Mouse Rollover.
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A PDF document showing comments that identify accessibility issues

• Select the Comments tab on the left side of the window. This opens the Comments List in the lower half of the 
window.
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A PDF document with the Comments List showing in the bottom half of the window

Delete comments from the PDF document after the accessibility issues have been repaired.

To delete all comments, do one of the following:

• With the cursor in the Comments List, choose Edit > Select All, and then press the Delete key.

• Press Ctrl + A (Windows) or Command + A (Mac OS) to Select All, and then press the Delete key.

Locating content and tags (Acrobat 6.0 Professional)

It is not always easy to determine what elements in a tags tree are related to content or text in a document. You can 
view the association between elements displayed in the tags tree and the actual page content. 

To view content associated with a tag:

1  Click on the Tags tab in the Navigation pane, or choose View > Navigation Tabs > Tags.

2  Choose Highlight Content from the Options menu on the Tags tab.

3  Open the tags tree in the Tags tab and select a tag element. The content associated with the selected tag is 
highlighted in the document by a bounding box.

You can also find tags in the tags tree by selecting content and viewing the corresponding tag.
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To find a tag for selected content: 

1  Use the Select Text tool or TouchUp Text tool to select content within the document.

2  Click on the Tags tab in the Navigation pane, or choose View > Navigation Tabs > Tags.

3  Choose Find Tag From Selection from the Options menu on the Tags tab. You may have to scroll through the tags 
tree to find the highlighted element tag associated with the selection.

Checking the reflow order of a document
One way to check the order of elements in a document is to reflow the document using the Reflow tool. The tagged 
PDF document is reflowed one page at a time in the document window. Documents can’t be saved in a reflowed state. 

If the reflowed document exhibits unexpected results, it may indicate a problem in the reading order. Locate the 
problem area in the tags tree to determine how to improve the structure, or if there is another problem, such as an 
element that needs to be changed to an artifact to remove it from the reading order. (See “Section Seven: Manipu-
lating Tagged PDF Structural Elements” on page 72.) For more information on fixing reflow problems, access 
Acrobat 6.0 Online Help.

To reflow a tagged PDF document, do one of the following:

• Choose View > Reflow. 

• Press Ctrl + 4 (Windows) or Command + 4 (Mac OS).

Once you have reviewed a document, you can return it to its normal viewing state.

To view the tagged PDF document in its original state, do one of the following:

• Click the Actual Size button, the Fit In Window button, or the Fit Width button in the toolbar.

• Choose View > Fit Page, View > Actual Size, View > Fit Width, or View > Fit Visible.

• Press Ctrl + 0 for Fit Page, Ctrl + 1 for Actual Size, Ctrl + 2 for Fit Width, or Ctrl + 3 for Fit Visible (Windows).

• Press Command + 0 for Fit Page, Command + 1 for Actual Size, Command + 2 for Fit Width, or Command + 3 
for Fit Visible (Mac OS).

Additional accessibility tests
The final step in creating an accessible PDF document is to access the document using available accessibility tools.

To test a PDF document for accessibility, do any of the following:

• Check the logical reading order: Click on the Tags tab in the Navigation pane, or choose View > Navigation Tabs 
> Tags. Choose Highlight Content from the Options menu on the Tags tab. Select the tags in descending order, 
and expand tags with a plus sign (+) by using the right arrow key when keyboard focus is on the tag, or by clicking 
the plus sign. This lets you see the tags’ reading order and their corresponding highlighted content. 

• Save a document as Text (Accessible) to visually confirm the reading order.

• Choose View > Read Out Loud to confirm the reading order using Read Out Loud.

• Use a screen reader to read the document.
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Section Two: Accessibility Basics

Publishing accessible content in HTML, PDF, or other format requires more than just accurately representing the 
original document. Sighted people can look at a printed page and easily discern differences among titles, subtitles, 
columns of text, headers, footers, and so on. Visual clues, such as location of the text on a page, bold text, and large 
font sizes, help sighted people determine the structure of a document so that they can easily read and navigate it.

Although this guide uses screen readers as an example of assistive technology that aids individuals who are blind or 
visually disabled, other disabilities may require the use of a different assistive technology:

Low vision/visual impairment  Screen magnification software magnifies the information on the screen and provides 
auditory feedback. 

Blindness Screen reading software provides auditory feedback for all elements in the operating system and applica-
tions. People who are blind, or deaf and blind, can also use refreshable Braille displays to interact with their 
computers.

Cognitive or learning disabilities  Text-to-Speech (TTS) software provides auditory feedback for content. Users with 
cognitive or learning disabilities may also require larger fonts or highlighted text in synchronization with auditory 
feedback to isolate individual words or phrases.

Mobility Impairments Alternate input devices, such as on-screen keyboards or voice recognition software, help users 
navigate the computer’s operating system and applications.

Note: Screen reading software provides feedback on essential computer activities, menu bars, dialog and message boxes, 
as well as content; TTS provides feedback on only the document content.

Creating accessible content

Although software tools that check for accessibility and create more accessible output make it easier for the author, 
authors continue to play the most important role in creating accessible documents. In addition to the traditional 
editorial issues of content accuracy, spelling, grammar, artwork, and formatting, authors need to think about acces-
sibility.

Authors of digital documents planning for the evolution of technology also need to be aware of formatting conven-
tions used by native applications. Typically, this means authors need to use styling conventions available in word 
processing and desktop publishing applications. This method is preferable to using character formatting conventions 
to convey structural information. Refrain from using bolded text with modified font sizes to indicate a paragraph 
heading, for example, and instead apply a style, such as Heading 1, to achieve the same effect. This approach enables 
planning for future accessibility.
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A document containing both content and structure 
A. Logos B. Titles C. Chapters D. Table data E. Scanned images F. URLs G. Columns

To improve accessibility of PDF documents: 

• Define structure such as headers and columns. 

• Add navigation and explanatory information.

To make documents more accessible and readable for people using assistive technology, include the following 
techniques:

• Use styles to indicate the logical order of document elements such as headings, tables, and form fields.

• Rely on multiple formatting conventions to indicate emphasis, for example: combine color with boldface type or 
underlining.

• Provide alt text for graphical elements.

• Use applications that produce accessible content.

To improve the accessibility of PDF documents, applications should: 

• Retain and encode both content and structure. 

• Effectively deliver the information to assistive technology. 

• Provide useful tools to help optimize documents. 

• Be usable by people with disabilities. 

• Assist in the conversion of legacy files. 

Creating accessible content and documents is a team effort.

E

DA

B

C

GF
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Elements of accessible PDF documents

Authors of PDF documents should be aware of enhancements they can make to optimize the document’s accessi-
bility. 

Reading order  For a screen reader or TTS software to effectively read information on a page, a logical structure must 
be provided to help assistive technology determine the order in which the text on the page is meant to be read. This 
order can be ambiguous in the case of multi-column text, sidebars, pulled quotes inserted in the middle of or 
between columns, tables, and so on. Tagging the various blocks of text and other page layout elements in tagged 
Adobe PDF documents provides a means of supplying this structure and defining the intended reading order of the 
page.

Alt text for images  Graphic representations, such as illustrations, drawings, charts, and graphs, cannot be inter-
preted by a screen reader. By supplying alt text for images, people with visual or learning disabilities have improved 
access to the information the image is meant to impart. Alt text functions as an alternative for an image, communi-
cating its purpose for people who cannot see the document but must rely on an alternate sense, such as hearing or 
touch, to read the document. 

Alt text for links  By including alt text for links, people using screen readers will hear “go to Access Adobe.com” 
instead of “http://access.adobe.com,” or “Acrobat accessibility” instead of 
“http://www.adobe.com/products/acrobat/solutionsacc.html.”

Bookmarks The document should include useful links and other interactive content, such as bookmarks, so that 
users can go directly to the section they want. 

Navigation The document should include navigational and organization aids, such as a table of contents and useful 
headings. These aids provide an easy way for users to move through the document so they don’t have to read the 
entire document page by page to find the information they need. 

Document language  Although current screen readers are designed to read the document according to a specific 
language, specifying the document language in the structure can benefit future screen reader technologies that may 
be able to change languages on the fly. In addition, the Adobe Accessibility Checker indicates an error if you do not 
specify a document language.

Image-only documents  Authors can scan a printed page to create a PDF document. These documents are inherently 
inaccessible because the end result is an image, not text that can be tagged into a logical document structure or 
reading order.

Two tools are available from Adobe to assist in converting scanned image-only documents into accessible PDF 
documents:

• Adobe Capture 3.0 and the Adobe Capture Agent Pack, which contains the Adobe Tag Agent and PDF Forms 
Access Agent

• Paper Capture, a built-in tool in Acrobat 6.0 Professional and Acrobat 6.0 Standard

A. Scanned text B. Text entered by the author using a keyboard

BA
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Security Features One of the advantages of PDF is document integrity and security features. The security settings 
for Adobe PDF documents include the option to Enable Text Access For Screen Reader Devices For The Visually 
Impaired. Choose Document > Security > Restrict Opening and Editing. From the Password Security Settings dialog 
box, you can choose to disallow printing, copying, extracting, commenting, or editing. Note that the availability of 
this setting depends on the type of encryption chosen. To allow screen reader access to a tagged PDF document, select 
Enable Text Access For Screen Reader Devices For The Visually Impaired. This option is selected by default.

PDF forms  One of the more popular uses of PDF documents is the distribution of forms. Using Acrobat 6.0 Profes-
sional, you can make forms accessible online by adding form fields with Tooltips to PDF forms. If forms don’t include 
form fields, users must print PDF forms and complete them by hand or on a typewriter. Adding Tooltips to form 
fields provides an audio cue for users of screen readers. Users hear “First name” when tabbing to the field where a 
first name should be entered, for example. Tooltips should be as terse as possible, and should be descriptive rather 
than declarative; they should never contain instructions such as “Enter...”

 
An example of accessible form design

Tagged PDF
Adobe Acrobat 6.0 Professional or Adobe Acrobat 6.0 Standard software lets you create Adobe PDF files that contain 
logical document structures. Logical structure refers to the organization of a document, such as the title page, 
chapters, sections, and subsections. The logical structure can indicate the precise reading order, and improve 
navigation, particularly for longer, more complex documents. For people who are not able to see or decode the visual 
appearance of documents, assistive technology can provide document content by accessing the document structures 
and their associated content.

Most assistive technology looks for the underlying structure of a document and depends on that structure to convey 
meaning in an alternative format. For visually impaired users, an alternative format conveys the meaning of the 
content and images on the computer screen through sound.
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When presenting an untagged PDF document to assistive technology, Adobe Reader and Acrobat attempt to 
construct tags on the fly, using one of the reading order choices. Because this is difficult to do reliably, assistive 
technology may be presented with erroneous information because of incorrect structure inferences, items may not 
be conveyed in their logical reading order, or items may not be read at all. 

Thinking about and applying logical structure to documents also assists people who visually access the information. 
It is easier to follow the flow of the text, ideas, and other information when a logical structure is applied.

In an untagged PDF document, only the appearance of the document is represented inside the PDF file. In a tagged 
PDF document, information about the reading order, flow, and organizational structure is also included. This extra 
information allows readers using assistive technology to access the content of the document reliably beyond the 
graphical appearance of the pages.

Tag information in a document is organized into a hierarchical tree structure. The tag tree is displayed as a parent-
child tree. You can expand or collapse the information under tags by clicking the plus sign (+) or the minus sign (-) 
next to the tag. (The keyboard shortcut is to use the Left Arrow key to collapse, or the Right Arrow key to expand, 
when focus is on the tree item.)

A tags tree of a document containing parent and child elements. Once a parent element is expanded to reveal child elements, the (+) becomes a 
(-) in the tags tree.

With HTML, <H1> tags indicate first level headings, <P> tags indicate paragraphs, and <Table> tags indicate tables. 
In word processors, authors apply heading, paragraph, and other styles in a similar way. Each piece of a document 
has a style assigned to it that can function as its tag.

In PDF documents, adding tags results in a similar view. When you view the tags, you see elements such as <H1>, 
<P>, or <Table>. Each element of an Adobe PDF file can be tagged.
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For detailed information on the standard tag elements of tagged Adobe PDF documents, see “Appendix D: Adobe 
Standard Elements” on page 81.

Logical document structure (tags tree)

When a PDF document is tagged, a relationship is established between the document’s elements and an order or 
structure for those elements.

The tags root is the parent, and the structural elements are children. The tags root remains the “common ancestor” 
for all tags, but subsequent tags can have child tags of their own. These are specific relationships among elements. 

For more information on accessible tagged PDF, visit http://access.adobe.com.

Viewing the tags tree

You can easily view the logical document structure or tags tree. The tags tree is found in the Tags tab of the Navigation 
pane.

To view the tags tree of a PDF document, do one of the following:

• Choose View > Navigation Tabs > Tags.

• On a Windows system, choose Alt + V for View, N for Navigation, then G for Tags. There is no Mac OS equivalent 
for this command.

• Click on the Tags tab in the Navigation pane.

To dock the Content, Tags, and Fields tabs in the Navigation pane:

• Drag individual tabs to the Navigation pane.

• Choose View > Navigation Tabs > Dock All Tabs to move all floating tabs to the Navigation pane.



17

 How To Guide

Section Three: Accessible PDF documents 
from Native Applications

Authors of digital documents planning for the evolution of technology need to be aware of structural formatting 
conventions used by native applications. Use structural styling conventions available in word processing and desktop 
publishing applications. Outline and heading structures are preferable to character formatting conventions to 
convey structural information. Refrain from using bolded text with modified font sizes to indicate a paragraph 
heading; you can apply a structural style, such as Heading 1, to achieve the same effect. This approach enables current 
accessibility features and assists in planning for future accessibility.

This section addresses creating accessible PDF documents using Adobe InDesign, Adobe FrameMaker, Adobe 
PageMaker, and Microsoft Office applications.
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Creating accessible PDF documents using Adobe InDesign
To complete these tasks, you need Adobe InDesign 2.0 or later.

Using workflows

You can use practices and techniques in InDesign to control the logical flow of generated PDF documents. Given this 
basic background information, you can minimize, if not eliminate, the amount of post-PDF processing required to 
accurately produce an accessible PDF document. Post-processing changes to the PDF tag structure cannot be saved 
and must be manually reapplied each time the original document is converted. 

Problem areas may increase with the complexity of the document. Decide the relevance of certain visual embellish-
ments, and consider ways to provide meaningful alternate descriptive text for graphics. 

To a great extent, the workflow is a develop-and-test iteration until test criteria are met. At a minimum, test criteria 
should specify that the document flows logically and includes alt text for relevant graphics. Changes to the logical 
structure should be made in the InDesign document structure and tagging.

Correcting PDF tag order

Two areas that affect PDF tag order from the original InDesign document are threads and tags. 

Threads InDesign uses threads to indicate the flow of text among visually separate frames that contain related 
content. When frames are moved or resized, the body of text repositions itself within the frames accordingly. The 
InDesign export-to-PDF process groups threaded frames together in the PDF tag hierarchy. As a result, specifying 
how frames are threaded in InDesign can affect the PDF tag structure and logical flow. 

Tags InDesign tags added with the Tags palette are not the same as PDF tags. However, InDesign tags determine the 
tagged PDF structure. You can tag a graphic in InDesign and add alt text to it using the InDesign Structure pane. 
This ability is an important feature because documents created using InDesign tend to be graphic-intensive. If the 
alt text is not added within the InDesign tag structure, it needs to be added using Acrobat 6.0 Professional once the 
tagged PDF document has been created. You can also tag every frame in the document, which lets you arrange the 
sequence of tags in the InDesign Structure pane. This directly controls the sequence of tags in the exported PDF file. 

The use of threads and tags in InDesign provides relatively complete control over the tag structure used for accessi-
bility purposes in PDF documents. No post-PDF processing modifications to the PDF tag structure should be 
necessary if the InDesign document is structured appropriately in regard to logical flow

Threading

When you thread a collection of InDesign frames together, the frames are represented as a single element, called a 
Story in InDesign. Ultimately, when you export a document to PDF, the group of threaded frames is represented in 
the PDF tag hierarchy as a <Sect> tag. 
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When threading frames, keep the following in mind:

• Threading can describe the flow sequence in separate logical sections of a document. When one logical section 
ends and another begins, start a new thread for the next section. 

• Overuse of threading results in fewer, but deeply nested tag hierarchies in which the identities of the individual 
logical elements are obscured. 

• Inappropriate threading can result in a PDF tag structure that doesn’t represent the logical reading order of the 
document.

• Threading can only be done among text frames. Frames around graphics cannot be threaded. 

• Threading frames in the document is best done as part of the initial document planning and design. Threading as 
an afterthought can sometimes be difficult and disruptive to the document layout.

 
A page from an InDesign document showing threaded frames

InDesign accessibility tips
Tags created in InDesign have a direct effect on the way tags are subsequently generated in PDF format, but InDesign 
tags and PDF tags are separate mechanisms that have different effects. Perhaps the essential accessibility reason to 
use tags in InDesign is that they provide the only way to assign alt text to graphics in the original document. 
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Another reason for using InDesign tags is that you can arrange them in a logical order without affecting the visual 
layout of the document, and the tags translate directly to PDF tags, which maintain their sequence when you export 
the InDesign document.

 
InDesign document tags

In InDesign, you create alt text by assigning an attribute-value pair to a graphics tag. Two forms of alt text attributes 
are used for graphics: ActualText and Alt. The ActualText attribute is used for text rendered in a graphic format; the 
ActualText value should be the equivalent of the graphic text as it would be read. The Alt text attribute is a description 
of the graphic or its content and can be detailed. 

Keep these points in mind:

• Actual Text should be short, 150 characters or less. It should be used only for graphically rendered text, and it 
should exactly replicate that text.

• Alt text can be as long as necessary. It is used to provide annotations or detailed alternate text descriptions of 
graphics that convey information about images.

Thread multiple columns within a logical section of the document. If a document has disconnected or unthreaded 
frames, the results are out-of-sequence tag structures. The resulting illogical document reading order causes 
problems for screen reader devices. 
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Exporting to PDF
Generating tagged PDF files from InDesign involves exporting the document as a PDF file and ensuring that the 
appropriate options are selected from the Export PDF dialog box. 

To export an InDesign document as an accessible PDF document:

1  In the InDesign menu, choose File > Export. 

 
The Export option in the File menu

2  In the Export dialog box, select Adobe PDF in the Save As Type (Windows) or Format (Mac OS) menu, and then 
enter a filename.

3  Click Save.
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The InDesign Export PDF dialog box

4  In the Export PDF dialog box, choose a style or preset. Make sure that your style or preset includes compatibility 
with Acrobat 5.0 or greater.

5  Select Export to start the PDF conversion process.

Viewing InDesign tags

If you have set up tags in your document, you can view the InDesign tag structure to ensure that document content 
has a logical order.

To view the InDesign tags:

1  Choose View > Structure > Show Tagged Frames.

2  Choose Window > Tags to see the InDesign Tags palette. Note that only one top level tag, Root, is blue. 

3  Choose View > Structure > Show Structure to display the document tag structure in the left pane, which currently 
contains only Root. 

4  Click the arrow next to Root to expand the structure outline.

To finish the PDF document:

1  Return to InDesign to complete the repairs if the PDF document requires alt text for images or links, the addition 
of bookmarks, or other tag element repairs. You will then need to re-export the document to PDF.

2  Use Acrobat 6.0 Professional to perform an accessibility Full Check. (See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.)

3  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Creating accessible PDF documents using Adobe FrameMaker
To complete these tasks, you need Acrobat 6.0 Professional, Adobe FrameMaker 7.0 or later, and Adobe Distiller® 
installed on your computer.

To create a tagged PDF document, use the procedure described in this section. Do not use Print > Adobe PDF 
(printer name); it creates an untagged PDF document and requires that you add tags and alt text to your PDF 
document using Acrobat 6.0 Professional.

To create accessible PDF documents using Adobe FrameMaker:

1  Choose File > Print.

2  Select Generate Acrobat Data, and then click PDF Setup.

3  In the PDF Setup dialog box, select the Tags tab. 

 
The FrameMaker PDF Setup dialog box

4  Select Generate Tagged PDF.

5  Choose the structure you want, such as book or document title, chapter title, head1, head2, and so forth. (Your 
tag names can be whatever you choose.) 

6  Click Set at the lower left to start the PDF generation process. After the process is complete, you can locate the 
accessible PDF document where you saved it.

Graphics in FrameMaker

To add alt text to graphics in FrameMaker documents, graphics must be placed in Anchored Frames. 

To create the Anchored Frame:

1  Choose Special > Anchored Frame. 

2  Select a position for the frame, and then click New Frame.

3  Add the image file by choosing File > Import > File. Select an image, and then click Import.
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To add alt text to an image inside an anchored frame:

1  Select the Anchored Frame and right-click to show the context menu.

2  Select Object Properties.

3  In the Object Properties dialog box, click Object Attributes. 

4  Type the Alternate text or Actual text in the appropriate input field. The graphic and its text description will be 
properly exported to the resulting PDF.

Note: Actual text should be short, 150 characters or less; it should be used only for graphically rendered text; and it should 
exactly replicate that text. Alt text can be as long as necessary; it is used to provide annotations or detailed alternate text 
descriptions of graphics that convey information about images.

To finish the PDF document:

1  For information on providing alt text for images and links using Acrobat 6.0 Professional, see “Section Seven: 
Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

3  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Creating accessible PDF documents using Adobe PageMaker
To complete these tasks, you need Adobe PageMaker 7.0 or later and Adobe Distiller installed on your computer.

To create a tagged PDF document, use the procedure described in this section. Do not use Print > Adobe PDF 
(printer name); it creates an untagged PDF document and requires that you add tags and alt text to your PDF 
document using Acrobat 6.0 Professional.

To create accessible PDF documents from a PageMaker document:

1  Open the PageMaker document.

2  Choose File > Export > Adobe PDF. 

3  Select PDF as the Save As Type in the PDF Options dialog box.

 
The PageMaker PDF Options dialog box with the Embed Tags In PDF option selected

4  In the General tab of the PDF Options dialog box, verify that the Embed Tags In PDF (for accessibility and reflow) 
option is selected.

5  Click Export to generate the tagged PDF file. Saving a PageMaker 7 file as a PDF file invokes the Acrobat Distiller 
for PageMaker.

To finish the PDF document:

1  For information on providing alt text for images and links using Acrobat 6.0 Professional, see “Section Seven: 
Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

3  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Creating accessible PDF documents using Microsoft Office applications
You can create accessible PDF documents using Microsoft Office applications. This section describes how to use 
Microsoft Word, Microsoft Excel, or Microsoft PowerPoint to create an accessible PDF document. 

To complete the following tasks, you need:

• Microsoft Office XP® or later

• Adobe Acrobat 6.0 Professional or later

Install Microsoft Office prior to installing Acrobat 6.0 Professional for successful integration of the tools and to have 
the Adobe PDF-generation options appear on the Microsoft application menu.

Microsoft Office accessibility tips
To create more accessible documents, consider the following factors while you are creating Microsoft Office 
documents that you will convert to PDF documents.

Structure

• Always use document style formats, such as Heading 1 and Heading 2, to identify structural elements of 
documents. 

• Use bullets and numbering to create lists and outlines. You create accessible PDF documents using the logical 
structures for your documents.

• Choose sharp color contrast for all elements of Microsoft Office documents.

• Choose Format > Columns to create columns in Word documents. Don’t use tabs to simulate two-column text. 

• Use Adobe PDF to convert hyperlinks created with text descriptions (alt text) to accessible links in a PDF 
document.

Images

If you create illustrations out of several smaller illustrations, use the Group command to group them into a single 
illustration.

To provide alt text for images in Microsoft Word, Microsoft Excel, or Microsoft PowerPoint:

1  Select the image, and then press the AppKey or right-click. 

2  Choose Format Picture. 

3  Select the Web tab, and then type alt text for the image in the appropriate field.

4  Click OK.

Note: Not all keyboards have an AppKey; if one option is to use the AppKey, this document will always give an alternative 
way to complete a task.
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Tables

Create tables using the table structure of Microsoft Office applications rather than using the Tab key to position text 
on a page. For more information on document structure, see “Section Two: Accessibility Basics” on page 11. 

To create accessible tables in Microsoft Word, do one of the following:

• Choose Table > Insert > Table.

• Choose Table > Draw Table.

Use tables to display data or information. Don’t use tables to create a column effect in a document. If you place a 
large piece of content in one cell and the cell is allowed to break across pages, readers might become disoriented and 
lose track of what content is related to which row or column.

To clear the Do Not Allow Row To Break Across Pages option:

1  Select the table by choosing Table > Select > Table. 

2  Press the AppKey or right-click, and then select Table Properties. 

3  Clear Allow Row To Break Across Pages in the Row tab of the Table Properties dialog box.

In cases where a table doesn’t fit on one page, ensure that headings appear on each subsequent page. Headings assist 
readers in following the flow of information in a table.

To create a heading row for a column:

1  Select the row that contains the column headings, and then press the AppKey or right-click.

2  Choose Table Properties. 

3  Select Repeat As Header Row At The Top Of Each Page in the Row tab of the Table Properties dialog box.

4  Click OK.

 
An inaccessible table design. Although the content is about creating accessible tables, there is no heading row to provide references for the reader, 
and the cell has been allowed to break across the page, which breaks the flow of content. This piece of content is too large for one cell.
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You can also add a chart to a Microsoft PowerPoint document. By using the tools in native applications rather than 
copying and pasting, you achieve higher levels of accessibility.

To add charts to Microsoft PowerPoint presentations:

1  Choose Insert > Slide > Title And Table.

2  Double-click the icon to add the chart.

Converting Microsoft Office documents to accessible PDF documents
Once you have created a document in a Microsoft Office application, it can be converted to an accessible PDF 
document. To create a tagged PDF document, use the procedure described in this section. Do not use Print > Adobe 
PDF (printer name); it creates an untagged PDF document and requires that you add tags and alt text to your PDF 
document using Acrobat 6.0 Professional. 

To convert Microsoft Office documents to accessible PDF documents: 

1  Open the document in the Microsoft Office application. 

2  Choose Adobe PDF > Change Conversion Settings. 

 
Adobe PDF menu options

3  In the Settings tab, select View Adobe PDF Result.

4  Select Prompt for Adobe PDF File Name.

5  Select Convert Document Information.

6  Select Add Bookmarks To Adobe PDF.

7  Select Add Links To Adobe PDF.

8  Select Enable Accessibility And Reflow With Tagged PDF (critical for accessibility).

9  Click the Security tab, and then select Enable Text Access For Screen Reader Devices For The Visually Impaired to 
allow people using assistive technology to read a tagged PDF document (this is the default).

10  Click the Bookmarks tab, and select the styles for which you want to create bookmarks in the PDF document. 

11  Click OK.
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Bookmark Options in the Settings tab in the Acrobat PDFMaker dialog box

To complete the conversion process, do one of the following:

• Choose Adobe PDF > Convert To Adobe PDF, and then name and save the file. 

• In the PDF toolbar, select the Convert To Adobe PDF tool, and then name and save the file. 

To enhance the accessibility of a PDF document:

1  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Repair any tagged elements. For information on repairing tagged elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.

3  Perform an accessibility Full Check using Acrobat 6.0 Professional. (See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.)

4  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Microsoft Excel

To create an accessible PDF document from a Microsoft Excel worksheet, see “Converting Microsoft Office 
documents to accessible PDF documents” on page 32.

Working with large tables.  If you are working with a large table, the Print Titles options in the Page Setup dialog box 
need to cleared before converting the document. 

The message you receive if Print Titles isn’t turned off

To clear the Rows To Repeat At Top option in Microsoft Excel:

1  Choose File > Page Setup.

2  Click the Sheet tab, and then clear any cell references in the Rows To Repeat At Top text box.

 
The Page Setup dialog box in Microsoft Excel

To clear the Columns To Repeat At Left option in Microsoft Excel:

1  Choose File > Page Setup.

2  Click the Sheet tab, and then clear any cell references in the Columns To Repeat At Left text box.

To enhance the accessibility of a PDF document made from a Microsoft Excel worksheet:

1  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Repair any tagged elements. For information on repairing tagged elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.
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3  Perform an accessibility Full Check using Acrobat 6.0 Professional. (See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.)

4  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)

An accessible PDF document created using a Microsoft Excel document

Microsoft PowerPoint

To create accessible PDF documents from Microsoft PowerPoint slide presentations, see “Converting Microsoft 
Office documents to accessible PDF documents” on page 28.

Adding transitions to an accessible PDF document  When creating accessible PDF documents from Microsoft 
PowerPoint slides, you may want to apply transitions to the tagged PDF document using Acrobat 6.0 Professional. 
Transitions are effects such as dissolve, blinds left, box in, or cover down. You can apply transitions in PDF 
documents to any page, however PDF content based on slide presentations lends itself to transitions more than other 
types of content.

To apply a transition to a tagged PDF document or page using Acrobat 6.0 Professional:

1  Choose Document > Pages > Set Page Transitions.

2  Select the transition you want.

3  Select a speed for implementing the transition.

4  If you want the transition timed, select Auto Flip, and then select an Auto Flip time interval.

5  Select the Page Range option that corresponds to the transition.
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6  Click OK. 

7  View the document in Full Screen mode by pressing Ctrl + L (Windows) or Command + L (Mac OS) to test the 
speed and effect.

 
The Set Transitions dialog box

Transitions will be seen only when the reader uses full-screen mode in either Adobe Acrobat or Adobe Reader. 
Instructions should be included when using transitions in PDF documents.

Advise readers of the following:

• How to access full-screen mode using the mouse and keyboard. (The keyboard shortcut to start full-screen mode 
is Ctrl + L (Windows) or Command + L (Mac OS); press the Escape key to exit full-screen view.)

• How to turn off transitions by choosing Edit > Preferences > Full Screen, and then selecting No Transitions. 
(Readers may find the transitions distracting, especially if an Auto Flip or timing mechanism is used.)

• How to turn off transitions in the current document only by choosing Document > Pages > Set Page Transitions, 
and then selecting No Transition from the Effect menu.

For information on the options readers can choose for full-screen mode, please consult the companion guide to this 
one: “Reading PDF Documents with Adobe Reader 6.0, A Guide for People with Disabilities.”

To enhance the accessibility of a PDF document made from a Microsoft PowerPoint slide presentation:

1  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Repair any tagged elements. For information on repairing tagged elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.

3  Perform an accessibility Full Check using Acrobat 6.0 Professional. (See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.)

4  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Section Four: Creating Accessible PDF 
Documents from Untagged PDF Documents

The majority of existing PDF documents are not tagged because they were usually created using applications that 
cannot create tagged or accessible PDF documents. This section describes the basic steps for making existing PDF 
files accessible by adding tags to untagged documents.

In an untagged PDF document, only the appearance of the document is represented inside the PDF file. In a tagged 
PDF document, information about the reading order, flow, and organizational structure of the document is 
included. This extra information allows readers using assistive technology to access the content of the document 
beyond the graphical appearance of the pages.

If you are working with scanned PDF documents, see “Section Five: Creating Accessible PDF Documents from 
Scanned Documents” on page 36.
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Converting untagged PDF documents to accessible PDF documents
To complete the tasks in this section, you need Acrobat 6.0 Professional or Acrobat 6.0 Standard.

The first step in creating accessible PDF documents from existing PDF documents is to assess the conversion needs 
of the existing documents. The process of creating accessible PDF documents has a logical order to the steps, just as 
the end document will have a logical structure.

Open the PDF document in Acrobat 6.0 Professional or Acrobat 6.0 Standard and review the following before 
tagging the document:

• If the PDF document has form fields, see “Section Six: Creating Accessible Forms” on page 48.

• If the PDF document is a scanned document, see “Section Five: Creating Accessible PDF Documents from 
Scanned Documents” on page 36.

• If the PDF document contains text that should be linked, add the active link objects to the text before running the 
Add Tags To Document tool. Choose Advanced > Links > Create From URLs In Document. Add alt text for links 
after tagging the document. For information on links in PDF documents, see “Creating accessible hyperlinks” on 
page 58.

To add tags to existing PDF documents, do one of the following:

• In Acrobat 6.0 Standard, choose Advanced > Accessibility > Make Accessible.

• In Acrobat 6.0 Professional, choose Advanced > Accessibility > Add Tags To Document.

Adding tags to a PDF document creates a tags tree or logical document structure. Acrobat uses the structure inherent 
in a document to create a logical document structure. Acrobat analyzes each page to determine the proper reading 
order and tags to apply. For complex page layouts, the resulting tags may require manual editing to achieve the 
desired reading order. Many authors and legacy applications may not have added structure as they created 
documents. Images and links most likely don’t have alt text, and bookmarks have not been added for navigating PDF 
documents.



35ADOBE ACROBAT 6.0
Section Four: Creating Accessible PDF Documents from Untagged PDF Documents

 How To Guide

A tags tree of an accessible PDF document

To finish the PDF document:

1  Add alt text to any links in the document. (See “Adding alt text to links” on page 60.)

2  Add alt text to images in the document. (See “Adding alt text to images” on page 57.)

3  Repair any structural elements. For information on repairing structural elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.

4  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

5  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Section Five: Creating Accessible PDF 
Documents from Scanned Documents

You can create an Adobe PDF file directly from a paper document using a scanner. You can also open previously 
scanned documents that have been saved as TIFF files using Adobe Acrobat 6.0 Professional or Acrobat 6.0 Standard. 
The resulting file is an image-only PDF file, a bitmap picture of the pages that can be viewed but not searched. 

To search, correct, and copy the text in a PDF image-only file and make it accessible as a tagged Adobe PDF 
document, you need to perform Optical Character Recognition (OCR) using Adobe Acrobat Capture 3.0 software 
or the Paper Capture option in Acrobat 6.0 Professional or Acrobat 6.0 Standard. If you have scanned paper 
documents and have not saved the scanned images as Adobe PDF files yet, you can use Adobe Acrobat Capture 3.0 
in conjunction with the Tag Adobe PDF Agent to create tagged Adobe PDF files. Consider purchasing Adobe Acrobat 
Capture software if you need to convert large volumes of legacy paper documents into searchable PDF archives.

Adobe Acrobat Capture 3.0 and Adobe Acrobat 6.0 Standard and Professional can open the following image file 
types: BMP, GIF, JPEG, JPEG2000, PCX, PNG, and TIFF. Using Adobe Acrobat Capture 3.0 or the Paper Capture 
option in Acrobat 6.0 Professional or Acrobat 6.0 Standard, you can then convert the documents to PDF and then 
create searchable PDF documents.

This section covers creating accessible PDF documents using Paper Capture with Acrobat 6.0 Professional and 
Acrobat 6.0 Standard, and using Adobe Acrobat Capture 3.0 and Tag Adobe PDF Agent.
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Using Paper Capture to create accessible PDF documents from scanned PDF 
documents
Documents that you scan directly into Adobe Acrobat and save as PDF files are not accessible to all readers. A 
scanned PDF document doesn’t contain text, structure, or elements that can be tagged, so assistive devices can not 
access them. Paper Capture performs OCR to add text to scanned PDF documents. In some instances, Paper Capture 
can’t recognize text. These instances are directly related to the clarity of the scanned material. For example, a smudge 
on a page might be interpreted by Paper Capture as suspect text. In this case, you can examine, confirm, or correct 
the suspect text.

Open the scanned PDF document in Acrobat 6.0 Professional or Acrobat 6.0 Standard.

• If the document format is TIFF, JPEG, BMP, PNG, or PCX, choose File > Create PDF > From File.

• If you are using an existing scanned PDF file, or you are using File > Create PDF > From Scanner, you’ve already 
created a PDF file and can proceed to setting the Paper Capture output options.

Before running Paper Capture, you need to set the PDF Output Style in the Paper Capture Settings.

To set the PDF Output Style and run Paper Capture:

1  Choose Document > Paper Capture > Start Capture.

2  Click Edit in the Paper Capture dialog box.

 
The Paper Capture dialog box

3  Select a PDF Output Style in the Paper Capture Settings dialog box.

Note: To replace text with actual rendered characters that result from OCR recognition, choose Formatted Text & 
Graphics as your PDF Output Style in the Paper Capture Settings dialog box. Any characters not properly recognized 
remain as scanned images of the characters. You can make corrections so that the scanned images of characters are recog-
nized as actual characters. Formatted Text & Graphics offers optimum accessibility. You can keep the exact appearance of 
the scanned document and supplement it with the recognized text; choose Searchable Image to produce documents in 
which OCR-recognized text lies behind the actual scanned images of the documents. 
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The Paper Capture Settings dialog box

4  Click OK in the Paper Capture Settings dialog box.

5  Click OK in the Paper Capture dialog box to start the capture of the scanned PDF document.

Finding OCR suspects

If the OCR dictionary has difficulty identifying characters, it considers them suspect or questionable. You have two 
choices in reviewing OCR suspects: Use Find First OCR Suspect to find suspects sequentially in a PDF document; or 
choose to have all OCR suspects displayed.

To find the first OCR suspect:

1  Choose Document > Paper Capture > Find First OCR Suspect. The Find Element window displays the first 
suspect for inspection.

 
The first OCR suspect displayed in the Find Element dialog box

2  Compare the suspect in the document with the image of the word in the Find Element dialog box, and do one of 
the following:

• Click Accept And Find to accept the text as correct, and then move to the next suspect word.

• Click the suspect in the document and type edits to correct the text (The TouchUp Text tool became active when 
Acrobat began looking for suspects). 

• Click Find Next to leave the suspect unchanged, and then move to the next suspect.

3  Close the Find Element dialog box when you have finished reviewing the suspects.

You can also choose to have all OCR suspects displayed in the PDF document.
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To find all OCR suspects:

1  Choose Document > Paper Capture > Find All OCR Suspects. The suspects are outlined in thin frames.

 
A paper-captured document with all the suspects highlighted

2  In the Advanced Editing toolbar, select the TouchUp Text tool, and select a suspect in the document. 

3  In the Find Element dialog box, choose the appropriate option:

• Click Accept And Find to accept the text as correct, and then move to the next suspect.

• Click the suspect in the document to edit the text. 

• Click Find Next to leave the suspect unchanged, and then move to the next suspect.
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A paper-captured document with all suspects identified and the Find Element dialog box displayed

4  Click Close when you have reviewed all suspects.

To tag the PDF document for accessibility, do one of the following:

• In Acrobat 6.0 Standard, choose Advanced > Accessibility > Make Accessible.

• In Acrobat 6.0 Professional, choose Advanced > Accessibility > Add Tags To Document. 

To finish the PDF document:

1  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Repair any structural elements. For information on repairing structural elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.

3  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

4  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Using Adobe Acrobat Capture 3.0 and the Tag Adobe PDF Agent to create 
accessible PDF documents
To complete these tasks, you need Adobe Capture 3.0 and the Adobe Tag Agent. You also need Acrobat 6.0 Profes-
sional to test your documents for accessibility.

Important: You need the Tag Adobe PDF agent to create a tagged PDF file. This is a separate product that is available for 
purchase from Adobe. For more information, see the Adobe Acrobat Capture product page at www.adobe.com. 

Tag Adobe PDF Agent tips

Users who convert high volumes of paper documents to PDF documents using Adobe Acrobat Capture 3.0 find Tag 
Adobe PDF Agent useful because it allows tagging of PDF documents to be incorporated in an Adobe Acrobat 
Capture workflow.

Advantages to using Tag Adobe PDF Agent:

• It allows users to specify more than one language dictionary for processing documents.

• It recognizes table of contents and index layouts, and automatically creates hyperlinks to the appropriate views in 
the document.

• It includes a Move Graphics to Artifact option, which is especially useful when converting forms to Tagged Adobe 
PDF.

Foreign Language Processing  Paper Capture in Acrobat 6.0 Professional and Acrobat 6.0 Standard allows users to 
specify any one of 17 foreign languages as the primary OCR language.

The Tag Adobe PDF Agent for Adobe Acrobat Capture 3.0 provides access to a number of dictionaries and also allows 
more than one dictionary to be selected for processing multiple-language documents.

Adobe Acrobat Capture 3.0 accessibility workflow

The first step in using Adobe Capture 3.0 is to build an accessibility workflow. 
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The Acrobat Capture 3.0 interface

To build a workflow to create accessible PDF documents in Acrobat Capture 3.0: 

1  In the Configure panel, click Insert Workflow.

2  Right-click on the newly inserted workflow (named “Untitled”), select Rename, and then type in an appropriate 
name (such as “Accessible PDF”).

The Insert Workflow button in the Configure panel

3  Click Insert Steps.
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The Insert Steps button in the Configure panel

4  Add the following steps in order:

• (For PDF Image-only files) Split Multipage PDF Image files to individually process each page of the PDF Image-
only file. 

• (For PDF Image-only files) Convert Image To TIFF to make the image on each page usable for the OCR software 
that the Capture Image agent applies. 

• Capture Image to apply OCR to each page as marked with the zone template. (The zone template lets you specify 
areas on pages to treat as though they contain text or images.) 

• QuickFix Page to let you review and correct suspects on each page. 

• Bind Pages to assemble the individual pages into a single document. 

• Export To PDF Agent to save files as Adobe PDF files. 

• Tag PDF to create tagged Adobe PDF files. (Tag PDF is a separately purchased plug-in available from Adobe.) 

• Store File (PDF) to save the file in Adobe PDF in the location you specify. 

 
The Insert Steps dialog box

5  Click Done. 
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A workflow as steps are added

To complete building the workflow:

1  In the Configure panel, select the Export To PDF agent in the workflow.

2  Right-click Export To PDF, and then choose Properties. 
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A workflow with the Export To PDF agent context menu active

3  Click the General tab, and then select the appropriate page content. 

4  Click OK.

Note: To replace text with actual rendered characters that result from OCR recognition, choose Formatted Text & 
Graphics as your Page Content in the Export To PDF Properties dialog box. Any characters not properly recognized remain 
as scanned images of the characters. You can make corrections so that the scanned images of characters are recognized as 
the actual characters. Formatted Text & Graphics offers optimum accessibility. You can keep the exact appearance of the 
scanned document and supplement it with the recognized text; choose Searchable Image to produce documents in which 
OCR-recognized text lies behind the actual scanned images of the documents.
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The General tab in the Export To PDF Properties dialog box

5  Right-click the Tag Adobe PDF agent in the workflow, and then choose Properties. 

6  Choose the language to use in discerning word breaks. 

7  Select the default options.

8  Click OK. 

9  Right-click the Store File agent in the workflow, and then choose Properties. 

10  Enter a location in which to store the resulting tagged Adobe PDF files. 

11  Click OK. 

Submitting documents to the Adobe Acrobat Capture 3.0 accessibility workflow

Now that the Accessibility PDF workflow has been created, documents submitted to it will be automatically 
converted to accessible documents.

To run an Adobe Acrobat Capture 3.0 workflow: 

1  Open Adobe Acrobat Capture 3.0. 

2  Click the Configure tab. 

3  In the Configure panel, click the Run button for your Accessible PDF workflow. 

4  Click the Submit tab. 

5  Select the folder or files you want to capture. 

6  At the bottom of the Submit panel, select how you want to treat files and how you want to combine the images. 

7  On the Target Workflow menu at the bottom of the Submit tab, choose the Accessible PDF workflow you created. 

8  Click the Submit to Workflow button. 

9  Use the QuickFix tool to review and correct suspects on each page. 

The image files are automatically assembled into a single file, exported to Adobe PDF files with tagged Adobe PDF, 
and stored. 
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The Submit tab

To finish the accessible PDF document:

1  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

2  Repair any structural elements. For information on repairing structural elements and rearranging tags in a logical 
document structure using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural 
Elements” on page 64.

3  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

4  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Section Six: Creating Accessible Forms

While it is helpful to have experience creating a PDF form from scratch, it is not a prerequisite to understand the 
process of making a PDF form accessible. A full treatment of creating PDF forms is significantly beyond the scope of 
this guide. Refer to the Adobe Acrobat documentation for detailed information about types of form fields and the 
various actions and calculations they can trigger.

This section covers using Adobe Acrobat 6.0 Professional, and using the PDF Forms Access tool in conjunction with 
Adobe Acrobat 6.0 Professional, to create accessible forms.
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Using Acrobat 6.0 Professional to create accessible forms
You need Adobe Acrobat Professional 6.0 to complete these tasks.

For information on using tables for form design, see “Appendix C: Accessible Form Tables” on page 79.

Creating an accessible form from an untagged PDF document

If you have an untagged PDF document with no interactive forms, you can still create accessible forms by adding tags 
to the document and then adding interactive form fields. The recommended method for creating accessible forms is 
to use the Adobe PDF Forms Access tool.

To tag an untagged PDF document:

1  Open the untagged PDF form in Acrobat 6.0 Professional.

2  Open the Navigation pane.

3  From the menu bar, choose Advanced > Accessibility > Add Tags To Document.

 
Form field options in the Advanced Editing toolbar

To add electronic form fields to your newly tagged PDF document: 

1  Click the Tags tab in the Navigation pane, or choose View > Navigation Tabs > Tags to open the Tags tab.

2  Choose Highlight Content from the Options menu on the Tags tab.

3  Choose Tag Annotation from the Options menu of the Tags tab.

4  Select the element of the tags tree that should precede the field you are about to create. When you add the new 
field, the form field automatically inserts into the tags tree at that point.

5  On the Advanced Editing toolbar, select Forms, and then the field type you want to create (for example, button, 
radio button, list box, or combo box).

6  Drag the cross-hair pointer to create a field of the required size in your desired location in the form. When you 
release the mouse button, the Field Properties dialog box appears.
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The Text Field Properties dialog box showing options for text boxes

7  In the Field Properties dialog box, enter a name in the Name text box. 

Note: If the field is a radio button, it is also important to go to the Options tab and set the Export field to be the text that 
describes this choice. The Tooltip for radio buttons should describe the category.

8  Enter a description of the field in the Tooltip text box. The screen reader uses this information to describe the field 
to vision-impaired users. 

9  Fill in other options as desired.

10  Click Close.

11  Save the document.

To finish the PDF document:

1  Test the form using keyboard commands:

• Press the Tab key to move focus to the next field.

• Press Shift + Tab to move focus to the previous field.

• Press the spacebar to select options.

• Press the arrow keys to select radio button options or list items.

2  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

3  Repair any structural elements. For information on repairing structural elements and rearranging tags in a tags 
tree using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural Elements” on page 64.

4  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

5  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Using the Adobe PDF Forms Access tool in conjunction with Acrobat 6.0 
Professional to create accessible forms
To complete the following tasks you need Acrobat 6.0 Professional and the Adobe PDF Forms Access tool.

For information on using tables for form design, see “Appendix C: Accessible Form Tables” on page 79.

How the Adobe PDF Forms Access tool helps with accessibility

The Adobe PDF Forms Access tool, distributed as part of the Adobe Acrobat Capture 3.0 Agent Pack, automates the 
tagging process required to create accessible Adobe PDF forms from untagged PDF forms. The PDF Forms Access 
tool recognizes the objects and structures in a form and links content with fillable form fields to make forms acces-
sible. It is possible to manually create tags for data fields in forms, and the PDF Forms Access tool significantly 
decreases the amount of time and effort required to do so. This decrease is particularly helpful as the number of fields 
in the form, or the complexity of the form, increases. 

You can modify and rearrange the tag structure of the processed form. A useful feature of Forms Access is that you 
can import a tag structure from another document to the current document. This feature makes it possible to 
preserve the PDF tag structure of a form among successive updates without having to completely reconstruct the tag 
structure in the updated document. 

Note: The Adobe PDF Forms Access tool can be installed and run as a stand-alone application or as an agent (plug-in) 
for Adobe Acrobat Capture 3.0.x. In Acrobat Capture, the PDF Forms Access tool appears under Step Templates as Tag 
Form and under the Workgroup Tab as a manual step. 

Form file initialization and initial tag structure

When you open a non-tagged PDF form, the PDF Forms Access tool initially identifies elements in the document, 
such as graphic artifacts, document sections, text blocks, and fields, and automatically defines an initial set of tags 
based on the page layout analysis. In most cases, however, you need to make further adjustments and refinements to 
the tags tree to make the form logically or fully accessible.

Note: Although Tag PDF appears immediately after Tag Form under Step Templates in Acrobat Capture, don’t use Tag 
PDF when creating accessible PDF forms. Use Tag PDF with PDF documents, and use Tag Form with PDF forms.

The PDF Forms Access tool allows you to add other types of tags to the tags tree, and to delete, modify, and rearrange 
existing tags. The objective is to create a tags tree hierarchy, which determines the reading order of the document, 
that accurately and clearly reproduces the meaning and the intended logical flow of the visual document. 

The visual representation of a form and the tags tree representation of a form are separate, but parallel, structures. 
Each might contain elements not found in the other; for example, the visual form may contain graphical artifacts 
that are meaningless in the logical reading order.

In general, the relevant content, reading order, and logical processing order of the form should be equivalent in both 
representations of the document. There are always exceptions. For example, visual techniques might be used to make 
a certain piece of information in a document – for example a warning – stand out to the reader, so that he or she 
notices it first regardless of where it is placed. There would be a case for first placing that piece of information in the 
tags tree, no matter where it is visually placed in the reading sequence of the document. In this respect, the visual 
layout of the document and the layout of the tags tree are independent of each other.
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Steps to create an accessible PDF form with the Adobe PDF Forms Access tool
Creating a PDF form document using the Adobe PDF Forms Access tool is a four-step process.

Step one: Create a document using a suitable authoring tool

The first step is to create a document containing the layout and format for the text and data fields that will comprise 
the form. The easiest way to create this document is to use an authoring tool that is already integrated with Acrobat 
Distiller, such as Adobe FrameMaker, Adobe InDesign, Adobe PageMaker, Adobe GoLive®, Microsoft Word, or 
Microsoft Excel. Use the authoring tool to design the page layout or pages of the form, including headings, instruc-
tions, and any fields in which users will enter data. At a minimum, you should provide each field with a label, 
although you can also draw lines or boxes next to the labels to indicate where the fillable field itself will be located. 
Use graphics tools to draw lines and boxes – do not use characters, such as underlines and vertical bars.

Step two: Convert the document to an untagged PDF document

The second step is to convert the original document to an untagged PDF document. 

Use whatever method the authoring tool provides to generate a PDF version of the original file. In some authoring 
tools, this method is a Save As operation, and in others it is a separate tool or menu selection. It is important that 
you save the file as a non-tagged PDF file. 

To do this, choose one of the following methods:

• In the PDF Setup dialog box, which appears prior to the generation of the PDF file, click the Tags tab and ensure 
that Generate Tagged PDF is not selected.

• You can also use Print > Adobe PDF (printer name), which saves documents as untagged PDF documents.

Step three: Add active fields to the untagged PDF document

In the third step, add fields to the PDF document using Acrobat 6.0 Professional.

To add electronic form fields to a PDF document: 

1  Select the appropriate tool from the Advanced Editing > Forms toolbar. 

2  Drag the cross-hair pointer to create a field of the required size where you want it placed on the form. When the 
mouse button is released, the Field Properties dialog box appears.

3  In the Field Properties dialog box, enter a name in the Name text box. 

4  Enter a description of the field in the Tooltip text box. The screen reader uses this information to describe the field 
to vision-impaired users. 

5  Complete any other options you want.

6  Click Close. 

7  After you’ve added all the fields to the document, save and close the file.
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Step four: Use the Adobe PDF Forms Access tool to tag a PDF form

The fourth and final step is to tag the form.

To create accessible electronic forms using the Adobe PDF Forms Access tool:

1  Launch the Forms Access utility by choosing Start > All Programs > Adobe > Forms Access > Adobe PDF Forms 
Access.

2  Open the PDF document containing the active form fields. The Adobe PDF Forms Access tool creates tags for the 
document as it is opened.

Note: You can only see and edit tags on one page at a time.

 
The tags tree of an Adobe PDF Forms Access document

Form documents tend to have relatively complex layouts compared to documents with a simple, single column 
structure. Form documents frequently use multiple columns and multiple line text blocks to provide instructions for 
individual fields. You can place both instructions and labels in various locations relative to the fields they reference 
– above, below, right, left, or across the page connected by ellipses, for example. For this reason, the initial PDF Forms 
Access processing of the document generally produces a tags tree hierarchy that does not completely reflect the 
logical reading order of the form. The success that the PDF Forms Access tool has in analyzing and tagging the form 
depends largely on the original formatting and layout and the types of fields that are used in it. 

Sometimes the layout of the form field parts in the original document – the identifying number, the label, special 
instructions, and so on – cause problems with the way the elements in the tags tree are sequenced. The top-to-bottom 
order of document elements as they are represented in the tags tree determines the order in which a screen reader 
will read the document elements.
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Finishing the form

There are two steps to finishing a form using the Adobe PDF Forms Access tool. You can save changes as you work 
with a PDF document in the Adobe PDF Forms Access tool: However, you must finish the document to complete 
the process.

To finish the accessible PDF form:

1  Choose File > Save As, and then select the file name from the browser list. 

2  Click Yes in the dialog box that asks whether you want to replace the existing file. You can use the PDF Forms 
Access Save As command at various points to save the modifications you have made to the tags tree. 

3  When you are satisfied with the modifications, choose File > Finish to complete PDF Forms Access processing of 
the form. The form file closes when processing finishes.

You can now exit the Adobe PDF Forms Access tool. The next steps in the development process are to open the 
finished file in Acrobat and test its accessibility.

Notes: 

• A PDF form saved using the Finish command cannot be loaded back into the PDF Forms Access tool for further editing. 
It is advisable that you use the Save As command to save a copy of the file with your final tags tree structure just prior 
to issuing the Finish command. If you decide to edit the document again later, you can use the copy.

• When you run the Adobe PDF Forms Access tool with Acrobat Capture, you can save forms as temporary files that 
remain in the form tag state until you commit the temporary files to the next step in the workflow. Committing a PDF 
form marks the form as finished and moves it to the next step in the workflow, which is typically a store step. The file 
uses typical Acrobat Capture workflow naming conventions, rather than appending “new” to the filename. 

To finish the PDF document: 

1  Test the form using the following keyboard commands:

• Press the Tab key to move focus to the next field.

• Press Shift + Tab to move focus to the previous field.

• Press the spacebar to select options.

• Press the arrow keys to select radio button options or list items.

2  Optimize the PDF document for accessibility. For information on providing alt text for images and links using 
Acrobat 6.0 Professional, see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55. 

3  Repair any structural elements. For information on repairing structural elements and rearranging tags in a tags 
tree using Acrobat 6.0 Professional, see “Section Eight: Manipulating Tagged PDF Structural Elements” on page 64.

4  Perform an accessibility Full Check using Acrobat 6.0 Professional. [See “Full Check (Adobe Acrobat 6.0 Profes-
sional)” on page 4.]

5  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)



55

 How To Guide

Section Seven: Optimizing the Accessibility 
of Tagged PDF Documents

You should have performed an accessibility Full Check using Acrobat 6.0 Professional to isolate accessibility 
problems in a PDF document. See “Full Check (Adobe Acrobat 6.0 Professional)” on page 11.

To perform the tasks in this section, you need Acrobat 6.0 Professional. 

This section covers adding document navigation, adding alt text to images, and creating accessible hyperlinks.
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Creating document navigation
Create bookmarks to help readers navigate PDF documents. You can use the structure you applied in the native 
application to identify a hierarchy of topics. Using color to denote top level bookmarks further eases navigation.

Note: Bookmarks are placed at the next insertion point. To nest bookmarks for subheadings, use the mouse or arrow keys 
to select the previous bookmark, and then create another one. 

Using a mouse, you can also drag bookmarks under each other to create a hierarchy. 

 
A series of nested bookmarks with the level 1 bookmarks in blue for ease of navigation

To add bookmarks to a PDF document:

1  Use the mouse or arrow keys to select the previous bookmark.

2  Select the Select Text tool from the Basic toolbar.

3  Select the text you want as a bookmark.

4  Right-click the text, and then choose Add Bookmark, or press Ctrl + B (Windows) or Command + B (Mac OS) 
to insert a bookmark. This creates a bookmark in the document and opens the Navigation pane. 

5  Edit the new bookmark.

6  Repeat steps 2 and 3 to continue creating bookmarks.

You can make the following bookmark modifications:

• Rename bookmarks.
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• Wrap long text so text is easier to read.

• Modify the properties or appearance of bookmarks. For example, if section title bookmarks are a different color, 
they are easier to find in a long list of bookmarks. (Right-click a bookmark, and then choose Properties.)

 
The Bookmark Properties dialog box

Adding alt text to images
Alt text provides a written description of images or graphics for people who are not able to access the visual infor-
mation. If you have an image that has been tagged as a <Figure> in a PDF document, and it doesn’t have alt text, use 
one of the following methods to provide alt text.

To create alt text for an image:

1  Choose Tools > Advanced Editing > TouchUp Object Tool.

2  Select the image that needs alt text.

3  Right-click the image.

4  Choose Properties from the context menu.

5  In the alt text dialog box, type alt text for the image.

6  Click Close.

 
The TouchUp Properties dialog box in which you can enter alt text for images
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You can also create alt text for graphic material from the tags tree. In the tags tree, an image or graphic is represented 
by the <Figure> tag.

To create alt text from the <Figure> tag in the tags tree:

1  Right-click the <Figure> tag.

2  Choose Properties from the context menu.

3  In the alt text dialog box, type alt text for the image.

4  Click Close.

When you position the pointer over the image, the alt text appears.

Creating accessible hyperlinks
Hyperlinks let readers quickly move from one part of a document to another, to related information in a different 
document, or to a Web site relevant to the content. Accessibility is enhanced because it is easier to activate a hyperlink 
than to switch documents and search for a specific reference point. 

You can create links in a PDF document using Adobe Acrobat. Add alt text descriptions of the link to make the 
purpose or use of the link clearer for readers who use screen reading software.

There are three ways to create links in a PDF document:

• Use the Select Text tool. 

• Use an untagged PDF document. 

• Use the Link tool.

Creating links with the Select Text tool 

When you use selected text in the PDF document to create a link, that text is used as the link’s text.

To create a link using the Select Text tool:

1  Select the Select Text tool from the Basic toolbar.

2  Select the text you want as a link.

3  Right-click or press the AppKey to bring up the context menu. 

4  Choose Create Link to open the Create Link from Selection dialog box.



59ADOBE ACROBAT 6.0
Section Seven: Optimizing the Accessibility of Tagged PDF Documents

 How To Guide

The Create Link from Selection dialog box

5  Identify the type of link you want, and then enter the appropriate details.

6  Click OK. You should now see a <Link> tag in the tags tree.

You do not need to add alt text to this link. The selected text becomes the alt text.

Creating links in an untagged PDF document

If a PDF document has many links to web pages, for example an extensive resource or reference section or web-based 
links throughout the document, you should create these links before the document is tagged for accessibility.

To create links in an untagged PDF document:

1  Open an untagged PDF document.

2  Choose Advanced > Links > Create From URLs In Document. You can create links in the entire document or on 
certain pages. 

3  When all the links are added to the PDF document, tag the PDF document by choosing Advanced > Accessibility 
> Add Tags To Document. The <Link> tag appears in the tags tree of the tagged document.

A tags tree containing a <Link> tag

You need to add alt text to this type of link. (See “Adding alt text to links” on page 60.)

Creating links with the Link tool

Use this method of creating links to make an image a link, or if you are touching up a PDF document in which a link 
was not identified using the Links > Create From URLs In Document option.



60ADOBE ACROBAT 6.0
Section Seven: Optimizing the Accessibility of Tagged PDF Documents

 How To Guide

To use the Link tool:

1  Open the Tags tab.

2  Locate the content under the link. (See “Locating contents and tags” on page 9.)

3  Create a <Link> tag and move the content under that tag. 

4  Select the <Link> tag.

5  Choose the Link tool on the Advanced Editing toolbar.

6  Hold down the left mouse button, and then drag a box around the element you want to use as a link.

7  In the Create Link dialog box, identify the type of link you want, and then enter the appropriate details.

8  Click OK.

9  Choose Options >Find from the Tags tab.

10  From the pop-up menu in the Find dialog box, select Unmarked Links.

11  Click Find. The new link should be highlighted with a blue box. 

12  Click Add Tag to place an OBJR object under the <Link> tag.

The Create Link dialog box

You need to add alt text to this type of link.

Adding alt text to links

When you need to provide alt text for a link, you must first find its tag in the tags tree. You may find it easier to start 
with the link in the PDF document than to search the tags tree.

To find a <Link> in the tags tree from a link in a PDF document and add alt text to it:

1  Choose the Select Text tool. 

2  Select a range of text that will be near the link in the tags tree. (Ideally, you would select the text for the link. 
However, doing so in this case would activate the link.)

3  In the Tags tab, click Options.
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4  Select Find Tag From Selection. If you are working with a long document, you may have to scroll down to that 
point in the tags.

5  Find the <Link> tag for the link.

To add alt text to a link in a tags tree;

1  In the tags tree, find the <Link> tag.

2  Right-click the <Link> tag.

3  On the context menu, select Properties.

4  Enter alt text for the link.

5  Click Close.

Adding watermarks to PDF document

You can add watermarks to PDF documents that optimize the accessibility of the PDF document. The best way to 
add a watermark is to use Adobe Acrobat, rather than adding the watermark to the document in its native appli-
cation.

To add a watermark to a tagged PDF file:

1  In a blank document in a native application (for example a word processor), create the watermark.

2  Save the watermarked document as an untagged PDF file by choosing File > Print > Adobe PDF (as the printer 
name), and then click Print.

3  In Adobe Acrobat, open the tagged PDF document in which you want the watermark to appear.

4  Choose Document > Add Watermark & Background.
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Add Watermark & Background dialog box

5  Select the Browse button in the Add Watermark & Background dialog box to choose the watermarked PDF file.

6  Select the page on which the watermark should first appear, and then select any subsequent pages on which it 
should appear.

7  Make any other desired position or appearance changes.

8  Click OK.

The watermark is inserted into the tagged PDF document but doesn’t appear in the tags tree. Not having the 
watermark appear in the tagged PDF document is helpful for people using screen readers because they won’t hear 
pieces of the watermark read in document content.

Establishing document language

The readability and accessibility of PDF documents and other digital documents improves when you identify a global 
language for a document. If there are changes in language for parts of the document, you can identify and tag them 
individually.

To set the language for an entire document:

1  Choose File > Document Properties, or press Ctrl + D (Windows) or Command + D (Mac OS).

2  In the Document Properties dialog box, select Advanced, and then choose a language from the Language menu.
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When a document in one language contains text within it that is of a different language, you can identify the other 

language in the tags tree. You can set the language for an element and have it apply to all text within that element. It 

is not necessary to tag each word individually.

To specify the text language for elements within a document: 

1  In the tags tree, select the element or sub-tree that does not have a text language defined for it. 

2  Right-click the element, and then choose Element Properties. 

3  In the Tag tab of the TouchUp Properties dialog box, choose a language from the Language menu. The language 
encodings are based on ISO standards. The languages and their respective codes are as follows: 

• Brazilian Portuguese: PT-BR 

• French: FR 

• Chinese: ZH 

• German: DE 

• Danish: DA 

• Italian: IT 

• Dutch: NL 

• Japanese: JA 

• English: EN 

• Korean: KO 

• US English: EN-US 

• Norwegian: NO 

• UK English: EN-GB 

• Spanish: ES 

• Finnish: FI 

• Swedish: SV 

4  Click OK. 

To finish the PDF document:

1  Repair any existing structural elements that affect the reading order. For information on repairing structural 
elements, see “Section Eight: Manipulating Tagged PDF Structural Elements” on page 64.

2  Test the PDF document for accessibility. (See “Additional accessibility tests” on page 10.)
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Section Eight: Manipulating Tagged PDF 
Structural Elements

Manipulating tagged PDF elements allows you to perform detailed repairs on tags. You can also combine multiple 
PDF documents into single accessible PDF files.

To perform the tasks in this section you need Acrobat 6.0 Professional.

This section addresses correcting tagging problems, manually tagging documents to make them accessible, 
improving the accessibility of tables, combining pages of content in a PDF document, and creating PDFs from web 
pages for HTML-based documents.
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Correcting tagging problems in a PDF document
If you discover tags that require repairs when reviewing tagged PDF documents, you have several options for making 
repairs to the tags tree. This section provides information on repairing tagging problems.

What are elements?

When you create documents, you add structure or “elements” to content to identify the roles or uses of the content 
pieces or to define relationships among the pieces. For example, a heading may be followed by a paragraph and a list 
of items that relate to the heading. Rows and columns in a table are related to each other according to row and 
column titles and their placement in the table.

Accessible PDF provides a way of identifying the relationships among the tagged content elements of a tagged PDF 
document. For example, a document might have a section element. Within section 1 is a hierarchy of content, a 
reading order of information that can be mapped through the tags tree.

It is essential to review documents for accessibility and readability, and to ensure that the relationships among the 
content elements are correct. The information provided in this section provides solutions for repairing relationships 
among tag elements.

For definitions of specific PDF tag elements, see “Appendix D: Adobe Standard Elements” on page 81.

Rearranging elements in the tags

The tags tree displayed in the Tags tab of the Navigation pane provides an easy way to change the order in which 
assistive technology reads the elements. 

To change the order of an element:

1  In the tags tree, select the element you want to move.

2  Drag the element to the desired position in the tags tree.

Notes: 

• As you drag an element, the cursor changes to a pointed arrow to indicate legal moves, and to a circle with a line 
through it to indicate illegal moves. If you release the mouse button while the cursor indicates an illegal move, the 
element snaps back to its original position in the tree. 

• The legal move cursor lets an author either “drop after this item” or “drop as a child of this item” depending where 
the small downward pointing arrow is located. The downward pointing arrow “drops after this item” if it appears 
under the tag icon in the tags tree; it “drops as a child of this item” if it appears under the tag text in the tags tree.

Deleting elements

At times you may want to delete some portion of the tags tree and create your own tags and structure. Deleting 
elements is useful when working with table tags.

To delete an element:

1  In the tags tree, select an element.

2  Do one of the following:

• Choose Delete Element from the Options menu on the Tags tab.

• Right-click the selected element to bring up a context menu, and then select Delete Element.
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Note: When you delete an element, the element and all of its children are removed from the tags tree. The associated page 
content is not deleted from the document, but it does become unmarked content.

Changing element types

In some cases, the structure element may be the wrong type. You can change an element type so that it better reflects 
a logical structure.

To change the element type:

1  In the tags tree, select the element you want to change.

2  Choose Edit > Properties.

3  In the Type text box, type a new element type.

4  Click OK.

Artifacts
An authoring application, Tag PDF Agent, or the Make Accessible plug-in may mark content as an artifact even 
though the content is important and needs to be made available for screen reading devices. 

It is also possible that unimportant or distracting information is marked as a structural element and, therefore, you 
want to change it to an artifact so that a screen reader won’t attempt to read it. An example of unimportant infor-
mation might be a decorative sidebar with text.

Using the tags tree in the Tags tab, you can find and fix improperly marked artifacts.

To find artifacts:

1  Choose View > Navigation Tabs > Tags, or click the Tags tab in the Navigation pane to open the Tags tab.

2  Choose Find from the Options menu on the Tags tab.

3  From the menu in the Find Element dialog box, select Artifacts. The radio buttons allow you to search either the 
current page or the entire document.

4  Click Find. When an artifact is found, it is highlighted in the document view, and the type of artifact is displayed. 

5  Click Find Next to find more artifacts, or click Close to end the search.

In some instances, content may have been mistakenly identified as an artifact. In these instances, you need to change 
artifacts into elements that assistive technology can access.

To change an artifact to an element: 

1  Search the document for artifacts.

2  After the desired artifact is found, select the tag item in the tags tree that the artifact should follow. 

3  Click Tag Element. The new element tag appears as a child of the selected element in the tags tree.

Sometimes when you tag a document for accessibility, decorative items (such as sidebars containing images and text) 
are mistaken for content that is necessary for the understanding and comprehension of the document.

To change an element into an artifact:

1  In the tags tree, select the content that appears below the Tag and the tag title.
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2  Choose Options > Change Tag To Artifact.

3  Select an artifact type and a position on the page to attach the artifact.

4  Click OK.

Note: If you select the content in the document, the Change Tag to Artifact command is not enabled. in the Tags tab, you 
must select the tag content displayed under the element tag in the tags tree to use this command.

Content associated with a tag element in the tags tree. Tag content is shown highlighted in the tags tree, with the corresponding page content 
shown highlighted in the document view.

Applying tags manually to fix problem areas

Improperly marked content can create reflow and accessibility problems. If tagged content creates problems for 
reflow or accessibility, you can manually correct the problems by marking content and assigning element types.

You must first create a tags tree if you are working with an untagged PDF file and want to add tags to the document. 
The Create Tags Tree command is available only no available tags are in the document.

To create a tags tree:

1  Open the Tags tab in the Navigation pane, or choose View > Navigation Tabs > Tags to open the Tags Tab.

2  Choose Create Tags Tree from the Options menu on the Tags tab.

3  Save the document. Changes to the tags tree do not become part of the document until it is saved. 
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Adding tags to an existing tags tree

You can add new elements to an existing tags tree.

To add tags to existing tags:

1  Select the element preceding the new tag.

2  Choose New Tag from the Options menu on the Tags tab.

3  In the menu, choose the type of element you want to create. 

4  If necessary, drag the new element to the desired position in the tags tree, and then save the document.

Note: If an element is selected when you create a new child element, an empty structure element of the type selected is 
inserted after the selected element. If no element is selected, or if the root tag is selected, the new element is inserted as the 
last child of the tags tree.

Adding page content to tags

There are also occasions where you can use the Select Text tool to highlight document content and create a new tag 
element in the tags tree. This method is useful if the PDF document is lengthy and makes finding content easier than 
specific tag elements.

To add page content to the tags tree:

1  Choose Options > Find in the Tags tab.

2  Select Unmarked Content to locate any content that has not already been added to the tags tree or marked as an 
artifact.

3  Click Find. Any unmarked content found is highlighted in the document view.

4  In the tags tree, select the element that should precede the new content.

5  Select Tag Element. The content is added after the selected tag.

6  Select Find Next to repeat the operation.

7  Close the Find dialog box.

Improving the accessibility of tables
Tables pose a special challenge for screen readers and other assistive technologies. They present textual or numerical 
data in layout that sighted people can easily reference without having to read all of the information contained in the 
table.

Problems with automatically recognizing tables is minimized by always defining a table with rules around the table 
and among columns, rows, and cells. “White space” tables, where data is organized in a table format without rules, 
can create unexpected results, because it is difficult for the tagging agent to readily recognize such layouts as tables.

It is also helpful to use table formats in the authoring application, such as table column heading, row heading, or 
table cell data. 

A table should have the following hierarchy of elements: a table element <Table> is a container element with 
attributes specifying placement and bounding box information; table row elements <TR> define each row of table 
cells as immediate children of the <Table> container element; a table data element <TD> or table heading element 
<TH> is the immediate child of each table row element.
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Cell content can be complex. It could be another table, a form field, a list, a link, or several paragraphs. 

Check the structure of a table in an accessible PDF document by viewing the <Table> tags in the Tags tab of the 
Navigation pane.

 
A table structure shown in the tags tree of a PDF document

Tables commonly include merged cells to create a column or row heading that straddles or spans two or more 
associated columns or rows. For such a structure to be accurately reflected in the tags tree, ColSpan and RowSpan 
attributes should be properly set.

To set ColSpan and RowSpan attributes:

1  Select the <TD> or <TH> elements in the tags tree.

2  From the context menu, select Properties.

3  In the Tags tab of the TouchUp Properties dialog box, click Edit Attribute Objects.

4  Select Attribute Objects and click New Item to create a new Attribute Object Dictionary.

5  Expand the new dictionary and select the O attribute, then click Change Item.

6  Change the value to Table.

7  Select the Attribute Object Dictionary and Click New Item.

8  Create an attribute with Key ColSpan or RowSpan (as appropriate), Type Integer, and Value X (with X the number 
of columns or rows spanned).

9  Press OK to close the Attributes dialog box.

10  Close the TouchUp Properties dialog box.

For information on converting Microsoft Excel documents to accessible PDF documents, see “Microsoft Excel” on 
page 30.

For information on using tables in accessible PDF forms, see “Appendix C: Accessible Form Tables” on page 79.
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Adding pages or documents to a PDF document
Typically, more than one person is working on a document or project. One person might be writing content, while 
another is creating a cover page with artwork. These people may use different applications to create the PDF content. 

PDF files can be combined using two methods:

• Inserting pages into an existing PDF document.

• Combining files from native applications.

Inserting content pages into an existing PDF document

You can use the Document > Pages option to insert, replace, or delete pages from a PDF document.

Whenever pages are added to a tagged document, the tags for the new pages are added to the end of the tags tree. 

If you insert or replace pages in the middle of a document, the tags tree needs to be manually repaired after the 
insertion or replacement of pages. 

The best strategy is to arrange a workflow so pages are always being added to the end of a PDF document. For 
example, if you create a title page separately from the rest of the PDF document, you must add the document PDF 
to the title page PDF, even though it is much larger.

Be cautious when combining tagged and untagged PDF files. A partially tagged PDF document is difficult for readers 
to work with. Adobe Reader 6.0 assumes that if there are any tags, everything has been tagged. People using assistive 
technology are not aware that they are missing valuable content in such a partially tagged PDF document.

To insert a page into a PDF document:

1  Choose Document > Pages > Insert.

2  Choose the file from which you want to insert pages.

3  Choose the target location for the inserted pages in the existing PDF document.

The Insert Pages dialog box

4  Click OK.

5  If necessary, modify the tags tree to reflect the new logical structure of the PDF document.
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To replace a page in an existing PDF document:

1  Choose Document > Page > Replace.

2  Choose the file that contains the pages you want to use as replacements.

3  In the Replace Pages dialog box, identify the pages to be replaced and the replacement pages.

 
The Replace Pages dialog box

4  Click OK 

5  Select Yes to confirm the replacement process.

6  Modify the tags tree to reflect the new tags tree of the PDF document.

You have the option to delete pages from a PDF document. If the document was tagged, however, the structure in 
the tags tree for the deleted pages is left behind. The tags tree doesn’t connect to any data in the document. You may 
have large pieces of “empty” tags tree sections. 

If you need to work in the tags tree, prune the tags tree when you delete pages to help reduce document size, improve 
assistive technology performance, and reduce confusion.

To delete a page from an existing PDF document:

1  Choose Document > Pages > Delete.

2  In the Delete Pages dialog box, select the page you want to delete.

3  Click OK.

4  Prune the tags tree to remove tagged elements of the deleted pages.

 
The Delete Pages dialog box



72ADOBE ACROBAT 6.0
Section Eight: Manipulating Tagged PDF Structural Elements

 How To Guide

Combining documents from native applications

Acrobat 6.0 Professional and Acrobat 6.0 Standard let you combine documents to create single PDF documents. 
With this ability, you can combine word processor documents with slide presentations, spreadsheets, or Web pages.

Don’t use this capability to combine tagged and untagged PDF documents, however. If you combine these types of 
documents, the resulting PDF documents contain tagged and untagged content, and you will be unable to use the 
Advanced > Accessibility > Add Tags To Document tool, which makes manual repairs necessary.

Use Acrobat Professional when using the combining tools, because generally modifications are needed to the tags 
tree when this process is used. The conversion process in a combined document doesn’t always correctly interpret 
document structure due to the varying formats of the documents being combined.

To combine non-PDF documents:

1  Launch Acrobat 6.0 Professional.

2  Choose File > Create PDF > From Multiple Files. 

 
The Create PDF From Multiple Documents dialog box

3  In the Create PDF From Multiple Documents dialog box, select the files you want to combine to create the PDF 
document.

4  Click Move Up or Move Down to put the files in the desired order for the new PDF document.

5  Choose one or both of the following options:

• Include All Open PDF Documents. This option allows you to combine PDF documents without closing and 
relocating them.

• Include Most Recent List Of Files To Combine. This option allows authors who have been working on sections of 
a document represented by separate files to identify the recently used documents as part of the new PDF 
document.
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6  Click OK.

 
The Progress dialog box that appears as Acrobat 6.0 Professional creates the PDF document

Acrobat 6.0 Professional opens each application and converts the document to an accessible PDF document.

A PDF document created from a Microsoft Word document, a Microsoft PowerPoint document, and a Microsoft Excel document

The tags tree contains a <Document> tag and three <Part> tags representing the three combined documents. In the 
previous example, the author correctly tagged the text in the slide presentation and the table in the spreadsheet. 
Perform a Full Check on combined documents to ensure that all structural elements have been made accessible.

Options for combining documents

If you choose to combine PDF documents, avoid using tagged PDF documents. When you combine PDF documents, 
the conversion process attempts to retag content, resulting in a tags tree that requires extensive repair. It is best to 
combine either untagged PDF documents or documents from native applications.



74ADOBE ACROBAT 6.0
Section Eight: Manipulating Tagged PDF Structural Elements

 How To Guide

Choosing Combine In Adobe Acrobat from the Windows Explorer context menu produces one accessible PDF 
document; choosing Convert To PDF produces individual PDF documents that are accessible. 

To combine documents located in a common folder:

1  In Windows Explorer, select the files to be combined.

2  Press the AppKey or right-click to bring up the context menu.

3  Choose Combine In Adobe Acrobat.

4  Choose the files you want to combine to create the PDF document. Click Move Up or Move Down to put the files 
in the desired order for the new PDF document.

5  Choose one or both of the following options:

• Include All Open PDF Documents. This option allows you to combine PDF documents without closing and 
relocating them.

• Include Most Recent List Of Files To Combine. This option allows authors who have been working on sections of 
a document represented by separate files to identify the recently used documents as part of the new PDF 
document.

6  Click OK. Acrobat 6.0 Professional opens each application and converts the document to an accessible PDF 
document.

Creating PDFs from web pages
A Web page is only as accessible as the HTML source code it is based on. For example, if you used tables to design 
the layout of the web page (as is typical of most web pages) the source HTML text may not flow in a logical order. To 
get the most accessible web pages, create the pages to read in a logical order. Depending on the complexity of the web 
page, extensive tag correction may be required.

To ensure the HTML document is converted to tagged Adobe PDF:

1  Choose File > Create PDF > From Web Page. 

2  Select Settings.

3  Select Create PDF Tags.

4  Click OK.

To finish a PDF document:

1  Ensure that the document is optimized for accessibility. For information on adding alt text to images and links, 
see “Section Seven: Optimizing the Accessibility of Tagged PDF Documents” on page 55.

2  Test the PDF for accessibility. (See “Additional accessibility tests” on page 10.)
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Appendix A: Acrobat Distiller Options

Adobe lets you optimize the conversion process to PDF with Acrobat Distiller.

You can access the distiller either through Acrobat Distiller 6.0 or by choosing the Advanced menu item in Acrobat 
6.0 Professional or Acrobat 6.0 Standard.

Acrobat Distiller settings
Choose settings in Acrobat Distiller to best fit the kind of document you are creating.

The Acrobat Distiller main dialog box

To access Acrobat Distiller settings, do one of the following:

• Choose Start > All Programs > Adobe > Acrobat Distiller 6.0.

• In Acrobat 6.0 Professional or Acrobat 6.0 Standard, choose Advanced > Acrobat Distiller.

Setting types including High Quality, Press Quality, Standard, and Smallest File Size.

Some available settings include:

• Standard settings for Adobe PDF files that are displayed on the World Wide Web or an intranet, or that will be 
distributed through an e-mail system for on-screen viewing 

• High Quality settings for Adobe PDF files intended for desktop printers, digital copiers, CD-ROMs, or publishing 
proofs sent to a client

• Press Quality settings for Adobe PDF files that are printed as high-quality final output to an image-setter or plate-
setter

• The Smallest File Size settings for interim documents during the review stage
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For more information on setting and customizing settings, see the “Acrobat Distiller Options” chapter in the Adobe 
Acrobat online Help.

PDF compression options

You can set changes to the way PDF documents compress information for documents you are creating. Set the 
compression for each setting.

An eBook job option showing compression options in the General tab

To modify PDF compression options, do one of the following:

• Choose Start > All Programs > Adobe > Acrobat Distiller 6.0, and then choose Settings > Edit Adobe PDF Settings.

• In Acrobat 6.0 Professional or Acrobat 6.0 Standard, choose Advanced > Acrobat Distiller.

Compression choices include:

• If Object Level Compression is set to “Off,” the resulting document has readable structure for Acrobat 4 or later.

• If Object Level Compression is set to “Tags only,” the structure is readable by Acrobat 6 and later. The rest of the 
document is readable by earlier versions, but the document appears untagged.

• If Object Level Compression is set to “Full” (Acrobat PDF Optimizer options only), the document is readable only 
by Acrobat 6 and later.

• If Compression is set to “None,” this can result in large file sizes for some tagged files. Consider this option only if 
your expected audience uses older versions of Acrobat Reader.

Note: You are referring only to the compression applied to the object streams within the file. In the Distiller scope, there is 
also image compression (for example, JPEG or LZW). These are on the Images panel.
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An eBook Job Option showing the Compression options for images

For more information on PDF compression, see “PDF Compression” in the Adobe Acrobat Online Help documen-
tation.
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Appendix B: Working with Fonts

Common problems with fonts
The most common problems encountered with fonts involve fonts that do not provide adequate encoding. 

Some things you can do to eliminate font incompatibility problems include using the most recent version of Acrobat 
Distiller to create PDF, rather than using older releases of Acrobat Distiller. Do not use PDFWriter. 

Also, it can be helpful to perform the conversion using Acrobat Distiller on the same machine and system that was 
used to author the original document. This consistency eliminates problems that may arise if Acrobat Distiller is 
forced to substitute fonts because it is unable to find the font that was used in document creation.

Note: In some cases, TrueType fonts that have gone through a PostScript® driver and Acrobat Distiller can no longer be 
searched, copied, cut, or pasted. These results may also occur in the case of some “protected” fonts. Using Acrobat Distiller 
on the same system on which the PostScript file was created can help alleviate this problem. Use the Base 14 fonts and 
Type 1 fonts whenever possible as they rarely have these problems.
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Appendix C: Accessible Form Tables

Creating accessible tables presents some special challenges. Sighted people are able to recognize and orient 
themselves very quickly to large tables. A glance across the column headings and down the rows will, in most cases, 
allows sighted people to quickly grasp the general meaning and purpose of a table, although fully comprehending or 
processing its contents may take longer. A sighted person might be able to immediately recognize, for example, that 
only a few cells in the entire table are of personal interest or relevance. 

Creating accessible form tables – tables that contain data entry fields – adds to the challenge of creating accessible 
tables. Imagine completing fields in a table in an electronic form without a monitor. You could be listening to the 
form using a screen reader. What would you need to know, and what would you want to know, about the table and 
about each cell in the table to successfully complete the form?

Consider these aspects of accessibility when creating forms:

• You should be informed that the screen reader is about to read a table. 

• For orientation, you should know how many columns and rows the table contains.

• To convey the overall meaning of the table, the screen reader should read the column headings. 

• As the screen reader encounters each cell, you should know the column and the row number of the cell.

• If the table contains data fields, you should know the name of the data field and any special instructions for 
entering data. 

Recommendations for creating fields in tables
The most efficient way to create a multiple-column, multiple-row table is described in the Creating Form Tables 
section of the Acrobat online Help documentation.

To create multiple table fields:

1  Individually create a complete row of fields in the table. 

2  Select those fields by using Shift-drag, and then replicate them by selecting Advanced > Forms > Fields or selecting 
Create Multiple > Copies from the context menu. This will expand the first row to the rest of the table.

3  Edit the replicated fields one at a time. 

When you replicate the first row of data fields, Acrobat appends a unique row identifier to the end of each field’s 
name. This appendage, in effect, creates unique names for each field in the table. Acrobat separates the field’s original 
name with a period followed by the numerical value of the row. For example, FirstName.0... LastName.0..., 
Phone.0..., FirstName.1..., LastName.1..., Phone.1...

Creating data fields one at a time for such a table becomes proportionally more tedious as the size of the table 
increases. Each data field must be drawn and a unique name entered for it in the Field Properties dialog box. Do not 
use Copy and Paste in Acrobat to create data fields in the table unless you intend to have an exact duplicate of the 
copied field in some other location in the table. You cannot create unique names for copied fields: If you change the 
name of one table, the name of the other table also changes. Data entered into one field is reflected in its copy, and 
vice versa.
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When PDF Forms Access processes the table, it ignores the appended period and row number and analyzes the table 
as if all the data fields in each column were copies of one another. This analysis produces various undesirable effects. 
When the form table is initialized in Forms Access, the short descriptions for the datum elements in each row are 
given the correct row numbers. However, if the initialized file is immediately finished, none of the datum elements 
have short descriptions, and screen readers are unable to tell the reader in what field he or she is working.
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Appendix D: Adobe Standard Elements

The following standard Adobe element tag types appear in the New Tag sub-menu in the Tags tab Options menu, as 
well as in the Tag Type pop-up menu in the TouchUp Properties dialog box. Adobe strongly encourages the use of 
these tag types to provide the best results when repurposing tagged content.

Block-level elements
All elements that are comprised of text laid out in paragraph-like forms are referred to as block-level elements. All 
block-level elements are part of the document’s logical structure and are represented in the tags tree. Such elements 
can be further classified as container elements, special text elements, heading and paragraph elements, and label and 
list elements.

Container elements These are the highest level of elements and provide grouping of other block-level elements:

• Article element (Art) – A self-contained body of text considered to be a single narrative

• Division element (Div) – A generic block-level element or group of block-level elements

• Document element (Document) – The root element of a document’s tags tree

• Part element (Part) – A part element defines a large division of a document, and may group smaller divisions 
together, such as article elements, division elements, or section elements

• Section element (Sect) – A general container element type, comparable to Division <DIV Class=“Sect”> in 
HTML, which is usually a component of a part element or an article element

Special text elements These elements identify text that is not used in a narrative paragraph:

• Block quote element (BlockQuote) – One or more paragraphs of text attributed to someone other than the author 
of the immediate surrounding text.

• Caption element (Caption) – A brief portion of text that describes a table or a figure. A caption element is different 
from a label element, which identifies but does not describe, a table or a figure.

• Index element (Index) – A sequence of entries that contain identifying text and reference elements that point out 
the occurrence of the text in the main body of the document.

• Table of contents element (TOC) – An element that contains a structured list of items and labels identifying those 
items. A table of contents element has its own discrete hierarchy.

• Table of contents item element (TOCI) – An item contained in a list associated with a table of contents element.

Heading and paragraph elements These are paragraph-like block-level elements that include specific level headings 
and generic paragraphs (P). A heading element (H) should appear as the first child of any higher level division. Six 
levels of headings (H1 – H6) are available for applications that don’t hierarchically nest sections. 

Label and list elements These block-level elements are used for structuring lists:

• List element (L) – A list can be any sequence of items of similar meaning or other relevance.

• List item element (LI) – Any one member of a List. The immediate child elements of a list element should be list 
item elements. A list item element may have a label element (optional) and a label body element (required) as a 
child.
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• Label element (LBL) – A label can be a bullet, name, or number that identifies and distinguishes an element from 
others in the same list.

• List body element (LBody) – The descriptive content of a list item

Table elements  These are special structural elements for structuring tables:

• Table element (Table) – A table is a two-dimensional arrangement of data or text cells that contains table row 
elements as children and may have a caption element as its first or last child element.

• Table row element (TR) – One row of headings or data in a table. A table row element may contain table header 
cell elements and table data cell elements.

• Table data cell element (TD) – A table cell that contains non-header data.

• Table header cell element (TH) – A table cell that contains header text or data describing one or more rows or 
columns of a table.

Inline-level elements

Inline-level elements are used to identify a span of text having specific styling or behavior. They are differentiated 
from block-level elements, and may be contained in or contain block-level elements. The standard inline-level 
elements are:

• Bibliography entry element (BibEntry) – A description of where some cited information may be found, which 
may contain a label element as a child element.

• Quote entry element (Quote) – An inline portion of text attributed to someone other than the author of the text 
surrounding it. It is different from a block quote, which is a whole paragraph or multiple paragraphs, as opposed 
to inline text.

• Span entry element (Span) – Any inline segment of text. A common use of a span entry element is to delimit text 
associated with a given set of styling properties.

Special inline-level elements

Similar to inline-level elements, these elements are used to describe an inline portion of text that has special styling 
or behavior:

• Code entry element (Code) – Computer program text embedded within a document

• Figure entry element (Figure) – A graphic or graphic representation associated with text

• Form entry element (Form) – A PDF form annotation that can be or has been filled out 

• Formula entry element (Formula) – A mathematical formula

• Link entry element (Link) – A hypertext link embedded within a document associated with a PDF link annotation 
that goes to another place in the same document or another document

• Note entry element (Note) – Explanatory text, such as a footnote or endnote, that is referred to in the main body 
of text

• Reference entry element (Reference) – A citation to text or data found elsewhere in the document
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