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The National Association of State Units on Aging (NASUA), with funding 
from the Administration on Aging (AoA), has engaged Synergy Software 
Technologies Inc. to develop a software reporting structure for the State 
Program Report (SPR) section of the National Aging Program Information 
System (NAPIS). 

This effort was initiated to accomplish three primary tasks:  

1. Reduce SUA reporting burden, i.e., client detail information, system edits, 
validity checks, and requirements for transmission. 

2. Incorporate required information regarding the National Family Caregiver 
Support Program.  

3. Comply with Office of Management and Budget (OMB) reporting 
requirements regarding reporting classifications, e.g., race and ethnicity. 

The resulting system is the NAPIS State Reporting Tool (NAPIS SRT). The 
NAPIS SRT will help State Units on Aging to create, edit and validate SPRs 
and to create transmission files for submitting data to the AoA. Through this 
project, the NAPIS SRT will be provided to all State Units on Aging free of 
charge for use in either a hosted, web based, or locally installed model. 
Training on use of the system will also be provided to SUAs as part of this 
project. 

About NAPIS SRT 

NAPIS SRT offers several features that make preparing a State Program 
Report (SPR) faster and easier. 

 XML and DBF import - many database systems can export to XML and 
DBF files. Import files destined for NAPIS SRT need to conform to the 
appropriate schemas supplied by the AoA. 

 Clean and efficient spreadsheets for report data entry. The data entry 
spreadsheets are based directly off of the paper based SPR. 

 Error correcting tools - NAPIS SRT offers several tools to help you clean 
up data for export. 

 Flexible print options - you can print out one or more sheets of the report 
or the whole report quickly and easily. 

 Straight forward export - NAPIS SRT creates export files ready for 
transmission using simple procedures. 

Introduction 



 

4 NAPIS State Reporting Tool User's Guide 
 

About the Documentation 

The goal of the documentation is to describe the procedures and provide any 
extra information you will need to use the program. In the case of the printed 
manual, the documentation was not meant to be read cover to cover. If you 
are comfortable using the Windows® operating system, skip to Using 
NAPIS SRT  (on page 25) for an outline of how to use the software.  

Documentation Sections 

Installing NAPIS SRT (on page 6) - step by step instructions on how to 
install NAPIS SRT.   

Working in NAPIS SRT (on page 15) - for the novice computer user. 
Working in NAPIS SRT describes the parts of the screen and explains how to 
use screen features. 

Using NAPIS SRT  (on page 25) - step by step procedures used to get your 
data ready for transmission. The first part of the section outlines the process 
of using the program. 

Administering NAPIS SRT (on page 53) - describes way to customize the 
program and how to do a simple backup of program data. 

We are always looking to make our documentation better. Please contact 
Synergy Software support (email: info@synergysw.com or  phone: (802) 
878-8514) if you find any errors or have any comments or suggestions.  

 
 

Typographical Conventions 
Before you start using this guide, it is important to understand the terms and 
typographical conventions used in the documentation. 

For more information on specialized terms used in the documentation, see the 
Glossary at the end of this document. 

The following kinds of formatting in the text identify special information. 

Formatting convention Type of Information 
Triangular Bullet( ) Step-by-step procedures. You can follow these 

instructions to complete a specific task. 

Special Bold Items you must select, such as menu options, 
command buttons, or items in a list. 
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Emphasis Use to emphasize the importance of a point or for 
variable expressions such as parameters. 

CAPITALS Names of keys on the keyboard. for example, 
SHIFT, CTRL, or ALT. 

KEY+KEY Key combinations for which the user must press and 
hold down one key and then press another, for 
example, CTRL+P, or ALT+F4. 
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Installing NAPIS SRT is similar to installing most Windows® based 
programs. If you decide that you don't want to install NAPIS SRT, click the 
Cancel button at any time during the process.  

Please check the System Requirements (on page 13) to make sure your 
computer meets the minimum hardware specifications before installing the 
program.  

 To install NAPIS SRT 
1 Quit any open or running programs. 

2 Insert the NAPIS SRT CD into the CD-ROM drive.  Proceed with step 6 
if the CD runs automatically.  If it does not run, go to step 3. 

3 On the Windows® desktop, double-click My Computer. 
4 Browse to the location where you downloaded the file or to your 

computer's CD drive. 

5 Double-click on Setup.exe (The file may just say Setup, depending on 
your view in Windows Explorer.) 

6 Your computer should display the Welcome screen.  

 
7 Click Next>. 

Installing NAPIS SRT 
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8 Read through the license agreement and then click I accept the license 
agreement.   

 
9 Click Next>. 

10 Enter your name and the name of your organization on the Registration 
Information screen. 

 
11 Click Next>. 

12 Choose a directory for the program.  The default install directory is 
NAPIS SRT in the Program Files directory on the machine running the 
install program. (C:\Program Files\NAPIS SRT) 
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Depending on the software policies of your organization, you may need 
to install NAPIS SRT on a shared server.  Please check with your system 
administrator for guidance. 

To install NAPIS SRT in a different directory, click Browse.... 

 
13 When the Destination Folder is correct, click Next>. 

14 Choose whether or not you wish to backup files to allow for an 
installation roll-back. By selecting Yes, the install program backs up 
DLLs and any other components of the operating system that the program 
installation will change. A roll-back allows you to restore the operating 
system to its state previous to installing NAPIS SRT. 

Make any changes as necessary to the Backup File Destination Directory 
by clicking Browse.... 
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If you are unsure about roll-back, leave the default settings.   

 
15 Click Next>. 

16 Choose the Program Manager group where the install program will place 
the NAPIS SRT icon.  The Program Manager is the set of menus you see 
when you select Start->Programs or Start->All Programs in Windows®.  
Leave the default if you don't have a preference. 

 
17 Click Next>. 
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18 Select if the menu icons you chose in the previous step will be available 
to just your Windows login or to all people who log into the computer. 
This option only appears in Windows NT/2000 or Windows XP 
machines. 

 
19 Click Next>. 

20 The installation program can create an NAPIS SRT icon on your desktop.  
Choose Yes, create a shortcut...  to give yourself quick access to the 
program.  You can always access NAPIS SRT through the Start menu in 
Windows®. 

 
21 Click Next>. 
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22 Click the <Back button to make any changes to the installation settings.  
Click Next> to begin the install. 

 
23 The installation program will start copying files to the appropriate 

directory and make changes to your computer's settings.  Please wait 
while the installation program runs.  
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24 When the installation program finishes, you have the option of reviewing 
the release notes.  Check the View Release Notes box to kick off a web 
browser that will display the release notes. To exit the installation, click 
Finish. 

 
25 You will not need to reboot your computer. NAPIS SRT is ready to go! 
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The system requirements for NAPIS SRT are similar to the OmniaSystem® 
offered by Synergy Software. 

System Requirements for NAPIS State Reporting Tool for Windows 
98/Me/2000/XP: 
 256 MB available memory 
 400 MHz Pentium class III processor or better 
 Display resolution of 800x600 or higher 
 Microsoft Internet Explorer 5.5 or later with 128-bit encryption 
 

System Requirements 
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Working in NAPIS SRT describes screen features and basic procedures, 
including starting and exiting the program. 

If you are comfortable using Windows® based programs, you will probably 
want to skip most of this section. You maybe interested in the information in 
Formatting Columns (on page 20) which describes ways to customize the 
main list screen in NAPIS SRT.   

If you are not confident in using Windows or are new to using a computer, 
read through most of this section. It should help you better understand how to 
work in NAPIS SRT. 

Using NAPIS SRT (on page 25) contains step by step procedures on how to 
create, edit, and export program reports. 
 

Start and Log In 
 To start and log into NAPIS SRT 

1 Double-click on the NAPIS SRT  desktop icon.  

-OR- From the Windows Start menu, select Programs (or All Programs in 
Windows XP), NAPIS SRT, and then the NAPIS SRT icon. 

Working in NAPIS SRT 
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2 Your computer will display a screen with program information and then 
the NAPIS SRT Log In screen.   

 
3 If necessary, change the Database and System Database files. To change 

a file, highlight either the Database or System Database row. Click the 
Browse  button. Navigate to the correct file and click Open. If you are 
unsure about which files to use, leave the default. 

4  Click OK to start the program. 
 

Switching Databases 
You can switch to another NAPIS SRT database without exiting the program. 

 To switch to a different database without closing NAPIS SRT 
1 From the File menu, select Log In.... 
2 To change the Database file, highlight the Database row. The Database 

file stores the data and settings for your organization's SPRs. A valid 
database filename ends in .mbd.  

3 Click Browse . 

4 Navigate to the appropriate file. 

5 Click Open. 

6 To change the System Database, highlight the System Database row. The 
System Database stores important settings about the NAPIS SRT 
program, but not the actual data.  A valid System Database file ends in 
.mdw. 

7 Click Browse . 

8 Navigate to the appropriate file. 
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9 Click Open. 

10 Click OK in the Log In screen to access the new database. 
 

Data Tree 
NAPIS SRT displays the structure of a program report in a Data Tree.  Data 
trees organize the screen to make it easier to locate and enter information. 

In a data tree, individual sheets are grouped together under a section heading. 
Each heading is called a "node." Tree nodes can be "expanded" to display all 
the fields under them, or they can be "collapsed" to hide the fields from view.   

 

To expand a node, use your mouse to click on the plus sign   located to the 
left of the node. Notice that the plus sign that was just expanded has been 
replaced by a minus sign  . To collapse the node, click on the minus sign. 
 

To see the data "tree", 
imagine the upper left most 
node as the "root," with the 
"branches" (other nodes) 
extending off and to the 
right of the "root." 
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Menus 
The NAPIS SRT menus are located directly below the NAPIS SRT title bar. 
Menus give you access to all functions of the program.  NAPIS SRT contains 
these menus: File, Edit, View, Tools, Window, and Help. Other menus, such as 
Report, appear as you access different areas of the program. 

 

Toolbars 
NAPIS SRT contains contextual toolbars that appear below the program 
Menus. A toolbar is a row of screen buttons that allow you to quickly access 
program functions. 
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The buttons or icons that appear in the toolbars depend on the area currently 
open in NAPIS SRT.  If you would like more information about a button in 
the toolbar, hover your mouse over the icon. After a few seconds, you will 
see the icon label appear in a yellow box. 
 

Keyboard Shortcuts 
NAPIS SRT offers several ways to use the keyboard instead of the mouse.   

Moving Between Fields 

Use the UP ARROW and DOWN ARROW on the keyboard to move 
between fields. The ENTER key moves you to the next field. 

Shortcut/CTRL Keys 

Some frequently used NAPIS SRT menu options have shortcut keys, which 
are displayed to the right of the option. These shortcut keys can be used to 
access a function without having to open a menu. For instance, under the File 
menu, the Save option shows the shortcut key "CTRL+S."  To save without 
using the mouse, hold down the CTRL key while pressing "S."  

ALT Keys 

All menus and option buttons in NAPIS SRT have labels with one letter 
underlined. If the ALT key is pressed in combination with the underlined 
letter, the effect is the same as clicking on the menu or button with the 
mouse.  For example, the File menu can be opened by holding down the ALT 
key while typing an "F." Use ESC for Cancel and Close.  
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List or Grid Screens 
NAPIS SRT displays program reports in a List Screen. List Screens, also 
known as Grids, display several records in a list, similar to a spreadsheet.  
Each row contains one record. Columns divide each row, listing key 
information about each record. To open the record, double click on the row 
of the entry.   

Sorting Information 

You can sort the records in a list screen by clicking the column headings. 
Click once on the appropriate column heading. The records will sort 
themselves by the data that appears in the column. The program will sort in 
ascending order by default. Click one more time on the same column heading 
to sort the information in descending order.     

Refreshing List Screens 

Most list screens have a Refresh   button. As you add or edit records, the 
records displayed by a list screen may not reflect the most recent changes to 
the database.  When you click Refresh, NAPIS SRT will update the list 
screen with current data. 

Customizing List Screens 

NAPIS SRT also gives you options to customize the columns displayed on 
the screen - see Formatting Columns (on page 20) for more information. 

 
 

Formatting Columns 
NAPIS SRT allows you to format the columns of the Report list (grid) 
screen. You can change the size and number of columns in view, the sort 
order of the data, and the order of the columns themselves. 

 To adjust column widths 
1 Hover the mouse over the right border of a column heading. 

2 When the pointer becomes a double-headed arrow, click and hold down 
the mouse button. 

3 Drag the column border to the left or right.  
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4 Let go of the mouse button. 

 

 To adjust the column to fit the column contents 
1 Double-click the right border of the column heading. 
 

Changing the Column Order 
 To change the column order of a list screen 

1 In a list screen, click on the title of a column you need to move.  Hold the 
mouse button down. 

2 Move the mouse left or right as needed.   NAPIS SRT will display a grey 
line, showing you where the column will appear. 

3 Let go of the mouse button. The column should appear in the new 
location.   

------------------------------- OR -------------------------------  

1 In the list screen, right-click (use the alternate mouse button). 

2 In the menu that appears, select Format Columns....   

-OR- From the View menu, choose Format Columns.... 

 
3 In the Format Columns screen, highlight the column you wish to move in 

the Current Columns box.   

4 Click the Up or Down buttons as needed. The top of the list corresponds 
to the left side of the screen. 

5 Click OK.  
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Add or Remove Columns from View 
 To add or remove a column from a list screen 

1 In the list screen, right-click (click with the alternate mouse button). 

2 In the menu that appears, select Format Columns....   

-OR- From the View menu, select Format Columns.... 

3 In the Format Columns screen, highlight the column you wish to have 
appear in the Available Columns box.  If you wish to remove columns 
from view, highlight one or more columns in the Current Columns box. 

  
4 Click on the right arrow if you are adding a column. Click on the left 

arrow if you are removing a column. The double arrows will add (right) 
or remove (left) all columns. 

5 Click OK.  
 

Changing List Screen Sort Order 
You can easily change the order of the data that appears on a list screen. 

 To change the sorting of a list screen 
1 Click once on the appropriate column heading.  Examples: State Unit, 

Fiscal Year.  The records will sort themselves in ascending order by the 
data in the column. 

2 Click one more time on the same column heading to sort the information 
in descending order. 
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Exiting NAPIS SRT 
 To exit NAPIS SRT 

1 From the File menu, choose Exit. 

--------------------------------  OR ---------------------------------- 

1 Click on the X in the upper right most corner.  

--------------------------------  OR ---------------------------------- 

1 ALT+F+X 
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Using NAPIS SRT outlines the individual procedures used to create a 
transmission file. The checklist below describes the general process you will 
go through to get your data ready for transmission.  

NAPIS SRT Checklist 
1 Import an XML or DBF file (see "Importing Reports" on page 40) or 

spend time Creating a New SPR (on page 26). 

2 Edit the SPR (see "Editing Reports" on page 28) as needed to clean up 
data. 

3 Verify the data - sheet by sheet (see "Verifying a Sheet" on page 34) or 
the whole report (see "Correcting Errors" on page 38). 

4 Correct any errors (see "Correcting Errors" on page 38) that the program 
has found.  NAPIS SRT offers several error correction features, including 
the ability to print parts or all of the SPR. (see "Printing Reports" on 
page 47) 

5 Re-verify the report (see "Verifying a Report" on page 35). 

6 Export the report (see "Exporting a Signed (Verified) Report" on page 
45) to create a signed file (package) ready for transmission. 

 
 

Using NAPIS SRT 
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Creating a New SPR 
If you import from XML or DBF files (see "Importing Reports" on page 40), 
NAPIS SRT creates the new SPRs automatically. 

 To create a new state program report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Click New  on the toolbar. 

3 Enter the name of your State's Unit. Select your state's abbreviation under 
State ID.  

 
4 Enter the Fiscal Year Start Month, Fiscal Year, the From and To Date of 

the report and any Comments. You can view any of these items later on 
through Properties in the Report Data Entry screen (see "Deleting 
Reports" on page 40). 

5 Click OK. 

6 NAPIS SRT will bring you to the Report Data Entry screen.  

7 Begin data entry as outlined in Report Data Entry. 

8 As you work, click Save   periodically.  Click Save and Close  to 
close the report. 

 

The From and To dates 
need to be 10/01 and 
09/30 , matching the 
Federal fiscal year, to 
create a Verified report.  
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Copying Report 
Accomplishments 

NAPIS SRT can copy Developmental Accomplishments in Sections IV.A 
and IV.B from an existing report into a new one. 

 To copy report accomplishments from an existing report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to copy accomplishments from. 

3 Click New  on the toolbar. 

4 Enter the name of the State Unit.  Select your state's abbreviation under 
State ID.  

 
5 Enter the Fiscal Year Start Month, Fiscal Year, the From and To Date of 

the report and any Comments. You can view any of these items later on 
through Properties in the Report Data Entry screen (see "Deleting 
Reports" on page 40). 

6 Select Yes in Copy Accomplishments? 

7 Click OK. 

8 NAPIS SRT will bring you to the Report Data Entry screen.  

9 Begin data entry as outlined in Report Data Entry. 

10 As you work, click Save   periodically.  Click Save and Close  to 
close the report. 

 

The From and To dates 
need to be 10/01 and 
09/30 , matching the 
Federal fiscal year, to 
create a Verified report.  
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Editing Reports 
If you edit a report that has been Verified, you'll need to re-verify the report 
(see "Verifying a Report" on page 35) after saving your changes. 

 To edit an existing report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight a report you want to edit. 

3 Click Edit  on the toolbar. 

4 NAPIS SRT will bring you to the Report Data Entry screen.  

5 Begin data entry as outlined in Report Data Entry. 

6 As you work, click Save   periodically.  Click Save and Close  to 
close the report. 
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Report Data Entry 
NAPIS SRT uses clean, efficient spreadsheets for most of the data entry into 
an SPR. The look of the sheets is based on the paper SPR used to gather and 
report data. The spreadsheets are organized by the Title and Section.   

Using the Report Data Entry Screen 

To begin data entry, click on the plus sign  next to an appropriate section in 
the Navigation pane. You cannot enter data into most Section Headings. 
They are there to organize the data entry sheets within the report and display 
your progress.  A check mark means the section has been verified.  Lines in a 
section heading icon means that you've made changes that have not been 
saved.  A blank icon indicates that either the section has not been entered or 
all changes to that section have been saved, but not verified. You will see a 
lock icon on the required sections that must be filled out and verified to 
create a verified report. 

Each section contains one or more sheets, based on the paper version of the 
SPR.  You enter data directly into these sheets.  After highlighting an 
appropriate sheet, NAPIS SRT will display it in the Work pane.  Highlight a 
Data Entry Cell.  Use your keyboard to enter the number or text.  Use the 
ENTER key or the RIGHT arrow to move onto the next cell. 
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After verifying the data, (see "Verifying Data" on page 33) NAPIS SRT will 
display any errors in the Errors pane in the lower right. Use the Show Errors 

 button on the toolbar to bring the Errors pane in and out of view. To see 

an entire error description, highlight the error and click Description  on 
the toolbar. 
 

Moving through a Report 
The SPR has many sections and subsections.  NAPIS SRT offers multiple 
tools to move through an SPR as efficiently as possible. 

Navigation Toolbar 

NAPIS SRT displays the Navigation toolbar just above the Navigation and 
Work panes in the Report Data Entry screen. 

 

Most of the sheets are 
organized with the Total 
column on the left with 
overall Totals in the upper 
left.  If you are used to 
seeing number totals in the 
lower right, pay attention to 
the reversal of the total 
locations.  
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From left to right, here are the functions of the Navigation toolbar: 

 Previous - goes to the previous sheet in the section. 
 Next - goes to the next sheet in the section. 
 Expand All - expands all sections so you can see all sheets. 
 Collapse All - display just the sections in the Navigation pane. 
 Go To Sheet - highlight an error and go to the appropriate sheet causing 

the error. (Works only after you've tried to verify data. (see "Verifying 
Data" on page 33)) 

Tips for using the Navigation pane 
 Click on the plus signs  to expand Section Headings to see data entry 

sheets.   
 When you enter data into a sheet, you will see that the sheet and section 

icons have changed to indicate you've made unsaved changes.   
 After a sheet has been successfully verified the sheet icon will change to 

a checked icon. After all the sheets in a section have been verified, the 
section icon will also change to a checked icon. 

 

After verifying the data (see "Verifying Data" on page 33), NAPIS SRT will 
display any errors in the Errors pane in the lower right. Use the Show Errors 

 button on the toolbar to bring the Errors pane in and out of view. To see 

an entire error description, highlight the error and click Description  on 
the toolbar. 
 

Entering Data into Cells 
 To modify numbers or data within a sheet 

1 After creating a new report (see "Creating a New SPR" on page 26) or 
accessing an existing report (see "Editing Reports" on page 28), find the 
appropriate section and sheet with the cell you need to enter or modify.   
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2 The screen defaults to showing you the sheet in the first section.  Use the 
plus sign  to expand section headings to see sheets in the Navigation 
pane.  Highlight the appropriate sheet. 

3 The sheet of the section will appear in the Work pane to the right. 

4 Click in a cell.  Enter or modify information as needed.  Press ENTER or 
use the RIGHT ARROW to continue moving through the cells. 

5 When finished, click Save  or to exit the report, click Save and Close. 
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Verifying Data 
Before your exported data package can be transmitted to the AoA, it must be 
Verified. The verification process checks to make sure that a series of rules 
about the data in the report have been followed.   

NAPIS SRT verifies data at three levels: cell level, sheet, and report level.  

Cell Level Verification 

Cell level verification works differently than sheet and report level 
verification.  Cell level verification automatically checks to make sure that 
the data matches the rules as you make changes to each cell.  Sheet and report 
level verification require you to make changes and tell NAPIS SRT you are 
ready for verification by clicking a button. You can turn cell level 
verification on and off - see Customizing Verify Options for more details.  
By default, cell level verification is turned off.  

It makes sense to turn off cell level verification as you enter data.  If you are 
starting with a fresh report, entering data into the first cell will cause errors 
with all the rest of the cells in each sheet. Cell level verification is a great tool 
to help you clean up an existing report to prepare it for final verification, 
signature, and export. 

Sheet Level Verification 

Sheet level verification allows you to verify just the current sheet in the 
Report Data Entry screen. To use, navigate to a particular sheet in an SPR. 

Once you see the sheet in the Work pane, click Verify Sheet.    NAPIS 
SRT will verify the current sheet and let you know of any errors. See 
Verifying a Sheet (on page 34) for detailed instructions. 

Report Level Verification 

An SPR will need to pass Report Level verification before receiving a 
signature for the AoA. To verify a report, highlight it on the Reports list 
screen and click Verify Report. NAPIS SRT will check all the data in the 
report.  For more details on report verification, please see Verifying a Report 
(on page 35). 
 



 

34 NAPIS State Reporting Tool User's Guide 
 

Verifying a Sheet 
When you verify a sheet within an SPR, an Error pane will appear in the 
lower right of the screen. Numbers in any cells related to the errors will 
change color. You can customize the colors that NAPIS SRT uses for error 
cells.  See Customizing Verify Options for more details. 

 To verify a sheet within an SPR 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you need to edit and verify. 

3 Click Edit  on the toolbar. 

4 Navigate to the the appropriate sheet in the Navigation pane. 

5 Highlight the sheet so that NAPIS SRT displays it in the Work pane. 

6 Click Verify Sheet   on the toolbar. 

 
7 NAPIS SRT will show any errors in the Errors pane displayed below the 

Work pane. Click Show Errors  on the toolbar to bring the Errors 
pane in and out of view.  
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8 To view a description of the error, highlight the item you wish to see in 

the Errors pane and click Description . Click OK after viewing the 
description. 

9 If the sheet was successfully verified, you will see a check on the 
appropriate sheet in the Navigation pane. 

 

Verifying a Report 
Even if you have verified each sheet within an SPR, you will still need to 
verify the whole report to export it to a file (see "Exporting Reports" on page 
43) ready for transmission. If you have not yet entered data into certain parts 
of the report, Verify will skip over non-required sections with all zeros. 

When you verify an SPR with errors, an Error pane will appear in the lower 
right of the screen. Numbers in any cells related to the errors will change 
color. You can customize the colors that NAPIS SRT uses for error cells. See 
Changing Report Colors (on page 55) for more information. 

Required Sections for Report Verification 

All sections listed below must have values (non-zero) and be error free before 
NAPIS SRT can export the SPR to an SRT file ready for transmission. 

 I.A 
 II.A 
 II.B 
 II.C 
 II.D 
 III.A 
 III.B 
 III.C 
 III.D 

 To verify a report for signature  

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you want to verify. 

3 Click Verify Report  on the toolbar. 

You can print the list of 
errors displayed in the 
Error Pane.  From the File 
menu, select Print and 
then Print Errors....  See 
Printing Errors (on page 
38) for more information. 
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4 NAPIS SRT will display the Report Data Entry screen. It will take a 
minute or two (or longer depending on the speed of your computer) for 
the program to verify the whole report.   

 
5 NAPIS SRT will show any errors in the Errors pane displayed below the 

Work pane.  Click Show Errors  on the toolbar to bring the Errors 
pane in and out of view.  

6 To view a description of the error, highlight the item you wish to see in 

the Errors pane and click Description .  Click OK after viewing the 
description. 

 To find an error listed in the Error pane, highlight the error.  Click Go to 
Sheet  .   Please see Correcting Errors (on page 38) for more tips on 
correcting problems that NAPIS SRT finds. 

1 If the report was successfully verified, the program will prompt you. 

Click OK at the prompt. Click Save and Close  to save and close the 
verified report. 

 

You can print the list of 
errors displayed in the 
Error Pane.  From the File 
menu, select Print and 
then Print Errors....  See 
Printing Errors (on page 
38) for more information. 



 

 Using NAPIS SRT 37 
 

 

------------------------------------- OR -------------------------------------------------- 

 To verify a report from within the Report Data Entry screen 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you need to edit and verify. 

3 Click Edit  on the toolbar. 

4 On the Report Data Entry screen, click Verify Report  on the toolbar. 

5 NAPIS SRT will show any errors in the Errors pane displayed below the 

Work pane.  Click Show Errors  on the toolbar to bring the Errors 
pane in and out of view.  

6 To view a description of the error, highlight the item you wish to see in 

the Errors pane and click Description .  Click OK after viewing the 
description. 

7 To find an error listed in the Error pane, highlight the error.  Click Go to 
Sheet  . Please see Correcting Errors (on page 38) for more tips on 
correcting problems that NAPIS SRT finds. 

8 If the report was successfully verified, the program will prompt you.  

Click OK at the prompt. Click Save and Close  to save and close the 
verified report. 
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Correcting Errors 
After verifying a report or sheet, you will probably see a list of errors that 
NAPIS SRT has found.  In a report as complex as the SPR, it can be difficult 
to find which piece or pieces of data are causing the problems. Try these 
ideas to help resolve report errors:   

 You can print out the errors in the Error pane, if it makes it easier for you 
to read. When the Error pane is in view, go to the File menu and select 
Print and then Print Errors.... 

 Use the Error pane to easily shift to the sheets that are causing problems. 

Highlight an error and either double-click or click Go To Sheet  on 
the toolbar to go to the appropriate sheet. 

 If it's not easy for you to see which cells are causing problems, try 
changing the color of the error cells. See Customizing Verify Options for 
details. 

 Turn on cell level verification (see "Verifying Data" on page 33). Cell 
level verification automatically checks for errors as you enter data. Cell 
level verification can be helpful if you want to see how changing one cell 
will affect other data throughout the report. See Customizing Verify 
Options for information on how to turn on and off cell level verification. 

 If you choose to use cell level verification, you can also have the 
program beep whenever you enter a value that causes an error.  Please 
refer to Customizing Verify Options for details. 

 Try printing or exporting a sheet to see the data in a different format. See 
Printing a Sheet (on page 48) and Exporting a Sheet (on page 44) for 
more information. 

 

Printing Errors 
You can print the list of errors found in the Errors pane. 

 To print a list of errors 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you need to edit and verify. 

3 Click Verify Sheet    -OR- Verify Report . 

4 NAPIS SRT displays all problems found in the Errors pane.   

5 Click on the down arrow next to the Print Active Sheet button. Select Print 
Errors. 

-OR- From the File menu, select Print and then Print Errors.... 
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6 Click OK to print. 

Error List Sample 

 

 
 

Viewing Report Properties 
 To view the properties of a report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to view. 

3 Click Edit  on the toolbar. 

4 Click on Properties . 
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-OR- From the File menu, select Report Properties.  -OR- F4 

 
5 When finished viewing report properties, click OK. 
 

Deleting Reports 
 To remove a report from NAPIS SRT 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to delete. 

3 Click Delete  on the toolbar. 

-OR- Select Delete Report from the Edit menu. 

4 At the prompt, click Yes to continue or No to cancel. 
 

Importing Reports 
NAPIS SRT can import SPRs from properly formatted XML and DBF files. 
Schemas for XML and DBF files can be found through the AoA's website: 
http://www.aoa.gov/prof/agingnet/napis/napis.asp 

You can also import from more than one file at a time.  Click Browse... in 
step 5 to import SPRs from additional files.   

 To import SPRs into NAPIS SRT 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

http://www.aoa.gov/prof/agingnet/napis/napis.asp
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2 Click Import  on the toolbar. 

-OR- Select Import... from the Tools menu. -OR- CTRL+I 

3 If necessary, navigate to the folder of the import file. Highlight the file 
you wish to import. The file must be a DBF or an XML file.  (reports.dbf  
or *.xml) 
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4 Click Open. 

 
5 In the Import screen, check the reports you want to import. Click 

Browse... to select SPRs from more than one import file. Use Select All to 
check all files and reports. Deselect All removes all checks. 

6 Click Import to bring all checked reports into NAPIS SRT.  

7 Click OK at the prompt. 
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Exporting Reports 
NAPIS SRT offers two types of exports: a full report export that creates files 
suitable for transmission to the AoA and a sheet export for use in 
troubleshooting reports. 

The sheet export allows you to export one sheet at a time into a variety of 
different formats. Use the sheet export to take data from the report and pull it 
into other applications.   

The export creates a signed file ready for transmission to the AoA. A report 
must be verified (see "Verifying a Report" on page 35) before you can export 
it from NAPIS SRT.  
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Exporting a Sheet 
NAPIS SRT's printing mechanism exports individual sheets of a program 
report. If you need to export more than one sheet, repeat the procedure below 
from step 4. 

Use the export to pull information into Microsoft Excel® and other third 
party programs. Files created using the sheet export cannot be imported by 
NAPIS SRT. 

Export Options 

Here's a list of some of the more frequently used export options offered by 
NAPIS SRT:   

 Acrobat Format (PDF) - PDFs are a read-only forma and typically 
opened with Acrobat Reader. 

 Crystal Reports (RPT) - report format used by Crystal Reports®, a 
common report writing software package. 

 HTML 3.2 - HyperText Markup Language - this is the file format most 
commonly used by web sites.  

 HTML 4.0 -  a newer version of the HTML standard - see HTML 3.2 
 MS Excel 97-2000 - output to an Excel spreadsheet including header 

information. 
 MS Excel 97-2000 (Data only) - output only the data to an Excel 

spreadsheet.  
 MS Word® - convert the sheet into a Microsoft Word document. 
 Rich Text Format - convert the sheet into a word processing document 

that saves some formatting information. All most all word processors can 
open an RTF file. 

 Separated Values (CSV) - or comma separated values - a text file where 
data is separated by commas. Most spreadsheet and database applications 
(such as Microsoft Access®) can import CSV files. 

 Tab-separated text - another way of delineating data in a text file.  
 XML - Extensible Markup Language - a text file where data is delineated 

with tags. 

 To export a sheet of a report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to export from.  

3 Click Print  on the toolbar. 
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-OR- Select Print... from the File menu.  -OR- CTRL+P  

4 Highlight the sheet you wish to export. Make sure it appears in the 
Preview pane to the right. The Export ignores any check marks in the left 
pane. 

5 Click Export Active Sheet . 

-OR- From the Tools menu, select Export Active Sheet... -OR- CTRL+E 

 
6 In Export, choose a Format and a Destination. If you are unsure of the 

Destination, choose Disk file. Disk file saves the export to a local or 
networked drive. 

7 Click OK. 

8 Click OK in Export Options to have NAPIS SRT finish the export. 
 

Exporting a Signed (Verified) Report 
NAPIS SRT can only export verified SPRs (see "Verifying Data" on page 
33) to SRT files.  

 To create a signed export package ready to go to the AoA 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to export. 

3 If the report is not yet verified, click the Verify   icon on the toolbar.  
See Verifying Data (on page 33) for more details on the verification 
process and error correction. 

4 If the report is verified, then click Export  on the toolbar. 
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-OR- From the Tools menu, select Export.... -OR- CTRL+E 

 
5 Navigate to the folder where you want to store the export. 

6 Enter a File name. 

7 Click Save. 

8 NAPIS SRT will create a signed export file ending in ".srt". 

9 Click OK when prompted. 
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Printing Reports 
NAPIS SRT can print individual sheets from a report or the entire program 
report. When you click Print on the Reports list or while changing a program 
report, NAPIS SRT brings you to the Print Preview screen. Print Preview 
looks like the Report Data Entry screen and you'll use them in similar ways. 
Use the Navigation pane on the right to select which sheets you wish to print. 
The Preview pane allows you to view the sheet selected (highlighted) in the 
Navigation pane. 
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Print Toolbar 

The Print Toolbar contains two rows of icons.   

The top row: 

 Print - to the left of Print <options> is a down arrow that gives you a 
menu with other printing options. Clicking the button or selecting from 
the menu actually sends the report to the printer. 

 Export Active Sheet - export the sheet visible in the Preview pane. See 
Exporting a Sheet (on page 44) for details on how to use this option. 

 Zoom - change the magnification of the sheet. 

The bottom row: 

 Previous - selects the previous sheet in the report and displays it in the 
Preview pane.  

 Next - selects the next sheet in the report and displays it in the Preview 
pane.  

 Expand All - view all sheets in the report under their respective section 
headings in the Selection pane. 

 Collapse All - view only section headings in the Selection pane. 
 Select All - select all sheets and sections. Places a check mark in every 

box. 
 Deselect All - removes all checks or selections.   

 

Printing a Sheet 
 To print out a single sheet from the Report Data Entry screen 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to print out.  

3 Click Edit  on the toolbar. 

4 Highlight the sheet you want to print. 

5 Click Print Active Sheet in the Report Data Entry screen. 

6 Click Print Selected Sheets in the Print Preview screen. If you wish to 
cancel printing, click on the lower X in the upper right corner.  

7 Select a printer. Change printing Preferences as needed. 

8 Click Print. 
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------------------------------------- OR ----------------------------------------- 

 To print out a single sheet from the Reports list screen 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to print out.  

3 Click Print  on the toolbar. 

-OR- Select Print Report... from the File menu.  -OR- CTRL+P  

4 Highlight the sheet you wish to print so it appears in the right Preview 
pane. If you wish to cancel printing, click on the lower X in the upper 
right corner. 

5 Click on the Down arrow to the right of the Print  <option>  button. Select 
Print Active Sheet. This is the equivalent of printing the "Current Page" in 
a program such as Microsoft Word®. 

 
6 Select a printer. Change printing Preferences as needed. 

7 Click Print. 
 

Printing Selected Sheets 
 To print out select sheets from a report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to print out.  

3 Click Print  on the toolbar. 

-OR- Select Print Report... from the File menu.  -OR- CTRL+P  

4 In the Print Preview screen, select which sheets or section of the report 
you'd like to print by checking the boxes.    

5 Click Print Selected Sheets on the toolbar. NAPIS SRT will print all the 
sheets checked in the right Navigation pane. 

6 Select a printer. Change printing Preferences as needed. 
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7 Click Print. 

Report Sample 

 

Printing an Entire Report 
 To print out an entire report 

1 Click Reports  on the toolbar. 

-OR- Select Reports from the View menu. -OR- CTRL+R 

2 Highlight the report you wish to print out.  

3 Click Print  on the toolbar. 

-OR- Select Print Report... from the File menu.  -OR- CTRL+P  
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4 To print the entire report, click on the Down arrow to the right of the Print 
<options> button.  Select Print Entire Report. 

 
5 Select a printer. Change printing Preferences as needed. 

6 Click Print. 
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Administering NAPIS SRT discusses how to do a simple backup of the 
NAPIS SRT database and how to change program options.  
 

Simple Backup 
Regular backups of the NAPIS SRT database are crucial to a swift recovery 
in the event of a major electrical disruption or other disaster. This section 
includes instructions for a simple backup, but Synergy Software recommends 
that backups be done to removable media such as tape drives. Please consult 
your system administrator for information about your organization's backup 
procedures. 

The files containing the NAPIS SRT data (usually NAPISSRT.mdb and 
NAPISSRT.mdw) will need to be backed up at the end of each workday 
when the software is in use. A typical rotation schedule for backup includes 6 
media  - one for each weekday and two for Fridays. The Friday media is 
taken off-site and the older backup is returned on Monday. Your backup 
needs may vary based on how often you use NAPIS SRT and your security 
procedures. Please consult your system administrator if you need further 
recommendations on backup based on your individual needs and available 
equipment. 

Please note that NAPIS SRT stores service maps with the appropriate SAMS 
database. Backups of the SAMS database will also backup the service map.   

 To do a simple backup of NAPIS SRT 
1 From Start in the Windows® Task Bar, select Programs (or All 

Programs), the Accessories folder and then Windows Explorer.  
2 Find the database files named in the NAPIS SRT Log In screen.  In a 

local install, the file is usually located in C:\Program Files\NAPIS SRT. 

3 Copy the NAPIS SRT database files, usually named NAPISSRT.mdb and 
NAPISSRT.mdw, to a different computer or hard drive. 

 

Administering NAPIS SRT 
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Customizing Verify Options 
By default, NAPIS SRT's cell level verification is turned off. Use the 
procedure outlined below to change cell verification settings.  You can also 
have NAPIS SRT produce a sound when it finds an error.  See Verifying 
Data (on page 33) for more information about NAPIS SRT's verification 
features. 

 To change NAPIS SRT's verification options 

1 Click Options  on the toolbar. 

-OR- From the Tools menu, select Options. 

 
2 When Automatic Verify under the Verify heading is set to Yes, NAPIS 

SRT will check any changes made on each cell or field on the report 
against the rest of the report for errors. This feature is useful for getting 
rid of the last few errors in a report, but you may find it in the way when 
initially importing or creating a report. Select No in Automatic Verify to 
prevent the program from doing any verification until you click Verify. 

3 To have NAPIS SRT produce a sound when an error is found, select Yes 
in Beep On Error.  To make the program silent upon finding an error, 
select No. 

4 When finished making changes, click OK. 
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Changing Report Colors 
You can customize the colors NAPIS SRT displays on program reports for 
data verification (see "Verifying Data" on page 33). 

 To change the colors displayed on a program report  

1 Click Options  on the toolbar. 

-OR- From the Tools menu, select Options. 

 
2 Under the Report Color heading, choose an Error Cell ForeColor and an 

Error Cell BackColor. The ForeColor is the color of the text in the cell. 
The BackColor is the cell background color. 

3 To choose a color, click on the box to the right of Error Cell ForeColor 
or Error Cell BackColor.   

4 Click the Browse  button. 

5 Select a color. 

6 Click OK to close the Color screen. 

7 When you are finished making changes, click OK to close the Options 
screen. 
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A 
AoA 
Federal Administration on Aging. Part of the  
Dept. of Health and Human Services. Website: 
http://www.aoa.gov 
 

D 
DBF 
A database file using the xBase (dBase) format. 
NAPIS SRT can import SPRs from DBF files 
formatted to the schema provided by the AoA. 
 

E 
Export Package 
An export file produced by NAPIS SRT with 
one or more program reports. An export package 
maybe verified (signed) or unverified 
(unsigned). 
 

N 
NAPIS 
National Aging Program Information Systems - 
see http://www.aoa.gov for more information. 
 

S 
Sheet 
A section or part of an SPR. A sheet in NAPIS 
SRT corresponds to a sheet in the printed version 
of the SPR. 
 

Signature or Signed 
When a verified SPR is exported, the export file 
receives a signature that the data is ready for 
transmission. 
 

SPR 
State Program Performance Report - required by 
the AoA from each state. Reports information on 
the effectiveness of social programs geared 
towards the elderly under the Older Americans 
Act. Also the extension of a verified, signed file 
ready for transmission to the AoA. 
 

SRT 
State Reporting Tool - Software developed 
through a grant from the AoA and offered by 
Synergy Software Technologies Inc. to verify 
SPRs transmitted to the AoA. 
 

X 
XML 
Extensible Markup Language - a way of 
formatting data files. Uses tags similar to HTML 
(webpages) to delineate data. NAPIS SRT can 
import from XML formatted to the schema 
provided by the AoA. 
 

Glossary of Terms 

http://www.aoa.gov
http://www.aoa.gov
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accomplishments, report • 27 

B 
backup • 53 

C 
cell level verification • 33, 38 
checklist • 25 
colors, report • 55 
columns, customizing • 20, 21, 22 
copy accomplishments • 27 

D 
data entry • 29 
data tree • 17 
database file • 15, 53 

switching • 16 
DBF files • 40 

E 
error 

correction • 38 
printing • 38 

exiting • 23 
export • 43 

reports • 43 
sheet • 44 
signed packages • 45 

F 
Federal Fiscal Year • 26 
file formatting, XML and DBF • 40 

G 
grid screens •  See list screens 

I 
import • 40 
installing • 6 

K 
keyboard shortcuts • 19 

L 
list screens • 20, 21, 22 
log in • 15 

M 
menus • 18 
modifying reports • 28 

N 
navigation toolbar • 30 
new report • 26 
nodes • 17 

O 
OMB • 3 
options • 54, 55 

P 
packages •  See export 
print reports 

error • 38 
reports • 47 
sheet • 49, 50 

properties, report • 39 

Q 
quiting • 23 

R 
refresh • 20 
remove 

report • 40 
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S 
schemas • 40 
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sheet 
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