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NETWARS Network Model Configuration and Navigation Identification
Identification

Document Identification

Document Title: NETWARS Network Model Configuration and Navigation
Version: Final (OPNET 229)

Software Identification

Product Name: NETWARS
Product Release: 5.1

Documentation Conventions

This documentation uses specific formatting and typographic conventions to present the 
following types of information:

• Objects, examples, and system I/O

• Object hierarchies

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in standard Courier typeface:

C:\Netwars\User_Data\Projects

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier typeface:

/* determine the object ID of packet’s creation module */ 
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<NETWARS path>\Scenario_Builder\op_admin\err_log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:

Edit > Preferences > Advanced
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Documentation Conventions NETWARS Network Model Configuration and Navigation
Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press the 
<button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you should press 
the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps. 
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NETWARS Network Model Configuration and Navigation Document Revision History
Document Revision History

Release Date
Product 
Version Chapter Description of Change

June 27, 2005 5.2 Final 2

3

Inserted new figure: Figure 2-4 Adding Units via Object Palettes

- Added section “Using Configuration Utilities” to describe device 
configuration wizard for promina and multiplexer circuits.

- Replaced term “subnet” with “OPFACS and Organizations” 
(where more appropriate to NETWARS users.)

- In Procedure 3-4, clarified where to find specific protocol user’s 
guides ~ provided as individual chapters in the OPNET Standard 
Models User Guide (NETWARS menu accessible.)

April 4, 2005 5.1 Draft All Preliminary version.
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1 Introduction

NETWARS Overview

The Command, Control, Communications, and Computer Systems Directorate 
of the Joint Staff, in partnership with the Defense Information Systems Agency, 
Directorate for Technical Integration Services, developed Network Warfare 
Simulation (NETWARS). NETWARS provides modeling and simulation (M & S) 
capabilities for measuring and assessing information flow through strategic, 
operational, and tactical military communications networks. Analyzing the 
results from NETWARS can provide considerable utility in determining which 
communication systems might be overloaded during selected times in a 
particular scenario, and can assist with making prudent acquisition planning 
decisions. 

Document Overview

NETWARS provides a variety of features that are specifically designed to 
increase productivity and efficiency in your modeling and simulation projects. 
These features are designed to make it easier and faster for you to configure 
and navigate your network model, understand its configuration, and extract 
information to include in your reports.

This user’s guide, NETWARS Network Model Configuration and Navigation, 
builds on information provided in the NETWARS User’s Manual and NETWARS 
Technical Reference Manual to further describe and explain some of the 
powerful modeling and simulation features available to you in NETWARS.

This user’s guide explores the following topics:

• File Management, including:

— Managing file directories,

— Using object libraries and palettes,

— Accessing log files, product info and modules,

— Managing and recovering project files, and

— Refreshing and packaging.

• Configuration Helpers, including:

— Editing attributes (for one object or a group of objects), 

— Configuring protocols, and

— Using the Model Assistant to automate frequently applied scenario 
changes.
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• Visualization and Navigation, including:

— Finding and editing objects,

— Viewing and editing demands,

— Visualizing routing protocols and link loads,

— Sizing and scaling icons,

— Setting display preferences, and

— Visualizing the effects of changing the network time.

• Reports, including:

— Generating Summary Tables to view summary information for a scenario 
in table format,

— Creating User-defined Report Tables to get a quick configuration 
overview of specific attributes of a number of network objects, and 
generate publishable HTML reports, and

— Accessing Capacity Planning Web Reports to review the current state of 
a scenario after performing a capacity planning evaluation. 

Referenced Documents

• NETWARS User’s Manual, 2005-1 Final (OPNET 162), April 1, 2005.

• NETWARS Technical Reference Manual, 2005-1 Final (OPNET 176), April 
1, 2005.
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2 File Management

NETWARS network models are comprised of many significant files. The better 
you understand these files—where they are stored and what data they 
contain—the better you can manage your NETWARS environment.

Information provided in this chapter can help you to locate and identify important 
NETWARS files, as well as: manage the Organization and OPFAC Library, 
manage log files; display NETWARS product information, select product 
modules; backup NETWARS projects, and prepare a support log file to send to 
technical support if you should ever need assistance.

Manage File Directories

Two directories containing folders that, by default, store key NETWARS files 
include:

• C:\Netwars\Scenario_Builder\ — Stores administrative and model 
files.

• C:\Netwars\User_Data\ — Stores IER Text Files, OPFACS, 
Organizations, Projects, SB Data, Terrain Data, and Traffic Data files.

Administrative Files

Administrative files are located, by default, in the 
c:\Netwars\Scenario_Builder\op_admin folder. Files stored here 
include:

• Environment database (env_db) file — Stores NETWARS environment 
attributes (or preferences).

• Error log (err_log) and message log (session_log) files,

• ‘bk’ sub-directory containing backup files, and

• ‘tmp’ sub-directory containing temporary NETWARS-generated files.

Model Files

Model directories are located, by default, in the 
c:\Netwars\Scenario_Builder\op_models folder. You can change the 
default location where model files are stored by editing the ‘mod_dirs’ global 
environment attribute which contains the list of model directory pathnames.

Procedure 2-1   Setting Preferences for Model Directory Pathnames

1 In the System Editor or Scenario Builder, select Edit > Preferences > Advanced. 
The Advanced Preferences dialog box displays.
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2 Locate the ‘mod_dirs’ attribute, and double-click it to open it in another window.

Figure 2-1   Advanced Preferences dialog box

3 Edit, add to, or delete from the list of model directory pathnames.

Figure 2-2   mod_dirs Attribute dialog box

4 Click OK to accept the attributes values and close the dialog box, or Cancel to 
close the dialog box without making any changes to the attribute. 

End of Procedure 2-1
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Project Files

Each project has a single .prj file in a project folder under 
C:\Netwars\User_Data\Projects. The project folder and the .prj file 
have the same name as the project itself. A NETWARS project may make use 
of other library files.  Library files may be used by any number of projects.  The 
only way to know which library files are included in a project is to examine the 
contents of the project.

Scenario Files

Each project consists of one or more scenarios. Each scenario is a subfolder 
under the main project folder. The scenario consists of a file with the extension 
‘.nt.m’ and possibly an XML file with the same base name.

Traffic Files
Demand Files

A demand file for each scenario, if one exists, would be located in the 
NTWARS\data\User_Data\Projects\<Project>\<Scenario> 
directory. Its name would be the Project Name followed by the Scenario Name 
connected with a plus ('+') and with an extension of '.dm'. 

IER Text Files

All IER Text files are available for use by every scenario. IER Text files are 
located in the C:\Netwars\User_Data\IER_Text_Files directory and 
have an extension of '.txt'.

Organization Files

Organizations are represented by '.nt.m' files located in the 
C:\Netwars\User_Data\Organizations directory. The project may 
include any, all, or none of the template organizations.

OPFAC Files
The OPFACs used by a project/scenario may reside in any folder under the 
C:\Netwars\User_Data\Opfacs directory. NETWARS OPFACs consist of 
‘.nd.m’ and ‘.nt.m’ files. The ‘nt.m’ file includes all the OPFAC specific 
information while the ‘.nd.m’ file is only necessary for an OPFAC to appear in 
a palette.

The names of the various files that relate to a specific OPFAC have similar base 
names, although not identical.
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Manage the Organization and OPFAC Libary

In NETWARS, the Organization and OPFAC library is divided into two parts: 

• Custom Library—Contains OPFACs and organizations that were created or 
modified by the user. All users have privileges to edit the contents of the 
custom library. You can make copies of the standard templates, store them 
in the custom library and then make changes to them. OPFACs and 
organizations in the custom library are called custom templates.

• Pre-Configured Library—Contains doctrinal OPFACs and organizations. 
OPFACs and organizations in the pre-configured library are called 
pre-configured templates. Only the local administrator has privileges to 
modify the contents of the pre-configured library, however any user can use 
its contents when building scenarios. A scenario can contain a combination 
of pre-configured and custom templates. 

It is also possible to have sub-folders within the above set of folders. Use of 
sub-folders allows you to further categorize the organizations and OPFACs 
within a service folder. 

The figure below shows an example of a library treeview with custom and 
pre-configured OPFAC and organization folders.

Figure 2-3   Library Treeview with Custom and Pre-Configured Folders
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In addition to the above treeview interface, you can also use objects from the 
OPFAC and organization palettes to build the scenario. To build a scenario, 
you can drag-and-drop OPFACs and organizations from the palettes on to 
the workspace.

Figure 2-4   Adding Units via Object Palettes
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Edit the Library
You can edit the contents of the Organization and OPFAC library. You can 
rename templates, save them under a different name or delete them from the 
library. Right-click menu options are provided for performing these operations.

If you login using the local administrator profile, you can perform the above 
operations on the pre-configured and custom sections of the library. If you login 
as a regular user, you can change the OPFACs or organizations in the custom 
section, but not the pre-configured section.

Procedure 2-2   Renaming a Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Rename Template.

Figure 2-5   Renaming a Template OPFAC/Organization

2 Type a new name for the selected OPFAC/organization in the dialog box that 
displays, and change the folder to which the OPFAC/organization belongs. You 
can also create a new folder to store this OPFAC/organization.

The selected OPFAC/organization will be renamed, and if you changed the folder, 
the files will be moved to the new location on disk. The treeview is also 
automatically updated.

End of Procedure 2-2

Procedure 2-3   Saving a Template OPFAC/Organization As

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Save As.
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2 Type a new name for the selected OPFAC/organization in the dialog box that 
displays, and change the folder to which the OPFAC/organization belongs. You 
can also create a new folder to store this OPFAC/organization.

A copy of the selected OPFAC/organization will be made, and if you changed the 
folder, the files will be moved to the new location on disk. The treeview is also 
automatically updated.

End of Procedure 2-3

Procedure 2-4   Deleting a Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Delete Template.

2 Confirm the deletion as prompted to delete the selected OPFAC/organization from 
the library.

The selected OPFAC/organization will be removed from its current location on 
disk. The treeview is also automatically updated.

End of Procedure 2-4

Manage Error and Message Logs

The NETWARS error log contains descriptions and stack traces for recoverable 
and non-recoverable errors. This information is useful to NETWARS Technical 
Support in diagnosing and addressing application errors. The error log has a file 
name of ‘err_log’ and is stored, by default, in the 
c:\Netwars\Scenario_Builder\op_admin folder.

The NETWARS message log contains status updates that monitor the 
performance of NETWARS. The message log is also stored, by default, in the 
c:\Netwars\Scenario_Builder\op_admin folder.

Note—These log files accumulate messages over time. It is good practice to 
periodically check the sizes of the log files, and trim or empty the logs to prevent 
the files from becoming too large.
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Procedure 2-5   Viewing the Error Log

1 In the System Editor or Scenario Builder, select Help > Error Log > View. The 
error log displays the most recent error log entries. If errors occur during the 
operation of NETWARS, they are logged in this error log file.

Figure 2-6   NETWARS Error Log

End of Procedure 2-5

Procedure 2-6   Clearing the Error Log

1 In the System Editor or Scenario Builder, select Help > Error Log > Clear. The 
Clear Error Log dialog box displays.

Figure 2-7   Clear Error Log dialog box

2 Click the Clear all lines radio button if you want to remove the entire contents of 
the log file, or click the Keep last: radio button if you want to type a number of most 
recent lines to keep (and remove earlier lines from the beginning of the log file so 
that only the specified number of lines remain.)
UG1-2-8 NETWARS/Release 5.1



NETWARS Network Model Configuration and Navigation 2—File Management
3 Click OK to clear the error log and close the dialog box, or Cancel to close the 
dialog box without making any changes to the error log. 

End of Procedure 2-6

Procedure 2-7   Viewing the Message Log

1 In the System Editor or Scenario Builder, select Help > Message Log > View. The 
message log displays the most recent status messages.

Figure 2-8   NETWARS Message Log

2 Click OK to close the NETWARS Message Log.

End of Procedure 2-7

Procedure 2-8   Clearing the Message Log

1 In the System Editor or Scenario Builder, select Help > Message Log > Clear. The 
message log clears immediately with no other dialog boxes or messages 
displayed.

End of Procedure 2-8
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Display NETWARS Product Information

NETWARS provides important information about the OPNET core software 
version, the models version, and copyright information.

Procedure 2-9   Displaying NETWARS Product Information

1 In the System Editor or Scenario Builder, select Help > About NETWARS. The 
About NETWARS dialog box displays.

2 Click the About tab to display the information shown in the figure below:

Figure 2-9   About NETWARS dialog box — About tab

3 Click the Environment tab to display the information shown in the figure below:

Figure 2-10   About NETWARS dialog box — Environment tab
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4 Click the Notices tab to display the information shown in the figure below:

Figure 2-11   About NETWARS dialog box — Notices tab

End of Procedure 2-9
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Select Product Modules

OPNET provides a variety of product modules that are specifically designed to 
increase productivity and efficiency in your modeling and simulation projects. 
Product modules that are licensed and available to you via NETWARS can be 
displayed and selected as discussed below.

Procedure 2-10   Selecting Product Modules

1 In the System Editor, select License > Product Modules. The Select Product 
Modules dialog box displays.

Figure 2-12   Select Product Modules dialog box

2 Click the checkboxes corresponding to the product modules you want to use. 

3 Click OK to accept the checked modules and close the dialog box, or Cancel to 
close the dialog box without making any changes to your product module selection.

End of Procedure 2-10

Automatic Project File Backup

Project files are backed up automatically at a predetermined interval. You can 
modify the backup interval by editing the ‘backup_interval’ global environment 
attribute which contains the period (in minutes) of automatic file backups.
UG1-2-12 NETWARS/Release 5.1



NETWARS Network Model Configuration and Navigation 2—File Management
The backed up files have ‘-backup<index>’ appended to the filename. You 
can load these backup files into Scenario Builder as needed.

Procedure 2-11   Setting Preferences for Backup Interval

1 In the System Editor or Scenario Builder, select Edit > Preferences > Advanced. 
The Advanced Preferences dialog box displays.

2 Locate the ‘backup_interval’ attribute, and click in the Value field.

Figure 2-13   Advanced Preferences dialog box

3 Type a new value (in minutes) for the backup interval in the Value field.

Figure 2-14   backup_interval Attribute Value field

4 Click OK to accept the attributes value and close the dialog box, or Cancel to close 
the dialog box without making any changes to the attribute. 

End of Procedure 2-11
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Generate Support Info

If you should ever need assistance, generate a support log file to send to 
NETWARS Technical Support. This can help Technical Support resolve your 
problem quickly and efficiently.

Procedure 2-12   Generating a Support Log File

1 In the System Editor, select Help > Generate Support Info.... The Save Support 
Info dialog box displays.

Figure 2-15   Save Support Info dialog box

2 Click Save to save a log file named opnet_support.info to the displayed 
directory.

3 When the log file has been created, the following message box displays. Click OK 
to close the message box.

Figure 2-16   Support Info Log message box

End of Procedure 2-12
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3 Configuration Helpers

NETWARS provides several features that make it easier and faster for you to 
configure your network model. Features discussed in this chapter can help you 
to edit attributes (for one object or a group of objects), configure protocols, and 
use the Model Assistant to automate frequently applied scenario changes.

Editing Object Attributes

Network objects have attributes that define their functionality, behavior, and 
physical characteristics. NETWARS provides several ways in which you can 
view, create, and edit network object attributes and their properties—for one 
object or for many objects—quickly and easily.

Editing Attributes for One Object

To edit the value of an attribute on a single object, use the following procedure.

Procedure 3-1   Edit Attributes for One Object

1 To view an object’s attributes, right-click on the object to open the shortcut menu.

2 Select Edit Attributes to open the corresponding Attributes dialog box.

Figure 3-1   Attributes dialog box

The Attributes dialog box displays all primary attributes associated with the object. 
Primary attributes are those you use most often to define an object. For example, 
primary attributes specify the object’s name and its underlying (node or link) model.

3 Set a new value for an attribute by typing a new value (or selecting one from the 
drop-down list if provided) in the corresponding Value field.
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4 If the attribute that you want to edit does not appear in the main Attribute list, click 
the Advanced checkbox to display the object’s advanced attributes.

Figure 3-2   Advanced Attributes dialog box

Advanced attributes specify parts of the object definition that you might set less 
frequently. They typically define information such as an object’s appearance and 
location in the workspace.

5 To find a specific attribute or value in the Attribute or Value lists, type a search term 
in the Find Next field and click Find Next. The first occurrence of the term will be 
highlighted.

6 To view details about an attribute, click the ? button next to the attribute in the 
Attribute list. The Attribute Details dialog box displays.

Figure 3-3   Attribute Details dialog box

6.1 Click Close to close the Attribute Details dialog box and return to the 
Attributes dialog box.
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7 Click the Apply changes to selected objects checkbox if you want to apply the 
changes to an object’s attribute values to both the object and all selected objects 
in the workspace.

8 To view extended attributes, click Extended Attributes in the Attributes dialog 
box. The Extended Attributes dialog box displays with a data table for creating new 
attributes.

Figure 3-4   Extended Attributes dialog box

Extended attributes are optional model attributes that you can add to an object, 
thus further customizing its behavior in a network model.

8.1 Enter the name of the attribute in the New attribute field and click Add. You 
can also type directly in the data table by clicking in a cell in the Attribute Name 
column. The attribute is added to the table and automatically assigned a type 
and default value.

8.2 Under the Type column, select an appropriate data type from the pull-down 
menu.

8.3 In the Units column, type in the units to be associated with the attribute, if any.

8.4 In the Default Value column, type in a default value for the attribute.

9 To view, create, or edit the properties of an attribute, click Edit Properties in the 
Extended Attributes dialog box. The attribute’s corresponding Properties dialog 
box displays.
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Figure 3-5   An Attribute’s Properties dialog box

All attributes share a set of basic of properties that define the attribute, specifying 
information such as its name, data type, and allowed values. These properties are 
generally fixed, but can be given different values in some cases.

9.1 Set the type of the attribute in the Data type drop-down list.

9.2 Click the Private radio button if you want the property values to apply only to 
this attribute, or the Public radio button if you want the property values to be 
shared with other attributes. If the attributes are public, any changes to 
property values affect all attributes sharing these property values. 

9.3 Click Load Public if you want to load a predefined set of public attribute 
properties. 

9.4 Click Save Public if you want to save the current attribute properties to your 
default model directory with the suffix ".ad.m". This option is available only 
when you select the Public radio button. 

9.5 Enter a range of allowable values for attributes of data type integer or double 
(this option does not apply to other data types) in the Range fields. For both 
the lower (From) and upper (To) limits, you can specify a numeric value and 
indicate that the value is included in the range (“inclusive”) or not included 
(“exclusive”). To indicate no limit, select open.

9.6 Enter the default value for the attribute in the Default value field. Check the 
Auto assign value checkbox to automatically assign the default value to the 
attribute when a new instance of its parent object is created.

9.7 Enter the units for the attribute value in the Units field.

9.8 Use the Symbol map table to assign symbols (“friendly” names) to specific 
values that the attribute can have. 
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• Symbol Map table—Lists the names and values of defined symbols. 

• New Symbol field—Use to add a symbol to the Symbol Map table. Type the 
name in this field and click the Add button. 

• Add button—Adds the new symbol named in the New Symbol field to the 
Symbol Map table. 

• Allow other values checkbox—If checked, allows the attribute to have 
values other than those specified in the symbol map table. If unchecked, 
only the values in the symbol map table are allowed for the attribute. 

• Delete button—Deletes the selected symbol from the Symbol Map table. 

9.9 Describe the attribute to users of a model in the Comments field. Comments 
should include a definition of the attribute, how it is used by an object, and any 
other information helpful to the model user. 

9.10 Click OK to accept the current property values and close the Properties dialog 
box, or Cancel to close the dialog box without making any changes to the 
property values. 

10 Click OK to save the information, close the Extended Attributes dialog box, and 
return to the Attributes dialog box.

11 Click OK to accept the attributes values and close the Attributes dialog box, or 
Cancel to close the dialog box without making any changes to the attributes. 

End of Procedure 3-1

Editing Attributes for Many Objects

You might need to set values for the same attributes on several objects in a 
network model. For a few attributes, you could make these changes individually 
using Procedure 2-1. However, this method can be tedious and error-prone for 
large numbers of objects. NETWARS provides several alternate methods for 
quickly changing attributes on many objects, one of which is using the Edit 
Objects Using Template command on the Edit menu.

NETWARS allows you to edit attributes for multiple objects in one window, using 
an attribute table similar to a User Defined Report. You can create your own 
attribute templates (as described in Procedure 2-3) to generate tables of 
specific attribute values for one or more objects in a network. An attribute 
template specifies the following information about an attribute table:

• Table category and name—Every attribute table belongs to a category, such 
as “IP” or “Application”, and has a name that identifies it.

• Object types to include—A table can include all network objects, a specific 
type of network object, or objects selected by custom criteria that you specify.

• Attributes to include—Each row of an attribute template specifies the title and 
contents of a column that will appear in the attribute table.
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Procedure 3-2   Edit Attributes For Many Objects Using a Template

1 Select Edit > Edit Objects Using Template. The Edit Objects Using Template 
dialog box displays.

Figure 3-6   Edit Objects Using Template dialog box

2 Select an attribute template in the Select table to include in user report list box from 
which to generate an editable table of attribute values.

To select an entire category of tables, click on the top-level category entries. To 
select an individual table, expand the top-level category subtree and click on the 
table entry. Selected tables and categories show a green checkmark. Categories 
with some but not all of its tables selected will display a green dot instead.

Note—If you want to define a custom template, click Close, define a template as 
described in Procedure 2-3, then begin this procedure again.

3 Select the Include only selected objects checkbox if you want to collect table 
data only for objects that are currently selected in the network.

4 Select the Ignore views checkbox if you want to collect table data even for objects 
that are not in the current view or views of the network.

5 Select the Send reports to the Report Server (host) checkbox if you want to send 
reports to the Report Server. This option is active only when a Report Server 
license is available. 

5.1 Specify a name for the report in the Report Server text field. 
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6 Click Generate to generate the table data for all of the selected tables. The 
corresponding dialog box displays.

Figure 3-7   Table of Generated Attributes

7 Edit the attributes as needed. There are two editing modes:

7.1 Standard Mode—Click on any attribute value and edit it as you would in the 
Attributes dialog box.

7.2 Copy and Paste Mode—Copy an attribute value and paste it to one or more 
similar attributes. This mode disables the standard methods for changing 
attribute values (edit fields, pull-down lists, and so on).

• Select the Copy and Paste Mode checkbox.

• Select an attribute value and press <Ctrl>+<C>.

• Select the attribute value or a range of contiguous values and press 
<Ctrl>+<V>.

You can paste only into the same attribute column from which you copied.

8 When you are finished editing attribute values, click OK to make the changes.
NETWARS/Release 5.1 UG1-3-7



3—Configuration Helpers NETWARS Network Model Configuration and Navigation
Procedure 3-3   Define or Edit an Attribute Template

1 Select Edit > Edit Attribute Template. The Edit Attribute Template dialog box 
displays.

Figure 3-8   Edit Attribute Template dialog box

Each table row corresponds to an attribute column in tables generated from this 
template. At first, the only column defined is for an object name.

2 Choose whether to define a new template or edit an existing one:

2.1 To define a new template, leave the category and template names set to 
“unnamed”. (You will specify these names when you save the template.)

2.2 To edit an existing template, select its category and name from the pull-down 
menus.

3 Choose what object types to include in the table:

3.1 Select an object type from the Include pull-down menu.

3.2 If you selected “Objects in logical selection”, use the Logical selection 
pull-down menu to specify a selection criterion.

4 Choose what attributes to include in table columns:

4.1 To add a new undefined column, click New.

4.2 To add a new column based on an existing one, select the desired attribute 
row and click Duplicate.

4.3 To edit a column definition, select a row and click Edit. (Alternatively, you can 
double-click the Column Value field.) This opens a dialog box for specifying 
the contents and format of the table column.
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4.4 To delete a column, select its row and click Delete.

4.5 To add a drilldown, select a row and click Add Drilldown. A drilldown is a child 
table that you open by following a link in the parent table. Drilldowns are useful 
when you want to show a set of related attributes in a separate window. For 
example, you might want to create a drilldown table for IP port attributes on a 
router.

This operation creates a drilldown table definition, which is initially equivalent 
to the current table definition. To edit the drilldown table, select the row and 
click Edit.

5 Move attributes around as needed to modify the appearance of tables generated 
from the template:

5.1 To change the sequence of attributes, select an attribute row and click Move 
Up or Move Down (thus moving the resulting table column left or right, 
respectively).

5.2 To see what the generated table will look like, click Preview. A dialog box 
displays a preview of the table to be generated using the current template.

Figure 3-9   Preview of Table to be Generated from Template

6 Click Save As in the Edit Attribute Template dialog box.

6.1 If you are defining a new template, enter names for the category and table. 
The category can be one of the existing categories or a new one.

6.2 If you are editing a template, you can either keep the original category and 
table names (to replace the original template) or change the table name (to 
create a new version of the original).

The template is saved with the extension .urep.xml. New templates are 
saved in your default model directory; edited templates are saved in the same 
directory as the original template.

7 Click Cancel to close the dialog box.

End of Procedure 3-3
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Configuring Protocols

Each protocol supported by NETWARS and listed under the Protocols menu 
has commands associated with it that enable you to perform operations related 
to the configuration of that protocol. 

The protocols are not documented in this manual; please refer to the OPNET 
documentation listed for each menu option listed below (consult the IT Guru 
documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

Procedure 3-4   Access Options for Configuring Protocols

1 Select Protocol > Applications > option. Select from the provided options to add 
ACE application models to the existing network, configure application demands, or 
clear various types of application traffic from the network. Refer to the Applications 
Model User’s Guide for more information (available via Protocol > Applications 
> Model User Guide.)

2 Select Protocol > IP > option. Select from the provided options to assign, 
configure, and clear IP addresses, configure routing protocols, enable reachability 
analysis to view routing data from Flow Analysis or DES, characterize traffic 
demands, display/hide routes, ping traffic, and configure QoS. Refer to the IP 
Model User’s Guide for more information (available via Protocol > IP > Routing > 
Model User Guide.)

3 Select Protocol > BGP > option. Select from the provided options to configure 
BGP start time, status, IBGP and EBGP peers, and route redistribution from other 
protocols into BGP. Refer to the BGP Model User’s Guide for more information 
(available via Protocol > BGP > Model User Guide.)

4 Select Protocol > EIGRP > option. Select from the provided options to configure 
EIGRP start time and route redistribution from other protocols into EIGRP. Refer to 
the EIGRP Model User’s Guide for more information (available via Protocol > 
EIGRP > Model User Guide.)

5 Select Protocol > IGRP > option. Select from the provided options to configure 
IGRP start time and route redistribution from other protocols into IGRP. Refer to 
the IGRP Model User’s Guide for more information (available via Protocol > IGRP 
> Model User Guide.)

6 Select Protocol > IS-IS > option. Select from the provided options to configure 
interface metrics, interface circuit types, system types, metric styles, SPF 
calculation parameters, and route redistribution. Refer to the IS-IS Model User’s 
Guide for more information (available via Protocol > IS-IS > Model User Guide.)

7 Select Protocol > OSPF > option. Select from the provided options to configure 
interface cost and timers, OSPF start time, areas, and route redistribution. Refer to 
the OSPF Model User’s Guide for more information (available via Protocol > 
OSPF > Model User Guide.)
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8 Select Protocol > RIP > option. Select from the provided options to configure RIP 
start time, and route redistribution from other protocols into RIP. Refer to the RIP 
Model User’s Guide for more information (available via Protocol > RIP > Model 
User Guide.)

9 Select Protocol > RSVP > option. Select from the provided options to configure 
interface status. Refer to the RSVP Model User’s Guide for more information 
(available via Protocol > RSVP > Model User Guide.)

10 Select Protocol > ATM > option. Select from the provided options to configure 
over-subscription on a per-service class basis for all or selected nodes in the 
network, display/hide ATM VC routes, and create IMA groups. Refer to the ATM 
Model User’s Guide for more information (available via Protocol > ATM > Model 
User Guide.)

11 Select Protocol > Frame Relay > option. Select the provided option to configure 
PVCs between nodes in the network. Refer to the Frame Relay Model User’s 
Guide for more information (available via Protocol > Frame Relay > Model User 
Guide.)

12 Select Protocol > VLAN > option. Select from the provided options to configure 
VLANs for selected nodes or links, configure selected links as trunk links, and 
enable/disable VLANs for selected switches. Refer to the VLAN Model User’s 
Guide for more information (available via Protocol > VLAN > Model User Guide.)

13 Select Protocol > STP > option. Select from the provided options to apply or clear 
Spanning Tree visualization.

End of Procedure 3-4
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Using Configuration Utilities

NETWARS provides a Configuration Wizard to help you configure Promina and 
Multiplexer utility nodes. Utility nodes contain information/attributes pertaining 
to multiple nodes in the scenario. They provide a convenient way of configuring 
information that is conceptually shared. 

A sample Configuration Wizard workflow for configuring Prominas is provided 
below. Workflows are similar for other utility nodes; however, they do vary 
depending on the utility being configured. 

Procedure 3-5   Configure Promina Devices

1 Select Topology > Configuration Utilities > Promina to start the wizard. The 
scenario must contain at least two Promina devices that have available LAN port 
to support the configuration; otherwise, an error will be prompted and the wizard is 
terminated. 

2 Select the source Promina device and its associate LAN port. To help identify the 
LAN port, the subscriber side device is also shown in the drop-down menu. 

Figure 3-10   Selecting a Source Promina Device

The treeview contains all Promina devices in the scenario that have available LAN 
port to support the configuration. Expand the treeview and select the desired 
source device by left-clicking on the Promina device. 
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3 Once the source device is selected, the Subscriber Side Device drop-down list 
becomes enabled. This drop down list provides the available LAN ports on the 
selected promina device.  It consists of the <subscriber side device>: <LAN port 
that’s connected to the subscriber side device>. Select the desire LAN port from 
the list, and click the Next>> button to advance to the next step. 

3.1 If you want to cancel out from the wizard, click Cancel.

3.2 If you want to return to the previous step, click <<Back.

4 After the source Promina device has been selected, select the destination Promina 
device and its LAN port. This step is the same as selecting the source Promina 
device described above. Only those Prominas that have LAN side devices 
connected to them are considered to be potential source/destination Promina 
devices. 

5 After the source and destination Promina devices and ports have been selected, 
configure circuit attribute values including the CCSD codes for the Promina circuit 
name as shown in the figure below. All fields have default values.

Figure 3-11   Promina Circuit Attributes dialog box

The following attributes can be set for the Promina circuit:

• Direction – The direction of the circuit; some ports can only receive and some 
only send. Dual represents a full duplex circuit.

• Max Port Speed – Ports on the same card can have different maximum speed 
values; 64Kbps is the only value allowed for PRI-type cards. The Auto-sense 
option will take the link data rate as the circuit speed.

• Call Type – A permanent call will be set up at the beginning of simulation and 
never torn down; a demand call will be set up whenever demanded by the 
connected end devices and torn down if inactive.

• Inactivity Timer – If there is no packet exchange for the specified amount of 
time, the demand call will be torn down.
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• Start/Stop Time – The start/stop time for the Promina circuit.

• Number of Circuits – Specify one or more circuits over the same path.

• Define Circuit Path – If no other Promina devices exist in the scenario, other 
than the selected source and destination Promina devices, the Define Circuit 
Path checkbox will be unchecked and disabled; you can click the Complete 
button to complete the Promina circuit configuration. If another Promina does 
exists, this field will be checked by default; you can click the Next>> button to 
add more Prominas to the circuit sequence.

Click the Help button for information on the current dialog box, <<Back button to 
return to the previous dialog box, and Cancel button at anytime to terminate the 
wizard.

6 If the Define Circuit Path checkbox is unchecked, click the Complete button to 
complete the Promina circuit configuration and circuit information is automatically 
applied to the utility OPFAC that contains the pro_portmap_utility node. If the 
Define Circuit Path checkbox is checked, click the Next>> button to specify path 
for the circuit as shown below.

Figure 3-12   Define Promina Circuit Path dialog box

The left-side treeview of the Define Promina Circuit Path dialog box contains all 
Promina devices in the scenario with the exception of the source and destination 
Promina devices. The right-side treeview indicates the path of the circuit. Initially, 
it lists only the source and destination Promina devices.
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7 Expand the left-side treeview and select an intermediate Promina device and click 
the >> button to add it as an intermediate node to the right-side treeview. 
Intermediate devices are positioned before the destination device so devices are 
added in sequence. Select an intermediate node from the right-side and click the 
<< button to remove it from the path. The removed device will be added back to the 
left-side treeview and becomes available for later selection.

Figure 3-13   Defining Intermediate Nodes

Reposition intermediate nodes if needed by first selecting the desired device and 
clicking on the Down or Up buttons to move it down or up, respectively, from the 
path. 

8 Click the Complete button to finish the configuration and apply the information to 
the utility OPFAC that contains the Promina_Utility node. 

The Promina circuit definition is maintained on the Promina_Utility node, which 
resides in the Multiplexer Utility OPFAC. You can view the attributes of the circuit 
by accessing the Attributes of the Promina_Utility node and clicking on the 
Value cell of the Portmap Configuration attribute.

9 Once the configuration is completed, users have the opportunity to configure 
another Promina circuit without exiting the wizard through a pop-up dialog box that 
displays.

10 Click the Help button for information on the current dialog box, <<Back button to 
return to the previous dialog box, and Cancel button at anytime to terminate the 
configuration wizard.

End of Procedure 3-5
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Using the Model Assistant

The Model Assistant allows you to automate frequently applied scenario 
changes by editing and saving data in model assistant files and then applying 
the data to your network. A model assistant file is an ASCII text file that specifies 
a set of changes to a scenario. You can specify multiple changes in one file, and 
then apply the file to make multiple changes in one operation. For example, you 
can create a model assistant file to:

• Create/remove objects (subnetworks, nodes, links, and demands),
• Modify object attributes, and
• Specify object locations.

Procedure 3-6   Edit a Model Assistant File

1 Select Topology > Model Assistant > Edit File. The Edit Model Assistant File 
dialog box displays.

Figure 3-14   Edit Model Assistant File dialog box

This dialog box contains multiple tabbed pages; each page has fields for entering 
the data you want to apply.

2 Specify the information you want to apply on each page (click the tabs to view 
specific pages).

2.1 If you do not want to apply a certain type of data, leave the page empty.

2.2 If you want to edit an existing file, click Load, choose the file to load, and click 
OK. The dialog box updates each tabbed page to reflect the data in the loaded 
file.
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2.3 If you want to reset all settings on all pages and reenter your data, click Clear.

2.4 If you want to open the model assistant file you are editing in the text editor 
specified in the editor_prog preference, click Edit in Text Editor. This gives 
you some additional flexibility when editing your model assistant file. When 
the text editor is closed, the changes you made are immediately reflected in 
the GUI.

3 Click the Demand Creation tab if you want to specify demands to create in the 
network. Each row in the table represents a demand to be created. 

3.1 Type the name of the demand object in the Demand Name field. 

3.2 Enter the source node of the new demand in the Source Node field and the 
destination node of the new demand in the Destination Node field. You do not 
need to specify the full hierarchical names of these nodes. If there is only one 
node with the specified name in the network, the model assistant will find it. 
You can select a node model from the pull-down menu (single click) or type 
the model name (double click). The pull-down menu lists all nodes in the 
network and in the Node Creation page. 

3.3 Enter the model name of the demand object in the Demand Model field. You 
can select a demand model from the pull-down menu (single click) or type the 
model name (double click). 

4 Click the Object Attributes tab if you want to specify attributes for the various 
objects in your network. Each row in the table represents an object attribute. 

4.1 Enter the name of the object whose attribute you want to set in the Object 
Name field. You do not need to specify the full hierarchical name of this object. 
If there is only one object with the specified name in the network, the model 
assistant will find it. You can select a network object from the pull-down menu 
(single click) or type the object name (double click). The pull-down menu lists 
all objects in the network.

4.2 Enter the name of the attribute to set in the Attribute Name field. This can be 
a simple or a compound attribute. Note that simple attributes include simple 
(non-compound) attributes of compound attributes. 

4.3 Enter a new value for the specified attribute in the Attribute Value field. If you 
specified a compound attribute for the name, you can enter only symbolic 
values. 

Specifying Attributes in the Model Assistant:

If you want to set an attribute that is part of a compound attribute, you must 
enter the full hierarchical name of the attribute. The hierarchical name 
includes each parent attribute and the row number. The best way to verify the 
correct format for an attribute name is to do the following: 

• Right-click on a network object and choose Edit Attributes. 

• If the attribute is part of a compound attribute, expand the attribute tree until 
the attribute you want to set is visible in the “Name” column. 

• Set the “Value” field to the value you want to specify in the Model Assistant. 

• Rest the cursor over the Value field. The tooltip shows the full hierarchical 
name and current value setting for the attribute. 
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5 Click the Node Aliases tab if you want to specify aliases on the nodes in your 
network. Each row in the table represents an alias. 

5.1 Enter the name of the node whose aliases you want to set in the Node Name 
field. You do not need to specify the full hierarchical name of this node. If there 
is only one node with the specified name in the network, the model assistant 
will find it. You can select a node from the pull-down menu (single click) or 
type the node name (double click). The pull-down menu lists all nodes in the 
network.

5.2 Enter an alias to set on the specified node in the Alias field. 

6 Click the Subnet Properties tab if you want to set certain display properties on 
subnets (OPFACs/Organizations) in your network. Each row in the table 
represents a property.

6.1 Enter the name of the OPFAC or Organization whose properties you want to 
set in the Subnet Name field. You do not need to specify the full hierarchical 
name of the OPFAC or Organization. If there is only one OPFAC or 
Organization with the specified name in the network, the model assistant will 
find it. You can select an OPFAC or Organization from the pull-down menu 
(single click) or type the OPFAC or Organization name (double click). The 
pull-down menu lists all OPFACs/Organizations in the network. 

6.2 Select the OPFAC or Organization property to set in the Subnet Property field. 
You have five choices: Display Resolution, Display Units, Grid Draw Style, 
Grid Division, and Map. Note that none of the “properties” that appear when 
you right-click on the OPFAC or Organization and select Edit Attributes are 
on this list. This is because those are the OPFAC or Organization’s attributes, 
and can be set using the Object Attributes tab.

6.3 Enter the value of the OPFAC or Organization property you want to set in the 
Property Value field. The input to this column depends on your choice of 
property in the previous column as follows: 

• Display Resolution — Display resolution of your OPFAC or Organization in 
pixels per whatever your OPFAC or Organization units are. 

• Display Units — Units in which your OPFAC or Organization will be 
displayed. Your choices are miles, feet, kilometers, meters, and degrees. 

• Grid Draw Style — Grid draw style in the OPFAC or Organization. Your 
choices are solid, dashed, or disabled. 

• Grid Division — Grid division in the OPFAC or Organization, in whatever 
your display units are. 

• Map — Background image for the OPFAC or Organization. The value 
specified must be a valid image file.

7 Click the Site Locations tab if you want to set the geographical locations of sites 
in your network. Each row in the table represents a site location.

7.1 Enter the name of the site whose location you want to set in the Site Name 
field. You do not need to specify the full hierarchical name of this site. If there 
is only one site with the specified name in the network, the model assistant will 
find it. You can select a site from the pull-down menu (single click) or type the 
site name (double click). The pull-down menu lists all sites in the network.
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7.2 Select the format in which your site’s location is to be specified in the Location 
Type field. You have four choices: [NPA, NXX], [City, Country], [City, Province 
(Canada)], [City, State (USA)], [Lat, Long] and [X, Y (in parent’s units)].

7.3 Enter the location of the site in the Location Data field. The input to this column 
depends on your choice of format in the previous column as follows:

• NPA, NXX — Area code (NPA) and first three digits of the phone number 
(NXX) of the area where your node is to be placed (e.g. “240, 497”). This 
format is only valid for locations within the US and Canada.

• City, Country — City and country where your node is to be placed (e.g. 
“Paris, FR”). You can specify the country using the full country name or a 
two letter country code from the ISO-3166 standard.

• City, Province (Canada) — City and province where your node is to be 
placed (e.g. “Toronto, ON”). You can specify the province using a two-letter 
code, or the full province name. This format is only valid for locations within 
Canada. 

• City, State (USA) — City and state where your node is to be placed (e.g. 
“Bethesda, MD”). You can specify the state using a two letter code, or the 
full state name. This format is only valid for locations within the US. 

• Lat, Long — Latitude and longitude where your node is to be placed (e.g. 
“38.4, -75.2”). 

• X, Y (in parent’s units) — X and Y coordinates at which your node is to be 
placed (e.g. “1234, 234.5”). The values of the coordinates you specify will 
be interpreted in the units of the site’s parent OPFAC or Organization. 

8 Click the Router/Switch Coupling tab if you want to couple routers with switches 
in your network. Each row in the table represents a coupling.

8.1 Enter the name of the router to be coupled with a switch in the Router Name 
field.

8.2 Enter the name of the switch to be coupled with the chosen router in the 
Switch Name field.

9 If you want to save your data to a model assistant file so you can reuse it later, click 
Save. If an existing file is selected, it will be overwritten.

10 Click Apply to apply the data in the various tabs of the dialog box to the current 
network, or Close to close the dialog box without applying your data or saving any 
changes.

End of Procedure 3-6
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Procedure 3-7   Apply a Model Assistant File to the Network

1 Select Topology > Model Assistant > Apply File. The Select a Model Assistant 
File to Apply dialog box displays.

Figure 3-15   Select a Model Assistant File to Apply dialog box

2 Enter the name of the Model Assistant file that you want to apply to the current 
network in the Filename field, and then click OK.

End of Procedure 3-7
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4 Visualization and Navigation

NETWARS provides several features that make it easier and faster for you to 
visualize and navigate your network model. Features discussed in this chapter 
can help you to find and edit objects, view and edit demands, visualize routing 
protocols and link loads, size and scale icons, set display preferences, and 
visualize the effects of changing the network time.

Finding Objects by Attribute

NETWARS provides a Selection Filter feature that enables you to find and 
select objects quickly and easily based on their attributes. 

Procedure 4-1   Find Objects by Attribute

1 Select Edit > Select. The Selection Filter dialog box displays.

2 At the top of the Selection Filter dialog box, select the type of object that you want 
to find by clicking the appropriate Object Type check box.

3 In the table in the middle of the Selection Filter dialog box, click in the top empty 
field of each column to display a drop-down menu to use for selecting objects. 
Menu options change dynamically with the type of object chosen for selection.

From these menus, select one or more attributes and their matching criteria to be 
used for selecting objects:

3.1 In the PROP column, select Require if you want only to find objects that 
satisfy all attribute criteria for selection, or select Consider if you want to find 
any objects that satisfy at least one of the attribute criteria for selection.

3.2 In the Attr Name column, select the name of the attribute to be used as the 
selection criteria.

3.3 In the ?= column, select the type of matching to be used. 

• For a string, the only option is a complete match or equal to. 

• For numeric values, the satisfying condition could be less than, greater 
than, or equal to the specified value.
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3.4 In the VALUE column, select the value that the attribute must match for 
selection.

Figure 4-1   Searching for Objects by Attribute

4 Click OK. NETWARS searches through all the objects in the scenario looking for 
those that match the specified criteria. When it finds objects that match the given 
criteria, it marks those objects as selected.

End of Procedure 4-1

Finding Objects by Name

NETWARS provides a Find Node/Link feature that enables you to find and 
select objects quickly and easily based on their names. 

Procedure 4-2   Find Objects by Name

1 Select Edit > Find Node/Link (or press <Ctrl>+F). The Find Node/Link dialog box 
displays.

2 In the Name Contains field, type a text string to search for specific names. You 
can specify part or all of the name. Leave the field blank to find all objects in the 
network. 
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3 Click Find. NETWARS searches through all the objects in the scenario looking for 
those that match the specified name. When it finds objects that match the given 
name, it displays those objects in the Results table by object name, name of the 
subnet that contains the object, and type of object.

Figure 4-2   Searching for Objects by Name

4 To view a single found object in the workspace, select the object in the Results list 
and then click Locate Node/Link. 

End of Procedure 4-2

Using the Network Browser

Large, complex network models can be difficult to navigate. The NETWARS 
Network Browser provides a treeview that you can use to organize and display 
objects (organizations, OPFACs, devices, links, etc.) in your network. This 
browser makes it much easier to find objects and edit their attributes, especially 
in large networks with multiple layers of subnets.

Procedure 4-3   Use the Network Browser

1 In Scenario Builder, select File > Open Project and then select an existing project 
to display.
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2 Select View > Show Network Browser (or press <Ctrl>+B) to toggle open the 
Network Browser.

Figure 4-3   Open the Network Browser

The Network Browser pane displays on the left side of the workspace. The pane 
can be resized horizontally if desired.

3 Filter the object list as needed by using the two drop-down filters and/or three 
checkbox filters displayed above the object list:

3.1 The top drop-down list controls the type of objects that display in the object 
list. For example, the filter can be set to display nodes, links, IP devices, 
workstations, etc. The filter also organizes the list by the selected object. 
These objects appear as top-level children within each subnet; any connected 
objects appear as children of an object. For example, if the view is set to 
Nodes; the treeview then displays all nodes as top-level children within each 
subnet. Any objects connected to a node (such as links, demands or paths) 
appear as children of the node. If you select All from the drop-down menu, 
then all of the objects in the network display in the tree.

3.2 The bottom drop-down list is a search field that allows you to search for 
objects by name. To search for an object by name, type a text string in the 
Find field and then press <Enter>, or select a previously entered search term 
from the drop-down list. If corresponding objects are found, they are 
highlighted in the object list.

3.3 Check (or uncheck) the three checkbox filters to show (or hide) objects in the 
Network Browser:

• Include hidden – Check this box to show paths, demands and cell systems 
that are hidden as a result of settings in the View menu. 
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• Only selected – Check this box to show only those objects that are 
currently selected.

• Ignore views – Check this box to show objects that are excluded from the 
current network view. 

4 Double-click an object in the list to display it in the workspace.

Figure 4-4   Display Object in the Workspace
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5 Right-click an object in the workspace to display the standard shortcut menu for the 
object. Use the shortcut menu to edit object attributes, view similar nodes, choose 
simulation statistics, etc., quickly from the Network Browser.

Figure 4-5   Access the Standard Shortcut Menu for an Object

6 Select View > Show Network Browser (or press <Ctrl>+B) again to toggle closed 
the Network Browser. 

End of Procedure 4-3
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Using the Flows Browser

The Flows Browser enables you to view and edit demands. Demands (as well 
as IERs) represent traffic in NETWARS. Demands shown in the Flows Browser 
are filtered by model and/or technology. Demands selectively appear when they 
or their attached nodes are selected in the treeview.

Procedure 4-4   Use the Flows Browser

1 Select Traffic > Visualize > Open Flows Browser. The Flows Browser dialog box 
displays.

Figure 4-6   Open the Flows Browser

Note—Right-clicking a demand in the treeview gives you access to the Show/Hide 
Attached Demands menu item.

2 Select a single demand in the treeview. Corresponding traffic graphs display to the 
right of the treeview below the workspace.
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3 Right-click on a traffic graph and choose Select Profile to select a profile from the 
profile library to preview.

Figure 4-7   Traffic Attribute Profile dialog box

4 Right-click on a traffic graph and choose Edit Profile to edit the current profile’s 
name, intervals, or start time (and show start time on the graph), or to import or 
export the profile from/to a text file.

Figure 4-8   Edit Traffic Attribute Profile dialog box

End of Procedure 4-4
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Visualizing Protocol Configurations

You can quickly determine which routing protocols are running on your network 
by using NETWARS’ routing protocol visualization feature.

Procedure 4-5   Visualize Protocol Configurations

1 Select View > Visualize Protocol Configuration > (option).

Figure 4-9   Protocol Visualization Menu Options
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1.1 Select View > Visualize Protocol Configuration > IP Interface Status to 
show whether the connected interface is active or shutdown. A green up arrow 
indicates that the interface is active, whereas a red down arrow indicates that 
the interface is shutdown.

Figure 4-10   Visualizing IP Interface Status

Note—Use <PageUp> and <PageDown> keys to zoom out and zoom in.
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1.2 Select View > Visualize Protocol Configuration > IP Routing Domains to 
show the routing protocols that are configured on the router interfaces.

Figure 4-11   Visualizing IP Routing Domains

1.3 Select View > Visualize Protocol Configuration > IP QoS Configuration to 
show the IP QoS configuration on the links. 

1.4 Select View > Visualize Protocol Configuration > IP Security 
Configuration to show the packet filtering security configured on the links.

1.5 Select View > Visualize Protocol Configuration > IP Tunnel Configuration 
to show the tunnels configured on the links.

1.6 Select View > Visualize Protocol Configuration > BGP Peers to show the 
BGP peering (neighbor) relationships in the network. EBGP confederation 
peers are shown in dark green, EBGP peers are blue, and all other colors 
indicate IBGP peers. You can view the tool tip of each peering visualization 
for more information about the peers. For networks using route reflection, the 
visualization also indicates if a router is a reflector or a client.

1.7 Select View > Visualize Protocol Configuration > OSPF Area 
Configuration to show the OSPF areas configured on the router interfaces.

1.8 Select View > Visualize Protocol Configuration > ATM Routing Domains 
to show which ATM routing protocols are configured on the switch ports.
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1.9 Select View > Visualize Protocol Configuration > VLAN Configuration to 
show the VLANs configured in the network. 

2 Select View > Visualize Protocol Configuration > Clear Visualization (or press 
<Ctrl>+<Shift>+C) to remove all protocol configuration visualizations from the 
workspace.

End of Procedure 4-5

Visualizing Link Loads

You can visualize the traffic loads on links in your network based on data 
collected from a Capacity Planning Evaluation. Link loads are easily identified 
in the workspace by link colors and line widths that you designate using the Link 
Load Visualization Settings dialog box. Link statistics are computed taking into 
consideration the entire duration of the Capacity Planning Evaluation, and 
values are reported in the workspace when you move your mouse over any link.

Note—You must first run a Capacity Planning Evaluation before you can 
visualize utilization. To run a Capacity Planning Evaluation, select Capacity 
Planning> Evaluate.

Procedure 4-6   Designate Link Load Visualization Settings

1 Select View > Visualize Link Loads > Settings. The Link Load Visualization 
Settings dialog box displays.

Figure 4-12   Link Load Visualization Settings dialog box

2 Control the display of link load link colors using the following options:

2.1 Color column - Lists the colors to use when visualizing link loads. 
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2.2 Color Lower Limit column - Shows the utilization value that corresponds to 
each color. The number represents the percentage of the link that is utilized. 

2.3 Click Insert to add a new row to the color table. 

2.4 Click Delete to delete the selected row from the color table. 

3 Control the display of link load widths using the following options:

3.1 Units pulldown - Specifies the throughput units to use when interpreting the 
values in the width table. 

3.2 Width column - Lists the link thickness to use when visualizing link loads. 

3.3 Width Lower Limit column - Shows the throughput value that corresponds to 
each link thickness. 

3.4 Click Insert to add a new row to the width table. 

3.5 Click Delete to delete the selected row from the width table. 

4 Click Restore Defaults at any time to reset the dialog box to the default link 
visualization settings.

5 Click Preview to apply the current settings to the network. This button only appears 
if link load visualization is enabled. 

6 Click OK to save the specified settings and close the dialog box. 

End of Procedure 4-6

Procedure 4-7   Visualize Link Loads

1 Select View > Visualize Link Loads > Color by Link Load. The Color Links by 
Load dialog box displays.

Figure 4-13   Color Links by Load dialog box
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2 Set the link colors and line widths based on the link’s peak, average, or current 
utilization (depending upon which one you choose in the Color links based on 
data from and using the drop-down list boxes in the Color Links by Load dialog 
box) and throughput statistics respectively. 

3 Click Apply to visualize the loads and keep the Color Links by Load dialog box 
open, or click OK to visualize the loads and close the dialog box. Click Clear to 
remove all link load visualizations from the workspace.

Figure 4-14   Link Loads Visualized in the Workspace

4 Move your mouse over any link to display link statistics.

End of Procedure 4-7
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Sizing and Scaling Icons

You can customize the appearance of objects in your workspace by scaling the 
icons to a larger or smaller size, and moving icon labels that overlap. NETWARS 
provides commands that will perform these functions automatically for you, or 
you can make adjustments manually to selected icons using the Scale Selected 
Icons dialog box.

For example, if an icon is 12 x 12 pixels at full size, you can scale the icon to 
50% so that it appears at half-size (6 x 6 pixels). If you scale an icon below a 
certain size, the icon becomes minimized—that is, it appears as a simple shape 
rather than as a bitmap.

Procedure 4-8   Automatically Scale Icons and/or Adjust Label Placement

The example provided below shows icons fixed at full size, before scaling.

Figure 4-15   Icons Fixed at Full Size, Before Scaling
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1 Select View > Layout > Automatic Icon Scaling. Icon sizes are adjusted 
automatically to minimize overlap.

Figure 4-16   Automatically Scale Icons
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2 Select View > Layout > Automatic Label Placement. Label positions are 
adjusted automatically to prevent overlap with adjacent icons.

Figure 4-17   Automatically Adjust Label Placement

End of Procedure 4-8
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Procedure 4-9   Manually Scale Selected Icons

1 Select the nodes whose icons you want to scale. To scale all node icons in a 
scenario, left-click in the network background to ensure that no nodes are selected.

2 Choose View > Layout> Scale Selected Icons. The Scale Selected Icons dialog 
box displays.

Figure 4-18   Scale Selected Icons dialog box

3 Scale icons by the desired amount:

3.1 Select the Fix icons at full size radio button to scale selected icons to their 
full size (as defined by the icon bitmaps). When zooming in or out in the 
workspace, the icons remain at full size regardless of the zoom level. This 
behavior is achieved by setting the “threshold” attribute on the selected 
objects to a value of 0. Selecting this option disables the icon scaling slider 
and the uniform size button. 

3.2 Select the Scale icons, minimize overlap radio button to use the Scale 
Factor slider and field to scale all of the selected icons, except those that 
would overlap other icons if they were scaled any larger. The size can range 
from 1% to the percentage at which all of the icons will appear full size. This 
maximum percentage will vary, depending on the icon size when you open 
this dialog box.

3.3 Select the Scale icons, ignore overlap radio button to use the Scale Factor 
slider and field to scale all of the selected icons equally, even those that 
overlap. The size can range from 1% to the percentage at which all of the 
icons will appear full size. This maximum percentage will vary, depending on 
the icon size when you open this dialog box.
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3.4 To scale all selected icons to the same size (that is, to the current size of the 
smallest icon in the selection set), click the Set Icons to Uniform Size button 
and then use the slider. A progress bar appears as the icons are updated.

Figure 4-19   Selected Icons Scaled to a Factor of 50

3.5 Click OK to change the selected icons as specified and close the dialog box. 
A progress bar appears as the icons are updated. If no changes are 
necessary, the dialog box will simply close. 

3.6 Click Cancel to close the dialog box without making any of the specified 
changes.

End of Procedure 4-9
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Setting Visualization Preferences

You can customize the appearance of objects by editing preferences that 
control the visualization of the network. The preferences can be controlled on 
either the global or subnet level. Those preferences specified at the subnet level 
take precedence over any global settings. The subnet preferences are retained 
per subnet, and can only be changed from the Edit Visualization Preferences 
dialog box for the active subnet. 

You can specify visualization settings (such as icon sizes to minimize, and 
which object labels to display and when) for nodes, links, demands, and paths.

Procedure 4-10   Set Visualization Preferences

1 Select View > Edit Visualization Preferences. The Edit Visualization Preferences 
dialog box displays.

Figure 4-20   Edit Visualization Preferences dialog box

2 Type the size (in number of pixels) at which you want icons to become minimized 
in the Minimize icons that are: edit field. If an object appears smaller than the 
specified number of pixels, it is drawn using its minimized icon, as specified by its 
minimized icon attribute. 
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3 Type the size (in number of pixels) of all minimized icons in the network in the Size 
of minimized icons: edit field.

4 Click the Show node/subnet labels for radio button that corresponds to which 
object labels you want to display:

4.1 All icons—Labels appear on all objects. 

4.2 No icons—No labels appear on any node or subnet objects. 

4.3 Full-size icons only—Labels only appear on objects that have not been 
scaled below their original full size. 

4.4 Non-minimized icons—Labels appear on any icons that have not been 
minimized. 

4.5 Icons larger than X pixels—Labels appear on any icons that are larger than 
the specificed number of pixels.

5 Select which links have arrowheads from the Show link arrowheads drop-down 
list: 

5.1 Never—No arrowheads appear on any link objects. 

5.2 As specified by attributes—The appearance of arrowheads is determined 
by each link object's arrowheads attribute. 

5.3 For simplex links only—For all simplex links, the appearance of arrowheads 
is determined by each link object's arrowheads attribute. For all other link 
types, no arrowheads display. 

6 Select which links have labels from the Show link labels drop-down list: 

6.1 Never—No link labels appear on any link objects. 

6.2 Always—Link labels appear on all link objects. 

6.3 For off-page links only—Link labels appear on links that are drawn out of the 
active subnet. 

7 Select which demands have labels from the Show demand labels drop-down list:

7.1 Never—No demand labels appear on any demand objects. 

7.2 Always—Demand labels appear on all demand objects. 

8 Select which paths have labels from the Show path labels drop-down list:

8.1 Never—No path labels appear on any path objects. 

8.2 Always—Path labels appear on all path objects. 

9 Click OK to close the dialog box. All settings take effect immediately, including 
modification of global environment preferences and subnet-level settings.

Or

Click Cancel to close the dialog box and return to the original display without 
making changes to the visualization settings, global environment attributes, or 
subnet-level settings.
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Or

Click Preview to make the changes take effect immediately; however, the 
environment preferences and subnet settings will not be retained unless you also 
click OK. 

Figure 4-21   Preferences Set to Show Icon and Link Labels and Arrowheads

Figure 4-22   Preferences Set to Not Show Icon and Link Labels or Arrowheads

End of Procedure 4-10
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Using the Time Controller

NETWARS can model many types of data that vary over time, such as link loads 
or utilizations, traffic levels between two nodes, simulation results that vary over 
time, and the locations of mobile nodes in wireless scenarios. NETWARS can 
measure and represent data using calendar times (for example, “Jan 12 
19:40:30 2005”) or relative times, which are offsets from a start time (for 
example, “30 seconds”). A scenario can have a network start time associated 
with it. The start time is a calendar time (that is, an absolute date/time) value that 
defines the start of the time window for which the scenario models the network. 
When you run a discrete event simulation, for example, NETWARS does the 
following:

• Treats all relative time values as offsets from the network start time, and

• Ignores any time-based data outside the simulation time window, which 
starts at <network_start_time> and ends at <network_start_time> + 
<simulation_duration>. 

To see how time-varying data changes over time, use the Time Controller. It 
allows you to change the current network time visualized in the editor and 
animate the time change effect. 

Procedure 4-11   Use the Time Controller

1 Select View > Show Time Controller (or press <Ctrl>+<Shift>+T). The Time 
Controller displays.

Figure 4-23   Open the Time Controller 

The Time Controller shows the current network time (text field); the start time, stop 
time, and step values (read-only text fields); buttons to change time by stepping 
through the time steps or through an animation; and a time slider which provides 
an alternative way to change the current time.

2 Click |<< (Rewind) to reset network time to slider start time.

3 Click << (Step back) to decrease network time by one time step.

4 Click > (Play) to start animation.

5 Click || (Pause) to stop animation.

6 Click >> (Step forward) to advance network time by one time step.
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7 Click >>| (Fast forward) to set network time to slider end time.

8 Click and slide the time slider bar if you’d like an alternative way to change the 
current network time.

9 Click Configure if you want to change Time Controller settings. The Time 
Controller Settings dialog box displays.

Figure 4-24   Time Controller Settings dialog box

9.1 Select the source plugin for the slider start time value from the Slider start 
time: drop-down list. If 'User-Defined' is selected, you can enter the value in 
the corresponding Slider start time: text field. The value should be in 
##h##m##.###s format. 

9.2 Select the source plugin for the slider end time value from the Slider end 
time: drop-down list. If 'User-Defined' is selected, you can enter the value in 
the corresponding Slider end time: text field. The value should be in 
##h##m##.###s format. 

9.3 Select the source plugin for the time step value from the Time step: 
drop-down list. If 'User-Defined' is selected, you can enter the time step in the 
corresponding Time step: text field. The value should be in ##h##m##.###s 
format. 

9.4 Type a time (in number of seconds) in the Real time between steps: field to 
control the speed of the animation. 

9.5 Check the Loop checkbox to restart animation after completion.

9.6 Check the Start modeling at time: checkbox if you want to specify a calendar 
time for the network start time in the Start modeling at time: drop-down list 
box. The value should follow “hours:minutes:seconds month date year” 
format. Otherwise, the start time is assigned a symbolic value of “time 0.0”.

9.7 Click OK to accept changes and close the dialog box.

10 Click Close to close the Time Controller.

End of Procedure 4-11
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5 Reports

NETWARS provides several reporting features that make it easier and faster for 
you to create and review reports, tables, and graphs to help you to understand 
your network configuration. This chapter discusses the following types of 
reports:

• Summary Tables—View summary information for a scenario in table format.

• User-defined Report Tables—Get a quick configuration overview of specific 
attributes of a number of network objects, and generate publishable HTML 
reports.

• Capacity Planning Web Reports—Review the current state of a scenario 
after performing a capacity planning evaluation. The web reports launch 
automatically once the evaluation is complete. 

Using Summary Tables

NETWARS provides immediate access to summary information for a scenario 
in table format. Available tables include a summary of: Free-Text Questions, IP 
Addresses, Links, Mission Analysis, Requirements, and SLDs. NETWARS 
allows you to print summary table data, or export the information displayed in a 
table to a spreadsheet (.xls) or HTML file.

Procedure 5-1   Open a Summary Table

1 Select Scenario > Summary Tables > Free-Text Questions. The Summary of 
Free-text Questions dialog box displays a summary of free-text questions attached 
to organizations, OPFACs, and devices.

Figure 5-1   Summary of Free-text Questions dialog box
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The Summary of Free-text Questions dialog box provides a mechanism for the 
planners to communicate with each other using free text. This is especially useful 
when a Subordinate Planner wants to communicate with a Lead Planner since the 
mission analysis question interface cannot import back new questions added by 
the Subordinate Planner. These questions and answers are stored as attributes on 
the objects and can be accessed by right-clicking on the object and selecting Edit 
Attributes and clicking the Value column next to the Free-Text Questions attribute.

Note—You cannot modify the values displayed in this table.

1.1 Click Export to File to export table data to a spreadsheet (.xls) file.

1.2 Click Export to HTML to export table data to an HTML file.

1.3 Click Print to print the table to the selected printer.

1.4 Click Close to close the Summary of Free-text Questions dialog box.

2 Select Scenario > Summary Tables > IP Addresses. The IP Address Summary 
dialog box displays IP addresses for all connected interfaces on the devices.

Figure 5-2   IP Address Summary dialog box

Note—You cannot modify the values displayed in this table.

2.1 Click Export to File to export table data to a spreadsheet (.xls) file.

2.2 Click Export to HTML to export table data to an HTML file.

2.3 Click Print to print the table to the selected printer.

2.4 Click Close to close the IP Address Summary dialog box.
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3 Select Scenario > Summary Tables > Links. The Link Summary dialog box 
displays a list of all links in the scenario along with some key attributes.

Figure 5-3   Link Summary dialog box

Note—You cannot modify the values displayed in this table.

3.1 Click Export to File to export table data to a spreadsheet (.xls) file.

3.2 Click Export to HTML to export table data to an HTML file.

3.3 Click Print to print the table to the selected printer.

3.4 Click Close to close the Links Summary dialog box.

4 Select Scenario > Summary Tables > Mission Analysis. The Mission Analysis 
Questions dialog box displays the default mission analysis questions that are 
applied to all new projects created in the Scenario Builder.

Figure 5-4   Mission Analysis Questions dialog box
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4.1 Click Situation, Mission, Execution, Admin & Logistics, or Command & 
Control to filter the displayed table results by functional area.

4.2 Click Add Question to add a new question or Delete Question to remove an 
existing question from the list.

4.3 Click Export to File to export table data to a spreadsheet (.xls) file.

4.4 Click Export to HTML to export table data to an HTML file.

4.5 Click Print to print the table to the selected printer.

4.6 Click Import to import additional mission analysis questions in to the Mission 
Analysis table instead of manually typing them. The text file must be 
tab-delimited and follow the same format as the Mission Analysis defaults file, 
i.e., MissionAnalysis.gdf.

4.7 Click OK to save any changes and close the Mission Analysis Questions 
dialog box, or Cancel to close the dialog box without saving.

5 Select Scenario > Summary Tables > Requirements. The Requirements Entry 
Summary dialog box displays a summary of the bandwidth requirements for all the 
organizations in the scenario.

Figure 5-5   Requirements Entry Summary dialog box

The table displays one row for every top-level organization in the scenario. Each 
row has the name of the organization followed by the required bandwidth for each 
service type. The default functional area is Voice.

5.1 Click Voice Services, Data Services, VTC Services, Message Services, or 
Joint Digital Network to filter the displayed table results by functional area.

5.2 Click Export to File to export table data to a spreadsheet (.xls) file.

5.3 Click Export to HTML to export table data to an HTML file.

5.4 Click Print to print the table to the selected printer.

5.5 Click Close to close the Requirements Entry Summary dialog box.
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6 Select Scenario > Summary Tables > SLDs. The SLD Summary dialog box 
displays all the SLDs specified in the scenario. The table lists all external, radio, 
and satellite links regardless of whether or not they use the SLD naming scheme.

Figure 5-6   SLD Summary dialog box

A SLD is a System Link Designator that connects two transmission systems/ 
devices. It follows an eight-character alphanumeric code to identify the 
transmission systems it connects. In NETWARS, transmission systems are 
connected by satellite, external, radio and internal links as well as broadcast 
networks.

The SLD Name column includes the SLD names or the previous device_a <-> 
device_b / sat_link_<n> names. The From “A” Loc and To “B” Loc columns include 
the corresponding From and To codes. The “A” Equip and “B” Equip columns are 
based on the self-description for the A and B devices. If no self-description exists 
for these models, names are used that are based on the model attribute on the 
device. The Responsible Unit column values directly correspond to the RCU 
values specified in the JNMS Attributes dialog box for the device’s parent 
organization. The From “A” Device and To “B” Device columns provide the 
hierarchical name of the end devices. 

Note—You cannot modify the values displayed in this table.

6.1 Select a name in the SLD Name column to zoom in to the corresponding link 
in the workspace.

6.2 Click Export to File to export table data to a spreadsheet (.xls) file.

6.3 Click Export to HTML to export table data to an HTML file.

6.4 Click Print to print the table to the selected printer.

6.5 Click Close to close the SLD Summary dialog box.

End of Procedure 5-1
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Creating User-Defined Reports

NETWARS allows you to create user-defined report tables that enable you to 
get a quick configuration overview of specific attributes of a number of network 
objects, and generate publishable HTML reports.

Procedure 5-2   Create User-Defined Reports

1 Select Scenario > Summary Tables > User-Defined Reports > Generate 
Report from Template.... The Generate User-Defined Report dialog box displays.

Figure 5-7   Generate User-Defined Report dialog box

2 Select the tables to include in the report.

To select an entire category of tables, click on the top-level category entries. To 
select an individual table, expand the top-level category subtree and click on the 
table entry. Selected tables and categories show a green checkmark. Categories 
with some but not all of its tables selected will display a green dot instead.

3 Select the Include only selected objects in report checkbox if you want to collect 
table data only for objects that are currently selected in the network.

4 Select the Ignore views checkbox if you want to collect table data even for objects 
that are not in the current view or views of the network.

5 Select the Send reports to the Report Server (host) checkbox if you want to send 
reports to the Report Server. This option is active only when a Report Server 
license is available. 

5.1 Specify a name for the report in the Report Server text field. 
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6 Click Generate. The View Results dialog box displays.

Figure 5-8   View Results dialog box

Note—You can also right-click an object in your network to display the shortcut 
menu, and select the View Results command to launch the View Results dialog 
box with only the graphs and tables of that object.

Figure 5-9   View Results via the Shortcut Menu

The left side of the View Results dialog box shows a result hierarchy, and the right 
side shows a rough preview (either in table or graph format.)

Several tabs are displayed above the results hierarchy and preview windows in the 
View Results dialog box.
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7 Click on a tab in the View Results dialog box to bring it forward (making it active) 
and preview any associated table or graph data. You can choose from the following 
options:

• Discrete Event Graphs tab (also displayed by selecting DES > Results > View 
Results)

• Flow Analysis Graphs tab
• Flow Analysis Tables tab
• Capacity Planning Tables tab
• User Tables tab
• Capacity Planning Graphs tab
• Displayed Panel Graphs tab

8 Click Show in the View Results dialog box to display a preview of the table or graph 
data for the active tab.

Figure 5-10   Table Data Preview

8.1 Use the graph options/filters drop-down menus to display graphs in a variety 
of layouts.

8.2 Right-click in the graph area to open a shortcut menu that allows manipulation 
of graph properties. Right-click on the margin of a graph to open a shortcut 
menu with different graph-manipulation options.

Figure 5-11   Graph Data Preview

 Right-click in margin Right-click in graph area
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9 Click Generate Web Report in the View Results dialog box to generate an 
HTML-based web report. The Select Tables for Web Report dialog box displays.

Figure 5-12   Select Tables for Web Report dialog box

9.1 From the Select Tables for Web Report dialog box, choose the results you 
want to include in the Web report.

9.2 Check the Include network diagram checkbox if you want the web report to 
include a graphic of the network topology.

9.3 Click Generate.The Browse for Folder dialog box displays.

Figure 5-13   Browse for Folder dialog box
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9.4 Select a directory for the HTML files and click OK. The web report is created 
and opens in the default Web browser.

Figure 5-14   Sample Web Report

End of Procedure 5-2

Opening User-Defined Report Tables in Live Mode

NETWARS allows you to open one or more user-defined report tables in live 
mode. This means the tables will not only show the corresponding values given 
the current selection set, but will also automatically repopulate themselves 
whenever the selection set changes. This provides a quick way of surveying the 
relevant attributes of a number of network objects without generating a full 
report and searching for the rows of interest. It can also sometimes be more 
handy than, for example, opening the Edit Attributes dialog box for each of the 
objects of interest.

Note—This functionality is supported independently of the Generate Report 
from Template functionality, so it will neither create a new report nor discard 
any existing report information.
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Procedure 5-3   Open User-Defined Report in Live Mode

1 Select Scenario > Summary Tables > User-Defined Reports > Open Live 
Report Table.... The Live User-Defined Report Tables dialog box displays.

Figure 5-15   Live User-Defined Report Tables dialog box

2 Specify which table of which category should be opened in the Select tables to 
open treeview. Expand the top-level category subtree and click on the desired table 
entry. You can select multiple tables by holding down the <Ctrl> key while 
left-clicking or by click-and-dragging a rectangular selection. Selecting a top-level 
category tree row itself does not imply selecting all or any of its tables (it is simply 
ignored). 

3 Click Show to build and open individual user-defined report table dialog boxes for 
each of the tables you have selected. 

4 Click Close to close the dialog box.

End of Procedure 5-3
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Using Capacity Planning Web Reports

After performing a capacity planning evaluation, you can use the resulting web 
reports to review the current state of a scenario. The web reports launch 
automatically once the evaluation is complete. Subsequently, you can open the 
web reports by selecting them individually by name from the Capacity Planning 
> Reports menu where they are listed. You can also open the most recent set 
of Capacity Planner web reports for the current scenario by selecting Capacity 
Planning > Reports > View Web Report.

The web reports include the following reports for the overall evaluation:

• Executive Summary
• Overall Peak Results
• Overall Average Results

Additionally there are a group of reports which are generated for each time step:

• Traffic Report—The Traffic Route Report contains the Traffic ID, the source 
of the traffic (IER, Flow or Application), the traffic type (voice or data), the 
priority, the load in kbps, a link to a secondary table giving the routing 
information, and the source and destination of the traffic. Additionally, the 
source and destination are hyperlinked to the source and destination nodes 
in the workspace. Unroutable demand entries are highlighted in red and link 
to an Unroutable Traffic report, which contains the reason the traffic could not 
be routed and possible debugging suggestions. The sorting in the table is 
done first over unroutable versus routable demands with unroutable 
demands positioned higher, then the table is sorted by traffic source, 
followed by destination and finally load, with higher loads located higher.

• Link Utilization Report—The Link Utilization Report contains the link name, 
its data rate in kbps, the maximum total utilization, the total forward 
utilization, the total reverse utilization, the forward data utilization, the 
reverse data utilization, the forward circuit utilization, the reverse circuit 
utilization, and the voice utilization. Under the link name, there are hyperlinks 
to both the link object in the workspace and to a report containing that 
specific link’s traffic and circuits. The table is sorted by the max total 
utilization. Links that have very high max total utilizations are highlighted in 
red and links that have somewhat high max total utilizations are highlighted 
in yellow. The default values for highlighting are 75% and 60% respectively.  
You can select the value for which links with greater utilization have 
highlighted entries. 

• Circuit Reports (Promina, CellXpress & ATM, and FCC-100)—Circuit 
Reports contain the names of the source and destination device as well as 
the names and ports of the end source and destination circuits. All of these 
table entries are hyperlinked to the nodes in the workspace. Additionally, the 
report contains the data rate of the circuit in kbps, the direction of the circuit 
(forward, duplex or reverse) and a hyperlink to the route table of the circuit. 
Table entries are highlighted in red if they were unroutable and contain a link 
to an Unroutable Circuit Report, which gives a reason why the circuit was 
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unroutable and debugging information.  The report is sorted first by routable, 
then unroutable, with unroutable routes on top and highlighted in red.  
Further sorting is done by source name, and then further sorted by 
destination and finally by data rate.

There are also Route Reports for each routed circuit and traffic demand, and 
Unroutable Reports for each unroutable circuit and traffic demand. Each 
Individual Link also has a group of tables that show the circuit and traffic 
demands which flow over it specifically.

• Route Table—The Route Table lists each hop the traffic takes, including the 
source, destination, and link that is traversed. The source and destination are 
both hyperlinked to the object nodes in the workspace. The link also has 
hyperlinks to the link object in the workspace and the Individual Link Traffic 
Report for the link.  

• Unroutable Circuit Report—The Unroutable Circuit Report contains the 
source and destination devices for the circuit, which are hyperlinked to the 
workspace. The report also contains a reason for why the circuit was 
unroutable and debugging suggestions.

• Unroutable Traffic Report—The Unroutable Traffic Report contains the 
source and destination devices with hyperlinks to the workspace. The report 
also contains a reason for why the traffic was unroutable and debugging 
suggestions.

• Individual Link Traffic Report—The Individual Link Traffic Report contains 
three tables: forward traffic over the link, reverse traffic over the link, and 
circuits over the link.  Depending upon the link, some of these tables may be 
empty. The format of the traffic tables is the same as in the Traffic Route 
report. The format of the circuit table is the same as the Promina Circuit 
Route Report.

Each report contains hyperlinks explaining how the statistics were calculated.  
Each report also includes the date, project and scenario name in its header. Due 
to the long hierarchical names sometimes used in models, you can view the 
reports with variable name lengths. The default value is opfac.device. You can 
change this setting before running an evaluation as discussed in Procedure 4-4.
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Procedure 5-4   Set Capacity Planning Web Report Parameters

1 Select Capacity Planning > Reports > Settings. The Web Report Settings dialog 
box displays.

Figure 5-16   Web Report Settings dialog box

2 In the Select Naming Convention Preferred for Web Reports section, click the radio 
button that corresponds to the naming convention you want to use for all the 
devices and links that are in the report.

3 Check the Include Web Reports checkbox if you also want to select the link and 
circuit traffic reports. Unchecking this option will disable the options for the 
individual reports.

4 Check the Include Individual Link Traffic Reports checkbox if you want 
individual reports to be included in the web report for each link in the scenario. The 
reports will include all the traffic going directly over the link as well as any circuits 
that are going over the link. The reports will take longer to generate if this option is 
selected.

5 Check the Include Individual Circuit Traffic Reports checkbox if you want 
individual reports to be included in the web report for each routable circuit. The 
reports will include all the traffic using the circuit. The reports may take longer to 
generate if this option is selected.

6 In the Number of Balanced Routes to Report field, type the number of balanced 
routes that you want reported in the web reports. The entry must be an integer 
greater than 0.

7 Click OK to save your settings, or Cancel to close the Web Report Settings dialog 
box without saving your changes.

End of Procedure 5-4
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Procedure 5-5   Open Capacity Planning Web Reports

1 Select Capacity Planning > Reports > <report name>. The individually selected 
Capacity Planning Report for the current scenario displays in a web browser 
window.

2 Select Capacity Planning > Reports > View Web Report. The most recent set of 
Capacity Planning Reports for the current scenario displays in a web browser 
window.

Figure 5-17   Capacity Planning Web Report

The report opens to the Executive Summary, which gives you a short overview of 
the report highlights. More detailed results are available by clicking on one of the 
links provided on the left-hand side of the window.

End of Procedure 5-5
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