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Introduction to the ACE Editors Identification
Identification

Document Identification

Document Title: Introduction to the ACE Editors
Version: Final (OPNET 230)

Software Identification

Product Name: NETWARS
Product Release: 5.1

Documentation Conventions

This documentation uses specific formatting and typographic conventions to present the 
following types of information:

• Objects, examples, and system I/O

• Object hierarchies

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in standard Courier typeface:

C:\Netwars\User_Data\Projects

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier typeface:

/* determine the object ID of packet’s creation module */ 
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<NETWARS path>\Scenario_Builder\op_admin\err_log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:

Edit > Preferences > Advanced
NETWARS/Release 5.1 UG2-FM-iii



Documentation Conventions Introduction to the ACE Editors
Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press the 
<button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you should press 
the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps. 
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Introduction to the ACE Editors Document Revision History
Document Revision History

Release Date
Product 
Version Chapter Description of Change

August 31, 2005 5.1 Final All Changed document title from Introduction to ACE to Introduction 
to the ACE Editors to better reflect the relationship to NETWARS.

Chap. 1: Rewritten to more directly address the ‘why’ & ‘when’ 
(not just the ‘how’) for NETWARS users utilizing the ACE Editors.

Reorganized document around specific use cases rather than 
product workflow. Moved chapters on ‘Capturing Application 
Traffic’ and ‘Importing Capture Files’ to Appendices. 

May 13, 2005 5.1 Draft All Preliminary version.
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1 Introduction

NETWARS Overview

The Command, Control, Communications, and Computer Systems Directorate 
of the Joint Staff, in partnership with the Defense Information Systems Agency, 
Directorate for Technical Integration Services, developed Network Warfare 
Simulation (NETWARS). NETWARS provides modeling and simulation (M&S) 
capabilities for measuring and assessing information flow through strategic, 
operational, and tactical military communications networks. Analyzing the 
results from NETWARS can provide considerable utility in determining which 
communication systems might be overloaded during selected times in a 
particular scenario, and can assist with making prudent acquisition planning 
decisions. 

Document Overview

NETWARS provides access to an optional OPNET module called the 
Application Characterization Environment, or ACE. This user’s guide, 
Introduction to the ACE Editors, describes how NETWARS users can utilize 
ACE and the ACE Whiteboard to perform network performance analysis and 
troubleshooting.

The examples provided in this guide were presented at OPNETWORK as part 
of various ACE-related workshops. If you do not have access to the sample files 
referenced in a particular example, simply view the screenshots provided in this 
guide.

Note—To learn more about the ACE module, access the ACE User Guide by 
selecting Help > ACE Product Documentation from within ACE.

Referenced Documents

• ACE User Guide, OPNET Technologies.
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ACE Editors Overview

The capabilities of the NETWARS software are organized into multiple editors: 
the System Editor, the Scenario Builder, the IER Editor, the Icon Editor, and (if 
you have an ACE license) ACE and the ACE Whiteboard.

• ACE allows you to troubleshoot application and network performance 
problems by analyzing raw traffic data files obtained from a live network 
without months of data gathering and error prone traffic approximations (i.e, 
IERS).

• ACE Whiteboard enables you to predict application performance under 
varying configurations and network conditions, and simulate the behavior of 
an application that does not exist yet by creating a model of the application 
and then running analyses on it.

Thus, the ACE Editors can be used in a pre-deployment environment to assist 
in application rollouts on the network, or in a post-deployment environment to 
troubleshoot the behavior of existing applications on the network.

When Should You Use the ACE Editors?

The ACE Editors can help you to answer important questions about your 
network such as:

• Why is my application slow? (Use Case 1: Troubleshooting Problems)

— User’s desktop running slowly?

— Server delays? 

— Application not doing what it’s supposed to do?

— Non-optimal TCP settings?

— Heavy congestion over WAN?

— Too little bandwidth?

— Latency too high?

• Can this new application be deployed over our network? (Use Case 2: 
Predicting Performance)

— Will users have to wait two seconds or two minutes?

— Will deploying this applicaiton impact other critical applications?

— Do you need to add bandwidth?

Use Case 1: Troubleshooting Applications Using the ACE Editor

The standard workflow to follow when using ACE to troubleshoot applications 
on your network is provided below:

• Identify application with performance issues,
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• Work with users to enumerate tasks or workflows that have performance 
issues,

• Capture each task from production network, trying to reproduce bad 
performance,

• Import traces into ACE,

• Visualize, diagnose, and perform predictive analysis, and

• Create reports to share what you have learned.

Use Case 2: Predicting Application Performance Using ACE Whiteboard

The standard workflow to follow when using ACE Whiteboard to predict 
application performance before deployment is provided below:

• Determine key workflows and tasks:

— Frequent tasks, and

— Big tasks.

• Capture key tasks in lab environment:

— One capture file per task, and

— All tiers usually on same LAN.

• Import a task into ACE,

• Create templates of import and report options, prediction scenarios, etc.,

• Import other tasks,

• Flag tasks with application problems,

• Use QuickPredict to predict performance from different sites, and

• Optional: Use Discrete Event Simulation (DES) to predict response times or 
perform server capacity planning.

ACE Inputs and Outputs

The ACE Editors require ACE traffic data (atc.m) files (called “trace files” or 
“capture files” as input. Trace files are simply a snapshot of the application traffic 
in your network. This traffic is in the form of packets generated by your 
applications. Assuming that the trace files were captured correctly, their traffic 
information would be more accurate that any user approximations of real-world 
traffic using IERs in NETWARS.
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The ACE Editors analyze your traffic data and present results in:

• Reports, graphs, and tables,

• Visualization of application behavior,

• Diagnosis of bottlenecks and performance problems,

• Predictive analysis of same traffic on different network, and

• Information NETWARS can use for capacity planning studies.

ACE Features and Tools

ACE provides several important features and tools to help you visualize, 
analyze, diagnose, and predict network traffic behavior. 

For additional product information, access the ACE User Guide by selecting 
Help > ACE Product Documentation from within ACE.

Visualization Features

ACE includes three different windows for viewing your application; often you can 
troubleshoot an application just by viewing it in one of these windows. You can 
also use these windows to remove or delete sections of an ACE file, and thereby 
focus on transactions of interest:

• Treeview window—Organizes a task into tier pairs, connections and frames. 
This window also shows summary information and a timeline of the individual 
transactions that make up your application.

• Data Exchange Charts—Use a timeline to show the overall flow of data 
between tiers. You can view applications from both the network and the 
application layer, quickly determine inefficient or “chatty” applications, and 
pinpoint delays in both the network and the application.

• Tier Pair Circle window— View all tier-pair conversations in your ACE file. 
You can easily determine which tiers are conversing (and not conversing), 
view general information on each conversation, and zero in on conversations 
of interest.

Refer to Chapter 2 in this user’s guide for more information. For additional 
product information, access the ACE User Guide by selecting Help > ACE 
Product Documentation from within ACE.
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AppDoctor Tool

The AppDoctor feature includes three different tools for performing high-level 
analysis. You can use AppDoctor to identify and diagnose bottlenecks, 
determine the relative amounts of application vs. network delay, and view 
detailed statistics on your network and application. ACE also allows you to 
decode and analyze the protocol and application data found in individual 
packets.

Refer to Chapter 2 in this user’s guide for more information. For additional 
product information, access the ACE User Guide by selecting Help > ACE 
Product Documentation from within ACE.

Predictive Features

ACE includes four separate predictive features: QuickPredict, QuickRecode, 
discrete-event simulations, and ACE traffic flows.

• QuickPredict—This feature provides instant feedback on how network 
variations will affect an application’s performance. This allows you to answer 
questions such as, “If I double the bandwidth between two tiers, will it speed 
up my application’s response time?”.

• QuickRecode—You can use this feature to predict how proposed fixes and 
changes to your application will affect its performance. You do this by 
manually editing your ACE file to create a “hypothetical application” and 
comparing its performance to the original. This enables you to study 
questions such as, “How will my application be affected if my database could 
transmit a record in 30 messages, instead of the current 300?”

• Discrete-event ACE simulations—You can take full advantage of OPNET’s 
event-based simulation technology and model library to test your application 
in a wide variety of network scenarios. For example, you could create a 
“virtual deployment” of an FTP application to test the effects of multiple 
downloads on the application’s overall response time. Using the Import from 
ACE operation, you can easily generate and configure network scenarios 
based directly on an ACE task.

• Given an existing network, you can import end-to-end traffic directly from 
ACE. You can also scale the ACE traffic to model the effects of multiple 
iterations on a single node or multiple nodes. ACE traffic flows are especially 
useful when you want to study the effects of massive deployments, in which 
a discrete-event simulation of hundreds or thousands of transactions would 
require too much time or memory.
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Before You Begin

Before you can use the ACE Editors to perform traffic analyses, you must have 
ACE traffic data (atc.m) files to use as input. If you do not have these files, you 
can create them and import them for use in the ACE Editors. This involves two 
general steps:

1) Capturing application traffic—ACE uses raw traffic data, captured from your 
network, as the basis for modeling an application. You can use ACE’s 
application capture utility or a third-party tool such as Sniffer to create these 
capture files.

Refer to Appendix A in this user’s guide for more information. For additional 
product information, access the ACE User Guide by selecting Help > ACE 
Product Documentation from within ACE.

2) Importing the capture file—The ACE Import Wizard guides you through the 
process of importing your capture data. This wizard might prompt you for 
additional information about your network, such as tier locations and the 
bandwidths of certain connections. ACE can import multiple capture files of 
the same exchange and merge the results into an accurate, realistic model 
of your application. Using ACE’s capture and import features, you can 
model highly complex application exchanges that span many tiers.

ACE can import capture files from external programs like Sniffer and 
TCPdump. ACE also interfaces with the conversion utility ProConvert to 
support a wide variety of other formats.

Refer to Appendix B in this user’s guide for more information. For additional 
product information, access the ACE User Guide by selecting Help > ACE 
Product Documentation from within ACE.
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2 Troubleshooting Applications Using the ACE Editor

The ACE Editor provides visualization graphs, diagnosis charts, and predictive 
analysis features and tools to enable you to analyze ‘near real’ NETWARS 
traffic data obtained via capture agents from a real network without months of 
data gathering and error prone traffic approximations (i.e., IERs).

Use the ACE Editor features and tools described in this chapter to generate the 
most granular traffic description of NETWARS traffic available today.

Note—For instructions for capturing NETWARS traffic data using ACE’s 
application capture utility or a third-party tool such as Sniffer, refer to Appendix 
A. For instructions for importing captured data into the ACE Editor for analysis, 
refer to Appendix B.

Overview of ACE Editor Features

The ACE Editor provides three primary windows for visualizing your application:

• Treeview window—Organizes a task into tier pairs, connections and frames. 
This window also shows summary information and a timeline of the individual 
transactions that make up your application.

Figure 2-1   ACE Visualization Windows and Charts
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• Tier Pair Circle window— View all tier-pair conversations in your ACE file. 
You can easily determine which tiers are conversing (and not conversing), 
view general information on each conversation, and zero in on conversations 
of interest.

• Data Exchange Charts—Use a timeline to show the overall flow of data 
between tiers. You can view applications from both the network and the 
application layer, quickly determine inefficient or “chatty” applications, and 
pinpoint delays in both the network and the application.

For additional information about using ACE visualization windows and charts, 
access the ACE User Guide by selecting Help > ACE Product Documentation 
from within ACE.

Treeview Window

You can access the Treeview window by clicking the Treeview window toolbar 
icon. The Treeview window provides a breakdown of conversation pairs, 
organized in three views:

•  Tier Pairs – Application Messages,

•  Tier Pairs – Network Packets, and

•  Application Messages.

Figure 2-2   Sample Treeview window
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Each view has three panes:

• Tree pane (on the left-hand side) showing tier pairs, connections, and 
frames,

• Table pane (center) shows detailed statistics by tier pairs, connections, and 
frames, and

• Timeline pane (on the right-hand side) shows an overview of messages 
(color coded by size) over the time of the task.

Tier Pair Circle Window

The Tier Pair Circle window shows the flow of data between different tiers for a 
transaction. Each arrow (in a one-way conversation) or arrow pair (in a two-way 
conversation) represents a conversation between tiers.

The Tier Pair Circle can also be used to visualize other statistics, such as:

• Response times,

• Application turns,

• Application information (Messages, Data, Average size),

• Network information (packets, data, average size),

• Latency,

• Bandwidth,

• Effects of Protocol/Congestion,

• Max Application Bytes Per Turn (directional),

• Max Unacknowledged Data (directional),
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• Retransmissions, and

• Connections Resets.

Figure 2-3   Sample Tier Pair Circle Window and Menu

Data Exchange Chart

The Data Exchange Chart shows the data transferred between tiers on a time 
line. As with the Tier Pair Circle window, the colors of the application messages 
indicate the size of the messages. Each group’s color represents a histogram of 
message sizes.

Data provided on the Data Exchange Chart includes:

• Application messages (exchange between tiers),

• Application tiers,

• Network messages, 

• Time line of task,
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• Messages dependencies (application and network), and

• Application payload sizes.

Figure 2-4   Sample Data Exchange Chart with Application Chart Only

 

Dependencies 
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Figure 2-5   Sample Data Exchange Chart with Network Chart Only

Figure 2-6   Sample Data Exchange Chart with Application and Network Charts
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Overview of the ACE AppDoctor Tool

ACE’s AppDoctor tool automates the process of application troubleshooting. 
AppDoctor finds the major components of delay and determines the root cause 
of application performance problems. 

AppDoctor presents four (4) main tabbed windows, and if applicable, special 
tabs for specific statistical information:

• Summary of Delays window,

• Executive Summary window,

• Diagnosis window,

• Statistics window, and

• Special windows of statistical information (optional) for HTTP, Citrix ICA, 
Corba, and SOAP.

For additional information about AppDoctor, access the ACE User Guide by 
selecting Help > ACE Product Documentation from within ACE.

Summary of Delays Window

The AppDoctor Summary of Delays window divides the total application 
response time into separate components of network and application delay:

• Tier-Processing delay is the total time it takes to process the application at 
each tier, including user “think time”.

• Latency delay is the component of delay due to latency in the network. 
(Latency is the time required for 1 bit to be transmitted across the network. 
Using ping is one way to measure latency.)

• Bandwidth delay is the component of delay caused by the limited bandwidth 
of the network. 

• Protocol/Congestion delay is a metric of network restriction to packet flow. 
This restriction may be caused by packet queuing in the network 
(congestion), or by flow control mechanisms imposed by network protocols. 
TCP, for example, has several built-in flow control mechanisms.
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Figure 2-7   Sample AppDoctor Summary of Delays window

Executive Summary Window

The AppDoctor Executive Summary window provides the following information:

•  Total Transaction time,

•  Total Application data transferred,

•  Single greatest cause of delay,

•  Tiers in application, and

•  Bandwidth and latency at each tier.

Figure 2-8   Sample AppDoctor Executive Summary window
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Diagnosis Window

The AppDoctor Diagnosis window provides a detailed analysis of probable 
bottlenecks for the application. Bottleneck categories exist for both network and 
application issues and are identified by machine or by network segment.

Figure 2-9   Sample AppDoctor Diagnosis window
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Statistics Window

The AppDoctor Statistics window provides detailed task statistics by tier on 
various measures of network and application performance.

Figure 2-10   Sample AppDoctor Statistics window

Troubleshooting Applications Using the ACE Editor

The following sample use cases illustrate three common application problems: 
bandwidth constraints, “chatty” applications, and TCP window constraints. 
Follow the procedures in this section to import three example application packet 
traces that show these different application and network issues or problems. 
Read each trace file, one at a time, and then use ACE diagnosis, visualization, 
and statistics features to study each of the problem traces and evaluate the 
results and findings in ACE. 

Note—The following examples were presented at OPNETWORK 2004 in 
Session 1209, Introduction to Using ACE, as Lab 2. If you do not have access 
to the files that this procedure uses, you can still follow the procedure using the 
sample screens provided in this user’s guide.
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Use Case 1: Troubleshooting Bandwidth Constraints

Procedure 2-1   Diagnose an Application with Bandwidth Constaints

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture File(s) dialog box displays.

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

5 In the Select Capture File for Import dialog box, select the file named 
1209_LAB_2_Problem1, and then click Open.

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.

6 Proceed through the ACE Import Wizard screens without modifying any data. The 
Treeview window displays the following information.

Figure 2-11   Treeview window
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7 Click the Data Exchange Chart toolbar icon to switch to the Data Exchange Chart.

Figure 2-12   Data Exchange Chart

8 Click the AppDoctor toolbar icon, and then use AppDoctor to diagnose the trace.

This trace shows an application that is being constrained by bandwidth. Increasing 
the bandwidth would help this application with improved response time.

9 Click the QuickPredict toolbar icon, and then use QuickPredict to test the 
bottlenecks you find, and determine what changes would improve the response 
time (i.e., ranges, how much?)

The decision to be made involves weighing the cost of upgrading links vs. the gain 
in response time. A possible option would be to upgrade links in smaller increments 
to different user locations, based on urgency and user priorities.

10 Close all currently opened windows, except for NETWARS.

End of Procedure 2-1

Use Case 2: Troubleshooting Chatty Applications

Procedure 2-2   Diagnose a Chatty Application

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

 

UG2-2-12 NETWARS/Release 5.1



Introduction to the ACE Editors 2—Troubleshooting Applications Using the ACE Editor
3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture File(s) dialog box displays.

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

5 In the Select Capture File for Import dialog box, select the file named 
1209_LAB_2_Problem2, and then click Open.

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.

6 Proceed through the ACE Import Wizard screens without modifying any data. The 
Treeview window displays the following information.

Figure 2-13   Treeview window
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7 Click the Data Exchange Chart toolbar icon to switch to the Data Exchange Chart.

Figure 2-14   Data Exchange Chart

8 Click the AppDoctor toolbar icon, and then use AppDoctor to diagnose the trace.

This trace shows that the number of application “turns” (applications that are very 
“chatty”) could cause a considerable amount of delay, even for applications over a 
high-speed connection with low latency. A large number of turns through the 
connection will build up latency.

9 Click the QuickPredict toolbar icon, and then use QuickPredict to test the 
bottlenecks you find, and determine what changes would improve the response 
time (i.e., ranges, how much?)

The application would have to be modified to reduce its interaction/activity. This 
can be validated with “QuickRecode”.

10 Close all currently opened windows, except for NETWARS.

End of Procedure 2-2

Use Case 3: Troubleshooting TCP Window Constraints

Procedure 2-3   Diagnose an Application with TCP Window Contraints

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 
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3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture File(s) dialog box displays.

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

5 In the Select Capture File for Import dialog box, select the file named 
1209_LAB_2_Problem3, and then click Open.

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.

6 Proceed through the ACE Import Wizard screens without modifying any data. The 
Treeview window displays the following information.

Figure 2-15   Treeview window
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7 Click the Data Exchange Chart toolbar icon to switch to the Data Exchange Chart.

Figure 2-16   Data Exchange Chart

8 Click the AppDoctor toolbar icon, and then use AppDoctor to diagnose the trace.

This trace shows the application is constrained by the TCP window. The 
application could complete faster, but the TCP window size between the Client and 
Server was not set for optimum use by this application. This can be validated with 
QuickPredict.

9 Click the QuickPredict toolbar icon, and then use QuickPredict to test the 
bottlenecks you find, and determine what changes would improve the response 
time (i.e., ranges, how much?)

Operating systems have standard defaults for the TCP Window size (i.e., Windows 
NT = 8K, Windows 2K = 17K). Some applications programmatically set the TCP 
window size.

10 Close all currently opened windows, except for NETWARS.

End of Procedure 2-3

Analyzing an FTP Download

In the following example, the client is executing a large FTP download over a 
T1, but is only observing approximately 400 Kbps of throughput. The network 
has high and variable latencies. There are traces already captured at Client and 
FTP Server.
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We will merge the client trace with the FTP server trace within ACE to generate 
an accurate model of the transaction. This production environment, with 
high/variable latency, lends itself to diagnosing the problem using the ACE trace 
merge feature. Then we will use the ACE diagnostic and visualization 
capabilities to identify the bottleneck, and contrast trace merge to single trace 
import in this production environment.

Note—The following example was presented at OPNETWORK 2004 in Session 
1415, Application Capture and Import Strategies with ACE, as Lab 2. If you do 
not have access to the files that this procedure uses, you can still follow the 
procedure using the sample screens provided in this user’s guide.

Procedure 2-4   Analyze an FTP Download

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture File(s) dialog box displays.

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

5 In the Select Capture File for Import dialog box, select the file named 
1415_lab_2_FTP_download_client.enc, and then click Open. The selected 
file name displays in the Capture File column of the ACE Import: Choose Capture 
File(s) dialog box.

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.

6 Click Add Capture File. The Select Capture File for Import dialog box displays.
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7 In the Select Capture File for Import dialog box, select the second file named 
1415_lab_2_FTP_download_server.enc, and then click Open. The selected 
file name displays in the Capture File column of the ACE Import: Choose Capture 
File(s) dialog box.

Figure 2-17   ACE Import: Choose Capture File(s) dialog box

8 After you have specified the two (2) capture file(s) to import in the ACE Import: 
Choose Capture File(s) dialog box, click Next. The ACE Import: Rename Hosts 
dialog box displays.

9 Assign a Tier Name to each Hostname as indicated below.

Figure 2-18   ACE Import: Rename Hosts dialog box

10 Click Next. The ACE Import: Specify Tier Locations dialog box displays.

Notice that both Tiers’ locations were Auto-detected by ACE. When the traces 
being merged contain shared traffic, ACE will auto-detect tier locations.

11 Click Next. The ACE Import: Specify Bandwidth/Latency between Locations dialog 
box displays.

12 Specify the bandwidth and latency between the capture locations. Specifying this 
information is very important for accurate AppDoctor results.

12.1 Specify 1,544 (Kbps) as the Bandwidth.
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12.2 Note that the One-way Latency was Auto-Detected by ACE.

Figure 2-19   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

13 Click Next. The Save Import Configuration dialog box displays.

To finish the import, you can save an import configuration to avoid typing in all of 
the information again if you were to import another set of traces that were captured 
at the same locations. You can also select the view that will be launched when the 
import completes.

14 In the Save Import Configuration dialog box, click Finish to complete the import 
process.

15 View the merged result using the Data Exchange chart (shown below).

Figure 2-20   Data Exchange Chart
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16 For diagnosis, select AppDoctor > AppDoctor Analysis or click the AppDoctor 
toolbar icon, and display AppDoctor’s Summary of Delays window.

Figure 2-21   Summary of Delays window

17 Use the drop-down menu to view the various options (bar chart, pie chart, exploded 
pie chart).

The big portion of delay seems to be Protocol/Congestion.

18 Click the Executive Summary tab to display the Executive Summary window.

Figure 2-22   Executive Summary window
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19 Click the Diagnosis tab to display the Diagnosis window.

Figure 2-23   Diagnosis window

TCP Windowing (Server to Client) seems to be the bottleneck.

20 Click Close to close AppDoctor.

21 Zoom in on the network on the Data Exchange Chart by selecting Network chart 
only from the drop-down list.

Figure 2-24   Data Exchange Chart drop-down list

22 Select View > Set Visible Time Range from the Data Exchange Chart’s menu bar. 
Set the time range to “10.83 – 11.06”.
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23 Check the accuracy of the trace merge.

Figure 2-25   Data Exchange Chart with Network chart only

The Server is very clearly waiting for TCP ACKs before sending additional data. 
Note that large (blue) data packets are sent out simultaneously, but arrive 
fanned-out, which is caused by queuing in the network. The accurate, fanning-out 
visualization only exists with trace merge.

24 Compare the two-trace approach with the approach of only capturing traffic on the 
client side.

24.1 Do not close the existing trace; instead select File > New > ACE, and then 
click OK. The ACE Import: Choose Capture File(s) dialog box displays.

24.2 Click Add Capture File. The Select Capture File for Import dialog box 
displays.
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24.3 In the Select Capture File for Import dialog box, select the file named 
1415_lab_2_FTP_download_client.enc, and then click Open. The 
selected file name displays in the Capture File column of the ACE Import: 
Choose Capture File(s) dialog box.

Figure 2-26   ACE Import: Choose Capture File(s) dialog box

24.4 Click Next. The ACE Import: Rename Hosts dialog box displays.

24.5 Assign a Tier Name to each Hostname as indicated below.

Figure 2-27   ACE Import: Rename Hosts dialog box
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24.6 Click Next. The ACE Import: Specify Tier Locations dialog box displays.

Figure 2-28   ACE Import: Specify Tier Locations dialog box

Notice that both Tiers have the same location. In a single trace import you 
need to input tier location.

This trace was captured near the Client; you need to change the Server Tier 
from Local to Site 1 to Remote.

24.7 Left-click the Tier Location for the Server and select Remote.

Figure 2-29   ACE Import: Specify Tier Locations dialog box

24.8 Click Next. The ACE Import: Specify Bandwidth for Segment dialog box 
displays. As the following screen is the Client side, leave it as is.

24.9 Click Next. The ACE Import: Specify Bandwidth/Latency between Locations 
dialog box displays.
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24.10Input the bandwidth and latency for the Server Bandwidth “1,544” (Kbps) and 
One-Way Latency “77.7” (ms) (this latency value was previously determined 
during trace merge.)

Figure 2-30   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

24.11Click Next. The Save Import Configuration dialog box displays.

24.12In the Save Import Configuration dialog box, click Finish to complete the 
import process.

24.13Zoom in on the network on the Data Exchange Chart by selecting Network 
chart only from the drop-down list.

Figure 2-31   Data Exchange Chart drop-down list
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24.14Select View > Set Visible Time Range from the Data Exchange Chart’s 
menu bar. Set the time range to “10.83 – 11.06”.

Figure 2-32   Data Exchange Chart with Network chart only

It is not as obvious that the Server was waiting for the TCP ACKs before 
sending additional data. Since only the Client trace was imported, the fact that 
all the large (blue) data packets were actually sent out simultaneously is not 
visible.

From this example, we can conclude that a trace merge paints a more accurate 
picture in high-latency, low-bandwidth environments.

End of Procedure 2-4
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3 Predicting Application Performance Using ACE 
Whiteboard 

Introduction

The ACE Whiteboard is an easy-to-use graphical environment for defining the 
behavior of an application. It is licensed as part of the ACE Module. You can use 
the ACE Whiteboard to create models of applications that do not yet exist. Also, 
you can substantially edit the behavior of applications captured with ACE in a 
lab or production environment. The application models created in the ACE 
Whiteboard can then be used in planning and prediction studies using 
QuickPredict or discrete event simulation.

Sample Use Cases

The ACE Whiteboard allows you to graphically create and modify application 
definitions, ranging from small changes to existing applications captured with 
ACE to creating new application models entirely from scratch. 

Sample use cases for the ACE Whiteboard include the following: 

• Use Case 1: You have captured an ACE trace of an application that currently 
exists in your network. This application always downloads an image of a fixed 
size. You are interested in studying how the application will perform if a 
different image size is used. You can use the ACE Whiteboard to: 

— Import the existing ACE file of the transaction,

— Change the image size, and

— Use QuickPredict or Discrete Event Simulation to predict performance.

An alternative approach is to parameterize the image size. This technique is 
shown in the section “Modify an Existing ACE File”, provided later in this 
chapter. 

• Use Case 2: You have captured an ACE trace of a database application that 
currently exists on your network. This application has a variable number of 
SELECT statements, and the amount of data returned per statement is also 
variable. You can use the ACE Whiteboard to: 

— Import the existing ACE file of the transaction,

— Use distributions for the number of requests and sizes of the responses, 
and

— Use Discrete Event Simulation to study the variability of the application’s 
response time.
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• Use Case 3: You have captured an ACE trace of an application that includes 
a significant amount of user think time. You wish to study the response time 
of this application without user think time. You can use the ACE Whiteboard 
to: 

— Import the existing ACE file of the transaction, 

— Change the dependencies on the client to only reflect tier processing 
time, and

— Use QuickPredict or Discrete Event Simulation to predict performance.

• Use Case 4: You are planning to add more robust authentication to an 
existing login transaction. You have an ACE capture of the existing login and 
a separate ACE capture of the authentication transaction. You can use the 
ACE Whiteboard to: 

— Import the two existing transactions into two separate ACE Whiteboard 
models, and

— Copy the first transaction and paste it into the second ACE Whiteboard 
model.

A more advanced and flexible alternative is to use the ACE Whiteboard 
Scripting API to dynamically invoke or call one transaction from the other. 
This technique is shown in the tutorial “Advanced: Modeling an Application 
Using Logic Scripts” available by selecting Help > ACE Tutorials in ACE 
Whiteboard. 

• Use Case 5: You are interested in predicting the response times for an 
application that either does not currently exist or cannot be captured in ACE. 
Based your knowledge of how the application behaves, you can graphically 
draw the application layer data exchange in the ACE Whiteboard. More 
advanced users can take advantage of Python scripting and the ACE 
Whiteboard Scripting APIs to introduce sophisticated logic into the 
application definition. 

This last use case is the subject of the next section, “Create a New Application 
Model.”

Create a New Application Model 

In this section, you will use the ACE Whiteboard to model the behavior of the 
OPNET Capture Agent when finishing a capture. (Note that this tutorial is also 
available by choosing Launch the ACE Whiteboard Tutorial from the ACE 
Whiteboard Startup Wizard Welcome dialog box, or selecting Help > ACE 
Tutorials in ACE Whiteboard.)
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The OPNET Capture Agent is a utility for performing packet captures. When a 
user finishes a capture, the capture file is automatically transferred to the 
Capture Manager. However, if the capture is performed over a low-bandwidth 
link or on a heavily congested network, it may not be desirable to immediately 
transfer the capture file from the agent back to the Capture Manager.

Objectives 

1) Create a new ACE Whiteboard model.

2) Use QuickPredict to determine the expected response time to four remote 
locations.

Understanding the Application’s Behavior 

The following is a description of the application’s behavior: 

• The Capture Manager sends a 50-byte message to the capture agent and 
receives a 100-byte response. 

• The Capture Manager sends a 600-byte request for the file; the Capture 
Agent then responds by sending the capture file.

Creating a New ACE Whiteboard Model

Procedure 3-1   Create a New ACE Whiteboard Model

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE Whiteboard, and then click 
OK. The ACE Whiteboard Startup Wizard launches and displays the Welcome 
dialog box.

Figure 3-1   ACE Whiteboard Startup Wizard Welcome dialog box
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4 In the Welcome dialog box, select Create application from scratch, and then 
click Next. The ACE Whiteboard Startup Wizard displays the Specify Tiers dialog 
box.

Figure 3-2   ACE Whiteboard Startup Wizard Specify Tiers dialog box

5 In the Specify Tiers dialog box, specify the names of the tiers; type 
capture_manager in the first row, and capture_agent in the second row, as 
shown in the figure above.

6 Click Next to advance to the next wizard dialog box, and then click Finish to close 
the startup wizard. Your ACE Whiteboard model now contains the two tiers 
specified in the wizard, capture_manager and capture_agent. Now you are ready 
to add messages to the model. 

7 From the Insert menu, choose Message. The cursor in the Data Exchange Chart 
changes color from blue to green when you enter message creation mode. 

8 Create the first message from the capture_manager to the capture_agent:

8.1 Click the capture_manager line to specify the source tier and start time of the 
message. 
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8.2 Click the capture_agent line to specify the destination tier. A green arrow 
displays between capture_manager and capture_agent.

Figure 3-3   First Message from capture_manager to capture_agent

Note—Since this is the only message in the trace, the start time of the message is 
automatically shifted to 0.0 seconds. 

9 Create the response from the capture_agent to the capture_manager: 

9.1 Click the capture_agent line just to the right of the reception of the first 
message. 
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9.2 Click anywhere on the capture_manager line to complete the second 
message. (The reception time for the newly drawn message is determined by 
the Simple Network Estimation settings in the lower-left hand corner of the 
ACE Whiteboard window). Also note that each newly created message is 
automatically added to the Message Editor. 

Figure 3-4   First Response from capture_agent to capture_manager

9.3 Right-click on a blank section of the Data Exchange Chart to exit message 
creation mode. The cursor changes from green back to blue. 

10 Edit the sizes and the dependency between the first two messages: 

10.1 Make sure the two messages are displayed in the Message Editor. If the 
Message Editor is empty, select the two messages in the Data Exchange 
Chart. 

10.2 Click in the Bytes cell for the first message (ID: 1). From the drop-down menu, 
choose Edit..., and then type 50 as the new size. The color of the arrow will 
change to orange. 

10.3 For the second message (ID: 2), change the Bytes value to 100. 
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10.4 By looking at the value in the Depends On column for the second message, 
you can see that message 2 depends on message 1. Double-click on the 
Processing Time cell for the second message, and change the value to 
0.005.

Figure 3-5   Edit Size/Dependency between First Two Messages

11 Create the next request/response pattern between capture_manager and 
capture_agent: 

11.1 From the Insert menu, choose Message.

11.2 Create another request message from capture_manager to capture_agent, 
following the procedure outlined in step 8.

11.3 Create the response message from capture_agent to capture_manager, 
following the procedure outlined in step 9. 

11.4 Right-click on a blank section of the Data Exchange Chart to exit message 
creation mode. 

11.5 Change the size of message 3 to 600. 

11.6 Change the size of message 4 to 100,000. 

11.7 Change the Processing Time delay of message 3 to 0.01. 
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11.8 Change the Processing Time delay of message 4 to 0.2, as shown in the 
figure below. 

Figure 3-6   Edit Size/Dependency between Next Two Messages
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12 Change the zoom level to Full Zoom by right-clicking on a blank portion of the Data 
Exchange Chart, and then choosing Full Zoom from the short-cut menu. 

Figure 3-7   View with Full Zoom Selected

Notice that the large message from capture_agent to capture_manager takes 
longer to arrive than the three smaller messages. To make it easier to draw and 
edit messages, the ACE Whiteboard determines the reception time of each 
message based on a single bandwidth and latency value. This is known as Simple 
Network Estimation.
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13 In the lower-left corner of the ACE Whiteboard window, uncheck the Simple 
Network Estimation checkbox. With Simple Network Estimation turned off, each 
message displays straight up-and-down.

Figure 3-8   View with Simple Network Estimation Unchecked

Note—The Simple Network Estimation settings can be used to make an 
application’s behavior easier to visualize. The settings do not impact any 
simulation results. 

13.1 Recheck the Simple Network Estimation checkbox. 

14 Select File > Save As..., and save your ACE Whiteboard model as 
<your_initials>_ tutorial_create_new_model. 

End of Procedure 3-1
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Using QuickPredict to Determine Expected Response Time

Using the ACE Whiteboard, you created an application model that defined the 
communication between the Capture Manager and Capture Agent when 
downloading a file. Next, you will use QuickPredict to evaluate how this 
application will perform on a variety of network conditions. 

Procedure 3-2   Use QuickPredict to Determine the Expected Response Time 

1 From the Prediction menu in ACE Whiteboard, choose QuickPredict. The 
QuickPredict dialog box displays.

2 Click Load Template.... 

3 Select the file tutorial_new_model.ace.qpb in 
C:\Netwars\Scenario_Builder\11.0.A\models\std\tutorial_req\m
odule.

4 Click the Open button. The specified template is applied to the QuickPredict results 
and the following bar chart displays.

Figure 3-9   QuickPredict Bar Chart
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This chart shows the results of running this application from the four locations with 
the specified bandwidth and latency values. Notice that it takes significantly longer 
to retrieve the capture file when running across a low-bandwidth link. 

Using QuickPredict Bar Charts

You can use elements provided in the QuickPredict Bar Chart window as follows:

• Parameter Slider: When you put a parameter on the slider, you can see instant 
result updates by moving the slider bar. To put a parameter on the slider, click in 
the parameter cell in the table and choose Put on Slider. 

• Parameter/Scenario/Tier pair—Indicates which item is on the slider bar. 
These fields are empty if nothing is on the slider. 

• Value—Current value of the slider. To set the slider to an exact value, click 
in this field. 

• Min and Max fields—Below the slider to the left and right, these specify the 
range of the slider.

• Graph Options: Control some display options for the graphical results.

• Label categories—Show labels for tiers and tier pairs. To specify a 
threshold, click in the percent field. A low threshold might cause labels to 
overlap. 

• Show SLA—When this option is enabled, a vertical dashed line indicates 
the SLA time. Click in the field to enter an SLA (in seconds) or choose 
"Don't Show SLA" to make the SLA line disappear.

• Update Results button—Updates all results. You must click this button after 
making any change to the table.

• Add Scenario button—Adds a new scenario. To remove a scenario, right-click 
in an open part of the "Bar Charts" domain.

• Save Template button—Saves your current set of scenarios to a text file, which 
you can either edit or load for this or a different ACE task.

• Load Template button—Loads scenarios from a template file and overwrites 
any existing scenarios. If the tier names do not match exactly, ACE might prompt 
you for the correct mapping.

• Close button—Closes the QuickPredict Bar Chart window. If you reopen this 
window without closing ACE, your current results will reappear.

• Scenario Input Table: Controls the values for the different network scenarios.

• Name—To edit a scenario name, click in the table cell. The new name 
appears in the results panel after you click Update Results. 

• Other columns—You can change the value of any parameter for any tier 
pair for any of your scenarios. To put a value on the slider, click on the cell 
and choose Put On Slider. To remove an item from the slider, click on the 
cell again and choose another value for the parameter. You must click 
Update Results after making any changes in this table.

• Bar Charts Page: Shows a graphical representation of the results. ACE creates 
one bar for every (scenario/task) combination.
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• Right-click options—Right-clicking in an open part of this pane will allow 
you to remove traces and scenarios. 

• Tooltips—If you hold your tooltip over a result bar, the exact time for that 
component will be displayed.

• Tabular Results Page: Shows the exact numbers for the components of 
response time for the (scenario, trace) pairs. Not all categories (such as app 
delay for a tier pair) will have values; these will be denoted with an “N/A”.

• Right-click options—If you right-click in the table, you can copy the entire 
table to the system clipboard.

5 Click the Close button to close QuickPredict. 

6 Select File > Save to save your model. 

7 Select File > Close to close the ACE Whiteboard. 

End of Procedure 3-2

Conclusion 

In this section, you learned how to use the ACE Whiteboard to model the 
behavior of the OPNET Capture Agent when finishing a capture. You also 
learned how to use QuickPredict to determine the expected response time to 
four remote locations.

Additional Details 

• To add more flexibility to your ACE Whiteboard model, you could have 
parameterized the size of the capture file that the Capture Agent sends back 
to the Capture Manager. You will see an example of this in the next section, 
“Modifying an Existing ACE File”.

• Instead of creating messages 3 and 4 using the Insert > Message operation, 
you could have copied and pasted messages 1 and 2, and then edited the 
message sizes and dependency values. This technique is useful when 
copying a large block of messages, especially when moving them from one 
file to another. 

• You can also create messages using keyboard shortcuts using Rapid 
Message Creation. For example, to create a message that starts at tier 1 and 
ends at tier 2, press Ctrl + 1 then Ctrl + 2. To create a message from tier 3 
to tier 2, press Ctrl + 3 then Ctrl + 2. See the documentation (Help > ACE 
Product Documentation) for more details.

• If you want to create a repeating pattern of messages (such as a 120 byte 
SELECT statement and a 400 byte response, repeated 1,000 times), you can 
use a Message Group (Insert > Message Group). For more information, 
look at the “Message Group Operations” section of the “ACE Whiteboard – 
User Interfaces and Procedures” chapter of the ACE User Guide. 
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• If you want to change the same value on many messages in the Message 
Editor, you can use multi-message editing. This can be used, for example, to 
move 30 messages from one connection to another connection. For more 
information, see the topic “Multi-Message Editing,” which is in the “Message 
Operations” section of the “ACE Whiteboard – User Interfaces and 
Procedures” chapter of the ACE User Guide.

Modifying an Existing ACE File 

In the following section, assume that you have been asked to determine the 
expected response time for a portion of a new “Staff Listing” application that will 
be rolled out in a few months. You have used ACE to capture a beta version of 
this application, and you will now use the ACE Whiteboard to create an 
application model that accurately represents the anticipated final application 
version. (Note that this tutorial is also available by choosing Launch the ACE 
Whiteboard Tutorial from the ACE Whiteboard Startup Wizard Welcome 
dialog box, or selecting Help > ACE Tutorials in ACE Whiteboard.)

Objectives 

1) Import an existing ACE file into the ACE Whiteboard. 

2) Modify the application model so that it matches the final version of the 
application. 

3) Parameterize the size of a message so that you can change the size of the 
message in the project editor, and have different applications that use the 
same Whiteboard model, but have different message sizes. 

Importing an ACE Whiteboard Model

Procedure 3-3   Import an ACE Whiteboard Model 

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 
UG2-3-14 NETWARS/Release 5.1



Introduction to the ACE Editors 3—Predicting Application Performance Using ACE Whiteboard
3 From the Open Editor drop-down menu, select ACE Whiteboard, and then click 
OK. The ACE Whiteboard Startup Wizard launches and displays the Welcome 
dialog box.

Figure 3-10   ACE Whiteboard Startup Wizard Welcome dialog box

4 In the Welcome dialog box, select Import application from ACE, and then click 
Next.

5 In the subsequent dialog box, choose the ACE file 
tutorial_staff_listing_beta under 
C:\Netwars\Scenario_Builder\11.0.A\models\std\tutorial_req\m
odule and then click Import. The existing ACE file imports into the ACE 
Whiteboard. 

6 In the Data Exchange Chart, notice that the task contains three tiers and some 
messages.

Figure 3-11   Task containing three tiers and multiple messages

7 Select File > Save, and then save the file as 
<your_initials>_tutorial_auth. Leave the file open. 
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The file imported from ACE contains the messages sent as a result of the client 
selecting the division of interest from a Web page. The first message from Client to 
Oracle App Server is the HTTP POST message. The Oracle App Server processes 
this message and requests the appropriate data from the Oracle DB Server. The 
Oracle App Server then sends a Web page containing the requested data back to 
the Client. 

End of Procedure 3-3

Modifying the Application Model in the ACE Whiteboard

Prior to sending a message to the Oracle DB Server, the Oracle App Server 
needs to authenticate with the Authentication Server. 

Procedure 3-4   Modify the Application Model in the ACE Whiteboard 

1 Insert a new tier for the Authentication Server. 

1.1 Select Insert > Tier from the main menu.

1.2 In the Insert Tier dialog box, enter Authentication Server as the tier name.

Figure 3-12   Insert Tier dialog box

1.3 Click OK. 

2 Create a single request/response pattern between Oracle App Server and 
Authentication Server. 

2.1 Select Insert > Message from the main menu.

2.2 Click on the Oracle App Server tier just after the orange message.

2.3 Click on the Authentication Server tier to complete the message.

2.4 Click on the Authentication Server tier just after the arrival of the newly 
created message.

2.5 Click on the Oracle App Server tier to complete the message. 
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2.6 Right-click in the workspace to exit message creation mode.

Figure 3-13   Single request/response pattern between two tiers

3 Modify the first message between Oracle App Server and Oracle DB Server so that 
it is dependent on the last message you just created. Notice that this message is 
currently dependent on the orange message from the Oracle App Server to the 
Client.

3.1 In the Data Exchange Chart, right-click on the dependency just before the 
first message from Oracle App Server to Oracle DB Server (the yellow 
message). 

3.2 Select Change Parent Dependency. 

3.3 Click on the Oracle App Server tier near where the green message from 
Authentication Server to Oracle App Server was received. Notice that this 
causes the yellow message to shift to the right.

Figure 3-14   Edit Parent Dependency

4 Edit the two green messages you created in Step 2.
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4.1 Select the two messages in the Data Exchange Chart. You can select the 
two messages by clicking in the background, holding the mouse button down, 
and drawing a rectangle around the two messages. Alternatively, you can 
shift-click to select the messages individually.

Figure 3-15   Select Messages with a Rectangle

4.2 In the Message Editor, change the size of the first green message (ID: 15) to 
50. 

4.3 Change the size of the second green message (ID: 16) to 100. 

4.4 Change the Processing Time value of the first green message (ID: 15) to 
0.05. 

4.5 In the Message Editor, change the Processing Time value for the second 
green message (ID: 16) to a Uniform distribution from 0.2 to 0.3:

• Click in the Processing Time field for the response message (ID: 16). 

• Select Edit As Distribution..., and then change the distribution to Uniform 
in the Specify Distribution dialog box. 

• Change the Minimum Outcome to 0.2.

• Change the Maximum Outcome to 0.3.

Figure 3-16   Specify Distribution dialog box

• Click OK. The Message Editor should now look like the following figure.

Figure 3-17   Edit Size/Processing Time between Two Messages
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5 Change the zoom level to Full Zoom by right-clicking on a blank portion of the Data 
Exchange Chart, and then choosing Full Zoom from the short-cut menu. At this 
point, the Data Exchange Chart should look similar to the following figure.

Figure 3-18   View with Full Zoom Selected

6 Select File > Save to save the file. Leave the file open. 

At this point, you have imported an ACE file into the ACE Whiteboard, created a 
new tier, added two messages, used a distribution to specify a processing time 
dependency, and reassigned a message’s parent dependency.

End of Procedure 3-4

Adding a Parameter to the ACE Whiteboard Model 

Assume that based on your knowledge of the application, you know the size of 
the last response message from the Oracle DB Server to the Oracle App Server 
depends on the number of employees in the division (specified by the user in 
the initial request). Since you want to be able to change this value in the Project 
Editor prior to running a simulation, you should parameterize the response size. 

Procedure 3-5   Add a Parameter to the ACE Whiteboard Model 

1 Add a parameter to the task: 

1.1 Select Scripting > Declare Parameters....The Declare Parameters dialog 
box displays. 

1.2 Click Add to add a new row to the table.
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1.3 Specify the Parameter, Type, Default Value, and Description values as 
shown in the figure below.

Figure 3-19   Declare Parameters dialog box

1.4 Click OK. 

2 Identify the last message from Oracle DB Server to Oracle App Server by giving it 
a unique tag. This will allow you to access this message from within a logic script.

2.1 In the Data Exchange Chart, select the last message from Oracle DB Server 
to Oracle App Server. 

2.2 In the Message Editor, click the Tag field for message 11, and then change 
the value to db_response. 

Figure 3-20   Edit Message Tag

3 Logic scripts can be used to dynamically modify the behavior of an application 
model. You will write a logic script that changes the size of the db_response 
message based on the value of the parameter num_employees. 
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3.1 Add a logic script before the message you just tagged as db_response. 
Right-click on the dependency before the message and choose Add Logic 
Script at End.

Figure 3-21   Add Logic Script at End

3.2 The Edit function window displays. Add the following lines of code to the logic: 

num_employees = self.get_parameter ('num_employees') 
response_msg = self.get_message ('db_response') 
response_msg.size = num_employees * 2000

3.3 Select File > Save to save the logic script. 

End of Procedure 3-5

Using QuickPredict to Determine the Expected Response Time 

Procedure 3-6   Use QuickPredict to Determine the Expected Response Time 

1 From the Prediction menu, choose QuickPredict. The QuickPredict dialog box 
displays.

2 Click Load Template.... 

3 Select the file tutorial_staff_listing_modified.ace.qpb in 
C:\Netwars\Scenario_Builder\11.0.A\models\std\tutorial_req\m
odule. 

 

→
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4 Click the Open button. The specified template is applied to the QuickPredict results 
and the following bar chart displays.

Figure 3-22   QuickPredict Bar Chart with num_employees parameter set to 15

Notice that the revised application takes less than 1 second to complete when 
there are 15 employees. (Note: We gave the parameter num_employees a default 
value of 15 earlier in this procedure.)

5 In the main ACE Whiteboard window, select Scripting > Declare Parameters. 
Change the default value of num_employees to 200, and then click OK. 
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6 In QuickPredict, click the Update Results button.

Figure 3-23   QuickPredict Bar Chart with num_employees parameter set to 200

Notice that increasing the default value for the num_employees parameter caused 
an increase in the response time of the application. 

7 Click the Close button to close QuickPredict. 

8 Select File > Save to save your model. 

9 Select File > Close to close the ACE Whiteboard. 

End of Procedure 3-6

Conclusion

Starting with an ACE file of a beta version of your application, you used the ACE 
Whiteboard to modify the behavior of the application. These modifications 
included adding a request/response pattern to a new Authentication Server tier, 
changing the parent dependency of a message, adding variability to the 
application using a distribution, and specifying the size of a message based on 
a parameter. You also learned how to use QuickPredict to determine the 
response time of the application for two different values of the parameter. 
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Additional Details

• In this section, you wrote a logic script to dynamically change the size of a 
message based on a parameter. If you had deployed this application on a 
network in the Project Editor to run a Discrete Event Simulation, you would 
be able to specify the message size in the ACE Parameters field of the task 
specification. 

• Instead of manually adding a request/response pattern to an authentication 
server, you could have created a separate ACE Whiteboard file to handle the 
authentication. Then, you could have invoked your authentication 
Whiteboard file. You can see an example of this in the tutorial “Advanced: 
Modeling an Application Using Logic Scripts” available by selecting Help > 
ACE Tutorials in ACE Whiteboard.

• When making a large number of changes to an ACE Whiteboard file, it is 
often useful to turn on Multi-Message Editing Mode via the Edit menu. See 
the documentation (Help > ACE Product Documentation) for more details. 
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App A Capturing Application Traffic

Introduction

The first step to creating a model of your application using ACE is recording 
application transactions in one or more capture files. ACE uses raw traffic data, 
captured from your network, as the basis for modeling an application. You can 
use ACE’s application capture utility to create these capture files (also known 
as “packet trace files”), or you can use files that were captured using other 
third-party tools and/or probes (then converted by third party utilities.) ACE 
accepts capture file formats including:

• OPNET .appcapture

• Network Associates’ Sniffer

— Industry-standard Binary Ethernet format (.enc, .cap). Other analyzers 
(such as NetScout) can also generate .enc files.

— Binary Token Ring format (.trc)

— Binary FDDI format (.fdc) 

• Free utilities, such as TCPdump and Windump

• Comma Separated Value file (.csv)

Documentation on specific analyzers is beyond the scope of this user’s guide, 
as individual equipment can vary. However, you should follow these general 
guidelines when you capture traffic to import into ACE:

• Configure your analyzer’s filtering capabilities to focus on hosts of interest. 
Filtering keeps your trace file shorter and enables your analyzer to 
accommodate a longer duration for your capture, given limited memory and 
disk resources.

• Aim for as “clean” a trace as possible. You might want to run and record your 
application at a time when network traffic is minimal–such as late in the 
evening or during the weekend–to keep as many irrelevant packets out of the 
capture file as possible.

• If using network probe and you are limited in the number of probes available, 
place your analyzer as close as possible to the application instance(s) 
relevant to your studies. For example, if you want to study performance on a 
file server, you should capture on the same LAN as the server so that 
network delays across a WAN link or the Internet do not affect the analyzer’s 
view of the relevant information (application performance on the file server).

• Capture one application exchange in its entirety. For example, if want to 
study an FTP application, you should capture the exchange from the initial 
request from the client host to the conclusion of the download. The 
application exchange should not include user “think time.” This is especially 
important if you want valid results and diagnoses from AppDoctor. ACE does 
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not distinguish between processing delay at a tier and user think time (that 
is, the delay when an application simply waits for input from a user). If the 
captured exchange does include user think time, you might want to divide the 
resulting ACE task into multiple tasks, then analyze each task individually. To 
do this, you would:

— Open the original task,

— Exclude or delete packets so only a specific phase is included, and

— Save the task under a different name (for example, 
FTP_download_phase_1).

Repeat this process for each part of the original task, so you have a group of 
individual tasks that record the entire transaction, minus think time.

Using ACE Capture Agents

You can use the ACE application capture utility to record traffic throughout your 
network and import the data into ACE. This utility uses capture processes 
(called capture agents) that enable you to capture traffic from multiple locations 
simultaneously. ACE includes an Application Capture Manager so you can 
manage all capture agents and operations from your NETWARS computer.

Before you can capture traffic using this utility, you must:

• Install a capture agent on every computer where you want to capture traffic, 
and

• Create a capture agent list, which specifies the agents you want to use for a 
capture operation and the configuration settings for each agent.

Install/Uninstall and Troubleshoot Capture Agents

Before you can capture traffic, you must first install capture agents on the 
computers where you want to capture traffic. A capture agent resides on a local 
or remote computer. It records packet-by-packet traffic in response to 
commands from the Application Capture Manager (Start Capture, Finish 
Capture, etc.)

Install Capture Agents

ACE includes agent installers for several platforms, including Windows, Solaris, 
Linux, HP/UX, and AIX. You can download installers and instructions for all 
available platforms from the Support Center section of the OPNET website 
(http://www.opnet.com/support).
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Place Capture Agents

Place agents on or near tier(s) involved in an application conversation. For a 
single trace import, place the agent on or near the most active tier, or near the 
tier of most interest. If it is not possible to place agents on a tier, consider port 
mirroring, hubs, passive taps, etc.

Troubleshoot Capture Agents

The OPNET Support Center maintains a set of Frequently Asked Questions 
(FAQs) that address common questions and issues involving ACE capture 
agents. To search the FAQ database for the latest troubleshooting information 
on capture agents, go to http://www.opnet.com/support and follow the “FAQ” 
link. To obtain a list of useful FAQs, search for the string “ACE capture agents”; 
you also might want to search based on a specific error message you receive.

Uninstall Capture Agents

The FAQ database includes several entries that describe how to uninstall ACE 
capture agents. Go to http://www.opnet.com/support and follow the “FAQ” link. 
To obtain a list of relevant FAQs, search for the string “uninstall.”

Creating a Capture Agent List

After you install your capture agents at the desired locations, the next step is to 
create a capture agent list. An agent list specifies the agents to use during a 
capture and the configuration settings to use with each agent.

Procedure A-1   Create a Capture Agent List

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture Files dialog box displays.

4 Click Open Capture Manager.The Application Capture Manager window displays.

Note—You can also open the Application Capture Manager by selecting File > 
Application Capture Manager in the ACE Treeview window, Data Exchange 
Chart, or Tier Pair Circle.
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Figure A-1   Application Capture Manager

5 For each agent you want to add to the list, perform the following steps:

5.1 Click Add Agent.The Remote Application Capture Agent Editor window 
displays.

Figure A-2   Remote Application Capture Agent

5.2 Specify the computer where the agent resides in the Hostname field. You can 
use either a computer name or an IP address.

5.3 An agent can capture traffic on one network interface only. If the host 
computer has multiple network adapter cards, set the Agent network 
adapter radio buttons to enter a specific interface.
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5.4 If a host computer has multiple interfaces, you can create separate agents 
(one per interface) for that computer. This is essentially equivalent to creating 
agents on separate computers. When you create multiple agents for the same 
computer, you must specify the interface for each agent under Agent 
network adapter; do not use the default setting of “Any”.

5.5 Configure other settings for your agent as needed:

• Capture Service TCP Port field—Port on which the Capture Manager and 
capture agent communicate. This port is set when installing the capture 
agent. The default is 27401.

• Promiscuous Mode checkbox—When enabled, the agent captures all 
traffic seen by the host on that LAN segment.

• Maximum Size of Packet Data To Store (Bytes) field—Specifies the 
maximum number of bytes from each packet that the agent should include 
in a capture file.

• Agent Buffer Size (Kbytes) field—Specifies the buffer size used by the 
capture agent to store packet-trace data before it gets saved to disk.

• Maximum Number of Packets to Capture field—Configurable safety 
measure in case you forget to stop a capture. The default setting is 
100,000. You can enter -1 to specify “all packets”.

• Manually Edit Filter button—Use to specify a capture file filter so the agent 
captures certain packets.

• Leave file on remote host checkbox—Controls whether data is 
automatically downloaded from remote agent when capture completes. 
Provides better control and security of remote capture files.

• Download data rate (Kbits/sec) field—Controls amount of bandwidth 
consumed when remote capture file is downloaded.

5.6 Click OK to return to the Capture Manager. A new agent entry displays in the 
Capture Agents treeview.

6 (Optional) After you add and configure all agent entries in the list, you can save 
your list by clicking Save Agent List and then entering a file name and directory. 
ACE saves the agent list file with an “.agents” extension in your capture save 
directory. You can reuse a previously saved agent list by clicking Load Agent List.

Note—You can return to this Editor to edit a capture agent at any time.

End of Procedure A-1

Advice for Using Capture Agents

Keep in mind the following advice when using ACE Capture Agents:

• Capturing in Promiscuous Mode—Enabling this option means the agent will 
capture all traffic seen by the host on that LAN segment, which is typically 
more data than is required for analysis.
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• Make sure that you specify the correct NIC on the host in Capture Manager. 
You need to know which NIC card is connected to the appropriate link that is 
being monitored.

• The filter named Default is UDP/TCP. It is defined to capture only UDP/TCP 
protocol information. Use the filter named None if you want to capture “all” 
protocols, or create a custom filter and specify which protocols to capture.

• Make sure that you know where your ACE files reside—New (raw) capture 
files have suffixes of “.enc”  and “.appcapture”. When you save a new file, it 
will be stored in the first directory specified in the “mod_dirs” preference with 
an “atc.m” suffix. Existing ACE capture files are “.atc.m” files. ACE will search 
all directories specified in the “mod dirs” preference and present all files with 
an “.atc.m” suffix.

• Use filtering to keep out extraneous traffic—Diagnosis, graphs, and statistics 
will present inaccurate information on a task if extraneous, irrelevant traffic is 
left in the trace. Filter out traffic during the capture and the import process 
(with filters), and after the import (delete tier-pairs, connections, or individual 
packets and messages within the ACE editor.)

• Analyzing human “think time”—Take into account that the processing time 
credited to “Client” hosts, that are being driven by people, will have think time 
(pauses by individual, and the speed at which the individual can enter data) 
as part of the total tier process time.

Capturing Traffic Using the Application Capture Manager

To capture traffic using the ACE Application Capture Manager, launch the 
Capture Manager, then configure a capture agent, and finally, perform a 
capture.

Procedure A-2   Capture Traffic using the Application Capture Manager

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture Files dialog box displays.

4 Click Open Capture Manager.The Application Capture Manager window displays.

Note—You can also open the Application Capture Manager by selecting File > 
Application Capture Manager in the ACE Treeview window, Data Exchange 
Chart, or Tier Pair Circle.

5 If necessary, click Load Agent List and select the agent list you want to use for 
the capture.
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6 Enable the agent(s) that you want to capture data. To enable an agent, select the 
agent in the Capture Agents tree, then click the Enable Agent button. You can also 
right-click on an agent and choose Enable Agent from the pull-down menu.

7 Click Capture Save Directory and select the local directory where you want to 
store the capture files.

8 Click Start Capture to start the capture operation. Each enabled agent begins to 
capture data, and the Start Capture button changes to Finish Capture.

9 Start the transaction you want to capture.

9.1 To stop the capture, click Abort Capture.

9.2 To view the statistics about the capture, click the Update Status button.

10 When the transaction ends, click Finish Capture. The message “Capture 
complete” should display in the Status field next to each enabled agent. The file 
name for the resulting capture displays in a line beneath each enabled agent.

11 Proceed with the ACE import. You can import a capture file directly into ACE by 
selecting the file in the agent tree and clicking the Import Trace button at the 
bottom of the Application Capture Manager window. Then proceed with the import 
as described in Appendix B of this user’s guide.

End of Procedure A-2
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App B Importing Capture Files

Introduction

After you have captured application traffic data from your network using ACE’s 
application capture utility or a third-party tool (as described in Appendix A of this 
user’s guide), you can import the capture file(s) into the ACE Editor to create a 
model of your application. The ACE Editor parses the data and creates a single 
representation of the exchange. This representation is called an application task 
characterization or simply application task.

Using the ACE Import WIzard

The ACE Import Wizard guides you through the process of importing your 
capture data. This wizard might prompt you for additional information about your 
network, such as tier locations and the bandwidths of certain connections. ACE 
can import multiple capture files of the same exchange and merge the results 
into an accurate, realistic model of your application. Using ACE’s capture and 
import features, you can model highly complex application exchanges that span 
many tiers.

To import capture files into the ACE Editor, use the ACE Import WIzard to 
perform the following steps:

1) Specify capture file(s) to import,

2) Filter traffic,

3) Rename hosts,

4) Specify tier locations,

5) Specify bandwidth and latency, and

6) Save import configuration.

Specifying Capture File(s)

The first step in creating an application task is to specify the capture files you 
want to import. The ACE Editor can create a task based on a single capture file, 
or on multiple files that were captured simultaneously.

Procedure B-1   Specify Capture File(s)

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 
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3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

Figure B-1   ACE Import: Choose Capture File(s) dialog box

The ACE Import: Choose Capture File(s) dialog box contains four columns of 
information, a drop-down list of selectable Import Configurations, and several 
buttons as described below:

• Capture File column: You can create a list of capture files to import using the 
Add Capture File and Remove Capture File buttons.

• Capture Agent Location column (optional): For each capture file, you can enter 
a logical name for the capture agent location—for example, “Chicago office” or 
“My PC”. Capture Agent Location refers to the network segment where the 
capture agent/protocol analyzer was located. Subsequent dialog boxes in the 
ACE Import Wizard will refer to these capture agent locations when requesting 
additional information.

• Filter column (optional): Use this column to filter out extraneous packets 
unrelated to the application transaction of interest. 

• Preprocessor column (optional): If you want to import a capture file that uses a 
non-standard format, and have a script or program to convert the file, you can 
specify this in the Preprocessor column.

• Import Configuration drop-down list (optional): You can save and reuse your 
ACE import settings. Choosing a saved or previous configuration from this menu 
fills the editable fields in all the ACE Import Wizard dialog boxes.

• Open Capture Manager button: Launches the Application Capture Manager that 
you can use to create a capure agent list (as described in Appendix A of this 
user’s guide.)
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4 Click Add Capture File. The Select Capture File for Import dialog box displays.

Figure B-2   Select Capture File for Import dialog box

5 In the Select Capture File for Import dialog box, select the file that you want to 
import, and then click Open. The selected file name displays in the Capture File 
column of the ACE Import: Choose Capture File(s) dialog box.

6 (Optional) To enter a logical name for the capture agent location, click in the 
Capture Agent Location column to the right of the Capture File name and type a 
name.

7 (Optional) To specify a filter to prevent extraneous frames from being imported, 
click in the Filter column to the right of the Capture File name. Choose a predefined 
filter from the pull-down menu, or select Edit to define your own filter. To edit an 
existing filter, choose it and then select Edit.

Note—Default filters include None, which accepts all frames, and Default, which 
accepts all frames that contain TCP or UDP. Capture agents use the None filter by 
default, and the import process uses the Default filter.

8 (Optional) To specify a script or program to convert a capture file that uses a 
non-standard format, click in the Preprocessor column to the right of the Capture 
File name and enter the information.

9 (Optional) To automatically fill the editable fields in all the ACE Import Wizard 
dialog boxes with settings that were saved from a previous import (such as tier 
names, tier locations, bandwidth, latency), select the saved configuration from the 
Import Configuration drop-down list.

10 After you have specified your data manually (capture files, capture locations, 
packet filters and preprocessors) or automatically (by choosing an import 
configuration file), click Next and continue to follow the ACE Import WIzard screens 
as they are presented to you.

End of Procedure B-1
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Filtering Traffic

By default, the ACE Editor imports nearly all packets captured in a file. The 
Capture File Filter dialog box enables you to filter out unwanted packets when 
you import your capture data. You can filter packets based on host, ports or 
protocols. You can also save a defined filter to disk and reuse it when creating 
other ACE files.

Procedure B-2   Edit Filters

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

5 Select the file that you want to import, and then click Open. The selected file name 
displays in the Capture File column.

6 In the Filter column to the right of the Capture File name, select Edit to define your 
own filter. To edit an existing filter, choose it and then select Edit. The Capture File 
Filter dialog box displays.

Figure B-3   Capture File Filter dialog box
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7 Click the Import all of the following hosts/ports radio button(s) if you want ACE 
to import only those packets that meet the host/port or protocol criteria defined in 
the Host/Port and/or Protocol filters panes.

8 Click the Import everything but the following hosts/ports radio button(s) if you 
want ACE to import only those packets that do NOT meet the host/port or protocol 
criteria defined in the Host/Port and/or Protocol filters panes.

9 Use the Host/Port and/or Protocol filters panes to define the filter:

• Host/Port filters pane: A capture file filter is composed of one or more criteria, 
each residing on a separate line in the Host/Port or Protocol filters panes. You 
can define host, port, and direction for a line by clicking in each column and 
selecting an item from the pull-down menu. ACE performs a logical AND on the 
criteria in both panes to create a compound filter. For example, if the Host/Port 
filters pane were configured to import all packets originating from host A, and the 
Protocol filters pane were configured to import only those packets that do not 
have UDP data, ACE would then import only those packets originating from host 
A that do not have UDP data (these might be TCP, DLC, and others).

• Protocol filters pane: This pane works in the same general way as the Host/Port 
filters pane. Each line contains one protocol (or All Protocols) found in the 
capture file.

• Click the Add Line/Add Protocol and Remove Line/Remove Protocol buttons 
to add or remove a line, or Clear to clear all filtering criteria, from either the 
Hosts/Ports or the Protocols filters panes.

Clicking Clear with the Import everything but the following hosts/ports radio 
button in either pane will result in a filter that excludes all packets from the 
capture file.

10 Type criteria into the Import only frame numbers and Import frames from time 
fields if you want to filter out packets based on frame number and time stamp.

11 If you want to reuse your filter in other tasks, you can save your filter to disk. Type 
a name for the filter in the field next to the Save button, and then click Save.

12 Click OK to close the Capture File Filter dialog box.

End of Procedure B-2

Renaming Hosts

The ACE Editor enables you to assign friendly names, or “tier names”, to 
replace host names (IP addresses.) Tier names display on all reports. 

Sometimes you might want to represent multiple hosts as one tier in your ACE 
task. For example, you might have multiple web servers handling traffic 
between a client and a database server. You can combine hosts into one tier by 
assigning them both the same logical tier name.
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Procedure B-3   Rename Hosts

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 After you have specified the capture file(s) to import in the ACE Import: Choose 
Capture File(s) dialog box, click Next. The ACE Import: Rename Hosts dialog box 
displays.

Figure B-4   ACE Import: Rename Hosts dialog box

5 Change a Hostname (IP address) by clicking on the address in the Tier Name 
column. Either select another name from the drop-down list, or select Lookup to 
perform a DNS lookup on the specified tier, or select Edit to modify a tier name.

Note—ACE retains a database of previously assigned tier names in the 
tier_name_db.txt file located in the ace_import_configs directory. This database is 
automatically used when importing new files. You can modify the database by 
selecting Edit.

6 Click the DNS Lookup button if you want to perform a DNS lookup on all tiers.

7 After you have renamed your hosts, click Next and continue to follow the ACE 
Import WIzard screens as they are presented to you.

End of Procedure B-3

 

UG2-B-6 NETWARS/Release 5.1



Introduction to the ACE Editors App B—Importing Capture Files
Specifying Tier Locations

“Tier location” is the location of each application tier relative to where the 
capture was done (probe, capture-agent, etc.) By default, the ACE Editor places 
each tier in the same network segment as the agent that captured its traffic. 
However, you might need to change the location of particular tiers if your actual 
network is different—for example, if a tier is in a remote segment from an agent.

ACE will automatically detect locations when you import multiple capture files.

Procedure B-4   Change Tier Locations

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 Follow the Import Wizard screens as they are presented to you, specifying your 
capture file(s) and tier names, until the ACE Import: Specify Tier Locations dialog 
box displays.

Figure B-5   ACE Import: Specify Tier Locations dialog box

5 Click on a tier’s location in the Tier Location column and select a different location 
from the drop-down list. Repeat for each tier as needed.

Note—In a capture file that contains tiers that are not local (on the same LAN 
segment), you MUST specify which tiers are remote, relative to the capture 
location, by selecting Remote as their tier location from the drop-down list.

6 After you have changed your tier locations, click Next and continue to follow the 
ACE Import WIzard screens as they are presented to you.

End of Procedure B-4
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Specifying Bandwidth for Segment

Sometimes (this option does not always display) you might need to specify the 
bandwidth (Kbps) observed between hosts at a capture site location.

Procedure B-5   Specify Bandwidth for Segment

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 Follow the Import Wizard screens as they are presented to you, specifying your 
capture file(s) and tier names and locations, until the ACE Import: Specify 
Bandwidth for Segment dialog box displays.

Figure B-6   ACE Import: Specify Bandwidth for Segment dialog box

5 Click on a capture agent’s bandwidth in the Bandwidth column and enter a new 
bandwidth value (in Kbps).

6 After you have changed your bandwidth value, click Next and continue to follow the 
ACE Import WIzard screens as they are presented to you.

End of Procedure B-5

Specifying Bandwidth/Latency between Locations

Sometimes (this option does not always display) you might need to specify the 
bandwidth (Kbps) and one-way latency (ms) measurements between each 
capture site location.
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Bandwidth should be a known factor about your network. If you have different 
bandwidth’s due to multiple segments, then use the “minimum bandwidth” (the 
capacity of the slowest link.)

Procedure B-6   Specify Bandwidth/Latency between Locations

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 Follow the Import Wizard screens as they are presented to you, specifying your 
capture file(s) and tier names and locations, etc., until the ACE Import: Specify 
Bandwidth/Latency between Locations dialog box displays.

Figure B-7   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

5 Click on a location’s bandwidth in the Bandwidth column and enter a new 
bandwidth value (in Kbps).

6 Click on a location’s one-way (NOT round-trip) latency in the One-way Latency 
column and enter a new latency value (in ms).

Note—If you use PathProbe to provide latency estimates, the data will be reflected 
as one-way already. However, if you use Ping, then you must divide the latency in 
half.

7 After you have changed your bandwidth and latency values, click Next. The Save 
Import Configuration dialog box displays.

8 Click Finish if you want to complete the import process.

End of Procedure B-6

Using PathProbe to Estimate Bandwidth and Latency

You can use PathProbe, an OPNET utility, to measure and provide bandwidth 
and latency estimates.
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Procedure B-7   Run PathProbe

1 Launch NETWARS.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture Files dialog box displays.

4 Click Open Capture Manager.The Application Capture Manager window displays.

Note—You can also open the Application Capture Manager by selecting File > 
Application Capture Manager in the ACE Treeview window, Data Exchange 
Chart, or Tier Pair Circle.

Figure B-8   Application Capture Manager

5 Click Run PathProbe.... The PathProbe dialog box displays.

Figure B-9   PathProbe dialog box

6 Specify the Source agent and Destination, and name the run in the appropriate 
fields.

7 Click Configure to configure different experiments. 
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8 Click Start to start the run, and then view the results displayed in the PathProbe 
Results Dialog Box.

Figure B-10   Sample PathProbe Results

End of Procedure B-7

Saving an Import Configuration

You can create and use Import Configuration files that contain the filters, tier 
names, tier locations, and bandwidth/latency settings that you’ve designated 
previously in the ACE Import: Choose Capture File(s) dialog box. The import 
information is saved for use with future imports that involve the same tiers and 
the same capture locations. The ACE Editor automatically saves the settings 
you designated most recently under the name “Previous Configuration.”

Procedure B-8   Save Import Configuration

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import WIzard displays the ACE Import: Choose Capture File(s) dialog box.

4 Follow the Import Wizard screens as they are presented to you, specifying your 
data (capture files, capture locations, packet filters and preprocessors) until the 
Save Import Configuration dialog box displays.
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5 In the Save Import Configuration dialog box, type a name for the import 
configuration file in the field next to the Save button, and then click Save.

Figure B-11   Save Import Configuration dialog box

6 Click Finish if you want to complete the import process.

End of Procedure B-8

Import Strategies

There are three strategies for importing capture file(s) that can handle any 
network configuration:

• Import a single capture file, 

• Auto-merge and import multiple capture files, and

• Manually merge and import multiple capture files.

Single Capture File

A single capture file is easy to set up, but tiers must be co-located to see all 
traffic, and high/variable latencies aren’t captured well. This strategy is ideal for 
a lab environment where all tiers’ locations are “Local to…” and 
bandwidth/latency often matches default values of 100,000 Kbps, 0 ms.

Refer to the “Importing a Single Capture File” section provided later in this 
chapter for a sample scenario that walks you through the import process for a 
single capture file.

Multiple Capture Files

You can “merge” multiple capture files, which is when two or more traces of an 
application transaction are combined to create a unified view of an application. 
This strategy allows analysis of multi-tier transactions where all traffic does not 
go through one location, and improves analysis in a production environment 
with large and/or variable latencies.
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The benefits to merging multiple capture files over using a single capture file 
include:

• Packets’ send/receive times are accurate,

• Time spent at each tier is accurate, and

• The result is a better visualization of delays and better diagnosis.

ACE can merge traces that come from opposite sides of a simple packet filtering 
firewall, but cannot automatically merge traces that come from opposite sides 
of an application proxy firewall.

Auto-Merge Import

To auto-merge multiple capture files, you need capture files containing common 
traffic, and you need to specify the bandwidth between the capture locations 
(i.e., between tiers where the captures occurred.) ACE auto-detects locations 
and one-way latency between the capture locations.

Refer to the “Merging Multiple Capture Files” section provided later in this 
chapter for a sample scenario that walks you through the import process for an 
auto-merged import of multiple capture files.

Manual Merge Import

Manual merging of capture files is an advanced feature that is rarely needed for 
most users. It allows merging of non-shared traffic, including traces from 
dual-homed hosts, traces from non-contiguous hosts (missing tiers in 
conversation path, and captures separated by capture time and collection 
method.

To merge capture files manually, you must select the traces that you want to 
merge, and specify a synchronization value:

• Two traces from a dual-homed machine

— Accept synchronization value proposed by ACE

• Two traces from two machines with synchronized clocks

— Accept synchronization value proposed by ACE (you may have to 
re-import and tweak the synchronization value)

• Two traces from two machines with unsynchronized clocks

— Specify 0.0 as the synchronization value

— Estimate the offset, then re-import using the estimated offset

— Repeat until you get the desired result
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Importing a Single Capture File

When importing application traffic into ACE, it is important that you set the 
parameters appropriately. In the following procedure, we will import a single 
capture file without specifying the appropriate relationship (locations) between 
the application tiers and the capture site. You will see the steps involved in the 
import process and understand the importance of providing the correct 
information to the import process. After we import this capture file, we will 
re-import the same file (this time with appropriate parameters) and compare the 
differences. 

Note—The following example was presented at OPNETWORK 2004 in Session 
1209, Introduction to Using ACE, as Lab 1. If you do not have access to the files 
that this procedure uses, you can still follow the procedure using the sample 
screens provided in this user’s guide.

This section uses the following example scenario:

• An application capture trace was taken at the Washington, DC, data center 
(Site 1), where the Web and Database Server are located, on a 100MB LAN. 
The Network Probe was placed on the local switch. The Application request 
is initiated by a remote Client, located in Dallas. The network connection 
between the Client and the Servers is a 512Kb link, with an average of 80Ms 
latency.

Figure B-12   Example Scenario for Importing a Single Trace FIle

Procedure B-9   Import a Single Capture File

1 Launch NETWARS, if not already opened.

2 From the System Editor’s File menu, choose Open Editor. 

 

 

Probe 

  Dallas   Wash. DC

 512Kb

 80Ms100Mb LAN

100Mb LAN
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3 From the Open Editor drop-down menu, select ACE, and then click OK. The ACE 
Import: Choose Capture File(s) dialog box displays.

Figure B-13   ACE Import: Choose Capture File(s) dialog box

4 Click Add Capture File. The Select Capture File for Import dialog box displays.

Figure B-14   Select Capture File for Import dialog box

5 In the Select Capture File for Import dialog box, select the file named 
1209_Lab_1_SingleMerge.sniff, and then click Open.

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.
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The ACE Import: Choose Capture File(s) dialog box shows the capture file in the 
Capture File column.

Figure B-15   ACE Import: Choose Capture File(s) dialog box with Selected 
Capture File

6 In the ACE Import: Choose Capture File(s) dialog box, click Next. The ACE Import: 
Rename Hosts dialog box displays.

Figure B-16   ACE Import: Rename Hosts dialog box

7 In the ACE Import: Rename Hosts dialog box, change the IP addresses by clicking 
on the address in the Tier Name column and selecting Edit. 

7.1 Change 172.161.1.254 to “DataBase Server”.

7.2 Change 172.164.4.134 to “Client”.

7.3 Change 172.16.6.27 to “Web Server”.
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8 In the ACE Import: Rename Hosts dialog box, click Next. The ACE Import: Specify 
Tier Locations dialog box displays.

Figure B-17   ACE Import: Specify Tier Locations dialog box

9 In the ACE Import: Specify Tier Locations dialog box, click Next. The ACE Import: 
Specify Bandwidth for Segment dialog box displays.

Figure B-18   ACE Import: Specify Bandwidth for Segment

10 In the ACE Import: Specify Bandwidth for Segment dialog box, click Next. The 
Save Import Configuration dialog box displays.
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11 In the Save Import Configuration dialog box, click Finish to complete the import 
process.

Figure B-19   Save Import Configuration dialog box

12 Analyze the application packet trace. Using the Data Exchange chart (shown 
below), you can view the number of messages between each tier and the 
messages sizes between the Web and Database Servers.

Figure B-20   Data Exchange Chart with no Parameters Set
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13 Select AppDoctor > AppDoctor Analysis or click the AppDoctor toolbar icon, 
and display AppDoctor’s Summary of Delays chart.

Figure B-21   AppDoctor Menu Commands and Toolbar Button

14 Check the Show values checkbox (located in the lower left corner), and study the 
exploded pie chart statistics.

Figure B-22   Exploded Pie Chart Statistics
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15 Select Bar Chart from the drop-down menu (located in the lower left corner), and 
study the bar chart statistics.

 

Figure B-23   Bar Chart Statistics

16 Select Pie Chart from the drop-down menu (located in the lower left corner), and 
study the regular pie chart statistics.

 

Figure B-24   Pie Chart Statistics

17 Close all currently opened windows, except for NETWARS.
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18 Re-import the same application packet trace file, this time specifying appropriate 
tier locations, bandwidth, and latency.

18.1 From the System Editor’s File menu, choose Open Editor. 

18.2 From the Open Editor drop-down menu, select ACE, and then click OK. The 
ACE Import: Choose Capture File(s) dialog box displays.

18.3 Click Add Capture File.

18.4 In the Select Capture File for Import dialog box, select the first capture file 
named 1209_Lab_1_SingleMerge.sniff, and then click Open.

The ACE Import: Choose Capture File(s) dialog box shows the capture file in 
the Capture File column.

18.5 In the ACE Import: Choose Capture File(s) dialog box, click Next. The ACE 
Import: Rename Hosts dialog box displays.

Note—The Tier Names have already been selected. ACE remembers IP 
addresses from previous packet trace imports. ACE builds and maintains a 
database of IP addresses so you will not have to keep renaming the same hosts.

Figure B-25   ACE Import: Rename Hosts dialog box

18.6 In the ACE Import: Rename Hosts dialog box, click Next. The ACE Import: 
Specify Tier Locations dialog box displays.
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18.7 In the ACE Import: Specify Tier Locations dialog box, click on the Client’s tier 
location in the Tier Location column and select “Remote”. Leave the other tiers 
as “Local to Site 1”.

Figure B-26   Changing the Client’s Tier Location

18.8 In the ACE Import: Specify Tier Locations dialog box, click Next. The ACE 
Import: Specify Bandwidth for Segment dialog box displays.

18.9 In the ACE Import: Specify Bandwidth for Segment dialog box, click Next. The 
ACE Import: Specify Bandwidth/Latency between Locations dialog box 
displays.

18.10In the ACE Import: Specify Bandwidth/Latency between Locations dialog 
box,edit the following values:

• Edit the Bandwidth column and specify “512” (Kbps).

• Edit the One-way Latency culumn and specify “40” (ms).

Figure B-27   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

18.11In the ACE Import: Specify Bandwidth/Latency between Locations dialog 
box, click Next. The Save Import Configuration dialog box displays.

18.12In the Save Import Configuration dialog box, click Finish to complete the 
import process.
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18.13Analyze the application packet trace. Using the Data Exchange chart (shown 
below), note the number and size of messages and which tier pair has the 
most activity.

Figure B-28   Data Exchange Chart with Parameters Set
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18.14Select AppDoctor > AppDoctor Analysis or click the AppDoctor toolbar 
icon, and display AppDoctor’s Summary of Delays chart.

Figure B-29   AppDoctor’s Summary of Delays Chart

18.15Check the Show values checkbox (located in the lower left corner), and 
study the exploded pie chart statistics.

End of Procedure B-9

Conclusion

In the first import, all three tiers were specified to be on the same segment as 
the capture location (Site 1). The Client was actually “remote” to the capture 
location on a WAN link of 512Kb. The fact that the Client was not correctly 
identified as remote caused the calculations of the network effects to be 
incorrect.

In the second import, the Client was specified as remote to the capture location, 
and shows the correct evaluation of network effects. 

Using QuickPredict to Analyze Bandwidth

In the previous section, we showed you how to import a single capture file. Next, 
we will show you how to use QuickPredict to validate the effect of bandwidth on 
the transaction and explore other different bandwidth “what-ifs”.
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Procedure B-10   Use QuickPredict to Analyze Bandwidth

1 Click the QuickPredict toolbar button.

Figure B-30   QuickPredict Toolbar Button

The QuickPredict Control dialog box displays along with an Impact of Bandwidth 
on Response Time graph showing bandwidth sweep.

Figure B-31   QuickPredict Control dialog box and graph

2 In the QuickPredict Control dialog box, change the Min Bandwidth and Max 
Bandwidth fields both to “512Kbps”, and then click Update Graph.

Figure B-32   Editing the QuickPredict Control dialog box
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The updated QuickPredict graph displays. The “Y” axis is response time, and the 
“X” axis is bandwidth.

Figure B-33   Impact of Bandwidth on Response Time graph

Note that at 512Kbps bandwidth, the response time is around 7.3 secs.

3 Increase the bandwidth, at different Intervals, and study its effect on the response 
time. 

3.1 In the QuickPredict Control dialog box, change the Max Bandwidth field to 
“756Kbps”, and then click Add Curve(s).

3.2 In the QuickPredict Control dialog box, change the Max Bandwidth field to 
“1Mbps”, and then click Add Curve(s).

3.3 In the QuickPredict Control dialog box, change the Max Bandwidth field to 
“1.544Mbps”, and then click Add Curve(s).

The updated QuickPredict graph should look like the one provided below.

Figure B-34   Updated Impact of Bandwidth on Response Time graph
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4 Note the impact (gain) of increasing bandwidth on response time when upgrading 
from 512Kbps to 756Kbps, from 756Kbps to 1Mbps, from 756Kbps to 1.544Mbps 
(T1), and the total potential gain from 512Kbps to 1.544Mbps.

5 Increase the bandwidth from 1.544Mbps (T1) to 100Mbps, and study its effect on 
the response time.

5.1 In the QuickPredict Control dialog box, change the Min Bandwidth field to 
“1.544Mbps” and the Max Bandwidth field to “100Mbps”, and then click Add 
Curve(s).

The updated QuickPredict graph should look like the one provided below.

Figure B-35   Updated Impact of Bandwidth on Response Time graph

6 Close all currently opened windows, except for NETWARS.

End of Procedure B-10

Conclusion

With QuickPredict, you can see the network effect of bandwidth on response 
time. You can evaluate how upgrading bandwidth may help the total response 
time, and even determine at what point (bandwidth) the response time may level 
off (point at which more bandwidth will not decrease or impact response time 
any more).

You can use the information provided by QuickPredict to evaluate the cost of 
increasing bandwidth against the return in increased response time. In our 
example, bandwidth was such a small percentage of the total process and 
network effects, that the percentage gained is probably not worth the cost. 
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Merging Multiple Capture Files

Note—The following example was presented at OPNETWORK 2004 in Session 
1209, Introduction to Using ACE, as Lab 1. If you do not have access to the files 
that this procedure uses, you can still follow the procedure using the sample 
screens provided in this user’s guide.

This section uses the following example scenario:

• An application packet trace was taken over the Far East Network. The Client 
is located in Beijing (Site 1), the Web and Application Servers are located in 
Seoul (Site 2), and the Database Server is located in Tokyo (Site 3). The 
network connection between Beijing and Seoul is a 1.544Mbps (T1) link, with 
a 23.754ms one-way latency. The network connection between Seoul and 
Tokyo is a 3.0Mbps link, with a 39.311 one-way latency. The LAN 
configurations at each site are 100Mbps. ACE capture agents were installed 
on each of the four hosts and used to capture the packet traces.

Figure B-36   Example Scenario for Merging Multiple Capture Files

In the following procedure, we will merge the capture files from Site 1 and Site 
2 and analyze the results. Then we will merge the capture files from Site 1, Site 
2, and Site 3, and analyze and compare the different results. This exercise will 
help you to understand the difference and importance of location of the capture.

Procedure B-11   Merge Multiple Capture Files

1 Launch NETWARS, if not already opened.

2 Merge multiple trace files:

2.1 From the System Editor’s File menu, choose Open Editor. 
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2.2 From the Open Editor drop-down menu, select ACE, and then click OK. The 
ACE Import: Choose Capture File(s) dialog box displays.

Figure B-37   ACE Import: Choose Capture File(s) dialog box

2.3 Click Add Capture File. The Select Capture File for Import dialog box 
displays.

2.4 In the Select Capture File for Import dialog box, select the first capture file 
named 1209_Lab_1_MultiMerge_Client, and then click Open.

 

Figure B-38   Select Capture File for Import dialog box

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.
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The ACE Import: Choose Capture File(s) dialog box shows the first capture 
file in the Capture File column.

Figure B-39   The ACE Import: Choose Capture File(s) dialog box with Selected 
Capture File

2.5 In the ACE Import: Choose Capture File(s) dialog box, click Add Capture 
File. The Select Capture File for Import dialog box displays.

2.6 In the Select Capture File for Import dialog box, select the second capture file 
named 1209_Lab_1_MultiMerge_Web_Server, and then click Open.

Figure B-40   Select Capture File for Import dialog box

Note—If you do not have access to this file, simply view the screens provided in 
this user’s guide to follow along with the procedure.
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The ACE Import: Choose Capture File(s) dialog box shows the second 
capture file in the Capture File column.

Figure B-41   The ACE Import: Choose Capture File(s) dialog box with Two 
Selected Capture Files

2.7 In the ACE Import: Choose Capture File(s) dialog box, click Next. The ACE 
Import: Rename Hosts dialog box displays.

Figure B-42   ACE Import: Rename Hosts dialog box

2.8 In the ACE Import: Rename Hosts dialog box, click Next. The ACE Import: 
Specify Tier Locations dialog box displays.
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Notice that both tiers’ locations were Auto-detected by ACE. When the traces 
being merged contain shared traffic, ACE will auto-detect tier locations.

Figure B-43   ACE Import: Specify Tier Locations dialog box

Note that the tier location for the Client and WebServer have been 
auto-detected as Site 1 and Site 2. The App Server shows it was found on 
capture location Site 2 (which is correct).

2.9 In the ACE Import: Specify Tier Locations dialog box, click Next. The ACE 
Import: Specify Bandwidth/Latency for Segment dialog box displays.

Figure B-44   ACE Import: Specify Bandwidth/Latency for Segment dialog box

2.10 In the ACE Import: Specify Bandwidth/Latency for Segment dialog box, click 
Next. The ACE Import: Specify Bandwidth/Latency between Locations dialog 
box displays.
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Now specify the bandwidth and latency. The following dialog box prompts you 
for the bandwidth and latency between the capture locations. Specifying this 
information is very important for accurate AppDoctor results.

Figure B-45   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

• Edit the Bandwidth column and specify “1544” (Kbps).

• Note that the One-way Latency was Auto-Detected by ACE.

2.11 In the ACE Import: Specify Bandwidth/Latency between Locations dialog box, 
click Next.

To finish the import, you can save an import configuration to avoid typing in all 
of the information again if you were to import another set of traces that were 
captured at the same locations. You can also select the view that will be 
launched when the import completes.

2.12 In the Save Import Configuration dialog box, click Finish to complete the 
import process.

3 Analyze the merged trace. Note that the Data Exchange chart shows three (3) 
application tiers:

• Captured at Site 1, where the Client host was located. 

• Captured at Site 2, where the Web Server and App Server hosts were located. 
Note that no traffic beyond the App Server was detected.
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• The 4th tier, the (Database Server), was not detected, therefore any processing 
and network effects are attributed to the App Server.

Figure B-46   Sample Data Exchange Chart

4 Select AppDoctor > AppDoctor Analysis or click the AppDoctor toolbar icon to 
use AppDoctor’s Summary of Delays, Diagnosis, and Statistics tabs.

Figure B-47   AppDoctor Toolbar button

5 Note which tier has the largest “processing effect” (and what the percentage of 
processing effect is for that tier.) Note the largest component of the “network effect” 
(and what the percentage of network effect is.) Note the existence of any other 
bottlenecks.

6 Close all currently opened windows, except for NETWARS.

7 Re-import packet traces, this time using packet traces captured at all hosts.

7.1 From the System Editor’s File menu, choose Open Editor. 

7.2 From the Open Editor drop-down menu, select ACE, and then click OK. The 
ACE Import: Choose Capture File(s) dialog box displays.

7.3 Click Add Capture File.
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7.4 In the Select Capture File for Import dialog box, select the first capture file 
named 1209_Lab_1_MultiMerge_Client, and then click Open.

The ACE Import: Choose Capture File(s) dialog box shows the first capture 
file in the Capture File column.

7.5 In the ACE Import: Choose Capture File(s) dialog box, click Add Capture 
File. The Select Capture File for Import dialog box displays.

7.6 In the Select Capture File for Import dialog box, select the second capture file 
named 1209_Lab_1_MultiMerge_Web_Server, and then click Open.

The ACE Import: Choose Capture File(s) dialog box shows the second 
capture file in the Capture File column.

7.7 In the ACE Import: Choose Capture File(s) dialog box, click Add Capture 
File. The Select Capture File for Import dialog box displays.

7.8 In the Select Capture File for Import dialog box, select the third capture file 
named 1209_Lab_1_MultiMerge_App_Server, and then click Open.

Figure B-48   Select Capture File for Import dialog box

The ACE Import: Choose Capture File(s) dialog box shows the third capture 
file in the Capture File column.

Figure B-49   ACE Import: Choose Capture File(s) dialog box with Three Selected 
Capture Files
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7.9 In the Select Capture File for Import dialog box, select the fourth capture file 
named 1209_Lab_1_MultiMerge_DB_Server, and then click Open.

Figure B-50   Select Capture File for Import dialog box

The ACE Import: Choose Capture File(s) dialog box shows the fourth capture 
in the Capture File column.

Figure B-51   ACE Import: Choose Capture File(s) dialog box with Four Selected 
Capture Files
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7.10 In the ACE Import: Choose Capture File(s) dialog box, click Next. The ACE 
Import: Rename Hosts dialog box displays.

Figure B-52   ACE Import: Rename Hosts dialog box

7.11 In the ACE Import: Rename Hosts dialog box, click Next. The ACE Import: 
Specify Tier Locations dialog box displays.

Notice that all tier locations were Auto-detected by ACE as Sites 1, 2, 3, and 
4. 

Figure B-53   ACE Import: Specify Tier Locations dialog box 
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7.12 In the ACE Import: Specify Tier Locations dialog box, click Next. The ACE 
Import: Specify Bandwidth/Latency between Locations dialog box displays.

Figure B-54   ACE Import: Specify Bandwidth/Latency between Locations dialog 
box

• Specify “1544” (Kbps) as the Bandwidth between Site 1 and Site 2.

• Specify “3000” (Kbps) as the Bandwidth between Site 3 and Site 4.

• Leave the default between Site 2 and Site 3.

• Note that the One-way Latency was Auto-Detected by ACE.

7.13 In the ACE Import: Specify Bandwidth/Latency between Locations dialog box, 
click Next.

To finish the import, you can save an import configuration to avoid typing in all 
of the information again if you were to import another set of traces that were 
captured at the same locations. You can also select the view that will be 
launched when the import completes.

7.14 In the Save Import Configuration dialog box, click Finish to complete the 
import process.

8 Analyze the merged trace. Note that the Data Exchange chart now shows all four 
application tiers.

• Captured at Site 4, where the DB Server host was located, now shows the activity 
between the App Server and DB Server.
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• The process and network effects between the App and DB Servers are now 
attributed to the correct tiers and are correctly calculated.

Figure B-55   Sample Data Exchange Chart

9 Select AppDoctor > AppDoctor Analysis or click the AppDoctor toolbar icon to 
use AppDoctor’s Summary of Delays, Diagnosis, and Statistics tabs.

10 Note what has the largest “effect” (and the percentage of effect) on the application. 
Note which tier has the largest “processing effect” (and what the percentage of 
processing effect is.) Note the existence of any bottlenecks between each tier.

11 Close all currently opened windows, except for NETWARS.

End of Procedure B-11

Conclusion

In the first import, two capture files were merged. One capture file was taken at 
the Client location (Site 1), and the second capture file was taken where the 
Web Server and Application Server resided (Site 2). In this merge you could see 
three of the four tiers of the application. In this analysis, the Application Server 
was “charged” with all the process effect and network effects that should have 
been attributed to the Database Server.
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In the second import, four capture files were merged, one at each application 
tier. This gave a complete/proper analysis of all processing and network effects. 
You will note that this analysis also highlighted that the “Nagle” algorithm was a 
factor between the Application Server and Database Server. This could not 
have been detected in the first capture merge.

When importing capture files into ACE, understand that processing and network 
effects may be charged/allocated/attributed to those tiers that are present in the 
capture.

When importing multiple capture files into ACE, be aware of the bandwidth 
between locations.
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