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JCSS User’s Manual Identification
Identification

Document Identification

Document Title: JCSS User’s Manual
Version: 7.0 Final

Software Identification

Product Name: JCSS
Product Release: 7.0

Documentation Conventions

This documentation uses specific formatting and typographic conventions to present the 
following types of information:

• Objects, examples, and system I/O

• Object hierarchies

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in standard Courier typeface:

C:\Netwars\User_Data\Projects

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier typeface:

/* determine the object ID of packet’s creation module */ 
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<NETWARS path>\Scenario_Builder\op_admin\err_log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:

Edit > Preferences > Advanced
JCSS/Release 7.0 UM-FM-iii
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Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press the 
<button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you should press 
the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps.
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JCSS User’s Manual Document Revision History
Document Revision History

Release Date
Product 
Version Chapter Description of Change

November 30, 2007 7.0 Final All

2

3

- Began introduction of product name change to JCSS from 
NETWARS.

- Updated figure 2-26 Logical View Selection dialog box, and 
removed refs to Frame Relay, VTC, etc., in this section.

- Added note that Modeler will not launch from JCSS without a 
Modeler license.

October 31, 2007 2007 
Final

2

3

4

- Added sentence to Procedure 2-17 that Network Layer Filters 
shown are only those which apply to the deployed network.

- Removed “Scenario Treeview” references from document, and 
updated procedures for deploying satellite links and defining 
broadcast networks.
- Added “Save As Link Type” section.

- Updated procedures for creating threads and creating 
relationships.

October 17, 2007 2007 
Draft

2

3

- Updated figures and text to reflect change to NETWARS v2007.
- Updated figure 2-11 list of pre-configured organizations.
- Changed Scenarios > Reports > Mission Analysis Questions to 
Scenarios > Reports > Mission Analysis.
- Added reference to CADRG/CIB Raster Catalog Directories and 
MrSID images to “Adding Background Images” section.
- Updated figure 2-26 with new Logical View options.

Updated figures with new options/lists:
- 3-3 Organization Attributes dialog box
- 3-4 OPFAC Attributes dialog box
- 3-5 Edit Objects Using Template dialog box
- 3-25 TSSP Group Config (Circuit Deployment) dialog box
- 3-38 Satellite Link Attributes dialog box
- 3-43 and 3-44 changed ‘Phase’ to ‘Scenario’
- 3-48 LOS Settings dialog box

- Added “Opening Node Models in Modeler” section.
- Updated “Defining Broadcast Networks” section to include new 
wizard.
- Added procedure to “Add Broadcast Networks via the 
Right-Click Menu.”
- Updated “Configuring Utility Nodes” section to reflect new 
Circuit Deployment Wizard.
- Added Protocols > Link 16 and Protocols > IPv6 submenus.
- Added View > Visualize Protocol Configuration > IP Address 
Types.
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Document Revision History JCSS User’s Manual
4

6

7

- Added note to “Create a Thread” procedure re: right-click “View 
Threads” option.
- Added note to “Create a Relationship” procedure re: right-click 
“Deploy Relationship” option.

- Added figure 6-2 Probe Model window.
- Updated figure 6-3 list of Attributes in Configure/Run DES dialog 
box.

- Updated figure 7-1 Results Browser.

December 6, 2006 6.2 Final 3

4

5

6

- Revised ref to “the three OPFACs” in Step 4 of Procedure 3-25 
to read “the two OPFACs that contain the endpoint earth 
terminals and the OPFAC that contains the home satellite.”
- Updated Figure 3-33, Satellite Bent Pipe Link Deployment.
- Removed Defining Application Profiles section (refer instead to 
Traffic Wizard in chapter 4.)

- Moved Creating Relationships section to after Creating IERs 
and Creating Threads sections (Relationships are no longer 
needed for IERs.)

- Updated figure 5-1 and accompanying text to reflect changes to 
Specifying Alternate Link Capacities procedure. Moved section to 
after Optimizing a Network section.
- Expanded descriptions of dialog box options in Evaluating a 
Network section.

- Updated figure 6-6 and accompanying text to reflect new Log 
Viewer feature.

November 3, 2006 6.2 Final 1

2

3

4

- Updated Task Assistant figures 1-1, 1-2, and 1-3.

- Updated Mission Analysis Questions figure 2-19.
- Changed Map > Set Area of Interest to View > Set Area of 
Interest, and Map > Background > (options) to View > 
Background > (options).
- Updated Logical View Selection figure 2-26 (removed Type of 
View drop-down list, and Re-use/Re-create options.)

- Updated Adding Units via the Library Treeview figure 3-2.
- Updated figures 3-18 and 3-22 to reflect new toolbar buttons.
- Updated Satellite Bent Pipe Link Deployment dialog box figure 
3-20.
- Changed Terrain > View Terrain Profile to Topology > Terrain > 
View Terrain Profile.
- Changed Map > LOS Settings to View > Show LOS > LOS 
Settings.

- Added Ctrl+W shortcut keys to Traffic Wizard section.

Release Date
Product 
Version Chapter Description of Change
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October 20, 2006 6.2 Draft 1

2

3

4

6

7

Glossary

- Removed references to separate IER Editor (functionality now 
accessible via System Editor’s IER Database menu.)

- Updated System Editor and Sign-in figures to reflect version 6.2.
- Updated Create a New Project to reflect use of File > New 
Project command in System Editor.
- Added Zoom to Window and Zoom to All procedures.
- Changed View > Network Views > Logical to View > Show 
Logical Views, and updated Logical View Selection dialog box.

- Updated all Object Palette figures.
- Updated Create a Device Model procedure to reflect new Create 
Custom Device dialog box and procedure.
- Updated references to Scenario menu to reflect name change 
to Scenarios menu.
- Updated Protocols menu items table.

- Updated Traffic Wizard dialog box.

- Updated Choose Results dialog box.
- Updated Perform a Network Simulation procedure to reflect 
simple and detailed modes and new dialog boxes.

- Updated Results Browser and graph shortcut menu figures.
- Removed DES > Results > Compare Results.

- Removed references to the Scenario Conversion Module.

March 30, 2006 6.1 Final 3 - Added references to Help Diagram and Help FAQs tabs on 
Satellite Bent Pipe Link Deployment dialog box.
- Added shortcut keys to TSSP circuit configuration, and added 
multiplexer circuit configuration.
-Removed references to Multiplexer utility node.

March 3, 2006 6.1 Draft 1

2
3

4

- Updated text toreflect name change from “Icon Editor” to “Icon 
Database”.
- Updated System Editor and Sign-in figures to reflect version 6.1.
- Updated Procedure 3-18, “Deploy a Satellite Link”, to reflect new 
tabbed design of dialog boxes.
- Removed “Converting Flows to IERs” section.

November 14, 2005 5.2 Final Front material

2

3

4

- Changed refs in Documentation Conventions section to be 
NETWARS-specific rather than OPNET-specific (i.e, changed 
<opnet_user_home>\... ref to <NETWARS 
path>\Scenario_Builder\...)

- Updated Logical View Selection figure.

- Added ‘Editing Attributes for Many Objects’ section.
- Added Object Palette Tree view to ‘Adding a Device to an 
OPFAC’section.
- Added ‘Deploy a Satellite Link’ procedure.
- Updated NETWARS Standard Models object palette figure.

- Removed Convert Link Loads to Flows procedure.
- Removed Advanced Traffic Wizard procedure.
- Updated Traffic Wizard figure.

Release Date
Product 
Version Chapter Description of Change
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October 14, 2005 5.2 Draft All

1

2

3

4

- Updated document footers and applicable screenshots to reflect 
new NETWARS version number.

- Added (optional) Server Characterization and Mainframe 
Characterization options to System Editor (File > Open Editor.)

- Added ‘Selecting the User Level’ section.
- Added New Project Wizard to ‘Creating a New Project’ section.
- Added detail to ‘Answering Mission Analysis Questions’ section.
- Updated ‘Setting the Area of Interest’ section (changed from 
‘Setting Area of Operation’.)
- Removed JMTK Data Maps and updated procedures in ‘Adding 
Background Images’ section.
- Changed ‘Zooming In/Out’ to ‘Zooming/Unzooming’, and 
updated procedures.
- Updated and added detail to ‘Viewing Scenarios’ section.

- Revised ‘Add Units via the Treeview’ section to reflect use of the 
Library Treeview.
- Added ‘Add Units via the Scenario Treeview’ section.
- Renamed Topology > Device Creator as Topology > Create 
Custom Device Model.
- Removed ‘Redeploying Links’ section.
- Removed ‘Remove a Scenario’ section.
- Added ‘Manage Scenarios’ section.
- Added Protocols > LDP, Protocols > RSVP, Protocols > VLAN, 
and Protocols > STP.
- Removed Protocols > MPLS and Protocols > DPT.
- Added detail to ‘Enabling Line-of-Sight (LOS) Connectivity and 
Range’ section.

- Revised ‘Creating Relationships’ and ‘Creating Threads’ 
sections to reflect use of the Scenario Treeview.
- Updated Figure 4-2 (Relationship Attributes dialog box) to 
reflect addition of Specify Start/Stop Time button.
- Removed ‘Creating Demands’ and ‘Converting Applications into 
Demands’ sections.
- Renamed Scenario > Convert Applications to Flows to Traffic > 
Convert Traffic > Applications to Flows.
- Added ‘Converting Link Loads into Flows’ and ‘Converting 
Flows into IERs sections.
- Added Traffic Wizard section.

April 1, 2005 5.1 Final Cover Changed release date to April 1, 2005, and removed OPNET 
contact info from Identification section.

Release Date
Product 
Version Chapter Description of Change
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March 21, 2005 5.1 Final 1

2

3

4

5

-Added ACE to ACE Whiteboard section.

- Added Procedure 2-13, Zoom to Selection.
- Updated Figure 2-8 to reflect new button placement.

- Added SLD info to ‘Deploying Links’ section, and added steps 
for editing SLDs to Procedure 3-14.
- In ‘Defining Additional Scenarios’section, replaced ‘Copy a 
Scenario’ procedure with ‘Create a New Scenario’ and ‘Duplicate 
a Scenario’. Also added ‘Remove a Scenario’ procedure.
- Changed Terrain>LOS Settings to Map>LOS Settings in 
Procedure 3-35.

- Updated Figure 4-6 to reflect removal of time step info, and 
Figures 4-3 and 4-4 to reflect new button placement.

- Updated Figures 5-2 and 5-7 to reflect new button placement.

February 21, 2005 5.1 Final No changes.

February 7, 2005 5.1 Draft All Ported existing Word document (NETWARS v 4.2) into Adobe 
FrameMaker 7.1, and applied commercial OPNET product 
documentation style template to improve quality and update 
manual. Reformatted text as needed to fit new format and style. 

Content changes:

- Updated applicable screenshots to reflect new NETWARS 
version number.

- Added reference to ACE in chapter 1.

- Noted that annotations are now saved as part of a template 
OPFAC/organization, and are also deployed with the template.

- Removed Alternate Link Cost field from Capacity Optimization 
Settings Advanced Parameters dialog box.

Release Date
Product 
Version Chapter Description of Change
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1 Introduction

The JCSS User’s Manual is a guide that covers basic aspects of JCSS 
operation and use. It contains figures that provide visual examples of the JCSS 
interfaces, step-by-step procedures, and other important JCSS features and 
concepts.

Organization of the chapter topics is based on a JCSS workflow for creating a 
communications plan. By following the chapter topics in sequence, users will be 
able to:

• Gain a high level-conceptual understanding of what the JCSS software is 
and what products it can deliver that are of use to military planners' goals.

• Acquire a set of rudimentary skills that enable military planners to create or 
modify JCSS scenarios, run simulations, and analyze the results.

Note—This manual contains frequent references to the JCSS Technical 
Reference Manual, which explains JCSS features, concepts, and 
methodologies in greater detail.

JCSS Overview

Military planners are challenged by several problems when considering 
communications needs for theater operations. You need to be able to visualize 
and describe the networks for which you are responsible. Where are the main 
communications nodes for the military units? Where are the main 
communications pipes linking these units? What interoperable communications 
devices are the units employing? Given the general message load demands of 
an impending major military operation, you need to anticipate where bottlenecks 
are likely to develop in the communications network infrastructure. Faced with 
the certainty that during the conduct of an operation, time critical messages 
must flow rapidly from one military unit to another, you must be able to anticipate 
whether all will arrive on time in order not to jeopardize mission 
accomplishment.

JCSS is a tool that helps military planners to solve these kinds of problems. It 
does this by enabling you to construct a computer representation of the 
communications network infrastructure coordinated to a map, and to use the 
computer to simulate the operational dynamics of message (or traffic) flow 
through this structure depending upon the scheduled loads you choose to input.
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JCSS is designed to be used in two phases:

• Phase 1 – Building network topology and setting traffic scenarios, and

• Phase 2 – Analyzing network performance using Capacity Planning for 
analytical analyses or/and using Simulation Domain for detailed analyses.

The framework for initiating a JCSS analysis is based on building a scenario. A 
scenario consists of one or more OPerational FACilities (OPFAC) and their 
associated communications equipment placed at specific geographic 
coordinates, a specific simulation start and end time, the operating parameters 
of the communications equipment, the movement (potentially dynamically 
determined) of these elements over time, and the associated communications 
traffic (e.g., Information Exchange Requirements or IERs). OPFACs are the 
basic building block of a JCSS scenario.  OPFACs are user-defined groupings 
of communication equipment that can move together like the communications 
assets of a tank or a plane. OPFACs can be grouped into organizations, to 
provide military hierarchical relationships and context.

Traffic, or the conveyance of messages through the communications 
infrastructure, is utilized during simulation and optimization. You define the 
traffic flow for a given operational scenario, and the JCSS simulation runs it 
through the constructed communications infrastructure. You then examine the 
output for unacceptable delays of critical messages. 

In order to assist you with the sequence of tasks along the way to achieving your 
goals with the JCSS tool, three workflows are presented below, and as wizards 
on the computer screen. These workflows are ordered by increasing complexity 
and precision, depending upon the time available for the work: first (1) the short 
term, high level Crisis Action Planner, which composes a network of nodes 
and links and loads it with traffic; then (2) the Operational Planner, which 
specifies actual communications devices located in OPFACs and is used in 
support of an OPLAN (Operations Plan); and finally (3) the Analyst, which 
specifies detailed IERs and makes use of detailed Measures of Performance 
(MOPs), such as Speed of Service, from the simulation results.

Sample Workflows

Crisis Action Planner’s Workflow

Sample workflows are provided via the JCSS Task Assistant. The Crisis Action 
Planner’s workflow, shown below, helps a Crisis Action Planner to develop, 
evaluate, and optimize a network to produce a communications plan. This 
workflow provides new or novice users with a checklist of sequenced tasks 
needed to perform this task following specific JCSS procedures.
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Figure 1-1   Crisis Action Planner’s Workflow

Operational Planner’s Workflow

Sample workflows are provided via the JCSS Task Assistant. The Operational 
Planner’s workflow, shown below, helps an Operational Planner to develop a 
communications plan in a semi-collaborative Joint Planner Environment. This 
workflow provides new or novice users with a checklist of sequenced tasks 
needed to perform this task following specific JCSS procedures.

Figure 1-2   Operational Planner’s Workflow
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Analyst’s Workflow

Sample workflows are provided via the JCSS Task Assistant. The Analyst’s 
workflow, shown below, helps an Analyst to develop and analyze a 
communications network. This workflow provides new or novice users with a 
checklist of sequenced tasks needed to perform this task following specific 
JCSS procedures.

Figure 1-3   Analyst’s Workflow

JCSS Interfaces

The capabilities of the JCSS software are organized into multiple editors: 
System Editor, Scenario Builder, Icon Database, (Optional) ACE and ACE 
Whiteboard, (Optional) Server Characterization, and (Optional) Mainframe 
Characterization. A description of each editor is provided below.

System Editor

The System Editor acts as an entry point to the remaining editors. It allows you 
to access user and profile information as well as the task assistant interface.

Scenario Builder

The Scenario Builder allows you to build template OPFACs and organizations, 
define infrastructure and Information Exchange Requirements (IERs) between 
OPFACs and organizations, specify movement and geographical context for 
OPFACs and organizations, and run discrete-event simulations for their 
developed scenarios. You can open and work with multiple projects 
simultaneously, and easily cut, copy and paste supported objects 
(Organizations, OPFACs, devices, links, etc.) between them.
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Additionally, the Scenario Builder provides you with the option of deploying a 
communications infrastructure using a top-down approach. More specifically, 
the Lead Planner sets up the planning view and sends the initial scenario to the 
Subordinate Planners. The Subordinate Planners modify their portion of the 
initial plan and then send it back to the Lead Planner who integrates them into 
a complete plan.

The Scenario Builder allows you to optimize link and broadcast network 
capacities as well as traffic load. The optimization of the link and broadcast 
network capacities is implemented by changing the size of links and broadcast 
networks while the optimization of the traffic load is implemented by changing 
the load caused by the IERs.

This editor also allows you to view results of the simulation. After the simulation 
is complete, the Simulation Domain creates text files that capture the results of 
the simulation. JCSS reads these files and displays the results graphically as 
Measures of Performance (MOPs). The MOPs focus on the ability of selected 
communication equipment to send and receive information (e.g., file transfers, 
situation awareness updates, e-mail messages, etc.)

Icon Database

The Icon Database allows you to create new icons for OPFACs and 
organizations displayed within the Scenario Builder.

(Optional) ACE and ACE Whiteboard

The Application Characterization Environment (ACE) and the ACE Whiteboard, 
which require a separate license, allow you to perform network performance 
analysis and troubleshooting. Use ACE to analyze traces obtained from a live 
network. However, if you want to simulate the behavior of an application that 
does not exist yet, use the ACE Whiteboard to create a model of the application 
and then run analyses on it. To learn more about ACE and the ACE Whiteboard, 
refer to the ACE User’s Guide.

(Optional) Server Characterization

The Server Characterization Editor (SCE) is an optional module that allows you 
to import server performance information for analysis of the processes and 
applications, and characterization into workloads used as the basis for 
simulation modeling. To learn more about the SCE, refer to the IT Guru 
documentation suite.

(Optional) Mainframe Characterization

The Mainframe Characterization Editor (MCE) is an optional module that allows 
you to import measured performance data, and analyze it to create workloads 
suitable for the mainframe models.To learn more about the MCE, refer to the 
MCE tutorials.
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System Architecture

Figure 1-4   JCSS System Architecture

JCSS is launched via the System Editor, which is considered a supporting 
interface.

In JCSS, organizations and OPFACS are built and modified inside the Scenario 
Builder, the primary interface.

The Simulation Domain allows the Scenario Builder to provide its output to a 
COTS Simulation Engine (e.g., OPNET Modeler) in a file structure expected by 
the Simulation Engine. 

After a simulation is run, the results are viewed in the form of graphs called 
Measures of Performance (MOPs). Scenarios can also be further analyzed and 
then optimized for network performance. 

Graphical presentations of JCSS objects, such as device models and military 
units, can assume various forms via the Icon Database. This editor is a 
supporting interface.
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2 Getting Started

Launching JCSS

Launch JCSS to access the desktop software application.

Procedure 2-1   Launch JCSS

1 Select Start > Programs > NETWARS > NETWARS v2007. The System Editor 
and the Sign In dialog box automatically display.

Figure 2-1   System Editor

Figure 2-2   Sign In dialog box

End of Procedure 2-1
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Signing In and Creating a New User Profile

Create a new user profile, which will allow you to sign into JCSS under your own 
account. Note that only one user at a time can be signed in. 

Procedure 2-2   Create a User Profile

1 Click the New button on the Sign In dialog box to create a new user profile. The 
New Profile window displays. 

Figure 2-3   Adding a New User Profile

2 Enter required information and any optional information. Click OK. 

3 The Sign In dialog box displays again with the new user name in the Profile field. 
Click Sign In to sign in.
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(Returning users can select their previously created profile name from the Profile 
drop-down menu and then click Sign In).

Figure 2-4   Signing In

End of Procedure 2-2

Selecting the User Level

Switch between JCSS interfaces (simple to complex) by selecting one of the 
available User Level options. JCSS menus change to reflect the selected User 
Level. Higher User Levels display more menu items and menu headers. You 
can switch between User Levels at any time, so that all menu items can be 
available if you so choose. Switching the User Level affects all open editors.

Procedure 2-3   Select the User Level

1 From the System Editor, select Edit > User Level > Beginner to access a 
simplified JCSS interface. The Beginner interface hides access to many of the 
functionalities of the system without removing the capabilities themselves. This 
results in an interface that is reduced in complexity, and is easier to navigate for 
beginner JCSS users.

2 Select Edit > User Level > Intermediate if you want to access a JCSS interface 
that exposes more functionalities of the system than the Beginner level, but less 
than the Advanced level. This results in an interface that is reduced in complexity, 
and is easier to navigate for intermediate users.

3 Select Edit > User Level > Advanced if you want to access the full-featured JCSS 
interface. The Advanced interface exposes all of the functionalities of the system. 
This results in an interface that is more complex, and best utilized by more 
experienced JCSS users.

End of Procedure 2-3
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Using the Task Assistant

The Task Assistant is a tool that guides you through the steps necessary to plan, 
analyze, and simulate a communications data/voice network. It presents 
workflows that provide new or novice users with a checklist of sequenced tasks 
needed to perform certain JCSS procedures.

The Task Assistant workflows are located in a unique window that can be 
moved or minimized on the screen.  The checklist of tasks displays in the 
Workflow pane on the left side of the Task Assistant; a corresponding detailed 
explanation displays in the Explanation pane on the right along with a pane for 
entering user annotations. The contents of the Explanation pane provide 
step-by-step instructions for completing the associated task.  

Not all of the tasks in the workflow are required; milestone tasks are marked with 
a red “M” and can be optional or required; required tasks are marked on the left 
with a green “R”, and optional tasks are marked with a blue “O”. After you 
complete a task, double-click it to check it off. More help is available through the 
Help button on the bottom left of the Task Assistant workflow window. 

Some tasks, marked with a plus (+) sign to the left, are made up of multiple 
sub-tasks. Clicking on the plus sign expands the task to show all of the 
sub-tasks in that task.

Procedure 2-4   Open a Workflow using the Task Assistant

Open Task
Assistant

1 From the System Editor, select Help > Task Assistant to launch the Task 
Assistant. Keep in mind that from the Scenario Builder you can click the Open 
Task Assistant button. 

2 To configure the Task Assistant to automatically display at startup, check the Show 
At Startup checkbox at the bottom of the Task Assistant.

Figure 2-5   Checking the Show At Startup Checkbox
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3 Select the Develop Communications Plan workflow from the Workflows pane. A 
description of this workflow displays in the Explanation pane. 

4 Click the Open Workflow button (double-clicking on Develop Communications 
Plan also initiates the workflow). This launches the Scenario Builder and the 
selected workflow in the Task Assistant. 

5 Follow the sequential tasks in the Workflows pane until completion.

Figure 2-6   Following Sequential Tasks in the Workflows Panel

End of Procedure 2-4     

Creating a New Project

The first step in the planning process is to create a new project in the Scenario 
Builder. Projects are files that contain scenarios (time phases or courses of 
action). A scenario or groupings of related scenarios can be saved under one 
project.

You can simply name and launch a generic project, or use the New Project 
Wizard to select and set the area of operation, top-level units (including their 
locations and templates), an equipment list for each organization, an owner for 
each unit, and the types of equipment to use in the new project.
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Procedure 2-5   Create a New Project

Create a New
Project

1 From the System Editor, select File > New Project to open the Create Project 
dialog box, or click the Create a New Project button.

Figure 2-7   Creating a new project

2 Specify the names for the project and the initial scenario in the Create Project 
dialog box.

Note—The names for both the project and the scenario cannot contain any spaces 
or special characters. In addition, the scenario name cannot be the same as any 
existing OPFAC; it must be unique.

3 Select a classification level for the project in the Create Project dialog box.

4 Click OK. If Launch New Project Wizard is not checked, then JCSS creates a 
generic project using the names you have designated. If Launch New Project 
Wizard is checked, then JCSS displays a sequence of dialog boxes that enable 
you to make selections specific to your new project.

5 If you selected to launch the New Project Wizard, perform the following steps to 
make selections specific to your new project:
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5.1 Set the geographical context for your project in the New Project Wizard: Set 
Area of Operations dialog box.

Figure 2-8   New Project Wizard: Set Area of Operations dialog box

• Choose the border map that you want to see in the Project Editor from the 
Map drop-down list, and specify the area of view and center of view. The 
view settings determine the initial zoom level of the project. You will still be 
able to place units outside that area if needed.

• Click Preview to display the chosen view area in the workspace.

• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.

5.2 Specify top level units in the New Project Wizard: Specify Top-Level Units 
dialog box.

Figure 2-9   New Project Wizard: Specify Top-Level Units dialog box

• Choose a project template from the Project Template drop-down list with 
which to fill in the units table, or select the number of units from the Number 
of Top Level Units field drop-down list.
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• For each top-level unit in the table, type the name of the unit in the Name 
column, and select whether the unit is an organization or an OPFAC in the 
Type column.

• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.

5.3 Specify top level units in the New Project Wizard: Unit Locations and 
Templates dialog box.

Figure 2-10   New Project Wizard: Unit Locations and Templates dialog box

• Specify the location of each top-level unit in the units table by specifying the 
Latitude and Longitude of each unit.

• If you want, you can specify a unit template for each unit (organization or 
OPFAC template) by clicking in the Unit Template column and launching 
the Choose Unit Template dialog box.

Figure 2-11   Choose Unit Template dialog box
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• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.

5.4 (Optional) Specify the equipment list for each organization in the New Project 
Wizard: Specify Equipment Lists dialog box.

Figure 2-12   New Project Wizard: Specify Equipment Lists dialog box

• Click in the Equipment List column for each unit to launch the Equipment 
List dialog box and create an equipment list.

Figure 2-13   Equipment List dialog box

The table has three columns: Equipment Name, Quantity, and Device 
Model. The Equipment Name can be typed in by clicking on the cell. This 
name must be unique within this organization's equipment list.  When the 
Quantity cell is clicked, a separate Quantities dialog box displays from 
which the quantity can be edited. Clicking the Device Model cell displays a 
popup list of all available device models. When a device model is chosen, 
the model name is automatically placed in the Equipment Name field if that 
field is currently empty.

Click Insert and/or Delete to add a new row after the currently selected row 
or delete the currently selected row, respectively.

Click Export to export the information in this table to a comma-separated 
file and open the file in Excel. Click Print to send the data directly to the 
printer.
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Click OK to save the changes that have been made. If the organization is a 
template organization, this new information is immediately saved to disk.

• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.

5.5 (Optional) Specify the owner for each unit in the New Project Wizard: Specify 
Owners dialog box.

Figure 2-14   New Project Wizard: Specify Owners dialog box

• Click in the Owner column for each unit to launch the Set Owner dialog box 
and specify an owner.

Figure 2-15   Set Owner dialog box

Owner information contains a list of attributes: Last Name, First Name, 
Organization and Title. Title is the only optional field. If the desired owner is 
not listed in the popup menu, click New Owner to add owner information.

To unset the owner information, enable the Unset owner information 
checkbox.

If there are multiple units selected, enabling the Apply owner information 
to selected units will apply changes to all selected units.
UM-2-10 JCSS/Release 7.0



JCSS User’s Manual 2—Getting Started
Once the owner is set, the unit is marked. If the unit is an organization, all 
its children are also set with the same owner. Subordinate planners are 
able to edit units if the organization name in the owner information is the 
same as the subordinate planners' organization.

This dialog box could be disabled due to one of the following reasons:

* The owner information was set from the parent. Perform an unset on the 
parent before you can set the owner on the current unit.

* A subordinate query file had already been exported on the current unit.

* At least one of the current organization's children has already exported a 
subordinate query.

• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.

5.6 Review top level units in the New Project Wizard: Top Level Unit Summary 
dialog box.

Figure 2-16   New Project Wizard: Top Level Unit Summary dialog box

• This table lists all of the organizations and OPFACs that were specified in 
the previous dialog boxes. The properties of each unit are listed in the table 
and may be modified by clicking on the cells.

• You can also modify the number of units and choose a project template. 
Choosing a project template automatically replaces what is currently in the 
table with the information in the template.

• After reviewing all the information in the unit table, you can save it as a new 
project template by clicking Save New Project Template... and specifying 
a name for the template in the Specify Project Template Name dialog box. 
You should do this if you often create projects with the same or similar 
top-level units.

• Click Next to continue to the next setting, or Finish to create the new 
project using the settings you have chosen, along with other setting 
defaults.
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5.7 Select the types of equipment you will use in your project in the New Project 
Wizard: Select Equipment Types dialog box.

Figure 2-17   New Project Wizard: Select Equipment Types dialog box

• This table lists all existing device palettes. The devices within each of the 
included palettes will be concatenated into a single new palette for this 
project. The new palette will be named 
<project_name>-<phase_name> and will be the default palette. Note 
that you will still be able to use devices in other palettes.

• Click Finish to create the new project using the settings you have chosen. 
Scenario Builder displays your new project in the workspace, and displays 
the project name and active scenario name in the title bar.

End of Procedure 2-5

Setting Scenario Classification

Now that the project is created, you can specify initial scenario information such 
as the scenario classification. This information applies to the entire scenario. 
Providing initial scenario information is optional in JCSS; if the information is not 
provided, default values will be used. The default scenario classification is 
Unclassified.

Procedure 2-6   Set Scenario Classification

1 Select Scenarios > Set Classification to open the Set Scenario Classification 
dialog box. 

2 Select the desired classification from the Scenario Classification drop-down menu.
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3 Click OK. The scenario classification displays in the upper-left and lower-right 
corners of the Scenario Builder.

 

Figure 2-18   Setting the Scenario Classification

End of Procedure 2-6     

Answering Mission Analysis Questions

Every project has a default set of mission analysis questions that is 
automatically included when the project is created. The questions are grouped 
into five sections that correspond to a 5-paragraph operations order:

• Situation,

• Mission, 

• Execution, 

• Admin & Logistics, and 

• Command & Control.

The questions are filled in by the Lead Planner and used by Subordinate 
Planners when entering requirements.

If you want to modify the mission analysis questions inherited by a specific 
scenario, you can do so via Scenarios > Reports > Mission Analysis. 
Changes made here affect only the selected scenario; they do not affect your 
project defaults.

If you want to modify the default mission analysis questions to be used for any 
newly created projects, you can do that via Edit > Project Defaults > Mission 
Analysis. Any newly created projects/scenarios will inherit these questions. 
Existing ones will remain unchanged.
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Procedure 2-7   Answer Mission Analysis Questions for a Project

1 Select Edit > Project Defaults > Mission Analysis. The Mission Analysis 
Questions dialog box displays. 

Figure 2-19   Answering Mission Analysis Questions (5 Sections)

When the Mission Analysis Questions dialog box is launched, questions under the 
Situation section are displayed. The planner can view questions in the other 
sections by clicking on the appropriate button below the table. The label on top of 
the table represents the current section.

2 Click in either the Question or Answer/Comment cell to enter the desired text. 
Click the OK button to populate the question/answer back into the table. 

3 Add or delete questions, as needed, using the Add Question or Delete Question 
buttons.

4 The content of the Mission Analysis Questions table can be exported to an Excel 
file or to an HTML file by clicking the Export to File or Export to HTML buttons, 
respectively. Specify the target location on disk to store the exported file.

5 Print the contents of the Mission Analysis Questions table to the default printer by 
clicking Print. The printout contains all mission analysis questions and answers 
including the last edited by information divided by each section.

6 In addition to manually typing in Mission Analysis Questions for each project, you 
may also import additional Mission Analysis Questions into the Mission Analysis 
Questions table. Import this information by clicking Import. A file chooser dialog 
box launches; select a desired text file and click Open. 

Note—The text file must be tab-delimited and must follow the same format as the 
Mission Analysis defaults file, i.e., MissionAnalysis.gdf.
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Once you have selected the file from which the additional Mission Analysis 
Questions are to be loaded, the table will be updated to display this newly 
appended information. Duplicate Mission Analysis Questions will not be appended 
to the dialog box.

7 Click OK to save the data in the Mission Analysis Questions table. Saving the 
changes will modify the MissionAnalysis.gdf file located in the Rules 
directory. To change the default file, click the Choose Defaults File button. 
Selecting this button launches a file chooser dialog box. Select the desired default 
file; the contents of the alternate file import into the Mission Analysis Defaults 
dialog box.

Note—The Choose Defaults File button is not available when the Mission 
Analysis Questions dialog box is launched from Scenarios > Reports > Mission 
Analysis to make changes to a selected scenario.

End of Procedure 2-7

Setting the Area of Interest

The area of interest gives geographical context to the scenario.

Procedure 2-8   Set the Area of Interest

1 Select View > Set Area of Interest from the Scenario Builder. The Set Area of 
Interest dialog box displays.

Figure 2-20   Setting the Area of Operations

The geographic focus can be specified by entering values for the Area of the View 
and the Center of the View. These attributes determine the location and size of 
the displayed view of the map. For example, if the center of view is (0,0) and the 
area of view is (width = 100, height = 50), then the portion of the map that would 
be displayed will be from (50W, 25N) to (50E, 25S). 
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The geographic focus also determines the relative range at which OPFACs (and 
their devices) are located from each other. This is of significance when exchanging 
IERs/traffic during a simulation. While TSC-85 radios and wire links have no range 
limitations, TRC-170 radios and tactical broadcast networks only work within a 
limited range of each other. For example, if two TRC-170 radios are more than 150 
miles apart, then all packets transmitted between them will be dropped, resulting 
in failed IERs.

2 Select desired options for displaying grid.

3 Click OK. The settings reflect in the Scenario Builder.

End of Procedure 2-8

Adding Background Images

You can provide further geographical context to a scenario through the use of 
various maps and images.

JCSS recognizes several different types of maps, including: border maps, 
image maps, MapInfo (MIF) maps, CADRG/CIB Raster Catalog Directories, and 
MrSID images.

Border Maps

Border maps use stylized lines to define political and geographical areas.  JCSS 
comes with a library of border maps that represent a geographic area described 
by latitude and longitude.

Image Maps

Image maps are TIFF or GEOTIFF files that provide additional geographical 
information on a border map, such as a satellite or aerial image.

MIF Maps

MIF maps are files that provide additional geographical information on a border 
map, such as roadways, waterways, regions, and counties. Several MIF maps 
come standard with JCSS.

Procedure 2-9   Add a Border Map

1 Select View > Background > Set Border Map from the Scenario Builder. The 
Choose Border Map dialog box displays.
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2 Choose a border map from the drop-down menu. Note that the border map list is a 
finite list and may not be modified.

Figure 2-21   Selecting a Border Map

3 If the desired map is not in the list, select the world map and zoom in to the desired 
location.

End of Procedure 2-9

Procedure 2-10   Add an Image Map

1 Select View > Background > Add Image Map from the Scenario Builder to open 
the Add Map dialog box.

Figure 2-22   Add Map dialog box

2 Choose an option of importing an existing map or specifying the file path to an 
image map located on the hard drive; select desired map.

3 Click OK.

End of Procedure 2-10
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Procedure 2-11   Add a MIF Map

1 To import a MIF map, select View > Background > Add MIF Map from the 
Scenario Builder to open the MIF menu. 

Figure 2-23   MIF Menu

2 Select the desired MIF map from the menu. 

3 Click Close. The MIF map automatically imports.

Note—When image maps are imported, the maps can be deleted, resized, or 
dragged and dropped to a different location while in Map Edit mode. To enter/exit 
Map Edit mode, select View > Background > Map Edit Mode.

End of Procedure 2-11

Zooming/Unzooming

Get a close-up view of a JCSS object or area in the workspace or restore the 
workspace view to the previous zoom level. 

Procedure 2-12   Zoom to Rectangle

1 To get a close-up view of the object in question in the workspace, first select View 
> Zoom > To Rectangle, or press <Ctrl>+<I>, or use the Zoom In option from the 
shortcut menu, or click the Zoom In toolbar button.
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2 Next, drag the cursor to define a rectangular shaped region to be magnified; the 
defined area magnifies in the workspace.

Figure 2-24   Zooming In

Apply this option multiple times to obtain an ever-closer view.

End of Procedure 2-12

Procedure 2-13   Zoom To Selection

1 First, drag the cursor to define a rectangular shaped region to be magnified.

2 Next, select View > Zoom > To Selection, or press <Ctrl>+<Shift>+<Z>. The 
defined area magnifies in the workspace.

End of Procedure 2-13

Procedure 2-14   Zoom To Window

1 Select View > Zoom > To Window. The entire area magnifies in the workspace so 
it shows completely in the window.

End of Procedure 2-14
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Procedure 2-15   Unzoom

Zoom Out 1 To restore the workspace view to the previous zoom level, select View > Zoom > 
Unzoom, or press <Ctrl>+<U>, or use the Zoom Out option from the shortcut 
menu, or click the Zoom Out toolbar button

Figure 2-25   Zooming Out

End of Procedure 2-15 

Procedure 2-16   Zoom To All

1 Select View > Zoom > To All, or press <Ctrl>+<Alt>+<Z>. The active areas in the 
workspace are magnified so they show in the window.

End of Procedure 2-16
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Viewing Scenarios

JCSS offers a number of different views of a scenario, accessible by selecting 
a view option from View > Network Views > (option):

• Planning – This view is useful for someone working in a collaborative 
planning environment. Using this view, the planner can display only the 
planning portions of the scenario and hide all others. Organizations, 
OPFACs and planning links are all part of the planning view. Devices and 
connectivity links are hidden in this view.

• Connectivity – If a planner is not interested in the planning links and just 
wants to view the connectivity links in the network, he or she can choose this 
view option. Planning links and OPFACs without any devices are hidden in 
this view.

• Planning and Connectivity – The planner can use this view option to return 
to the default view, which includes the planning and connectivity elements in 
the scenario.

• Operational – Selecting this view option switches from a Systems or Logical 
View back to the default view of the scenario, the same view that loads when 
you first open the scenario in Scenario Builder.

• OPFAC Systems – Selecting this view option switches from the current 
view, the Operational View or some other type of Systems View, to the 
OPFAC Systems View.  The OPFAC Systems View expands the contents of 
the organizations, collapses the contents of the OPFACs, and redraws the 
links to connect to their respective devices.

You can also choose View > Show Logical Views... which displays similar 
objects in an abstract manner, without geographical context. Selecting this view 
option launches the Logical View Selection dialog box that you may use to 
specify settings for filtering the logical views.

Each of these views offers the user a different perspective of the network.  
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Procedure 2-17   Selecting Settings for the Logical View of a Scenario

1 Select View > Show Logical Views.... The Logical View Selection dialog box 
displays.

Figure 2-26   Logical View Selection dialog box

2 Select a Network Layer Filter with which to filter your logical view. This filtering 
parameter enables you to hide all devices except for those of a particular layer of 
the network. [Note that this doesn’t necessarily mean OSI network layer, but 
instead, it means the various devices that use a particular protocol.] Network Layer 
Filters shown are only those which apply to the deployed network.

3 Select a Security Classification Filter with which to filter your logical view. This 
treeview enables you to filter elements of the network based on their security 
classifications. Any custom classifications added in the Operational view will be 
availabe here as well for filtering.

4 Specify the Duration and Start Time parameters to get the Capacity Planner 
graphs that are used for filtering for various layers.
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5 Check the Consider Link Capacities checkbox if you want to use this parameter 
to get the Capacity Planner graphs. A link capacity considered filter will result in the 
Capacity Planner creating a graph that may not show complete physical 
connectivity of the devices due to link load.  A link capacity ignored filter will result 
in a graph that shows complete physical connectivity of the devices regardless of 
link load.

6 Click Create View to create and load the type of view that you specified if you are 
not already in this view. The filter specifications are applied to the logical view 
model.

7 Click Save Settings to save the settings instead of creating a logical view network 
with the specified settings at this time.

8 Click Cancel to close the Logical View Selection dialog box without making any 
changes to the model.

End of Procedure 2-17
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3 Topology Building

Adding Units (Organizations and OPFACS)

To develop a JCSS scenario, add organizations and OPFACs that represent a 
communications plan.  Build it from scratch by adding an empty unit from the 
shortcut menu or the Organization and OPFACs Library Treeview (via 
drag-and-drop), or select a pre-configured unit complete with specific attributes 
and devices.

Organizations are groupings of sub-organizations and OPFACs that can 
represent military organizations or a physical location. 

Operational Facilities (OPFACs) are the fundamental building blocks of JCSS. 
They are collections of communications devices that are assigned to military 
units, which are used to construct Organizations.

Procedure 3-1   Add Units via the Library Treeview

1 Select Topology > Open Library Treeview to display the Organizations and 
OPFACs Library Treeview.

Figure 3-1   Adding Units via the Library Treeview

2 Select the unit you want to add in the treeview, and drag-and-drop it to the desired 
location on the Scenario Builder workspace.

End of Procedure 3-1
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Procedure 3-2   Add Units via the Shortcut Menu

1 Right-click in the workspace to open the shortcut menu.

2 Select Create New Organization or Create New OPFAC.

End of Procedure 3-2

Modifying Units

Units have attributes that define functionality, behavior, and physical 
characteristics.

Organization Attributes

• Organization Name – This field uniquely identifies an instance of an 
Organization.

• Organization Type – This attribute specifies the type of the Organization.

• Type Name – This attribute specifies the type name. This attribute does not 
affect the simulation at this time and maybe ignored or left blank.

• Echelon Size – This attribute specifies the echelon size. This attribute does 
not affect the simulation at this time and maybe ignored or left blank.

• Tasks – This attribute specifies the tasks for this organization. This attribute 
does not affect the simulation at this time and maybe ignored or left blank.

• Trajectory – Specify the trajectory for the organization from a selection 
menu that displays all the saved trajectories (Scenario Builder Editor 
Feature).

• Dissociate Subordinate Organization and OPFAC Movement – Check 
this option to separate the subordinate organization from the movement of 
the OPFAC.

• Start Time(s), Stop Time(s) – These are start and stop time(s) for the 
simulation (Scenario Builder Editor Feature).

• Altitude, Alt. Units, Altitude set by terrain – These attributes specify the 
location of the Organization (Scenario Builder Editor Feature).

• Icon Name – Click the Edit Icon button to select an icon for the organization; 
the name displays in the Icon Name field.

• Documentation – Access a free-form text box to enter organization purpose 
and topology notes to be stored with the scenario for documentation 
purposes.
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• Set Owner – Mark organizations for subordinate input by setting ownership 
information.

• JNMS Attributes – Set JNMS attributes for export to Network Engineer.

• Failure/Recovery – Specify a time interval or period of time for which the 
organization is inoperable.

OPFAC Attributes

• OPFAC Name – This field uniquely identifies an instance of an OPFAC.

• OPFAC Functional Profile – Click the Edit button to select a profile for the 
OPFAC; the name displays in the OPFAC Functional Profile field.

• OPFAC Type – This is the name of the OPFAC model stored on disk. If you 
modify this, Infrastructure Re-assignment dialog boxes may be launched. 

• Trajectory – Specify the trajectory for the OPFAC from a selection menu that 
displays all the saved trajectories (Scenario Builder Editor Feature).

• Start Time(s), Stop Time(s) – These are start and stop time(s) for the 
simulation (Scenario Builder Editor Feature)

• Altitude, Alt. Units, Altitude set by terrain – These attributes specify the 
location of the OPFAC (Scenario Builder Editor Feature).

• Icon Name – Click the Edit Icon button to select an icon for the organization; 
the name displays in the Icon Name field.

• Devices – This is a table that provides a list of all devices contained in an 
OPFAC.

• JNMS Attributes – Set JNMS attributes for export to Network Engineer.

• Failure/Recovery – Specify a time interval or period of time for which the 
OPFAC is inoperable.

• Set Owner – Mark OPFACs for subordinate input by setting ownership 
information.
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Procedure 3-3   Edit Unit Attributes

1 To edit unit attributes, right-click on the unit to open the shortcut menu.

2 Select Edit NETWARS Attributes to open the corresponding Organization 
Attributes or OPFAC Attributes dialog box. 

Figure 3-2   Organization Attributes
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Figure 3-3   OPFAC Attributes

3 Edit attributes as needed and then click OK.

End of Procedure 3-3

Editing Attributes for Many Objects

You might need to set values for the same attributes on several objects in a 
network model. JCSS provides several alternate methods for quickly changing 
attributes on many objects, one of which is using the Edit Objects Using 
Template command on the Edit menu.

JCSS allows you to edit attributes for multiple objects in one window, using an 
attribute table similar to a User Defined Report. You can create your own 
attribute templates (as described in Procedure 3-6) to generate tables of 
specific attribute values for one or more objects in a network. An attribute 
template specifies the following information about an attribute table:

• Table category and name—Every attribute table belongs to a category, such 
as “IP” or “Application”, and has a name that identifies it.
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• Object types to include—A table can include all network objects, a specific 
type of network object, or objects selected by custom criteria that you specify.

• Attributes to include—Each row of an attribute template specifies the title and 
contents of a column that will appear in the attribute table.

Procedure 3-4   Edit Attributes For Many Objects Using a Template

1 Select Edit > Edit Objects Using Template. The Edit Objects Using Template 
dialog box displays.

Figure 3-4   Edit Objects Using Template dialog box

2 Select an attribute template in the Select table to include in user report list box from 
which to generate an editable table of attribute values.

To select an entire category of tables, click on the top-level category entries. To 
select an individual table, expand the top-level category subtree and click on the 
table entry. Selected tables and categories show a green checkmark. Categories 
with some but not all of its tables selected will display a green dot instead.

Note—If you want to define a custom template, click Close, define a template as 
described in Procedure 2-3, then begin this procedure again.

3 Select the Include only selected objects checkbox if you want to collect table 
data only for objects that are currently selected in the network.

4 Select the Ignore views checkbox if you want to collect table data even for objects 
that are not in the current view or views of the network.
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5 Select the Send reports to the Report Server (host) checkbox if you want to send 
reports to the Report Server. This option is active only when a Report Server 
license is available. 

5.1 Specify a name for the report in the Report Server text field. 

6 Click Generate to generate the table data for all of the selected tables. The 
corresponding dialog box displays.

Figure 3-5   Table of Generated Attributes

7 Edit the attributes as needed. There are two editing modes:

7.1 Standard Mode—Click on any attribute value and edit it as you would in the 
Attributes dialog box.

7.2 Copy and Paste Mode—Copy an attribute value and paste it to one or more 
similar attributes. This mode disables the standard methods for changing 
attribute values (edit fields, pull-down lists, and so on).

• Select the Copy and Paste Mode checkbox.

• Select an attribute value and press <Ctrl>+<C>.

• Select the attribute value or a range of contiguous values and press 
<Ctrl>+<V>.

You can paste only into the same attribute column from which you copied.

8 When you are finished editing attribute values, click OK to make the changes.
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Procedure 3-5   Define or Edit an Attribute Template

1 Select Edit > Edit Attribute Template. The Edit Attribute Template dialog box 
displays.

Figure 3-6   Edit Attribute Template dialog box

Each table row corresponds to an attribute column in tables generated from this 
template. At first, the only column defined is for an object name.

2 Choose whether to define a new template or edit an existing one:

2.1 To define a new template, leave the category and template names set to 
“unnamed”. (You will specify these names when you save the template.)

2.2 To edit an existing template, select its category and name from the pull-down 
menus.

3 Choose what object types to include in the table:

3.1 Select an object type from the Include pull-down menu.

3.2 If you selected “Objects in logical selection”, use the Logical selection 
pull-down menu to specify a selection criterion.

4 Choose what attributes to include in table columns:

4.1 To add a new undefined column, click New.

4.2 To add a new column based on an existing one, select the desired attribute 
row and click Duplicate.

4.3 To edit a column definition, select a row and click Edit. (Alternatively, you can 
double-click the Column Value field.) This opens a dialog box for specifying 
the contents and format of the table column.
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4.4 To delete a column, select its row and click Delete.

4.5 To add a drilldown, select a row and click Add Drilldown. A drilldown is a child 
table that you open by following a link in the parent table. Drilldowns are useful 
when you want to show a set of related attributes in a separate window. For 
example, you might want to create a drilldown table for IP port attributes on a 
router.

This operation creates a drilldown table definition, which is initially equivalent 
to the current table definition. To edit the drilldown table, select the row and 
click Edit.

5 Move attributes around as needed to modify the appearance of tables generated 
from the template:

5.1 To change the sequence of attributes, select an attribute row and click Move 
Up or Move Down (thus moving the resulting table column left or right, 
respectively).

5.2 To see what the generated table will look like, click Preview. A dialog box 
displays a preview of the table to be generated using the current template.

Figure 3-7   Preview of Table to be Generated from Template

6 Click Save As in the Edit Attribute Template dialog box.

6.1 If you are defining a new template, enter names for the category and table. 
The category can be one of the existing categories or a new one.

6.2 If you are editing a template, you can either keep the original category and 
table names (to replace the original template) or change the table name (to 
create a new version of the original).

The template is saved with the extension .urep.xml. New templates are 
saved in your default model directory; edited templates are saved in the same 
directory as the original template.

7 Click Cancel to close the dialog box.

End of Procedure 3-5
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Creating Template Organizations and OPFACs

Reusable templates of organizations and OPFACs created in JCSS can be 
saved to object palettes. This provides a quick and easy way to add duplicate 
organizations and OPFACs to a workspace without having to configure them 
from scratch. All devices, links, and attributes (including annotations) of a 
template organization or OPFAC are captured. 

A change to a template will not replicate that change to instantiated 
organizations or OPFACs throughout the topology.

Procedure 3-6   Create a Template OPFAC or Organization

1 Right-click on a unit to open the shortcut menu. 

2 Select Create Template OPFAC or Create Template Organization.

3 (OPFACs Only) In the dialog box that displays, enter a cost for the OPFAC 
devices (if known) in the Cost field, and enter a description of the OPFAC in the 
Description field. 

4 Click OK. The Save OPFAC/Organization dialog box displays. 

5 Specify a folder/object palette to save the template in. Click Open. 

6 Click Save. The template is saved and is available on the specified object palette.

    

Figure 3-8   Template Organizations and OPFACs Saved to Object Palettes 

End of Procedure 3-6
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Drilling Down into Units

 “Drilling down” is a term that describes accessing the contents of organizations 
and OPFACs. For example, organizations may contain sub-organizations and 
OPFACs, while OPFACs contain devices.

Procedure 3-7   Drill Down into a Unit

1 Double-click on a unit icon to drill into/view its contents.

 

Figure 3-9   Drilling Down into Units

End of Procedure 3-7

Adding Devices to OPFACs

Place devices inside OPFACs. Devices are pieces of communications 
equipment that represent specific models. Examples include routers, 
computers, phones, and satellites.  We suggest using the 
NETWARS_Standard_Models palette to build OPFACs because the palette 
includes all of the updated device models and link models for connecting the 
devices.

OPFACs are automatically created for single devices that are added to the 
workspace or an organization (i.e., not placed directly in an OPFAC). The 
OPFAC will have the same icon as the device and both the OPFAC and device 
right-click menu options will be made available.

JCSS provides a variety of different object palettes containing nodes, devices, 
links, and paths (circuits.) All of these objects are easily added to a workspace 
using drag-and-drop or point-and-click techniques.
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Procedure 3-8   Add a Device to an OPFAC

Open Object
Palette

1 Click the Open Object Palette button, or select Topology > Open Object Palette. 
The object palettes display in either a Tree view style or an Icon view style, 
depending upon how your environment preferences are set.

Figure 3-10   Object Palette by Tree View

Note—The view style in which the object palettes display changes based on the 
value specified for the network_palette.style environment preference. You 
may set the object palette view style preference via Edit > Preferences > 
Advanced.
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2 In the Object Palette Tree view, click the Open Palette In Icon View icon button 
(upper left corner) to replace this dialog box with the Object Palette Icon view that 
displays only a single palette file at a time. 

Figure 3-11   Adding Devices to an OPFAC via Object Palette

The palette file initially displayed will be either the default palette of the scenario or, 
if the tree selection is within a particular palette file tree element, the palette that 
contains the current tree selection. 

3 Select the NETWARS Standard Models object palette or other palette.

4 Left-click the desired device in the object palette.

5 Drag-and-drop device from the object palette to the workspace. 

6 Right-click to exit Device Creation mode.

Note—Consult the JCSS Technical Reference Manual for instructions on 
configuring custom object palettes.

End of Procedure 3-8

Cutting, Copying and Pasting Objects

Cut, copy, or paste selected supported objects on the workspace to or from the 
Windows clipboard. Supported objects include:

• Organizations
• OPFACs
• Devices
• Links (External and Internal links)
• Satellite links
• Broadcast Networks
• OPNET demand objects
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Objects which are not supported include radio links, relationships, 
IERs/demands, and Configuration OPFACs. If unsupported objects are 
attached to a supported object, then the unsupported objects are also removed 
from the workspace but not maintained on the clipboard.

When copying, cutting or pasting an Organization and/or OPFAC, all supported 
children are also copied, cut, or pasted.

When undoing cut, copy, or paste operations, some actions may prevent 
certain, or all, prior actions from being undone (for example, saving a project 
file.) Immediately following a save to disk, there will be no undoable actions. 
There is no limit on the number of actions that can be undone; however, the 
actions can only be undone in the reverse order in which they were performed.

When redoing undone cut, copy, or paste operations, the actions can only be 
redone in the reverse order in which they were undone, which means that the 
last undone action will be the first one to be redone.

Any action (editing operation which includes add, delete, move, modify) 
performed after performing Undo will clear the Redo feature, and the undone 
operation cannot be redone. 

Procedure 3-9   Cut or Copy an Object

1 Select the object on your workspace that you want to cut or copy.

2 Select Edit > Cut (or press the Ctrl+X short-cut keys after the object has been 
selected) to remove the selected supported object to the Windows clipboard,

Or

Select Edit > Copy (or press the Ctrl+C short-cut keys after the object has been 
selected) to copy the selected supported object to the Windows clipboard.

End of Procedure 3-9

Procedure 3-10   Paste an Object

1 Select Edit > Paste (or press the Ctrl+V short-cut keys after the objects have been 
selected) to copy the object back from the clipboard into the workspace.

End of Procedure 3-10
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Procedure 3-11   Undo Editing Operations

1 Select Edit > Undo (or press the Ctrl+Z short-cut keys) to undo the previous 
editing operation. Only the following actions can be undone:

• Adding a unit (includes OPFAC and organization), device, or association 
(includes intra OPFAC link, inter OPFAC link, satellite link, broadcast network, 
relationship and circuit) from the palette or library.

• Moving a unit, device, association, or any group of these objects in the 
workspace.

• Deleting a unit, device, association, or any group of these objects in the 
workspace or using Scenario Builder treeview.

• Modifying attributes on devices; all attribute changes made while the Edit 
Attributes dialog box is open will be considered a single action.

End of Procedure 3-11

Procedure 3-12   Redo Editing Operations

1 Select Edit > Redo (or press the Ctrl+Y short-cut keys) to redo the last undone 
operation. The actions can only be redone in the reverse order in which they were 
undone, which means that the last undone action will be the first one to be redone.

End of Procedure 3-12

Creating Custom Models with Device Creator

In addition to using the built-in model objects provided by JCSS and creating 
derived models, you can create your own new device models using the Device 
Creator. Device Creator allows you to create several different types of network 
components, including routers, bridges, hubs, workstations, switches, LANs, 
and vendor devices. Models created with Device Creator have the following 
characteristics:

• They can be easily configured for specialized needs and then integrated into 
a network model.

• They support inheritance, so that changes to the original (parent) model can 
automatically affect all models derived from it.
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Procedure 3-13   Create a Device Model

1 Choose Topology > Create Custom Device Model. The Create Custom Device 
dialog box displays. This dialog box presents a treeview of the different device 
categories.

Figure 3-12   Selecting a Device Category for a New Device Model

2 Select the desired device category in the upper window. A corresponding list of 
parameters will immediately display in the lower window.

3 Set each parameter’s value appropriately in the lower window.

4 Select the model list from the Destination palette drop-down list in which you want 
the new device model to reside.

5 After you have specified all the required parameters for the desired model and 
selected a model list, click the Create As button to create the model. A dialog box 
displays prompting you to name your new device model.

6 Name your new device model. Once you have done so, your new device model 
displays in the model list you specified.

End of Procedure 3-13
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Opening Node Models in Modeler

If you have an OPNET Modeler license, you can easily open node models in 
Modeler via JCSS.

Note—For derived models, you must open the parent instead.

Procedure 3-14   Open a Node Model in Modeler

1 Double-click on a node model. The Open Node Editor message dialog displays.

Figure 3-13   Open Node Editor Message Dialog
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2 Click OK. OPNET Modeler launches and displays the node model.

Note—Modeler will not launch if you do not have a license for it.

Figure 3-14   Opening a Node Model in OPNET Modeler

3 Consult the documentation for OPNET Modeler for instructions on using Modeler 
with node models.

End of Procedure 3-14

Connecting Device Models

Connect communications devices. There are many different kinds of links in 
JCSS available from a variety of object palettes. Most links are available on the 
NETWARS_Standard_Models or NETWARS_Links palettes.
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Internal Connectivity Links

Internal Connectivity Links connect devices to other devices within the same 
OPFAC, and define actual physical links that show the specific type of 
connectivity; they are drawn as black solid lines.

Procedure 3-15   Link Devices via Object Palette

1 From the object palette drop-down menu, select the desired link palette.

Figure 3-15   Adding Links to OPFAC Devices via Object Palette

2 Select desired link icon.

3 Left-click endpoint 1 (device) to identify it as the source, and then left-click on 
endpoint 2 (device) to identify it as the destination.

4 Right-click to exit Device Creation mode.

End of Procedure 3-15
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Deploying Links

Quickly define valid links between devices using a wizard-like feature, instead 
of creating links using an object palette.

Procedure 3-16   Deploy a Link

1 Select two devices (in the workspace or the Network Browser) and then select 
Topology > > Link Operations > Deploy Link.  

2 If more than one device is present in an OPFAC, the Select Devices dialog box 
displays. Select the desired devices to connect and then click Next.

Figure 3-16   Select Devices dialog box

If a selected OPFAC has only one device, then the device is selected by default 
and the Select Devices dialog box is skipped. If the OPFAC doesn’t have a device, 
an error is flagged.

This feature will be only applicable to the fixed nodes (only wired ports will be 
considered for selection).

The best default link available and a list of the other applicable link types displays.

Figure 3-17   Select Link dialog box

A series of the most common default bandwidths for the selected link type is also 
provided as well as the first available ports applicable to the chosen link as default 
ports. 

3 Use the default values or select the desired values from the drop-down lists in the 
Select Link dialog box.
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4 When you create a satellite, external, or radio link, instead of providing long link 
names like SIPRNET_Router-GCCS_COP, JCSS supports the use of a System 
Link Designator (SLD) name. SLDs follow an eight-character alphanumeric code 
to identify the transmission systems that they connect.

If you want to specify the SLD codes that will make up the SLD Name for this link, 
click Next. The Edit SLD Name dialog box displays.

Figure 3-18   Edit SLD Name dialog box

4.1 To specify the SLD Name, choose a System/Link Type, From User, and To 
User from the drop-down lists and then enter a System Number and Number 
of Channels Per System. The full SLD Name will then be generated 
automatically based on what you have entered.

4.2 Click OK to complete the SLD creation, or click Cancel to cancel the process. 
The Select Link dialog box re-displays.

5 Click Finish. An inter-OPFAC link or internal link will be created with the 
user-defined attributes between the two devices, depending on whether the 
selected devices are within one OPFAC or different OPFACs.

End of Procedure 3-16

Deploying Satellite Links

JCSS supports two types of satellite links—bentpipe and broadcast links.

To create a bentpipe satellite link, the scenario must contain two earth terminals 
that are the endpoints of the satellite link and a home satellite through which the 
earth terminals communicate.

To create a generic broadcast satellite (GBS) link, the scenario must contain an 
earth terminal to act as one endpoint of the satellite link and a satellite to act as 
the other endpoint.
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Procedure 3-17   Deploy a Satellite Link

1 Select two OPFACs or devices and then select Topology > Link Operations > 
Deploy Link (or press <Ctrl> + L.) 

Figure 3-19   Selecting Satellites for Link Deployment

2 If more than one device is present in an OPFAC, the Select Devices dialog box 
displays. Select the desired devices to connect and then click Next.

Figure 3-20   Select Devices dialog box

If a selected OPFAC has only one device, then the device will be selected by 
default and the Select Devices dialog box will be skipped. If the OPFAC doesn’t 
have a device, an error will be flagged.
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The Satellite Bent Pipe Link Deployment dialog box displays.

Figure 3-21   Satellite Bent Pipe Link Deployment dialog box ~ Basic

The Basic tab displays the default Link Name, and allows you to select the 
Home Satellite which provides the available frequencies. The Help 
Diagram tab displays a diagram which explains the function of this dialog 
box. The Help FAQs tab lists helpful answers to frequently asked questions.

3 If you click the Advanced Tab, the following screen displays.

Figure 3-22   Satellite Bent Pipe Link Deployment dialog box ~ Advanced

Based on the frequencies provided by the chosen Home Satellite, this screen 
allows you to configure the frequencies uplink and downlink (in each direction) to 
establish a satellite link between the two selected satellite terminals.

The fields of this screen are pre-populated for you with the best available default 
link.
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4 If you are creating a GBS link, the Satellite Link Attributes dialog box displays 
(instead of the Satellite Bent Pipe Link Deployment dialog box shown previously in 
this procedure.)

Figure 3-23   Defining Satellite Link Attributes (GBS)
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5 Use the default values or select the desired values, and then click OK. The newly 
deployed satellite link displays in the workspace.

Figure 3-24   Deploying Satellite Links

After you have deployed a satellite link, you can create a TSSP circuit by selecting 
exactly two objects (devices or OPFACs) and configuring the circuit via the TSSP 
Group Config (Circuit Deployment) dialog box.

Note—The process for configuring multiplexer circuits is the same as the process 
for configuring TSSP circuits. You can create a multiplexer circuit by selecting 
exactly two devices and configuring the circuit via the Circuit Deployment dialog 
box. Select Topology > Configuration Utilities > Multiplexer > Configure 
Multiplexer Circuits. Shortcut keys are also provided for launching the Circuit 
Deployment dialog box for multiplexer circuits. Simply press Ctrl + Alt + M.
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6 Select Topology > Configuration Utilities > TSSP > Configure TSSP 
Groups (Circuits). The TSSP Group Config (Circuit Deployment) dialog box 
displays.

Figure 3-25   TSSP Group Config (Circuit Deployment) dialog box

Note—Shortcut keys are provided for launching the Circuit Deployment dialog box 
for TSSP circuits. SImply press Ctrl + Alt + T.

7 Use the default values provided on the Create Circuit tab in the TSSP Group Config 
(Circuit Deployment) dialog box (or select the desired values), and then click OK.

A message box displays to tell you that the circuit was successfully created.

8 Click Create Another to re-display the TSSP Group Config (Circuit Deployment) 
dialog box, or click Done to close the dialog box.

Figure 3-26   Successfully Created Circuit message box

End of Procedure 3-17
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Verifying Device Connectivity

Verify that devices are connected properly.  

Procedure 3-18   Verify a Link

1 Select Topology > Link Operations > Verify Links, or click the Verify Link 
Consistency button. Inconsistent links (e.g., links not connected to the right ports 
on the end points of the link) will be marked with a red X in the workspace.

Figure 3-27   Inconsistent Links

In addition, the results of the link consistency check will be displayed in the 
Scenario Link Consistency dialog box. 

Figure 3-28   Link Errors and Failure Reasons Display

2 The Scenario Link Consistency dialog box lists the link errors and failure reason. 
Troubleshooting solutions are provided, where possible in the text of the failure 
reason.

Note—In most cases, one or more of the link's attributes may be the source of the 
failure. In the Attributes dialog box, carefully review the attributes. Pay particular 
attention to the model, port assignments, and data rate.

End of Procedure 3-18

Save As Link Type

You can save inter-OPFAC links to a new link.

Procedure 3-19   Saving As Link Type

1 Right-click on a link in the workspace, and select Save As Link Type. 
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2 The status bar at the bottom left corner of the Scenario Builder window displays the 
following message, “New Link type ‘<selected link name>’ saved.”

End of Procedure 3-19

Defining Planning Links

Set placeholders for the connectivity links that will be created based on the 
subscriber requirements. These links can have organizations or OPFACs as 
terminating points, and show the anticipated bandwidth. Planning links are 
drawn as green dashed lines. Planning links cannot be used for discrete event 
simulation and capacity planning analyses.

Procedure 3-20   Add Planning Links via Object Palette 

1 From the object palette drop-down menu, select the NETWARS_Links palette. 

2 Select the Planning Link icon.

3 Left-click endpoint 1 (OPFAC, organization) to identify it as the source, and then 
left-click on endpoint 2 (OPFAC, organization) to identify it as the destination.

Figure 3-29   Planning Links Drawn as Green Dashed Lines

End of Procedure 3-20
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Defining External Connectivity Links

Connect OPFAC devices to devices in other OPFACs. These links define actual 
physical links that show the specific type of connectivity. Organizations are not 
valid terminating points for connectivity links. External links are drawn as green 
solid lines and show the actual bandwidth.

Procedure 3-21   Add External Connectivity Links via Object Palette 

1 From the object palette drop-down menu, select the 
NETWARS_Standard_Models or NETWARS_Links palette. 

2 Select the desired link icon (10BaseT, T3, wire point-to-point, etc.).

3 Left-click endpoint 1 (OPFAC) to identify it as the source, and then left-click on 
endpoint 2 (OPFAC) to identify it as the destination.

Figure 3-30   External Links Drawn as Green Solid Lines

End of Procedure 3-21

Table 3-1   Planning Links vs. Connectivity Links

Planning Link Connectivity Link

High level link Actual physical link

Shows general connectivity Shows the specific type of connectivity

Shows anticipated bandwidth Shows actual bandwidth

Can connect organizations and OPFACs Can only connect OPFACs

Drawn as dashed green line Drawn as solid green line
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Defining Broadcast Networks

Connect radio system devices that are tuned to the same frequency and/or 
belong to the same frequency hop group. Only OPFACs can be included as 
members of a broadcast network. Broadcast networks are drawn as a broadcast 
network object with members connected by blue links.

Procedure 3-22   Add Broadcast Networks via Object Palette 

1 From the object palette drop-down menu, select NETWARS_Links palette.

Figure 3-31   Broadcast Network Object Palette Icons

2 Click the nw_bcast_network icon and drop it to the desired location. 

3 Click the nw_bcast_network_attachment.

4 Left-click on an OPFAC to be added, and then left-click the nw_bcast_network 
icon on the workspace to add the member to the network.

Figure 3-32   Broadcast Network

End of Procedure 3-22
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Procedure 3-23   Deploy Broadcast Networks via the Topology Menu

1 Select the source and destination OPFACs or organizations in the workspace.

2 Select Topology > Deploy Broadcast Network (or press Ctrl + Shift + B). The 
Network Attributes dialog box displays. 

Figure 3-33   Defining Broadcast Network Radio Attributes

3 Type a name for the broadcast network in the Network Name field.

4 On the Radio Attributes tab, enter the desired attributes for default frequency, 
channel bandwidth, and data rate.
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5 On the Choose Devices tab, select devices for the corresponding OPFACs or 
organizations.

Figure 3-34   Defining Broadcast Network Devices
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6 On the Optimization Attributes tab, enter the desired attributes for possible 
capacities, and target and maximum utilization.

Figure 3-35   Defining Broadcast Network Optimization Attributes

6.1 Possible Capacities table: Specifies all of the capacities that the optimization 
engine can use when mutating solutions. For example, if there are two 
capacities specified, then the engine will be able to set either of them as the 
suggested capacity for this network. The Capacity column is where the 
capacity is specified. The Status column is used to mark the “original” capacity 
and the “current” capacity (or “Orig/Current” if the current capacity is also the 
original capacity.)

6.2 Insert Row button: To add a new capacity, click this button and type the new 
capacity into the Capacity column of the new row.  

6.3 Delete Row button: To remove a capacity, select a cell in the row and click 
this button.

6.4 Target Utilization: Specifies the target utilization to be achieved on this 
network. The default value is to use the global values specified in the Capacity 
Optimization Settings dialog. You can override this just on this network by 
specifying a new value.
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6.5 Maximum Utilization: Specifies the maximum utilization that is allowed on this 
network. The default maximum utilization is set to use the global values 
specified in the Capacity Optimization Settings dialog. You can override this 
just on this network by specifying a new value.

7 Click OK to create the newly defined broadcast network.

End of Procedure 3-23

Verifying Link Consistency

Verify that links are connected consistently. This feature is identical to Device 
Connectivity covered in the Verifying Device Connectivity section in this manual. 
Clicking the Verify Link Consistency button prompts JCSS to simultaneously 
check all links (external, internal, etc.) in the scenario.
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Configuring Utility Nodes

Utility nodes contain information/attributes pertaining to multiple nodes in the 
scenario. They provide a convenient way of configuring information that is 
conceptually shared. 

The Circuit Deployment Wizard provides step-by-step guidance for configuring 
Promina utility nodes. 

Procedure 3-24   Configure Promina Devices

1 Select Topology > Deploy Circuit to start the wizard. You must select at least two 
compatible circuit devices or OPFACs that contain circuit devices; otherwise, an 
error will be prompted and the wizard is terminated.

The Circuit Deployment Wizard dialog box displays.

Figure 3-36   Circuit Deployment Wizard Ports Tab

Note—Click the Help button for information on the current dialog box, and the 
Cancel button at any time to terminate the wizard.

2 On the Ports tab, specify the ports for the selected source and destination Promina 
devices in the scenario. 
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3 On the CCSD tab, configure the CCSD codes for the Promina circuit.

Figure 3-37   Circuit Deployment Wizard CCSD Tab

4 On the Attributes tab, configure the circuit’s attribute values.

Figure 3-38   Circuit Deployment Wizard Attributes Tab
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The following attributes can be set for the Promina circuit:

• Call priority – Specify the range and value for call priority.

• Preempt priority – Specify the range and value for pre-empt priority.

• Terestrial routing – Do not care leaves the attribute set to the default value

• Encryption routing – Do not care leaves the attribute set to the default value

• Fiber routing – Do not care leaves the attribute set to the default value.

• Call type – A permanent call will be set up at the beginning of simulation and 
never torn down; a demand call will be set up whenever demanded by the 
connected end devices and torn down if inactive.

• Direction – The direction of the circuit; some ports can only receive and some 
only send. Dual represents a full duplex circuit.

5 Click the OK button to complete the Promina circuit configuration and deploy the 
circuit. 

End of Procedure 3-24

Reviewing the Requirements Matrix

Answer a series of questions designed to help identify the requirements for a 
particular organization or OPFAC. Each new organization and OPFAC added to 
the project contains these default questions. The questions, which can be 
modified or deleted, are divided into five functional areas:

• Voice Services
• Data Services
• VTC Services
• Message Services
• Joint Digital Network

The collaborative planning features of JCSS allow lead planners to designate 
portions of the planning process/topology building to subordinate planners. To 
assist the subordinate planner in completing the assigned tasks, the lead 
planner should provide background information on the scenario using the 
requirements matrix.

A filter in the upper-right of the requirements matrix controls the type of 
requirements that display—either approved or requested.

Approved Requirements:

• Filled by the upper-level planners
• Requirements specified on organizations and OPFACs
• Values are not aggregated
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Requested Requirements:

• Filled by the subordinate planners
• Requirements specified on organizations, OPFACs, and devices
• Values are aggregated from the lower up

Procedure 3-25   Provide Requirements Matrix Information

1 Right-click on the desired unit to open the shortcut menu, and then select Open 
Requirements Matrix. The Requirements Matrix dialog displays.

Figure 3-39   Answering Requirements Matrix Questions

2 Select either Approved or Requested in the Filter drop-down list in the upper-right 
of the Requirements Matrix to control the type of requirements that display.

3 Click the buttons below the table to view questions for each functional area.

4 Answer questions by clicking in the Answer cell and entering text in the dialog box 
that displays.

5 Click Close when complete.

End of Procedure 3-25

Defining Additional Scenarios

When a project is created, there is only one scenario (a ‘baseline’ scenario) in 
the project. You may want to define additional scenarios to use to define specific 
points in time in the project, such as pre-deployment, deployment, and 
execution. JCSS allows you to define additional scenarios by either creating a 
new blank scenario, or creating an exact duplicate of an existing scenario under 
a new name.

You can switch easily from one scenario to another by selecting from a menu of 
available scenarios in the project.
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A convenient way to manage all of the scenarios in a project is via the Manage 
Scenarios dialog box. Using this feature, you can view each scenario in the 
project and its status. Buttons and drop-down menus enable you to do the 
following:

• Add new scenarios,
• Duplicate scenarios,
• Delete scenarios,
• Run a simulation,
• Change the simulation duration,
• Delete results, and
• Reorder scenarios in the list.

Procedure 3-26   Create a New Scenario

1 Select Scenarios > New Scenario, or press <Ctrl>+<Shift>+<N>. 

2 Enter a name for the scenario in the New Scenario Name field, and then click OK.

Figure 3-40   Creating a New Scenario

The new scenario is blank and contains no data. The Scenario Builder indicates in 
the title bar the current open scenario.

End of Procedure 3-26

Procedure 3-27   Duplicate a Scenario

1 Select Scenarios > Duplicate Scenario, or press <Ctrl>+<Shift>+<D>. 

2 Enter a name for the scenario in the Duplicate Scenario Name field, and then click 
OK.

Figure 3-41   Duplicating a Scenario
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The new scenario is an exact copy of the current scenario, which can serve as the 
baseline scenario. The Scenario Builder indicates the current open scenario in the 
title bar.

End of Procedure 3-27

Procedure 3-28   Switch Between Scenarios

1 Select Scenarios > Switch To Scenario; a menu displays the current scenarios 
in the project. A black bullet indicates the current scenario open in the Scenario 
Builder.

2 Select the name of the scenario that you want to display.

End of Procedure 3-28

Procedure 3-29   Manage Scenarios

1 Select Scenarios > Manage Scenarios.The Manage Scenarios dialog box 
displays.

Figure 3-42   Manage Scenarios dialog box

2 Click in each table cell to edit its contents. Brackets indicate a change to the 
scenario is requested, and will be applied when you click OK. 

• #: Changes the order of the scenarios in the table. 

• Scenario Name: Lists the name of each scenario. 

• Saved: Shows if a scenario is saved or unsaved. Clicking within a cell also lets 
you delete a scenario. 

• Results: Shows the state of the results of each scenario simulation. 
“Uncollected” means that a probe file exists, but you have not run a simulation. 
“Out of date” means that the set of chosen results, simulation configuration, or 
network model has changed since the results file was created. 

• Sim Duration: Specifies the length of time to run the simulation. Use it with the 
Time Units column. 

• Time Units: Specifies the time units that apply to the simulation exam: seconds, 
minutes, hours, days, or weeks. Used with the Sim Duration column.
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3 If you want to save the project under a new name, type the name in the Project 
Name field. This is similar to the File > Save Project As... feature. 

4 If you want to delete a scenario from the project, select it in the list and then click 
Delete.

5 If you want to delete results from a scenario, select it in the list and then click 
Discard Results. 

6 If you want to run a simulation and collect the specified statistics for a scenario, 
select it in the list and then click Collect Results.

7 Click OK to close the Manage Scenarios dialog box, and run any simulations that 
are waiting. 

8 Click Cancel to close the Manage Scenarios dialog box without making changes. 

End of Procedure 3-29

Configuring Protocols

The Protocols menu contains operations related to the various protocols 
supported in the standard and specialized model libraries. The protocols are not 
documented in this manual; please refer to the OPNET documentation listed for 
each menu option below (consult the IT Guru documentation set, available via 
Help > Documentation > IT Guru Documentation):

Table 3-2   Protocols Menu Items

Menu Item Description Reference

Applications Adds ACE application models to 
the existing network and 
configures application traffic.

Model User’s Guide 

Servers Manages server models. Model User’s Guide

Mainframes Manages mainframe models. Model User’s Guide

TCP Configures TCP. Model User’s Guide

IP Configures IP addresses, dynamic 
routing protocols, type of service 
characteristics for conversation 
pair traffic, autonomous system 
numbers on routers, and ping 
traffic. 

Model User’s Guide 

Link16 Configures/assigns Time Slot 
Blocks (TSBs) on terminals in the 
network.

Model User’s Guide
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IPv6 Configures IPv6 addresses, 
routing protocols, interface status, 
and runs readiness assessment 
and migration planner. 

Model User’s Guide 

BGP Configures BGP start time, 
autonomous system numbers, and 
route re-distribution from other 
protocols into BGP. 

Model User’s Guide 

EIGRP Configures EIGRP start time and 
route re-distribution from other 
protocols into EIGRP. 

Model User’s Guide 

IGRP Configures IGRP start time and 
route re-distribution from other 
protocols into IGRP. 

Model User’s Guide 

IS-IS Configures interface metrics, 
interface circuit types, system 
types, metric styles, and SPF 
calculation parameters.

Model User’s Guide 

OSPF Configures interface cost, OSPF 
start time, areas, and route 
re-distribution.

Model User’s Guide 

RIP Configures RIP start time and 
route re-distribution from other 
protocols into RIP. 

Model User’s Guide 

MPLS Configures MPLS. Model User’s Guide

LDP Enables/disables LDP protocol 
status on all/selected routers.

RSVP Enables/disables RSVP protocol 
status across connected interfaces 
on all/selected links.

Model User’s Guide 

ATM Configures over-subscription on a 
per-service class basis for all or 
selected nodes in the network.  

Model User’s Guide 

Frame Relay Configures PVCs between nodes 
in the network. 

Model User’s Guide 

Ethernet Configures Ethernet. Model User’s Guide

FDDI Configures FDDI. Model User’s Guide

VLAN Configures virtual LANs (VLANs) 
for selected nodes and links.

Model User’s Guide 

Table 3-2   Protocols Menu Items

Menu Item Description Reference
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Visualizing Protocol Configuration

To determine which routing protocols are running on your network, run the 
routing protocol visualization feature.

Procedure 3-30   Run a Routing Protocol Visualization

1 Select View > Visualize Protocol Configuration > (option).

Control the display of protocol configuration using the following options:

• IP Interface Status – Shows whether the connected interface is active or 
shutdown. A green up arrow indicates that interface is active whereas a red down 
arrow indicates that the interface is shutdown.

• IP Routing Domains – Shows the routing protocols that are configured on the 
router interfaces.

• IP Address Types – Shows the IP address types on the network by color, along 
with a legend to explain the color-coding.

• IP QoS Configuration – Shows the IP QoS configuration on the links. 

• IP Security Configuration – Shows the packet filtering security configured on 
the links.

• IP Tunnel Configuration – Shows the router tunneling configured on the links.

• BGP Peers – Shows the BGP peering (neighbor) relationships in the network. 
EBGP confederation peers are shown in dark green, EBGP peers are shown in 
blue, all other colors indicate IBGP peers. You can view the tool tip of each 
peering visualization for more information about the peers. For networks using 
route reflection, the visualization also indicates if a router is a reflector or a client.

• OSPF Area Configuration – Shows the OSPF areas configured on the router 
interfaces.

• ATM Routing Domains – Shows which ATM routing protocols that are 
configured on the switch ports.

• VLAN Configuration – Shows the VLANs configured in the network. 

STP Applies STP visualization to the 
current scenario. 

MANET Configures MANET. DSR Model User’s Guide

UMTS Configures UMTS. Model User’s Guide

Wireless LAN Configures Wireless LAN. Model User’s Guide

Table 3-2   Protocols Menu Items

Menu Item Description Reference
JCSS/Release 7.0 UM-3-43



3—Topology Building JCSS User’s Manual
• Clear Visualization – Removes all protocol configuration visualizations from the 
workspace.

Figure 3-43   Viewing IP QoS Configuration on Links

End of Procedure 3-30
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Viewing a Terrain Profile

The JCSS license includes a license for the Terrain Modeling Module GUI 
(TMMGUI). The terrain profile feature is always available in JCSS if the Terrain 
Data is available.

Use this feature to visualize the physics of a radio link by displaying a 
cross-section of the path between a transmitter and receiver, as well as an 
optional plot of signal strength variations along that path.

JCSS supports the following terrain data formats:

• DTED Level 0,
• DTED Level 1,
• 15-minute DEM data,
• 2-arc-second DEM data, and
• 1-degree-DEM data.

Procedure 3-31   View a Terrain Profile

1 Select Topology > Terrain > View Terrain Profile.

2 In the workspace, click on the location of the transmitter, and then click on the 
location of the receiver. The View Terrain Profile dialog box opens, showing the 
terrain profile for the specified path.

Figure 3-44   Viewing a Terrain Profile
JCSS/Release 7.0 UM-3-45



3—Topology Building JCSS User’s Manual
3 Customize the signal path to match your situation by changing any of the 
parameters and clicking the Recompute button.

4 Control what is shown in the profile by selecting or deselecting any of the check 
boxes to the right of the profile. From the pull-down menus, select the propagation 
model and parameter set to use for the path loss calculations.

5 Click the Add to Graph button to generate the signal strength plot.

6 To see any messages generated by the path loss calculations, click the Signal 
Strength Diagnostics button.

7 To add additional plots to the graph, change the conguration as desired (for 
example, different frequency, propagation model, or parameter set) and click the 
Add to Graph button.

End of Procedure 3-31

Enabling Line-of-Sight (LOS) Connectivity and Range

Indicate whether a particular radio transmitter could communicate successfully 
with a radio receiver at a given location. This option requires terrain data; it 
computes LOS connectivity between multiple OPFACs and LOS range for 
selected OPFACs.

Procedure 3-32   Enable LOS Connectivity and Range

1 Select View > Show LOS > LOS Settings. The LOS Settings dialog box displays.

Figure 3-45   Enabling LOS Connectivity and Range

Measured in meters, the value in the LOS Range Radius field specifies the size of 
the circle that may appear around an organization or OPFAC. It is a nominal range, 
and this single setting affects all LOS Visualization in the editor. For reference, 
10,000 meters is the typical transmission limit when terrain elevation data is not 
available. Transmitters assisted by elevation could transmit many times this 
distance. 
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The value in the LOS Terrain Shading Density field specifies the number of 
samples to check within the LOS Range Radius for determining LOS Terrain 
Effects Shading. More samples give a more accurate representation, but can also 
slow display as more information must be considered to update Terrain Effects 
Shading.

2 Select the Enable LOS Connectivity checkbox if you want to allow the editor to 
display LOS Connectivity links when selected for organizations or OPFACs. This 
options is enabled by default. 

LOS Connectivity is a thick, dashed, double-headed arrow. The color of the arrow 
indicates whether the two objects could communicate. Connectivity is bi-directional 
and independent of specific device characteristics. Connectivity is based on signal 
loss between the transmitter and receiver positions as determined by the 
Longley-Rice signal propagation model. 

LOS Connectivity exists between OPFACs. Organizations that contain OPFACs 
may display LOS Connectivity links when they are collapsed. Enabling LOS 
Connectivity on an organization enables LOS Connectivity on all subordinate 
organizations and OPFACs. An organization that contains no subordinate 
OPFACs will not display any LOS Connectivity links (it would not be able to join a 
broadcast network or connect via point-to-point links either). 

LOS Connectivity works through broadcast networks and point-to-point 
transmission links to determine all of the OPFACs to which a selected Organization 
or OPFAC could possibly communicate and designates the state of that 
communication link. LOS Connectivity links are attributes of their end points. The 
existence of LOS Connectivity links indicates that one or both of the objects at an 
end of the link has LOS Connectivity enabled. LOS Connectivity links disappear 
when neither end point has LOS Connectivity enabled, in either the top-level 
organization or any subordinate organization or OPFAC. LOS Connectivity link 
coloration is automatically updated when either end point moves for any reason, 
including mouse dragging, attribute changes, or animation, to reflect the LOS 
closure state at the new location.

3 Select the Enable Scenario LOS Range checkbox if you want to allow the editor 
to display LOS Range circles and Terrain Effects Shading for selected 
organizations or OPFACs. This option is enabled by default. 

LOS Range is a circle of a fixed radius placed around the organization or OPFAC 
in question. The circle represents a ground distance and is used as a reference for 
the distance from a particular object. There is a single setting for the range that 
pertains to all LOS Ranges displayed in the entire scenario. The LOS Range is a 
nominal indicator, having no direct connection to a particular device's transmission 
range. The LOS Range does indicate the limit of the area within which locations 
may be sampled for determining LOS Terrain Shading. 

Any organization or OPFAC may display an LOS Range without regard for the type 
of device contained within or even if an OPFAC or device is contained. The LOS 
range simply indicates a distance.

4 Select the Enable LOS Terrain Shading checkbox if you want to allow the editor 
to display Terrain Effects Shading if LOS Range is also enabled. This option is 
disabled by default.
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Terrain Effects Shading indicates portions of the area around an organization or 
OPFAC where a radio receiver could not receive a hypothetical transmission from 
the object. 

Since the LOS Range defines the limit of the area where LOS Terrain Shading is 
tested, LOS Range must be enabled to view LOS Terrain Shading. Disabling LOS 
Range on an object also disables LOS Terrain Shading. 

Like LOS Range, LOS Terrain Shading does not indicate anything about the 
specific OPFACs or devices contained within the designated object. It simply 
indicates that if the object contained a radio transmitter, that radio transmitter would 
or would not be able to communicate with a generic radio device at a particular 
location. 

LOS Terrain Shading works by testing for LOS closure at a predetermined number 
of sample locations evenly spaced throughout the circle formed by the LOS Range. 
You can select the number of samples to take. 

LOS Terrain Shading updates when the selected object moves for any reason, 
whether by mouse dragging, attribute change, or animation.

5 Click OK to accept the settings in the LOS Settings dialog box.

End of Procedure 3-32
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Displaying Line-of-Sight (LOS) Connectivity

Indicate whether the two objects could communicate. Connectivity is 
bi-directional and independent of specific device characteristics. Connectivity is 
based on signal loss between the transmitter and receiver positions as 
determined by the Longley-Rice signal propagation model.

Procedure 3-33   Display LOS Connectivity

1 Select OPFAC(s) of interest in workspace. To use this feature, a broadcast network 
must connect the OPFACs.

2 Right-click to open the shortcut menu, and then select Enable LOS Connectivity.

3 Invalid connections are indicated by red links, clear connections are indicated by 
green links.

Figure 3-46   Displaying LOS Connectivity

End of Procedure 3-33
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Displaying Line-of-Sight (LOS) Range

Indicate LOS range, a circle of fixed radius placed around the organization or 
OPFAC in question. The circle represents a ground distance and is used as a 
reference for the distance from a particular object.

Procedure 3-34   Display LOS Range

1 Select unit(s) of interest in workspace.

2 Right-click to open the shortcut menu, and then select Enable Object LOS Range.

3 LOS Range displays as a circle around the unit.

Figure 3-47   Displaying LOS Range

End of Procedure 3-34
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Displaying Terrain Effects Shading

Indicate portions of an area around a unit where a radio receiver could not 
receive a hypothetical transmission from the object.

Procedure 3-35   Display Terrain Effect Shading

1 Make sure Enable LOS Terrain Shading is selecting in the LOS Settings dialog 
box.

2 After enabling LOS Range for an object, right-click to open the shortcut menu.

3 Select Display Terrain Effects.

Figure 3-48   Displaying Terrain Effects Shading

End of Procedure 3-35
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4 Traffic Specification

Creating IERs

Specify the conveyance of messages/data through your communications 
system. IERs are Information Exchange Requirements.

Procedure 4-1   Create an IER

1 Right-click on an OPFAC to open the shortcut menu, and then select View Traffic; 
the Edit IER Parameters table displays.

Figure 4-1   Specifying IER Attributes

2 Click the Insert button. A new IER containing default settings is created in row 1.

3 Modify IER attributes by clicking in the desired cell and entering new parameters:

3.1 IER ID – Identifies an IER in the database. IDs for IERs that are created by a 
user start with the prefix USER, as not to conflict with IER IDs in the database. 
Background IERs start with the prefix BKGD. 

3.2 Classification – Specifies the security classification of an IER. The security 
classification of an IER is one criterion that determines the system element 
through which the IER is transmitted. 

3.3 Perishability – Specifies the time in seconds for which the IER is alive. 

3.4 Priority – Determines the number of transmission retries and the wait time 
between successive retries. 

3.5 Traffic – Specifies the type of IER traffic. 

3.6 Average Size – Indicates the average size of the IER in bytes.

3.7 Equipment – Specifies the system element on which the IER can be 
transmitted. 

3.8 Consumer – Identifies OPFAC consumer of the traffic.

3.9 Distribution Type – Indicates the inter-arrival distribution for the IERs.

3.10 Interarrival – Represents the time, in seconds, between IER firings.
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3.11 Start Time – Identifies the time, in seconds, in which the IER will begin firing 
after a simulation begins.

3.12 Stop Time – Identifies the time, in seconds, in which the IER will stop firing 
after the simulation begins.

3.13 Producer Device and Consumer Device – Indicates the devices transmitting 
and receiving the IER.

3.14 Transport Protocol – Identifies the protocol used for transporting the IER.

3.15 Relationships – Defines start and stop times for specific relationship types. 
IERs will only be allowed to pass if they fall within the active time window of 
the infrastructure.

4 Click OK.

Note—IERs can also be imported from the IER Database or text files. Consult the 
JCSS Technical Reference Manual for import instructions.

End of Procedure 4-1

Creating Threads

Threads are groups of IERs that are fired in segments. For example, an OPFAC 
can fire an IER to their platoon leader OPFAC, which in turn can fire an IER to 
the company commander OPFAC. Threads can be configured to fire traffic only 
when certain conditions are met.

Procedure 4-2   Create a Thread

1 Right-click on the OPFAC to be the starting point of the thread, and then select 
View Threads from the shortcut menu; the View Threads dialog box displays.

2 Click Define Thread to open the Define Thread dialog box. Set the desired 
attributes for the thread in the dialog box fields. 

3 Click Define Segment to add the desired IERs and define their attributes and 
segment information. 

4 Click OK; a summary of the newly created thread displays in the View Threads 
dialog box. 
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5 Click OK to save the thread.

Note—Threads can also be imported from outside COTS applications. Consult the 
JCSS Technical Reference Manual for import instructions.

Figure 4-2   Creating Threads

End of Procedure 4-2
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Creating Relationships

Define the association or connection between two or more OPFACs. 
Relationships can be used to visualize command structure and to facilitate 
traffic flow for JCSS’ capacity planning features.

Procedure 4-3   Create a Relationship

1 Select the OPFACs that you want to associate in the workspace.

2 Select Topology > Deploy Relationship. The Relationship Attributes dialog box 
displays.

Figure 4-3   Creating a Relationship

3 Select the type of relationship from the Relationship Type drop-down menu. 

4 Select the source OPFAC from the Source drop-down menu.

5 Click OK. The relationship between the selected OPFACs is created.

End of Procedure 4-3
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Converting Applications into Flows

Automatically convert standard OPNET application and profile configuration 
parameters into IP flow objects. This process turns the discrete application 
traffic into background flows for use in simulation or traffic visualization. After 
creating the flows, the application and profile configuration objects are cleared 
of all traffic information in order to prevent duplication of traffic during simulation. 
It is recommended that a duplicate scenario be created prior to using this feature 
if you want to keep the application and profile configurations for later use.

Procedure 4-4   Convert Applications into Flows

1 Select Traffic > Convert Traffic > Applications to Flows. The Convert 
Applications to Flows dialog box displays.

Figure 4-4   Converting Applications into Flows

2 Enter flow generation parameters as needed, and then click OK.

2.1 Enter the start time of the flow objects in the Start-Time (Hours, Minutes, 
Seconds) fields. This will effectively act to truncate all flow traffic recorded 
prior to the value provided. The flow’s bps and pps values during this time will 
be set to 0.0. The input values must be integers.

2.2 Enter the duration of the simulated calculation window in the Duration 
(Length, Units) field. This method corresponds to the Capacity Planning 
Optimization feature. The input value must be an integer.

Flows will be aggregated for any source/destination pair. Thus, any number of 
applications that contribute to traffic between a given client and server will be 
aggregated into two flows with one for each direction of travel.

End of Procedure 4-4
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Deploying Traffic Using the Traffic Wizard

Deploying traffic between a single client-server pair within JCSS can be 
performed easily via the Traffic Wizard. Select two OPFACs, and then the 
Traffic Wizard walks you through selecting the end devices (and the profile to 
deploy between the client and server devices), and deploying a link between 
them.

Procedure 4-5   Deploy Traffic using the Traffic Wizard

1 Select Traffic > Traffic Wizard (or press <Ctrl> + W) to launch the Traffic 
Wizard.

Figure 4-5   Traffic Wizard

Note—The Traffic Wizard will launch only if you have selected two OPFACs 
between which the traffic is to be deployed.

2 Select a profile to deploy, specify client and server devices, and then click OK.

End of Procedure 4-5
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5 Capacity Planning

Evaluating a Network

Evaluate a scenario in its current state during the specified time interval or 
intervals. This is different from running an optimization in that it evaluates the 
scenario with the current capacities for links and networks. It does not mutate 
the capacities of the links and networks. It routes the demands through the links 
and broadcast networks, and provides a summary of the scenario’s current 
condition.

The Evaluation Settings dialog box allows you to set the number of time steps, 
length of each time step, and the start time. For example, if you know that your 
peak usage occurs from 9 A.M. to noon, you could evaluate that time period by 
setting number of time steps to 3, length of time step to 1 hour, and start time to 
9 hours 0 minutes 0 seconds.

Procedure 5-1   Perform a Network Evaluation

Evaluate Current
Network

1 Select Capacity Planning > Evaluate or click the Evaluate Current Network 
button. 

2 Set parameters as needed for the evaluation.

Figure 5-1   Setting Evaluation Parameters

2.1 Number of Time Steps: A Capacity Planning Evaluation can be done for 
multiple time steps by setting this value to an integer greater than one.  
Reports will be created for the evaluation at each time step as well as reports 
reflecting results over the entire time of evaluation. Must be an integer greater 
than zero.

2.2 Length and Units of Time Steps: The length and units of the time steps used 
in the evaluation. The value selected must be an integer greater than zero. 
Units can be seconds, minutes, hours, days or weeks.

2.3 Start Time: The start time used for the evaluation in hours, minutes and 
seconds. All values must be integers greater than or equal to 0.
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3 To provide finer control of the evaluation process, click the Advanced Parameters 
button (optional).

Figure 5-2   Setting Advanced Evaluation Parameters

4 Edit advanced parameters as needed, and then click OK.

4.1 Naming Convention: The names of all the devices and links that are in the 
report will use the naming convention selected here.

4.2 Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports.

4.3 Include Individual Link Traffic Reports: If this option is selected, individual 
reports will be included in the web report for each link in the scenario.  The 
reports will include all the traffic going directly over the link as well as any 
circuits that are going over the link.  The reports will take longer to generate if 
this option is selected.

4.4 Include Individual Circuit Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each routable circuit.  
The reports will include all the traffic using the circuit.  The reports may take 
longer to generate if this option is selected.

4.5 Enable IP Load Balancing: If this checkbox is selected, IP load balancing will 
be done during the evaluation so that traffic will use multiple equal hop length 
paths. 

4.6 Number of Balanced Routes to Report: If IP load balancing is selected, then 
the number of balanced routes to report can be selected.  The entry must be 
an integer greater than 0.  This number of route reports will be reported in the 
web reports

4.7 Allow ATM SVCs to be Setup: If this checkbox is selected, ATM SVCs will 
be setup during the evaluation when applicable.
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5 After specifying the evaluation parameters, click the Run button in the Evaluation 
Settings dialog box to start the evaluation.

6 After the evaluation is complete, the evaluation web reports launch automatically.

End of Procedure 5-1

Optimizing a Network

Given a network and its demands, the optimization process provides 
suggestions for optimal link and network capacities. If a link is over-utilized, 
optimization will suggest an alternate capacity that will support the demands 
and keep the cost of the link down to the required minimum. If a link is 
under-utilized, optimization will decrease the capacity for that link.

Before a capacity optimization is run, specify parameters that control how 
optimal solutions for the scenario are computed. Use the optimization 
parameters to search for an optimal solution with the smallest objective value 
cost. The Simulated Annealing Engine will try different configurations, 
increasing or decreasing the size of the links and networks, computing an 
objective cost for each.

Procedure 5-2   Perform a Network Capacity Optimization

Start Capacity
Optimization

1 Click the Start Capacity Optimization button or select Capacity Planning > 
Capacity Optimization > Start Optimization. The Capacity Optimization Settings 
dialog box displays.

Figure 5-3   Setting Optimization Parameters

2 Specify the start time and the duration for the optimization process.

3 Specify Voice and Data Target and Maximum Utilizations.
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4 Specify weights for Link Goals, Traffic Load, and Performance by setting the 
corresponding slider bar.

5 To provide finer control of the optimization process, click the Advanced 
Parameters button (optional).

Figure 5-4   Setting Advanced Optimization Parameters

6 Edit advanced parameters as needed, and then click OK.

Note—Consult the JCSS Technical Reference Manual for descriptions of all 
optimization settings and advanced optimization settings.

7 After specifying the optimization parameters, click the Run button in the Capacity 
Optimization Settings dialog box to start the optimization.

JCSS computes the routes for the demands and then starts the optimization.

End of Procedure 5-2

Specifying Alternate Link Capacities

Suggest alternate link capacities that might improve the ability of the network 
architecture to support the mission plan. These settings are used to feed the 
optimization engine with an avenue of recourse; if capacity is exhausted in one 
link, available capacity alternatives are suggested during the optimization 
process. 

Procedure 5-3   Specify Alternate Link Capacities

1 Right-click on a link and choose Edit NETWARS Attributes.

2 From the Link Attributes dialog box, click the Optimization Attributes button.
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3 Specify possible alternate capacities for the link, and then click OK.

Figure 5-5   Specifying Alternate Link Capacities

3.1 Possible Capacities table: Use to specify all of the capacities that the 
optimization engine can use when mutating solutions. For example, if there 
are two capacities specified, then the engine will be able to set either of them 
as the suggested capacity for this link.

The first column in the table is the total capacity (voice capacity plus data 
capacity), the second is the number of voice channels, and the third is the 
voice channel size. Note that total capacity must be greater than or equal to 
the number of voice channels times the voice channel size. Anything left over 
is the capacity that is available for data. Any of these parameters can be 
modified by clicking on the appropriate cell and typing in a new value.

The fourth column in the table is status. This column is used to mark the 
“original” capacity and the “current” capacity (or “orig/current” if the current 
capacity is also the original capacity).  

3.2 To add a new capacity, click Insert Row and then type the values into the 
cells of the new row.

3.3 Select a cell in the row to remove, and then click Delete Row to remove the 
capacity.

3.4 Target Utilization fields: Use to specify the voice and data target utilization to 
be achieved on this link. The default value is to use the global values specified 
in the Capacity Optimization Settings dialog box. You can override this just on 
this link by specifying a new value.

3.5 Maximum Utilization fields: Use to specify the voice and data maximum 
utilization that is allowed on this link. When you run the optimization with an 
emphasis on minimizing capacity (Link Goals slider < 4) or getting the 
utilization close to the target (Link Goals slider > 7), a new capacity is 
considered only if it will keep the link utilization under the specified maximum 
utilization.
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The default maximum utilization is set to use the global values specified in the 
Capacity Optimization Settings dialog box. You can override this just on this 
link by specifying a new value.

End of Procedure 5-3

Displaying Web Reports

Display web reports after a Capacity Planning Evaluation or Optimization. Web 
reports include the following reports for the overall evaluation: Executive 
Summary, Overall Peak Results, and Overall Average Results.

Additionally there are a group of reports which are generated for each time step: 
Traffic Report, Link Utilization Report, Link Subscription Report, Promina Circuit 
Report, CellXpress & ATM Circuit Report, Frame Relay Circuit Report, and an 
FCC-100 Circuit Report.

There are also Route Reports for each routed circuit and traffic demand, and 
Unroutable Reports for each unroutable circuit and traffic demand. Each 
Individual Link also has a group of tables that show the circuit and traffic 
demands which flow over it specifically.  

Procedure 5-4   Display Web Reports

1 To open a report, select the desired option from the Capacity Planning > Reports 
menu.

2 To change settings used in the web reports, select Capacity Planning > Reports> 
Settings.

Figure 5-6   Changing Web Report Settings
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3 Edit web report settings as needed, and then click OK.

3.1 Naming Convention: The names of all the devices and links that are in the 
report will use the naming convention selected here.

3.2 Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports.

3.3 Include Individual Link Traffic Reports: If this option is selected, individual 
reports will be included in the web report for each link in the scenario.  The 
reports will include all the traffic going directly over the link as well as any 
circuits that are going over the link.  The reports will take longer to generate if 
this option is selected.

3.4 Include Individual Circuit Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each routable circuit.  
The reports will include all the traffic using the circuit.  The reports may take 
longer to generate if this option is selected.

3.5 Number of Balanced Routes to Report: If IP load balancing is selected, then 
the number of balanced routes to report can be selected.  The entry must be 
an integer greater than 0.  This number of route reports will be reported in the 
web reports

End of Procedure 5-4

Saving Optimization Settings

Save the results of multiple optimization runs and the effects of changing certain 
parameters on the optimization; saved optimization runs can be compared.

Procedure 5-5   Save Optimization Settings

1 When the optimization is complete, save the results of the optimization by selecting 
Capacity Planning > Capacity Optimization > Save Optimization As.

2 Enter a name for the optimization run in the Save Optimization As dialog box, and 
then click OK.

Figure 5-7   Saving Optimization Settings

End of Procedure 5-5
JCSS/Release 7.0 UM-5-7



5—Capacity Planning JCSS User’s Manual
Managing Optimization Results

Compare saved optimization results as follows:

• Compare Parameters
• Compare Bandwidths

Procedure 5-6   Compare Optimization Results

1 Select Capacity Planning > Capacity Optimization > Manage Optimization 
Results. The Manage Capacity Optimization Results dialog box displays.

Figure 5-8   Managing Optimization Results
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2 Select the row numbers for the optimizations to compare and click either Compare 
Parameters or Compare Bandwidths to compare the optimizations.

Figure 5-9   Comparing Parameters

Figure 5-10   Comparing Bandwidths

End of Procedure 5-6
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Examining Top Solutions

Review top solutions and use the one you think is best.

Procedure 5-7   Examine Top Solutions

1 Specify the number of solutions the engine must keep track of in the Advanced 
Parameters of the Configuration Settings dialog box before the optimization is run.

2 When the optimization is complete, select Capacity Planning > Capacity 
Optimization > Examine Top Solutions.

3 Use the Currently Visible Solution drop-down menu to view a desired solution.

Figure 5-11   Examining Top Solutions

End of Procedure 5-7
UM-5-10 JCSS/Release 7.0



JCSS User’s Manual 6—Simulation Execution
6 Simulation Execution

Choosing Device and Link Statistics

Choose statistics on devices, external links, and internal links to be collected 
during simulation.

Procedure 6-1   Specify Statistics for Collection During Simulation

1 Select the object in the workspace for which the statistics will be collected.

2 Select DES > Choose Individual Statistics or select Choose Individual 
Statistics from the shortcut menu.

3 Select statistics to be collected during a simulation by clicking the checkboxes next 
to the desired statistics.

4 Right-click on the individual statistic and select Change Collection Mode, as 
needed. The all values mode will collect all of the data points in a simulation for a 
particular statistic. In the bucket mode, a representative data point (e.g., max 
value, etc.) will be collected to represent all the other data points in that bucket.

Figure 6-1   Choosing Device Statistics
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5 Click OK.

End of Procedure 6-1

Procedure 6-2   Specify Advanced Statistics for Collection During Simulation

1 Select the object in the workspace for which the statistics will be collected.

2 Select DES > Choose Statistics (Advanced). The Probe Model window displays 
advanced statistics on devices, inter-OPFAC, and intra-OPFAC links to be 
collected during simulation.

Figure 6-2   Choosing Advanced Device Statistics

End of Procedure 6-2
UM-6-2 JCSS/Release 7.0



JCSS User’s Manual 6—Simulation Execution
Running a Simulation

Evaluate your scenario’s network performance through the use of simulations.  
Simulations model communications behavior of the network and provide detail 
down to the packet and protocol level. You can choose to use a “simple” 
configuration mode or a “detailed” configuration mode. The simple mode 
presents fewer controls to configure, thereby simplifying the configuration and 
execution of DES.

Procedure 6-3   Perform a Network Simulation

Configure/Run
Simulation

1) Click the Configure/Run Simulation button or select DES > Configure/Run 
Discrete Event Simulation. The Configure/Run DES dialog box displays in simple 
mode. This dialog box has a set of commonly used dialog box controls, and two 
tabbed windows to configure DES inputs (Global attributes) and outputs (Reports.)

Figure 6-3   Setting Simulation Parameters - Simple Mode

1 Set the duration of the simulation in the Duration field. The units are specified by 
the pull-down menu next to this field. This sets the duration simulation preference.

2 Set the number of values collected for each statistic in the Values per statistic 
field. This sets the num_collect_values simulation preference. 
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3 Set the simulation attributes in the Global attributes window to the desired values. 
The Attribute table displays all simulation attributes declared by models involved in 
the scenario to be simulated and the values assigned to each attribute. Click on a 
question mark icon to display information about the corresponding attribute. Click 
on an Attribute Value to change it.

2) Click the Reports tab to select Statistics and Service Level Agreement (SLA) 
reports for the simulation to collect. Reports are predefined sets of statistic probes.

Figure 6-4   Setting Simulation Parameters - Reports

• Record the following date and time in results label—Displays the date and 
time associated with the network model, if any.

• Generate web report for simulation results checkbox—When selected, 
simulation results are included in a report viewed from a web browser. 

• Minimum number of decimal places for statistics in output reports 
counter—Sets the number of decimal places to use in number formatting. If you 
expect values to differ in minute amounts, use a large number of decimal places. 

• Number of entries displayed in 'Top N' reports counter—Sets the value of 'N'. 

• Statistics reports pane—Specifies the statistics reports to generate at the end 
of the simulation. Each selected value is added to the reports simulation 
preference. 

• Define Statistics Report button—Opens a dialog box used to define new 
statistics reports. 
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• SLAs pane—Specifies the SLA reports to generate at the end of the simulation. 
Each selected value is added to the sla_reports simulation preference. 

• Define SLA Report button—Opens a dialog box used to define new SLA reports.

3) Click Detailed if you want to open the dialog box in “detailed” mode. Detailed mode 
lets you configure all the parameters of DES, some of which are not available in 
simple mode. This dialog box contains a treeview of information categories for 
configuring different aspects of the simulation.

Figure 6-5   Setting Simulation Parameters - Detailed Mode

• Set the attributes on the Common page to the desired values. Changes affect 
only the current scenario.

• If you need to set additional attributes, go to the appropriate pages by selecting 
them in the tree view and setting the desired values. For further details on the 
individual fields that can be configured for each page, refer to the JCSS 
Technical Reference Manual.

4 Click Apply to save the current settings and keep the dialog box open, or click Run 
to save the current settings, close the dialog box, and run the simulation 
immediately. The simulation runs for set duration, displaying frequent progress 
updates in the viewing window until completion.

5 Upon completion, a summary of results displays.

Figure 6-6   Summary of Results
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If fatal errors are present in the scenario when a simulation is run, the simulation 
process quits. A pop-up dialog box will instruct you to access the Scenario 
Conversion Log file, which details errors that correspond to incorrect scenario 
elements requiring adjustment prior to a successful simulation. You can display the 
log file, which resides on the same level as the nt.m file, using any text editor tools.

When the simulation is complete, a file named <project name>-<phase name>.ov 
is saved in the same location as the nt.m file. This file will be used for results 
analysis.

Note—Before a simulation is executed, certain parameters that influence the 
behavior of the simulation can be configured. These parameters, which specify the 
behavior of traffic during simulation, are configured through the Priority Table, 
Decision Table, and System Element Table. Consult the JCSS Technical 
Reference Manual for instructions.

End of Procedure 6-3

Viewing the Simulation Log File

Display a list of errors compiled during the simulation. JCSS encounters two 
major classes of errors. The first class is in building the scenario, including 
capacity planning analysis. The second class is in executing a discrete event 
simulation. The following section applies to the discrete event simulation only. 
Please refer to section 8 for Scenario Builder error handling.

Procedure 6-4   Display DES Simulation Log File

1 After a simulation execution, select DES > Open DES Log to display the log of 
errors and significant simulation events maintained by JCSS during discrete event 
simulation. The DES log is written to a tab-delimited ASCII file. Because there may 
be many events in a DES log, a Log Viewer is provided so that you can view only 
those events of interest to you.

Figure 6-7   Viewing the Simulation Log
UM-6-6 JCSS/Release 7.0



JCSS User’s Manual 6—Simulation Execution
2 Click the module tabs to move between modules for which logs are available. The 
Miscellaneous tab gives you access to session and error logs.

3 Use the treeview provided in the Logs pane to select from the available logs 
associated with the selected module. 

4 For text-based logs, the Selected Log pane displays a single pane with simple text 
descriptions of events. For event-based logs, it displays two panes. The first pane 
displays sections of the log. Select the section(s) that you want displayed. The 
second pane displays the log data, one event per row.

4.1 Click and drag the vertical lines in the header row to resize columns.

4.2 Click on an entry in the Message column to open an edit pad containing the 
full text of the message.

5 Check (or uncheck) the Display logs for current scenario only checkbox to 
specify whether the treeview (in the Logs pane) should list all logs or only those for 
the current scenario.

6 Click the Open Advanced Viewer button to open an advanced log viewer that 
provides additional capabilities using a menu bar. The additional capabilities 
include: changing which column is used to color-code a log entry, changing which 
columns are visible or filterable, saving the current viewer settings, and exporting 
the log information to a file.

7 Click the Close button to close the Log Viewer dialog box.

End of Procedure 6-4

Viewing Web Reports

Generates a Web report that contains one or more of the reports available in the 
Results Viewer.

Procedure 6-5   Generate Web Report

1 From the Select Tables for Web Report dialog box, choose the results you want to 
include in the Web report.

2 Select the Include Network Diagram checkbox if you want the web report to include 
a graphic of the network topology.

3 Click Generate.

4 Select a directory for the HTML files and click OK. 

5 The web report is created and opens in the default Web browser.

End of Procedure 6-5
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7 Results Analysis

Viewing Measures of Performance

View the results of a simulation, represented by Measures of Performance 
(MOPs). MOPs are statistics, displayed in graphs, which reflect the ability of 
selected communications equipment to satisfactorily send and/or receive 
information.

Procedure 7-1   Display MOP Graphs

1 Select DES > Results > View Results; the View Results window displays. You can 
also right-click in the workspace and select View Results from the shortcut menu, 
or click the View Results toolbar button.     

2 Select the checkbox(es) of desired MOP(s) in the treeview. A graphical preview of 
the MOP(s) displays in the Preview pane. Preview mode does not allow graph 
interaction.

3 Use the graph options/filters drop-down menus to display the MOP graphs in a 
variety of layouts.

Figure 7-1   Viewing MOPs
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4 To view the graph(s) in full detail, click Show. 

Figure 7-2   Sample Filtered Graphs

End of Procedure 7-1

Interacting with MOP Graphs

Modify the look and style of a graph or manipulate properties as outlined below.

Procedure 7-2   Change MOP Graph View Properties

1 Examine statistics by placing the cursor over a segment of the trace; a tool tip 
displays the coordinates of the graph.

Figure 7-3   Example Graph Tool Tip

2 Zoom in on any segment of the trace by drawing a small box around the segment 
with the cursor.
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Figure 7-4   Zooming In on a Trace

3 Resize the graph window as needed.

4 Right-click on the inner panel of an MOP graph to open a shortcut menu that allows 
manipulation of graph properties. Right-click on the outer panel of an MOP graph 
opens a shortcut menu with different graph-manipulation options.

 

Figure 7-5   Accessing Graph Panel Shortcut Menus

End of Procedure 7-2

Finding Top Statistics

Sort statistics and find bottlenecks by using the Find Top Statistics feature.
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Procedure 7-3   Find Top Statistics

1 Select Results > Find Top Statistics from the main menu.

2 Select the statistic of interest from the Select Statistic for Top Results dialog box.

Figure 7-6   Selecting a Statistic of Interest

3 Click the Find Top Statistics button. The top objects display in the Top Objects 
dialog box.

Figure 7-7   Finding Top Results

End of Procedure 7-3
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8 Error Handling

Technical Support

Log Files

JCSS encounters two major classes of errors. The first class is in building the 
scenario including capacity planning analysis. The second class is in executing 
a discrete event simulation. The following section applies to the Scenario 
Builder only.

Sometimes program crashes cannot be consistently reproduced. Without a 
reproducible set of steps to follow, fixing them is difficult. In such cases, to help 
identify and fix these crashes, the following information is needed from the 
software installation where the error occurred:

• The OPNET error log file – This file is called err_log and is located in the 
<Scenario_Builder>\op_admin folder. This file contains the function 
calls stacks recorded by NetBiz when there is a recoverable error or a 
program crash. Error messages are always appended to this file.

• The JCSS function log file – This file is called nw_function_log and is 
located in the <Scenario_Builder>\op_admin folder. This file contains 
the list of functions that were executed just before the program crashed. This 
file also contains the following version information:

— JCSS software (major release and update)

— NetBiz software (major release and patch level)

— Windows Operating System

The contents of this file are overwritten when there is a program crash.

• The JCSS error log file – This file is called nw_message_log.txt and is 
located in the <Scenario_Builder>\op_admin folder. This file contains 
error messages that were recorded by JCSS during program execution.

• The project, scenario, and associated files in use when the error occurred.

All of this information automatically packages into a zip file. The zip file is called 
exception_data-<time_stamp>.zip. <time_stamp> is the time at which 
the crash occurred. In the event of a program crash, you should send this zip 
file to NETWARS Technical Support. The information contained in this zip file 
will help the developers in debugging the problem.

Contact Information

For issues regarding using the software, please contact us either at 
netwars@opnet.com or at 240.497.3000 x2699. Note that email and voice mail 
to the NETWARS Help Desk are checked once a day, Monday through Friday.
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Glossary

B

Broadcast Networks Network of radio system devices that are tuned to same 
frequency and belong to same frequency hop group. All the radio devices 
belonging to same broadcast network hear transmission by one radio device.

C

Connectivity Links Created based on the subscriber requirements. 
Connectivity links are different from planning links in that they are connected to 
actual devices instead of organizations.

Courses of Action Define specific conditions or situations, such as when an 
enemy uses chemical, biological, or nuclear weapons. It is important to note that 
time phases and courses of action perform exactly the same way in JCSS.  You 
simply have the option of calling your scenario subdivisions time phases or 
courses of action.

I

IERs The acronym for Information Exchange Requirement. IERs are the 
primary traffic representation in JCSS. A relationship between OPFACs is 
needed to create an IER.

K

Kernel Procedure An OPNET provided function that supports the 
development of protocols and algorithms. All Kernel Procedures start with op_.

M

Mainframe Characterization Module MCE is an optional module that allows 
you to import measured performance data, and analyze it to create workloads 
suitable for the mainframe models. 

Mod_Dirs An environment attribute that tells OPNET which folders to look in 
for locating files. The mod_dirs attribute is found under Edit > Preferences.

MOPs The acronym for Measures of Performance. Analyze the results of a 
simulation session to produce a set of MOPs. Manipulate the set of MOPs using 
data filters and produce graphs of the data. The MOPs explain various 
communication burdens, latency, and other critical performance measures 
associated with communication infrastructures.
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O

Online Documentation An Adobe Acrobat manual that has information about 
the OPNET models, kernel procedures, modeling concepts etc. The manual can 
be launched from Modeler by choosing the Online Documentation option under 
the Help menu.

OPFACs The acronym for Operational Facility. OPFACs are the fundamental 
building blocks of JCSS. They are collections of communications devices that 
are assigned to military units, which are used to construct Organizations.

Organizations Hierarchies of military units. An organization is a container that 
can hold OPFACs and other organizations (sub-organizations).

P

Planning Links Placeholders for the connectivity links that will be created 
based on the subscriber requirements. These links can have organizations or 
OPFACs as terminating points, and show the anticipated bandwidth. Planning 
links cannot be used for discrete even simulation and capacity planning 
analyses.

Process Registry It is a model-wide registry where any process mode can 
register itself and any process model can obtain information about other 
process models that are registered. For a list of kernel procedures available for 
using the process registry, refer to the OPNET Modeler online documentation, 
General Model’s Manual, OPNET Model Support chapter, Process Registry 
section (consult the IT Guru documentation set, available via Help > 
Documentation > IT Guru Documentation).

Projects Projects are containers for scenarios, time phases or courses of 
action. Related scenarios can be grouped under one project. JCSS enables you 
to open and work with multiple projects simultaneously.

S

Scenarios Scenarios are instances of C4I communications architectures that 
consist of associated OPFACs and Organizations, Information Exchange 
Requirements (IERs) and links. Scenarios are stored as part of a project created 
within the Scenario Builder. Thus, projects act as containers for scenarios and 
a single project may include several scenarios, i.e., instances of C4I 
communications architecture.

Server Characterization Editor SCE is an optional module that allows you to 
import server performance information for analysis of the processes and 
applications, and characterization into workloads used as the basis for 
simulation modeling.
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Simulation Engine The COTS OPNET Modeler tool. It processes the 
simulation events and provides the output to the Scenario Builder.

U

Unified Modeling Language UML is an industry standard set of graphical 
notations to describe a system from an object-oriented approach. Diagrams 
include a set of static notations (class diagrams, use case diagrams) and a set 
of dynamic notations (state diagrams and sequence diagrams). UML does not 
require a specific design process and does not require implementation with any 
specific object-oriented languages or tools. The state diagrams, for example, 
are consistent with OPNET Modeler’s Process Model notation.
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