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JCSS Technical Reference Manual Identification
Identification

Document Identification

Document Title: JCSS Technical Reference Manual
Version: 7.0 Final

Software Identification

Product Name: JCSS
Product Release: 7.0

Documentation Conventions

This documentation uses specific formatting and typographic conventions to present the 
following types of information:

• Objects, examples, and system I/O

• Object hierarchies

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in standard Courier typeface:

C:\Netwars\User_Data\Projects

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier typeface:

/* determine the object ID of packet’s creation module */ 
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<NETWARS path>\Scenario_Builder\op_admin\err_log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:

Edit > Preferences > Advanced
JCSS/Release 7.0 TR-FM-iii
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Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press the 
<button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you should press 
the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps.
TR-FM-iv JCSS/Release 7.0



JCSS Technical Reference Manual Document Revision History
Document Revision History

Release Date
Product 
Version Chapter Description of Change

November 30, 2007 7.0 Final All

3

- Began introduction of product name change to JCSS from 
NETWARS.

- Updated figure 3-33 Logical View Selection dialog box, and 
removed refs to Frame Relay, VTC, etc., in this section.

- Added list of filters to Show Network Browser section, and 
added note that Modeler will not launch from JCSS without a 
Modeler license.

- Updated LOS Settings section to include info about altitude and 
altitude unit conversion.

- Modified Deploy Circuits section to clarify that sample procedure 
is for generic circuit deployment and works for all circuits.

- Added figures to Deploy Broadcast Network and Deploy 
Relationship sections.

- Updated Results Browser figure to reflect addition of Capacity 
Planning tables/graphs for Link-16 (and UHF DAMA).

October 26, 2007 2007 
Final

3

Appendix C

- Added sentence to “Show Logical Views” that Network Layer 
Filters shown are only those which apply to the deployed network.

- Removed “Animate” section, and updated “Show Time 
Controller” section.

- Added section on opening a Node Model using Modeler, and 
setting related preferences (pgs 3-32 and 3-33.)

- Added “Save As Link Type” section (pg 3-100.)

Added and/or updated figures:
- 3-78 Free-Text Questions Report
- 3-120 through 3-122 UHF DAMA SATCOM Wizard
- 3-127 through 3-130 Multiplexer Circuit Deployment
- 3-131 View Multiplexer Circuits dialog box
- 3-132 Enable Cut-Through on Selected Devices
- 3-133 Disable Cut-Through on Selected Devices

- Removed “Scenario Treeview” references.

- Added Topology > Deploy Broadcast Network, and Topology > 
Deploy Relationship.

- Added “Undo/Redo Template Units” to “Editing the Contents of 
the Library” section.

October 10, 2007 2007 
Draft

2

3

- Updated figures to reflect change to NETWARS v2007.

Updated figures:
- 3-8 updated models list
- 3-21 updated dialog box options layout
- 3-32 updated groups list
JCSS/Release 7.0 TR-FM-v



Document Revision History JCSS Technical Reference Manual
4

Appendix B

Appendix C

- 3-34 added UHF DAMA and Link 16 options and updated dialog 
box layout
- 3-44 and 3-47 updated file path
- 3-56 updated dialog box layout
- 3-61 added Preview button
- 3-63 and 3-64 changed ‘phases’ to ‘scenarios’
- 3-88 and 3-89 updated list of tables
- 3-90 added Load button
- 3-93 updated dialog box layout
- 3-94 updated list order
- 3-99 updated list of pre-configured OPFACs and organizations
- 3-179 added figure of Probe Model Window
- 3-181 updated list of attributes

Changes to View menu: 
- Added View > Background > Add CADRG/CIB Raster Catalog 
Directories
- Added View > Background > Add MrSID Image
- Added View > Circuits
- Added View > Wireless Domains
- Added View > Visualize Protocol Configuration > IP Address 
Types

Change to Scenarios menu:
- Removed Scenarios > Scenario Components submenu

Changes to Topology menu:
- Changed Topology > Import submenu to Topology > Import 
Topology
- Added Topology > Import Topology > Convert DCI to 
NETWARS Scenario
- Added Topology > Import Topology > From Configlets.
- Changed Topology > Model Assistant > View Error Log to 
Topology > Model Assistant > Open Error Log.
- Added Topology > Link Operations > Import Links from File.
- Added Topology > Deploy Circuit.
- Removed Topology > Configuration Utilities > Promina.
- Changed Topology > Terrain > Define Trajectory to Topology > 
Define Trajectory.

Change to Protocols menu:
- Added Protocols > IPv6 submenu.

Change to NetDoctor menu:
- Added NetDoctor > Configure/Run Trending
- Added NetDoctor > Open NetDoctor Log.

Change to DES menu:
- Changed DES > Panel Options submenu to DES > Panel 
Operations.

- Updated Figure 4-1 to reflect new toolbar icons in Icon 
Database.
- Added File > Manage Model Files submenu, and Edit > 
Preferences.

- Updated figures to reflect change to NETWARS v2007.

- Updated Figure C-1to reflect current list of pre-configured 
OPFACs and organizations in Library Treeview.

Release Date
Product 
Version Chapter Description of Change
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December 13, 2006 6.2 Final 2

3

4

- Removed refs to User’s Guides 1-4, since they are no longer 
built into the NETWARS software.

- Clarified use of Rules folders (pg TR-3-22).
- Removed unnecessary step (old step 2) from View > Set Area 
of Interest section.
- Removed reference to Map menu (changed to View > 
Background > Map Edit Mode).
- Added Topology > Define Trajectory.
- Updated Figure 3-151, Traffic Flows Import dialog box (now 
Figure 3-155), and accompanying text description.
- Removed ref to traffic_import_suppress_unrecognized_ 
sources_dialog preference from Unrecognized Traffic Assistant 
section.
- Removed Traffic > Specify Core/Edge Devices.
- Updated list of Capacity Planning web reports (pg TR-3-145).

- Updated instructions for accessing Icon Database and locating 
files.

December 8, 2006 6.2 Final 1

2

3

Appendix C

- Removed descriptions of editors that are not provided with 
standard NETWARS.

- Updated “Open Project” section to direct users to use the Project 
directory.
- Updated Figure 2-13 to reflect version 12.0.
- Updated Figure 2-19 and associated text to reflect new 
Preferences Editor.

- Removed duplicate step from “Edit > Preferences > Device 
Model Map > New” section, and added ref to specific directory.
- Updated figures 3-38, 3-79, 3-87, 3-88, 3-92, 3-170, 3-171, 
3-179, 3-180, and 3-181.
- Added “DES > IER Results” section.

- Updated refs from 11.5 to 12.0.

Release Date
Product 
Version Chapter Description of Change
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Document Revision History JCSS Technical Reference Manual
November 3, 2006 6.2 Final 3

Appendices
B, C, and D

- Provided updated figures: 3-1 (Scenario Builder with a project 
open); 3-3, 3-5, 3-7, and 3-33 (removed references to old 
UserGuide_SB_Scenario); 3-6 (removed Add Logical View 
button); 3-34 (removed Type of View drop-down list, and 
Re-use/Re-create options); 3-35 (added new Settings 
drop-down); 3-79 (names in CCSD Summary Report); 3-87 and 
3-88 (clearer); 3-101 (Library treeview changes); 3-113 (added 
Classification drop-down); 3-111, 3-117, 3-187, and 3-188 (reflect 
new toolbar buttons).

- Added new figures 3-36 and 3-37 for network showcase feature.

- Removed Map Menu (moved Map > Set Area of Interest to View 
> Set Area of Interest, moved Map > Background > <options> to 
View > Background > <options>, removed Map > Background > 
Add CADRG/CIB Raster catalog directories, moved and renamed 
Map > Background > Toggle Map Edit Mode to View > 
Background > Map Edit Mode, moved Map > LOS Settings to 
View > Show LOS > LOS Settings, moved Map > Clear LOS 
Ranges to View > Show LOS > Clear LOS Ranges, moved Map 
> Display LOS Legend to View > Show LOS > Display LOS 
Legend, moved Map > View OPFAC Distances to View > OPFAC 
Distances > View OPFAC Distances, moved Map > Remove 
OPFAC Distances to View > OPFAC Distances > Remove 
OPFAC Distances, removed Map > Define Trajectory, moved 
Map > Animate to Scenarios > Animate.)

- Added Topology > Configuration Utilities > UHF DAMA 
SATCOM and Topology > Configuration Utilities > Cut-through > 
<options>.

- Moved Terrain menu options to Topology menu.

- Added Ctrl+W shortcut keys to Traffic Wizard section.

- Updated NETWARS System Adminstrator’s Manual and moved 
to new Appendices in this manual.

Release Date
Product 
Version Chapter Description of Change
TR-FM-viii JCSS/Release 7.0



JCSS Technical Reference Manual Document Revision History
October 13, 2006 6.2 Draft 1

2

3

4 & 5

Glossary

- Removed references to the IER Editor.

- Updated System Editor and Sign-in figures to reflect version 6.2.
- Removed File > Open Editor and Open Editor dialog box.
- Added File > New Project, File > Open Project, File > Open 
Subordinate Query, File > New Other, File > Open Other, File > 
Manage Model Files, and File > Recent Projects.
- Added IER Database menu and options.
- Added Help > Show All Logs.

- Added File > Close, File > Page Setup, File > Print Graphs, and 
File > Manage Model Files.
- Removed File > Close Project and File > Close Subordinate 
Query.
- Added Edit > Save Object Selection Set, Edit > Load Object 
Selection Set, Edit > Edit Objects Using Template, and Edit > Edit 
Attribute Template.
- Replaced Advanced Preferences dialog box with new 
Preferences Editor dialog box.
- Added View > Show Logical Views, View > Show Network 
Topology, View > Show Network Showcase, View > Open 
Network Showcase Window, View > Demands, View > Paths, 
View > Annotations, View > Layout > Lay Out Nodes Interactively, 
View > Zoom > To Window, and View > Zoom > To All.
- Updated Edit Visualization Preferences dialog box.
- Changed View > Layout > Scale Selected Icons
to View > Layout > Scale Node Icons Interactively.
- Removed View > Network Views > Logical.
- Updated Scenario menu to reflect name change to Scenarios 
menu. Added Scenarios > Scenario Components, Scenarios > 
Reports > CCSD Summary, and Scenarios > Reports > SLD 
Summary.
- Added Protocols > Servers, Protocols > Mainframes, Protocols 
> TCP, Protocols > MPLS, Protocols > Ethernet, Protocols > 
FDDI, Protocols > MANET, Protocols > UMTS, and Protocols > 
Wireless LAN.
- Removed Topology > Import > Template OPFAC into Library 
from XML.
- Added DES > Choose Statistics (Advanced), DES > Expert 
Service Prediction, DES > Configure/Run Discrete Event 
Simulation (Advanced), DES > Restart Discrete Event 
Simulation, DES > Results > View Application Delay Tracking, 
and DES > Panel Operations > Reload Data Into All Panels.
- Removed DES > Results > Compare Results.
- Updated Choose Results dialog box.

- Removed IER Editor chapter (functionality now accessible via 
System Editor’s IER Database menu) and renumbered chapters.

- Removed references to the Scenario Conversion Module.

Release Date
Product 
Version Chapter Description of Change
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Document Revision History JCSS Technical Reference Manual
March 30, 2006 6.1 Final 3

Appendix A

- Updated Traffic Flow Preferences dialog box figure to reflect 
checkbox options design.
- Removed “Rename Scenarios “ feature from Manage Scenarios 
section.
- Added Import Scenario > TNAPS to XML.
- Removed Import Scenario > From Visio.
- Added shortcut keys for configuring/viewing TSSP circuits.
- Added Configuration Utilities > Multiplexer > Configure 
Multiplexer Circuits and View Multiplexer Circuits.
- Noted the default username and password for the IER database.

- Removed Multiplexer Utility Nodes section.

March 3, 2006 6.1 Draft 2

3

4

5

- Updated System Editor and Sign-in figures to reflect version 6.1.
- Added Edit > Preferences > Device Model Map > (options).
- Removed Help > Generate Support Info.
- Renamed Help > Error Log > View as Help > Error Log > Open.
- Renamed Help > Message Log > View as Help > Message Log 
> Open.
- Added Help > Session Log > (options).

- Updated “Deploying Satellite Links” section to reflect new 
tabbed design of Satellite Bent Pipe Link Deployment dialog box.
- Updated TSSP Circuit Deployment dialog box figure (and 
corresponding text description) to reflect new tabbed design.
- Updated View TSSP Circuits dialog box figure (and 
corresponding text description) to reflect new column names.
- Removed Traffic > Convert Traffic > Flows to IERs.

Added Edit > Preferences.

- Updated figure (and text) to reflect name change from “Icon 
Editor” to “Icon Database”, and new toolbar buttons.
- Added File > Exit.

Release Date
Product 
Version Chapter Description of Change
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November 14, 2005 5.2 Final Front material

2

3

Changed refs in Documentation Conventions section to be 
NETWARS-specific rather than OPNET-specific (i.e, changed 
<opnet_user_home>\... ref to <NETWARS 
path>\Scenario_Builder\...)

- Added statement (“Please contact NETWARS CM to register 
your license.”) to Starting License Manager section.
- Changed Express method description to “(Requires authorized 
access.)” in Adding a License section.
- Updated Task Tracking Workflow GUI figure.

- Updated Edit > Project Defaults > IER figure.
- Updated View > Visualize Link Loads > Color by Link Load 
figure.
- Updated View > Network Views > Logical figure.
- Added Map > Background > Add CADRG/CIB Raster catalog 
directories.
- Renamed Scenario > Scenario Documentation as Scenario > 
Set Scenario Documentation.
- Corrected ref to old command (Topology > Import > Subordinate 
Response) in Scenario > Import Scenario > Subordinate 
Response.
- Updated Object Palettes to include Tree view and reflect new 
icons.
- Updated Annotation Palette.
- Removed Topology > Link Operations > Deploy TSSP Groups.
- Added Deploying Satellite Links section.
- Added Topology > Configuration Utilities > TSSP > Configure 
TSSP Groups (Circuits.)
- Added Topology > Configuration Utilities > TSSP > View TSSP 
Group Configs (Circuits.)
- Updated Topology > Import Device Configuration Files.
- Removed Advanced Traffic Wizard.
- Updated Traffic Wizard figure.
- Removed Traffic > Convert Traffic > Link Loads to Flows.
- Removed Traffic > Convert Traffic > Open Conversion Log.
- Removed Traffic > Convert Traffic > Clear Conversion Log.
- Updated Terrain > Edit Parameter Sets figure.

Release Date
Product 
Version Chapter Description of Change
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Document Revision History JCSS Technical Reference Manual
October 10, 2005 5.2 Draft All

1

2

3
File menu

Edit menu

- Updated document footers and applicable screenshots to reflect 
new NETWARS version number.

- Added (optional) Server Characterization and Mainframe 
Characterization options to System Editor (File > Open Editor.)

- Added Edit > User Level options.
- Updated Figure 2-4 (Open Editor dialog box) to reflect addition 
of (optional) Server and Mainframe Characterization editors.
- Updated Figure 2-9 (Security Classifications dialog box) to 
reflect addition of Set Default button.
- Updated Figure 2-11 (Advanced Preferences dialog box) to 
reflect new prefs and correct CORE version in title bar.)
- Removed figure of License Manager Help dialog box (not 
necessary to document since Help changes with each version.)
- Added Previous Editor and Circulate Editors options to Windows 
menu.
- Added Help > Documentation > User’s Guides options.
- Removed references to ‘demands’.
- Updated File > Close Project to reflect that both the project and 
the Scenario Builder window close (instead of the project only.)
- Updated Figure 3-6 (Briefings dialog box) to reflect addition of 
Add Logical View button.
- Added Figure 3-7 (Print Preview dialog box.)
- Renamed File > Package as File > Package Project Files, and 
old File > Package submenu ‘Project Files’ as ‘Project’.
- Added File > Recent Projects (with submenu) to replace old list 
of recent projects.
- Removed File > Close Scenario Builder.
- Renamed File > Exit NETWARS as File > Exit.
- Renamed Edit > Select All in Subnet as Edit > Select All.
- Added Edit > Find Node/Link.
- Renamed Edit > Select as Edit > Group Selection/Action > 
Selection Filter
- Renamed Edit > Apply Action as Edit > Group Selection/Action 
> Action Filter
- Renamed Edit > Object Palette as Topology > Open Object 
Palette
- Renamed Edit > Annotation Palette as Topology > Open 
Annotation Palette
- Moved Edit > Device Model Map submenu to Edit > Preferences 
> Device Model Map.
- Added Edit > Preferences > Device Model Map > Open.
- Renamed Edit > Defaults > Device Model Map as Edit > 
Preferences > Device Model Map > Choose.
- Removed Edit > Defaults > Demands, Edit > Defaults > 
Bandwidth Requirements, and Edit > Defaults > Application 
Conversion.

Release Date
Product 
Version Chapter Description of Change
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View menu

Map menu

Scenario menu

- Added View > Show Scenario Treeview.
- Added View > Layout > Geographic Positioning.
- Added View > Layout > Layout Nodes Automatically (Balanced).
- Renamed & moved View > Edit Visualization Preferences to 
View > Layout > Edit Display Preferences.
- Renamed & moved View > Zoom In to View > Zoom > To 
Rectangle.
- Renamed & moved View > Zoom to Selection to View > Zoom 
> To Selection.
- Renamed & moved View > Zoom Out to View > Zoom > 
Unzoom.
- Renamed View > Redraw as View > Refresh Workspace.
- Removed View > Network Views > Organization Systems and 
View > Network Views > Device Systems.
- Renamed View > Network Views > Logical Views as View > 
Network Views > Logical.
- Renamed Figure 3-42 (View Filtering dialog box) as Logical 
View Selection dialog box & added detail to dialog box options.
- Renamed & moved View > Set View Properties to Map > 
Background > Set Properties.
- Added View > Visualize Protocol Configuration > IP Tunnel 
Configuration.
- Renamed Map > Set Area of Operations as Map > Set Area of 
Interest.
- Replaced Figure 3-45 (Set Area of Operations dialog box) with 
new Set Area of Interest dialog box.
- Updated Figure 3-46 (Setting background view properties) to 
reflect addition of Translucency column and Edit CADRG/CIB 
Properties button.
- Replaced Figure 3-47 (Set Area of Operations dialog box) with 
new Choose Border Map dialog box.
- Renamed Map > Background > Import Image as Map > 
Background > Add Image Map.
- Renamed Map > Background > Import Background Image as 
Map > Background > Add Image.
- Removed Map > Background > Import JMTK Data.
- Renamed Map > Background > Import MIF Data as Map > 
Background > Add MIF Map.
- Added Figure 3-50 (MIF Import Log dialog box.)
- Updated Figure 3-57 (Define Trajectory dialog box) to reflect 
changes.
- Added Figure 3-58 (Trajectory Segment Information dialog box.)
- Added Scenario > Manage Scenarios and Figure 3-64 (Manage 
Scenarios dialog box.)
- Removed Scenario > Remove Scenario.
- Renamed Scenario > Import as Scenario > Import Scenario.
- Renamed Scenario > Import > NETWARS Scenario as Scenario 
> Import Scenario > From NETWARS.

Release Date
Product 
Version Chapter Description of Change
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Topology menu

Traffic menu

- Renamed Scenario > Import > OPNET Modeler Scenario as 
Scenario > Import Scenario > From OPNET Modeler.
- Renamed Scenario > Import > Scenario from XML as Scenario 
> Import Scenario > From XML.
- Renamed Scenario > Import > Scenario from Visio XML as 
Scenario > Import Scenario > From Visio.
- Removed Scenario > Export > Export to HTML.
- Renamed Scenario > Export as Scenario > Export Scenario.
- Renamed Scenario > Export > Scenario to XML as Scenario > 
Export Scenario > To XML.
- Added Scenario > Export Scenario > To JNMS.
- Renamed Scenario > Export > Scenario to Visio XML as 
Scenario > Export Scenario > To Visio.
- Renamed Scenario > Summary Tables as Scenario > Reports.
- Renamed Scenario > View Task Organization Report as 
Scenario > Reports > Task Organization.
- Added Scenario > Reports > User-Defined Reports > Open Live 
Report Table and Scenario > Reports > User-Defined Reports > 
Generate Report from Template.
- Added Scenario > Generate Scenario Web Report and Scenario 
> Generate Scenario Bitmap.
- Added Figures 3-87 (Generate Scenario Web Report dialog 
box), 3-88 (Displaying Scenario Web Report in Web Browser), 
and 3-89 (Model Image Capture Preview dialog box.)

- Added Topology > Open Library Treeview and Figure 3-95 
(Library Treeview.)
- Renamed Topology > Device Creator as Topology > Create 
Custom Device Model.
- Renamed Topology > Import > Subordinate Response as 
Scenario > Import Scenario > Subordinate Response.
- Renamed Topology > Export > Subordinate Response as 
Scenario > Export Scenario > Subordinate Response.
- Added Topology > Link Operations > Deploy TSSP Groups and 
Figure 3-101 (TSSP Circuit Deployment.)
- Removed Topology > Link Operations > Redeploy Link.

- Added Traffic submenus for Traffic Wizard, IERs, Flows, 
Device/Link Loads, and Convert Traffic.
- Added descriptions of Traffic Wizards (Simple & Advanced.)
- Removed Traffic > Collector Import Settings and Traffic > 
Visualize submenus.
- Renamed Traffic > IER/Demand Import Options as Traffic > 
IERs > Set Import Options.
- Renamed Traffic > Specify Demands as Traffic > IERs > Specify 
IERs.
- Added Traffic > IERs > Import from IER Report.
- Renamed Traffic > Visualize > Export Traffic Report as Traffic > 
IERs > Export IER Report.
- Added Traffic > IERs > Export IERs to XML.
- Renamed Traffic > Import Flows > (options) as Traffic > Flows > 
Import > (options).
- Renamed Traffic > Create Traffic Flows as Traffic > Flows > 
Create Flows.
- Replaced Create Traffic Demands dialog box in Figure 3-132 
with Create IP Unicast Traffic Flows dialog box.

Release Date
Product 
Version Chapter Description of Change
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Protocols menu

NetDoctor menu

DES menu

Windows menu

Glossary

- Renamed Traffic > Visualize > Open Flows Browser as Traffic > 
Flows > Open Flows Browser.
- Renamed Traffic > Visualize > Export Traffic Flows as Traffic > 
Flows > Export to Spreadsheet.
- Updated Figure 3-139 (Export Traffic Flows dialog box.)
- Renamed Traffic > Import Device/Link Baseline Loads > 
(options) as Traffic > Device/Link Loads > Import > (options).
- Removed Traffic > Convert NETWARS Applications to 
Demands.
- Renamed Traffic > Convert Applications to Flows as Traffic > 
Convert Traffic > Applications to Flows.
- Updated Figure 3-140 (Convert Applications to Flows dialog 
box) to remove Time Step settings.
- Renamed Traffic > Convert Link Loads to Flows > Configure/ 
Convert as Traffic > Convert Traffic > Link Loads to Flows.
- Renamed Traffic > Convert Traffic Flows to NETWARS 
Demands as Traffic > Convert Traffic > Flows to IERs.
- Renamed Traffic > Convert Link Loads to Flows > Open 
Conversion Log as Traffic > Convert Traffic > Open Conversion 
Log.
- Renamed Traffic > Convert Link Loads to Flows > Clear 
Conversion Log as Traffic > Convert Traffic > Clear Conversion 
Log.
- Added Traffic > Generate Traffic Web Report.
- Renamed Traffic > Visualize > Visualization Aggregate Traffic 
Preferences as Traffic > Set Aggregate Traffic Preferences.
- Renamed Traffic > Collector Import Settings > Specify 
Core/Edge Devices as Traffic > Specify Core/Edge Devices.

- Added Protocols > LDP, Protocols > RSVP, Protocols > VLAN, 
and Protocols > STP.
- Removed Protocols > MPLS and Protocols > DPT.
- Updated Figure 3-149 (Terrain Data Directory Preferences 
dialog box) to reflect addition of Format drop-down list and 
support for terrain data type ‘OpenFlight’.
- Updated Figure 3-151 (Import Elevation Lines dialog box) to 
reflect reorganization of dialog box fields, etc..
- Updated Figure 3-153 (Evaluation Settings dialog box) to reflect 
reorganization of dialog box buttons.

- Added NetDoctor > Auto-Generate Report Template..., 
NetDoctor > Suppress Messages, NetDoctor > Rule 
Development..., and NetDoctor > Options.
- Removed NetDoctor > Security.

- Removed DES > Record Animation for Subnet.
- Added DES > Record Packet Flow Animation for Subnet and 
DES > Record Node Movement Animation for Subnet.
- Removed DES > Color Links by Utilization.
- Removed DES > Clear Link Visualization.
- Removed DES > Panel Operations > Export Panels > To HTML.

- Added Previous Editor and Circulate Editors options to Windows 
menu.

- Removed ‘Demands’ from Glossary.

Release Date
Product 
Version Chapter Description of Change
JCSS/Release 7.0 TR-FM-xv



Document Revision History JCSS Technical Reference Manual
April 1, 2005 5.1 Final Cover Changed release date to April 1, 2005, and removed OPNET 
contact info from Identification section.

March 21, 2005 5.1 Final 1

2

2 and 3

3

- Added ACE to ACE Whiteboard section.

- Added ACE option to System Editor (File > Open Editor.)

- Corrected definition of functional names in Edit > Preferences > 
Functional Profiles.

- Added View > Zoom to Selection and View > Layout options.
- Added Scenario > New/Duplicate/Previous/Next Scenario.
- Updated Figure 3-18 to reflect new button placement.

February 21, 2005 5.1 Final No changes.

February 7, 2005 5.1 Draft All Ported existing Word document (NETWARS v 4.2) into Adobe 
FrameMaker 7.1, and applied commercial OPNET product 
documentation style template to improve quality and update 
manual. Reformatted text as needed to fit new format and style. 

Content changes:

- Updated applicable screenshots to reflect new NETWARS 
version number.
- Added reference to ACE doc in chapter 1, and added ACE 
Whiteboard option to System Editor (File > Open Editor) and 
Scenario Builder (Traffic > Import Flows.)
- Removed Capacity Planning > Restore Link Colors and 
Capacity Planning > Show Link Legend.
- Removed Alternate Link Cost field from Capacity Optimization 
Settings Advanced Parameters dialog box.

Release Date
Product 
Version Chapter Description of Change
TR-FM-xvi JCSS/Release 7.0
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JCSS Technical Reference Manual 1—Introduction
1 Introduction

The JCSS Technical Reference Manual is a comprehensive reference and 
guide that covers all aspects of JCSS operation and use. It contains over 200 
figures that provide visual examples of the JCSS interfaces, step-by-step 
procedures, and other important JCSS features and concepts.

Organization of the chapter topics is menu-based, meaning topics are grouped 
and ordered according to the various menus and menu options available in the 
respective JCSS interfaces.

Editor Interfaces

The capabilities of the JCSS software are organized into separate editors:

• The System Editor,

• The Scenario Builder, and

• Other optional editors that require an extra license (To learn more about 
available editors, refer to the IT Guru documentation suite.)

System Editor

The System Editor acts as an entry point to the remaining editors. It allows you 
to access user and profile information as well as the task assistant interface.

Scenario Builder

The Scenario Builder allows you to build template OPFACs and organizations, 
define infrastructure and Information Exchange Requirements (IERs) between 
OPFACs and organizations, specify movement and geographical context for 
OPFACs and organizations, and run discrete event simulations for developed 
scenarios. You can open and work with multiple projects simultaneously, and 
easily cut, copy and paste supported objects (Organizations, OPFACs, devices, 
links, etc.) between them.

Additionally, the Scenario Builder provides you with the option of deploying a 
communications infrastructure using a top-down approach. More specifically, 
the Lead Planner sets up the planning view and sends the initial scenario to the 
Subordinate Planners. The Subordinate Planners modify their portion of the 
initial plan and then send it back to the Lead Planner who integrates them into 
a complete plan.
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The Scenario Builder allows you to optimize link and broadcast network 
capacities as well as traffic load. The optimization of the link and broadcast 
network capacities is implemented by changing the size of links and broadcast 
networks while the optimization of the traffic load is implemented by changing 
the load caused by the IERs.

This editor also allows you to view results of the simulation. After the simulation 
is complete, the Simulation Domain creates text files that capture the results of 
the simulation. The Scenario Builder reads these files and displays the results 
graphically as Measures of Performance (MOPs). The MOPs focus on the 
ability of selected communication equipment to send and receive information 
(e.g. file transfers, situation awareness updates, e-mail messages, etc.).
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2 System Editor

The System Editor is the editor that opens first when you start JCSS. From the 
System Editor, you can open any of the other JCSS editors, like the Scenario 
Builder. The System Editor allows you to access user and profile information, as 
well as the task assistant interface.

Accessing the System Editor

Starting up the JCSS software launches the System Editor and a Sign In dialog 
box, as shown below.

Figure 2-1   System Editor

Figure 2-2   Sign In dialog box
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1) By clicking the New button in the Sign In dialog box, the system launches 
the New Profile dialog box as shown below. The * designates a required 
field and must be filled-in to continue the sign-in process.

Figure 2-3   New Profile dialog box

2) Enter required information and any optional information. Click OK.

JCSS will save up to five (5) user names so that multiple users can use the 
software without re-typing their user information. This information is used to 
track the changes made in the scenario by the planner. The Subordinate 
Planners also use this information when they need to send the subordinate 
response files back to the Lead Planner. If you have logged in before, select 
your name from the drop-down menu. To enable the Task Assistant to open 
upon sign-in, ensure that the Use Task Assistant at Startup is checked. 

3) The Sign In dialog box displays again with the new user name in the Profile 
field. Sign in by clicking the Sign In button or, if you elect to edit your profile, 
you may do so at this time by clicking the Edit button.
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File Menu

Figure 2-4   System Editor’s File menu

New Project File > New Project...: Opens a new Scenario Builder and displays the Create 
Project dialog box. Create a new project, the first step in the Lead Planner’s 
workflow. You can simply name and launch a generic project, or use the New 
Project Wizard to select and set the area of operations, top-level units (including 
their locations and templates), an equipment list for each organization, an owner 
for each unit, and the types of equipment to use in the new project.
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1) Specify the names for the project and the initial scenario in the Create 
Project dialog box.

Figure 2-5   Creating a new project

2) Select a classification level for the project in the Create Project dialog box.

3) Click OK. If Launch New Project Wizard is not checked, then JCSS 
creates a generic project using the names you have designated. If Launch 
New Project Wizard is checked, then JCSS displays a sequence of dialog 
boxes that enable you to make selections specific to your new project.

Note—The names for both the project and the scenario cannot contain any 
spaces or special characters. In addition, the scenario name cannot be the 
same as any existing OPFAC; it must be unique.
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Open Project File > Open Project...: Displays the Open Project dialog box in which you can 
select a project file to open, and then opens the selected file in a new Scenario 
Builder.

1) Navigate to the NETWARS Project directory, and select the .prj file 
corresponding to the project that you wish to open.

Figure 2-6   Opening a Project in Scenario Builder

Open Subordinate
Query

File > Open Subordinate Query...: Displays the Open Subordinate Query 
dialog box in which you can select a query file to open, and then opens the 
selected file in a new Scenario Builder.

New Other File > New Other...: Displays the New dialog box which lists standard OPNET 
editors from which you can select to create.

Figure 2-7   New dialog box

Open Other File > Open Other...: Displays the Open dialog box which lists standard OPNET 
files from which you can select to open.
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Manage Model
Files

File > Manage Model Files > (option): This submenu lists options which allow 
you to manage model files.

Manage Model
Files > Delete

Model Files

File > Manage Model Files > Delete Model Files...: Displays a list of models 
from which you can select to delete files.

Figure 2-8   Delete Models dialog box

Manage Model
Files > Add Model

Directory

File > Manage Model Files > Add Model Directory...: Displays the Directory 
Browser in which you can create a new directory for models.

Manage Model
Files > Refresh

Model Directories

File > Manage Model Files > Refresh Model Directories: JCSS maintains a 
list of folders called the model directories (or mod_dirs for short) where the 
models are stored. Models include OPFACs, organizations, projects and 
scenarios, icon databases, and device models. When you move such models 
around on the hard drive using Windows Explorer, the software does not 
recognize the change. To make the software aware of the changes, use this 
option.

Recent Projects File > Recent Projects > (option): This submenu lists recently opened projects 
for easy re-opening.

Exit NETWARS File > Exit NETWARS: Exit NETWARS.
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Edit Menu

Figure 2-9   System Editor’s Edit menu

Login Information Edit > Login Information: Edit user profile information.

1) After modifying profile information, click OK.

Change User Edit > Change User: Change the current signed in user and sign in information 
at any time by using the System Editor. 

1) To change the user’s profile, choose the user’s name from the drop-down 
menu, as shown in the figure below.

Figure 2-10   Select User dialog box

2) Click OK when modifications are complete.
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User Level Edit > User Level > (option): Switch between JCSS interfaces (simple to 
complex) by selecting one of the available User Level options. JCSS menus 
change to reflect the selected User Level. Higher User Levels display more 
menu items and menu headers. You can switch between User Levels at any 
time, so that all menu items can be available if you so choose. Switching the 
User Level affects all open editors.

User Level >
Beginner

Edit > User Level > Beginner: Select this User Level to access a simplified 
JCSS interface. The Beginner interface hides access to many of the 
functionalities of the system without removing the capabilities themselves. This 
results in an interface that is reduced in complexity, and is easier to navigate for 
beginner JCSS users.

User Level >
Intermediate

Edit > User Level > Intermediate: Select this User Level to access a JCSS 
interface that exposes more functionalities of the system than the Beginner 
level, but less than the Advanced level. This results in an interface that is 
reduced in complexity, and is easier to navigate for intermediate users.

User Level >
Advanced

Edit > User Level > Advanced: Select this User Level to access the 
full-featured JCSS interface. The Advanced interface exposes all of the 
functionalities of the system. This results in an interface that is more complex, 
and best utilized by more experienced JCSS users.

Preferences Edit > Preferences > (option): Display and edit JCSS preference settings.

Note—These menu options perform the same functions as the Preferences 
options under the Edit menu in the Scenario Builder.

Preferences >
Device Model Map

Edit > Preferences > Device Model Map > (option): Set default device model 
map files.

Preferences >
Device Model Map

> New...

Edit > Preferences > Device Model Map > New...: Using the Choose Source 
and Target Model Name Lists dialog box, select the paths to where you want 
new source and target model list .txt files to reside, and then click OK.

Figure 2-11   Choose Source and Target Model Name Lists dialog box
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Preferences >
Device Model Map

> Open...

Edit > Preferences > Device Model Map > Open...: Using the Device Model 
Map Browser, navigate to and select an existing JCSS device model map .xml 
file to open, and then click Open.

Figure 2-12   Device Model Map Browser

Preferences >
Device Model Map

> Choose...

Edit > Preferences > Device Model Map > Choose...: Using the Device Model 
Map Preferences dialog box, navigate to and select a device model map .xml 
file to import into JCSS as needed, and then click OK.

Figure 2-13   Device Model Map Preferences dialog box
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Preferences >
Functional Profiles

Edit > Preferences> Functional Profiles: Set default functional profiles and 
functional names. Every OPFAC has one or more functional names. A 
functional name maps an IER or series of IERs to a producer/consumer OPFAC 
pair. A collection of such functional names is called a functional profile. A 
functional profile can be defined locally on an individual OPFAC, or globally, so 
that it is available to all OPFACs and across different scenarios.

Figure 2-14   Functional Profile dialog box

1) Add, rename, or remove functional profiles as needed.

2) Insert, delete, or edit functional names as needed.

3) Click OK.

Preferences >
Geographical

Coordinates

Edit > Preferences> Geographical Coordinates: Sets the default 
geographical coordinate system view displayed in the workspace of the 
Scenario Builder. There are three types of geographical coordinate systems 
available in JCSS: Lat/Long, UTM, and MGRS. 

Figure 2-15   Geographical Coordinates dialog box

1) Select the Lat/Long, UTM, or MGRS radio button.

2) Click OK.
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Preferences >
Owners List

Edit > Preferences> Owners List: Set owner information for units marked for 
subordinate query.

Figure 2-16   Owner List dialog box

Owner information contains four fields: Last Name, First Name, Title and 
Organization. All fields, except the Title field, are required fields. 

• Modify existing records or add/delete records to the list as needed.

Preferences >
Security

Classifications

Edit > Preferences> Security Classifications: Set security classification for a 
variety of items in a scenario, such as devices and IERs. This dialog allows you 
to add, remove, or change values in the list of recognized security classification 
values. The list is used to populate drop-down lists in edit fields and table cells 
that specify security classification values. Since some fields and cells only allow 
values from this list, you will need to modify this list in order to specify custom 
security classifications. Any value is permitted, although duplicates are not 
allowed in the list.

The list order indicates the classifications’ levels of restriction. Less restrictive 
classifications appear toward the top of the list. 

Figure 2-17   Security Classifications dialog box
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A value in the list may be modified by selecting and editing it. The Up button 
moves the selected value toward the top of the list. The Down button moves the 
selected value toward the bottom of the list. The Insert button inserts a blank 
entry above the selected value. The Delete button deletes the selected value. 
The Set Default button sets the selected classification as your default. The 
Save button saves all changes. Once saved, the changes will affect all edit 
fields and table cells, but the values stored in those attributes will not be 
modified.

Preferences >
Traffic Flow
Thresholds

Edit > Preferences> Traffic Flow Thresholds: Specify a minimum value and 
the colors to be used for each threshold; traffic flow thresholds are used in 
conjunction with the Aggregate Traffic Flows feature. Flows are colored based 
on the threshold they fall under. If the load of an aggregate flow is more than the 
highest threshold, the flow is colored black. If the load is lesser than the 
minimum threshold, the flow is not displayed. The default minimum value is 0 
Kbps.

Figure 2-18   Traffic Flow Thresholds dialog box

• Set desired traffic load/color combinations, and then click OK.
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Preferences >
Advanced

Edit > Preferences> Advanced: View and/or set environment attributes, or 
“preferences”, that control program operation. These values are stored in the 
environment database file (env_db for short).

Figure 2-19   Sample Preferences Editor

1) Use the Seach for field (and drop-down list) to search for preferences that 
contain specific words or values (Anywhere specifies to search Tags, 
Names, Values and Descriptions; In Names specifies to search Tags and 
Names only; In Values specifies to search Values only.)

2) Use the Arrange by drop-down list to display preferences by category 
(Groups specifies to arrange preferences by group; Source specifies to 
arrange preferences by source.)

3) Check (or uncheck) the Advanced view checkbox to toggle between 
showing an advanced or basic view of the preferences table (basic view 
shows the name and value of each preference; advanced view shows the 
name, tag, source of the preference’s value and the value itself.)

4) Edit desired preference values by clicking in the corresponding Value cell, 
selecting or typing the new value, and then pressing the <Enter> key on 
your keyboard.

5) Click OK to save edits and close the Preferences Editor.
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License Menu

Figure 2-20   System Editor’s License menu

License Management

License > License Management: A license conveys the right to use an 
application. A single license typically bundles one or more applications (such as 
Modeler), the simulation program, and one or more modules.

Licenses are allocated on a per-component basis. A component that is part of a 
license (perhaps a module such as TMMGUI) may be free and can be given to 
any requester, even if another component of the same license (most likely an 
application program) is in use. 

License Terminology

• Add license – Add a license to the machine’s license file.

• Deregister License – Remove a license from a machine’s license file (it is 
then free to be installed on a different machine).

• License – Authorization to use an OPNET product.

• License Manager – Software interface for performing license operations.
TR-2-14 JCSS/Release 7.0



JCSS Technical Reference Manual 2—System Editor
• License Server – A service running on a machine that will distribute licenses 
to other computers.

• Revoke License – Free a license that is currently in use.

• Standalone Mode – A licensing mode in which only the local machine can 
obtain the licenses.

License Attributes

• License number – Specifies the software license. A single license may 
bundle several programs (for example, 100/1 that includes the programs IT 
Guru, Expert Service Prediction, and Multi-Vendor Import will be shown as 
three separate lines in the License Manager interface.)

• Program name – Specifies which programs are included in the license (such 
as IT Guru and the Radio module).

• Status – Identifies the state of the program.

— A free program (shown in green) is available to the next user who 
requests it.

— An in use program (shown in white) is unavailable.

— An expired program (shown as yellow with red X) is no longer valid. 

• License expiration – Displays a date or the word “permanent,” depending 
on the type of license purchased.

• Maintenance expiration – An expiration date. It is not possible to buy 
perpetual maintenance.

• User – Shows the user ’s name if the license is in use.

• Host – Shows the machine where the license is being used.

License Files 

Files for dedicated licenses (as opposed to floating licenses) are stored in the 
OPNET_license directory.

Note—When it is time to install a new version of the software, do not delete the 
license files.

Starting License Manager

The License Manager can be accessed from the Start Menu or the System 
Editor. If you need to perform license maintenance, it is better to access the 
License Manager from the Start Menu (JCSS does not need to obtain a license).

Note—Please contact NETWARS CM to register your license.
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• To access License Manager from the Start Menu, simply select it from the 
Start/Programs/NETWARS/License Manager menu option.

• To access License Manager from the System Editor, select it from the 
License menu. 

Figure 2-21   License Manager: Requested Server dialog box

The License Manager contains details about the license server that you 
requested during the installation of JCSS. The License Manager also provides 
a Help menu that can be accessed by clicking the Help button.
TR-2-16 JCSS/Release 7.0



JCSS Technical Reference Manual 2—System Editor
Adding a License

1) Click the Add License button on the License Manager to display the 
Choose Transaction Method dialog box.

Figure 2-22   Choose Transaction Method dialog box

There are four transaction methods:

• Express – Automatic via the Internet (Requires authorized access.)

• Browser – Through a Web browser if the Express method does not work.

• Email – Exchange Codes with OPNET via Email.

• Offline – Exchange codes with OPNET via Telephone or Fax.

Product Modules License > Product Modules: Select active modules. Product Modules refer to 
additional licensed OPNET functionality. For example, JCSS uses the Terrain 
Modeling Module GUI (TMMGUI) and Multi-Vendor Import (MVI) product 
options, which are licensed under the NETWARS license. (JCSS can also make 
use of NetDoctor and Simulation licenses to further enable the JCSS-resident 
functionality.)

If a module is deactivated using this option (by deselecting the checkbox next 
to a module name) the corresponding features of that module will not be active 
in JCSS. For example, the Terrain menu will not be available in JCSS if the 
TMMGUI module is deactivated.
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IER Database Menu

Figure 2-23   System Editor’s IER Database menu

Database Selection

By default, JCSS will install a database service. The name of the service would 
be the hostname of the system followed by \NW2004_1. JCSS allows users to 
select between multiple databases on the local server or to select any network 
accessible database server as a datasource.

Choose Current
Database

IER Database > Choose Current Database: Choose the current database 
server and database within that server for use as a default data source for the 
IER Editor. Each selected server requires login for a user account registered at 
that database server, so you may be prompted for a login when changing the 
selected server. 
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Edit IER Database > Edit...: View and edit IERs in the IER Database Editor table. 
This table will contain the current working set of IERs, which you may view, 
insert into, delete from and modify. The current working set contains IERs that 
have been queried from the database, imported from text files, or entered 
manually.

Figure 2-24   IER Database Editor Table

New IER Database > New...: Create a new database on the specified server. 
Creating a database requires Administrator access, so you will be prompted for 
an administrator login. Logging in as the administrator also selects the 
destination server.

Database names cannot contain spaces or duplicate an existing database 
name on the selected server. Differences in capitalization are not enough to 
make database names unique; for example, Database1 is considered the same 
as both database1 and DATABASE1. 

Duplicate IER Database > Duplicate...: Copy/duplicate the current default database. If no 
default database has been selected, you will be required to select one. You will 
also be required to provide a Database Administrator ID and password for the 
destination server. A new database will be created, and its name must be 
unique as described above. The newly created database will contain copies of 
all of the records in the source. 

Merge IER Database > Merge...: Merge one database into another. All of the records 
from the source database will be copied into the destination database. Any 
existing records in the destination database whose identifier fields match 
records in the source database will be overwritten by the source records. 

Compare IER Database > Compare...: Produce a record-by-record comparison report for 
two selected databases.  The resulting report can be in text or HTML format. 

Change User IER Database > Change User: Clear all retained user passwords; requires you 
to login again to the default database server.
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Manage Accounts IER Database > Manage Accounts > (option): Database Administrators have 
the authority to create databases or accounts, or to modify passwords or 
account access permissions. Administrator access allows control over any 
database or user account on a specified server.

Database users may read the contents of database tables and store changes to 
them. Users only have access to selected databases. When users login to a 
server, they will be given the list of databases on that server that they are 
allowed to access.

User accounts may differ for each database server, so switching servers may 
require a new login.

Manage Accounts
> Admin

IER Database > Manage Accounts > Admin: Manage JCSS administrator 
accounts.

Manage Accounts
> User

IER Database > Manage Accounts > User: Manage JCSS user accounts. rant 
or deny access to designated servers and databases, add and delete users, and 
change user passwords via the Database User Account Management dialog 
box shown below.

Figure 2-25   Database User Account Management dialog box

Password Retention

User logins are retained for the duration of the session until you select to change 
the user. For typical operations, password retention will minimize repetition of 
password prompts. JCSS will not retain administrator passwords. Each time a 
user conducts an administrator operation, JCSS will ask for the administrator 
login.
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Windows Menu

Figure 2-26   System Editor’s Windows menu

Previous Editor Windows > Previous Editor: Make the previously displayed editor the current 
editor.

Circulate Editors Windows > Circulate Editors: One at a time, make each open editor the 
current editor.

Hide This Editor Windows > Hide This Editor: Hide the current editor. If another editor is open, 
that editor is made the current editor.

Hide Other Editors Windows > Hide Other Editors: Hide all open editor windows except the 
current one.

Show All Editors Windows > Show All Editors: Re-display any hidden editors.
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Help Menu

Figure 2-27   System Editor’s Help menu

Task Assistant Help > Task Assistant: Display a list of workflows available to the planners. A 
workflow is simply an outline of steps to guide the planner through the flow of 
tasks associated with the particular mission being addressed.
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The Task Assistant dialog box is shown below. The treeview on the left hand 
side of the dialog box shows the list of workflows available, and the explanation 
for those is provided in the pane on the right.

Figure 2-28   Task Assistant dialog box

The list of workflows displayed in the Task Assistant dialog box are organized 
based on categories of user tasks and most recently used workflows. 

1) To start a workflow, first select the workflow and then use either the Start 
Workflow button or simply double-click the workflow of interest.

2) To review the items within each workflow, click the plus sign to the left of 
the workflow category. This expands that category as shown below.

Figure 2-29   Expand a workflow category 
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Assume that you have decided to develop a communications plan. You would 
select Develop Communications Plan by double-clicking the icon to the left of 
the text. This calls the Develop Communications Plan task.

Figure 2-30   Develop Communications Plan task

In the figure above, each line item of the workflow has a letter to the left of the 
text indicating whether it is a milestone (M), an optional (O) or a required (R) 
task. In addition, many of the tasks can be expanded, by clicking the plus sign 
to reveal details on what steps are necessary to complete each task. 
Additionally, each line of the workflow is supplemented by details on how to 
complete that task in the Explanation pane located on the right side of the Task 
Assistant dialog.
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1) If you do not find the workflow of interest, choose the Browse for Workflow 
option under the Recent Workflows in the Task Assistant dialog box to 
locate the desired workflow.

Figure 2-31   Task Assistant browse for workflow

2) If you chose not to use the Task Assistant workflows, exit by clicking the 
Close button.

Task Tracking

This feature, available from the Task Assistant, provides you with the capability 
to track timeline, dates due, milestones, and percent done for the planning tasks 
associated with the plan being developed.

1) Task tracking information is available from the Task Tracking dialog box. 
Right-click on a particular task or on the workflow in the Task Assistant, and 
select Task Tracking Information. If you click on the workflow name and 
select Task Tracking Information, the workflow dialog box launches.

2) Check the Edit Workflow Time Information and enter the number of days 
for the entire workflow. 
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3) Click OK to save changes and close the dialog box. The figure below shows 
workflow time information.

Figure 2-32   Entering number of days for the entire workflow

4) Right-click on a task and choose Task Tracking Information to launch the 
Task Tracking dialog box, as shown below.

Figure 2-33   Task Tracking dialog box

The Task Tracking dialog box shows the milestone information, and the percent 
task completion. The Task Tracking dialog box provided above shows that the 
task Create a New Project is a milestone task (also known from the “M” icon for 
this task). The task is currently 50% complete. It has a task weight of 1, and days 
to finish (from start of the workflow) is 1. 

5) To edit this milestone information, check Edit Milestone Information. You 
can then change task weight and days to finish. 
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6) Update the percent task completed accordingly.

Figure 2-34   Editing milestone information

A particular task can be completed by setting its task completion percent to 100 
(from the Task Tracking dialog box, as shown above), or by double-clicking the 
task from the Task Assistant. When a milestone task is completed, the icon in 
the Task Assistant dialog box changes from “M” to display a check mark.

In order to complete a milestone task, all of its required and milestone sub-tasks 
need to be complete. If they are not complete, you will be prompted to do so. 
Similarly, a completed task can be marked incomplete, either by entering a 
value for task completion percent that is less than 100, or by double-clicking the 
completed task from the Task Assistant dialog box.

In the figure below, task Define the Mission is complete (as indicated by the 
check-mark), and percent task completion is set to 100 in the Task Tracking 
Information dialog box.

Figure 2-35   Completing a task
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If a milestone is overdue, it is flagged with a red “X”.

Figure 2-36   Overdue milestone

1) Toggle the milestone display on or off using the Show Milestones 
checkbox at the bottom of the Task Assistant. This will display/hide the 
completion percentage and days remaining for the milestone tasks, and for 
the entire workflow. The completion percentage for the entire workflow is 
calculated as a function of the completion percentage of each of the 
milestone tasks, and their relative task weights. 

2) By clicking the Export button, you will be prompted for a filename and 
location to save the task information as a tab-delimited text file. This file can 
be opened in MS Project (choose Default Task Information for the Import 
Mapping when opening the file).

Documentation Help > Documentation > (option): Access the JCSS documents discussed 
below:

Documentation >
User’s Manual

Help > Documentation > User’s Manual: Open the JCSS User’s Manual using 
Adobe Acrobat Reader. Acrobat Reader software can be optionally installed 
with JCSS. The JCSS User’s Manual is a guide that covers basic aspects of 
JCSS operation and use. It contains figures that provide visual examples of the 
JCSS interfaces, step-by-step procedures, and other important JCSS features 
and concepts.

Documentation >
Technical

Reference Manual

Help > Documentation > Technical Reference Manual: Open this document, 
the JCSS Technical Reference Manual, using Adobe Acrobat Reader.

Documentation >
Software Release

Bulletin (SRB)

Help > Documentation > Software Release Bulletin (SRB): Open the JCSS 
Software Release Bulletin using Adobe Acrobat Reader. Acrobat Reader 
software can be optionally installed with JCSS. The SRB contains release notes 
for the current version of JCSS.
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Documentation >
NETWARS
Acronyms

Help > Documentation >NETWARS Acronyms: Open the NETWARS 
Acronyms table using Adobe Acrobat Reader. Acrobat Reader software can be 
optionally installed with JCSS. The NETWARS Acronyms table contains 
definitions for acronyms commonly used with JCSS.

Documentation >
IT Guru

Documentation

Help > Documentation > IT Guru Documentation: Open the complete IT 
Guru document set. IT Guru is an OPNET commercial-off-the-shelf (COTS) 
product that models the behavior of networks—many JCSS features are based 
on IT Guru features. In this JCSS Technical Reference Manual, many 
references will ask you to access the IT Guru documentation for further details 
on certain features.

The IT Guru documentation contains a global index and a search query feature 
that enables you to quickly find needed information.

Show All Logs Help > Show All Logs...: Launches the Log Viewer.

Figure 2-37   Log Viewer

Error Log Help > Error Log > (option): If errors occur during the operation of JCSS, they 
are logged in this error log file. 

Error Log > Open Help > Error Log > Open: Using this menu option, you can open the error log 
file to view the error messages in a text editor.

Error Log > Clear... Help > Error Log > Clear...: Clear the error log file of the selected range of error 
messages.

Message Log Help > Message Log > (option): Status updates that monitor the performance 
of JCSS are logged in this message log file. 
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Message Log >
Open

Help > Message Log > Open: Using this menu option, you can open the 
message log file to view the status messages in a text editor.

Message Log >
Clear

Help > Message Log > Clear: Clear the message log file of all status 
messages.

Session Log Help > Session Log > (option): Basic file operations during the current session 
are logged in this session log file. 

Session Log >
Open

Help > Session Log > Open: Using this menu option, you can open the session 
log file to view the session messages in a text editor.

Session Log >
Clear...

Help > Session Log > Clear...: Clear the session log file of the selected range 
of session messages.

About NETWARS Help > About NETWARS: View information about the OPNET core software 
version, the models version, and copyright information.
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3 Scenario Builder

The Scenario Builder is the JCSS interface for creating, modifying, and saving 
projects and scenarios; it allows you to develop a complete communications 
plan.

The Scenario Builder is also used to evaluate and optimize network 
performance. Given a network and the traffic, it runs the optimization and comes 
up with suggestions for optimal link and network capacities. 

Additionally, this interface analyzes the results of a simulation session. It 
converts output from a simulation session into data that is viewable and grouped 
into Measures of Performance (MOPs).

Accessing the Scenario Builder

When you choose to either open an existing project in JCSS or create a new 
project, the Scenario Builder displays.

Figure 3-1   Scenario Builder
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File Menu

New Project File > New Project: Opens a new Scenario Builder and displays the Create 
Project dialog box. Create a new project, the first step in the Lead Planner’s 
workflow. You can simply name and launch a generic project, or use the New 
Project Wizard to select and set the area of operations, top-level units (including 
their locations and templates), an equipment list for each organization, an owner 
for each unit, and the types of equipment to use in the new project.

1) Specify the names for the project and the initial scenario in the Create 
Project dialog box.

Figure 3-2   Creating a new project

2) Select a classification level for the project in the Create Project dialog box.

3) Click OK. If Launch New Project Wizard is not checked, then JCSS 
creates a generic project using the names you have designated. If Launch 
New Project Wizard is checked, then JCSS displays a sequence of dialog 
boxes that enable you to make selections specific to your new project.

Note—The names for both the project and the scenario cannot contain any 
spaces or special characters. In addition, the scenario name cannot be the 
same as any existing OPFAC; it must be unique.

Open Project File > Open Project or click the Open an Existing Project toolbar button: 
Displays the Open Project dialog box, and then opens the selected project in a 
new Scenario Builder. 
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1. Double-click on the project folder of interest and select the corresponding 
.prj file.

Figure 3-3   Opening a Project in Scenario Builder

To create a new project, click the Create a New Project button.

Save Project/
Save Project As

File > Save Project or File > Save Project As: Save changes to existing 
projects in the Scenario Builder by using either the Save or Save As option. 

1) To save the changes you made to an existing project in the Scenario 
Builder, select the Save option.

OR

1) To save the changes you made as a separate project in the Scenario 
Builder, select the Save As option.

2) Specify the desired name in the subsequent dialog box, and then click OK.

Open Subordinate
Query

File > Open Subordinate Query: Displays the Open Subordinate Query dialog 
box, and then opens the selected subordinate query file in a new Scenario 
Builder. 

1) The Subordinate Planner will be prompted to select the appropriate file to 
be edited. Select the file by double-clicking on it.
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2) The project that you select will then open in a new Scenario Builder. The 
green “e” icon on top of the units indicates that the Senior-level Planner has 
marked these units to be edited by the Subordinate Planner. Other units 
that have a red lock icon on top indicate that the Subordinate Planner may 
only view these units and cannot edit them. Lock units are hidden by default 
upon opening. 

3) To view all units, select View > Filter > Restore Full View.

Figure 3-4   Opened Subordinate Query

The Subordinate Planner also has the capability to export subordinate query 
files, allowing this process to be repeated through many levels of hierarchy.

Save Subordinate
Query

File > Save Subordinate Query: Save the Subordinate Planner’s changes to 
the subordinate query file.

Close File > Close: Close the open project or subordinate query file. 

1) You will be prompted to save your project. Choose the desired option.

Figure 3-5   Closing a Project

The selected project and its Scenario Builder window close.
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Generate Scenario
Briefing

File > Generate Scenario Briefing: Export scenario information directly to a 
PowerPoint (.ppt) file. Customize the briefings by selecting desired components 
from a set of elemental briefing components.

A graphical user interface (GUI) is provided to enable you to choose the briefing 
components that you want to include, and then generate the briefings.

Figure 3-6   Briefings dialog box

1) Choose from the available components shown on the left hand side of the 
dialog box. The explanation of the selected components displays on the 
right hand side text box. Some of the components may not be available and 
will be shown disabled in the dialog box accordingly.

2) After selecting the components, choose Launch Briefing or Save 
Briefing. 

a) Launch Briefing launches the PowerPoint application and opens the 
briefing generated. 

b) Save Briefing prompts you to specify a filename and location for saving 
the briefings PowerPoint file.

Page Setup File > Page Setup: Displays the Print Setup dialog box from which you can set 
printing options.
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Print Scenario File > Print Scenario: Prints the contents of a JCSS scenario. A preview of the 
scenario displays as it will appear when it is printed.

When the scenario is printed, the contents of each subnet are printed on a 
separate page. Every page has a default header, which is the hierarchical name 
of the subnet.

Figure 3-7   Print Preview dialog box

1) From the preview, browse through the pages and make choices about the 
following:

a) Set the header to be used on each printed page

b) Use the background color as it appears on the workspace, or click the 
White background checkbox to use a white background.

c) If you check Fit to single page, the contents of a subnet print in one 
page; if not, each subnet prints across multiple pages. The total number 
of pages displays at the top right corner of the preview window.

d) Choose to either scale the image directly, or adjust for printer resolution.

e) Click Page Setup if you want to select the mode (landscape or portrait), 
paper size, etc.

2) Click Print, and select the desired printer.
TR-3-6 JCSS/Release 7.0



JCSS Technical Reference Manual 3—Scenario Builder
Print Graphs File > Print Graphs: After you have defined and displayed graph panels, you 
can print the visible graphs.

Refresh IER Text
Files

File > Refresh IER Text Files: IERs are queried from various sources; text files 
are one of them. Text files are queried when you view the IERs for an OPFAC 
or run a simulation. If changes are made to the text files, they are not 
immediately reflected in the scenario that is currently loaded in the Scenario 
Builder. In such cases, you can use this menu option to force the list of IERs to 
be refreshed.

Manage Model
Files

File > Manage Model Files > (option): This submenu lists options which allow 
you to manage model files.

Manage Model
Files > Delete

Model Files

File > Manage Model Files > Delete Model Files: Displays a list of all models 
from which you can select to delete files.

Figure 3-8   Delete Models dialog box

Manage Model
Files > Add Model

Directory

File > Manage Model Files > Add Model Directory: Displays the Directory 
Browser in which you can create a new directory for models.
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Manage Model
Files > Refresh

Model Directories

File > Manage Model Files > Refresh Model Directories: JCSS maintains a 
list of folders called the model directories (or mod_dirs for short) where models 
are stored. Models include OPFACs, organizations, projects and scenarios, 
icon databases, and device models. When you move models around on the 
hard drive using Windows Explorer, the software does not recognize the 
change. To make the software aware of the changes, use this option.

Recent Projects File > Recent Projects: This submenu lists recently opened projects for easy 
re-opening.

Package Project
Files

File > Package Project Files: Provides you with the ability to package and 
import JCSS data files. It serves as a convenient mechanism to exchange JCSS 
data with other users, and with NETWARS Support.

There are different options for including different files in the package. These 
various options are available from the Package Project Files menu. Four 
different options are available for packaging the files; and there is one menu 
item for importing packaged files.

A zipped archive is created as a result of choosing one of the package menu 
items. The zipped archive contains the following files for the various options:

• Project – Project, scenario, subordinate query, traffic, trajectory, OPFAC 
and organization files, simulation model files (if they exist.)

• Project with Simulation Results – Project files as indicated in the Project 
Files option and simulation results files.

• Project for NETWARS Support – Project files as indicated in the Project 
Files option and other files needed by NETWARS Support (env_db files, 
various log files etc.).

• Custom OPFACs and Organizations – All OPFAC and organization files 
under the Custom OPFACs and Custom Organizations folders.

To import package file, choose Import from the Package Project Files menu. A 
file chooser is presented to browse for the zipped archive containing JCSS files. 
After you select the archive file to be imported, a dialog box with the different 
import options displays (see figure below.)  

Figure 3-9   Import Package options
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Backup copies of files being replaced are created by default. You can turn that 
off by un-checking the check box in the above dialog box.

If you choose to be prompted for each file separately, then for every conflicting 
file, a dialog box displays. From this dialog box, you can choose to not overwrite 
the existing file, to replace the existing file, or to quit the import process.

Info-ZIP’s Zip and UnZip1 are used to create and import the zip file.

Exit File > Exit: Shut down the entire JCSS program. If there are editors that are 
open, you will be prompted to save the contents of those editors. When all open 
editors have been acknowledged and closed, the software is shut down.

Edit Menu

Undo Edit > Undo: Undo editing operations.

Only the following actions can be undone:

• Adding a unit (includes OPFAC and organization), device, or association 
(includes intra OPFAC link, inter OPFAC link, satellite link, broadcast 
network, relationship and circuit) from the palette or library.

• Moving a unit, device, association, or any group of these objects in the 
workspace.

• Deleting a unit, device, association, or any group of these objects in the 
workspace or using Scenario Builder treeview.

• Modifying attributes on devices; all attribute changes made while the Edit 
Attributes dialog box is open will be considered a single action. 

Some actions may prevent certain, or all, prior actions from being undone (for 
example, saving a project file.) Immediately following a save to disk, there will 
be no undoable actions.

There is no limit on the number of actions that can be undone; however, the 
actions can only be undone in the reverse order in which they were performed.

Redo Edit > Redo: Redo the undone operations. The actions can only be redone in 
the reverse order in which they were undone, which means that the last undone 
action will be the first one to be redone.

1. Copyright (c) 1990-1999 Info-ZIP.  All rights reserved.  "Info-ZIP" software is provided "as is," without warranty of any kind, express or 
implied.  In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages 
arising out of the use of or inability to use this software. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip,""WiZ," "Pocket 
UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.
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Any action (editing operation which includes add, delete, move, modify) 
performed after performing Undo will clear the Redo stack, and the undone 
operations cannot be redone.

Cut Edit > Cut : Cut selected, supported objects on the workspace to the clipboard, 
and remove them from the workspace.  If unsupported objects are attached to 
a supported object, then the unsupported objects are also removed from the 
workspace but not maintained on the clipboard.

Supported Objects:

• Organizations
• OPFACs
• Devices
• External links
• Internal links 
• Satellite links
• Broadcast networks
• OPNET demand objects

Unsupported Objects:

• Radio links
• Circuits
• Relationships
• OE
• Configuration OPFAC

Copy Edit > Copy: Copy selected, supported objects on the workspace to the 
clipboard.

Supported Objects:

• Organizations
• OPFACs
• Devices
• External links
• Internal links 
• Satellite links
• Broadcast networks
• OPNET demand objects

Unsupported Objects:

• Radio links
• Circuits
• Relationships
• OE
• Configuration OPFAC
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Paste Edit > Paste: Paste all objects on the clipboard to the workspace. 

Delete Edit > Delete: Delete the objects selected on the workspace. 

1) Select the objects that need to be deleted. To select multiple objects, press 
the <Ctrl> key on the keyboard while clicking on the objects.

2) Once the objects are selected, use this menu option or use the <Del> key 
on the keyboard to delete them. 

3) Confirm the deletion. 

Select All Edit > Select All: Select all the objects in the current subnet. Once the objects 
are selected, perform edit operations (like move, delete, etc) on these objects 
as needed. 

Find Node/Link Edit > Find Node/Link: You can search for an object (such as a node, 
subnetwork, link, or path) based on its name (part or all of the name.) Every 
object whose name contains the string you specified is selected and listed. Or 
you can leave the search field blank to find all objects in the network.

Figure 3-10   Find Node/Link dialog box

1) Enter a text string in the Name contains field to search for specific names. 
Leave this field blank to find all objects in the network.

2) Click Find. Found objects are highlighted in the display (any objects in the 
display that were previously highlighted are de-selected.)

The Find Node/Link dialog box displays a list of the seached objects, 
including their names, subnet names, and types.

3) Select the name of an object in the list, and click Locate Node/Link. The 
display changes to locate and highlight the seleted object.
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Group
Selection/Action >

Selection Filter

Edit > Group Selection/Action > Selection Filter: Select multiple objects 
based on their attributes. 

1) Select the type of object by clicking the appropriate check box.

2) Choose the attribute to be used for selecting objects from the drop-down 
menu. The list of attributes changes dynamically with the type of objects 
chosen for selection. From this list, select one or more attributes and 
specify the matching criteria. If there are objects of the selected type that 
match the attribute selection criteria specified, they are marked as selected.

Figure 3-11   Selection Filter dialog box

The table used for specifying the matching criteria has four columns.

— PROP – If set to Require, an object must satisfy all attribute criteria for 
selection; if set to Consider, an object must satisfy at least one of the 
attribute criteria for selection.

— Attr Name – Name of the attribute used as the selection criteria.

— ?= – Specifies the type of matching to be used. For a string, the only 
option is a complete match or equal to. For numeric values, the 
satisfying condition could be less than, greater than, or equal to the 
specified value.

— VALUE – Value that the attribute must match for selection.

Multiple attributes can be used as matching criteria. Attributes can also 
be deleted as needed.

3) Click the OK button; the software goes through all the objects in the 
scenario looking for those that match the specified criteria. When it finds 
objects that match the given criteria, it marks those objects as selected.
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Group
Selection/Action >

Action Filter

Edit > Group Selection/Action > Action Filter: Used in conjunction with the 
object selection feature. A similar interface is provided for applying action on the 
selected objects.

Figure 3-12   Group Action dialog box

1) Select the type of object to which you want to apply group action. 

2) Select the attribute that needs to be changed. In the above example, the 
user selected the Opfac Name attribute. 

3) Specify the value. In the previous example, the user chose JTF as the 
name to be set on all selected OPFACs.

4) Click OK; the software goes through all the selected organization objects in 
the scenario and sets the trajectory attribute on them.

Save Object
Selection Set

Edit > Save Object Selection Set...: Allows you to save an object selection set 
to a .selset file in the SB_Data directory.

Load Object
Selection Set

Edit > Load Object Selection Set...: Allows you to choose a saved object 
selection set file from the SB_Data directory to load.
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Edit Objects Using
Template

Edit > Edit Objects Using Template...: Allows you to specify the content you 
want to include in your report. When you generate a report (by clicking 
Generate), your content settings are saved and will be reloaded the next time 
you generate a report.

Figure 3-13   Edit Objects Using Template dialog box

• Select tables to include in user report treeview: Specifies which tables of 
which categories should be included in the report. To select an entire 
category of tables, click on the top-level category entries. To select an 
individual table, expand the top-level category subtree and click on the table 
entry. Selected tables and categories show a green check mark. Categories 
with some but not all of its tables selected display a green dot instead.

• Include only selected objects in report checkbox: Indicates that table data 
will be collected only for objects that are currently selected in the network.

• Ignore views checkbox: Indicates that table data will be collected even for 
objects that are not in the current view or views of the network.

• Generate button: Generates the table data for all of the selected tables.

• Close button: Closes the dialog box but retains any table selections.
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Edit Attribute
Template

Edit > Edit Attribute Template...: Allows you to edit the objects in your attribute 
templates.

Figure 3-14   Edit Attribute Template dialog box
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Project Defaults >
Link

Edit > Project Defaults > Link: Specify the default values for a link’s attributes 
based on the link type.

Figure 3-15   Link Defaults dialog box

1) Specify the desired default values for a particular link type.

2) If needed, change the default values for another type by choosing the 
desired type from the Defaults for Link Type drop-down menu. 

3) Click the OK button to save the default values. 
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Project Defaults >
Network

Edit > Project Defaults > Network: Specify the default values for a broadcast 
network’s attributes based on the network type.

Figure 3-16   Network Defaults dialog box

1) Specify the desired default values for a particular network type.

2) If needed, change the default values for another type by choosing the 
desired type from the Defaults for Network Type drop-down menu. 

3) Click the OK button to save the default values.
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Project Defaults >
IER

Edit > Project Defaults > IER: Specify the default values for an IER’s attributes 
based on the IER’s traffic type. 

Figure 3-17   IER Defaults dialog box

1) Specify the desired default values for a particular traffic type.

2) If needed, change the default values for another type by choosing the 
desired type from the Defaults for Traffic Type drop-down menu. 

3) Click the OK button to save the default values.

Project Defaults >
Requirements

Matrix

Edit > Project Defaults > Requirements Matrix: Edit the default requirements 
matrix questions that are applied to all new projects and scenarios created in 
the Scenario Builder. All fields are editable and can be modified by clicking on 
a cell and entering new values. 
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The Applications column displays application names for the specified service. 
If there is more than one application for the service, a comma separates 
application names with no space after the comma separator.

Figure 3-18   Requirements Matrix Default dialog box

Clicking on the buttons below the table displays different functional areas. 
Questions can be added or deleted via the Add Question and Delete Question 
buttons. 

By default, the Save button saves the changes and replaces the ReqMatrix.gdf 
file located in the Rules directory. To change the default file, click the Choose 
Defaults File button. Selecting this button launches a file chooser dialog box. 
Select the desired default file; the contents of the alternate file import into the 
Defaults Requirements Matrix dialog box.

Figure 3-19   Specifying the Requirements Matrix defaults file
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Project Defaults >
Mission Analysis

Edit > Project Defaults > Mission Analysis: Edit the default mission analysis 
questions that are applied to all new projects created in the Scenario Builder.  

Figure 3-20   Mission Analysis defaults

Answer questions by clicking on a cell and entering values.

Clicking on the buttons below the table displays different functional areas. 
Questions can be added or deleted via the Add Question and Delete Question 
buttons.

Saving the changes will modify the MissionAnalysis.gdf file located in the 
Rules directory. To change the default file, click the Choose Defaults File 
button. Selecting this button launches a file chooser dialog box. Select the 
desired default file; the contents of the alternate file import into the Mission 
Analysis Defaults dialog box.
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Project Defaults >
Distance Between

OPFACs

Edit > Project Defaults > Distance Between OPFACs: Configure the 
preferences for the Distance Between OPFACs feature. See field descriptions 
below.

Figure 3-21   Distance Between OPFACs Defaults

• Display Duration – Specifies the amount of time that the OPFAC Distance 
Links will display if you do not have the Do not hide “distance links” 
preference enabled.

• Do not hide “distance links” – Specifies whether the Scenario Builder will 
automatically hide the OPFAC Distance Links after a specified amount of 
time (refer to the Display Duration field above).

• Display Units – Sets the units in which the OPFAC Distance Links will 
display their distances.

• Elevation Threshold – Determines whether the distance calculation will 
consider the Earth’s curvature. If both OPFACs’ altitudes fall below this 
value, it will consider the Earth’s curvature, but it will not if either OPFACs’ 
altitude exceeds or equals this value.

Preferences >
Device Model

Map > New

Edit > Preferences > Device Model Map > New: Bridge the differences in 
model names/naming conventions that exist between JCSS and Network 
Engineer. Device model mapping allows you to define a mapping between two 
sets of device model names. During export of data, the JCSS XML processing 
code can substitute model names in the source data with alternate names in the 
target data.
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1) From the Scenario Builder, select Edit > Preferences > Device Model 
Map > New. The Choose Source and Target Model Name Lists displays. 
Use this dialog box to select a source model list and a target model list; this 
means that device model names in the source list will be replaced with 
designated model names in the target list.

Figure 3-22   Choose Source and Target Model Name Lists dialog box

2) Click the Browse button for the Source Model List. The Source Model List 
Browser dialog box displays.

3) Open the appropriate Rules folder. 

Figure 3-23   Source Model List Browser

Note—JCSS provides template source and target model list files from which you 
can choose in the Scenario_Builder/12.0.A/netwars/rules directory. You can select 
a template file, modify it, and save it under a new name in the User_Data/Rules 
folder to use again. Remember: Save your rules files to the default 
User_Data/Rules folder so you can easily find them again.

4) Select the desired input file and then click Open.

5) Click the Browse button for the Target Model List. Repeat steps 3-4, this 
time selecting an output file as the target model list.
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6) Click OK. The Edit Device Model Mapping File dialog box displays.

Figure 3-24   Edit Device Model Mapping File dialog box

Devices in the Unmapped Source Model Names panel (from the source 
model list) can be mapped to only one device in the Mapped Target and 
Source Model Names panel (from our target model list). However, it is 
possible to map more than one source name to the same target name 
(many-to-one mapping).

7) Select the desired model in the Unmapped Source Model Names panel. 
Next, in the Mapped Target and Source Model Names panel, select one 
or more models.
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8) Click the Map>> button. The source device name displays under the target 
device name in the Mapped Target and Source Model Names panel.

Figure 3-25   Mapped devices

9) Click the Save button. The Device Model Map Browser dialog displays. 
Name the file in the File Name field and then click Save.

Preferences >
Device Model Map

> Open

Edit > Preferences > Device Model Map > Open: Launches the Device Model 
Map Browser dialog box which enables you to select a previously created 
device model map to edit using the Edit Device Model Mapping File dialog box.

Preferences >
Device Model Map

> Choose

Edit > Preferences > Device Model Map > Choose: Use this dialog box to 
select an import map (source model list) and an export map (target model list) 
defaults for device model mapping.

Figure 3-26   Device Model Map Preferences dialog box

1) Click the Browse buttons for the Import Map and Export Map fields to 
select desired device model maps. 

2) Click OK.
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Preferences >
Functional Profiles

Edit > Preferences > Functional Profiles: Set default functional profiles and 
functional names. Every OPFAC has one or more functional names. A 
functional name maps an IER or series of IERs to a producer/consumer OPFAC 
pair. A collection of such functional names is called a functional profile. A 
functional profile can be defined locally on an individual OPFAC, or globally, so 
that it is available to all OPFACs and across different scenarios.

Figure 3-27   Functional Profile dialog box

1) Add, rename, or remove functional profiles as needed.

2) Insert, delete, or edit functional names as needed.

3) Click OK.

Preferences >
Geographical

Coordinates

Edit > Preferences > Geographical Coordinates: Sets the default 
geographical coordinate system view displayed in the workspace of the 
Scenario Builder. There are three types of geographical coordinate systems 
available in JCSS: Lat/Long, UTM, and MGRS. 

Figure 3-28   Geographical Coordinates dialog box

1) Select the Lat/Long, UTM, or MGRS radio button.

2) Click OK.
JCSS/Release 7.0 TR-3-25



3—Scenario Builder JCSS Technical Reference Manual
Preferences >
Owners List

Edit > Preferences > Owners List: Set owner information for units marked for 
subordinate query. Modify existing records or add/delete records to the list as 
needed.

Figure 3-29   Owner List dialog box

Owner information contains four fields: Last Name, First Name, Title and 
Organization. All fields, except the Title field, are required fields. 

Preferences >
Security

Classifications

Edit > Preferences > Security Classifications: Set security classification for 
a variety of items in a scenario, such as devices and IERs. This dialog allows 
you to add, remove, or change values in the list of recognized security 
classification values. The list is used to populate drop-down lists in edit fields 
and table cells that specify security classification values. Since some fields and 
cells only allow values from this list, you will need to modify this list in order to 
specify custom security classifications. Any value is permitted, although 
duplicates are not allowed in the list.

Figure 3-30   Security Classifications

The list order of an entry indicates the classification’s level of restriction. Less 
restrictive classifications appear toward the top of the list.
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A value in the list may be modified by selecting and editing it. The Up button 
moves the selected value toward the top of the list. The Down button moves the 
selected value toward the bottom of the list. The Insert button inserts a blank 
entry above the selected value. The Delete button deletes the selected value. 
The Set Default button sets the selected classification as your default. The 
Save button saves all changes. Once saved, the changes will affect all edit 
fields and table cells, but the values stored in those attributes will not be 
modified.

Preferences >
Traffic Flow
Thresholds

Edit > Preferences > Traffic Flow Thresholds: Specify a minimum value and 
the colors to be used for each threshold; traffic flow thresholds are used in 
conjunction with the Aggregate Traffic Flows feature. Flows are colored based 
on the threshold they fall under. If the load of an aggregate flow is more than the 
highest threshold, the flow is colored black. If the load is lesser than the 
minimum threshold, the flow is not displayed. The default minimum value is 0 
Kbps.

Figure 3-31   Traffic Flow Thresholds dialog box

Set desired traffic load/color combinations and then click OK.
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Preferences >
Advanced

Edit > Preferences > Advanced: Display the Preferences Editor and set 
environment attributes that control program operation. These values are stored 
in a file called the environment database file (env_db for short).

Figure 3-32   Preferences Editor dialog box

• Search for: Enables you to search for preferences. The system searches for 
words or values containing the specified text in whole or in part (a wildcard 
search is assumed.) From the pull-down menu, select the preference 
information to include in the search: Anywhere specifies to search Tags, 
Names, Values and Descriptions; In Names specifies to search Tags and 
Names only; and In Values specifies to to search Values only.

• Arrange by: Enables you to display preferences by category. From the 
pull-down menu, select Groups to arrange preferences by group (filters the 
list of displayed preferences to a specific group by selecting the group in the 
treeview,) or Source to arrange preferences by source (preferences are 
classified based on the source of their values.) 

• Advanced view checkbox: Toggles between showing an advanced or basic 
view of the preferences table. In the basic view, the table shows the name 
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and value of each preference. In the advanced view, the table shows the 
name, tag, source of the preference's value and the value itself.

• OK button: Saves changes and closes the Preferences Editor.

• Cancel button: Closes the Preferences Editor without saving changes.

• Apply button: Saves changes.

View Menu

Show Logical
Views

View > Show Logical Views...: Specify filtering parameters for logical views. 

Figure 3-33   Logical View Selection dialog box

• Network Layer Filters: Enables you to hide all devices except for those of a 
particular layer of the network. (Note that this doesn’t necessarily mean OSI 
network layer, but instead, it means the various devices that use a particular 
protocol.) Network Layer Filters shown are only those which apply to the 
deployed network. 

• Security Classification Filters: Enables you to filter elements of the 
network based on their security classifications. Any custom classifications 
added in the Operational view will be availabe here as well for filtering.

• Duration and Start Time: These parameters are used to get the Capacity 
Planner graphs that are used for filtering for various layers.
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• Consider Link Capacities checkbox: This is another parameter used to get 
the Capacity Planner graphs. A link capacity considered filter will result in the 
Capacity Planner creating a graph that may not show complete physical 
connectivity of the devices due to link load.  A link capacity ignored filter will 
result in a graph that shows complete physical connectivity of the devices 
regardless of link load.

• Create View button: Creates the type of view that you specified and loads it 
into a Network Showcase window. The filter specifications are applied to the 
logical view model.

• Save Settings button: This button is availabe from the Operational View and 
gives you the option to save the settings instead of creating a logical view 
network with the specified settings at this time.

• Close button: Closes the dialog without making any changes to the model.

Show Network
Browser

View > Show Network Browser: Use the Network Browser, a pane that lists 
objects (organizations, OPFACs, nodes, devices, links, etc.) in the network, to 
locate objects in the workspace and edit their attributes.

Figure 3-34   Network Browser

You can modify the object list by applying filters. Available filters include:

• Classification: Filters based on the classification attribute on each device.

• Equipment Type: Filters based on the equipment type attribute on each 
device.
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• Ownership: Shows the associated owner for each device in the scenario. 
Used with Collaborative Planning. 

• Broadcast Networks: Shows all of the broadcast networks in the scenario 
and to which OPFACs/devices they are attached. 

• Relationships: Shows all of the relationships in the scenario and to which 
OPFACs they apply. 

• Satellite Links or Radio Links: Shows all of the satellite (or radio) links in 
the scenario and to which OPFACs/devices they are attached. 

Click on an object in the object list to display it in the workspace (upper-right.) 
Select and check an object to display it in a Showcase window (lower-right.) Use 
options provided on the right-click menu to modify object attributes. 

Figure 3-35   Network Browser with Showcase Window and Right-click Menu
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If you have an OPNET Modeler license, you can easily open node models in 
Modeler by double-clicking on a device in the workspace. Note that for derived 
models, you must open the parent instead.

1) Double-click on a node model. The following message dialog displays.

Figure 3-36   Open Node Editor Message Dialog

2) Click OK. OPNET Modeler launches and displays the node model.

Note that Modeler will not launch if you do not have a license for it.

Figure 3-37   Opening a Node Model in OPNET Modeler
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Using the Preferences Editor in JCSS, you can set preferences for the Modeler 
launch feature:

• modeler_ipc.enable: Enables (set to TRUE) or disables (set to FALSE) the 
Modeler launch capability. 

• modeler_ipc.port: Sets your port preference for Modeler launch. Specify 
the port number you want to use to connect to Modeler when opening node 
models.

• modeler_ipc.show_dialog: Shows (set to TRUE) or hides (set to FALSE) 
the Open Node Editor message dialog on Modeler launch.

Consult the documentation for OPNET Modeler for instructions on using 
Modeler with node models.

Show Network
Topology

View > Show Network Topology: Toggles the view of the network topology on 
and off in the Scenario Builder workspace.

Show Network
Showcase

View > Show Network Showcase: Toggles the showcase display on and off in 
the Scenario Builder window. Allows you to choose to use the default showcase 
(or select another showcase to use from the Showcase pull-down menu) and 
the default view (or select another view from the View pull-down menu.) You can 
also create a new showcase, and import, duplicate, rename or delete a 
showcase using options in the Showcase pull-down menu.

Figure 3-38   Show Network Showcase in Scenario Builder
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Open Network
Showcase Window

View > Open Network Showcase Window: Allows you to select a saved 
network showcase and display it in a separate window.

Figure 3-39   Network Showcase window

Show Time
Controller

View > Show Time Controller:  Displays the Time Controller dialog box that 
allows you to change the current network time visualized in the editor and 
animate the time change effect. 

Figure 3-40   Time Controller dialog box

The Time Controller dialog box shows the current network time (text field), value 
for the time step which is used for stepping forward or backward using the 
animation buttons, animation control buttons (to Jump to start to reset the 
network time to the slider start time, Step backward to decrease network time 
by one time step, Play forward or Pause animation, Step forward to increase 
network time by one time step, Jump to end to set network time to slider end 
time, Slow down play and Speed up animation), and a time slider which 
provides an alternative way to change the current network time.
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Click the Configure button to display the Time Controller Settings dialog box, 
which allows you to set and change Time Controller values.

Figure 3-41   Time Controller Settings dialog box

• Slider start time, Slider end time, and Time step: Specifies the source 
plug-in for the slider start time, end time, and time step values. If 
User-Defined is selected, you can enter the value in the corresponding field.

• Real time between steps field: Specifies the speed of the animation.

• Loop checkbox: If checked, animation restarts after completion.

• Start modeling at calendar time: Check and type a value if you want to 
specify a calendar time for the network start time. Otherwise, the start time is 
assigned the symbolic value of 0.0.

Set Area of
Interest

View > Set Area of Interest: Provide geographical context to the scenario.

Figure 3-42   Set Area of Interest dialog box

The geographic focus can be specified by entering values for Area of the View 
and Center of the View. These attributes determine the location and size of the 
displayed view of the map. For example, if the center of view is (0,0) and the 
area of view is (width = 100, height = 50), then the portion of the map that would 
be displayed will be from (50W, 25N) to (50E, 25S). 
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The geographic focus also determines the relative range at which OPFACs (and 
their devices) are located from each other. This is of significance when 
exchanging IERs/traffic during a simulation. While TSC-85 radios and wire links 
have no range limitations, TRC-170 radios and tactical broadcast networks only 
work within a limited range of each other. For example, if two TRC-170 radios 
are more than 150 miles apart, then all packets transmitted between them will 
be dropped, resulting in failed IERs.

Go to Parent
Organization

View > Go to Parent Organization or click the Go to Parent Organization 
toolbar button: Change the view in the workspace to the next higher level in the 
network. For example, if this option were selected inside an OPFAC, the next 
level up would include the parent OPFAC. Similarly, if this option were selected 
for an OPFAC inside an organization, the next level up would be the parent 
organization as seen below.

Figure 3-43   Go to Parent Organization

Background > Set
Properties

View > Background > Set Properties: Control the look-and-feel of the 
scenario in the workspace. Specify the units and draw style to be used for the 
grid lines, the color of the links, the space between grid lines, and the resolution 
to be used for displaying the network.

1) Select desired view properties from the options at the top of the dialog box.
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2) The scenario displayed in the workspace is made up of many different 
layers. Specify which layers to view and hide using the checkboxes next to 
each layer. 

Figure 3-44   Setting background view properties

3) Move layers backward and forward to indicate the layer ordering in the 
workspace.

4) The Translucency column specifies the level of layer content translucency 
with a value between 0 (opaque) and 100 (transparent).

NOTE: Presently, only layers with CADRG/CIB and MrSID raster images 
support translucency.

5) Click the Edit CADRG/CIB Properties... button to open a dialog box with 
configurations of background slices with CADRG/CIB rasters.

NOTE: Requires an active Terrain Modeling Module license. 

Background > Set
Border Map

View > Background > Set Border Map: Specify a border map for a scenario. 
Border maps use stylized lines to define political and geographical areas. JCSS 
comes with a library of border maps that represent a geographic area described 
by latitude and longitude. 
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1) To specify the border map from the Choose Border Map dialog box, choose 
the border map from the drop-down menu. Note that the border map list is 
a finite list and may not be modified.

Figure 3-45   Selecting a Border Map

2) If the desired map is not in the list, select the world map and zoom in to the 
desired location.

Background > Add
Image Map

View > Background > Add Image Map: Import an image into the scenario. 

1) Choose an option of importing an existing map or specifying the file path to 
an image map located on the hard drive; select desired map.

2) Click OK.

Figure 3-46   Importing an Image Map
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Background > Add
MIF Map

View > Background > Add MIF Map: Import MIF maps, which are files that 
provide additional geographical information on a border map, such as 
roadways, waterways, regions, and counties. Several MIF maps come standard 
with JCSS.

1) From the MIF menu, select the desired MIF map.

Figure 3-47   Importing MIF Data

2) Click Close. The MIF map automatically imports.

Background >
Show MIF Log

View > Background > Show MIF Log: Display the MIF Import Log dialog box.

Figure 3-48   MIF Import Log dialog box

Background > Add
Image

View > Background > Add Image: Import ordinary background images, i.e., 
those images that do not include geographical information, into a scenario. 
Background images differ from background image maps in that they are 
described by referencing points on an x-y axis.

1) In the Add Background Image dialog box, select the Import background 
image radio button and then click Browse to select the TIFF file to import. 
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Figure 3-49   Importing a Background Image

2) Select Open and then OK to import the image.

3) Next, JCSS enters Map/Background Editing mode. In this mode, you can 
edit image maps and backgrounds, but not border maps. To 
select/move/resize image maps or backgrounds, simply click, right-click or 
drag them. You can also copy, cut and paste maps/backgrounds.

After you are done, exit Map/Background Editing mode by right-clicking on 
one of the maps or backgrounds and choosing Exit Map Editing Mode, or 
by selecting View > Background > Map Edit Mode. 

Background > Add
CADRG/CIB

Raster Catalog
Directories

View > Background > Add CADRG/CIB Raster Catalog Directories...: Select 
a raster catalog directory from which to import.

Background > Add
MrSID Image

View > Background > Add MrSID Image...: Select a MrSID image file (*.sid) 
to import.

Background > Map
Edit Mode

View > Background > Map Edit Mode: Modify background images. Once this 
mode is selected, edit the image as desired using techniques described in the 
following table.

Table 3-1 Edit Image Map Operations

To... Follow These Steps...

Resize an image map Right-click on the image map and drag one of the 
handles on the image map.

Right-click on the image map and choose Set 
Location and Size and fill in the desired values.

Move an image map Drag the object to the desired location.

Right-click on the image map and choose Set 
Location and Size and fill in the desired values.

Remove an image map from the 
workspace

Click on the image map and press the <Delete> key.

Exit map edit mode Right-click on the image map and select Exist Map 
Editing Mode. 
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Edit Display
Preferences

View > Edit Display Preferences: Edit preferences that control the 
visualization of the network. Preferences can be controlled on either the global 
or subnet level. Those preferences specified at the subnet level take 
precedence over any global settings. The subnet preferences are retained per 
subnet and can only be changed from this dialog box for the active subnet.

Figure 3-50   Edit Visualization Preferences dialog box - Global tab

Global preferences are available on the Global tab:

• Minimize icons that are X pixels or smaller: Determines at what size icons 
become minimized. If an object appears smaller than the specified number 
of pixels, it is drawn using its minimized icon, as specified by its minimized 
icon attribute. This setting also changes the 
network_visualization.minimized_icon_pixel_threshold environment 
preference.
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• Size of minimized icons: Determines the size, in pixels, of all minimized 
icons in the network. It also changes the 
network_visualization.minimized_icon_size environment preference.

• Size of minimized balloons: Determines the size, in pixels, of all minimized 
balloons in the network. It also changes the 
network_visualization.minimized_balloon_size environment preference.

• Icon style: Specifies the model icon style to display. Select Symbolic or 
Chassis.

• Show node/subnet labels for: Specifies which nodes and subnet objects 
display labels. It also changes the network_visualization.show_node_labels 
environment preference. The selections have the following effects: 

— All icons: Labels appear on all objects. 

— No icons: No labels appear on any node or subnet objects. 

— Full-size icons only: Labels only appear on objects that have not been 
scaled below their original full size. 

— Non-minimized icons: Labels appear on any icons that have not been 
minimized. 

— Icons larger than X pixels: Labels appear on any icons that are larger 
than the specified number of pixels. It also changes the 
network_visualization.show_labels_icon_pixel_threshold environment 
preference. 

• Show link arrowheads: Specifies which links have arrowheads. It also 
changes the network_visualization.show_link_arrowheads environment 
preference. The selections have the following effects: 

— Never: No arrowheads appear on any link objects. 

— As specified by attributes: The appearance of arrowheads is 
determined by each link object's arrowheads attribute. 

— For simplex links only: For all simplex links, the appearance of 
arrowheads is determined by each link object’s arrowheads attribute. For 
all other link types, no arrowheads display. 

• Show link labels: Specifies which links have labels. It also changes the 
network_visualization.show_link_labels environment preference. The 
selections have the following effects: 

— Never: No link labels appear on any link objects. 

— Always: Link labels appear on all link objects. 

— For off-page links only: Link labels appear on links that are drawn out 
of the active subnet. 
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• Show demand labels: Specifies which demands have labels. It also 
changes the network_visualization.show_demand_labels environment 
preference. The selections have the following effects: 

— Never: No demand labels appear on any demand objects. 

— Always: Demand labels appear on all demand objects. 

• Show path labels: Specifies which paths have labels. It also changes the 
network_visualization.show_path_labels environment preference. The 
selections have the following effects: 

— Never: No path labels appear on any path objects. 

— Always: Path labels appear on all path objects. 

Figure 3-51   Edit Visualization Preferences dialog box -Subnet tab
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Subnet preferences are available on the Subnet tab:

• Default to Global Visualization Settings checkbox: Determines if the 
subnet inherits the global preferences, or uses the subnet settings specified 
in the dialog box. If checked, the subnet-level dialog box controls are 
disabled. If unchecked, the subnet settings can be specified for the active 
subnet.

• Minimize icons that are X pixels or smaller: Determines at what size icons 
become minimized in the subnet. If an object appears smaller than the 
specified number of pixels, it is drawn using its minimized icon, as specified 
by its minimized icon attribute.

• Size of minimized icons: Determines the size, in pixels, of all minimized 
icons in the active subnet.

• Size of minimized balloons: Determines the size, in pixels, of all minimized 
balloons in the active subnet.

• Icon style: Specifies the model icon style to display. Select Symbolic or 
Chassis.

• Show node/subnet labels for: Specifies which nodes and subnet objects 
display labels in the active subnet. 

— All icons: Labels appear on all objects. 

— No icons: No labels appear on any node or subnet objects. 

— Full-size icons only: Labels only appear on objects that have not been 
scaled below their original full size. 

— Non-minimized icons: Labels appear on any icons that have not been 
minimized. 

— Icons larger than X pixels: Labels appear on any icons that are larger 
than the specified number of pixels. 

• Show link arrowheads: Specifies which links have arrowheads in the active 
subnet. The selections have the following effects: 

— Never: No arrowheads appear on any link objects. 

— As specified by attributes: The appearance of arrowheads is 
determined by each link object's arrowheads attribute. 

— For simplex links only: For all simplex links, the appearance of 
arrowheads is determined by each link object's arrowheads attribute. For 
all other link types, no arrowheads display. 

• Show link labels: Specifies which links have labels in the active subnet. The 
selections have the following effects: 

— Never: No link labels appear on any link objects. 

— Always: Link labels appear on all link objects. 

— For off-page links only: Link labels appear on links that are drawn out 
of the active subnet. 
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• Show demand labels: Specifies which demands have labels in the active 
subnet. The selections have the following effects: 

— Never: No demand labels appear on any demand objects. 

— Always: Demand labels appear on all demand objects. 

• Show path labels: Specifies which paths have labels in the active subnet. 
The selections have the following effects: 

— Never: No path labels appear on any path objects. 

— Always: Path labels appear on all path objects.

• OK button: Closes the dialog box. All settings take effect immediately, 
including modification of global environment preferences and subnet-level 
settings.

• Cancel button: Closes the dialog box and returns to the original display 
without making changes to the visualization settings, global environment 
attributes, or subnet-level settings.

• Preview button: All of the settings changed take effect immediately, although 
the environment preferences and subnet settings are not retained unless you 
click OK. 

Refresh
Workspace

View > Refresh Workspace: Redraw/refresh the workspace view.

Layout View > Layout > (option): You can customize the appearance of objects in your 
workspace by scaling the icons to a larger or smaller size, and moving icon 
labels that overlap. JCSS provides commands that will perform these functions 
automatically for you, or you can make adjustments manually to selected icons 
using the Scale Selected Icons dialog box.

Layout >
Automatic Icon

Scaling

View > Layout> Automatic Icon Scaling: Toggle on and off the ability to adjust 
icon sizes automatically to minimize overlap.

Layout >
Automatic Label

Placement

View > Layout> Automatic Label Placement: Toggle on and off the ability to 
adjust label positions automatically to prevent overlap with adjacent icons.

Layout > Scale
Node Icons

Interactively

View > Layout > Scale Node Icons Interactively: Scale/change the size of 
node/subnet icons. For example, if an icon is 12 x 12 pixels at full size, you can 
scale the icon to 50% so that it appears at half-size (6 x 6 pixels).
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If you scale an icon below a certain size, the icon becomes minimized—that is, 
it appears as a simple shape rather than as a bitmap.

1) Choose View > Layout > Scale Node Icons Interactively. The Scale All 
Icons dialog box displays.

Figure 3-52   Scale All Icons dialog box

2) Scale the selected icons by the desired amount.

a) Select the Fix icons at full size radio button to scale selected icons to 
their full size (as defined by the icon bitmaps). When zooming in or out 
in the workspace, the icons remain at full size regardless of the zoom 
level. This behavior is achieved by setting the “threshold” attribute on the 
selected objects to a value of 0. Selecting this option disables the icon 
scaling slider and the uniform size button. 

b) Select the Scale icons, minimize overlap radio button to use the Scale 
Factor slider and field to scale all of the selected icons, except those that 
would overlap other icons if they were scaled any larger. The size can 
range from 1% to the percentage at which all of the icons will appear full 
size. This maximum percentage will vary, depending on the icon size 
when you open this dialog box.

c) Select the Scale icons, ignore overlap radio button to use the Scale 
Factor slider and field to scale all of the selected icons equally, even 
those that overlap. The size can range from 1% to the percentage at 
which all of the icons will appear full size. This maximum percentage will 
vary, depending on the icon size when you open this dialog box.

d) To scale all selected icons to the same size (that is, to the current size 
of the smallest icon in the selection set), click the Set Icons to Uniform 
Size button and then use the slider. A progress bar appears as the icons 
are updated.

3) Click OK to change the selected icons as specified and close the dialog 
box. A progress bar appears as the icons are updated. If no changes are 
necessary, the dialog box will simply close. 

4) Click Cancel to close the dialog box without making any of the specified 
changes.
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Layout > Lay Out
Nodes

Interactively

View > Layout > Lay Out Nodes Interactively...: Use this option to change the 
position of various node/subnet/utility objects.

Figure 3-53   Layout Network Objects dialog box

• Algorithm pull-down menu: Specifies the currently selected layout 
algorithm. The layout algorithm determines how the positions of the selected 
objects will change when the Run button is clicked. The algorithms are: 

— Expand/Contract: Moves the selected network objects away from or 
toward the Mark icon (the movable green cross icon in the Project Editor 
workspace). 

— Expand/Contract Horizontally: Moves the selected network objects 
horizontally away from or toward the Mark icon. 

— Expand/Contract Vertically: Moves the selected network objects 
vertically away from or toward the Mark icon. 

— Rotate: Moves the selected network objects as if they were rotated about 
the Mark icon. 

— Disperse: Moves the selected network objects with the specified layout 
region. 

• Layout region pull-down menu: Specifies a rectangular region for the 
algorithm to operate on. This element will be disabled if the selected 
algorithm does not use a particular layout region. 

• Percentage/Degrees combo field: Specifies a variable parameter to 
customize the behavior of the selected layout algorithm. The label changes 
between Percentage and Degrees, depending on the selected algorithm. 
You can either drag the slider or enter a number directly to specify the value. 
This is disabled, if the selected algorithm does not use a parameter value. 

• OK button: Closes the dialog box. The position changes become permanent 
and a single undo command is added to the editor’s undo stack. 

• Cancel button: Closes the dialog box after undoing all position changes that 
were made while this dialog box was open. 

• Run button: Performs the selected layout algorithm upon the current 
selection set or, if no objects are selected, all objects in the current subnet. 
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• Undo button: Undoes the effect of the last algorithm run or the last object 
drag. The dialog box maintains a local undo stack since the time it was 
opened, so you can undo repeatedly to return to any earlier state. This button 
is disabled if there are no operations that can be undone. 

• Redo button: Redoes the effect of the last local undo operation. Until you run 
another algorithm or directly drag objects, you can redo repeatedly to return 
to any previously undone state. This button is disabled if there are no 
operations that can be redone. 

• Undo All button: Undoes the effect of all algorithm runs and object drags 
since the dialog box was opened. This has the same effect as repeatedly 
clicking the Undo button until it becomes disabled.

Note—While the Layout Network Objects dialog box is open, the toolbar and the 
menu bar of the editor window are disabled. However, the editor workspace is 
still active. You can change the selection set, and you can directly drag selected 
objects around. Any drags are considered part of the interactive layout 
operation and will be undone if you cancel out of this dialog box. Also, while this 
dialog box is open, the Mark icon (a green cross) is present at the center of the 
current selection set. This icon represents the Mark point used by various 
algorithms. You can drag this icon around without dragging any network objects 
and without changing the current selection set.

Layout > Layout
Nodes (Balanced)

View > Layout> Layout Nodes (Balanced): Selecting this option automatically 
balances the layout of nodes in the current view.

Layout > Layout
Nodes (Simple)

View > Layout> Layout Nodes (Simple): Selecting this option automatically 
simplifies the layout of nodes in the current view.

Layout > Layout
Nodes (Core

Centric)

View > Layout> Layout Nodes (Core Centric)...: Use this option to create a 
meaningful network layout, based on core nodes. The layout places core nodes 
in the center. All other nodes are placed around the core nodes based on the 
quantity of links. Nodes attached to the network with only one link are placed 
furthest from the core nodes. Nodes with no link attachments to the network are 
placed on the left side of the workspace.
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Layout >
Geographic
Positioning

View > Layout> Geographic Positioning: Toggle on and off the current view 
mode to logical/physical.

Zoom > To
Rectangle

View > Zoom > To Rectangle or press <Ctrl>+<I>, or use the Zoom In option 
from the shortcut menu, or click the Zoom In toolbar button: Get a close-up view 
of the object in question in the workspace. Apply this option multiple times to 
obtain an ever-closer view. 

1) Select the Zoom > To Rectangle command, and then drag the cursor to 
define a rectangular shaped region to be magnified.

Figure 3-54   Selecting an area to zoom in

Zoom > To
Selection

View > Zoom > To Selection or press <Ctrl>+<Shift>+<Z>: Get a close-up 
view of a selected area or object in the workspace.

1) Drag the cursor to define a rectangular shaped region to be magnified, and 
then select the Zoom > To Selection command.

Zoom > To
Window

View > Zoom > To Window: Zoom out on the workspace so it shows 
completely in the window.

Zoom > Unzoom View > Zoom > Unzoom or press <Ctrl>+<U>, or use the Zoom Out option 
from the shortcut menu, or click the Zoom Out toolbar button: Restore the 
workspace view to the previous zoom level.

Zoom > To All View > Zoom > To All or press <Ctrl>+<Alt>+<Z>: Zoom out on the workspace 
so it shows active areas in the window.
JCSS/Release 7.0 TR-3-49



3—Scenario Builder JCSS Technical Reference Manual
Filter View > Filter > (option): Apply a number of different filters to the scenario.

Filter > Selected
Objects

View > Filter > Selected Objects: Filters can be applied on objects that have 
been selected on the workspace. The objects could have been selected by 
manually clicking on them, or by the use of the selection filter.

Figure 3-55   Filter Map dialog box

Using this option, you can hide the selected objects or show only the selected 
objects. An option is also provided to redisplay all objects.

Filter > Devices View > Filter > Devices: Filters can be applied to devices based on the type of 
applications they support. Filtering can be done based on the functional area or 
the service. For example, if you are interested in viewing just the SIPRNET 
portion of the scenario, you can apply a device filter and specify SIPRNET as 
the service of interest. All other devices will be hidden. If an OPFAC has no 
visible devices, the OPFAC is hidden as well.

Figure 3-56   Filter OPFACs and devices dialog box

You can display the result of this filtering operation either on the workspace or 
in a table. The table displays the OPFAC name, device name, application name, 
functional area and service.
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Filter >
Infrastructure

View > Filter > Infrastructure: Show or hide the different types of infrastructure 
like relationships, links, broadcast networks and satellite links. By default, all 
infrastructures are displayed and all the options are checked. If you want to hide 
a certain type of infrastructure, uncheck that option and all infrastructure of that 
type will be hidden.

Figure 3-57   View Infrastructure dialog box

For example, if you do not want to view relationships in the scenario, you can 
go to this interface and uncheck the option View Relationships.

Filter > Hide
Locked Units

View > Filter > Hide Locked Units: Hide all locked units in the Subordinate 
Planner query file.

Filter > Restore
Full View

View > Filter > Restore Full View: View all locked units. In the Subordinate 
Planner query file, all locked units are hidden by default.

Network Views View > Network Views > (option): JCSS offers a number of different views of 
the scenario. Each of these views offers the user a different perspective of the 
network. 

Network Views >
Planning

View > Network Views > Planning:This view is useful for someone working in 
a collaborative planning environment. Using this view, the planner can display 
only the planning portions of the scenario and hide all others. Organizations, 
OPFACs and planning links are all part of the planning view. Devices and 
connectivity links are hidden in this view.

Network Views >
Connectivity

View > Network Views > Connectivity: If a planner is not interested in the 
planning links and just wants to view the connectivity links in the network, he can 
choose this menu option. Planning links and OPFACs without any devices are 
hidden in this view.

Network Views >
Planning and
Connectivity

View > Network Views > Planning and Connectivity:The planner can use this 
menu option to return to the default view, which includes the planning and 
connectivity elements in the scenario.
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Network Views >
Operational

View > Network Views > Operational: Selecting this menu item will switch 
from a Systems or Logical View back to the default view of the scenario, the 
same view that loads when you first open the scenario in Scenario Builder.

Network Views >
OPFAC Systems

View > Network Views > OPFAC Systems: Selecting this menu item will 
switch from the current view, the Operational View or some other type of 
Systems View, to the OPFAC Systems View.  The OPFAC Systems View 
expands the contents of the organizations, collapses the contents of the 
OPFACs, and redraws the links to connect to their respective devices.

Save Current Unit
View

View > Save Current Unit View: Set a default view to which you can return.

Restore Saved
Unit View

View > Restore Saved Unit View: Return to the saved view.

Show LOS >
LOS Settings

View > Show LOS > LOS Settings: Set the parameters for the editor to control 
what LOS visualizations are displayed and how they appear.

Note—The LOS that you see takes into account the position as well as the 
altitude for that device. You can set the altitude for an OPFAC via the OPFAC 
Attributes dialog box (right-click on the OPFAC and select Edit NETWARS 
Attributes.) By default, altitude is set by terrain and measured in meters. You 
can enter an altitude value in another unit of measurement (such as kilometers, 
feet, yards, or miles), and JCSS will automatically convert the measurement to 
meters the next time you open the OPFAC Attributes dialog box.

Figure 3-58   LOS Settings

• LOS Range Radius – Measured in meters, this specifies the size of the 
circle that may appear around an organization or OPFAC. It is a nominal 
range, and this single setting affects all LOS Visualization in the editor. For 
reference, 10,000 meters is the typical transmission limit when terrain 
elevation data is not available. Transmitters assisted by elevation could 
transmit many times this distance. 
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• LOS Terrain Shading Density – Specifies the number of samples to check 
within the LOS Range Radius for determining LOS Terrain Effects Shading. 
More samples give a more accurate representation, but can also slow display 
as more information must be considered to update Terrain Effects Shading. 

• Enable LOS Connectivity – Allows the editor to display LOS Connectivity 
links when selected for organizations or OPFACs. Enabled by default. 

LOS Connectivity is a thick, dashed, double-headed arrow. The color of the 
arrow indicates whether the two objects could communicate. Connectivity is 
bi-directional and independent of specific device characteristics. 
Connectivity is based on signal loss between the transmitter and receiver 
positions as determined by the Longley-Rice signal propagation model. 

LOS Connectivity exists between OPFACs. Organizations that contain 
OPFACs may display LOS Connectivity links when they are collapsed. 
Enabling LOS Connectivity on an organization enables LOS Connectivity on 
all subordinate organizations and OPFACs. An organization that contains no 
subordinate OPFACs will not display any LOS Connectivity links (it would not 
be able to join a broadcast network or connect via point-to-point links either). 

LOS Connectivity works through broadcast networks and point-to-point 
transmission links to determine all of the OPFACs to which a selected 
Organization or OPFAC could possibly communicate and designates the 
state of that communication link. LOS Connectivity links are attributes of their 
end points. The existence of LOS Connectivity links indicates that one or 
both of the objects at an end of the link has LOS Connectivity enabled. LOS 
Connectivity links disappear when neither end point has LOS Connectivity 
enabled, in either the top-level organization or any subordinate organization 
or OPFAC. LOS Connectivity link coloration is automatically updated when 
either end point moves for any reason, including mouse dragging, attribute 
changes, or animation, to reflect the LOS closure state at the new location.

Figure 3-59   LOS Connectivity
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• Enable Scenario LOS Range – Allows the editor to display LOS Range 
circles and Terrain Effects Shading for selected organizations or OPFACs. 
Enabled by default. 

LOS Range is a circle of a fixed radius placed around the organization or 
OPFAC in question. The circle represents a ground distance and is used as 
a reference for the distance from a particular object. There is a single setting 
for the range that pertains to all LOS Ranges displayed in the entire scenario. 
The LOS Range is a nominal indicator, having no direct connection to a 
particular device's transmission range. The LOS Range does indicate the 
limit of the area within which locations may be sampled for determining LOS 
Terrain Shading. 

Any organization or OPFAC may display an LOS Range without regard for 
the type of device contained within or even if an OPFAC or device is 
contained. The LOS range simply indicates a distance.

Figure 3-60   LOS Range

• Enable LOS Terrain Shading – Allows the editor to display Terrain Effects 
Shading if LOS Range is also enabled. Disabled by default.

Terrain Effects Shading indicates portions of the area around an organization 
or OPFAC where a radio receiver could not receive a hypothetical 
transmission from the object. 

Since the LOS Range defines the limit of the area where LOS Terrain 
Shading is tested, LOS Range must be enabled to view LOS Terrain 
Shading. Disabling LOS Range on an object also disables LOS Terrain 
Shading. 

Like LOS Range, LOS Terrain Shading does not indicate anything about the 
specific OPFACs or devices contained within the designated object. It simply 
indicates that if the object contained a radio transmitter, that radio transmitter 
would or would not be able to communicate with a generic radio device at a 
particular location. 
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LOS Terrain Shading works by testing for LOS closure at a predetermined 
number of sample locations evenly spaced throughout the circle formed by 
the LOS Range. You can select the number of samples to take. 

LOS Terrain Shading updates when the selected object moves for any 
reason, whether by mouse dragging, attribute change, or animation.

Figure 3-61   Terrain Effects Shading

Show LOS > Clear
LOS Ranges

View > Show LOS > Clear LOS Ranges: Clears LOS range circles and terrain 
effects shading for all units.

Show LOS >
Display LOS

Legend

View > Show LOS > Display LOS Legend: Display the LOS Legend, which 
explains the color-coding of LOS Connectivity as well as LOS Ranges and 
Terrain Shading. The Auto-Display Legend checkbox determines whether the 
LOS Legend will automatically appear following the activation of LOS 
visualization. Clearing the checkbox will prevent this automatic display. 

Figure 3-62   LOS Legend

OPFAC Distances
> View OPFAC

Distances

View > OPFAC Distances > View OPFAC Distances: Create OPFAC 
Distance Links (LOS Connectivity Links with a label showing the distance 
between each pair of OPFACs) between all selected OPFACs.
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OPFAC Distances
> Remove OPFAC

Distances

View > OPFAC Distances > Remove OPFAC Distances: Remove any 
OPFAC Distance Links currently existing in the scenario. 

Demands View > Demands > (option): Sub-menu allows you to select whether or not you 
want to show or hide all demands from the view.

Circuits View > Circuits > (option): Sub-menu allows you to select whether or not you 
want to show or hide all circuits from the view.

Paths View > Paths > (option): Sub-menu allows you to select whether or not you 
want to show or hide all paths from the view.

Wireless Domains View > Wireless Domains > (option): Sub-menu allows you to select whether 
or not you want to show or hide all wireless domains from the view.

Annotations View > Annotations > (option): Sub-menu allows you to select whether or not 
you want to show annotations in the subnet, and show, hide, minimize or clear 
annotation balloons from the view.

Visualize Protocol
Configuration

View > Visualize Protocol Configuration > (option): Control the display of 
protocol configuration using the following options:

• IP Interface Status – Shows whether the connected interface is active or 
shutdown. A green up arrow indicates that interface is active whereas a red 
down arrow indicates that the interface is shutdown. 

• IP Routing Protocols – Shows the routing protocols that are configured on 
the router interfaces. 

• IP Address Types – Shows the IP address types on the network by color, 
along with a legend to explain the color-coding. 

• IP QoS Configuration – Shows the IP QoS configuration on the links. 

• IP Security Configuration – Shows the packet filtering security configured 
on the links. 

• IP Tunnel Configuration – Shows the router tunneling configured on the 
network. 

• BGP Peers – Shows the BGP peering (neighbor) relationships in the 
network. EBGP confederation peers are shown in dark green, EBGP peers 
are shown in blue, all other colors indicate IBGP peers. You can view the tool 
tip of a peering visualization for more information about the peers. For 
networks using route reflection, the visualization also indicates if a router is 
a reflector or a client. 

•  OSPF Area Configuration – Shows the OSPF areas configured on the 
router interfaces. 
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• ATM Routing Domains – Shows which ATM routing protocols that are 
configured on the switch ports. 

•  VLAN Configuration – Shows the VLANs configured in the network.

• Clear Visualization – Removes all protocol configuration visualizations from 
the workspace. 

Visualize Link
Loads

View > Visualize Link Loads > (option): Control the display of link loads using 
the options discussed below.

Visualize Link
Loads > Settings

View > Visualize Link Loads > Settings: Designate your choice of link load link 
colors and thickness.

Figure 3-63   Link Load Visualization Settings dialog box

• Color Settings table – Lists the colors to use when visualizing link loads, 
and shows the utilization value that corresponds to each color. The Lower 
Limit number represents the percentage of the link that is utilized. 

• Width Settings table – Lists the link thickness to use when visualizing link 
loads, and shows the throughput value that corresponds to each link 
thickness.

• Preview button – Applies the current settings to the network. This button 
appears only if link load visualization is enabled.

• Restore Defaults button – Resets the dialog box to the default link 
visualization settings.

Visualize Link
Loads > Color by

Link Load

View > Visualize Link Loads > Color by Link Load: Set the link colors and 
thickness based on the link’s peak, average, or current utilization (depending 
upon which one you choose in the Color links based on data from and using 
the drop-down list boxes) and throughput statistics respectively.
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The recorded statistic values and the peak time are reported in the display that 
appears when you move your mouse over any link. These statistics were 
collected from a Capacity Planning Evaluation. The link statistics are computed 
taking into consideration the entire duration of the Capacity Planning 
Evaluation.

You must first run a Capacity Planning Evaluation before you can visualize 
utilization.

Figure 3-64   Color Links by Load dialog box

Visualize Link
Loads > Clear
Visualization

View > Visualize Link Loads > Clear Visualization: Removes all link load 
visualizations from the workspace.

Visualize Link
Loads > Show

Legend

View > Visualize Link Loads > Show Legend: Displays a legend that explains 
the current link load visualization settings.

Scenarios Menu

New Scenario Scenarios > New Scenario or press <Ctrl>+<Shift>+<N>: Create a new blank 
scenario.

1) Enter a name for the new scenario in the New Scenario Name field, and 
then click OK.

Figure 3-65   Creating a New Scenario

The new scenario is blank and contains no data. The Scenario Builder 
indicates in the title bar the current open scenario.
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Duplicate Scenario Scenarios > Duplicate Scenario or press <Ctrl>+<Shift>+<D>: Create an 
exact duplicate of an existing scenario under a new name. 

1) Enter a name for the new scenario in the Duplicate Scenario Name field, 
and then click OK.

Figure 3-66   Duplicating a Scenario

The new scenario is an exact copy of the current scenario, which can serve 
as the baseline scenario. The Scenario Builder indicates in the title bar the 
current open scenario.

Manage Scenarios Scenarios > Manage Scenarios: View each scenario in the project and its 
status. Buttons and drop-down menus enable you to do the following:

• Add new scenarios,
• Duplicate scenarios,
• Delete scenarios,
• Run a simulation,
• Change the simulation duration,
• Delete results, and
• Reorder scenarios in the list.

Click in each table cell to edit its contents. Brackets indicate a change to the 
scenario is requested, and will be applied when you click OK. 

Figure 3-67   Manage Scenarios dialog box
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• Project Name field—Saves the project under a different name. If you enter 
a new name and save your project, the project is saved under the new name. 
This is similar to the File > Save Project As... feature.Scenario Table 
columns: 

— #: Changes the order of the scenarios in the table. 

— Scenario Name: Lists the name of each scenario. 

— Saved: Shows if a scenario is saved or unsaved. Clicking within a cell 
also lets you delete a scenario. 

— Results: Shows the state of the results of each scenario simulation. 
“Uncollected” means that a probe file exists, but you have not run a 
simulation. “Out of date” means that the set of chosen results, simulation 
configuration, or network model has changed since the results file was 
created. 

— Sim Duration: Specifies the length of time to run the simulation. Use it 
with the Time Units column. 

— Time Units: Specifies the time units that apply to the simulation exam: 
seconds, minutes, hours, days, or weeks. Used with the Sim Duration 
column.

• Delete—Deletes scenarios that you select. 

• Discard Results—Deletes results from a scenario. 

• Collect Results— Runs the simulation and collects statistics you specify. 

• OK—Closes the Manage Scenarios dialog box, and runs any simulations 
that are waiting. 

• Cancel—Closes the Manage Scenarios dialog box without making changes. 

Previous Scenario Scenarios > Previous Scenario or press <Ctrl>+<Up>: Display the previous 
scenario in the project.

Next Scenario Scenarios > Next Scenario or press <Ctrl>+<Down>: Display the next 
scenario in the project.

Switch To
Scenario

Scenarios > Switch To Scenario: Switch between the scenarios associated 
with a project, as a project can have scenarios. A black bullet indicates the 
current scenario open in the Scenario Builder.

1) Select the desired scenario.

Figure 3-68   Switch between scenarios
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When the project is saved, the scenario that is currently open is set as the 
default scenario.

Set Classification Scenarios > Set Classification: Set the classification of a scenario. Every 
project in JCSS has a classification. The default classification is Unclassified.

Select a classification from a drop-down list or specify a user-defined 
classification. Once the classification is set, the classification string will always 
appear at the top-left and bottom-right hand corners of the workspace.

Set Scenario
Documentation

Scenarios > Set Scenario Documentation: Access a free-form text box to 
enter scenario purpose, traffic, and topology notes to be stored with the 
scenario for documentation purposes. The scenario’s Operational Scenario In 
Time (OPSIT) name is also entered here.

Figure 3-69   Scenario Documentation dialog box

1) Type desired text in the Scenario Documentation field.

2) Enter desired value in the OPSIT Name field.

3) Click OK.

Import Scenario Scenarios > Import Scenario > (option): Import scenarios from the sources 
discussed below.

Import Scenario >
Subordinate

Response

Scenarios > Import Scenario > Subordinate Response: The Lead Planner 
imports subordinate response files from the Subordinate Planners into the 
original scenario. 

1) Open the original project (or the subordinate query file if you are an 
Intermediate Planner.)
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2) Select Scenarios > Import Scenario > Subordinate Response, and 
choose a response file received from a subordinate. The dialog box below 
displays. 

Figure 3-70   Response File Information dialog box

The edit area at the top of the dialog box will display the message that the 
Subordinate Planner entered when generating the response (this will 
contain the string “<none>” if the subordinate did not enter a message). The 
other edit area will display the hierarchical names of the units in the 
subordinate response that still have outstanding queries (once again this 
will contain the string “<none>” if there are no such units). These are shown 
to the Lead Planner because they are an indication that the response is an 
interim response. The Display list of changes during import checkbox 
controls whether or not the Changes dialog box will appear, as discussed 
later in this section.
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3) Click the Continue button to proceed with the import. During the import, if 
the subordinate has made any changes to external associations (links, 
satellite links, and broadcast networks that connect an editable unit to a 
locked unit), the Lead Planner will be given options to import or ignore the 
changes. This will be accomplished through a treeview dialog box that 
breaks down the different types of external associations according to the 
type of change (add, delete, or modify). 

Figure 3-71   External Associations

Items that are checked off will be imported, and unchecked items will be 
ignored. All items will be checked by default when the dialog box opens. 
Note that this dialog box will not appear if no changes were made to 
external associations.
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4) Proceed with the import by clicking the Continue button. If the Display list 
of changes during import checkbox was checked on the Message dialog 
box, the next step in the import process will be to display the Changes Made 
to the Original Scenario dialog box, which is shown below. 

Figure 3-72   Changes Made to the Original Scenario

Note that this dialog box will display directly after the Response File 
Information dialog box if there were no modifications to external 
associations. Otherwise, it will display after clicking the Continue button on 
the External Associations dialog box. The main feature of this dialog box is 
a treeview that displays all of the changes that will be made to the Lead 
Planner’s scenario if the import is completed. For each object that was 
changed by the subordinate, the treeview lists whether it was added, 
deleted, or modified. If it was modified, you will be able to expand the entry 
to see more information about the modifications that were made. For most 
objects, this will be a list of the attributes that changed, along with the old 
and new values. However, organizations and OPFACs are more complex 
since they can have child objects. So, expanding one of those entries will 
show a listing of the types of child objects that were changed, and inside 
each of those will be more information about the exact changes that were 
made to the child objects. The above example shows how the individual 
changes within an organization can be viewed. 
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a) The contents of the treeview can be exported to HTML by clicking the 
Export To HTML button. Clicking the Cancel Import button will stop the 
import process. 

5) Click the Continue button to perform the actual import. After the import is 
complete, a “Subordinate Response import complete” message will be 
printed in the message buffer.

After this import process is repeated for each of the subordinate response files, 
the Lead Planner will have a consolidated view of the entire scenario based on 
the requirements specified by his subordinates.

Import Scenario >
From NETWARS

Scenarios > Import Scenario > From NETWARS: Combine the organization 
structures of different scenarios automatically, thereby eliminating the need to 
duplicate another scenario’s organization structure manually. The organization 
structure of the imported scenario is added to the top level of the current 
scenario.

1) In the Import Scenario dialog box, select the scenario for which the 
organization structure is to be imported. 

2) Click Open. The newly added organization structure displays both in the 
treeview and in the workspace.

Import Scenario >
From OPNET

Modeler

Scenarios > Import Scenario > From OPNET Modeler: Import scenarios 
already developed in the OPNET Modeler and create the JCSS specific 
objects/hierarchy. The location information is intact in the newly created 
OPFACs and organizations. The new structure is below the newly created 
scenario to which the modeler scenario is imported.

1) Create a new Scenario. 

2) Select Scenarios > Import Scenario > From OPNET Modeler. 

3) In the subsequent Import Scenario from OPNET Modeler dialog box, select 
the scenario for which the organization structure is to be imported. 

4) When prompted to save OPFACs, click OK. Saving the OPFACs is 
necessary to reuse the OPFACs in other scenarios and to run simulation. 
The newly added organization structure displays both in the treeview and 
in the workspace.

Import Scenario >
From XML

Scenarios > Import Scenario > From XML: Import a scenario in XML format 
into JCSS. 

1) Create a new project (or start with an already existing project).
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2) Choose Scenarios > Import Scenario > From XML. 

3) Select the XML file to be imported and then click Open to start the import 
process. At the end of this process, the scenario represented by the XML 
file has been imported into the current project.

Import Scenario >
TNAPS to XML

Scenarios > Import Scenario > TNAPS to XML: Convert a TNAPS file into an 
equivalent JCSS XML representation of the network.

The converter reads transmission nodes, data network, circuit switch network, 
links, circuits, transmission node layout, site mux plan, site equipment inventory, 
mode and link properties/configurations, and ports. It does not read message 
switch network, local long circuits, unrouted circuits, circuits with sub-groups 
and sub-channels, and TNAPS annotations.

1) Select Scenarios > Import Scenario > TNAPS to XML to run the TNAPS 
converter. The TNAPS to NETWARS Converter dialog box displays.

Figure 3-73   TNAPS to NETWARS Converter dialog box

2) Select a TNAPS 6.0 file to open and an XML filename to which you want to 
save, and then click OK.

The TNAPS file converts into XML, and a message box displays to inform 
you of its success. Click OK to close the message box.

3) Now you can create a new project in the Scenario Builder and import the 
new XML file into it (select Scenarios > Import Scenario > From XML.) 
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Export Scenario Scenarios > Export Scenario > (option): Export scenarios to the formats 
discussed below.

Export Scenario >
Subordinate Query

Scenarios > Export Scenario > Subordinate Query: Export a subordinate 
query file and send it to Subordinate Planners to get the subscriber 
requirements. Various Subordinate Planners fill different portions of the 
scenario. The Lead Planner marks portions of the scenario to be editable by a 
Subordinate Planner by setting owner information on units. Units will be editable 
for the subordinate if the organization of the Subordinate Planner matches the 
organization field in the owner information. Otherwise, units will be locked; 
therefore, the Lead Planner must remember to set the correct owner information 
on units before exporting the subordinate query file.  

1) If the scenario contains any units that do not have owner information set, 
the planner will be warned and given a chance to set the owner information 
before the subordinate query file is created. The dialog box shown below 
contains un-owned units in the current scenario in a treeview format. 

Figure 3-74   Unowned Units dialog box

Double-click on a unit to set owner information, which will display the Set 
Owner dialog box. Expand the treeview on an organization and set owner 
on individual sub-units. Note that you can continue the export process with 
un-owned units in the scenario, however, those un-owned units will become 
locked to the Subordinate Planners.
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2) Specify a name for the subordinate query file, option to automatically send 
the subordinate query file via email, and the functional areas that will be 
available to the Subordinate Planner in the following dialog box. 

Figure 3-75   Export Subordinate Query File

The Lead Planner has the option in the dialog box to email the exported 
subordinate query to a recipient. If the email option is selected and the 
recipient’s email address specified, not only is the file saved to the disk, but 
it is sent to the Lead Planner’s default email application using MAPI. If the 
email application is configured for MAPI server support, an email message 
is created addressed to the recipient’s email address with the subordinate 
query file attached to the email. Preview the message and click the Send 
button. If the email application is configured for MAPI to automatically send 
the email, the email is sent without the preview option. Much of the behavior 
of MAPI is dependent on the particular email application and its MAPI 
configuration. If the auto-email option is not selected, send it to the 
Subordinate Planners by whatever means available, such as FTP or use a 
location on a shared network drive. 

3) Click OK; the subordinate query file is written to the disk and is located in 
<NETWARS path>\User_Data\Projects\<current 
project>\<current phase>\Subordinate_Queries\.

4) Save the project directly by clicking the Yes button.

Once the subordinate query file has been generated, all units with yellow 
marked icons will change to an orange folder icon indicating that there’s an 
outstanding query.

Figure 3-76   Outstanding Query in a Scenario
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Export Scenario >
Subordinate

Response

Scenarios > Export Scenario > Subordinate Response: Send the scenario 
back to the Lead Planner after the Subordinate Planner has elaborated the 
network and specified the subscriber requirements. 

1) A check will be performed to see if there are any empty Requirements 
Matrix entries on any editable units. Any Requirements Matrix entries that 
have zero requested bandwidth and an empty answer field are considered 
to be empty. If there are empty entries, an alert dialog box as shown below 
will display.

Figure 3-77   Alert dialog box when Exporting Response

This dialog box alerts the Subordinate Planner with a list of organizations 
and OPFACs that have at least one empty Requirements Matrix entry. 
Continue the export process or cancel the export.

2) If the Subordinate Planner clicks the Continue button, or if there were no 
empty fields, the Export Subordinate Response dialog box displays.

Figure 3-78   Export Subordinate Response dialog box
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This dialog box serves three purposes: specify the save location for the 
response file, enter a message for the receiving planner, and email the 
response file. 

3) To specify the save location, either type the full path in the Save Location 
field, or click the Browse button and choose the path from the resulting file 
chooser. 

4) To enter a message for the receiving planner, type the message in the 
Message for the receiving planner field. The message will be shown to 
the receiving planner during the response import process. 

5) To automatically email the response file that is generated, check the Email 
this response file checkbox and enter the destination email address in the 
Recipient email address field. If the recipient’s email address is specified, 
MAPI is used to create a new email message in the Subordinate Planner’s 
default email application. The subordinate response file is attached to this 
email. Depending on the MAPI configuration of the default email 
application, the email may or may not be previewed by the Subordinate 
Planner. Much of the behavior of MAPI is dependent on the particular email 
application and its MAPI configuration. If the auto-email option is not 
selected, send it to the Subordinate Planners by whatever means available, 
such as FTP or use a location on a shared network drive.

6) Click OK.

Export Scenario >
To XML

Scenarios > Export Scenario > To XML: Export the contents of a scenario to 
XML. This allows for easy transfer of projects and scenarios between 
computers. The XML file is written to the folder that contains the scenario file. 
The exported XML file contains all the information in the scenario, except for 
some traffic information.

Export Scenario >
To JNMS

Scenarios > Export Scenario > To JNMS: Export the scenario to JNMS.

Export Scenario >
To Visio

Scenarios > Export Scenario > To Visio: Export the scenario to Visio XML. A 
<scenario name>.xml file and <scenario name>.vdx file are created in the 
scenario folder.
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Reports Scenarios > Reports > (option): Access the reports to view summary 
information in a table format. These options, as well as steps for working with 
these features, are discussed below.

Reports > CCSD
Summary

Scenarios > Reports > CCSD Summary: View a CCSD Summary report.
.

Figure 3-79   CCSD Summary Report

Reports >
Free-Text

Questions

Scenarios > Reports > Free-Text Questions: View a summary report of 
free-text questions attached to organizations, OPFACs, and devices. This 
provides a mechanism for the planners to communicate with each other using 
free text. This is especially useful when a Subordinate Planner wants to 
communicate with a Lead Planner since the mission analysis question interface 
cannot import back new questions added by the Subordinate Planner.
.

Figure 3-80   Free-Text Questions Report
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These questions and answers are stored as attributes on the objects and can 
be accessed by right-clicking on the object and selecting Edit Attributes and 
clicking the Value column next to the Free-Text Questions attribute.

Figure 3-81   Free-text Questions Stored as Object Attributes

Reports > IP
Addresses

Scenarios > Reports > IP Addresses: Examine the IP addresses for all 
connected interfaces on the devices. The IP Address Summary report contains 
the device name, interface name, IP address and subnet mask information. 
Buttons at the bottom of the table export the contents to an Excel file or to a 
HTML file, and print the contents to the default printer, respectively. You cannot 
edit any of the fields in this table.

Figure 3-82   IP Address Summary Report
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Reports > Links Scenarios > Reports > Links: View a list of all links in the scenario along with 
some of the key attributes like name, bandwidth, type of link, etc. Buttons at the 
bottom of the table export the contents to an Excel file or to a HTML file, and 
print the contents to the default printer, respectively.

Figure 3-83   Links Summary Report

Reports > Mission
Analysis

Questions

Scenarios > Reports > Mission Analysis Questions: Every project has a 
default set of mission analysis questions that is automatically included in the 
project when the project is created. Any planner can answer these questions 
using the table interface shown below. Modifications made to the mission 
analysis questions and answers get exported to the Subordinate Planner; 
however, modifications made by the Subordinate Planner will not get imported 
back to the Upper-level Planner during the import response process.

Figure 3-84   Mission Analysis Questions Report
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The mission analysis questions are stored in five different sections: Situation, 
Mission, Execution, Admin & Logistics and Command & Control. When the 
Mission Analysis Questions table is launched, questions under the Situation 
section are displayed. The planner can view questions in the other sections by 
clicking on the appropriate button below the table. The label on top of the table 
represents the current section. 

1) Click on either the Question or Answer/Comment cell to enter the desired 
text. 

2) Click the OK button to populate the question/answer back into the table. 

Figure 3-85   Answering a Mission Analysis Question

a) Add or delete a question from the Mission Analysis Questions table by 
selecting the Add Question or Delete Question buttons. 

b) Print the content of the Mission Analysis Questions table to the default 
printer by clicking on the Print button. The printout contains all mission 
analysis questions and answers including the last edited by information 
divided by each section.
TR-3-74 JCSS/Release 7.0



JCSS Technical Reference Manual 3—Scenario Builder
c) The content of the Mission Analysis Questions table can be exported to 
an Excel file or to an HTML file by clicking the Export to File or Export 
to HTML buttons, respectively. Specify the target location on disk to 
store the exported file.

d) In addition to manually typing in mission analysis questions for each 
project, you may also import additional mission analysis questions in to 
the Mission Analysis table. Import this information by selecting the 
Import button. A file chooser dialog box launches; select a desired text 
file and select the Open button. 

Note—The text file must be tab-delimited and must follow the same format as 
the Mission Analysis defaults file, i.e., MissionAnalysis.gdf.

Once you have selected the file from which the additional Mission Analysis 
questions are to be loaded, the table will be updated to display this newly 
appended information. Duplicate mission analysis questions will not be 
appended to the dialog box.

Reports >
Requirements

Scenarios > Reports > Requirements: View a summary report of the 
bandwidth requirements for all the organizations in the scenario. When this 
table is launched, there is one row for every top-level organization in the 
scenario. Each row has the name of the organization followed by the required 
bandwidth for each service type. The default functional area is Voice. 

1) View the requirements summary for a different functional area by clicking 
on the appropriate button.

Figure 3-86   Requirements Summary Report
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a) Click on the organization name to view its sub-organizations examine a 
breakdown of the bandwidth requirement for each sub-organization.

b) Export the contents of the table to an Excel spreadsheet, to HTML, or 
send it directly to a printer. 

Reports > SLD
Summary

Scenarios > Reports > SLD Summary: View a list of all SLDs in the scenario 
along with some of the key attributes like name, location, equipment, etc. 
Buttons at the bottom of the table export the contents to an Excel file or to a 
HTML file, and print the contents to the default printer, respectively.

Figure 3-87   SLD Summary Report

Reports > Task
Organization

Scenarios > Reports> Task Organization: View the Task Organization 
Report, which provides basic information about organizations within the mission 
plan, such as organization name, parent organization, and location. The report 
displays various JCSS and JNMS attributes of the organization; the values in 
the columns are not editable.

1) To view rolled-up device information for an organization, click its cell in the 
Device Information column.

Figure 3-88   Task Organization Report
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The Device Information Report for the organization displays.

Figure 3-89   Device Information Report

Reports >
User-Defined

Reports

Scenarios > Reports> User-Defined Reports > (option): Select from these 
options to open user-defined reports in live mode, and specify the content you 
want to include in your reports.

Reports >
User-Defined

Reports > Open
Live Report

Table...

Scenarios > Reports> User-Defined Reports > Open Live Report Table...: 
Open one or more user-defined report tables in live mode. This means the 
tables will not only show the corresponding values given the current selection 
set, but will also automatically repopulate themselves whenever the selection 
set changes. This provides a quick way of surveying the relevant attributes of a 
number of network objects without generating a full report and searching for the 
rows of interest. It can also sometimes be more handy than, for example, 
opening the Edit Attributes dialog box for each of the objects of interest.

Note—This functionality is supported independently of the Generate Report 
from Template... functionality, so it will neither create a new report nor discard 
any existing report information. 
JCSS/Release 7.0 TR-3-77



3—Scenario Builder JCSS Technical Reference Manual
1) Select Scenarios > Reports> User-Defined Reports > Open Live Report 
Table... The Live User-Defined Report Tables dialog box displays.

Figure 3-90   Live User-Defined Report Tables dialog box

2) Expand the top-level category subtree and left-click on the desired table 
entry to select it for opening. You can select multiple tables by holding down 
the <Ctrl> key while left-clicking or by clicking-and-dragging a rectangular 
selection. Selecting a top-level category tree row itself does not imply 
selecting all or any of its tables; it is simply ignored. 

3) Click Show to build and open individual user-defined report table dialog 
boxes for each of the tables you have selected. Click Close to close this 
dialog box but not any of the user-defined report tables you might have 
opened. 
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Reports >
User-Defined

Reports >
Generate Report
from Template...

Scenarios > Reports> User-Defined Reports > Generate Report from 
Template...: Specify the content you want to include in your report.

1) Select Scenarios > Reports> User-Defined Reports > Generate Report 
from Template... The Generate User-Defined Report dialog box displays.

Figure 3-91   Generate User-Defined Report dialog box

2) Specify which tables of which categories should be included in the report 
by selecting them in the treeview. To select an entire category of tables, 
left-click on the top-level category entries. To select an individual table, 
expand the top-level category subtree and left-click on the table entry. 
Selected tables and categories show a green check mark. Categories with 
some but not all of its tables selected will display a green dot instead. 

3) Click the Include only selected objects in report checkbox if you want 
table data to be collected only for objects that are currently selected in the 
network. 

4) Click the Ignore views checkbox if you want table data to be collected even 
for objects that are not in the current view or views of the network. 

5) Click the Send reports to the Report Server (<host>) checkbox if you 
want to send reports to the Report Server. This option is active only when 
a Report Server license is available. 

a) Specify a name for the report in the Report Server in the Report name 
as it will appear on the Report Server text field. 
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6) Click Generate to generate the table data for all of the selected tables. Your 
content settings are saved and will be reloaded the next time you generate 
a report. Click Close to close this dialog box but retain any table selections. 

Generate Scenario
Web Report

Scenarios > Generate Scenario Web Report: Choose the location where you 
want to save the scenario web report, and then generate the report.

Figure 3-92   Generate Scenario Web Report dialog box

Click Generate to create the scenario web report. Navigate to the folder in which 
you saved the web report, and open it in your chosen web browser.

Figure 3-93   Displaying Scenario Web Report in Web Browser
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Generate Scenario
Bitmap

Scenarios > Generate Scenario Bitmap: Export a bitmap image of the model 
in the active window and set parameters of the export file.

Figure 3-94   Model Image Capture Preview dialog box

Use the bitmap image controls to set the elements of the bitmap: 

• Image Width: Lets you set the bitmap width using the up and down arrows. 
The height is adjusted accordingly. 

• Capture Visible Area Only: Captures only the area visible in the editor 
window. When unselected, the entire subnetwork or model is captured. 

• White background: Sets the bitmap background color to white, which 
improves contrast and visibility. 

• Scale Image Directly: Sets the bitmap to the same level of detail as seen in 
the editor, regardless of the bitmap size. 

• Adjust Resolution: Adjusts the level of detail based on the target bitmap 
size, that is, reduces the level of detail in smaller bitmaps and increases 
detail in larger ones. 

Click Save to open the Select Captured Image Location dialog box, and select 
the directory to which the bitmap file is saved and name the file. Click Close to 
close the Model Image Capture Preview dialog box.
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Topology Menu

Open Object
Palette

Topology > Open Object Palette or click the Open Object Palette toolbar 
button: Access object palettes. JCSS provides a variety of object palettes which 
contain nodes, devices, links, and paths (circuits.) Once a new project is 
created, start building the network topology using the models provided in the 
object palettes. All of these objects are easily added to a scenario using the 
drag-and-drop technique. 

Displaying Object Palettes

The object palettes display in either a Tree view style or an Icon view style, 
depending upon how your environment preferences are set.

Figure 3-95   Object Palette by Tree View
TR-3-82 JCSS/Release 7.0



JCSS Technical Reference Manual 3—Scenario Builder
In the Object Palette Tree view, click the Open Palette In Icon View icon button 
(upper left corner) to replace this dialog box with the Object Palette Icon view 
that displays only a single palette file at a time. The palette file initially displayed 
will be either the default palette of the scenario or, if the tree selection is within 
a particular palette file tree element, the palette that contains the current tree 
selection. 

Figure 3-96   Object Palette by Icon View

Note—The view style in which the object palettes display changes based on the 
value specified for the network_palette.style environment preference. You 
may set the object palette view style preference via Edit > Preferences > 
Advanced.

Adding Objects to a Scenario

Adding an instance of a device model to a network (from either style object 
palette) is as simple as dragging an icon to the workspace.

1) Select and drag an icon from the palette to the workspace to create a new 
object. The newly created object in the network is an instance of the 
corresponding model.

Whenever possible, planners are encouraged to use the NETWARS 
standard models as opposed to the more generic models contained in the 
other model palettes. The NETWARS models are designed to gather 
specific Measures of Performance (MOPs), which will be useful when 
modeling the network at a later point. 
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Note—JCSS device models must be used as endpoints for sending and 
receiving traffic. If generic device models are used as endpoints, JCSS will not 
be able to produce the traffic.

2) Once you drag an icon from the palette to the workspace, you may continue 
creating objects of the same type and model by clicking again in the 
workspace as needed.

3) Right-click in the workspace to stop creating new objects. 

Some object types, like paths and demands, use a right-click menu during 
the creation process. In those cases, you should pick the appropriate menu 
operation to complete or cancel the object creation.

4) Right-click a device icon in the workspace, and open a shortcut menu to set 
the name of the device or set different model attributes that influence the 
behavior of the model. Device attributes can be changed by clicking on a 
cell and typing or selecting a new value.

Using Dynamic Listing Option for Object Palettes

The software provides you with the option of displaying the object palettes in two 
modes: alphabetical or dynamic. In alphabetical mode, the palettes display in 
alphabetical order; in dynamic mode, the five most recently used object palettes 
display at the top followed by the alphabetical listing.

Figure 3-97   Dynamic Palette Listings Mode
 

The order in which the palettes display changes based on the value specified 
for the palette_listing environment preference. You may set this preference via 
Edit > Preferences > Advanced.
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Configuring Custom Palettes

1) Click the Configure Palette button located at the upper-right corner of an 
Object Palette Icon view dialog box. The Configure Palette dialog box 
displays.

Figure 3-98   Configure Palette dialog box

2) Click the appropriate Models button to add or remove specific models or 
units from the palette. 

3) Toggle the Status column to either included or not included to add or 
remove models units from the palette. To conclude, click OK, specify the 
name of the palette in the Save As dialog box, and then click OK to save 
the new configuration.

Figure 3-99   Select Included Entries dialog box
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Open Library
Treeview

Topology > Open Library Treeview: Add Organizations and OPFACs to 
scenarios by dragging and dropping them from the Library Treeview onto the 
Scenario Builder window.

Figure 3-100   Library Treeview

Open Annotation
Palette

Topology > Open Annotation Palette: Add graphic elements to a scenario to 
help organize it visually or call attention to key elements. The annotation palette 
includes five types of objects: Box, Ellipse, Line, Text, and Icon.

1) Click on the desired annotation object in the annotation palette.

Figure 3-101   Annotation palette

2) Create: 

a) A box or an ellipse by dragging an outline of the shape in the workspace.
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b) A line by clicking in the workspace for the start of the line and each 
vertex (direction change) and then double-clicking to end.

c) Text by clicking on the workspace where the text is to be inserted, and 
then entering text in the text edit pad that displays.

d) An icon annotation by clicking in the workspace where you want the 
annotation to appear. To specify the icon to use, right-click on the 
annotation object and choose Edit Attributes; then set the “icon name” 
attribute. You can specify an icon from any icon database included in 
your model directories.

3) When you have finished creating an annotation object, you can:

a) Click to define another box, ellipse, line, or icon.

b) Right-click to stop creating boxes, ellipses, lines, or icons.

c) Click in the annotation palette to create a different type of annotation.

4) Modify the annotation object’s attributes to customize its appearance. 
Select the object, and then right-click and select Edit Attributes to display 
the Attributes dialog box and make your changes.

Adding an annotation object does not affect a scenario’s functionality in any 
way.

Import Topology Topology > Import Topology > (option): Import various files relating to 
topology. The following import options are discussed in the sections below: 

• From Device Configurations
• Convert DCI to NETWARS Scenario
• Link Specification
• From Configlets

Import Topology >
From Device

Configurations

Topology > Import Topology > From Device Configurations: Device 
Configuration Imports (DCI) lets you generate a network model by importing 
configuration data for Juniper routers, Cisco routers, and Cisco Catalyst 
switches. DCI uses the data in the configuration files to set the OPNET 
attributes that control routing and switching behavior.

OPFACs that are created as part of the import process will house a single 
device; the icon of that OPFAC will be same as the icon of the device inside.

Note—This section does not discuss in detail how the device configurations are 
converted to the network topology from the OPNET core software point of view. 
The discussion is limited to general workflow from the JCSS point of view. 
Consult the IT Guru documentation set, available via Help > Documentation > 
IT Guru Documentation, for complete details.
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1) The device configuration files can be imported in a new scenario or on top 
of an existing scenario. To perform a new import, create a new project. If 
you want to import these files on top of an existing network and then 
selectively add the various imported components to this network, open the 
relevant project.

2) Select Topology > Import Topology > From Device Configurations. 
The Import Device Configurations dialog box displays.

Figure 3-102   Import Device Configurations dialog box

3) Select how this import affects the existing topology (if one exists):

a) Replace entire model radio button – Use this option when creating a 
new project or scenario, or when you want to overwrite the existing 
topology.

b) Merge with existing model radio button – Use this option to add 
devices to the existing topology. If some of the devices are already in the 
topology, these devices are replaced (that is, re-imported) using the 
configuration files of this import. The Mapping Editor displays upon 
import so that users can map devices to the current network.

c) Reimport configurations for selected devices radio button – Select 
this option to reimport the device configuration files of the nodes that are 
currently selected in the workspace. DCI imports the files from the same 
location specified in the original import. 

d) Reimport configurations for modified devices radio button – Select 
this option to reimport any device configuration files in the current 
topology that were modified since the last import. DCI imports the files 
from the same location specified in the original import. 
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4) Specify where the configuration files are located by vendor(s), directory 
path and whether to include subfolders in this directory path table. If you 
previously imported device configuration files, your previous selection is 
configured; you can keep the selection or change it. Multiple directories are 
supported.

5) Select the desired import options:

a) Create nodes to represent external ASes – Creates dummy objects to 
represent missing external BGP (EBGP) neighbors.

b) Create nodes to represent edge LANs – Creates LAN objects for 
active router interfaces that are not connected. By connecting these 
interfaces to LAN objects, no active router interfaces are left 
unconnected after the import. 

c) Create PVCs – Creates PVCs based on network data, if available; if this 
is not available, PVCs are created for all possible pairs of devices in the 
network.

d) Generate import log – Creates a log of actions during the import. You 
can access the log through the object or workspace pop-up menus after 
the import.

6) Specify one or more model assistant files. These files can be model 
assistant files, which have a .ma extension, or import assistance files, 
which have an .ia extension. Consult the IT Guru documentation set, 
available via Help > Documentation > IT Guru Documentation, for 
information about model assistant files.

7) Click Import. During the import process, various nodes can be created by 
the core DCI process for the end devices. The following table lists the 
corresponding NETWARS models that will be created:.

Table 3-2 DCI And NETWARS End Station Models

DCI End Station Models NETWARS End Station Models

ppp_wkstn_adv nw_ppp_wkstn_adv

10BaseT_LAN nw_ethernet_wkstn_adv

100BaseT_LAN nw_ethernet_wkstn_adv

1000BaseX_LAN nw_ethernet_wkstn_adv

fr_wkstn_adv No current support.

atm_wkstn_adv No current support.

16TR_LAN No current support.

FDDI_LAN No current support.
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8) If the Merge with existing model import option was selected, the Node 
Map Editor displays.

Figure 3-103   Node Map Editor dialog box

a) Add – Adds a node (router) from the imported network to the original 
network. Successful addition of the node requires that you select a node 
in the Source Network treeview and an OPFAC/organization in the 
target network before the addition can be performed.

b) Assign – Assigns or map a node (router) from the imported network to 
the original network. Successful assignment of the node requires that 
you select a node in the source network treeview and another node in 
the target network before the addition can be performed.

c) OK – Closes the mapping editor dialog box and performs any link 
creation as necessary.

d) Cancel Import – Cancels any changes made to the network due to 
mapping or assignment and brings you back to the original scenario.
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e) Auto-Mapping Feature – Performs the mapping if router configuration 
files have been previously imported into this scenario. The Perform 
Auto-Mapping dialog box displays to confirm the mapping of the nodes 
based on the mapping performed in the previous imports. 

Figure 3-104   Perform Auto-Mapping

f) Manual or Auto – Continues with the auto mapping or manual mapping. 
The main dialog box for the node mapping will still display allowing you 
to map any nodes that were not mapped as part of the auto-mapping 
operation.

g) Cancel Import – Cancels the import procedure.

Import Topology >
Link Specification

Topology > Import Topology > Link Specification: Import link information 
from text files. The link specification is separated into two sections—the JCSS 
attributes and the standard OPNET attributes. If a link with the specified 
hierarchical name already exists in the scenario, the changes are applied to the 
existing link. If there are no links with the specified hierarchical name, a new link 
is created with the specifications provided in the text file.

Import Topology >
From Configlet

Topology > Import Topology > From Configlet: Import topology from 
configlets (configuration files.) Only those devices which have configuration files 
associated with them can be re-imported via this feature.

Export Topology > Export > (option): Export various file types relating to topology. 
The following export options are discussed in the sections below: 

• Attributes for Selected Objects
• Attributes for All Objects
• Selected Area to Bitmap
• Visible Area to Bitmap

Export > Attributes
for Selected

Objects

Topology > Export > Attributes for Selected Objects: Export the selected 
object attributes to text files. 

1) Select the objects of interest (e.g., nodes and links). 
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2) Choose the Topology > Export > Attributes for Selected Objects option. 
The Export Attributes for Selected Objects dialog box displays. 

Figure 3-105   Export Attributes for Selected Objects dialog box

3) After making the appropriate selection select OK. The Save As dialog box 
displays prompting you to select the desired location and specify the file 
name to which to save the attribute text file on the hard drive.

Export > Attributes
for All Objects

Topology > Export > Attributes for All Objects: Export all object attributes to 
text files. 

1) The Export Attributes for All Objects dialog box displays. 

Figure 3-106   Export Attributes for All Objects dialog box

2) After making the appropriate selection select OK. The Save As dialog box 
displays prompting you to select the desired location and specify the file 
name to which to save the attribute text file on the hard drive.

Export > Selected
Area to Bitmap

Topology > Export > Selected Area to Bitmap: Specify an arbitrary area on 
the workspace and export the contents to an image file.

1) Drag a rectangle around the area of interest for the screen capture.

2) In the Model Image Capture Preview window, set desired image options 
and click Save.

3) In the Select Captured Image Location dialog box, choose a file format, file 
name, and location, and then click Save.
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Export > Visible
Area to Bitmap

Topology > Export > Visible Area to Bitmap: Capture the visible area of a 
subnet as a screen shot and save it as a GIF or TIF file.

1) In the Model Image Capture Preview window, set desired image options 
and click Save.

Figure 3-107   Model Image Capture Preview window

2) In the Select Captured Image Location dialog box, choose a file format, file 
name, and location, and then click Save.

3) Click OK.

Model Assistant Topology > Model Assistant > (option): Edit model assistant files, apply the 
data to your network, and save the data to reuse later. A model assistant file is 
an ASCII text file that specifies a set of changes to a scenario. You can specify 
multiple changes in one file, then apply the file to make multiple changes in one 
operation. For example, you can create a model assistant file to:

• Create subnetworks, nodes, and links,
• Set object attributes,
• Import node aliases, and
• Specify object locations.

Model Assistant >
Edit File

Topology > Model Assistant > Edit File: Edit model assistant files.

1) The Edit Model Assistant File dialog box displays. This dialog box contains 
multiple tabbed pages; each page has fields for entering the data you want 
to apply. If you want to edit an existing file, click Load, choose the file to 
load, and click OK. The dialog box updates each tabbed page to reflect the 
data in the loaded file.

2) Specify the information you want to apply on each page (click the tabs to 
view specific pages).

a) If you do not want to apply a certain type of data, leave the page empty.
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b) If you want to reset all settings on all pages and reenter your data, click 
Clear.

c) If you want to save your data to a model assistant file so you can reuse 
it later, click Save.

3) Click Apply to apply your data to the network, or Close to close the dialog 
box without applying your data.

Model Assistant >
Apply File

Topology > Model Assistant > Apply File: Apply the selected model assistant 
file.

Model Assistant >
Open Error Log

Topology > Model Assistant > Open Error Log: View errors that occur when 
the model assistant file is applied to your scenario.

Model Assistant >
Save Current

Topology to File

Topology > Model Assistant > Save Current Topology to File: Create a 
model assistant file based on your current topology.

Create Custom
Device Model

Topology > Create Custom Device Model...: Create your own new device 
models, in addition to using the built-in model objects provided by JCSS and 
creating derived models. Create several different types of network components, 
including routers, bridges, hubs, workstations, switches, LANs, and vendor 
devices. For complete instructions, consult the IT Guru documentation set, 
available via Help > Documentation > IT Guru Documentation.

Link Operations Topology > Link Operations > (option): Use the sub-menu options to perform 
link consistency checks and define valid links between devices using a 
wizard-like feature.

Link Operations >
Deploy Link

Topology > Link Operations > Deploy Link: Quickly define valid links 
between devices using a wizard-like feature.

1) Select two devices (through GUI or Network Browser) and then select 
Topology > Link Operations > Deploy Link (or press <Ctrl> + L.) 

2) If more than one device is present in an OPFAC, the Select Devices dialog 
box displays. Select the desired devices to connect and then click Next.

Figure 3-108   Sample Select Devices dialog box
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If a selected OPFAC has only one device, then the device will be selected 
by default and the Select Devices dialog box will be skipped. If the OPFAC 
doesn’t have a device, an error will be flagged.

This feature will be only applicable to the fixed nodes (only wired ports will 
be considered for selection.)

3) The best default link available and a list of the other applicable link types 
displays. A series of the most common default bandwidths for the selected 
link type is also provided as well as the first available ports applicable to the 
chosen link as default ports. Use the default values or select the desired 
values, and then click OK.

Figure 3-109   Sample Select Link dialog box

An inter-OPAFC link or intra-OPFAC link will be created with the 
user-defined attributes between the two devices, depending on whether the 
selected devices are within one OPFAC or different OPFACs.
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Deploying Satellite Links

Defining satellite links can be performed using a procedure similar to defining 
other links.

1) Select two OPFACs or devices and then select Topology > Link 
Operations > Deploy Link (or press <Ctrl> + L.) 

Figure 3-110   Selecting Satellites for Link Deployment

2) If more than one device is present in an OPFAC, the Select Devices dialog 
box displays. Select the desired devices to connect and then click Next.

Figure 3-111   Sample Select Devices dialog box

If a selected OPFAC has only one device, then the device will be selected 
by default and the Select Devices dialog box will be skipped. If the OPFAC 
doesn’t have a device, an error will be flagged.
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3) The Satellite Bent Pipe Link Deployment dialog box displays.

Figure 3-112   Satellite Bent Pipe Link Deployment dialog box ~ Basic

The Basic tab displays the default Link Name, and allows you to select 
the Home Satellite which provides the available frequencies.

a) Click the Advanced Tab. The following screen displays.

Figure 3-113   Satellite Bent Pipe Link Deployment dialog box ~ Advanced

Based on the frequencies provided by the chosen Home Satellite, this 
screen allows you to configure the frequencies uplink and downlink (in 
each direction) to establish a satellite link between the two selected 
satellite terminals.

The fields of this screen are pre-populated for you with the best available 
default link. 
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b) Click the Help Diagram tab. The following screen displays a diagram 
which explains the function of this dialog box .

Figure 3-114   Satellite Bent Pipe Link Deployment dialog box ~ Help Diagram

c) Click the Help FAQs tab. The following screen displays a scrollable list 
of Frequently Asked Questions and answers regarding satellite link 
deployment.

Figure 3-115   Satellite Bent Pipe Link Deployment dialog box ~ Help FAQs
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4) Use the default link values provided in the Satellite Bent Pipe Link 
Deployment dialog box (or select the desired values), and then click OK. 
The newly deployed satellite link displays in the workspace.

Figure 3-116   Deploying Satellite Links

Link Operations >
Verify Links

Topology > Link Operations > Verify Links: Perform inter and intra OPFAC 
link consistency checks. Inconsistent links (e.g., links not connected to the right 
ports on the end points of the link) will be marked with a red X in the workspace. 
This option can also be launched using the Verify Link Consistency toolbar 
button.

Figure 3-117   Inconsistent Links
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In addition, the results of the link consistency check will be displayed in the 
Scenario Link Consistency dialog box. Troubleshooting solutions are provided, 
where possible, in the text of the failure reason. 

Figure 3-118   Scenario Link Consistency dialog box

If all links are properly connected, a message will be displayed in the bottom left 
corner of the scenario builder editor after the consistency check is performed.

Link Operations >
Clear Links

Topology > Link Operations > Clear Links: Remove red Xs marking 
inconsistent links in the workspace.

Link Operations >
Import Links from

File

Topology > Link Operations > Import Links from File: Imports links from 
designated link import file.

Save As Link Type To save inter-OPFAC links to a new link, right-click on a link in the workspace 
and select Save As Link Type. The status bar at the bottom left corner of the 
Scenario Builder window displays the following message, “New link type 
‘<selected link name>’ saved.”

Deploy Circuit Topology > Deploy Circuit: Follow the steps in the Circuit Wizard to configure 
the desired circuit. All circuit devices (i.e., SCREAM, SHOUTip, CTP, and 
Promina) are deployed using the same procedure. A sample generic Circuit 
Wizard workflow – using Prominas as an example – is provided below. 
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1) Select Topology > Deploy Circuit (or press Ctrl + D) to start the wizard. 
You must select at least two compatible circuit devices or OPFACs that 
contain circuit devices; otherwise, an error will be prompted and the wizard 
is terminated.

The Circuit Deployment Wizard displays.

Figure 3-119   Circuit Deployment Wizard Ports Tab

2) On the Ports tab, specify the ports for the selected source and destination 
Promina devices in the scenario.
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3) On the CCSD tab, configure the CCSD codes for the Promina circuit.

Figure 3-120   Circuit Deployment Wizard CCSD Tab

4) On the Attributes tab, configure the circuit’s attribute values.

Figure 3-121   Circuit Deployment Wizard Attributes Tab
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5) Click the OK button to complete the Promina circuit configuration and 
deploy the circuit.

Deploy Broadcast
Network

Topology > Deploy Broadcast Network: Define broadcast networks by 
selecting units in the workspace, and then selecting Topology > Deploy 
Broadcast Network.

1) Select the source and destination OPFACs or organizations in the 
workspace, and then select Topology > Deploy Broadcast Network (or 
press Ctrl + Shift + B). The Network Attributes dialog box displays. 

Figure 3-122   Defining Broadcast Network Radio Attributes

2) Type a name for the broadcast network in the Network Name field.

3) On the Radio Attributes tab, enter the desired attributes for default 
frequency, channel bandwidth, and data rate.
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4) On the Choose Devices tab, select devices for the corresponding OPFACs 
or organizations.

Figure 3-123   Defining Broadcast Network Devices
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5) On the Optimization Attributes tab, enter the desired attributes for possible 
capacities, and target and maximum utilization.

Figure 3-124   Defining Broadcast Network Optimization Attributes

a) Possible Capacities table: Specifies all of the capacities that the 
optimization engine can use when mutating solutions. For example, if 
there are two capacities specified, then the engine will be able to set 
either of them as the suggested capacity for this network. The Capacity 
column is where the capacity is specified. The Status column is used to 
mark the “original” capacity and the “current” capacity (or “Orig/Current” 
if the current capacity is also the original capacity.)

b) Insert Row button: To add a new capacity, click this button and type the 
new capacity into the Capacity column of the new row.  

c) Delete Row button: To remove a capacity, select a cell in the row and 
click this button.

d) Target Utilization: Specifies the target utilization to be achieved on this 
network. The default value is to use the global values specified in the 
Capacity Optimization Settings dialog. You can override this just on this 
network by specifying a new value.
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e) Maximum Utilization: Specifies the maximum utilization that is allowed 
on this network. The default maximum utilization is set to use the global 
values specified in the Capacity Optimization Settings dialog. You can 
override this just on this network by specifying a new value.

6) Click OK to create the newly defined broadcast network.

Deploy
Relationship

Topology > Deploy Relationship: Define relationships by selecting units in the 
workspace, and then selecting Topology > Deploy Relationship. 

1) Select the OPFACs that you want to associate in the workspace, and then 
select Topology > Deploy Relationship (or press Ctrl + Alt + R). The 
Relationship Attributes dialog box displays.

Figure 3-125   Creating a Relationship

2) Select the type of relationship from the Relationship Type drop-down menu.

3) Select the source OPFAC from the Source drop-down menu.

4) Click OK. The relationship between the selected OPFACs is created.

Configuration
Utilities > UHF

DAMA SATCOM

Topology > Configuration Utilities > UHF DAMA SATCOM: Follow the steps 
in the Configuration Wizard to configure the desired UHF DAMA SATCOM utility 
node. You must select at least one NCS device and two terminals in order to 
start the wizard. 

1) Select Topology > Configuration Utilities > UHF DAMA SATCOM to 
start the wizard.

Figure 3-126   UHF DAMA SATCOM Wizard: Define CPS Node Attributes (Step 1 
of 3) dialog box
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2) Browse and select a service plan file, and browse and select a noise area 
file (or check Create default file to create a default file.) Click Next>> to 
continue.

Figure 3-127   UHF DAMA SATCOM Wizard: Define Channels (Step 2 of 3) dialog 
box

3) Specify the settings for the channel that you want to define, and then click 
Next>> to continue.

Figure 3-128   UHF DAMA SATCOM Wizard: Define Services (Step 3 of 3) dialog 
box
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4) Specify the settings for the service that you want to define, and then click 
Finish to end and close the wizard.

Configuration
Utilities > TSSP >

Configure TSSP
Groups (Circuits)

Topology > Configuration Utilities > TSSP > Configure TSSP Groups 
(Circuits): After you have deployed a satellite link, you can create a TSSP 
circuit by selecting exactly two objects (devices or OPFACs) and configuring the 
circuit via the TSSP Group Config (Circuit Deployment) dialog box.

Figure 3-129   TSSP Group Config (Circuit Deployment) dialog box ~ Create 
Circuit
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1) Click the Help tab. The following screen displays a diagram which explains 
the function of this dialog box .

Figure 3-130   TSSP Group Config (Circuit Deployment) dialog box ~ Help

Note—Shortcut keys are provided for launching the Circuit Deployment dialog 
box for TSSP circuits. SImply press Ctrl + Alt + T.

2) Use the default values provided on the Create Circuit tab in the TSSP 
Group Config (Circuit Deployment) dialog box (or select the desired 
values), and then click OK.

A message box displays to tell you that the circuit was successfully created.

3) Click Create Another to re-display the TSSP Group Config (Circuit 
Deployment) dialog box, or click Done to close the dialog box.

Figure 3-131   Successfully Created Circuit message box
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Configuration
Utilities > TSSP >
View TSSP Group
Configs (Circuits)

Topology > Configuration Utilities > TSSP > View TSSP Group Configs 
(Circuits): View configured TSSP circuits in a table format, and delete selected 
circuits. The table includes the following circuit configuration information: Name, 
Device A Name, Device A Input Port, Device A Demultiplexer (deMUX), Device 
B Name, Device B Input Port, and Device B Demultiplexer (deMUX).

Figure 3-132   View TSSP Circuits dialog box

Note—Shortcut keys are provided for launching the View TSSP Circuits dialog 
box. SImply press Ctrl + Alt + U.
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Configuration
Utilities >

Multiplexer >
Configure

Multiplexer
Circuits

Topology > Configuration Utilities > Multiplexer > Configure Multiplexer 
Circuits: The process for configuring multiplexer circuits is the same as the 
process for configuring TSSP circuits (see the previous section in this manual.) 
You can create a multiplexer circuit by selecting exactly two devices and 
configuring the circuit via the Multiplexer Circuit Deployment dialog box.

Figure 3-133   Multiplexer Circuit Deployment dialog box ~ Create Circuit

Note—Shortcut keys are provided for launching the Circuit Deployment dialog 
box for multiplexer circuits. SImply press Ctrl + Alt + M.
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1) Click the Help Diagram tab. The following screen displays a diagram which 
explains the function of this dialog box.

Figure 3-134   Multiplexer Circuit Deployment dialog box ~ Help Diagram

2) Click the Help FAQs tab. The following screen displays answers to 
frequently asked questions about multiplexer circuit deployment.

Figure 3-135   Multiplexer Circuit Deployment dialog box ~ Help FAQs
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3) Use the default values provided on the Create Circuit tab in the Multiplexer 
Circuit Deployment dialog box (or select the desired values), and then click 
OK.

A message box displays to tell you that the circuit was successfully created.

4) Click Create Another to re-display the Multiplexer Circuit Deployment 
dialog box, or click Done to close the dialog box.

Figure 3-136   Successfully Created Circuit message box

Configuration
Utilities >

Multiplexer > View
Multiplexer

Circuits

Topology > Configuration Utilities > Multiplexer > View Multiplexer 
Circuits: View configured multiplexer circuits in a table format, and delete 
selected (or all) circuits. The table includes the following circuit configuration 
information: Name, Device A Name, Device A Input Port, Device A 
Demultiplexer (deMUX), Device B Name, Device B Input Port, and Device B 
Demultiplexer (deMUX).

Figure 3-137   View Multiplexer Circuits dialog box

Note—Shortcut keys are provided for launching the View Multiplexer Circuits 
dialog box. SImply press Ctrl + Alt + O.
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Configuration
Utilities >

Cut-through >
Enable

Topology > Configuration Utilities > Cut-through > Enable Cut-through on 
Selected Devices (All Ports): Select the two devices that you want to be 
cut-through enabled, then select this command (or press Ctrl + Alt + E). The 
selected devices will be cut-through enabled on all ports. (Note the message 
that displays in the status bar at the bottom of the Scenario Builder window.)

Figure 3-138   Enable Cut-Through on Selected Devices
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Configuration
Utilities >

Cut-through >
Disable

Topology > Configuration Utilities > Cut-through > Disable Cut-through on 
Selected Devices (All Ports): Select two cut-through enabled devices that you 
want to be cut-through disabled, then select this command (or press Ctrl + Alt 
+ D). The selected devices will be cut-through disabled on all ports. (Note the 
message that displays in the status bar at the bottom of the Scenario Builder 
window.)

Figure 3-139   Disable Cut-Through on Selected Devices

Set Owner Topology > Set Owner: Determine which units are needed for subordinate’s 
input (performed by Lead Planner), and then mark them for subordinate input 
by setting ownership information.

Alternative method to access this option: right-click on a unit and select Edit 
NETWARS Attributes, and then click the Set Owner button. 

1) Select units to be marked for subordinate before accessing this option.

2) After this option is accessed, click on the Last Name drop-down menu to 
select an owner. 

a) An owner can be set on multiple units through one operation by enabling 
the Applying owner information on all selected units option. 
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b) If the desired owner is not listed in the drop-down menu, add the desired 
owner to the list by clicking on the New Owner button.

Figure 3-140   Set Owner dialog box

Once the owner information is applied to the desired units, those units will 
display a yellow icon indicating the owner has been set and those units have 
been marked. Units are unmarked by default; therefore, the Lead Planner must 
remember to set ownership information on the units before exporting the 
subordinate query files to Subordinate Planners.

Figure 3-141   Owner Information Set on Desired Units

Remove Owner Topology > Remove Owner: Remove ownership from selected units.

Alternative method to access this option: right-click on the unit, select Edit 
NETWARS Attributes, click the Set Owner button, and then enable the Unset 
Owner Information checkbox.

1) Select units to be unmarked before accessing this option. Once the remove 
owner operation is applied, the yellow icons are removed.
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Terrain Topology > Terrain <options>: This menu is available only if a Terrain 
Modeling Module GUI (TMMGUI) license is obtained. Use this feature to import 
terrain data, view the terrain profile and study the effects of the atmosphere on 
the communication.

JCSS supports the following terrain data formats:

• DTED Level 0
• DTED Level 1
• 15-minute DEM data
• 2-arc-second DEM data
• 1-degree-DEM data

Terrain > View
Terrain Profile

Topology > Terrain > View Terrain Profile: View the terrain profile between 
two points.

1) In View Profile mode, click on one point and then click on the second point. 
This will display the terrain profile between the two selected points.

Figure 3-142     Terrain profile

The brown area indicates terrain. Using this interface, you can turn on or off 
the Fresnel Zone and also the Earth’s curvature (which is represented by 
the green arc). The blue line in the profile can be used to determine whether 
line-of-sight exists between the two points. If the blue line crosses over the 
terrain or the Earth’s curvature, there is no line-of-sight.

Terrain > Set
Propagation Model

Topology > Terrain > Set Propagation Model: Set the model used by the 
TMMGUI module for representing the atmospheric conditions. Example 
propagation models include the Free-Space model and the Longley-Rice model 
You can also create user-defined propagation models.
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Terrain > Edit
Parameter Sets

Topology > Terrain > Edit Parameter Sets: Access the tabular interface for 
making changes to the propagation models.

Figure 3-143     Edit TMM Propagation Parameter Sets dialog box

1) From the drop-down menu, select the propagation model to modify. 

2) Once the desired changes to the propagation model are made, save it to 
the same model or save it to a new model (sing the Save or Save As 
buttons) and close this table.

Terrain > Specify
Terrain Data

Directory

Topology > Terrain > Specify Terrain Data Directory: Set the directory where 
JCSS will access terrain data.

Figure 3-144     Terrain Data Directory Preferences dialog box

1) Type in the folder name where the files are stored or use the Browse button 
to browse to that location using the file browser.

JCSS supports three types of terrain data—DTED, USGS DEM, and 
OpenFlight. The specified folder must contain the files of the specified type.

Terrain > Rebuild
Terrain Data

Catalog

Topology > Terrain > Rebuild Terrain Data Catalog: Refresh terrain data 
before import if files are added to the terrain data directory or changes are made 
to the location of the terrain data directory. JCSS does not automatically detect 
the changes.
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Terrain > Set
Elevation Maps

Topology > Terrain > Set Elevation Maps: Set elevation or contour lines on 
the map. If terrain data has already been imported, it can be saved as elevation 
lines and can be reused in future sessions of JCSS. This saves the time taken 
to import the data and create the elevation lines.

Figure 3-145     Select Elevation Lines dialog box

1) If there are no elevation lines for the area of interest, import terrain data and 
use the new elevation lines. Click the Import button to launch the Import 
Elevation Lines dialog box.

Figure 3-146     Import Elevation Lines dialog box

2) When importing the data, specify the following information:

a) Area to Import: Specifies the portion of the map corresponding to which 
one you want to import the terrain information. You have three choices: 
Currently Visible Area, Entire Subnet, or Define Area.

b) Elevation Lines Name: Identifies a name for the elevation lines being 
imported. By saving the elevation lines, you can avoid going through the 
import process again.

c) Resolution: Indicates the number of sample points per unit.

d) Line Spacing: Specifies how far away the elevation lines are spaced 
when imported into the scenario.

e) Terrain Data Directory: Click this button to select the folder that 
contains the terrain data. This launches the same interface as the 
Terrain > Specify Terrain Data Directory menu option.
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f) Display Settings: Click this button to control the display preferences. 
This option launches the same interface as the Terrain > Edit Map 
Display Settings option.

3) Click OK.

Terrain > Edit Map
Display Settings

Topology > Terrain > Edit Map Display Settings: Specify map display 
settings, such as the colors and thresholds to be used for the elevation lines.

Figure 3-147     Current Elevation Line Display Settings dialog box

Define Trajectory Topology > Define Trajectory: Create a trajectory defined in segments.

1) Define a trajectory type, how long the unit waits at the starting location 
before it starts moving, and the altitude at which the unit is when it starts its 
trajectory. 

a) Trajectory name – Sets the name of the trajectory.

b) Trajectory type – The types are Variable interval and Fixed interval. 

Figure 3-148   Define Trajectory dialog box
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c) Initial altitude – This field sets the initial altitude of the trajectory. 
Choose the units of measurement for the altitude with the pull-down 
menu. 

d) Initial wait time – In a variable-interval trajectory, the initial wait time 
pauses a mobile object for a specified time before it covers the next 
segment.

e) Initial pitch – Sets the initial pitch of the trajectory. Possible 
assignments are: Autocomputed to assign a value automatically 
according to the trajectory; Unspecified to not assign any value; or 0.0, 
which you can edit to assign an explicit value. 

f) Initial yaw – Sets the initial yaw of the trajectory. Possible assignments 
are: Autocomputed to assign a value automatically according to the 
trajectory; Unspecified to not assign any value; or 0.0, which you can 
edit to assign an explicit value.

g) Initial roll – Sets the initial roll of the trajectory. Possible assignments 
are: Autocomputed to assign a value automatically according to the 
trajectory; Unspecified to not assign any value; or 0.0, which you can 
edit to assign an explicit value. 

h) Coordinates are relative to object’s position – You can specify a 
trajectory that is either relative to an object's initial position or has its own 
absolute initial position. If you define a relative trajectory, all objects that 
are assigned this trajectory will trace out the same path starting at their 
initial positions. If you define an absolute trajectory, all the objects that 
are assigned this trajectory jump to the trajectory's initial position before 
traversing it. Also indicate whether the trajectory’s path points are 
absolute or relative to the object’s current location. 

2) Click Define Path to enter trajectory definition mode, display the Trajectory 
Status dialog box, and change the cursor into a line tool in the Project 
Editor. This is used to draw a node's mobile trajectory; the path displays in 
red.
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3) When you define a variable interval trajectory, the Trajectory Segment 
Information dialog box displays after you create a path. This dialog box is 
used to specify trajectory information for each segment.

Figure 3-149   Trajectory Segment Information dialog box

4) Click Continue to add a segment, and/or click Complete when you are 
finished.

5) From the Scenario Builder, right-click on the desired unit to open the 
shortcut menu.

6) Select Edit NETWARS Attributes. The OPFAC/Organization Attributes 
dialog box displays.
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7) Select the name of the trajectory from the Trajectory drop-down menu.

8) Click OK. 

Figure 3-150   Assigning Trajectory

The assigned trajectory displays as a light-green arrow.

Figure 3-151   An Assigned Trajectory
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Traffic Menu

Traffic Wizard Traffic > Traffic Wizard: Launch the Traffic Wizard which provides users with 
a quick and simple way to deploy traffic within JCSS. Select two OPFACs, and 
then the Traffic Wizard walks you through selecting the end devices (and the 
profile to deploy between the client and server devices), and deploying a link 
between them.

Note—The Traffic Wizard will launch only if you have selected two OPFACs 
between which the traffic is to be deployed.

1) Select Traffic > Traffic Wizard (or press <Ctrl> + W) to launch the Traffic 
Wizard.

Figure 3-152   Traffic Wizard

2) Select a profile to deploy, specify client and server devices, and then click 
OK.

IERs > Set Import
Options

Traffic > IERs > Set Import Options: Specify the various sources from which 
traffic is imported into the scenario.

Figure 3-153   IER Import dialog box
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• Use implicit IERs: If this option is checked, the software creates implicit 
relationships based on the user-created relationships and creates IERs for 
these newly created relationships. 

• Import IERs from database: JCSS can query databases containing IERs in 
the specified format. This is based on the producer and consumer OPFACs’ 
functional names and the URC between them. If you check this option, the 
software imports IERs from the JCSS database.

• Import IERs from files: In addition to the database, JCSS can also import 
IERs from text files in the specified format. This is based on the producer and 
consumer OPFACs’ functional names and the URC between them. If you 
check this option, the software imports IERs from such files.

• Additionally, you can specify all traffic coming from a source as background. 
This causes the simulation to treat all IERs coming from that source as 
background traffic, resulting in improved simulation efficiency.

• IER Database Selection: Designate a source database for a scenario by 
clicking this button. Since the database may exist anywhere on the network, 
you must pick both a server and a database.

a) The first step in selecting a database is to login to the server. You only 
need to login to a database server once, but since each server may have 
a different set of passwords, changing servers may require a new server 
login.

Note: During installation, JCSS creates a default database user account 
with username scenario_builder and password netwars.

Figure 3-154   Database Server Login
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b) Once logged into the server, the second dialog box displays to allow you 
to change the server or the database. The selection lists will contain all 
available servers, and the databases for the currently selected server. 
Of course, if you change the server, you may need to log in to that server 
before seeing the list of available databases.

Figure 3-155     Select Server and Database

c) Click OK to update the scenario to use the designated server and 
database combination for database IER queries.

IERs > Specify
IERs

Traffic > IERs > Specify IERs or click the Specify IERs toolbar button: Create 
IERs, and view existing IERs in the scenario.

Figure 3-156     Specify IERs dialog box

• Producer Tree: This tree provides a hierarchical view of all the OPFACs and 
organizations in the current scenario. When creating new IERs, the 
producing OPFAC is selected in this tree. Only one OPFAC may be selected 
at a time.

• Consumer Tree: This tree provides the same hierarchical view of all the 
OPFACs and organizations that the Producer Tree does. When creating 
IERs, the consuming OPFAC(s) are selected in this tree. Multiple OPFACs 
may be selected at once. 
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• View IERs: If a producer is selected in the producer tree, clicking this button 
displays the Edit IER Parameters dialog box which shows all of the IERs 
produced by the selected OPFAC.

Figure 3-157     Edit IER Parameters dialog box

The following list provides definitions of IER attributes:

— IER ID: Identifies an IER in the database. IDs for IERs that are created 
by a user start with the prefix USER, as not to conflict with IER IDs in the 
database. Background IERs start with the prefix BKGD. 

— Classification: Specifies the security classification of an IER. The 
security classification of an IER is one criterion that determines the 
system element through which the IER is transmitted. 

— Perishability: Specifies the time in seconds for which the IER is alive. 

— Priority: Determines the number of transmission retries and the wait time 
between successive retries. 

— Traffic: Specifies the type of IER traffic. 

— Average Size: Indicates the average size of the IER in bytes.

— Equipment: Specifies the system element on which the IER can be 
transmitted. 

— Consumer: Identifies OPFAC consumer of the traffic.

— Distribution Type: Indicates the inter-arrival distribution for the IERs.  

— Interarrival: Represents the time, in seconds, between IER firings.

— Start Time: Identifies the time, in seconds, in which the IER will begin 
firing after a simulation begins.

— Stop Time: Identifies the time, in seconds, in which the IER will stop firing 
after the simulation begins.  

— Producer Device and Consumer Device: Indicate the devices 
transmitting and receiving the IER.

— Transport Protocol: Defines the underlying Transport Layer protocol 
that traffic (IERs) will use for transmission. Typical transport layer 
protocols include TCP and UDP.
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• Create IER: If a producer and at least one consumer are selected, clicking 
this button displays the IER Specification dialog box where new IER(s) can 
be created. If only one consumer is selected, the single IER creation dialog 
box (shown below) displays.  If multiple consumers are selected, a similar 
dialog box for multiple IERs displays instead.

Figure 3-158     IER Specification dialog box for a single IER

The Required Parameters section has a set of parameters that have to be 
specified for the IER. The Optional Parameters section has some additional 
parameters. If no values are specified for the Optional Parameters, default 
values will be used.

— Traffic Type: This is the type of IER - voice, VTC or data.

— Size: This is the size of the IER. For data IERs, the size is specified in 
bytes. For voice or VTC IERs, the size is specified in number of seconds.

— Average: This is the time (specified in seconds) between the start of two 
consecutive IERs.

— Distribution Type: The distribution type combined with the Average 
value is used to determine the load caused by this IER on the links and 
broadcast networks. The default distribution type is "Exponential."

— Priority: This is the IER's precedence. The default precedence is 
"Routine."

— Classification: This is the IER's security classification. The default 
classification is "Unclassified."

— Producer Device: This is the device in the producer OPFAC which will 
be used to transmit this IER. If the producer device is not specified, the 
Capacity Planner will choose a device in the producer OPFAC to transmit 
this IER.
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— Consumer Device: This is the device in the consumer OPFAC which will 
receive this IER. If the consumer device is not specified, the Capacity 
Planner will choose a device in the consumer OPFAC to receive this IER.

— Equipment Type: This is the type of equipment that will be used to 
transmit this IER.

— Perishability: If the time taken by the IER to reach the destination from 
the source is greater than the perishability, the IER is recorded as 
"failed."

IERs > Import from
IER Report

Traffic > IERs > Import from IER Report: Load a previously created IER 
Report.

IERs > Export IER
Report

Traffic > IERs > Export IER Report: Export all traffic in the scenario (excluding 
threads) to a text file.

1) The Create IER Report dialog box displays.

Figure 3-159     Create IER Report dialog box

2) Select a location and enter a name for the file, and then click Save.

IERs > Export IERs
to XML

Traffic > IERs > Export IERs to XML: Automatically sends IERs to an XML file.

Flows > Open
Flows Browser

Traffic > Flows > Open Flows Browser: Opens the Traffic Center, which 
allows you to view and edit traffic flows in your network.

Threads are groups of IERs that are fired in segments. Threads are a 
conditional sequence of IERs that represent complex real world information 
exchanges.  

1) Right-click on an OPFAC with an established relationship to be the starting 
point of the IER thread.  
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2) Select View Threads from the right-click menu to open the View Threads 
dialog box.

Figure 3-160     View Threads dialog box

3) Click Define Thread to open the Define Thread dialog box.

Figure 3-161     Define Thread dialog box

4) In the Name field, enter a name for the thread.

5) If you want to gather statistics on this thread after running a simulation, 
select Included in the MOP field.

6) On the Firing Rules panel, set the Start Time and the Stop Time, which 
control when the thread will start firing and stop firing after the simulation 
begins.

7) Set the Thread Interarrival, which determines the firing interval in seconds 
(e.g., 50 means the thread will fire every 50 seconds).
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8) Select an option from the Distribution Type field, which indicates the 
inter-arrival distribution for the IERs. 

9) Set the desired Thread Trigger option. The thread trigger is used to fire off 
a thread once a condition is met. For example, when a status report thread 
reaches the commanding OPFAC, that condition could kick off another 
thread being sent back down the chain of command representing marching 
orders.

10) Click Define Segment. A default IER segment inserts into the table.

Figure 3-162     Adding a thread segment

Notice the default values for the first three attributes: Segment Index, 
Condition, and Producer OPFAC. 

This IER is the first segment of the thread, so it is assigned Segment Index 
1. This sequential number identifies unique segments within the thread.

The Condition attribute defines the condition leading to the execution of 
the respective segment. This field can be either Start, to signify the start 
time event of the thread, or an integer, to refer to a segment index within 
the thread that causes this segment to fire.

The OPFAC originally selected in step 2 in the Define Infrastructure dialog 
box is identified as the Producer OPFAC. 

11) Click in the Consumer OPFAC cell to specify an OPFAC consumer of the 
thread. 

12) Next, click in the Reaction IER cell. This is where you actually define the 
IER segment. The View Thread IERs dialog box displays. This dialog box 
is similar to the View Traffic dialog box. 
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13) Click the Insert button. A new explicit IER containing default settings is 
created in row 1 of the table. 

Figure 3-163     View Thread IERs dialog box

14) Click on the Traffic cell and use the drop-down menu to select a value that 
specifies the type of IER traffic. 

15) Click in the Average Size cell and change the bytes to indicate the average 
size of the IER in bytes.

16) In the Equipment cell, specify the system element on which the IER can be 
transmitted. 

17) Click in the Start Time cell and select Thread. This means the IER will only 
fire as part of the thread. If the Begin value is selected, the IER will fire as 
part of thread and as an individual IER.

18) Specify the time between IER firings in the Interarrival cell.

19) Use the Distribution Type cell to indicate the inter-arrival distribution for 
the IERs. 

20) The Critical cell is used for reporting/results analyses purposes.  A thread 
is considered a success only if all critical IER segments are received. A 
thread is still considered a success if non-critical IER segments fail.

21) Create the next segment of the thread. Click Define Segment. Another 
default IER segment inserts into the table.

22) In the Condition cell of segment 2, enter 1 to define the condition leading 
to the execution of this segment. This means segment 1 within the thread 
causes segment 2 to fire. 
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23) Click in the Consumer OPFAC cell of Segment 2. From the drop-down 
menu, choose Select Other OPFAC. The Select Other OPFAC dialog box 
displays. Expand the scenario tree, and then select the desired OPFAC. 
Click OK.

Figure 3-164     Select Other OPFAC dialog box

24) Next, click in the Reaction IER cell to define the IER segment. The View 
Thread IERs dialog box displays. When defining a segment for an OPFAC, 
all previously created traffic originating for that OPFAC also becomes 
available.

25) Create a new IER or use one that was previously created. Select the 
desired IER by clicking in the Row# cell, and then clicking OK.

26) From the Define Threads dialog box, either add another thread segment 
using the steps outlined previously, or click OK. When you click OK, a 
summary of the newly created thread displays in the View Threads dialog 
box.

Figure 3-165     Newly Created Thread

27) Click OK to save the thread.
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Flows > Import Traffic > Flows > Import > (option): The Import sub-menu contains operations 
related to importing traffic; consult the IT Guru documentation set, available via 
Help > Documentation > IT Guru Documentation, for further details. What 
follows below is a sample workflow for importing Cisco Netflow traffic files; 
workflows are similar for the other data sources listed above; however, there 
may be subtle differences.

Netflow Import Process

The traffic import for Netflow traffic files involves a two-step process. The first 
step involves the conversion of the traffic information included in the Netflow 
traffic file into traffic profiles for the appropriate nodes in the network while the 
second step involves converting the imported flow profiles into JCSS-specific 
traffic.

During the first step, each line in the Netflow traffic files is integrated into a traffic 
profile based on parameters such as the source and destination IP addresses 
and the aggregation scheme. Thus, if there are multiple lines in the file that have 
the same values for source, destination and aggregation scheme, then these 
lines will be integrated into a single traffic profile by the software. In the second 
step, each flow profile is converted into a single IER using the information that 
you provided in the Traffic Import Defaults dialog box. 

The average size for the IER is calculated based on the total number of packets 
and total number of bits of the traffic profile while the inter-arrival time is 
calculated based on the difference between start and stop times and the total 
number of packets.

The minimum inter-arrival time, displayed in the Traffic Import dialog box, is 
used for those IERs where the calculated inter-arrival time is less than the 
user-specified minimum. In this case, the average size of the IER is increased 
proportionately. For example, if you specified inter-arrival time is 1 sec and the 
calculated inter-arrival time is 0.0002 secs, then the calculated average size is 
multiplied by the ratio of the user-specified minimum and the calculated 
inter-arrival time (1/0.0002) to get the new average size (new avg size = avg 
size x 1/0.0002).

If the calculated inter-arrival time is greater than the user-specified inter-arrival 
time, the calculated average size is not modified. For the case where the 
user-specified value for the minimum inter-arrival time is greater than the 
difference between the start and stop times, the size is computed based on the 
total number of bits and this IER is sent only once during the simulation.

1) Collecting Netflow Traffic Data

The first step in importing traffic data is capturing or creating the Netflow 
traffic data file(s) to be imported. When capturing the Netflow traffic data, 
please ensure that the Netflow data file meets the following requirements:

a) The data file must use one of the following aggregation schemes:
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– RouterAS or RouterPrefix

– CallRecord or DetailCallRecord

– AsHostMatrix or DetailHostMatrix

b) The file may use either Format A or Format 2.

c) The file must be an uncompressed ASCII file. You may need to manually 
uncompress a file and/or convert it from binary to ASCII before you can 
import it.

d) The file must have a four-digit extension where the extension follows the 
“MMSS” (mins-secs) format. 

e) The header of the file must include the correct format type, i.e. if the file 
is of Format A then the format field in the header must say Format A and 
not Format 2. 

f) The number of records in the file must match the number of records 
specified in the header of the file.

If the header of the file is incorrect, the Start and End times in the Import 
Traffic Flows dialog box will be set to Jan 1, 1970.

For additional details, please refer to the Traffic Import section in the MVI 
User’s Guide of your Modeler documentation.

2) Getting Started

To import traffic from Cisco Netflow traffic files, a project must currently be 
open in the Scenario Builder. Once a project has been loaded, start the 
import process by choosing the Traffic > Flows > Import > From Cisco 
Netflow menu item. Note that this menu item will be disabled (grayed out) 
if no project is open.

3) Deleting Previously Imported Netflow IERs

If you already performed a Cisco Netflow traffic import and chose to save 
the IERs created from that import, the software launches the following 
dialog box. This dialog box provides you with the option to delete all those 
IERs that were created as a result of previous Cisco Netflow traffic data 
imports. 
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4) Specifying the Traffic Import Defaults

The Traffic Import dialog box displays. Specify values for the parameters 
required in converting the imported flow profiles into IERs.

Figure 3-166     Traffic Import dialog box

The minimum inter-arrival time is used for those IERs where the calculated 
inter-arrival time is less than the user-specified inter-arrival time. When this 
occurs, the average size of this IER is increased proportionately. If the 
calculated inter-arrival time is greater than the user-specified inter-arrival 
time, the average size computed from the flow profile is not modified. For 
the case where the user-specified value for minimum inter-arrival time is 
greater than the difference between the start and stop times, the size is 
computed based on the total number of bits and this IER is sent only once 
during simulation. 

5) Choosing the Netflow File

After selecting the OK button in the Traffic Import dialog box, the Traffic 
Flows Import dialog box will be launched. Click the + signs for all the 
subdirectories that appear under the Netflow directory. Click the 
10.0.0.1.0000 traffic file that is included in the ASHostMatrix directory.

The directory that appears in the Traffic Flows Import dialog box is 
determined by the traffic_archive_dir preference that may be set via the 
Preferences dialog box. By default, this preference is set to the 
…\User_Data\Traffic_Data directory on your machine.

6) Add and/or remove directories and/or servers from the Traffic archive 
directories tree by clicking the Add Directory, Add Server, or Remove 
buttons.
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Figure 3-167     Traffic Flows Import dialog box

7) Specifying the Netflow Traffic Import Parameters

The Archive information corresponds to each traffic archive file and 
provides identifying information about the file:

a) Host – Specifies the IP address of the probe.

b) Media – The type of NetMetrix probe (Ethernet, FDDI, etc.) used to 
collect network traffic.

c) Device – The name of the NetMetrix probe.

d) Start – The start time of the traffic capture period.

e) End – The end time of the traffic capture period.

f) Interval – The amount of time between traffic collections.

The remaining sections include the following options that control the traffic 
import:

a) From – Indicates the start time of the period of traffic to import. 

b) To – Indicates the end time of the period of traffic to import. 

c) Data Source Time Zone – Indicates the time zone.
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d) Multiple archive alignment – Indicates whether JCSS aligns or 
concatenates multiple archives from a single traffic server. This menu 
has three options:

Align Start of Each Archive – Each archive is aligned so that all traffic 
starts simultaneously (at simulation time = 0) and runs concurrently. This 
option is useful for archives from separate network probes that started 
simultaneously.

Align Archives Based on Time Stamps – The traffic is aligned based 
on the time stamps in each archive to replicate its real-world behavior. 
This option is useful for archives (from separate probes) that have 
overlapping time frames but did not start simultaneously.

Concatenate Archives – The archives are aligned by start time so that 
traffic runs consecutively: the traffic for each subsequent archive follows 
the traffic in the preceding archive. This option is most useful if you made 
successive runs from a single network probe.

e) When duplicate data from different sources exists use the – 
Indicates what merging mode to use when (1) you are importing from 
multiple traffic files, or, (2) you choose to retain (not overwrite) the 
current traffic data in your scenario. In both these cases the merge mode 
resolves any conflicting data in multiple traffic sources. Merging is useful 
when you have nodes on different segments, and probes on each 
segment as well. When nodes send traffic to one another, the probe on 
each segment will record the traffic, so that multiple values for the same 
traffic will be stored in the archive file. During import, you can set the 
Archive Merging Mode option either to Maximum, Addition, or Minimum. 
Setting the merge mode to Maximum selects the maximum of the two 
traffic values during import (this setting is most commonly used), while 
setting Minimum selects the smaller of the two traffic values. Choosing 
Addition adds the two traffic values.

f) Traffic Preprocessor – This menu lets you import traffic archives that 
use ASCII formats unsupported by JCSS. You can create preprocessor 
scripts (either shell scripts or executable files) that convert a traffic file to 
a format that JCSS can import. By selecting an archive and then 
choosing a preprocessing script in this menu, you can automatically 
convert the archive to Flexible CSV (.tr2) format prior to the import. Note 
that you cannot assign a script to multiple archives—you must assign a 
script to each archive individually. The initial setting for all archives is 
None. This tells JCSS to import the files “as is,” and is the correct setting 
for CSV, NetMetrix and Sniffer files.

g) Import threshold – Specifies the import threshold in average octets per 
second.

h) Aggregation options – Allows you to specify the method by which to 
aggregate traffic.

Select the Import button to proceed with the traffic import process.
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8) Unrecognized Traffic

If OPNET could not map all the imported traffic to specific nodes in the 
network/scenario, the Unrecognized Traffic Assistant dialog box displays. 
You may then manually specify sources and/or destinations for any 
unrecognized traffic.

Figure 3-168     Unrecognized Traffic Assistant dialog box

For the cases where the exact source and destination nodes for the 
unrecognized traffic are unknown, you may assign certain nodes in your 
network to be edge devices. Specifying edge devices in your network will 
route this unrecognized traffic randomly between the edge devices in your 
network.

After you finish mapping some/all of your unrecognized traffic, select the 
Close button in the Unrecognized Traffic Assistant dialog box. The 
Remaining Unrecognized Sources dialog box displays, prompting you for 
confirmation to proceed with the traffic import. 

Figure 3-169     Remaining Unrecognized Sources dialog box
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Selecting Yes in this dialog box launches the Reimport Traffic dialog box, 
giving you the option of re-importing all the traffic in this network. 

Figure 3-170     Reimport Traffic dialog box

If you click the Yes button, the Import Flows dialog box will be displayed 
again and this time choosing the Import button will include all of your 
recognized traffic as well as any unrecognized traffic that was mapped 
using the Unrecognized Traffic Assistant. Clicking the No button will not 
include any unrecognized traffic that was mapped during the import.

9) Examining the IERs

After the traffic import is complete, a message indicating the number of 
IERs created from this traffic import displays in the message buffer at the 
bottom right corner of the Scenario Builder. 

The IERs created from this import are populated as background IERs on 
the source node and therefore may be viewed using the View Traffic dialog 
box. The View Traffic dialog box is accessible both from the Define 
Infrastructures treeview as well as from the right-click menu option of an 
OPFAC.

IERs created from a Cisco Netflow traffic import are tagged with DMD_CNF 
in their IER ID.

10) Visualizing the IERs

To view these IERs in your workspace, zoom in so that your units are visible 
and select the Traffic > Show Aggregate Traffic option.

Flows > Import >
Open Import Log

Traffic > Flows > Import > Open Import Log: Opens the traffic flow import log, 
which contains error and diagnostic information generated during previous 
imports.

Flows > Import >
Clear Import Log

Traffic > Flows > Import > Clear Import Log: Clears the link load import log.
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Flows > Export >
To Spreadsheet

Traffic > Flows > Export > To Spreadsheet: Exports traffic flows to an ASCII 
file that can be viewed as a spreadsheet in Microsoft Excel.

Figure 3-171     Export Traffic Flows dialog box

These options allow you to set parameters for the exported traffic:

• Specify calendar time checkbox and drop-down menu: Sets the start time 
of the traffic that the file spans. The time steps reference this date and time 
in the file. The default is determined by the earliest time set in all existing 
traffic pairs, network base time, or current time. To specify a date and time 
other than the default, select Choose date/time from the Specify calendar 
time pull-down menu. The Set Date/Time... dialog box appears. Select a 
date and time and click OK. 

• Traffic Duration field: Sets the total time the traffic file spans. It is 
determined by the length of the conversation pair traffic in the scenario. 

• Time Step field: Sets the bucket size of the exported traffic.

• Traffic Units drop-down menu: Lists the units of the exported traffic. This is 
specified in bits/sec, Kbits/sec, Mbits/sec, or Gbits/sec.

• Export traffic only for selected nodes check box: When selected, only 
traffic for selected nodes in the scenario is considered for export. When 
unselected traffic for all nodes is considered for export. This option is useful 
when you want to view and edit traffic for a few objects. 

• Export node pairs that have no traffic flows check box: When selected, 
the entire matrix of node pairs is exported, including node pairs that have no 
traffic flows. When unselected, only node pairs that have traffic flows 
between them are exported. 

• Display file in spreadsheet program check box: When checked, the 
exported traffic file displays automatically in the program specified by the 
spreadsheet_prog preference (environment attribute).
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• Export node names check box: Exports full hierarchical node names with 
the traffic data. If unchecked, node names are only exported if IP address 
information is missing. Including the node names with the export data affects 
the import of the data. The import engine attempts to match the traffic flow to 
its endpoints based on node name first, if available. If that lookup fails, then 
the endpoint IP addresses are used for matching.

• Export button: Accepts the current export settings, exports to a spreadsheet 
program, and closes the dialog box. 

Flows > Create
Flows

Traffic > Flows > Create Flows: Create IP traffic flows, which represent 
background traffic, between all or selected nodes in the network. The traffic 
flows can be a full mesh between all or selected nodes, or can be from one node 
to the remaining selected nodes (or all nodes in the case of no selection). In the 
latter case, you can specify the direction of the traffic.

This feature filters out all IP nodes in the network and provides a list of eligible 
nodes for which you can configure the flows. The traffic can also be specified in 
bits/packets.  

Figure 3-172     Create IP Unicast Traffic Flows dialog box
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Device /Link Loads
> Import

Traffic > Device/Link Loads > Import > (option): The Import sub-menu 
contains operations related to importing background traffic loads on devices and 
links; consult the IT Guru documentation set, available via Help > 
Documentation > IT Guru Documentation, for further details. The following 
options are available from the sub-menu:

Device /Link Loads
> Open Import Log

Traffic > Device/Link Loads > Open Import Log: Opens the traffic flow import 
log, which contains error and diagnostic information generated during previous 
imports.

Device /Link Loads
> Clear Import Log

Traffic > Device/Link Loads > Clear Import Log: Clears the link load import 
log.

Convert Traffic >
Applications to

Flows

Traffic > Convert Traffic > Applications to Flows: Automatically convert 
standard OPNET application and profile configuration parameters into IP flow 
objects.  This process turns the discreet application traffic into background flows 
for use in simulation or traffic visualization. After creating the flows, the 
application and profile configuration objects are cleared of all traffic information 

Table 3-3   Device/Link Loads > Import Sub-menu Items

Menu Item Description Reference

From CA eHealth… Imports the background traffic load 
on a device or link from CA 
eHealth. (MVI module only)

MVI User’s Guide: Importing 
Device/Link Loads 

From MRTG Imports the background traffic load 
on a device or link from MRTG 
traffic file. (MVI module only)

MVI User’s Guide: Creating 
MRTG Link-Load Data 

From InfoVista Imports the background traffic load 
on a link from InfoVista reports. 
(MVI module only)

MVI User’s Guide: Creating 
InfoVista Link-Load Data 

From HP Openview 
Performance Insight

Imports the background traffic load 
on a link from HP Openview 
Performance Insight reports. (MVI 
module only)

MVI User’s Guide: Creating 
HPOpenview Link-Load Data 

From Text Files Imports the background traffic load 
on a device or link from ASCII 
(.gbu) traffic files.

MVI User’s Guide: Importing 
Device/Link Loads 
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in order to prevent duplication of traffic during simulation. It is recommended 
that a duplicate scenario be created prior to using this feature if you want to keep 
the application and profile configurations for later use.  The following dialog box 
displays to input the required flow generation parameters.

Figure 3-173     Convert Applications to Flows dialog box

As shown above, the required parameters include:

• Start-Time (Hours, Minutes, Seconds): The start-time of the flow objects. 
This will effectively act to truncate all flow traffic recorded prior to the value 
provided. The flow’s bps and pps values during this time will be set to 0.0. 
The input values must be integers.

• Duration (Length, Units): The duration of the simulated calculation window. 
This method corresponds to the Capacity Planning Optimization feature. The 
input value must be an integer.

Flows will be aggregated for any source/destination pair. Thus, any number of 
applications that contribute to traffic between a given client and server will be 
aggregated into two flows with one for each direction of travel.

Generate Traffic
Web Report

Traffic > Generate Traffic Web Report: Launch the most recent Traffic web 
report which details all of the different types of traffic contained in the scenario.

Set Aggregate
Traffic Preferences

Traffic > Set Aggregate Traffic Preferences: Specify the type of traffic to 
visualize—voice, data, and VTC. The default preference is to display all traffic. 
When you change the traffic flow preference, any rendered flows are updated.

Figure 3-174     Traffic Flow Preferences dialog box
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Traffic flows are automatically updated in the following cases:

• Closing the View IERs table, the flows on the producer unit are updated.

• Closing the Specify IERs interface, all displayed flows in the scenario are 
updated.

• Choosing File > Refresh IER Text Files, all displayed flows in the scenario 
are updated.

• Changing the thresholds or the traffic flow preference, all flows are updated.

Show Aggregate
Traffic

Traffic > Show Aggregate Traffic: You can turn on (or off) the visualization for 
all the units in the scenario, or for individual units. To turn the visualization on or 
off for individual units, options are provided on their right-click menus. 

When you activate the traffic flow visualization, colored path objects are drawn 
between units to represent the flow of traffic between them. The color of the path 
objects represents the total load caused by the IERs between the units.

Figure 3-175     Viewing aggregate traffic flows

If the visualization for an OPFAC is turned on, the traffic flow includes IERs 
produced by that OPFAC. If the visualization for an Organization is turned on, 
the traffic flow includes IERs produced by all of the OPFACs in that Organization 
and its sub-Organizations. Turning on the visualization for an Organization and 
then expanding that Organization or drilling into it will cause the traffic flows to 
be drawn at the OPFAC level.
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An option is provided on the right-click of a traffic flow to view the IERs that 
constitute that flow. The individual IERs are displayed in a table. They cannot 
be edited in this table.

Figure 3-176     Traffic that constitutes a flow

The tooltip on a flow will provide high-level details about the traffic flow, such as 
the number and average size of the voice and data IERs and their loads.

Figure 3-177     Tooltip for a flow

Flows are colored based on their total loads. For data IERs, the load is 
computed as follows: Traffic load (kbps) = (average IER size (bytes) * 8) / 
(interarrival time (sec) * 1000)

For voice IERs, the load is computed as follows: Traffic load (kbps) = (average 
call duration (sec) * channel size (kbps)) / interarrival time (sec)

A default channel size of 16Kbps is assumed when computing the traffic load 
for voice traffic.

Hide Aggregate
Traffic

Traffic > Hide Aggregate Traffic: Hide the traffic flows on all units in the 
scenario. Options are provided on the right-click menus to hide flows for 
individual OPFACs or organizations.

Import Node
Aliases > From

Text File

Traffic > Import Node Aliases > From Text File...: Select a file from which to 
import node aliases into a scenario.

Export Node
Aliases > To Text

File

Traffic > Export Node Aliases > To Text File...: Export node aliases from a 
scenario to a text file. Edit the aliases using a spreadsheet program like Excel, 
and then import the aliases back into a scenario.
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Protocols Menu

The Protocols menu contains operations related to the various protocols 
supported in the standard and specialized model libraries. The protocols are not 
documented in this manual; please refer to the OPNET documentation listed for 
each menu option below (consult the IT Guru documentation set, available via 
Help > Documentation > IT Guru Documentation):

Table 3-4   Protocols Menu Items

Menu Item Description Reference

Applications Adds ACE application models to 
the existing network and 
configures application traffic.

Model User’s Guide 

Servers Manages server models. Model User’s Guide

Mainframes Manages mainframe models. Model User’s Guide

TCP Configures TCP. Model User’s Guide

IP Configures IP addresses, dynamic 
routing protocols, type of service 
characteristics for conversation 
pair traffic, autonomous system 
numbers on routers, and ping 
traffic. 

Model User’s Guide 

Link16 Configures/assigns Time Slot 
Blocks (TSBs) on terminals in the 
network.

Model User’s Guide

IPv6 Configures IPv6 addresses, 
routing protocols, interface status, 
and runs readiness assessment 
and migration planner. 

Model User’s Guide 

BGP Configures BGP start time, 
autonomous system numbers, and 
route re-distribution from other 
protocols into BGP. 

Model User’s Guide 

EIGRP Configures EIGRP start time and 
route re-distribution from other 
protocols into EIGRP. 

Model User’s Guide 

IGRP Configures IGRP start time and 
route re-distribution from other 
protocols into IGRP. 

Model User’s Guide 

IS-IS Configures interface metrics, 
interface circuit types, system 
types, metric styles, and SPF 
calculation parameters.

Model User’s Guide 
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OSPF Configures interface cost, OSPF 
start time, areas, and route 
re-distribution.

Model User’s Guide 

RIP Configures RIP start time and 
route re-distribution from other 
protocols into RIP. 

Model User’s Guide 

MPLS Configures MPLS. Model User’s Guide

LDP Enables/disables LDP protocol 
status on all/selected routers.

RSVP Enables/disables RSVP protocol 
status across connected interfaces 
on all/selected links.

Model User’s Guide 

ATM Configures over-subscription on a 
per-service class basis for all or 
selected nodes in the network.  

Model User’s Guide 

Frame Relay Configures PVCs between nodes 
in the network. 

Model User’s Guide 

Ethernet Configures Ethernet. Model User’s Guide

FDDI Configures FDDI. Model User’s Guide

VLAN Configures virtual LANs (VLANs) 
for selected nodes and links.

Model User’s Guide 

STP Applies STP visualization to the 
current scenario. 

MANET Configures MANET. DSR Model User’s Guide

UMTS Configures UMTS. Model User’s Guide

Wireless LAN Configures Wireless LAN. Model User’s Guide

Table 3-4   Protocols Menu Items

Menu Item Description Reference
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Capacity Planning Menu

Evaluate Capacity Planning > Evaluate or click the Evaluate Current Network toolbar 
button: Evaluate the scenario in its current state during the specified time 
interval or intervals. This is different from running an optimization in that it 
evaluates the scenario with the current capacities for links and networks. It does 
not mutate the capacities of the links and networks. It routes the traffic through 
the links and broadcast networks, and provides a summary of the scenario’s 
current condition.

1) After choosing the Evaluate menu item or clicking the Evaluate Current 
Network toolbar button, the Evaluation Settings dialog box displays.

Figure 3-178     Evaluation Settings dialog box 

The Evaluation Settings dialog box allows you to set the number of time 
steps, length of each time step, and the start time. For example, if you know 
that your peak usage occurs from 9 A.M. to noon, you could evaluate that 
time period by setting number of time steps to 3, length of time step to 1 
hour, and start time to 9 hours 0 minutes 0 seconds.

You can set the following parameters for the evaluation:

a) Number of Time Steps: A Capacity Planning Evaluation can be done 
for multiple time steps by setting this value to an integer greater than 
one.  Reports will be created for the evaluation at each time step as well 
as reports reflecting results over the entire time of evaluation. Must be 
an integer greater than zero.

b) Length and Units of Time Steps: The length and units of the time steps 
used in the evaluation. The value selected must be an integer greater 
than zero. Units can be seconds, minutes, hours, days or weeks.

c) Start Time: The start time used for the evaluation in hours, minutes and 
seconds. All values must be integers greater than or equal to 0.

d) Advanced Parameters: Opens a dialog box for more parameters for the 
evaluation and reporting of the evaluation.

e) Click the Apply button to save any changes you made to the settings.
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2) If you click the Advanced Parameters button to access advanced 
evaluation settings, the Evaluation Settings Advanced dialog box displays.

Figure 3-179     Evaluation Settings Advanced dialog box

You can set the following advanced parameters for the evaluation:

a) Naming Convention: The names of all the devices and links that are in 
the report will use the naming convention selected here.

b) Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports.

c) Include Individual Link Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each link in the 
scenario.  The reports will include all the traffic going directly over the link 
as well as any circuits that are going over the link.  The reports will take 
longer to generate if this option is selected.

d) Include Individual Circuit Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each routable 
circuit.  The reports will include all the traffic using the circuit.  The 
reports may take longer to generate if this option is selected.

e) Enable IP Load Balancing: If this checkbox is selected, IP load 
balancing will be done during the evaluation so that traffic will use 
multiple equal hop length paths. 

f) Number of Balanced Routes to Report: If IP load balancing is 
selected, then the number of balanced routes to report can be selected.  
The entry must be an integer greater than 0.  This number of route 
reports will be reported in the web reports
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g) Allow ATM SVCs to be Setup: If this checkbox is selected, ATM SVCs 
will be setup during the evaluation when applicable.

h) Click the OK button to save any changes you made to the settings.

3) Once everything is set, click the Run button in the Evaluation Settings 
dialog box to start the evaluation.

The evaluation engine evaluates the specified number of time steps using 
only the traffic, circuits, devices, and links active at each time step. For 
traffic that is active during only a portion of the time step, the load will be 
prorated according to the fraction of the time step the traffic is active. 
Circuits, devices, and links will be considered active only if they are active 
at the end of the time period. 

4) Once the evaluation is complete, the evaluation web reports launch 
automatically.

The web reports include the following reports for the overall evaluation: 
Executive Summary, Overall Peak Results, and Overall Average Results.  
Additionally there are a group of reports which are generated for each time 
step: Traffic Report, Link Utilization Report, Residual Bandwidth Report, 
Circuit Switch Link Report, Transmission Link Report, Data Link Report, 
ATM & CellXpress TVC Report, Frame Relay Report, TSSP Circuit Report, 
and Multiplexer Circuit Report. There are also Route Reports for each 
routed circuit and traffic IER, and Unroutable Reports for each unroutable 
circuit and traffic IER. Each Individual Link also has a group of tables that 
show the circuit and traffic IERs which flow over it specifically. 

If a load object (IER, IP Flow, Promina circuit, etc.) is unroutable, the 
Unroutable Report will list reasons why the load could not be routed.  The 
following table lists all possible failure messages and their associated 
suggestions.:

Table 3-5   Route Failure Messages and Suggestions

Message Suggestion

There was no path at the Promina 
layer.

Make sure all of the necessary links between 
Promina devices have been added to the scenario.  
Also, check for lower-level CellXpress circuit failures 
that could prevent Promina devices from 
communicating.

There was no path at the ATM layer. Make sure all of the necessary links between ATM 
devices have been added to the scenario.

There was no path at the Frame 
Relay layer.

Make sure all of the necessary links between Frame 
Relay devices have been added to the scenario. 

There was no path at the Voice layer. Make sure all of the necessary links between Voice 
devices have been added to the scenario.  Also, 
check for lower-level Promina circuit failures that 
could prevent Voice devices from communicating. 
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Capacity
Optimization

Capacity Planning > Capacity Optimization > (option): Run an optimization 
for capacity. Given a network and the traffic, the optimization process provides 
suggestions for optimal link and network capacities. If a link is over-utilized, 
optimization will suggest an alternate capacity that will support the IERs and 
keep the cost of the link down to the required minimum. If a link is under-utilized, 
optimization will decrease the capacity for that link. Capacity optimization 
options are discussed in the sections below.

Application profiles are converted to IERs when a user evaluates or optimizes a 
scenario for the first time. Once the profiles have been converted to IERs, they 
are retained as IERs. The conversion process is not initiated again unless you 
add more application profiles.

There was no path at the IP layer. Make sure all of the necessary links between routers 
have been added to the scenario.  Also, check for 
lower-level circuit failures that could prevent IP 
routers from communicating.

An end device that can support this 
IER could not be located in the 
producer or consumer OPFAC.

Make sure the source and destination OPFACs both 
contain a non-failed end device that supports the 
IERs traffic type.

There was a mismatch in the number 
of layer 3 encryptors and decryptors 
in this route.

Make sure each layer 3 encryptor (NES, 
IP_ATM_TACLANE, etc.) has a corresponding 
decryptor.

Selected path for Promina circuit is 
invalid.

Make sure all necessary links between Prominas in 
the Selected Path have been added to the scenario.  
Also, check for lower-level CellXpress circuit failures 
that could prevent Promina devices from 
communicating.

Selected path for Promina circuit 
does not have sufficient bandwidth.

Increase the capacity of the links between Prominas 
in the selected path, or add additional links between 
the Prominas.

<xxx>  circuit does not have enough 
bandwidth.

Increase the reserved bandwidth of the circuit.

<link_name> does not have enough 
bandwidth.

Increase the capacity of the link or add an additional 
link between the endpoints.

Table 3-5   Route Failure Messages and Suggestions

Message Suggestion
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Capacity
Optimization >

Start Optimization

Capacity Planning > Capacity Optimization > Start Optimization: Specify 
parameters that control how optimal solutions for the scenario are computed. 

1) Select Start Optimization or click the Start Capacity Optimization 
toolbar button: The Capacity Optimization Settings dialog box displays.

Figure 3-180     Capacity Optimization Settings dialog box 

These options let you set optimization parameters:

a) Time Settings: Allows you to specify the start time and the duration for 
the optimization process. Only traffic that is active during the specified 
time frame is considered while optimizing.

b) Voice and Data Target Utilization: Specifies the average percentage 
utilization we are trying to achieve on the voice and data portions of the 
trunks.

c) Maximum Utilization: Specifies the maximum percentage utilization we 
are trying to achieve on the voice and data portions of the trunks. 

d) Link Goals, Traffic Load, and Performance Weights:

Link Goals: This value allows you to optimize for different criteria. If you 
want to minimize the capacity, move the slider to the left (towards 
Capacity). This will produce a final solution in which the capacity is 
reduced. If the target utilization is more important to you, move the slider 
to the right (towards Utilization). This will produce a final solution in 
which the link utilization values are closer to the target.

Traffic Load: This value allows you to control the load caused by the 
traffic on the network. If you set this value to 1, the engine uses the mean 
values from the distribution. As you increase this value, the engine uses 
values from the tail of the distribution. If the distribution type is 
"Constant,” this parameter does not make a difference.
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Performance – This value allows you to specify how fast or how 
accurate you want the optimization solution to be. If you set this slider at 
1, the engine converges on a solution quickly at the cost of accuracy. If 
you set this slider at 10, the engine tries more configurations and the 
solution may be better, but it will take longer.

2) Click the Advanced Parameters button on the Capacity Optimization 
Settings dialog box. The Advanced Parameters dialog box displays.

Figure 3-181     Advanced Parameters dialog box 

Configure advanced parameters, if needed, or use the default values:

a) Random Seed: This is the seed value used by the random number 
generators in the optimization engine.

b) Unroutable Demand Penalty: This is the penalty that will be added to 
the optimization cost for each IER that is unroutable in this configuration.

c) Number of Solutions to Store: The optimization engine stores the 
configurations corresponding to the 'n' best solutions and you can switch 
back and forth between these solutions. This value specifies the number 
of such solutions to store.

d) Penalize Underutilization: The utilization cost depends on the 
difference between actual link utilization and target utilization, 
regardless of whether link utilization is over or under target utilization. 

e) Allow ATM SVCs to be Setup: By not allowing ATM SVCs to be setup, 
you are forcing the Scenario Builder to always look for PVCs between 
gateway ATM devices. In this case, the route taken by the IER in the 
Scenario Builder will be the same as that in the simulation. 
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f) Enable IP Load Balancing: Allows you to disable or enable IP load 
balancing to be done during the evaluation so that traffic will use multiple 
equal hop length paths.

g) Per Hop Cost: This is a fixed cost that is computed for each load based 
on the number of device-to-device hops in the route. If there are multiple 
solutions that have the same objective cost, adding this cost will ensure 
that the solution in which the loads have the shortest path is chosen as 
the best solution.

3) Click Run to begin the optimization.

JCSS computes the routes for the traffic and then starts the optimization. 
After the optimization completes, a dialog box displays a summary of the 
optimization process:

a) Original Average Values - Displays the values before the optimization 
process was started.

b) Final Average Values - Displays the values at the end of the 
optimization.

c) Summary Table - Displays a list of links and broadcast networks for 
which the optimization engine suggested changes. Click on a row in this 
table to display the Attributes dialog box for that link or network. This 
Attribute dialog box shows the original values and the current values 
suggested by the engine. You can accept the changes suggested by the 
engine or selectively reject the changes for some links while retaining 
the changes for the others by setting the Status field to “Reject.”

Capacity
Optimization >

Save Optimization
As

Capacity Planning > Capacity Optimization > Save Optimization As: Save 
the results of an optimization as part of the scenario, so that it is available for 
future comparisons.  

During an optimization, JCSS might suggest changes to the link and network 
bandwidths or to the inter-arrival times of the IERs. If you save the project after 
an optimization, these values become the actual values and you will not be able 
the previous values.
JCSS/Release 7.0 TR-3-155



3—Scenario Builder JCSS Technical Reference Manual
To prevent losing the original values accidentally, you will be prompted by a 
dialog to save the scenario under a different name. If you choose this option, a 
copy of the scenario is made under the current project and the values in the 
original scenario are left unchanged.

1) Enter a name for the optimization and click OK. The name is used to identify 
the optimization in the Manage Results interface.

Figure 3-182     Save Optimization As dialog box

Capacity
Optimization >

Manage
Optimization

Results

Capacity Planning > Capacity Optimization > Manage Optimization 
Results: Access the Manage Capacity Optimization Results to delete 
optimization results from the scenario’s state, compare optimizations, and make 
one of the optimization solutions the current solution.

Figure 3-183     Manage Capacity Optimization Results dialog box

Select the row number(s) for the optimizations to compare, delete, or install as 
current solution, and then click the corresponding button.
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Capacity
Optimization >

Examine Top
Solutions

Capacity Planning > Capacity Optimization > Examine Top Solutions: 
Examine top solutions returned by the optimization. At the end of optimization, 
the engine returns the best solution that it found so far. Sometimes the best 
solution might have suggestions that you do not agree with. In such cases, 
review a few of the top solutions and use the one that you think is the best. You 
can specify the number of top solutions that the engine must store. At the end 
of optimization, you can review the top solutions and pick the one that suits your 
needs.

You can specify the number of solutions to store using the Advanced 
Optimization Parameters. 

1) The top most solution is highlighted in yellow. If you prefer a different 
solution, you can click on the drop-down menu at the top of the dialog box 
and change the currently visible solution.

Figure 3-184     Examining the Top Solutions

Capacity
Optimization >

Restore Original
Capacities

Capacity Planning > Capacity Optimization > Restore Original Capacities: 
Restore the scenario’s original capacities after an optimization is run.

Reports Capacity Planning > Reports > (option): Open the listed reports.

Reports > View
Web Report

Capacity Planning > Reports > View Web Report: Launch the most recent 
Capacity Planner web report for this scenario.
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Reports > Settings Capacity Planning > Reports > Settings: Web report settings are used in the 
web reports produced after a Capacity Planning Evaluation or Optimization.

Figure 3-185     Web Report Settings dialog box

These options let you set report parameters:

• Naming Convention: The names of all the devices and links that are in the 
report will use the naming convention selected here.

• Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports.

• Include Individual Link Traffic Reports: If this option is selected, individual 
reports will be included in the web report for each link in the scenario.  The 
reports will include all the traffic going directly over the link as well as any 
circuits that are going over the link.  The reports will take longer to generate 
if this option is selected.

• Include Individual Circuit Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each routable circuit.  
The reports will include all the traffic using the circuit.  The reports may take 
longer to generate if this option is selected.

• Number of Balanced Routes to Report: If IP load balancing is selected, 
then the number of balanced routes to report can be selected.  The entry 
must be an integer greater than 0.  This number of route reports will be 
reported in the web reports.
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NetDoctor

NetDoctor is a powerful rules-based engine that proactively identifies incorrect 
device configurations, including policy violations and inefficiencies. NetDoctor 
exposes hidden problems that can be difficult to discover due to the sheer 
volume of configuration information distributed throughout the network.

NetDoctor rules are normally run against model attributes, which are set from 
device configurations that you can import from a production network. Also, 
some NetDoctor rules use simulation data to identify inconsistencies in the 
operation or performance of the network.

You can run all of the NetDoctor rules on a JCSS network, except for the ones 
that have JCSS devices in them, usually on the networks that are created from 
Device Configuration Import (DCI). For the networks with JCSS devices in them, 
you can run only rules that are devised for individual devices or a device group.

Note—A separate NetDoctor license is required in order to run NetDoctor in 
JCSS. A JCSS license does not include a NetDoctor license.

The table below outlines the main menu options under NetDoctor:

Please refer to the NetDoctor User’s Guide (Chapter 3, Using NetDoctor) under 
the ITGuru product documentation for details on using NetDoctor.

Table 3-6   NetDoctor Menu Items

Menu Item Description

Configure/Run NetDoctor... Configure, save, and run NetDoctor report templates.

Run NetDoctor... Run NetDoctor using an existing report template.

Auto-Generate Report Template... Create a NetDoctor Report Template.

View Recent NetDoctor Reports... Choose a recently run NetDoctor report and open it in 
the appropriate viewer.

Configure/Run Trending Configure and generate NetDoctor Trending reports. 
Note: NetDoctor trending is project-specific. You 
cannot trend NetDoctor data using scenarios from 
more than one project.

Open NetDoctor Log Display the NetDoctor Log file contents.

Suppress Messages Choose not to display NetDoctor messages.

Rule Development... Create new or edit existing NetDoctor rules.

Options Configure NetDoctor operation and report generation 
settings.
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DES (Discrete Event Simulation) Menu 

Configuration OPFAC

Every time a new scenario is created (or an older scenario is converted), a 
Configuration OPFAC will automatically be placed in the top-level subnet. 
Simulations cannot be run if this object is not present in the scenario, therefore, 
the Configuration OPFAC cannot be deleted or duplicated. The Configuration 
OPFAC is an actual OPFAC, and can be accessed via the treeview or the 
workspace (the default location for the OPFAC is 60, -150). The Configuration 
OPFAC contains (at least) these four utility nodes: Failure/Recovery, Wireless 
Failure/Recovery, Standard NETWARS Node, and QoS.

Failure/Recovery Node

JCSS failure/recovery functionality allows you to specify a time interval or period 
of time for which devices of an OPFAC are inoperable. You can also specifying 
failure and recovery times for organizations, links, individual devices, and 
OPFACs. This feature simulates equipment failures or loss of forces. 
Failure/recovery times are specified on the individual objects listed above, 
however, once specified, the failure/recovery times for all objects in the scenario 
reside on the Failure/Recovery node. This node can be deleted.

1) From the Scenario Builder, right-click on an organization, link, individual 
device, or OPFAC to open the shortcut menu.

2) On the shortcut menu, select Edit NETWARS Attributes. The Attributes 
dialog box displays.

3) Click the Failure/Recovery button at the bottom of the dialog box. The 
Failure/Recovery Times dialog box displays.

Figure 3-186     Failure/Recovery Times dialog box
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4) Click Insert. A failure/recovery time with default values displays in row 1. 
Edit the Device, Time, and Status fields as needed. Repeat as needed to 
create all failure/recovery times for the selected object.

Figure 3-187     Inserting a Fail Time

5) Click OK to close the Failure/Recovery Times dialog box, and then click OK 
again to close the Attributes dialog box. Repeat steps 1–5 to create 
failure/recovery times for other scenario objects.

6) To view all failure/recovery times for the scenario, right-click on the 
Failure/Recovery node in the Configuration OPFAC and select Edit 
Attributes. 

7) Next, click in the Value cell of the Link Failure/Recovery Specification 
attribute and select (…) to view link failure/recovery times, or click the 
Value cell of the Node Failure/Recovery Specification attribute and 
select (…) to view node failure/recovery times.

Figure 3-188     Failure/Recovery node attributes

Wireless Failure/Recovery Node

The Wireless Failure/Recovery node works in the same manner as the 
Failure/Recovery node explained above, except it is only used for wireless 
networks (i.e., broadcast networks). This node can be deleted.
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Standard NETWARS Node

The Standard NETWARS node must exist to run a simulation; therefore, it 
cannot be deleted. Before a simulation is executed, certain parameters that 
influence the behavior of the simulation can be configured from this node. These 
parameters, which specify the behavior of traffic during simulation, are 
configured through the Priority Table, Decision Table, and System Element 
Table. These tables are accessible via the Standard NETWARS node shortcut 
menu by selecting Edit Attributes.

Figure 3-189     Accessing the Decision Table and Priority Table

Priority Table This table can be used to specify how the simulation deals with 
failed IER transmissions due to busy sending and receiving devices. For each 
precedence type, you can specify the number of retries and the wait time 
between retries.

Figure 3-190     Priority Table
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From this table we can see that if a Flash IER cannot be fired at the specified 
time, the simulation will wait for 5 seconds and try to send it again. For Flash, 
the simulation will try a maximum of 12 times before failing the IERs.

Decision Table and System Element Table When creating IERs, you specify the 
producing and consuming OPFACs. You do not have to specify the device 
within the OPFAC that produces or consumes the traffic, but the simulation 
needs to know the device within the OPFAC that handles the traffic.

This device selection process can be left to the simulation with the help of the 
Decision Table and the System Element (SE) Table. These tables have a series 
of entries tying the type of traffic, the classification, and the equipment type to 
be used for that traffic to the actual device within an OPFAC.

Figure 3-191     Decision Table and System Element Table

When it is time for the simulation to send traffic, it looks for a matching entry in 
the Decision Table. If an entry is found, it looks in the SE table corresponding to 
that entry for a matching equipment type. Using the equipment type and 
classification obtained from these two tables, the simulation looks for a device 
within the producer and consumer OPFACs that can produce and consume the 
traffic.

The Priority Table and Decision Table can also be configured in the 
Configuration OPFAC utility.
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Quality of Service (QoS) Node

The QoS node is used to define custom QoS schemes and apply 
quality-of-service constraints to your network. This node can be deleted.

Before a simulation is executed, certain parameters that influence the behavior 
of the simulation can be configured. 

Choose Individual
Statistics

DES > Choose Individual Statistics...: Choose statistics on devices, 
inter-OPFAC, and intra-OPFAC links to be collected during simulation.

1) Select the object in the workspace for which the statistics will be collected 
(includes all devices, the OE, inter-OPFAC, and intra-OPFAC links).

2) Select DES > Choose Individual Statistics or select Choose Individual 
Statistics from the shortcut menu. The Choose Results dialog box 
displays.

3) Select statistics to be collected during a simulation by clicking the 
checkboxes next to the desired statistics.

Figure 3-192     Choose Results dialog box
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4) Right-click on the individual statistic to make changes to the collection 
mode or draw style.

Figure 3-193     Change Collection Mode or Draw Style
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Choose Statistics
(Advanced)

DES > Choose Statistics (Advanced): In the Probe Model window, choose 
advanced statistics on devices, inter-OPFAC, and intra-OPFAC links to be 
collected during simulation.

Figure 3-194     Probe Model Window

Record Packet
Flow 2D Animation

for Subnet and
Record Node

Movement 2D
Animation for

Subnet

DES > Record Packet Flow 2D Animation for Subnet and DES > Record 
Node Movement 2D Animation for Subnet: Turn on or off the collection of 
animation data from the subnetwork. This data allows you to view the packet 
flow and (with the Wireless Module) node movement that occurs during a 
simulation.
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Expert Service
Prediction >

Define Service
Level Agreement

DES > Expert Service Prediction > Define Service Level Agreement: 
Defines the thresholds for a service level agreement (SLA.)

Figure 3-195     Define Service Level Agreement dialog box

• Show Compliance pull-down menu/fields: Displays a statistic’s compliance 
with an SLA. An SLA can include thresholds for one or more statistics. To 
view a statistic’s compliance, select it in the Statistic Browser. You must set 
each statistic’s threshold individually; if you select multiple statistics and set 
a threshold, the threshold applies only to the last statistic you selected. 

• Bucket Duration field/pull-down menu: Sets the duration for buckets for the 
simulation run. If a statistic has a bucket-capture mode set to time average, 
sum/time, or count, the SLA measures compliance for the entire simulation 
run. For all other statistics, it divides the total simulation run into buckets (set 
by the Bucket Duration field) and measures compliance for each bucket. 

• Service Level Agreement pull-down menu: Allows edits to existing service 
level agreements. 

• Import All Statistics button: Lists statistics for all models listed in the 
mod_dirs directory. 

• Clear button: Deselects all statistics, and resets the statistics tree. 

• Save button: Opens the Save As dialog box, which allows you to save the 
thresholds defined for the scenario.

• Close button: Opens the Confirm dialog box, which prompts you to save your 
changes before closing.
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Configure/Run
Discrete Event

Simulation

DES > Configure/Run Discrete Event Simulation or click the Configure/Run 
Discrete Simulation button: Set the values of simulation attributes and control 
how a discrete event simulation (DES) runs in the current (or specified) 
scenario. The Configure/Run DES dialog box displays in simple mode. This 
dialog box has a set of commonly used dialog box controls, and two tabbed 
windows to configure DES inputs (Global attributes) and outputs (Reports.)

1) Set the duration of the simulation in the Duration field. The units are 
specified by the pull-down menu next to this field. This sets the duration 
simulation preference.

2) Set the number of values collected for each statistic in the Values per 
statistic field. This sets the num_collect_values simulation preference. 

3) Set the simulation attributes in the Global attributes window to the desired 
values. The Attribute table displays all simulation attributes declared by 
models involved in the scenario to be simulated and the values assigned to 
each attribute. Click on a question mark icon to display information about 
the corresponding attribute. Click on an Attribute Value to change it.

Figure 3-196     Configure/Run DES dialog box

For details on the attributes that can be configured on the Global attributes 
page, refer to the OPNET Editors Reference Manual (consult the IT Guru 
documentation set, available via Help > Documentation > IT Guru 
Documentation).
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4) Click the Reports tab to select Statistics and Service Level Agreement 
(SLA) reports for the simulation to collect. Reports are predefined sets of 
statistic probes.

• Record the following date and time in results label—Displays the date 
and time associated with the network model, if any.

• Generate web report for simulation results checkbox—When 
selected, simulation results are included in a report viewed from a web 
browser. 

• Minimum number of decimal places for statistics in output reports 
counter—Sets the number of decimal places to use in number formatting. 
If you expect values to differ in minute amounts, use a large number of 
decimal places. 

• Number of entries displayed in 'Top N' reports counter—Sets the 
value of 'N'. 

• Statistics reports pane—Specifies the statistics reports to generate at 
the end of the simulation. Each selected value is added to the reports 
simulation preference. 

• Define Statistics Report button—Opens a dialog box used to define 
new statistics reports. 

• SLAs pane—Specifies the SLA reports to generate at the end of the 
simulation. Each selected value is added to the sla_reports simulation 
preference. 

• Define SLA Report button—Opens a dialog box used to define new SLA 
reports.

5) Click the Detailed button if you want to open the Configure/Run DES dialog 
box in “detailed” mode. Detailed mode lets you configure all of the 
parameters of DES, some of which are not available in the simple mode. 
This dialog box contains a treeview of information categories for configuring 
different aspects of the simulation.

6) Click Cancel to close the dialog box without saving any changed settings, 
or click Apply to save the current settings and keep the dialog box open, or 
click Run to save the current settings, close the dialog box, and run the 
simulation immediately. The simulation runs for set duration, displaying 
frequent progress updates in the viewing window until completion.
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Configure/Run
Discrete Event

Simulation
(Advanced)

DES > Configure/Run Discrete Event Simulation (Advanced): Set the 
values of advanced simulation attributes and control how a simulation runs.

Run Discrete
Event Simulation

DES > Run Discrete Event Simulation: Run a simulation of the current 
scenario. The dialog box that appears displays the status of the simulation as it 
runs and allows you to pause or stop the simulation, if desired.

1) Choose DES > Configure/Run Discrete Event Simulation to open the 
Simulation Set dialog box.

2) If desired, set the simulation attributes.

3) Click the Run toolbar button. The Simulation Execution dialog box opens.

Figure 3-197     Simulation Execution dialog box
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JCSS displays a series of messages in this dialog box. These messages show 
the progress of the simulation, beginning with the initialization stages and 
continuing with run-time statistics. The following statistics are displayed at each 
update:

• Time: Current simulation time.

• Events: Total number of events processed. An event usually signifies the 
arrival of a packet or an interrupt at a module, triggering some kind of 
response within the module.

• Speed: Average – Simulation Sequence graph displays the average 
number of simulation events per second of real time (measured since the 
beginning of the simulation).

• Speed: Current – Simulation Sequence graph displays the instantaneous 
number of simulation events per second (measured using real time over the 
last update interval).

• Time: Elapsed – Real running time of the simulation.

The following buttons stop, pause, and resume the simulation:

• Pause / Resume button—Pauses / Resumes the current simulation. You 
can save the output generated by the simulation up to this point when 
pausing the simulation.

• Stop button—Stops the current simulation. You can save the output 
generated by the simulation up to this point. (This acts as if op_sim_end() 
was invoked by model code.) 

The following panels display:

• Simulation Speed panel—Displays a graph of the current and average event 
speed for the simulation.

• Memory Usage panel—Displays a graph of the OPNET-managed memory 
usage of the simulation. 

4) When the simulation is finished, click Close.

If fatal errors are present in the scenario when a simulation is run, the simulation 
process is aborted. A pop-up dialog box instructs you to access the Scenario 
Conversion Log file, which details errors that correspond to incorrect scenario 
elements requiring adjustment prior to a successful simulation. The log file, 
which resides on the on the same level as the nt.m file, can be opened using 
any text editor. When the simulation is complete, a file named <project 
name>-<phase name>.ov is saved in the same location as the nt.m file. This file 
will be used for results analysis.
JCSS/Release 7.0 TR-3-171



3—Scenario Builder JCSS Technical Reference Manual
Restart Discrete
Event Simulation

DES > Restart Discrete Event Simulation: Restart a simulation of the current 
scenario. 

Open DES Log DES > Open DES Log: Display the log of errors and significant simulation 
events maintained by JCSS during discrete event simulation. The DES log is 
written to a tab-delimited ASCII file. Because there may be many events in a 
DES log, a log browser is provided so that you can view only those events of 
interest to you.

Figure 3-198   Log Viewer

1) Click the module tabs to move between modules for which logs are 
available. The Miscellaneous tab gives you access to session and error 
logs.

2) Use the treeview provided in the Logs pane to select from the available logs 
associated with the selected module. 

3) For text-based logs, the Selected Log pane displays a single pane with 
simple text descriptions of events. For event-based logs, it displays two 
panes. The first pane displays sections of the log. Select the section(s) that 
you want displayed. The second pane displays the log data, one event per 
row.

• Click and drag the vertical lines in the header row to resize columns.

• Click on an entry in the Message column to open an edit pad containing 
the full text of the message.

4) Check (or uncheck) the Display logs for current scenario only checkbox 
to specify whether the treeview (in the Logs pane) should list all logs or only 
those for the current scenario.
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5) Click the Open Advanced Viewer button to open an advanced log viewer 
that provides additional capabilities using a menu bar. The additional 
capabilities include: changing which column is used to color-code a log 
entry, changing which columns are visible or filterable, saving the current 
viewer settings, and exporting the log information to a file.

6) Click the Close button to close the Log Viewer dialog box.

IER Results DES > IER Results > (option): Select one of the listed options to view the 
following simulation results: Sent IERs, Received IERs, Failed IERs, Blocked 
IERs, Sent Threaded IERS, Received Threaded IERs, and Failed Threaded 
IERs.

Results DES > Results > (option): Select one of the listed options to view simulation 
results in various formats.

Results > View
Results

DES > Results > View Results: Launch a graphical interface, the Results 
Browser, that allows the planner to browse a list of MOPs loaded from an output 
vector file and create graph panels to display the MOPs.

Figure 3-199     View Results
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The list of MOPs is categorized and displayed in a tree on the left of the 
interface. Global statistics are calculated from all objects in the simulation. 
Object statistics are calculated from individual objects, which are primarily links 
and OPFACs. One or more statistics may be selected from multiple categories 
at any time. 

Configuration options may be set in the drop-down lists immediately above the 
lists and below the graph preview. These options control how multiple MOPs or 
a single MOP from multiple scenarios are combined in a graph panel, and allow 
the planner to apply filters to the raw MOP data.

If more than one output vector file has been loaded, the upper-left list allows the 
planner to configure the graph panel to contain graphs of the selected MOP from 
the most recently loaded file (Current Scenario), from all files (All Scenarios), 
or from individually selected files (Select Scenarios). If All Scenarios or 
Selected Scenarios is chosen, only one MOP may be selected.

If multiple MOPs are selected, or a single MOP is being graphed from multiple 
files, the lower-right lists specify how the graphs will be combined on the graph 
panel. The Stacked Statistics option causes the panel to contain a separate 
graph for each MOP or file. The Overlaid Statistics option causes the panel to 
contain one graph on which all MOPs are plotted, using colors to distinguish the 
plots. The Individual Statistic option ensures that only one MOP can be 
selected at any time.

Once the graph has been configured, the planner may create an independent 
graph panel containing the MOP(s) by clicking on the Show button. The graph 
panel will have the same appearance as the preview, but will exist as an 
independent dialog and provide editing features that can further configure the 
graph. Any number of graph panels may be created by repeatedly selecting 
statistics, setting options, and clicking on Show.

Figure 3-200     MOP graph panel
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MOP graphs should be interpreted in the same manner as a standard line 
graph. The graph heading displays the name of the MOP; the X axis always 
represents simulation time; and the Y axis represents various units of 
measurement, depending on the MOP selected.

Figure 3-201     Speed of Service MOP

The table below lists MOPs and their descriptions:

Table 3-7   MOP Descriptions

MOP Description

IERs sent count A cumulative count of IERs sent.

Number of blocks for 
each IER sent

The number of times each IER was blocked.

Perishability for the rcvd 
IERs

A cumulative count of IERs received where the delay (IER_Rcvd 
IER_Start) is greater than the IER_Perish time.

Speed of service (in 
sec.) for the rcvd IERs

The delay (IER_Rcvd IER_Start) computed for each received 
IER.

Forward Data 
Throughput (in bits/sec.)

The throughput of the point-to-point link in the forward direction.

Reverse Data 
Throughput (in bits/sec.)

The throughput of the point-to-point link in the reverse direction.

Forward Link Utilization 
(percent)

The utilization of the point-to-point link in the forward direction.

Reverse Link Utilization 
(percent)

The utilization of the point-to-point link in the reverse direction.

Broadcast Network 
Utilization

The broadcast network utilization during the simulation. A value 
of ‘1’ indicates that the network was utilized, and ‘0’ indicates that 
it was not utilized.
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MOP graphs allow user interaction. For example, examine statistics by placing 
the cursor over a segment of the trace to display a tool tip regarding graph 
coordinates, or zoom in on any segment of the trace by drawing a small box 
around the segment with the cursor. Right-clicking on an MOP graph opens a 
shortcut menu that allows manipulation of graph properties and other 
capabilities such as modifying the look and style of the graph, exporting the 
graph data to a spreadsheet, and creating a graph template.

Figure 3-202     MOP shortcut menu

Connection latency (in 
sec.) 

The latency (IER_Sent IER_Start) in establishing a connection.

Grade of service The percentage of IERs received within the IER_Perish time.

Message completion 
rate

The ratio of the number of IERs of type ‘data’ received to the 
number of those sent.

Message error rate The ratio of the number of IERs of type ‘data’ that failed to the 
number which were sent.

Call completion rate The ratio of the number of IERs of type ‘voice’ received to the 
number of those sent.

Blocking probability The ratio of the number of IERs that were blocked at least once 
to the number which were sent.

End-to-end delay (in 
sec.)

The delay (IER_Rcvd IER_Sent) computed for each received 
IER.

Channel Utilization 
(percent) 

The percentage of channels on this link that are used.

Voice Throughput (in 
bits/sec.)

The number of voice calls that go through this link.

Table 3-7   MOP Descriptions

MOP Description
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Results > Find Top
Statistics

DES > Results > Find Top Statistics: Launch a graphical interface that allows 
the planner to browse a list of MOPs loaded from an output vector file and create 
reports listing the objects that have the highest or lowest values for that MOP. 
Average, maximum, minimum, and standard deviation values may be evaluated 
for each MOP.

The primary interface is a list of available MOPs that can be evaluated.

Figure 3-203     Select Statistic for Top Results
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1) Select a statistic and click the Find Top Results button to launch a report 
interface. Several report interfaces may be opened concurrently by 
selecting different MOPs and launching the interface for each in turn.

Figure 3-204     Top Results report interface

The report interface lists all objects that have recorded the selected statistic and 
displays the minimum, average, maximum, and standard deviation values 
calculated from each object’s MOP data. Initially, the list is sorted in decreasing 
average values, but the planner may dynamically resort the list in increasing or 
decreasing order for each column by clicking on that column’s header.

Both graph and text reports may be created from the report interface. The 
content of each report is controlled using the fields on the left of the report 
interface. The maximum number of objects included in the report is set in the 
Report on top N statistics field. Further constraints may be placed on the 
report by setting a boundary on allowed values for one of the four calculated 
columns. For example, the report can be constrained to include only objects for 
which the Average value is greater than (>) a specific value (1.0).

1) Create a graph panel containing the full MOP graph for all objects matching 
the constraints by clicking on the Graph button. The graphs for each object 
may be stacked or overlaid on the panel, and filters may be applied to the 
graphs, as specified in the two drop-down lists beside the Graph button.

2) Create a text report based on the constraints by clicking on the Text Report 
button. The text report will be displayed in a text-edit interface and may be 
saved from that interface.

The Find Object button is not operational, since the Scenario Builder does not 
contain a scenario model in which to find the objects named in the list.
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Results > View
Application Delay

Tracking

DES > Results > View Application Delay Tracking: Select an application 
delay tracking file and use the Application Segment Tracking Viewer to display 
its data.

Results > View
DES Reports

DES > Results > View DES Reports: Displays output tables generated during 
a discrete event simulation.

Results >
Generate Web

Report

DES > Results > Generate Web Report...: Generates a Web report that 
contains one or more of the reports available in the Results Viewer.

1) From the Select Tables for Web Report dialog box, choose the results you 
want to include in the Web report.

2) Select the Include Network Diagram checkbox if you want the web report to 
include a graphic of the network topology.

3) Click Generate.

4) Select a directory for the HTML files and click OK. 

5) The web report is created and opens in the default Web browser.

Results > Launch
Last Web Report

DES > Results > Launch Last Web Report: Opens most recently generated 
Web report in the HTML browser.

Results > Import DES > Results > Import...: Load a previously created .ov file. Select the file to 
load and then click OK; the data is loaded into the current project and is 
available for analysis. When multiple files are loaded, each file will be a distinct 
scenario. The name of the scenario will match the name of the output vector file. 
Multiple scenarios may be active in the Scenario Builder concurrently, so that 
their MOPs may be graphed and compared.

Play 2D Animation DES > Play 2D Animation: View collected animations. Toolbar buttons display 
to control operations for playing animation sequences, pausing animation, and 
speeding animation up or slowing it down. You can also load animation history 
files, view “real-time” animation (simultaneously with an executing simulation), 
and use a variety of operations to control how animation data displays. The 
largest area of the display—the animation viewing area—is where you can load 
and view animations. Animation displays in windows called viewers. A viewer is 
a rectangular region with an internal coordinate system. Viewer windows can be 
manipulated using the standard GUI operations for moving, resizing, scrolling, 
and circulating editor windows.

The following toolbar buttons control animation operations:

• Play: Activates any animation flow that has been established.

• Pause: Pauses an animation indefinitely, until another operation reactivates 
it.
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• Restart: Restarts a paused or stopped animation flow from its beginning.

• Terminate: Stops an animation flow. After it is stopped, an animation can be 
restarted only using the Restart Animation flow operation.

• Slow Down Animation: Slows down the animation sequence in increments.

• Speed Up Animation: Speeds up the animation sequence in increments.

Panels DES > Panels: Display a list of all open panels and select one to make active. 

Panel Operations DES > Panel Operations > (option): Select one of the operations listed below 
to control panel display.

• Arrange Panels:

— Show All: This operation draws any analysis panels previously hidden.

— Hide All: This operation hides all analysis panels that have been drawn.

— Distribute: This operation arranges open panels along a grid but (unlike 
tile) does not redraw them to a uniform size.

— Cascade: This operation arranges open panels in an overlapping pattern 
that ensures the title bar of each panel is visible. Panels are not redrawn 
to a uniform size, unlike the tile operation.

— Tile: This operation redraws open panels to a uniform size and arranges 
them in a grid.

• Panel Annotations:

— Make All Panels Into Annotations: Creates annotation objects from all 
open analysis panels.

— Delete All Panel Annotations: Deletes all analysis panel annotations in 
the network.

• Panel Templates:

— Create From All Panels: Makes all analysis panels in the current 
scenario into templates.

— Load With Latest Results: Applies current statistics to all templates in 
the scenario.
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• Export Panels:

— To BMP: Creates BMP images of all graphs currently available in the 
Scenario Builder. Select a directory in which to place the new image files. 
One image file is then created for each graph.

— To TIFF: Creates TIFF images of all graphs currently available in the 
Scenario Builder. Select a directory in which to place the new image files. 
One image file is then created for each graph.

— To PowerPoint: Creates a PowerPoint document containing images of 
all graphs currently available in the Scenario Builder. Select a directory 
and provide a name for the new PowerPoint file.

• Reload Data Into All Panels: Reloads data into all panels.

• Delete All Panels: Deletes all analysis panels in the current scenario.
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Windows Menu

Previous Editor Windows > Previous Editor: Make the previously displayed editor the current 
editor.

Circulate Editors Windows > Circulate Editors: One at a time, make each open editor the 
current editor.

Hide This Editor Windows > Hide This Editor: Hide the current editor. If another editor is open, 
that editor is made the current editor. 

Hide Other Editors Windows > Hide Other Editors: Hide all open editor windows except the 
current one. 

Show All Editors Windows > Show All Editors: Re-display any hidden editors. 

Configure Toolbar Windows > Configure Toolbar: Customize the main toolbar by adding and 
deleting desired buttons, selecting button icons and names, and moving button 
order. 

To add a toolbar button, select an available operation from the left pane and 
then click the Add>> button. Use the Move Up or Move Down buttons to 
position the button in the desired toolbar location. In the Title field, enter a 
button title. Next, click the Choose button and select the desired icon from the 
palette that displays. Click OK.

To remove a toolbar button, select a button in the right pane and then click 
<<Remove.

Use the Move Up or Move Down buttons to reposition a button in the toolbar.
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Use the Add Separator>> button to add a divider between button icons.

Figure 3-205     Configuring the main toolbar

Show Toolbar Windows > Show Toolbar: Show or hide the main toolbar.

Float Toolbar Windows > Float Toolbar: Allow the main toolbar to be dragged and dropped 
anywhere in the viewing area.

Figure 3-206     Floating Toolbar

Note—The Configure Toolbar, Show Toolbar, and Float Toolbar options are 
also accessible on a shortcut menu, which is available by right-clicking on the 
toolbar.
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Help Menu

This menu is identical to the System Editor Help menu. See the Help Menu 
section in chapter 2 of this manual.
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4 Icon Database

The Icon Database allows you to create new icons for OPFACs and 
organizations displayed within the Scenario Builder.

Accessing the Icon Database

Access the Icon Database using the File > New Other or File > Open Other 
commands in the System Editor. The Icon Database is used to create new icon 
palettes (databases) that can be a collection of new customized icons and icons 
that are already present. The Image Editor that is a part of the Icon Database is 
used to create / modify the icons. The individual icons are organized into icon 
database files, with the suffix .icons. Many icon databases are included as part 
of JCSS; you can also create your own icon databases. 

Figure 4-1   Icon Database and Image Editor
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You may wish to modify icon databases; you may also wish to modify individual 
icons. Use the Icon Database window to modify the icon database. Use the 
Image Editor window to modify individual icons (double-click an icon in the Icon 
Database to launch the Image Editor.) You cannot create a single icon file, but 
you can create an icon database file that contains a single icon.

You cannot save an individual icon while in the Image Editor. To write the data 
related to an individual icon to disk, close the Image Editor and choose the Save 
operation in the Icon Database to save the entire database.

The icon databases included with JCSS are stored in various locations. Icons 
specific to JCSS are stored in: 
Netwars/Scenario_Builder/12.0.A/netwars/icons.
COTS icons are stored in: 
Netwars/Scenario_Builder/12.0.A/models/vendor_models.

Other icon databases are in the appropriate model directory or in the sys 
directory. When you create an icon database, it is stored in your default directory 
(the first directory listed in your mod_dirs preference, typically op_models).

File Menu

New File > New: Create a new icon database. This will open a blank database to 
which new icons can be added and the database can be customized. 

Open File > Open: Open an existing icon database. Once the database is opened, 
new icons can be added, existing icons can be deleted or modified using the 
image editor. 

Close File > Close: Close the currently open icon database. 

Save File > Save: Retain changes to an icon database. 

Save As File > Save As: Save the current database under a different name. Specify a 
name and click OK; the icon database is stored in <User_Data>\SB_Data. 

Manage Model
Files

File > Manage Model Files > (option): This submenu lists options which allow 
you to delete model files, add a model directory, or refresh model directories.

Exit File > Exit: Closes all windows and exits JCSS. 
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Edit Menu

Cut Icon Edit > Cut Icon: Cut the selected icon to the clipboard. 

Copy Icon Edit > Copy Icon: Copy the selected icon to the clipboard. 

Paste Icon Edit > Paste Icon: Paste the selected icon from the clipboard. 

New Icon Edit > New Icon: Create and add a new icon to an existing or new database. 
Click in the workspace to create a new icon with missing name as the name, 
and a default image for the icon. 

Delete Icon Edit > Delete Icon: Delete an icon from the icon database. 

Preferences Edit > Preferences: Display and edit JCSS preference settings. 

Windows Menu

This menu is identical to the Scenario Builder Windows menu. See the Windows 
Menu section in chapter 3 of this manual.

Help Menu

This menu is similar to the System Editor Help menu. See the Help Menu 
section in chapter 2 of this manual.
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App A Time Varying Infrastructure

You can define start and stop times for the infrastructure during a simulation run, 
which includes relationships, Promina circuits and satellite links. IERs will only 
be allowed to pass if they fall within the active time window of the infrastructure.

Relationships

The Relationship Attribute dialog box includes a button to specify start and stop 
times.

Figure A-1   Relationship Attribute dialog box

Clicking on the Specify Start/Stop Time button allows you to specify different 
start and stop times for a relationship. Start and stop times must be entered 
consecutively START/STOP, START/STOP, etc., as shown below.

Figure A-2   Specify Start/Stop Time dialog box
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IERs imported from a text file or the database that are tied to an explicit 
relationship will have the start and stop times assigned to the relationship 
applied to them.

User-created IERs can also have a relationship associated with them. You can 
set this relationship from a list of all relationship types attached to the producer 
OPFAC. Start and stop times assigned to the relationship will be applied to the 
IER.

Imported IERs with implicit relationships are not tied to a relationship, so you 
have to manually specify the start and stop times for these IERs when 
viewing/editing traffic.

Promina Circuits (smart multiplexers)

You can specify the start and stop time for a Promina circuit in the Portmap 
Configuration Table, accessed by opening the shortcut menu for a Promina 
utility, selecting Edit Attributes, and then selecting the Portmap 
Configuration option. In addition, you can also specify these times using the 
Promina Configuration Wizard, as shown below.

Figure A-3   Promina Configuration Wizard
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Satellite Links

The Satellite Link Attributes dialog box allows you to specify start and stop 
times.

Figure A-4   Satellite Link Attributes
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App B System Administration Utilities

Types of Administrators

System Administrators

• System Administrators are determined and managed by local policies. They 
alone have the access to install and remove software from computers. They 
are members of the Administrators group, based on the user ID and 
password submitted to the operating system authentication management. 

Database Administrators

• Database Administrators are database accounts that have the authority to 
create new databases and manage database accounts. These accounts 
authenticate to the Microsoft SQL Server 2000 Desktop Engine (MSDE) 
helper application installed as part of JCSS. 

• sa is a built-in Database Administrator account. JCSS requires a new 
password for sa during installation, because leaving the password 
unchanged represents a security vulnerability whereby an unauthorized 
individual could view and make changes to data and login accounts in the 
MSDE service. The default password is netwars.

• JCSS prompts for a Database Administrator user ID and password each time 
before performing any database operation requiring Database Administrator 
authority. These operations are determined by MSDE.

Local Administrator User Profile

• Every installation of JCSS has a Local Administrator user profile. You can 
login using this profile to make changes to the pre-configured section of the 
object library. 

• JCSS stores the login information for the five (5) most recently used 
accounts. The Local Administrator profile is always available and is in 
addition to the five (5) most recent users. 

• This special account does not have any security implications. Just as with 
any JCSS user profile, the Local Administrator account is not protected by a 
password. 

• In addition to selecting a user profile when starting JCSS, the current user 
profile can be changed from the Edit > Change User menu item of the main 
JCSS window.
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Database Administration

Database User Account Creation

During installation, JCSS creates a database user account with username 
scenario_builder and password netwars. Only Database Administrators 
registered with MSDE may create new Database User accounts. 

Procedure B-1   Create a New User Account

1 In the System Editor, select IER Database > Manage Accounts > Administrator.

Figure B-1   IER Database Menu’s Manage Accounts Submenu

2 Type your Database Administrator ID and password as prompted.

3 If you authenticate properly, a dialog box displays. Type a new user ID and 
password. The password will not be visible after it is entered, so you must enter it 
twice to confirm it.

End of Procedure B-1
TR-B-2 JCSS/Release 7.0



JCSS Technical Reference Manual App B—System Administration Utilities
Database Admin Account Creation

Only Database Administrators registered with MSDE may create new Database 
Administrator accounts. 

Procedure B-2   Create a New Admin Account

1 In the System Editor, select IER Database > Manage Accounts > User.

2 Type your Database Administrator ID and password as prompted.

3 If you authenticate properly, a dialog box displays. Type a new Administrator ID 
and password. The password will not be visible after it is entered, so you must 
enter it twice to confirm it.

End of Procedure B-2
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Database Creation

Only Database Administrators registered with MSDE may create new 
databases. 

Procedure B-3   Create a New Database

1 In the System Editor, select IER Database > New.

Figure B-2   IER Database Menu of the System Editor

2 Type your Database Administrator ID and password as prompted.

3 If you authenticate properly, a dialog box displays. Type a name for the new 
database. A new database will be created in that name, if valid, and filed with the 
default database information. 

End of Procedure B-3
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Database Copying

Only Database Administrators registered with MSDE may copy an existing 
database to a new database.

Procedure B-4   Copy a Database

1 In the System Editor, select IER Database > Duplicate.

2 Type your Database Administrator ID and password as prompted.

3 If you authenticate properly, a dialog box displays. Type a name for the new 
database. A new database will be created in that name, if valid, and filed with the 
default database information. 

End of Procedure B-4
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App C Operation/Maintenance Procedures

Object Library

JCSS does not enforce access restrictions on the Organization and OPFAC 
Library. Users should follow the policies and procedures of their organization 
when creating or modifying library contents.

OPFAC and Organization Library

The OPFAC and organization library are divided into two parts: 

• Custom Library 

• Pre-configured Library

Custom Library

The custom library contains OPFACs and organizations that were created or 
modified by the user. All users have privileges to edit the contents of the custom 
library. You can make copies of the standard templates, store them in the 
custom library and then make changes to them. OPFACs and organizations in 
the custom library are called custom templates. 

Pre-Configured Library

The pre-configured library contains doctrinal OPFACs and organizations. 
OPFACs and organizations in the pre-configured library are called 
pre-configured templates. 

Only the local administrator has privileges to modify the contents of the 
pre-configured library, such as creating new or editing existing OPFACs and 
organizations, creating new folders, etc. All other users are prevented from 
making changes to the pre-configured library and their corresponding object 
palettes. 

Even though editing privileges on the pre-configured library is limited to only the 
local administrator, any user can use its contents when building scenarios. A 
scenario can contain a combination of pre-configured and custom templates. 

It is also possible to have sub-folders within the above set of folders. Use of 
sub-folders allows you to further categorize the organizations and OPFACs 
within a service folder. 
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The figure below shows an example of a library treeview with the pre-configured 
folders and custom folders created by the user.

Figure C-1   Library Treeview with Custom and Pre-Configured Folders

OPFAC and Organization Palettes
In addition to the above treeview interface, users can also use objects from the 
OPFAC and organization palettes to build the scenario. To build a scenario, 
users can drag-and-drop OPFACs and organizations from the palettes on to the 
workspace.

There are four main folders to hold the custom and configured OPFACs and 
organization. They are:

• Custom OPFACs
• Custom Organizations
• Pre-configured OPFACs
• Pre-configured Organizations
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Regardless of the sub-folder it is in, every OPFAC or organization will belong to 
one of the above four palettes.

Editing the Contents of the Library
You can edit the contents of the organization and OPFAC library. You can 
rename templates, save them under a different name, delete them from the 
library, and undo or redo template units. Right-click menu options are provided 
for performing these operations.

If you login using the local administrator profile, you can perform the above 
operations on the pre-configured and custom sections of the library. If you login 
as a regular user, you can change the OPFACs or organizations in the custom 
section, but not the pre-configured section.

Procedure C-1   Rename Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Rename Template.

2 Type a new name for the selected OPFAC/organization in the dialog box that 
displays, and change the folder to which the OPFAC/organization belongs. You 
can also create a new folder to store this OPFAC/organization.

The selected OPFAC/organization will be renamed, and if you changed the folder, 
the files will be moved to the new location on disk. The treeview is also 
automatically updated.

End of Procedure C-1

Procedure C-2   Save Template OPFAC/Organization As

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Save As.

2 Type a new name for the selected OPFAC/organization in the Save As dialog box, 
and change the folder to which the OPFAC/organization belongs. You can also 
create a new folder to store this OPFAC/organization. 

A copy of the selected OPFAC/organization will be made, and if you changed the 
folder, the files will be moved to the new location on disk. The treeview is also 
automatically updated.

End of Procedure C-2
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Procedure C-3   Delete Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Delete Template.

2 Confirm the deletion as prompted to delete the selected OPFAC/organization from 
the library. The selected OPFAC/organization will be removed from its current 
location on disk. The treeview is also automatically updated.

End of Procedure C-3

Procedure C-4   Undo/Redo Template Units

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Undo or Redo.

2 Confirm the operation as prompted. The treeview is also automatically updated.

End of Procedure C-4

OPNET License Server Management

Standalone Mode

The OPNET application licenses reside on the application computer. The 
licenses are not available to any other system. 

Floating Mode (local)

The OPNET application licenses reside on the application computer, but the 
licenses are available to the local network as well as the host machine. The 
license server must run as a network service. 

The OPNET License Server shuts down each time a user logs off or shuts down 
the machine. Users can also shut down the OPNET License Server through the 
License Manager, available from the JCSS main menu. 

Floating Mode (external)

The OPNET application licenses reside on another computer, so this machine 
must compete for licenses with other computers on the local network.
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License Server Files and Directories

C:\OPNET_license

This folder cannot be moved or renamed. It will contain license files for 
Standalone and Floating (local) licensing modes. The folder and all its files must 
be writable by Authenticated Users, or those users will be unable to acquire a 
lock on a license to use the application.

licensing.ef

The location of this file is: 

• NETWARS\Scenario_Builder\12.0.A\sys\configs\
global_prefs\licensing.ef 

The format of the licensing.ef file is: 

• license_server_standalone : true | false 
• license_server : /LICENSE_SERVER/
• license_port : /LICENSE_PORT/

where:

• /LICENSE_SERVER/ is the local hostname 
• /LICENSE_PORT/ is the desired port for the server 
• license_server_standalone may be either true or false

env_db12.0
The env_db12.0 file contains option settings for JCSS and OPNET 
commercial modules. Among these options are license server settings. The 
env_db12.0 file can be edited manually or through the Edit > Advanced menu 
item. The env_db12.0 file license settings should be consistent with the 
settings in the licensing.ef file. The absence of license server settings in 
the env_db12.0 file means that the licensing.ef values take precedence. 

The env_db12.0 file is located in the following location:
NETWARS\Scenario_Builder\op_admin\env_db12.0. 
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Manually Configuring License Settings

Normally, configuration of license settings should be performed through the 
JCSS user interface. Manually changing configuration files should be used only 
as a last resort.

/hostname/ represents the hostname of the localhost system. To determine 
the hostname of a system, open a DOS console and run the hostname 
command.

/port/ represents the desired port, one of port_a, port_b, or port_c.

Procedure C-5   Configure Localhost Floating Licensing

1 Make sure that all JCSS windows are closed. This includes any JCSS editors as 
well as the OPNET License Manager.

2 The file named licensing.ef is located in 
NETWARS\Scenario_Builder\12.0.A\sys\configs\global_prefs 
Modify it as follows:

2.1 Set license_server_standalone to FALSE 

2.2 Set license_server to /hostname/ 

2.3 Set license_port to /port/

3 Modify the env_db12.0 file located in
NETWARS\Scenario_Builder\op_admin\ as follows:

3.1 Set license_server_standalone to FALSE 

3.2 Set license_server to /hostname/ 

3.3 Set license_port to /port/

End of Procedure C-5

Procedure C-6   Change from Localhost to External Floating Licensing

1 Using the License Manager, make sure that the localhost license server is shut 
down. 

2 Close all JCSS applications. 

3 The file named licensing.ef is located in 
NETWARS\Scenario_Builder\12.0.A\sys\configs\global_prefs 
Modify it as follows:

3.1 Set license_server_standalone to FALSE 

3.2 Set license_server to /hostname/ 

3.3 Set license_port to /port/
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4 Modify the env_db12.0 file located in
NETWARS\Scenario_Builder\op_admin\ as follows:

4.1 Set license_server_standalone to FALSE 

4.2 Set license_server to /hostname/ 

4.3 Set license_port to /port/

End of Procedure C-6

Procedure C-7   Change from Localhost to Standalone Licensing

1 Using the License Manager, make sure that the localhost license server is shut 
down. 

2 Close all JCSS applications. 

3 The file named licensing.ef is located in 
NETWARS\Scenario_Builder\12.0.A\sys\configs\global_prefs 
Modify it as follows:

3.1 Set license_server_standalone to TRUE 

3.2 Set license_server to /hostname/ 

3.3 Set license_port to /port/

4 Modify the env_db12.0 file located in
NETWARS\Scenario_Builder\op_admin\ as follows:

4.1 Set license_server_standalone to TRUE 

4.2 Set license_server to /hostname/ 

4.3 Set license_port to /port/

End of Procedure C-7
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License Management and Product Modules

JCSS comes with a built-in license that allows you to run the program. A special 
“simulation runtime license” is required in order to run simulations. Additional 
licenses are required for ACE and NetDoctor modules.

If the module licenses are installed on a single license server rather than on 
individual machines, various machines can share licenses, which may reduce 
the total number of licenses required. Simulation runtime licenses, ACE 
licenses, and NetDoctor licenses must be purchased from OPNET 
(http://www.opnet.com/products). 

To install module licenses, start by running JCSS (go to Start > Programs > 
NETWARS > NETWARS v2007). From the System Editor main menu, select 
License > License Management. 

Current instructions for loading and configuring OPNET License permits are 
available from the OPNET Support web site (http://www.opnet.com/support). 

Log Files

The various log files assist in troubleshooting or tracking user activity. Users 
should examine the relevant log files before consulting NETWARS Technical 
Support, and may be asked to include log files in submissions.

Note—All log files grow over time and can potentially become a constraint on 
system resources. Administrators should periodically check the sizes of the log 
files and prune the logs as needed.

nw_odbc_log

• Located in NETWARS\User_Data 

• Runtime log that records unusual events associated with extracting 
information from the IER Database, service provided by MSDE (Microsoft 
SQL Server Desktop Engine).

err_log

• Located in NETWARS\Scenario_Builder\op_admin 

• OPNET and NETWARS application warnings, recoverable errors, errors, 
and program abort messages, with stack traces for context, are stored in this 
file.
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Archiving and Backup Procedures

Project Packaging

Each project has a single .prj file in the project directory under 
NETWARS\User_Data\Projects. The project folder and the .prj file have 
the same name as the project itself. A JCSS project may make use of other 
library files.  Library files may be used by any number of projects.  The only way 
to know which library files are included in a project is to examine the contents of 
the project.

Scenario Files

Each project consists of one or more scenarios. Each scenario is a subfolder 
under the main project folder. The scenario consists of a file with the extension 
‘.nt.m’ and possibly an XML file with the same base name.

Traffic Files
Demand Files

A demand file for each scenario, if one exists, would be located in the 
NETWARS\User_Data\Projects\<Project>\<Scenario> directory. Its 
name would be the Project Name followed by the Scenario Name connected 
with a plus ('+') and with an extension of '.dm'. 

IER Text Files

All IER Text files are available for use by every scenario. IER Text files are 
located in the NETWARS\User_Data\IER_Text_Files directory and have 
an extension of '.txt'.

Organization Files

Organizations are represented by '.nt.m' files located in the 
NETWARS\User_Data\Organizations directory. The project may include 
any, all, or none of the template organizations.

OPFAC Files
OPFACs consist of ‘.nd.m’ and ‘.nt.m’ files.  The names of the various files 
that relate to a specific OPFAC have similar base names, though not identical.  

All .nd.m file names contain the prefix “opfac_”.

OPFAC .nd.m and nt.m files

The OPFACs used by a project/scenario may reside in any folder under the 
NETWARS\User_Data\OPFACs folder. The ‘nt.m’ file includes all the OPFAC 
specific information while the ‘.nd.m’ file is only necessary for an OPFAC to 
appear in a palette.
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Trajectories
Trajectory files, ending in '.trj', may be applied to any organization or OPFAC 
in its JCSS attributes. Trajectory files may be stored in any directory included in 
the system's mod_dirs environment attribute. Many trajectory files are stored in 
the NETWARS\User_Data\SB_Data directory, although they may be in other 
directories also.

IER Database Archiving

Procedure C-8   Save to Text File

1 To store relevant database entries in to an IER Text File for transport or backup, 
load the entries into the IER Editor Table using the Query functionality.

A query with no criteria specified will retrieve all records in a database.

2 Click the Export button and name a text file. 

End of Procedure C-8

Procedure C-9   Restore from Text File

1 To import IERs from a text file to the database, open the IER Editor Table and 
select Import, and then select the file containing the IERs.

The IERs in the text file will load into the editor table. 

2 Click the Save to Database button and save the records into the database.

These imported records will overwrite records with corresponding IER IDs in the 
database.

End of Procedure C-9
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App D Error Recovery Guidelines

Automatic Backup of Project Files

Project files are backed up automatically at a predetermined interval (the default 
setting is 15 minutes.) Users may modify the backup interval by selecting Edit 
> Preferences and changing the “backup_interval” preference. The backed up 
files have ‘-backup<index>’ appended to the filename. You can load these 
backup files into the Scenario Builder.

Note—Setting the “backup_interval” preference to 0 turns the backup off.
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Glossary

B

Broadcast Networks Network of radio system devices that are tuned to same 
frequency and belong to same frequency hop group. All the radio devices 
belonging to same broadcast network hear transmission by one radio device.

C

Connectivity Links Created based on the subscriber requirements. 
Connectivity links are different from planning links in that they are connected to 
actual devices instead of organizations.

Courses of Action Define specific conditions or situations, such as when an 
enemy uses chemical, biological, or nuclear weapons. It is important to note that 
time phases and courses of action perform exactly the same way in JCSS.  You 
simply have the option of calling your scenario subdivisions time phases or 
courses of action.

I

IERs The acronym for Information Exchange Requirement. IERs are the 
primary traffic representation in JCSS. A relationship between OPFACs is 
needed to create an IER.

K

Kernel Procedure An OPNET provided function that supports the 
development of protocols and algorithms. All Kernel Procedures start with op_.

M

Mainframe Characterization Module MCE is an optional module that allows 
you to import measured performance data, and analyze it to create workloads 
suitable for the mainframe models. 

Mod_Dirs An environment attribute that tells OPNET which folders to look in 
for locating files. The mod_dirs attribute is found under Edit > Preferences.

MOPs The acronym for Measures of Performance. Analyze the results of a 
simulation session to produce a set of MOPs. Manipulate the set of MOPs using 
data filters and produce graphs of the data. The MOPs explain various 
communication burdens, latency, and other critical performance measures 
associated with communication infrastructures.
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O

Online Documentation An Adobe Acrobat manual that has information about 
the OPNET models, kernel procedures, modeling concepts etc. The manual can 
be launched from Modeler by choosing the Online Documentation option under 
the Help menu.

OPFACs The acronym for Operational Facility. OPFACs are the fundamental 
building blocks of JCSS. They are collections of communications devices that 
are assigned to military units, which are used to construct Organizations.

Organizations Hierarchies of military units. An organization is a container that 
can hold OPFACs and other organizations (sub-organizations).

P

Planning Links Placeholders for the connectivity links that will be created 
based on the subscriber requirements. These links can have organizations or 
OPFACs as terminating points, and show the anticipated bandwidth. Planning 
links cannot be used for discrete even simulation and capacity planning 
analyses.

Process Registry It is a model-wide registry where any process mode can 
register itself and any process model can obtain information about other 
process models that are registered. For a list of kernel procedures available for 
using the process registry, refer to the OPNET Modeler online documentation, 
General Model’s Manual, OPNET Model Support chapter, Process Registry 
section (consult the IT Guru documentation set, available via Help > 
Documentation > IT Guru Documentation).

Projects Projects are containers for scenarios, time phases or courses of 
action. Related scenarios can be grouped under one project. JCSS enables you 
to open and work with multiple projects simultaneously.

S

Scenarios Scenarios are instances of C4I communications architectures that 
consist of associated OPFACs and Organizations, Information Exchange 
Requirements (IERs) and links. Scenarios are stored as part of a project created 
within the Scenario Builder. Thus, projects act as containers for scenarios and 
a single project may include several scenarios, i.e., instances of C4I 
communications architecture.

Server Characterization Editor SCE is an optional module that allows you to 
import server performance information for analysis of the processes and 
applications, and characterization into workloads used as the basis for 
simulation modeling.
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Simulation Engine The COTS OPNET Modeler tool. It processes the 
simulation events and provides the output to the Scenario Builder.

U

Unified Modeling Language UML is an industry standard set of graphical 
notations to describe a system from an object-oriented approach. Diagrams 
include a set of static notations (class diagrams, use case diagrams) and a set 
of dynamic notations (state diagrams and sequence diagrams). UML does not 
require a specific design process and does not require implementation with any 
specific object-oriented languages or tools. The state diagrams, for example, 
are consistent with OPNET Modeler’s Process Model notation.
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