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L ogistics

» Hours: 1:30 PM - 5:00 PM
% One break

» Please turn off or set pagers and cell phones on
vibrate

» If you need to talk on your cell phone, please
leave the room.

Training Support

» NONROAD Model Team:
» Craig Harvey
> Penny Carey
> Larry Landman
» And on nonroad NMIM issues:
> Harvey Michaels
> Web
> http://www.epa.gov/otag/nonrdmdl.htm
» Email
> nonroad@epa.gov




Course Objectives

>
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Overview of NONROAD2005
» versus NMIM and NR2004

Running NONROAD from the GUI

Creating output summaries with the
reporting utility

Viewing and post-processing raw output
Modifying inputs

Using new features of NONROAD2005
Deciding whether to use NONROAD vs NMIM
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Other topics, astime permits:
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Using Daily Temperature & RVP inputs
Getting & using “By-Model-Year” output
BATch (multiple) model runs
Site-specific inventories

Growth and Technology Year inputs
Creating your own Access queries




Topics You Care About?

» What modeling challenges do you face?

» What is the most creative thing you've done (or
tried to do) using NONROAD?

» What would you love to be able to model that
you can’t?

» eftc.

L ogisitics (cont.)

» For the hands-on exercises, I'll explain how to

do
qu

it while I do it, then you do it, asking

estions as needed.

So pay attention rather than typing along.
Work together — you'll learn more.

If you finish an exercise, please help others who are
having trouble.

Ask questions if you get stuck.




Expected Preparation

NONROAD2005 software installed

Basic familiarity with the Windows operating system
> Browsing folder structure with Windows Explorer

How to use Notepad or another text editor

¥ ¥

¥ ¥

How to open Excel or other spreadsheet

Questions

- Feel free to ask at any time -- if you are
confused, so are other people

» The answer may be

I'll cover that later

I don’t know

I'll provide an answer later by email
Out of the scope

YV YV V

\74
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M iscellaneous

¥

We won't be able to cover everything

» Apologies to the most experienced for going
too slowly, and to novices for possibly going
too quickly

»- Students are from States, EPA, RPOs, MPOs,
cities, consulting firms, industry, etc.

» I'll be here only through Tuesday morning
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Course Materials

» Handouts
» These slides
» NONROAD2005 Update Chronology

» Documentation on install disk or download
> NONROAD2005 User’s Guide
> NONROAD Model Technical Reports
( NR-001 — NR-015)
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What isNONROAD2005

» Final version of nonroad equipment
inventory model

» Generates inventory estimates for
v All off-highway mobile equipment & recreational vehicles
v Except locomotive, commercial marine, and aircraft

» Several draft versions issued since 1998, last was
2004

» Changes since NONROAD2004 are in later slide
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NONROAD Model Overview

» Stand Alone (WNo User Data Necessary)

»- Differentiated by Equipment Type and Other
Characteristics

» HC, CO, NO,, PM, SO,, CO,
» Equip Population & Fuel Consumption
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NONROAD Model Overview

» Past, Present, and Future Years
» 1970 - 2050

» Temporal Allocation
» Annual, Seasonal, Monthly, Typical Day

» Geographic Allocation
> US, State, County
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NONROAD Model Overview

» Graphical User Interface ("Gur", visual Basic)
» Scenario definition

% Core Model (rortran)
» Calculations
> Generates raw output (.OUT file)

» Reporting Utility (Microsoft Access)
» Output summaries
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How NONROAD Works

Access Report «— | Reporting Utility | —— Excel file

OUT file — —— Import to Excel

Input data files h Core Model

GUI| —— OPTfile
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NONROAD Model Overview

» Input Options
» Evaluation Year

» Temporal Period
(Year, Season, Month, Weekday, Weekend day)

> Geographic Area (National, State, County)
> Equipment Types (by fuel type, Hp, SCC)
> Fuel Characteristics (RVP, sulfur, oxygen)
> Temperature (min, max, avg)
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NONROAD Model Overview

» Output Options
> From Core Model
v ASCII File (.OUT comma separated text)
> From Reporting Utility (Access not required)
v Pre-formatted MS Access Reports
v Access database tables (NIF 3)
v Excel Spreadsheet
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NONROAD Model Overview

» Pre-Formatted Inventory Reports
» Tons by County
» Tons by Source Category
» Tons by Equipment type & SCC
» Tons By Horsepower range
» Emission Factor Reports
» Grams per Day by SCC (& Hp)
» Grams per Operating Hour by SCC (& Hp)
» Grams per Hp-Hour by SCC (& Hp), exhaust only

20
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NONROAD Model Overview

Exhaust Emissions Calculation

| =EF -DF-Act-LF-RP -Pop

| = Exhaust Emissions Inventory (ton/year)
EF = Emission Factor (g/hp-hr)

DF = Deterioration Factor

Act = Activity (hours/year)

LF = Load Factor

RP = average rated power (hp)

Pop = Equipment population (units)
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NONROAD versusNMIM

What NMIM does that NONROAD does not:

>

Multiple county-specific temperature & fuel
properties in a single run

Full fleet-specific retrofit modeling

Ammonia (NH;) and Toxics (HAPS)

Distributed processing (multiple computers)
National county-level inventories for the National
Emission Inventory (NEI) and AQ modeling

22
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NONROAD versusNMIM

What NONROAD does that NMIM does not:
» Equipment population & fuel consumption output*
> Detailed output by specific evap pollutant*
> Seasonal, annual, or typical day outputs

(but you can post-process to get most of these)
> Inventory years prior to 1999
> Dalily temperature inputs.

* (unless run NMIM from DOS and ask for OUT file)
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NONROADZ2005

» Changes from NONROAD2004
> Added evap categories: tank permeation, hose permeation,
running loss, and hot soak
> Enhanced output: Load Factor & Avg Hp
> Revised diurnal methodology and estimates
> Includes Rec/Large Sl rule evap controls
> Updated scrappage/age distribution
> Updated state and county allocations
> Dally inputs for temp and RVP at national/state level
> Adds Puerto Rico and the Virgin Islands
> Added report options (especially Emission Factors)
> Added diesel retrofit modeling capability
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NONROADZ2005 vs NR2004
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NONROADZ2005 vs NR2004

Diesel NOx

tonsfyear
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NONROADZ2005 vs NR2004

Diesel PM 10

tons/year
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NONROADZ2005 vs NR2004

Class1 Model Year Distribution in 2000, 2010, 2020

Equipment Model Year Population
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NONROADZ2005 vs NR2004

Sl THC total (exh & evap)
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NONROADZ2005 vs NR2004

S| NOx
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Future Changes

» Update per future rulemakings

( e.g., likely small gasoline engines and
recreational marine, final rule in 20077 )

» Transition to MOVES ( draft in 2007/2008? )
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Questions?

... on what NONROAD2005 is, or changes since
NONROAD2004 ?

32
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Hands-on Exercises

33

Configuring NONROAD

> Relevant files & directory structure:
> nr-gui.ini
> template.opt (note use of relative file paths)

c:\nonroad

\data
\activity
\allocate
\daily
\detfac
\emsfac
\retrofit
\season
\tech

\outputs

\reports

34
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Exercise 1: Use GUI to Run
NONROAD with default data

» Open GUI (nrgui.exe)
»- Save as... nrtestl.opt (suggest in outputs folder)

»- Scenario => Options, Period, Region, Sources
(make any desired changes)

» Model => Run with nrtestl.opt
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Post-run checks

» If DOS window is still open, look at it for errors
and warnings.
» Open MSG file to check for errors and warnings

» Can open OUT file in text editor to check for
desired counties, SCCs, pollutants

36
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Exercise 2. Use Reporting
Utility to Generate Reports

» From GUI select Model => Reports
» In Reporting Utility select
» Data => Re-attach tables (only needed after
install)
» Data => Import data
> Give brief description such as location, year, &
scenario designation (e.g., “Base”)
» Select Reports => Emission Totals by SCC
» Select Run, Pollutants, Fuel, HC & PM types
> Run
> File => Export to Excel
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Exercise 3: Postprocessing with
Excel

» Open Excel (or other spreadsheet software)

» Select File => Open...
» c:\nonroad\outputs\nrtestl.out
> Delimited: comma (only)

» Scroll to bottom and add a Totals line
= sum( ) select lastcell up to firstcell.

38
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Exercise 4: Export to NIF3

7 In Reporting Utility...
» Select Data => Export NIF File
» Choose available simulation to export

» Fill in contact info and any notes
(See sample on next slide)

»- Click Export button
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Exercise 4: Export to NIF3

B Export to NIF 3.0

[F33-214-4237 Telephone Nuraber Type
Electronic Address: nonroad@epa. gov

Electronic Address Type:
|affiliation Type [|Report Certifier [Tribal Code m

Total for year: 2005
Start Date (yyyymmdd) 20050101 End Date (yyyymmdd). 20051231
Period Type Episode Year 2005

[2005 baseline, Mo Daily inputs

ﬂl il
40
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Exercise 4: Export to NIF3

» Save as niftestl.mdb (Access MDB file)
» Click Open button, which saves the file

- Double-click on niftestl.mdb, which should
open MS-Access

~ Look at database tables

41

Exercise 5: Modify Input Data

» Inputs you might modify

f

r
r
4

Equipment population (*.pop)

> Activity (activity.dat)
» Geographic allocation (*.alo)

Temporal allocation (season.dat)

- Growth at state level (*.grw)

» We recommend not changing

>

Emission Factors (*.emf)
Deterioration Factors (*.det)
Useful life and scrappage (*.pop)

42
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Exercise 5: Modify Input Data

> Workmg with ASCII data files

YV VY

vV VvV

\4

\4

g

Use Text Editor (e.g., Notepad) not word processor
Must be in proper space-delimited vertical columns
If display font option, use Courier or Courier New
No word wrap

Use spaces not tabs

Refer to column descriptions near top of each file

Actual data is inside “packets”
/POPULATION/

. data ...
/END/

Anything outside of packet is just a comment

43

Exercise 5: Modify Input Data

_oix]
Fie Edt Format View Help

1- 5§ FIPS code j

7 - 11  subregion code (used for subcounty estimates)

13 - 18  year of population estimates

18 - 27 5cC code (no globals accepted)

29 - 68 equipment description (ignored)

70 - 74 minimum HP range

76 - B0 maximum HP range (ranges must match those internal to model)

82 - 86 average HP in range (17 hlank model uses midpoint)

88 - 92 expected useful 13fe (in hours of use)

93 - 102 flag for scrappage distribution curve (DEFAULT = standard curve)
106 - 122 population estimate
FIPS Year SCC Equipment Description HPmn  HPmx HPavg Life Scraprlag Population
| /ROPULATTON/
22000 1899 2260001020 2-5tr snownobiles 100 175 112.4 252 DEFAULT 0.0
22000 1998 2260001010 2-5tr offroad Motorcycles 0 1 1 19200 DEFAULT 23454.7
22000 18098 2265001010 4-5tr offroad motorcycles 0 1 1 16200 DEFALLT 11552.3
22000 1998 2260001030 2-5tr A1l Terrain vehicles 0 1 1 20410 DEFAULT 11854.4
22000 1808 2265001030 4-5tr A1l Terrain vehicles 0 1 1 20410 DEFALLT 102591.6
22000 1998 2265001050 4-str Golf Carts 6 11 9.15 400 DEFAULT 1867.7
22000 18098 2260001060 2-5tr specialty vehicle Carts & 11 8.046 200 DEFALLT 5077.6
22000 1998 2260001060 2-Str Specialty vehicle carts 25 40 37 942 DEFAULT 1.5
22000 1898 2260001060 2-5tr specialty vehicle Carts 50 75 55 942 DEFAULT 0.9
22000 1998 2265001060 4-5tr Specialty vehicle carts 1 3 3 200 DEFAULT 2.6
22000 1808 2265001060 4-5tr specialty vehicle Carts 3 64,424 200 DEFAULT 104.3
22000 1998 2265001060 4-5tr Specialty vehicle carts 11 16 15.99 400 DEFAULT 197.5
22000 1808 2265001060 4-5tr specialty vehicle Carts 16 25 16,62 750 DEFAULT 1555.6
2000 1998 2265001060 4-5tr Specialty vehicle carts 25 40 30.55 942 DEFAULT 15.9 J




Exercise 5: Modify Input Data

» Saving from Excel spreadsheet
> Save As... Formatted Text (Space delimited)(*.prn)
» Column widths & font sizes must be set to yield text
in correct columns
» Setting this up can be tedious trial & error
» Can request sample XLS files from EPA
No guarantee that settings will work right on
different systems, due to effects of:
Desktop display settings
Fonts

v
v Print driver
v etc.

<
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Exercise 6: Running from DOS

» Why run from the Command line?
(DOS window)
> Run BATch file (multiple model runs)

» Can send screen output to a file
c:\nonroad>nonroad.exe template.opt >outputs\screenout.txt

> Verify that core model works if having
problems running from GUI

46
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Exercise 6: Running from DOS

e+ DS Prompt
C:\>cd nonroad

c:xnounonn

eh 2086
C:\NONRORD>

Bisl}

i Phar Lap’s 3861D05-Extender<tm> Uersion 8.02
i Copyright (C) 1986-96 Phar Lap Software, Inc.

32-bit Pouver for Lahey Computer Systenms

fivailable Memory = 15356 Kh

Initializing..
Processing...10@x

.Done

Successful completion of EPA's NONROAD Emissions Model, Core Model Uer 2805a, F

|
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Exercise 6: Running from DOS

Example BATch file

[® test.bat - Notepad

Fle Edit

Format  Wiew Help

=1olx]

2xe
2xe
2xg
2xe
2xe
2xe
2xe
a2xe
2xg
2xe

cd cisNonroad
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.
nonroad.

oUtputshtesthtest200L,
outputshtesthtest2002,
oUtputshTesthtest2003,
outputshTesthtest2004,
outputshTesthtest2005,
oUTpUtshTesthTestZ 008,
oUtputshTesthtest2007,
outputshTesthtest2008,
oUtputshTesthtest20059,
outputshTesthtest20l0,

opt
opt
opt
opt
opt
opt
opt
opt
opt
opt

48

24



Ongoing Support

> Web
> http://www.epa.gov/otag/nonrdmdl.htm

» Email
> nonroad@epa.gov
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