Java

Java in Action Downloads Help Center

Installing Java

   

Do I need administrative permission to install Java?


This article applies to:
  • Platform(s):
    Windows XP (SP1 SP2)
  • JRE version(s):
    1.4.2_xx, 1.5.0



SYMPTOMS

During installation of the JRE, a dialog box appears displaying the following error message:

You need Administrative Permission to install the JRE.


CAUSE

For Windows XP, there are different types of user accounts (e.g. guest or administrator). Administrative accounts are needed to install software and make other changes to the computer.


SOLUTION

If you are trying to install the JRE on a personal computer, you may grant your account administrative privilege by going to:
Control Panel -> User Accounts -> Change An Account -> Select your account name -> Change My Account Type -> Select Computer Administrator.


If you are trying to install the JRE on a corporate computer, please contact the network administrator for administrative permission.



Sun provides third-party contact information to help you find technical support. This contact information may change without notice. Sun does not guarantee the accuracy of this third-party contact information.


NEED MORE HELP?
If you require further assistance, please make sure you check through our Help and FAQ sections thoroughly. We probably have a page that answers your question.

You may find information on the following topics in the Help section:
Installing Java
Configuring Java
Error Messages
Applet Application




Help Resources
> Installing Java
> Configuring Java
> Error Messages
> Applet Application
> Legal

 

FAQ
> General Questions
> Java for Mobile Devices

 

Select Language | Java Wear | Newsletter | About Java Technology | Partner with Us | Developers | java.com Changes
Privacy | Terms of Use | Trademarks | License | Disclaimer | Contact

Sun Microsystems