
Computer assisted sperm analysis using ImageJ; description of necessary components and use of free software

Abstract:

Although the efficacy of computer assisted sperm analysis (CASA) has been demonstrated for use with a variety 
of species in assessing male reproductive quality as well as the impact of various treatments on sperm motility, 
many investigations continue to rely on manual analytical methods. CASA has been consistently shown to 
outperform such methods in terms of reproducibility as well as in the variety of parameters obtainable to 
describe sperm motility, however, its high cost has hindered widespread adoption. Also, that much of the 
information necessary to reproduce data obtained with commercial systems is proprietary information, and thus, 
not available, limits the ability to conduct comparative evaluations.  Herein, we present a detailed manual for 
construction of a CASA systems based upon free software, which should increase the availability and utility of 
this technique.
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I. Construction of a video microscopy system

We have successfully performed CASA using video captured from a variety of microscopes and video 
cameras. Most commercial CASA systems utilize a 10x objective of a microscope; they do not, however, 
generally report the magnification factor used between the video camera and the microscope or the size of the 
chip in the video camera. In our experience, use of a 1x adapter in conjunction with a 10x objective and a 1/2” 
CCD or CMOS chip provides appropriate magnification. Although it is possible to use video captured from a 
brightfield microscope, the image produced by any of a variety of contrasting methods is preferable. (If 
brightfield microscopy is used, employment of contrast enhancing filters is almost a necessity and even with 
filters in place it may be difficult to distinguish between sperm and other particles). Phase contrast presents an 
image wherein the sperm head is bright; this results in high contrast and short shutter speeds. Darkfield can be 
used, but will require longer shutter speeds and dust on the slide or objective occasionally appears as bright as 
sperm, complicating analysis. Differential interference contrast does not appear to provide any advantage over 
phase contrast. Leica's Modulation Contrast may be more effective than general phase contrast due to the 
production of a very small bright center for each sperm; however, when sperm collide the bright portions do not 
touch and this may prevent the elimination of tracks due to collisions by our software. Zeiss' Varel Contrast does 
not appear to provide any advantage over phase contrast, and results in a less bright image. 

In general, use of an inverted microscope may be desirable as focus will not be impacted with the 
application of sperm to the slide (this may decrease the time between application of sperm and acquisition of an 
image, a quality important in the analysis of fish sperm). Inexpensive microscopes with phase contrast can be 
acquired from Zeiss, Leica, Nikon or Olympus as well as Chinese manufactures such as Meiji and Motic 
instruments. The only characteristics we have found to be of importance in selection of a microscope are 
production of a bright image and the use of a planar objective. Resolution of the objective does not appear to 
impact analysis; we have had more success with the Zeiss A-Plan ph1 10x/0.25 than with the Plan-Neofluar ph1 
10x/0.30 due to increased contrast. The objective used must be planar, otherwise portions of the field of view 
will always be out of focus; this will result in the elimination of sperm tracks by the software as sperm swim 
from one side of the field to the other. An electronic shutter speed shorter than 1/500th of a second appears to 
effectively freeze sperm motion; the camera sensitivity, microscope bulb wattage, condenser, and objective will 
impact shutter speed and thus should be considered when constructing a system. If the camera is coupled to the 
microscope by way of a trinocular tube, we recommend the prism directing light to the camera be 100/0 %, such 
that all light may be sent to the camera and none passed onto the eyepieces (this will increase brightness). It is 
possible to couple the camera through a binocular tube, but this will diminish brightness and if cost is an issue, 
use of a monocular tube would probably be preferable.

The most efficient flow of data is obtained by using a firewire machine vision camera and saving image 
sequences directly to a hard drive. A camera with the highest available frame rate should be employed as this 
provides the greatest amount of data and temporal resolution by locating the sperm at the most possible time 
points during analysis. Machine vision cameras operating at 100 frames per second may be best suited to the task 
as they are common and relatively inexpensive. Resolution of the camera does not appear to be of major 
importance and a camera with a low resolution 1/2” chip (659 x 490 pixels) is sufficient for recording the motion 
of 200 fish sperm using 10x total magnification. Possible sources for such cameras are Prosilica (prosilica.com), 
Basler (baslerweb.com) and Point Grey (ptgrey.com). Sources of software for writing image sequences directly 
to a hard drive include Unibrain (unibrain.com), National Instruments (ni.com) and the free software, Coriander 
(sourceforge.net/projects/coriander/). We have only performed data acquisition using a computer with a 3.4 ghz 
Pentium IV, 1 gigabyte of RAM, and two 7200 RPM SATA drives in a RAID 0 array. We were able to capture 
100 frames per second at 659 x 490 pixels reliably for several minutes. The camera we used was a Prosilica 
CV640 monochrome 1/2” CMOS.

 Alternatively, a consumer video camera could be mounted to a microscope via a specialized adapter, and 
the video processed using VirtualDub (virualdub.org); the video would either need to be converted to an 
uncompressed avi and opened in ImageJ with an avi plugin (http://rsb.info.nih.gov/ij/plugins/avi-reader.html) or 
saved as an image sequence. Importing video to ImageJ that is saved as an image sequence is accomplished by 
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way of the File->Import->Image Sequence menu. In this fashion one second of video from a specific time point 
in a longer recording can be opened.

3



II. Processing video in ImageJ

As above, the video should be imported as an image sequence or uncompressed avi. This will open an 
image stack. If National instruments Labview is used to capture video it is possible to threshold video during 
acquisition; otherwise thresholding must be performed on saved video. This is accomplished in ImageJ using the 
Image->Adjust->Threshold file menu. Sliders should be adjusted so that sperm are selected (red) and the 
background is not. Clicking Apply will then discard all information other than the sperm heads, turning sperm 
into black circles on a white background. It may be difficult to produce video from sample to sample wherein 
sperm present the same contrast with the background (due to differences in focusing precision, primarily), as 
such, a different threshold setting may need to be applied to each video analyzed. Using a constant threshold at 
the time of acquisition alleviates this concern, as sperm will not be visible unless they are focused such that their 
brightness is great enough to be retained by the constant threshold value employed. 
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III. Analysis of video using CASA plugin

Use of this plugin depends on a basic understanding of ImageJ operation. We strongly suggest that 
individuals interested in using this plugin review the basic instructions for using ImageJ available at 
http://rsb.info.nih.gov/ij/docs/index.html prior to attempting to analyze sperm motility. Of particular importance 
is an understanding of the documentation regarding file menus, macros and plugins.

We have tested this plugin using multiple species of fish (unpublished observations) and fully explained 
our methodology (reference forthcoming). Analysis with this plugin goes quickly on our computer 
(specifications listed above), but we do not know if use of less capable hardware will result in an increase in the 
time required. We do recommend that the maximum amount of RAM available be alloted to ImageJ (Edit-
>Options->Memory). The parameters measured by this plugin are shown in the table below:

Characteristic Description

Percent motility Percent of sperm moving in a manner fitting motility determination parameters.

Velocity curvilinear (VCL) Point to point velocity (total distance traveled) per second.

Velocity average path (VAP) Point to point velocity on a path constructed using a roaming average. The 
number of points in the roaming average is 1/6th of the frame rate of video used. 

Velocity straight line (VSL) Velocity measured using the first point and the average path and the point 
reached that is furthest from this origin during the measured time period.

Linearity (LIN) VSL/VAP, describes path curvature.

Wobble (WOB) VAP/VCL, describes side to side movement of the sperm head.

Progression (PROG) The average distance of the sperm from its origin on the average path during all 
frames analyzed; division of this variable by VAP yields a description of the 
average efficiency in terms of the portion of generalized motion that results in 
movement away from the origin (a perfectly circular path will have a higher 
efficiency than an erratic path with the same linearity).

Beat cross frequency (BCF) This value is determined in the plugin by detecting the frequency at which VCL 
crosses VAP. In cases where a sperm has a highly circular path, values 
generated are not valid (reference forthcoming). As such, we do not recommend 
use of this variable. Instead we suggest that directional changes per second 
would be a more valid measure. This measurement is present in the code of the 
program but is not output; we may substitute for BCF in the future depending on 
user demand.

The plugin must first be downloaded to the computer’s plugins folder and compiled (Plugins->Compile 
and Run, locate the file and open, see http://rsb.info.nih.gov/ij/docs/menus/plugins.html for more detailed 
instruction). Running the plugin will result in initiation of a dialog box where parameters for analysis may be 
entered (and must be entered for each analysis performed - we recommend use of a macro to input these values, 
macros can then be saved with particular settings for a specific species). Macros can be recorded by opening the 
macro recorder (Plugins->Macros->Record), and performing the analysis as normal.Clicking Create will open a 
new window with the text of the macro, running this macro will open the plugin, input the previously used 
values, and run the plugin.

See http://rsb.info.nih.gov/ij/docs/menus/plugins.html#macros and 
http://rsb.info.nih.gov/ij/developer/macro/macros.html#recorder for more detailed instructions regarding macro 
recording. 
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Output of the plugin will be the values mentioned in the above table, on a single row, separated by 
spaces ( % mot VCL VAP VSL LIN WOB PROG BCF Number of sperm tracked). Multiple analyses may be 
preformed and will result in the addition of each analysis to a new row in the Results window. This may then be 
saved using the File menu on the Results window; save the file as “filename.csv”. The file can be opened in a 
spreadsheet program by identifying the separator of values as a space (when opening, a dialog should appear 
asking how values are separated, one option should be Space). The plugin will also output an image the same 
size as a frame in the original video showing the paths of all analyzed sperm; grey sperm are ones that were 
identified as non motile. That all sperm were tracked can be verified by projecting the video; Image->Stacks-
>Zproject, choose Min Intensity. The projected image can then be compared with the tracks output by the 
plugin; cases where sperm were not tracked by the plugin generally occur because sperm move out of the field of 
view or out of the focal plane.

Values should be entered into the plugin's dialog box that accurately detect non motile sperm:
To be considered motile a sperm must meet the minimum VSL, VCL and VAP settings. It must also 

meet at least one of the following three sets of conditions (letters in quotes refer to the settings boxes in the 
screen capture below, refer to the values in this image for sample values that we have had success with): 

1. WOB below high WOB “m”, LIN below high LIN 
“n”, maximum percent low VAP between frames “j” 
condition met, and maximum percent zero VAP 
between frames “i” condition met (this set of 
conditions is intended to find sperm that are in 
motion for most of the time analyzed and that do not 
move in a perfectly straight line as would be 
expected of sperm moving due to bulk flow). 

2. VCL above low VCL “l” and VAP above low VAP 2 
“k” (this set of conditions identifies sperm moving 
faster than is characteristic of bulk flow regardless of 
their motion characteristics)

3. WOB below high WOB two “o”, and LIN below 
high LIN two “p” (this set of conditions identifies 
slow moving sperm with a high degree of path 
curvature as such curvature is not characteristic of 
sperm moving due to bulk flow)

Correct settings should be determined experimentally 
for the species of interest. The primary purpose of using two 
passes in detecting motile sperm is to increase the plugin's 
ability to identify slow sperm as motile, while not incorrectly 
classifying sperm moving due to bulk flow of the sperm 
suspension. Analysis of mammalian sperm, which can be 
recorded minutes after application of sperm to the slide (and 
thus after most bulk flow of the fluid has ceased) might be 
performed by applying generally reported velocity 
specifications (such as a VCL above 25 µm/s) in the first 
pass “g” and negating one of the second pass controls (by, for 
instance, setting high WOB two “o” and high LIN two “p” to 
200, such that any sperm qualifying for the first pass setting 
will also meet these second pass conditions).
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be entered into fields in order to determine data output and to  
input parameters for sperm path construction and motility  
determination. Values shown in the fields represent those that we 
have used to successfully analyze fish sperm motility.



Format of the plugin's output:
When the number “1” is entered in the Print all motile sperm motion parameters field “t” the following 

data will be output for each sperm (entering “0” in this field with prevent this data from being output): 
  % mot, VCL, VAP, VSL, LIN, WOB, PROG, BCF

When “1” is entered in the Print x,y co-ordinates for all sperm field “s”, x,y co-ordinates separated by a 
space will be printed for all sperm analyzed (motile and non-motile), entering a “0” in this field prevents these 
data from being output. We suggest using this for individual sperm only, as formatting is not applied to 
distinguish the co-ordinates of one sperm from the next (analysis of a single sperm can be completed by clearing 
the regions of the image containing other sperm – this is accomplished using selection tools and the Edit->Clear 
function). The first set of co-ordinates in each row represents the centroid positions of the sperm in all frames, 
the second set represents the VAP co-ordinates (fewer are printed because this can not be determined until a 
point in the sperm path where enough co-ordinates are present to average), and the third set of co-ordinates in 
each row represents those data used to determine VSL. 

At the end of the list of individual sperm motion parameters the average values for the population of 
sperm will be output in the same format (if individual sperm parameters are not printed, then this is all that the 
plugin will output into the Results window), additionally, the number of sperm analyzed will be written after 
BCF. If “1” is entered in the field for Print median motion characteristics “u”, the median values for the sperm 
population will be output between the average BCF and the number of sperm analyzed (entering the value “0” 
will prevent this data from being output), and the complete data format will be as follows:
% mot | VCL | VAP | VSL | LIN | WOB | PROG | BCF | Median VCL | Median VAP | Median LIN | Median WOB | Median PROG | Median BCF | Number of sperm tracked

Please contact the authors for assistance or clarification or refer to (reference forthcoming). 
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