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Exercise 14 – Modeling Alternative Scenarios, BMPs,  
     and TMDLs 
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In this exercise, we will simulate alternative conditions in the watershed, including best 
management practice (BMP) implementation, by making changes to the *.uci file using both 
WinHSPF and GenScn.  We will also perform various post-processing operations in order to 
analyze the differences between/among the scenarios.  In the final part of the exercise, we 
will demonstrate a method for calculating a simplified TMDL.  Actual TMDLs will likely 
require many other site-specific considerations. 
 
Questions addressed in this exercise:  
 

1.) How do I create a base case scenario? 
2.) How do I generate a scenario that represents historical conditions? 
3.) How do I generate a scenario that represents possible future conditions? 
4.) How do I generate a scenario that represents BMP implementation? 
5.) How do I use results of an HSPF model to calculate a TMDL? 
 
 

A. Base Case Scenario 
 
In this section, we will run the model using an input file that is similar (same initial input 
values) to those we used for Exercises 12 and 13.  We will define a ‘base’ scenario, which 
can be thought of as the ‘current’ state of the watershed with regard to point sources, land use 
area and distribution, topography, etc.  We will make changes to our simulation watershed 
and compare the results to our ‘base’ scenario in order to ascertain how various management 
options will affect the model output. Because of time constraints, we will focus on total 
nitrogen and sediment in this exercise. 
 
QUESTION ANSWERED:  
1.) How do I create a base case scenario? 
 
1. If WinHSPF isn’t already open, from the Start menu under Programs, select 

BASINS and then WinHSPF. 
 

2. From the File menu, select Open. 
 
3. Navigate to c:\basins\modelout\scen and select “scen.uci.”  Click OPEN. 
 



BASINS/HSPF Training                                                                               Exercises 
 
 
4. From the File menu, select Save As. 
 
5. Type “BASE” in the “New Project” box. 
 
6. Leave the “Path” and “Base DSN” as they are.  The “Save As” window should look 

like the following: 
 

 
 
7. Click OK. 
 

8. Click  (Run HSPF). 
 

9. Click  (View Output through GENSCN). 
 
10. Click the “HSPF Output” tab. 
 
11. Check the box beside “c:\basins\modelout\scen.wdm.” 
 
12. Click OK. 
 
13. In the “Scenarios” frame, select “BASE.” 

14. Click the “Add to time series list” button, . 
 
15. Plot TOTAL-N for Reach 5 and SSED for Reach 6. 
 
16. From the Analysis menu, select Run Script.  
 
17. Navigate to c:/basins/models/hspf/bin and select “GenScnWatershedSummary.spt.” 
 
18. Click OPEN. 
 
19. In the “Script Arguments” window enter “base” in the “CurScenario” box, “TotalN” 

in the “gCurConstituent” box, and “c:\BASINS\Modelout\scen\” in the “InputDir” 
box.   
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Note: Be sure to use the same capitalization for the constituent name and include the 

backslash at the end of the input directory path.   
 
20. Click OK. 
 
21. Repeat steps 16-20 and produce a report for sediment by entering “base” in the 

“CurScenario” box, “Sed” in the “gCurConstituent” box, and 
“c:\BASINS\Modelout\scen\” in the “InputDir” box.   

 
22. Click OK. Look at the annual loads for total nitrogen and sediment for various 

landuse categories. 
 
23. Close any open reports and return to WinHSPF. 
 
 
B. Scenario 1: Possible Historical Conditions 
 
QUESTION ANSWERED:  
2.) How do I generate a scenario that represents historical conditions? 
 
In this section, we will create a hypothetical historical scenario.  We will assume that at some 
point in the past, the land use distribution was different than it is currently.  We will adjust 
the land use segment areas, and then run the model and examine the effects of the change. 
 
1. From the File menu, select Save As. 
 
2. Type “HIST” in the “New Project” box. 
 
3. Leave the “Path” and “Base DSN” as the default. 
 
4. Click “OK.” 
 

5. Click  (Landuse Editor). 
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6. Click in the “Area (acres)” column.  Reassign the area (acres) associated with “Urban 

or Built-up Land” (both pervious and impervious) to “Forest Land,” “Barren Land,” 
and “Wetlands” for each reach except Reach 5.   
 
Note:  There is only urban land contributing to Reach 5.  For simplification purposes, 

we will not redistribute this urban area to other landuse segments. 
 

Note: It does not matter how you distribute the area associated with “Urban or Built-
up Land” among “Forest Land,” “Barren Land,” and “Wetland.”  We are 
creating a hypothetical historical scenario. After you have distributed the 
“Urban or Built-Up Land” area to the other landuse categories, make sure that 
the total area contributing to each reach has not changed.  The following shows 
an example of how you might distribute the urban area: 

 

 
 
7. Click OK. 
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We will assume for this hypothetical historical scenario that no point sources contributed to 
the watershed.  In the following steps, we will turn “off” the point source in our model. 
 

8. Click  (Point Sources). 
 
9. Click on the “Western Branch WWTP” in the “In Use:” frame. 
 
10. Click REMOVE. 
 
11. Click OK. 
 

12. Click  (Run HSPF). 
 

13. Click SAVE/RUN. 
 

14. Click  (View Output through GENSCN). 
 
15. Click the “HSPF Output” tab. 
 
16. Check the box beside “c:\basins\modelout\scen.wdm.” 
 
17. In the “Scenarios” frame, select “BASE” and “HIST.” 
 

18. Click the “Add to time series list” button, . 
 
19. Plot TOTAL-N for Reach 5 and SSED for Reach 6 for both scenarios to see how the 

changes in landuse affect the instream daily average concentrations. 
 
20. From the Analysis menu, select Run Script.  
 
21. Navigate to c:/basins/models/hspf/bin and select “GenScnWatershedSummary.spt.” 
 
22. Click OPEN. 
 
23. In the “Script Arguments” window enter “hist” in the “CurScenario” box, “TotalN” 

in the “gCurConstituent” box, and “c:\BASINS\Modelout\scen\” in the “InputDir” 
box.   
 
Note: Be sure to use the same capitalization for the constituent name and include the 

backslash at the end of the input directory path.   
 
24. Click OK. 
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25. Repeat previous steps and produce a report for sediment by entering “hist” in the 

“CurScenario” box, “Sed” in the “gCurConstituent” box, and 
“c:\BASINS\Modelout\scen\” in the “InputDir” box.   

 
26. Click OK.  Look at the annual loads for total nitrogen and sediment for various 

landuses.  Compare these loads to those generated in the BASE scenario. 
 
Note: When the reporting scripts are run, the file is saved in the “Output” folder 

located in the same folder as your “.uci” file (i.e., 
\BASINS\modelout\scen\output). 

 
27. Close all open reports and return to WinHSPF. 
 
 
C. Scenario 2: Future Conditions 
 
QUESTION ANSWERED:  
3.) How do I generate a scenario that represents possible future conditions? 
 
1. From the File menu, select Open. 
 
2. Navigate to c:\basins\modelout\scen and select “BASE.uci.”  Click OPEN. 

 
Note:  We are reopening the base case input file in order to create a new scenario 

with the original landuse area distribution. 
 

3. From the File menu, select Save As. 
 
4. Type “FUT” in the “New Project” box. 
 
5. Leave the “Path” and “Base DSN” as the default. 
 
6. Click OK. 
 

7. Click  (Land Use Editor). 
 
8. Click in the “Area (acres)” column and add 20-30% of the acres associated with 

“Forest Land” to “Urban or Built-up Land.”   
 

Note:  Make sure that when you distribute “Forest Land” to “Urban or Built-up 
Land,” the pervious/impervious fractions are similar to those in the base case 
scenario (50% pervious and 50% impervious) unless you think that future 
development will be either highly concentrated (resulting in a higher 
percentage of impervious urban land than pervious urban land) or sparsely 
concentrated (resulting in a lower percentage of impervious land than 

 14-6



BASINS/HSPF Training                                                                               Exercises 
 
 

pervious land). 
 
 

9. Click  (Run HSPF). 
 
10. Click SAVE/RUN. 
 

11. Click  (View Output through GENSCN). 
 
12. Click the “HSPF Output” tab. 
 
13. Check the box beside “c:\basins\modelout\scen.wdm.” 
 
14. In the “Scenarios” frame, select “BASE,” “HIST,” and “FUT.” 
 

15. Click the “Add to time series list” button, . 
 
16. Plot TOTAL-N for Reach 5 and SSED for Reach 6 for all scenarios to see how the 

changes in the landuse distribution affect the instream daily average concentrations. 
 
17. From the Analysis menu, select Run Script.  
 
18. Navigate to c:/basins/models/hspf/bin and select “GenScnWatershedSummary.spt.” 
 
19. Click OPEN. 
 
20. In the “Script Arguments” window enter “fut” in the “CurScenario” box, “TotalN” in 

the “gCurConstituent” box, and “c:\BASINS\Modelout\scen\” in the “InputDir” box.   
 
Note: Be sure to use the same capitalization for the constituent name and include the 

backslash at the end of the input directory path.   
 
21. Click OK. 
 
22. Repeat previous steps and produce a report for sediment by entering “fut” in the 

“CurScenario” box, “Sed” in the “gCurConstituent” box, and 
“c:\BASINS\Modelout\scen\” in the “InputDir” box.   

 
23. Click OK.  Look at the annual loads for total nitrogen and sediment for various 

landuses.  Compare these loads to those generated in the BASE and HIST scenarios. 
 
24. Close all reports and return to WinHSPF. 
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D. Scenario 3: BMP Implementation 
 
QUESTION ANSWERED:  
4.) How do I generate a scenario that represents BMP implementation? 
 
In this section, we will discuss modeling the impacts of best management practice (BMP) 
implementation within WinHSPF.  To represent a BMP within WinHSPF, you need to do the 
following: 
 

• Identify the landuse segments and model segments (i.e., PERLND segments and 
IMPLND segments) that will be affected by the BMP 

• Define the level of BMP implementation (i.e., the percentage of the model 
PERLND/IMPLND segment that will be affected by the BMP) 

• Define the specific BMP in terms of the removal efficiency for each constituent the 
BMP impacts 

 
1. From the File menu, select Open. 
 
2. Navigate to c:\basins\modelout\scen and select “BASE.uci.”  Click OPEN. 

 
3. From the File menu, select Save As. 
 
4. Type “BMP” in the “New Project” box. 
 
5. Leave the “Path” and “Base DSN” as the defaults and click OK. 
 
6. From the Functions menu, select BMP. The “Best Management Practices Editor” 

window will appear: 
 

 

 

 
 

Note: The Best Management Practices Editor allows you to apply typical BMPs to 
various landuse segments within your model.  

 
7. From the “Select Summary or Reach Below BMP:” menu, select “1:R1 Upper 

 14-8



BASINS/HSPF Training                                                                               Exercises 
 
 

Western Br” A window will appear that contains information about the contributing 
sources to Reach 1: 

 
 

 
 
8. Click ADD BMP.  A screen will appear in which you can edit landuse segment areas 

and the percentage of each landuse segment to which the BMP will be applied, and 
edit removal efficiencies. 

 
9. Click in the cell that corresponds to “PERLND:103 (Agricultural Land)” and “% 

BMP 1” and type “75.”  
 

 
 
10. Click in another cell: the cell corresponding to PERLND: 103 and “% No BMP” will 

automatically be changed to “25.” 
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Note:  This means that we are applying a BMP to 75% of the agricultural land that 
drains into Reach 1. 

 
11. Click UPDATE UCI. 
 
12. Make sure the cell corresponding to PERLND:103(Agricultural Land) is still selected 

and click the “Edit Removal Efficiency” button. 
 

Note:  The Best Management Efficiency Editor is an interface to a BMP database that 
contains removal rates from literature for commonly used BMPs. 

 
13. From the “BMP Name:” menu, select “Filter Strip.”  The following table will become 

available: 
 

 

 
 

14. Change the values in the “Fraction” column to match the following: 
 

Constituent Fraction 
Sediment:Sand 70% 
Sediment:Silt 70% 
Sediment:Clay 70% 
NO3:Solution 21% 
TAM:Solution 46% 
NO2:Solution 21% 
NH4:Sand Adsorbed 46% 
NH4:Silt Adsorbed 46% 
NH4:Clay Adsorbed 46% 
Organic Nitrogen 46% 

 
Note: Note that you will need to enter a fraction and not a percentage (e.g., 0.7 for 

70%).  This BMP database is limited, so you may want to adjust the sand 
fraction (and associated constituents) to have higher removal efficiencies than 
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silt, clay, and dissolved fractions.  For example, you may want to reduce the 
Sediment:Silt and Sediment:Clay to 50% and the NH4:Silt and NH4:Clay to 
30%. 

 
15. Click UPDATE UCI. 
 
16. Click CLOSE. 
 
17. Repeat Steps (7-15) for Reaches 2-4. 
 
18. Click UPDATE UCI within the “Best Management Practices Editor.” 
 
19. Change the “Description” in the “Current BMP Details” to “Filter Strip.” 
 
20. Click CLOSE. 
 

Note: Notice that “BMPRAC” nodes have been added to each reach within the 
watershed schematic. 

 

21. Click  (Run HSPF). 
 
22. Click SAVE/RUN. 
 

23. Click  (View Output through GENSCN). 
 
24. Click the “HSPF Output” tab. 
 
25. Check the box beside “c:\basins\modelout\scen.wdm.” 
 
26. In the “Scenarios” frame, select “BASE,” and “BMP.” 
 

27. Click the “Add to time series list” button, . 
 
28. Plot TOTAL-N for Reach 5 and SSED for Reach 6 for all scenarios to see how the 

BMPs in landuse affect the instream daily average concentrations. 
 
29. From the Analysis menu, select Run Script.  
 
30. Navigate to c:/basins/models/hspf/bin and select “GenScnWatershedSummary.spt.” 
 
31. Click OPEN. 
 
32. In the “Script Arguments” window enter “bmp” in the “CurScenario” box, “TotalN” 

in the “gCurConstituent” box, and “c:\BASINS\Modelout\scen\” in the “InputDir” 
box.   
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Note: Be sure to use the same capitalization for the constituent name and include the 

backslash at the end of the input directory path.   
 
33. Click OK. 
 
34. Repeat previous steps and produce a report for sediment by entering “bmp” in the 

“CurScenario” box, “Sed” in the “gCurConstituent” box, and 
“c:\BASINS\Modelout\scen\” in the “InputDir” box.   

 
35. Click OK.  Look at the annual loads for total nitrogen and sediment for various 

landuses.  Compare these loads to those generated in the BASE scenario. 
 

Note: Notice that the new loads are not different than those from the base scenario.  
This is due to the way that the HSPF BMP Module handles BMP reductions, as 
simple removal efficiencies.  Thus, the BMP module does not change the load 
from the land operations (PERLND and IMPLND), but instead reduces the 
percent of the load from the land that enters each reach.  It represents each 
BMP as a separate intermediate operation between the PERLNDs and the 
RCHRES segment. 

 
36. Look again at the reach portion of the same reports.  Notice that the load of total 

nitrogen and sediment reaching the stream reaches has been reduced.  
 

Note: You will see the reduction in the loads in the reaches due to the BMP. 
 
37. Close any reports you may have opened and return to WinHSPF. 
 
 
Other Optional Scenarios 
 
If you have time, you may want to run some of the following scenarios. 

 
• BMP scenario with alternative removal efficiencies and implementation levels  
• A combination of a future and BMP scenario to see what level of BMP 

implementation would be required to offset the impacts of the expected 
urbanization. 

 
 
E. TMDL Calculations 
 
In this section, we will use WinHSPF and GenScn to calculate a simple total maximum daily 
load (TMDL) for total nitrogen.  We will begin by plotting the existing state of the total 
nitrogen calibration with a hypothetical water quality standard for total nitrogen of 5 mg/L.  
The required margin of safety is 10%. 
 
QUESTIONS ANSWERED: 
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5.) How do I use results of an HSPF model to calculate a TMDL? 
 
1. From the File menu, select Open. 
 
2. Click OK when told you can only have one *.uci file open. 
 
3. Navigate to c:\basins\modelout\scen and select “BASE.uci.”  Click OPEN. 
 

4. Click  (View Output through GENSCN). 
 
5. In the Locations frame, select “UPMARLBR” and “RCH 5.” 
 
6. In the “Scenarios” frame, select “BASE” and “OBSERVED.” 
 
7. In the “Constituents” frame, select “FLOW”, “TOTAL-N”, and “TN-LOAD.” 
 

8. Click  (Add to Time-Series List).  Your “Time Series” frame should look like 
the following: 

 

 
 

We will now plot the total nitrogen load on the right axis and the observed and simulated 
flows on the auxiliary axis. 

 

9. Click  (Generate Graphs). 
 
10. Click “Yes” when asked if you want to use all timeseries in the list.  
 

11. Select the Standard graph. 
 
12. Click Generate. Your graph should look like the following: 
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13. Double click in the center of the plot. A “Graph Edit” window will appear. 
 

 
 

14. Double click in the center of each cell in the “Color” column to change the color of 
each timeseries if you would like.  

 
15. Double click in the cells corresponding to both your observed and simulated flow in 

the “Axis” column and select “Auxiliary.” 
 
16. Double click in the cell corresponding to TN-LOAD in the “Axis” column and select 

“Right.” 
 

 
 
17. Click on the “Axes” tab and set the Left axis “Max” to “20”and the Right axes “Max” 

to “9000.”  You may also want to change the axis titles within the “Titles” tab.  Click 
APPLY and then OK. 
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Your plot should look like the following: 
 

 
 

18. Double click in the center of the plot. A “Graph Edit” window will appear. 
 

19. Click on the “Lines” tab.  Add two lines to the plot to show the hypothetical standard 
(with legend “Standard = 5 mg/L”) and the standard minus a 10% margin of safety 
(with legend “Standard – MOS = 4.5 mg/L”).  You may want to change the colors 
and the thickness of the lines.  Click APPLY and then OK. 

 

 
 

Your plot should look similar to the following: 
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F. Reduce NPS Loads to Achieve Standard and Derive TMDL  
 
The above plot shows how much the standard is being exceeded.  We will try to lower the 
total nitrogen concentrations to meet the standard by adjusting nonpoint loading rates.   
 
Use the generated reports to help you focus on the land use segments that contribute the 
largest total nitrogen loads.  It might be useful to make large adjustments at first to ‘bracket’ 
the desired maximum concentration value.   
 
The TMDL can be determined by (1) identifying the day on which the maximum value of the 
total nitrogen concentration lies just below the 4.5mg/L standard and then (2) determining 
the corresponding daily load.  To determine the maximum concentration and corresponding 
date, select Listing from the View menu on your plot.  A list will appear that includes each 
date, nitrogen concentration, and nitrogen load shown in the plot.  Once you have identified 
the maximum concentration and the day on which it occurs, you can find the corresponding 
daily load in the same list.  This daily load can be considered your TMDL. 
 
This hypothetical example is considerably simplified in order to demonstrate the overall 
calculation process.  In most real-world TMDLs, the calculations will need to be done over a 
number of years, including varying flow and climate conditions especially if NPSs are 
dominant and represent a large fraction of the total load.  Many states may require analysis of 
WQ standard exceedances and associated probabilities as defined by their WQ regulations.  
The procedures demonstrated above can be used to establish the loads associated with each 
exceedance, and the corresponding probability can be calculated as the ‘% of time’ the 
standard is exceeded. 
 
Apply several BMP iterations to each land use segment.  The goal is for the highest 
(simulated) daily total nitrogen concentration to be just below 4.5 mg/L.  After each run, 
regenerate the plot described above to check your results. 
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If time allows, you can re-do the TMDL calculation under an increased urbanization 
condition (as simulated earlier) to see how the TMDL might change under projected future 
conditions.   
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