
 

 

Exercise 7: Greater Than Conditional Operator 
 
 
Lesson Description 
 
Lesson 7 introduces the use of Greater Than as a conditional operator for a query/report.  This lesson 
begins with the creation of a complex report displaying multiple fields from the Fleet Detail, Product 
Code, Card Transaction, and Credit Card folders.    
 
 
Training Objectives 
 
At the conclusion of this lesson, Agency Fleet Headquarters Coordinators and Local Fleet Program 
Coordinators will be able to:  
 

1. Create a complex report using fields from up to four (4) different folders. 
2. Create a New Condition using the Greater Than (>) conditional operator. 

 
 
Methodology 
 
This lesson will be delivered as an Instructor-led exercise.  
 
 
References.  None.  
 

 
Enclosures.  None.   
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____________________________________________________________________________________ 
 
Preparation.  Using your Fleet Username, log on to Discoverer 
 
 

 
Figure 7-1 

 
 
 

Creating the Basic Query / Report 
 
 

Step 1.  At the initial Workbook Wizard page, select Create a New Workbook and Table, and click 
 . 

 
 

 
Figure 7-2 
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Step 2.  Open the Fleet Detail folder from the Available column on the left by clicking  , and select 
Product Code and Net Fuel Amount. 
 
 

 
Figure 7-3 

 
 
Open the Product Code folder from the Available column on the left by clicking  , and select Product 
Code Description. 
 
 

 
Figure 7-4 

 
 
Open the Card Transaction folder from the Available column on the left by clicking  , and select 
Product Code and Net Fuel Amount. 
 
 

 
Figure 7-5 

 
Open the Credit Card folder from the Available column on the left by clicking  , and select 
Cardholder/Prop Number. 
 
 

 
Figure 7-6 
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When these actions are completed, your Selected column on the right-hand side of the paged should 
appear like Figure 7-7 below.  If yes, click  and to proceed through to Workbook Wizard Step 4.   
 
 

 
Figure 7-7 

 
 
Step 4.  Open the All Items drop-down list by clicking on  , shown in Figure 7-8. 
 
 

 
Figure 7-8 

 
The View Conditions for: selection list will appear. See Figure 7-9. 
  
 

 
Figure 7-9 

 
 

Select Transaction Amout SUM, and click  . 
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The New Condition window will appear, with selections in the Item and Condition fields as shown in 
Figure 7-10 below. 
 

 
Figure 7-10 

 
Click on  under Condition to display a menu of available conditional operators.  See Figure 7-11.  
Select >, the Greater Than conditional operator. 
 

 
Figure 7-11 

 
Under the Value(s) data entry field, enter the number 50.  When completed, your New Condition window 
should appear similar to Figure 7-12. 
 

 
Figure 7-12 
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When this action is completed, click  , which will return you to the Workbook Wizard Step 4 
window.  Click  to proceed to the next Workbook Wizard window, where you’ll add two Group 
Sorts to your query/report. 
 
 
Step 5.  The Workbook Wizard Step 5 page is shown in Figure 7-13 below.   
 
 

 
Figure 7-13 

 
 
Click on  , to access a menu of fields available for Sort operations.  See Figure 7-14. 
 
 

 
Figure 7-14 
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Select Merchant Name, then click  again and select Cardholder/Prop Number.  Now you’ve 
selected two fields for an action.  For Row 1 (Merchant Name), click on the  under Group, and select 
Group Sort from the menu.  See Figure 7-15.  Repeat this process for Row 2 (Cardholder/Prop Number).   
 
 

 
Figure 7-15 

 
 
Your selections should appear similar to Figure 7-16. 
 
 

 
Figure 7-16 

 
 
Your query is now ready to run.  Click  to run your query and generate a report.   
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When the initial results appear, resize them by selecting the entire table, and using the 
Format>Column>Auto Size function at the tool bar.  Adjust your column headings by selecting 
Format>Headings, and editing column sizes as learned in Lesson 6.  When complete, your report should 
appear similar to Figure 7-17 below. 
 
 

 
Figure 7-17 
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Finally, save your report by clicking on  , selecting a computer or the database for storing your report 
(Figure 7-18), and saving this report as Date Ranges and Column Headers (Figure 7-19). 
 
 

 
Figure 7-18 

 
 

 
Figure 7-19 

 
 
Summary.  In this lesson/exercise, you successfully created a report on purchases in excess of $50.00, 
by Merchant Name and Cardholder Name/Prop Number.  In the next lesson/exercise, you’ll create an 
Accounting Report to review valid accounting by Unit and Sub Unit Voyager No and PCMS User ID. 
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Exercise 8: Adding Totals to Reports 
 
 
Lesson Description 
 
Lesson 8 introduces the use of Totals and Subtotals as an added feature to your reports.  This lesson 
begins with the creation of a report of fuel sales by Product Code, Product Description and Transaction 
Amount.  Then, you’ll learn to add totals and subtotals to your report.    
 
 
Training Objectives 
 
At the conclusion of this lesson, Agency Fleet Headquarters Coordinators and Local Fleet Program 
Coordinators will be able to:  
 

1. Create a complex report, which details and summarizes fuel purchases for a specific period. 
2. Add totals and subtotals to a report. 

 
 
Methodology 
 
This lesson is delivered as a two-part exercise.  In Part 1, students will create a report on fuel purchases 
as an individual practical exercise.  Part 2 of this lesson, an Instructor-led exercise, will enhance the 
report by adding totals and subtotals to the final report.  
 
 
References.  None.  
 

 
Enclosures.  None.   
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Part 1 
 
 

1. Using your Fleet Username, log on to Discoverer. 
 

2. Create a New Workbook and Table-format report. 
 

3. Select the fields shown in Figure 8-1 for your report. 
 
 

 
Figure 8-1 

 
 

4. Change your table/column layout to mirror Figure 8-2 below. 
 
 

 
Figure 8-2 
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5. Create a New Condition on Purchase Date, and select all fuel purchases for fiscal year 2002.  See 
Figure 8-3 below. 

 
 

 
Figure 8-3 

 
 

6. Create a Group Sort on Region, Unit and Sub Unit.  See Figure 8-4. 
 

 

 
Figure 8-4 

 
 
 

7. Now, run your query and view your report. 
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8. After you resize and format your report, your results should appear similar to Figure 8-5 below.  
If yes, you’ve successfully completed Part 1 of this lesson/exercise.  Save your report as FY2002 
Fuel Purchase Report, and wait for instructions.  

 
 

 
 

Figure 8-5 
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Part 2 
 
 

1. Select Tools>Totals from the tool bar at the top of the screen.  See Figure 8-6. 
 

 

 
Figure 8-6  

 
 

2. The Totals window shown in Figure 8-7 below will appear. 
 
 
 

 
Figure 8-7 
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3. Click on  in the  window, which will present a menu of columns from 
which to select for total or subtotal functions.  See Figure 8-8. 
 

 

 
Figure 8-8 

 
 

4. Select Sub Unit, in order to create subtotals at each break in your report where Sub Unit changes, 
and click .  The Total window in Figure 8-9 will appear. 

 
 

 
Figure 8-9 
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5. Set the fields in the Calculate section of the Total window as shown in Figure 8-10. 

 
 

 
Figure 8-10 

 
 

6. Next, set fields in the Placement section of the Total window as shown in Figure 8-11. 
 

 

 
Figure 8-11 

 
 

7. Finally, insert a descriptive name in the Label field of the Total window.  Note that the text in the 
Preview field is modified as you type text into the Label field.  See Figure 8-12.  Ensure the Wrap 
text checkbox is selected and click  . 
 

 

 
Figure 8-12 
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8. Now, a page break should appear whenever the Sub Unit in your report changes, containing a 
subtotal of the Transaction Amounts for that Sub Unit.  Note the subtotal, which appears in the 
right-hand column of row 9703 in Figure 8-13. 
 

 

 
Figure 8-13 

 

 
9. Next, repeating the process used for subtotals, you’ll create a Total for Transaction Amount for 

your report.  Returning to the toolbar, select Tools>Totals. 
 
 

 
Figure 8-14 

 
 

10. At the Total window, select the options shown in Figure 8-14, use a descriptive name for your 
report’s total in the Label field, and click  . 
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11. Regenerate (or recompile) your report results by clicking  on the toolbar.  Scroll to the 
bottom of your report, and you should see a Total in the final row of your report containing the 
sum of all Transaction Amounts.  See Figure 8-15.  Remember, if your report contains more than 
100 rows, go to the tool bar, and select Sheet>Retrieve All Rows, so you can see the final row of 
data in your results set. 

 
 

 
Figure 8-15 

 

12.   Finally, click  to save the modifications you added to this report in Part 2 of this 
lesson/exercise. 

 
 
 
 
Summary.  In this lesson, you learned how to add totals and subtotals to your report results.  In the 
next and final lesson of Fleet / Oracle Discoverer Training Guide, you learn how to share your reports 
with other Discoverer users. 
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Exercise 9: Sharing or Deleting Reports  
 
 
Lesson Description 
 
Lesson 9 provides Oracle Discoverer users with the ability to share useful reports with other users, or to 
delete unneeded reports.   
 
 
Training Objectives 
 
At the conclusion of this lesson, Agency Fleet Headquarters Coordinators and Local Fleet Program 
Coordinators will be able to:  
 

1. Share a report with another user. 
2. Delete a report. 

 
 
Methodology 
 
This lesson will be delivered as an Instructor-led exercise.  
 
 
References.  None.  
 

 
Enclosures.  None.   
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Preparation.  Using your Fleet Username, log on to Discoverer 
 
 

 
Figure 9-1 

 
 

Sharing Workbooks 
 

When logging into Oracle Discoverer, the first Workbook Wizard page will automatically appear.  Close 
this page by clicking on the  in the upper right-hand corner.  See Figure 9-2 below.  
 

 
Figure 9-2 

 
Next, go to the toolbar, and select File>Manage Workbooks>Sharing.   
 
 

 
Figure 9-3 
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This action will open the Share Workbooks window.  See Figure 9-4. 
 
 

 
Figure 9-4 

 
 
The Share Workbooks window has two (2) tabs, the Workbook -> User tab and the User -> Workbook 
tab.  The Workbook -> User tab is used to provide one or more users access to a single report.  The User 
-> Workbook tab is used to provide multiple reports to a single user. 
 
To provide one or more users access to a single report, from the Workbook -> User tab, first select the 
report to be shared from the Workbook: list (Figure 9-5) by clicking on  and selecting the report by 
name.   
 
 

 
Figure 9-5 
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Next, select a single user by clicking on their User ID from Available list in the Users window.  See 
Figure 9-6. 
 
 

 
Figure 9-6 

 
 
To select multiple users, hold down the Ctrl key, and click each shared user with your mouse.  Once 
you’ve highlighted the shared user or users, click  , and the user name(s) will be moved to the 
Shared list.  Then click  , and the report you selected for sharing will immediately be available 
to the user(s) you selected. 
 
To share multiple reports with a single user, first click on the User -> Workbook tab on the Share 
Workbooks window.  (See Figure 9-7) 
 

 
Figure 9-7 
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Next, select a User by clicking  on the User: field drop-down menu, and selecting a User ID from the 
list.  See Figure 9-8. 
 
 

 
Figure 9-8 

 
Once you’ve identified a User, select a report or multiple reports from the Available list, and click 

  (See Figure 9-9), which will return you to the Share Workbooks window.  Click  ,  
and the report or reports you selected are immediately available to the User selected. 
 
 

 
Figure 9-9 
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Deleting Workbooks 

 
 
Over time, you will likely find you have reports (Workbooks) stored in the database, which you neither 
need nor want… so DELETE them. 
 
Go to the tool bar at the top of the Oracle Discoverer window, and select File>Manage 
Workbooks>Delete.  This action will open the Delete Workbook from Database window.   
 
 

 
Figure 9-10 

 
 

Click on the report or reports you wish to delete, and then click on  .  The report or reports 
selected are immediately deleted from the database. 
 
 
Summary.  In this final lesson/exercise, you learned how to share a report or reports with a single or 
multiple Users.  Additionally, you learned how to delete obsolete reports from the database.   
 
This is the final lesson for Fleet Oracle Discoverer users.  By applying the knowledge and experience 
gained in this and previous lesson/exercises, you are well prepared to begin creating your own custom ad 
hoc reports.  Retain and use these lesson/exercise outlines to assist you in this endeavor.   
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