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Powder Sample 
1. Select the data files, and press Load Data button. 
 

 
 
2. Choose the viewing axes, and press Calculate Projection button. 
 

 
 
3. Press Plot Slice button to view the color contour plot of the intensity over the chosen viewing axes, or 
Surf Slice to view the 3D surface plot.  
 

 
 
The plot will look like the following, which is a superfluid LHe4 roton spectrum. 
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4. Choose the cutting axis, and press Plot Cut to plot the cut. 
 

 
 
The plot will look like the following. 
 

 
 

Single Crystal Sample 
1. Select the data files, and press Load Data button. 
 

 
 
2. Select the background (empty can) files, then in Background menu, press Load Background File(s). 
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3. Choose the Vanadium file, and in Background menu, press Load Vanadium File(s). 
 

 
 
4. Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate Projection 
button. Psi is the angle from ki to u, with counterclockwise being the positive direction. 
 

 
 
5. Choose the slice plane. Press Plot Slice button to view the color contour plot of the intensity over the 
slice plane, or Surf Slice to view the 3D surface plot.  
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The plot will look like the following. 
 

 
 
6. Choose the cutting axis and thickness over the other two axes, and press Plot Cut to plot the cut. 
 

 
 
The plot will look like the following. 
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Single Crystal Diffuse Scattering 
1. Select the data files, and press Load Data button. 
 

 
 
2. In the option menu, select the average binning method, show Al powder line, and log scale intensity. 
Enter the lattice parameters, crystal orientation, and the viewing axes, then press Calculate Projection 
button. Psi is the angle from ki to u of the first file, with counterclockwise being the positive direction. 
 

 
 
3. Press Plot Slice button to view the color contour plot of the intensity over the viewing axes, or Surf 
Slice to view the 3D surface plot.  
 

 
 
The plots will look like the following. 
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The white lines denote the positions of the Al powder line. 
 

Load SPE File 
To read a SPE file, use the Load SPE File button in the File menu. The following dialog window will 
appear. PHX file refers to the detector configuration file that is associated with the SPE file. 
 

 
 
User will be asked to enter the incident neutron energy during the projection calculation. 
 

Load DAVE File 
To read a DAVE format file, use the Load DAVE File button in the File menu.  The DAVE file should 
contain all necessary information, preferably a DAVE file reduced from the DCS files. 
 

Convert DCS Files to SPE Format 
Convert DCS Files To SPE Format button in the File menu starts a stand-alone application to convert 
DCS files into SPE format which can be processed by MATLAB Mslice program. 
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Choose one or more DCS *.dcs or *.dcs.gz files in the DCS file directory, press Convert button to 
convert them into *.spe files. The converted files will have the same names as the DCS files except for the 
file extension and they are saved in the SPE file directory.  
 
To combine two or more DCS files, choose them in the DCS file directory, then press Combine button. 
The name of the combined SPE file can be specified in the save as: textbox. If no name is given, the 
default is 'combine.spe'. 
 
Overall background rate and Associated error are used to apply an overall background rate to all the 
detectors.  The background will be subtracted in Convert and Combine operations. 
 
Energy binning size is used to rebin the time channel to reduce the size of data. 
 
Load BG button is used to load background files, which will be subtracted in Convert and Combine 
operations. Once the background file is loaded, they will stay in the memory until Clear Bg button is 
pressed. The Clear Bg button will be sensitive only when a background file has been loaded. 
 
Load V button is used to load vanadium files, which will be used to calculate the detector efficiencies. 
The detector efficiencies and divided from data in Convert and Combine operation. Once the vanadium 
file is loaded, the detector efficiencies will stay in the memory until Clear V button is pressed. The Clear 
V button will be sensitive only when a vanadium file has been loaded. 
 
Both background files and vanadium files are selected in the DCS file directory. 
 
Detectors can be masked in various ways in the Mask menu. Once set, the mask will stay in the memory 
until Mask->Clear the mask is pressed. 
 
The data files can be saved as either single crystal or powder sample by choosing the corresponding 
sample type in the Sample menu. With the choice of powder sample, detectors with the same two theta 
angle will be combined. 
 
Detector configuration file (*.phx) can be created during file conversion by choosing the Yes option in 
Sample->Create Detector File. 
 
To exit the program, either go to File->Exit or simply close the window. 
 

Exit 
To exit the program, press the File->Exit button or simply close the window. 

 

Load Parameters 
To load a previously saved parameter file, click the Parameter->Load Parameters button. A file 
selection window will pop up. All the parameters shown in the main window plus some options will be 
restored. However, previous DCS data and projection are not loaded. 
 

Save Parameters 
To save the current settings in the main window, click the Parameter-> Save Parameters button. A file 
selection window will pop up. The default extension of saved file is *.prm. If no file name is entered or 
selected, no action is taken. 
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Change Self-Shielding Factor 
The self-shielding factor is used in background subtraction according to the following equation: 
  I     = I1-ssfactor*I2 , 
  Err = sqrt[Err1

2+(ssfactor*Err2)2] . 
 

Change Overall Intensity Factor 
The overall intensity factor is multiplied to the intensity during projection calculation. This factor is reset 
to 1 every time a data file is loaded. 
 

Change Smoothing Kernel 
The smooth kernel for smoothing the 2D slice data can be changed in the Parameter menu. The default 
kernel is [[0.1,0.2,0.1],[0.2,0.8,0.2],[0.1,0.2,0.1]]. An error will be given if the entered matrix is not 
symmetric. 
 

Set Data Directory 
Set Data Directory in the Parameter menu will change the data directory to a new one. 
 

Set Working Directory 
Set Working Directory in the Parameter menu will change the working directory to a new one. The 
working directory is used as the default directory in saving files. 
 

Load Background File(s) 
To load a background file, use the upper left file locator to select the background file(s). Then press the 
Background->Load Background File(s) button.  The background data will stay in the memory until the 
Background->Clear Background is pressed. The background will be subtracted in projection 
calculation. The intensity (I) and error (Err) are calculated as follow: 
  I     = I1-ssfactor*I2 , 
  Err = sqrt[Err1

2+(ssfactor*Err2)2] , 
where ssfactor is the average self-shielding factor. 
 

Set Overall Background Rate 
The Set Overall Background Rate button in the Background menu is used to input the overall 
background rate in counts/hour/detector. The value is then adjusted accordingly to be subtracted from 
DCS data in projection calculation. There is no error handling in this process. Use Background->Clear 
Background to clear it from the memory. 
 

Clear Background 
Background->Clear Background button is used to clear the background file and/or overall background 
rate from memory. To take effect, projection needs to be recalculated. 
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Load Vanadium File(s) 
To calculate the detector efficiency factor of the spectrometer, first highlight the vanadium file using the 
upper left file locator, then press the Load Vanadium File(s) button in the Background menu. The 
detector efficiency factor is calculated as proportional to the integrated intensity of the elastic peak in each 
detector. This factor is divided from the raw data every time the projection is calculated. However, the 
raw data and the projection data are stored differently. Use Background->Clear Vanadium to clear the 
detector efficiency factor from memory. 
 

Clear Vanadium 
Background->Clear Vanadium button is used to clear the detector efficiency factor from memory. To 
take effect, projection needs to be recalculated. 
 

Mask Upper and Lower Banks 
To view the data from only the central bank detectors, press the Mask Upper and Lower Banks in the 
Mask menu. The mask takes effect when projection is calculated. 
 
Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 
 

Mask Central and Lower Banks 
To view the data from only the upper bank detectors, press the Mask Central and Lower Banks in the 
Mask menu. The mask takes effect when projection is calculated. 
 
Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 
 

Mask Upper and Central Banks 
To view the data from only the lower bank detectors, press the Mask Upper and Central Banks in the 
Mask menu. The mask takes effect when projection is calculated. 
 
Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 
 

Set Your Own Mask 
To mask arbitrary detectors, press the Set Mask in the Mask menu. The detector number starts from 0. 
The mask takes effect when projection is calculated. 
 
Once set, the mask stays in the memory. To clear the mask, press Mask->Clear Mask button. 
 

Intensity Type 
Use Option->View Intensity As button to choose the intensity type as one of the following three: 
 S(Q,omega)                         ------ a factor of (ki/kf)4 is applied to the normalized intensity, 
 Symmetrized S(Q,omega) ------ a factor of exp(-E/2kBT)*(ki/kf)4 is applied to the normalized intensity, 
 d2(sigma)/d(Omega)d(Ef) ------ a factor of (ki/kf)3 is applied to the normalized intensity. 
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Binning Method 
Two binning methods, average and sum, can be chosen from the Option->Binning Method menu button. 
The binning method is applied in rebinning time channel according to E Rebin Size for powder and 
single crystal or energy range in loading diffuse scattering data, and rebinning data in displaying slices 
and cuts. 
 

Monitor Count 
There are two options to calculate the monitor count: sum of beam monitor counts or the integrated 
intensity of the beam monitor counts after fitted by a Gaussian. The option is set in Option->Monitor 
Count.  The monitor count is used to normalize data in loading DCS files. 
 

Viewing Axis Type 
For single crystal and diffuse scattering type, there are two options of viewing axis: orthogonal and 
arbitrary. They can be set in Option->Viewing Axis. If orthogonal option is chosen, the viewing axes 
given must be orthogonal to each other.  
 

Show Powder Line 
In diffuse scattering mode, either Al or Cu powder line can be overplotted to the intensity contour plots or 
detector trajectories (when the viewing axes are x and y axis). To do this, select the Al or Cu option in 
Option->Show Powder Line menu. The projection needs to be calculated to have the option in effect. 
 

E-Dependent Detector Efficiency Correction 
The energy dependent detector efficiency correction to the intensity can be applied to the data in 
projection calculation. To set this option on and off, press the Option->E-Dependent Detector 
Efficiency Correction button. When the program started, this option is off. 
 
Warning: The intensity at high energy end could be overly corrected when this option is set. 
 

Log Scale Intensity 
If Option->Log Scale Intensity menu button is set, subsequent plots will use log scale for the intensity. 
However, the log scale can be set back to linear in the plots. 
 

Hiding Part of the Window 
The projection, display, and detector trajectory frame of the window can be hidden by using the options in 
Window menu. This can be quite useful if the size of the window is larger than the screen. The following 
snapshot is an example. 
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View Current Plot Window 
By pressing Window->Current Plot Window menu button, the current active (not kept) plot window 
will gain focus.  
 

Load DCS File 
To load DCS file(s) ending with .dcs or .dcs.gz, use the top left file locator to select one or more files. 
Press Load Data button to load the data. An error will be given if no file is highlighted. The data will be 
normalized by the monitor counts of beam monitor 1 if shutter is open. 
 
For powder and single crystal sample type, the files will be combined. For diffuse scattering sample type, 
files are not combined, and energy range needs to be specified beforehand. 
 
The loaded data will not be modified by the program until new data file is loaded or added, or the sample 
type is changed to or from diffuse scattering. Press Clear DCS Data button to remove the data from 
memory. 
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Add Data 
The Add Data button will be activated when DCS data has been loaded.  
 
Select the data files to be added by the upper left file locator. Then press the Add Data button. An error 
will be given if the file selected and the existing data are of different wavelength, master speed, speed 
ratio, resolution mode, or tsdmin. 
 
For powder and single crystal data, the data are added to existing data; for diffuse scattering sample type, 
the data are appended to the existing data. 
 
The algorithm for computing added intensity(I) and error(Err) with weights(W) taken into account is as 
follows: 
  I3      = (I1*W1+I2*W2)/(W1+W2) , 
  Err3  = sqrt[(Err1*W1)2+(Err2*W2)2]/(W1+W2) , 
  W3   = W1+W2 . 
 

Clear DCS Data 
Press Clear DCS Data to clear from memory the loaded DCS data and calculated projection data if 
existed. 
 

Sample Type 
There are three sample types: single crystal, powder, and diffuse scattering. 
 
For single crystal sample, lattice parameters, crystal orientation, and three viewing axes need to be given 
to enable proper projection calculation.  The data is plotted as 2D intensity color map on the plane defined 
by two of the viewing axes. The third axis is used to restrict the slice range. The data can also be cut along 
one of the three viewing axes with restrictions on the other two axes, and plotted as 1d plot. 
 
For powder sample, two viewing axes need to be specified. In the projection calculation, detectors with 
the same two-theta angle are combined. The data is plotted as 2D intensity color map on the plane defined 
by the viewing axes.  The data can also be cut along one of the two viewing axes with restrictions on the 
other axis, and plotted as 1d plot. 
 
For diffuse scattering sample type, lattice parameters, crystal orientation, and two viewing axes need to 
be given to enable proper projection calculation.  The data is plotted as 2D intensity color map on the 
plane defined by the viewing axes. The data can also be cut along one of the viewing axes with 
restrictions on the other axis, and plotted as 1D plot. 
 
When the sample type is changed, the projection data is cleared and need to be recalculated before any 
plots can be made. The raw data is still stored in the memory if the change is between powder and single 
crystal type. 
 

Lattice Parameters 
For single crystal and diffuse scattering sample types, the direct lattice parameters of the unit cell  are 
specified by a, b, c, α, β, and γ.  α is the angle between b and c, β is the angle between c and a, and γ is 
the angle between a and b. An error will be given during projection calculation if any one of the six lattice 
parameters is missing. 
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Crystal Orientation 
For single crystal and diffuse scattering sample types, the crystal orientation with respect to the 
spectrometer is defined by two reciprocal crystal axes (u & v) in the principal scattering plane of the 
spectrometer and one angle (Psi) which uniquely identifies the rotation of the crystal in this plane.   
 

 
 
(ux, uy, uz) and (vx, vy, vz) specifies the two reciprocal crystal axes. u x v should point to the vertically 
upward direction. 
 
Psi is the angle between u and ki, and is positive if ki x u is pointing to the vertically upward direction.  It 
should be the same as DCS A2 angle if A2=0 when ki//u. For diffuse scattering, Psi is the angle for the 
first file. 
 
An error will be given in projection calculation if any value of u, v, or Psi is not set. 
 

Viewing Axes 
Powder 
The viewing axes for powder are two axes out of (Energy, |Q|, 2Theta, and Det Group Number). They can 
be specified from the droplists. The labels of the viewing axes are used as corresponding axes titles in the 
2d plots. The Most commonly used set of viewing axes for powder sample is u1=|Q| and u2=Energy. 
 
Single Crystal 
The viewing axes for single crystal are either wave vector directions or energy. They must be orthogonal 
if the orthogonal option is chosen for the viewing axis type. The energy axis is orthogonal to any wave 
vector direction. An example is  
 u1 = [1 0 0 0] ;a* 
 u2 = [0 1 0 0] ;b* 
  u3 = [0 0 0 1] ;E 
An error will be given in projection calculation if any value of the viewing axes is not given or the axes 
are not orthogonal when required. 
 
Diffuse Scattering 
The viewing axes for diffuse scattering are wave vector directions. They must be orthogonal if the 
orthogonal option is chosen for the viewing axis type. An example is  
 u1 = [1 0 0] ;a* 
 u2 = [0 1 0] ;b* 
An error will be given in projection calculation if any value of the viewing axes is not given or the axes 
are not orthogonal when required. 
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Energy Rebin 
To reduce the amount of data being processed and plotted, the raw data can be rebinned in the projection 
calculation for single crystal and powder sample types. Time channels are binned according to the size 
specified in the E Rebin Size textbox. No action is taken if the E rebin size is less than one or absent. The 
rebinning can be either average or sum according to the specified binning method. 
 

Calculate Projection 
Press Calculate Projections button to project the raw data into viewing axes. Detector masks and 
detector efficiency factors are applied if they are present. The background will also be subtracted if they 
have been previously loaded. Intensity data are also rebinned if E rebin size is greater than 1. The 
intensity will be calculated as one of three options chosen in Option->View Intensity As menu. Energy 
dependent detector efficiency will be calculated if the option is set. The projected data and the raw data 
are stored differently, i.e., the raw data are not changed by this calculation. If no DCS data has been 
loaded, the program will prompt for incident neutron energy Ei to calculate detector trajectories. 
 
For powder, detectors with the same 2theta angle will be combined.  
 
For diffuse scattering, data with the same sample rotation angles will be combined. 
 
For single crystal and diffuse scattering, an error message will be given if any value of the lattice 
parameter, crystal orientation, and viewing axes is not given, or if the viewing axes are not orthogonal 
when required. 
 

Intensity Label 
The intensity label is used as the axis title for intensity in plots. If not given, the default is Intensity. IDL 
formatting codes are supported. 
 

Title Label 
The title label is used as title in plots. IDL formatting codes are supported. It is set to the comment of a 
DCS data file after the file is loaded. The plot title can be easily modified in the plot window. 
 

Legend Label 
The legend label is used as the legend in plotting 1D cuts. It is set to the last word of the comment of a 
DCS data file after the file is loaded. The plot legend can be easily modified in the plot window. 
 

Intensity Color Contour Plot and Slice 
The intensity data projected into two viewing axes can be plotted as color contour plot by pressing the 
Plot Slice button. 
 
For single crystal data, the axis perpendicular to the slice plane is chosen from the perp to droplist which 
contains the three viewing axes. The choice of the perpendicular axis automatically defines the slice plane 
axes as the remaining two viewing axes, and the horizontal and vertical label will change accordingly. 
 
To fold the symmetrical data, choose the Fold x-axis option. The data can be folded into either positive or 
negative range depending on the sign of the horizontal range. 
 
Data can be rebinned by specifying the horizontal and/or vertical step.  If not specified, the default 
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binning size is 200 except for energy data. The binning algorithm is as follows: a grid of bins of size xstep 
x ystep is constructed with the lower left corner at (xmin-xstep/2, ymin-ystep/2) and not exceeding 
xmax+xstep/2 along x and ymax+ystep/2 along y. The x and y values for each bin are calculated by taking 
the average of the x and y values of all the data in that bin, and the intensity is the average or sum of all 
the data in that bin according to the specified binning method. The limits are inclusive to the left and 
exclusive to the right. 
 
The grid can be smoothed by choosing a nonzero Smoothing level. The default smoothing kernel is  
  0.1   0.2   0.1 
  0.2   0.8   0.2 
  0.1   0.2   0.1 . 
The kernel can be changed  in the Parameter menu. 
 
The color map of the contour plot can be chosen from the color map droplist. The names are the same as 
the predefined IDL color table names.  
 
Two types of shading are available: Flat and Gouraud. 
Flat: The color has a constant intensity for each face of the surface, based on the normal vector.  
Gouraud: The colors are interpolated between vertices, and then along scan lines from each of the edge 
intensities.  
 
The 2D data can also be plotted as color surface plots by pressing the Surf Slice button. 
 
Tip 1: Specify the horizontal and vertical range to reduce the amount of data and speed up the plotting. 
 
Tip 2: If the energy step is not specified, the original energies corresponding to the time channels are used. 
This will prevent the energies from being changed by the binning process. 
 

Cut 
Cuts can be made along one of the viewing axes with integration over the other two directions for single 
crystal or the other one direction for powder. Use along droplist to select the x axis, and y droplist to 
select the y axis. The plotted data are the average or summed values over the integrated volume according 
to the specified binning method. 
 
X and y range, integration volume (thickness) can be specified by the from: and to: textboxes. Data can 
also be rebinned by specifying the cut step. The x-range is divided into bins of length step starting at 
xmin-step/2 and not exceeding xmax+step/2.  The x and y value for each bin is calculated by taking the 
simple average of the x and y values of all data in that bin, where the limits are inclusive to the left and 
exclusive to the right. 
 
Plot symbols can be specified by the color, symbol style, and line style droplists. White color will be 
switched to black when the figure is printed or saved as a file. Press Plot Cut to plot the cut in the current 
plot window, or press Oplot Cut to overplot the cut in the current plot window. If save as type is other 
than none, the cut data will be saved as a .xye(x, y, yerr) file whose name can be either entered in a the 
filename textbox or chosen by pressing Browse button. 
 
The cut data can also be sent to the Peak Analysis (PAN) program for fitting. To do this, simply press the 
Fit button. The cut data will be saved in this operation if the saving file name is specified. 
 
Tip: If the cut is along energy and the step is not specified, the original energies corresponding to the time 
channels are used. This will prevent the energies from being changed by the binning process. 
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Plot Trajectories 
The Plot Trajectories button is insensitive until projection is calculated. The projection can be calculated 
without loading any DCS data.  
 
Detector trajectory is an x vs. y 1d plot. Both x and y are chosen from droplist. If None is chosen, the 
detector group number is used. Z can be used to restrict the range of data in extra dimension. If no ranges 
are set for x, y, and z, the default is to show all possible data. The following is an example in diffuse 
scattering mode. 
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