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Executive Summary 
PureEdge viewer works on an Apple Macintosh computer when used in conjunction with a 
software emulator.   IV&V tested its operation under three different operating systems (Windows 
95, 98 and 2000 Professional) running under emulation mode on a Mac iBook computer.  In all 
cases, it was possible to download a grant application, complete it offline, print it locally and 
submit it for processing to Grants.gov.  While the performance was somewhat slow due to the 
emulated environment, the user experience was similar to what a user experiences on a Windows 
machine.  IV&V did not discover any major issues that might prevent use of the Macintosh 
platform for interacting with Grants.gov.   

This document summarizes lessons learned during testing.  It also provides basic guidance on 
selection of emulation software, and detailed installation and configuration of PureEdge on Mac. 
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Preface 
Purpose and Scope 
This document provides information about using PureEdge in an emulated environment on Mac. 
It includes answers to basic questions about using Mac computers with Grants.Gov and describes 
detailed installation and configuration of an emulated environment.      

Background 
PureEdge viewer is required to open, complete and submit a grant application obtained from 
Grants.gov but it works only on Windows operating systems.  Microsoft Virtual PC (VPC) v6.1 
is PC emulation software that allows Mac users to run Windows applications.    Once VPC is 
installed on a Mac, a guest1 operating system such as Windows 2000 or Windows XP can be 
installed inside the emulated environment provided by VPC.   

This document is based on the results of testing several guest operating systems including 
Windows 952, Windows 98 and Windows 2000 Professional on a Virtual PC for Mac 6.1 on an 
Apple iBook running OS X 10.3.2.    

Audience 
This document is geared toward both customer support staff of Grants.gov and experienced Mac 
users in the Grantee community.    

Organization of this document 
The first section provides a discussion of some common Mac issues in a Frequently Asked 
Questions (FAQ) format.  It is followed by detailed installation and configuration information for 
Virtual PC for Mac.  

 

 

                                                 
1 The host platform is the machine that runs the Virtual PC for Mac software. The guest platform is the operating system and 

applications that Virtual PC is simulating. 
2 Please note that PureEdge is not officially supported on Windows 95 and Microsoft no longer provides support for this 

operating system.  On a related note, Microsoft recently extended support for Windows 98 to June 2006. 
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1 General FAQs When Using Macs with Grants.gov 
Q. What browsers on Mac are compatible with Grants.gov? 
While Grants.gov has not been thoroughly tested on with Macs, all newer versions of Safari, 
Netscape, IE and Mozilla should provide adequate capabilities to search and download grant 
applications from Grants.gov.  However, to fill out a grant application and submit it to 
Grants.gov, the PureEdge viewer is required.    

Q.  Is There A Macintosh Version Of The PureEdge Viewer? 
A.  No.  The PureEdge viewer runs only on Windows.  However, Mac users can use emulation 
software to run PureEdge. 

Q.  What Windows Emulation Software Is Available For Macs? 
A.  Microsoft Virtual PC for Mac is available in several flavors.  Costs range between $129-$250 
depending on if it comes bundled with a Windows operating system or not.    

Q.  What Else Do I Need To Run PureEdge On A Mac? 
A.  Microsoft Virtual PC for Mac requires a G3 or a G4 Mac with at least 256MB physical 
RAM, 2 GB free hard drive space running either Mac OS X 10.1.5 or higher or Mac OS 9.   

Q.  Is Virtual PC For Mac Compatible With G5 Processors? 
A.  No, as of writing this document (01/2004).(But check for the latest status on 
http://microsoft.com/mac.)   According to latest product announcements from Microsoft, v7.0 
due in 1st half of 2004 will support G5.   Please see the end of this FAQ for alternatives.  

Q.  Is There A Separate Version Of PureEdge Viewer That Works With 
Microsoft Virtual PC For Mac? 
A.  No, there is only one version of PureEdge, which can be downloaded from 
http://www.grants.gov/DownloadViewer.   
Q. What Can Be Done Using PureEdge Running On Microsoft Virtual 
PC For Mac? 
A.  You can download, complete, submit and print grant applications using PureEdge on Mac.    
Q.  Is USB Printing Supported Under Virtual PC? 
A. Yes, according to product documentation, but your specific capabilities will vary.  During our 
tests with two different printers - Samsung Laser ML 1450 and HP Officejet 4100 multifunction 
- USB printing did not work.  An alternative option is to install a PDF print driver (such as 
Adobe Acrobat or PDFCreator) under the emulated environment and transform the PureEdge 
forms to PDFs, then print the PDF as you would print any other document.  This eliminates the 
need to install additional printer drivers.  PDFCreator, which is open source software, is 
available here. 
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http://microsoft.com/mac
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http://www.adobe.com/products/acrobatpro/tryout.html
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Q.  Can I Access Mac Folders From Within A Virtual PC For Mac 
Session? 
A.  Yes.  Click on Window->Virtual PC List from the Virtual PC application menu bar (or 
alternatively press 3 and L together) to bring up the list of virtual PCs.  Select the desired 
virtual PC and click on settings.  Click on Shared Folders and make sure Local Volumes is 
checked in the right hand column.    
Q. What If There Is More Than One Mac User In An Organization?   
1) Install Virtual PC for Mac on all Macs.  2) Install the guest operating system (such as 
Windows 2000 or XP) on any one machine 3) Copy the .VPC6 file from the “Virtual PC List” 
folder to all the Macs (by default the complete path to a Windows 2000 file, assuming username 
of Joe will be /Users/joe/Documents/Virtual PC List/Windows 2000.vpc6) 
Q. What If There Are More Than 5-10 Mac Users In An Organization?   
For large number of users, organizations may want to explore using a Server-based solution to 
allow any number of Mac users to run PureEdge.  This has the advantage that end-users will not 
have to install any software except a free utility called Remote Desktop Connection available 
from Microsoft.  The downside is that a dedicated Windows Server machine is required.  Users 
can create and make changes to their applications; however they will need a Windows PC to 
submit their application. 

Microsoft Remote Desktop

Q.  Are There Any Open Source Alternatives To Virtual PC For Mac? 
Yes.  Bochs is an open source x86 emulator that works similar to Virtual PC.  It’s available in 
two different flavors - a free text-based installer and a paid graphical installer version called 
Wintel for Mac OS X.   Bochs/Wintel is compatible with G5 but provides no USB support. 

                                                 
3 Also known as the Command or Apple key 
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http://www.microsoft.com/mac/otherproducts/otherproducts.aspx?pid=remotedesktopclient
http://www.microsoft.com/mac/otherproducts/otherproducts.aspx?pid=remotedesktopclient
http://bochs.sourceforge.net/
http://twtelecom.dl.sourceforge.net/sourceforge/bochs/Bochs-2.0.2.dmg
http://openosx.com/wintel/


 

2 Obtaining And Installing Virtual PC 
2.1 Selecting The Right Version  
Microsoft sells Virtual PC for Mac in four flavors.   Three of them come bundled with a 
Windows operating system.  The fourth one is “bring your own OS” flavor.  The tested version 
was the latter variety called Virtual PC for Mac - Standalone.  The most significant difference is 
that with the standalone version, the user must provide a bootable installation CD of the 
windows operating system of their choice.  Otherwise they are identical.  

It is important to understand that regardless of the flavor of the chosen software, a complete 
Windows operating system must be installed on a Mac.  Virtual PC simply emulates an x86 
environment on a Mac to install and run Windows. 

# Name Operating System Included Retail Price Comments 

1 Virtual PC for Mac v6.1 – 
Windows XP Professional 

Yes $249 Recommended 

2 Virtual PC for Mac v6.1 – 
Windows 2000 
Professional 

Yes $249 Recommended 

3 Virtual PC for Mac v6.1 – 
Windows XP Home edition 

Yes $219 Not suitable for 
windows based 
domain networking 

4 Virtual PC for Mac v6.1 – 
Standalone 

No; User must provide a 
Windows installation CD 

$129 Appropriate for users 
experienced with 
installing Windows 

 Table 1 – Different flavors of Virtual PC (For options 1-3, there no additional software is required.)      

 

2.2 Minimum System Requirements 
Virtual PC for Mac can be run on Mac OS X or Mac OS 9.   For better performance a G4 
machine with 512MB RAM or more running OS X 10.2.3 is recommended.  Free hard drive 
space should be at least 2 GB.  

2.3 Where To Buy  
Virtual PC can be purchased from retail stores such as Bestbuy or from online retailers such as 
CDW, Macmall, and Maczone. 

2.4 Installing An Operating System Without A Bootable Installation 
CD (Such As Windows 95 Or Windows 984) 

If no bootable CD is available for installing Windows 95 or Windows 98 then a DOS image is 
required5.   Obtain a DOS boot image from one of the many free DOS projects on the Internet 
                                                 
4 Also covers Windows 98 Second Edition (SE). 
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http://www.cdw.com/shop/search/Results.aspx?key=virtual+pc+for+mac&platform=mac&x=0&y=0
http://www.macmall.com/macmall/search/search.asp?search=virtual+pc+for+mac&submit1.x=0&submit1.y=0&CurDSN=simple&calledfrom=1&incimage=on
http://www.maczone.com/cgi-bin/zones/site/list/index.html?txt_search=virtual+pc+for+mac&Submit2.x=0&Submit2.y=0&non_partner_search=no_partner_id


 

(http://newdos.yginfo.net/msdos71/index.htm, be sure to download the basic DOS image with 
CD support).   

  

                                                                                                                                                             
5 Please note you must still have a Windows 95 or 98 installation CD.       
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3 Installing Virtual PC 
3.1 Basic Installation 
Installation of Virtual PC is straightforward following the instructions in the “Getting Started 
Guide” on the installation CD.   It requires copying the Virtual PC file from the CD to the 
/Applications folder and starting the installation process by double clicking on the Virtual PC 6 
icon for Mac OS X.   

The next step is to create a virtual PC.  This is done by selecting File->New option from the 
Virtual PC menu which starts a wizard (Figure 1).    

 

Figure 1- Creating a Virtual PC 

If the installation disc came with a Windows OS pack, select the “Install from CD option.”  It 
will automatically create a virtual PC and configure the included Windows operating system.  In 
this case, the user should skip to the section entitled “Post-installation steps”.  

3.2 Installing Windows With No Bootable CD  
Select “Create a PC manually” and answer the wizard’s questions.  Make sure to allocate at least 
256MB RAM (or as much as you can) to the virtual PC.   At the end of the process, the wizard 
will create a standard virtual PC with 10MB that will automatically grow based on usage.  Once 
a virtual PC is created, a guest operating system needs to be installed: 
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1) Download the DOS image from  http://newdos.yginfo.net/dosware/msdos71b.zip.   
2) Unzip it to a folder (By default, Safari will automatically unzip it to a folder on the Desktop, 

for other browsers use appropriate steps).   
3) Start up the virtual PC by clicking on the “Start Up” button as shown in Figure 2. 
 

 

Figure 2- Starting up a Virtual PC  

4) As shown in Figure 3, it will result in a system response of “OS not found” since no 
Operating System has been installed yet on the virtual PC.   

 

Figure 3 

5) Click on Drives->Capture Floppy Image from the Virtual PC menu  
6) Navigate to the folder containing DOS image as shown in Figure 4.   
7) Select the DOS image (file ending with .img extension). 
8) Click open. 
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Figure 4 – Capturing DOS image 

9) Now click on Control->Restart to reboot the Virtual PC session.  This action is analogous to 
inserting a floppy disk in a physical PC and restarting it by using CTRL-ALT-DEL or the 
reset button.    

10) As shown in Figure 5, a DOS installation process is automatically started. 
 

 

Figure 5 – Installing DOS 

11) Follow the prompts and select the default option in most cases (except, don’t select the 2-disk 
full installation option).  This ensures that CDROM drive on the Mac becomes available to 
DOS sessions.   

12) Reboot the virtual PC session when prompted and you should see a “C:\ ” prompt.    
13) Type D: at the prompt and it should respond with “D:\.”   
14) Insert Windows 95 or Windows 98 installation CD and type “setup” at the prompt  
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15) Follow instructions to install the operating system.  
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4 Post-installation steps 
4.1 Optimizing Virtual PC Settings 
Start Virtual PC, select the virtual PC created in previous steps and click on Settings.   As shown 
in Figure 1, there are several 
settings that control how a 
virtual PC session interacts 
with the host Mac.  The 
following sections describe 
some key settings that must be 
configured after installing 
Windows. 

4.1.1 Memory 
Microsoft recommends 
minimum memory 
requirements in its “Getting 
Started Guide” on the product 
CD.   They were accurate but 
the minimum requirements 
were barely enough to provide 
a usable experience.  During 
testing, Windows 95 and 
Windows 98 showed 
acceptable performance with 
256MB memory allocation, 
while Windows 2000 required 
384MB to extract acceptable 
performance.  In all cases, 
running in full-screen mode 
produced somewhat of a better user experience than 
in a window.  

Figure 6 – Memory Settings 

Figure 7 

4.1.2 Networking  
Networking must be configured for downloading 
grant applications with Grants.gov6.   Click on 
Networking in the left pane of the main settings 
window.  As shown in Figure 5, the Shared 
Networking option uses Mac’s TCP/IP connection 
and does not require any IP configuration in 
Windows.  Enable Networking and make sure 
Shared Networking is checked.   

                                                 
6 As of this writing (1/12/04) Grants.gov has not been tested with Safari, Mozilla or Netscape browsers on Mac.  However, 

Internet Explorer version 5.2.3 on Mac should be usable. 
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4.1.3 Printing 
Setting up printing in the Windows environment requires several considerations.  To setup a 
USB printer 

1) USB must be enabled in the settings as shown in Figure 3 and appropriate drivers must be 
available for Windows.   

2) Click on USB Settings in the left pane of the Settings window.   
3) Enable USB and make sure your printer shows up in the list and is checked (Make sure 

your printer is connected if it is not listed).   
 
It is also instructive to remember that while the Virtual PC session is running, the USB 
printer is not be available to other Virtual PC sessions or even the host Mac machine.  
Alternatively, a Network printer can also be configured.  The steps required for configuring 
network printing for a virtual PC session are identical to that of a physical PC and differ only 
by type of print server used.   But the preferred approach to printing is installing a pdf printer 
driver.  Once this driver is installed, any file can be converted into a pdf file for viewing or 
printing via native Mac tools.   While there are several commercial pdf conversion tools are 
available (including Adobe Acrobat), PDFCreator7 is open source and free:  
1) Download and save the software from within a windows session to the windows desktop 

or any other windows folder of choice.   
2) Double click on the file from windows explorer to install 

the software.    

Figure 8 – Configuring USB 

3) Towards the end of the install process, select the option to 
create a desktop icon.   

4) Once installed, restart the machine and then double click 
on the PDFCreator icon on the desktop.    

5) Click on Printer->Options in the ensuing menu to review 
program settings (Figure 8).   

6) Save changes by creating a simple text file using built-in 
editor Wordpad (Start->Program Files->Accessories-
>Wordpad).  

7) Type some text and click on File-Print.  Make sure PDFCreator is highlighted in the 
printer list and click OK.    

8) In the next dialog box, uncheck “After saving, open the document with the default 
program,” click Save.   

9) Type in name of file or accept the default.  B 
10) e sure to save it on a Shared Folder to be able to access it from Mac OS X (or OS 9). 
11) Switch to OS X, locate the pdf file just created, and double click on it to verify the 

contents. 

                                                 
7 http://sourceforge.net/projects/pdfcreator/ 
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Figure 9 – Configuring PDFCreator 

4.2 Updating Windows 
Windows can be updated by running Internet Explorer and clicking on Tools->Windows Update.  
This updates Windows with the latest security patches, bug fixes and new versions of software 
including Internet Explorer.  Please note that Microsoft no longer supports Windows 95.  Figure 
4 shows Windows 98 being updated using this process. 
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Figure 10 – Updating Windows 98 using Internet Explorer 

 12



 

5 Obtaining And Installing PureEdge Viewer 
The latest version of the PureEdge viewer can be obtained from Grants.gov.8  Save the 
downloaded file into a folder and double click on the file in windows explorer to install it.  

 

Figure 11 - PureEdge viewer running inside a Windows 2000 Virtual PC session 

Once PureEdge viewer is installed, run Internet Explorer from within the Windows session and 
go to Grants.Gov to search or download an application.  Figure 8 shows an active Internet 
Explorer session with a grant application open inside the PureEdge viewer plug-in.   If you have 
any further questions, please call Grants.gov customer support at 800-518-Grants (4726). 

 

                                                 
8 http://www.grants.gov/DownloadViewer 
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 Additional Resources 
- Microsoft support articles on Virtual PC for Mac   

- Additional hints and discussion about Virtual PC for Mac 
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http://support.microsoft.com/search/default.aspx?InCC_hdn=True&Catalog=LCID%3D1033%26CDID%3DEN-US-KB%26PRODLISTSRC%3DON&Product=&KeywordType=ALL&Titles=false&numDays=&maxResults=25&Queryl=virtual+pc+mac&Query=virtual+pc+mac&QuerySource=gsfxSearch_
http://www.macwindows.com/VPC6.html
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